Subject: Help with assigning guest groups to class(es)

From: Stephen Kwan <[email-masked]>
Date: Fri, 27 Aug 1999 14:25:33 -0400

Hi all, I need some help configuring wu-ftpd for assigning multiple 
guest groups to class.

Here's what I'm trying to do:

I'd like to set up 2 classes of guest users, with each class having a 
maximum # of users.

In my case, I have 2 groups of users, ftponly1 and ftponly2.  There 
are multiple users in each group, each with their unique Login.  I 
want to allow maximum of 5 ftp users from each group, with chroot() 
guest access.

So I've entered in /etc/ftpaccess the following:
...
class ftponly1 guest *
class ftponly2 guest *
guestgroup ftponly1 ftponly2
...

Of course this doesn't work because users from _either_ groups would 
be classified as ftponly1 and the max limit for one group would 
applied to both groups of users.

I'd appreciate a direct email, the listserv traffic is not completely 
coming through and I have no idea why.

Thanks,
--
Stephen Kwan
[email-masked]
(814)863-2975
http://host46.mrl.psu.edu/~skwan

  -- I am Pentium of Borg.  Division is futile.  You will be approximated. --

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 27 Aug 1999 15:06:38 -0400

On Fri, Aug 27, 1999 at 02:25:33PM -0400, Stephen Kwan wrote:

> Of course this doesn't work because users from _either_ groups would be
> classified as ftponly1 and the max limit for one group would applied to
> both groups of users.

User IP address selection on the class.  If that won't work, you'll have to
wait for me to finish rewriting the ftpaccess file handling .. could be a
few months (read as: I'm working on other stuff right now).

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Stephen Kwan <[email-masked]>
Date: Fri, 27 Aug 1999 15:39:24 -0400

>wait for me to finish rewriting the ftpaccess file handling .. could be a

OK then, I'll wait :-).  Meanwhile, does anyone know if there's 
anyway to chroot() a real user?

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 27 Aug 1999 16:55:30 -0400

On Fri, Aug 27, 1999 at 03:39:24PM -0400, Stephen Kwan wrote:

> OK then, I'll wait :-).  Meanwhile, does anyone know if there's anyway to
> chroot() a real user?

That's the definition of a guest user.

--