Subject: Restricting a real user to a directory...

From: Emre Sevinç <[email-masked]>
Date: Mon, 23 Aug 1999 12:01:51 +0300

I found the question but not the answer in the mail archives so
unfortunately I have to
repeat it once again:

Specs: Solaris 2.6 Wu-Ftp 2.5.0

I can restrict the user anonymous to the directory specified in the
/etc/passwd
but I cannot do it for a regular user such as "bulent".

Of course I run the deamon with the -a option. And checked a couple of
things.
But since this is the first time I ever install and configure Wu-Ftp I
need a little bit
help.

Thanks in advance.

(Here are my passwd and shadow files:

/etc/passwd

root:AD4Tok4lri.No:10821::::::
daemon:NP:6445::::::
bin:NP:6445::::::
sys:NP:6445::::::
adm:NP:6445::::::
lp:NP:6445::::::
smtp:NP:6445::::::
uucp:NP:6445::::::
nuucp:NP:6445::::::
listen:*LK*:::::::
nobody:NP:6445::::::
noaccess:NP:6445::::::
nobody4:NP:6445::::::
ftp:NP:::::::
ergin:*LK*:::::::
bulent:wJ9FHVHP8Ab.I:10822::::::
arif::::::::

/etc/passwd

root:x:0:1:Super-User:/:/sbin/sh
daemon:x:1:1::/:
bin:x:2:2::/usr/bin:
sys:x:3:3::/:
adm:x:4:4:Admin:/var/adm:
lp:x:71:8:Line Printer Admin:/usr/spool/lp:
smtp:x:0:0:Mail Daemon User:/:
uucp:x:5:5:uucp Admin:/usr/lib/uucp:
nuucp:x:9:9:uucp Admin:/var/spool/uucppublic:/usr/lib/uucp/uucico
listen:x:37:4:Network Admin:/usr/net/nls:
nobody:x:60001:60001:Nobody:/:
noaccess:x:60002:60002:No Access User:/:
nobody4:x:65534:65534:SunOS 4.x Nobody:/:
ftp:x:30000:30000:Anonymous FTP:/data/home/./:/bin/false
emre:x:40000:40000:Emre Sevinc:/data/home/./:/bin/sh
ergin::9949:40000::/home/ergin:/bin/sh
bulent:x:40000:40000::/data/home/bulent/./:/bin/sh
arif:x:1069:10::/export/home/arif:/bin/sh
)

Emre

---

From: Jos Visser <[email-masked]>
Date: Mon, 23 Aug 1999 11:18:53 +0200

Real users can be restricted to a directory (like the anonymous user)
with the "guestuser" and "guestgroup" statements in the ftpaccess file.

e.g.
"guestuser bulent"

++Jos

-- 
Meningitis is one of the scariest diseases I know. If not diagnosed
correctly and treated quickly it can kill anyone, anywhere, anytime  
in a matter of hours! Don't let meningitis surprise you!

Read up on this disease at http://www.musa.org.