Subject: Problem building wu-ftpd-2.4

From: "Mª Carmen Sánchez" <[email-masked]>
Date: Mon, 30 Aug 1999 15:20:39 +0200

Hello,

I'm trying to install wu ftp in a Solaris 2.6 with cc 4.2, I have edit the
file /src/pathnames.h and then I run build sol (as the step 2 indicates) and
obtain the follow error:

make args are :
make opts are :

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
"ftpd.c", line 143: identifier redeclared: realpath
        current : function(pointer to char, pointer to char) returning
pointer t
o char
        previous: function(pointer to const char, pointer to char) returning
poi
nter to char : "/usr/include/stdlib.h", line 180
"ftpd.c", line 1446: cannot recover from previous errors
cc: acomp failed for ftpd.c
*** Error code 2
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsup
port -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to ftpcount
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c
vers.o -lsuppo
rt -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to ftpshut
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 5249 + 752 + 324 = 6325
Done

As you see, I need some help.
Thank you.

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 30 Aug 1999 10:32:02 -0400

On Mon, Aug 30, 1999 at 03:20:39PM +0200, Mª Carmen Sánchez wrote:

> I'm trying to install wu ftp in a Solaris 2.6 with cc 4.2, I have edit
> the file /src/pathnames.h and then I run build sol (as the step 2
> indicates) and obtain the follow error:

> As you see, I need some help.

No.  What you need is to get something writeen in, say, the last decade.
The current version is 2.5.0 (with patches).  Get it.  Version 2.4 has so
many security problems, I'd suggest the failure to compile is a godsend; at
least it stopped you from making a monsterous mistake.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195