Subject: New to this list.

From: "Todd Routhier - Muchoweb Webhosting" <[email-masked]>
Date: Thu, 19 Aug 1999 22:48:56 -0500

Hello all,
    I have a question..
Running:
Redhat 6.0
WU-FTPD 2.4.2

I am trying to configure the server so users can log in and they will be chrooted to there home directory and be stuck there, I don't want them to be able to move out of this directory not even in read only mode. So I added the line:

guestgroup    ftpusers

 THen I make everyone that I want to use FTP a member of the group ftpusers. I then go into the /etc/passwd file and modify each line so they chroot properly. All seems to work fine when i log in with a users id, the directory they see is / and they seem to have been placed in there home directory, they seem to be able to write an overwrite to teh directory fine but I can't get a directory listing AT ALL. I tried moving a copy of ls to the users home directory but that did not work. LS works fine via ftp until I set up this guestgroup and chroot stuff. I have read all teh docs and FAQs I can find and have banged my head in all teh newsgroups trying to find an answer but I am still stuck. I am pretty new to Linux as well as WU-Ftpd so please provide detailed answers if possible. 

       Thanks for your help in advance.

   Todd Routhier

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 20 Aug 1999 00:17:10 -0400

> WU-FTPD 2.4.2

You should upgrade to 2.5.0.  There's an RPM for it if that's how you do
your installs.

> I am trying to configure the server so users can log in and they will be
> chrooted to there home directory and be stuck there, I don't want them to
> be able to move out of this directory not even in read only mode. So I
> added the line:
> 
> guestgroup    ftpusers
> 
> THen I make everyone that I want to use FTP a member of the group
> ftpusers. I then go into the /etc/passwd file and modify each line so
> they chroot properly. All seems to work fine when i log in with a users
> id, the directory they see is / and they seem to have been placed in
> there home directory, they seem to be able to write an overwrite to teh
> directory fine but I can't get a directory listing AT ALL. I tried moving
> a copy of ls to the users home directory but that did not work.  LS works
> fine via ftp until I set up this guestgroup and chroot stuff. I have read
> all teh docs and FAQs I can find and have banged my head in all teh
> newsgroups trying to find an answer but I am still stuck. I am pretty new
> to Linux as well as WU-Ftpd so please provide detailed answers if
> possible. 

You also need to read the FAQ.  It has the detailed instructions you need.

Online resources, including the latest version of the daemon, are available
through:
 
      http://www.wu-ftpd.org/

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ted Keller <[email-masked]>
Date: Fri, 20 Aug 1999 00:22:23 -0400 (EDT)

Todd,

Looks like your well on the way.

First - for security reasons, UPGRADE to 2.5.0 (ftp.wu-ftpd.org).  The
2.4.2 if full of security holes.

Second, you have to do a bit more work on your chrooted environment.  I'm
assuming that the ls is staticly linked.  If so, then all you probably
need is the /dev/zero entry in the chrooted area.  Note, ls will be
looking for password and group entries.  You can skinny down copies of
these files and put them in the etc directory of your chrooted area.

If your ls is not statically linked, you will also have to add the
corresponding libraries.

ted keller