Subject: ftpconversions (tar + gzip)

From: "Veselin Terzic" <[email-masked]>
Date: Thu, 19 Aug 1999 22:31:40 -0700

hi,

platform: hpux, wu-ftpd-2.5.0, gnu tar-1.13, gzip (static)

when a guest user logs in, get <dir>.tar works, but
get dir.tar.gz says "no such file or directory".
i was hoping i can get a directory by taring  + gzip on the fly?

i use default ftpconversion.
i alo tried replacing "-z" with --use-compress-program:

 :   : :.tar.gz:/bin/tar -c --use-compress-program=/bin/gzip 
           -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

thanks
--veselin

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 20 Aug 1999 09:38:05 -0400

On Thu, Aug 19, 1999 at 10:31:40PM -0700, Veselin Terzic wrote:

> when a guest user logs in, get <dir>.tar works, but get dir.tar.gz says
> "no such file or directory".  i was hoping i can get a directory by
> taring  + gzip on the fly?
> 
> i use default ftpconversion.  i alo tried replacing "-z" with
> --use-compress-program:
> 

Some machines don't handle that very well.  Usually what you do is get a
'pipe' program and tell it to run tar, piping the results through gzip.

This may or may not be the case here.  All I can say is it must be an HP/UX
issue since tar+gzip works fine on other platforms using the default
ftpconversions.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195