Subject: <<425 Can't create data socket (142.148.10.35,20): Address alread y in use.>> &&& ftpaccess file

From: Magdalena Hewryk <[email-masked]>
Date: Tue, 31 Aug 1999 10:30:25 -0400

I am getting constantly this error message:
 
<<425 Can't create data socket (142.148.10.35,20): Address already in use.>>

I am fighting with it for few months by upgrading FTP to the newer version
and changing control files but nothing helps.
Lately I think that because ftpaccess is not started I am getting into this
problem
We do have one machine on which 'DATA Sockect' error never occurs.  Nothing
is really different except server starts with ftpaccess.

Any hints for me?

This is the output of 
strings /usr/sbin/in.ftpd | grep ftpaccess

FTP server started without ftpaccess file
FTP server (%s) ready.
Cannot create socket to listen on: %m
Cannot set SO_REUSEADDR option: %m
Cannot find service ftp: %m
Cannot bind socket: %m
accepting connections on port %i
Accept failed: %m
failed to fork: %m
MDTM
SIZE
STOU
XCUP
(change to parent directory)
CDUP
XPWD
(return current directory)
XRMD
XMKD
<sp> path-name
NOOP
[ <sp> <string> ]
HELP
STAT
(get type of operating system)
SYST
site-cmd [ <sp> arguments ]
SITE
NLST
[ <sp> path-name ]
LIST
XCWD
[ <sp> directory-name ]
DELE
(abort operation)
ABOR
RNTO
RNFR
(restart command)
REST
allocate storage (vacuously)
ALLO
(mail recipient)
MRCP
(mail recipient scheme question)
MRSQ
(mail send to terminal and mailbox)
MSAM
(mail send to terminal or mailbox)
MSOM
(mail send to terminal)
MSND
(mail to user)
MAIL
(mail file)
MLFL
APPE
STOR
<sp> file-name
RETR
(specify transfer mode)
MODE
(specify file structure)
STRU
<sp> [ A | E | I | L ]
TYPE
(set server in passive mode)
PASV
<sp> b0, b1, b2, b3, b4, b5
PORT
(terminate service)
QUIT
(reinitialize server state)
REIN
(structure mount)
SMNT
(specify account)
ACCT
<sp> password
PASS
<sp> username
USER
[ <sp> file-name ]
CHECKSUM
[ <sp> method ]
CHECKMETHOD
GROUPS
[ <sp> ] 
CDPATH
[ <sp> alias ] 
ALIAS
<sp> command [ <sp> arguments ]
EXEC
<sp> pattern
INDEX
MINFO
<sp> YYYYMMDDHHMMSS [ <sp> path-name ]
NEWER
<sp> access-password
GPASS
<sp> access-group
GROUP
<sp> mode <sp> file-name
CHMOD
[ <sp> maximum-idle-time ]
IDLE
[ <sp> umask ]
UMASK
PASS password
command: %s
%c%c%c
Timeout (%d seconds): closing control connection.
User %s timed out after %d seconds at %.24s
unknown
Time limit reached.  Goodbye.
Server shutting down.  Goodbye.
%s: IDLE
You could at least say goodbye.
SITE GPASS
%s: %s
Unknown state in scanner.
'%s': command not understood.
Please login with USER and PASS.
Ran out of memory.
SITE 
The following %scommands are recognized %s.
(* =>'s unimplemented)
%s%c
email
Direct comments to %s.
Direct comments to ftp-bugs@%s.
Unknown command %s.
Syntax: %s%s %s
%s%-*s
%s; unimplemented.
%s: not a plain file.
SIZE not implemented for Type %c.
?AEIL
/bin/ftp-exec
%s/%s
SITE EXEC (FAIL: %m): %s
site-exec-max-lines
*** Truncated ***
 (end of '%s')
SITE EXEC (lines: %d): %s
alias
%s is an alias for %s.
Unknown alias %s.
The following aliases are available.
   %-8s %s
The cdpath is:
cdpath
  %s
Group membership is:
  %d
yacc stack overflow
syntax error
USER %s
PASS %s
PASS password
PORT command successful.
refused PORT %s,%d from %s
Illegal PORT Command
TYPE %s
Type set to A.
Form must be N.
Type E not implemented.
Type set to I.
Type set to L (byte size 8).
Byte size must be 8.
STRU %s
STRU F ok.
Unimplemented STRU type.
MODE %s
MODE S ok.
Unimplemented MODE type.
ALLO %d
ALLO command ignored.
ALLO %d R %d
RETR %s
(null)
STOR %s
APPE %s
NLST %s
LIST %s
STAT %s
DELE %s
RNTO %s
Bad sequence of commands.
ABOR command successful.
CWD %s
HELP %s
NOOP command successful.
MKD %s
RMD %s
SITE HELP
SITE HELP %s
SITE UMASK
Current UMASK is %03o
SITE UMASK %03o
umask
Bad UMASK value
UMASK set to %03o (was %03o)
Permission denied. (umask)
SITE CHMOD %03o %s
chmod
CHMOD: Mode value must be between 0 and 0777
%s of %s changed permissions for %s
CHMOD command successful.
Permission denied. (chmod)
SITE IDLE
Current IDLE time limit is %d seconds; max %d
SITE IDLE %d
Maximum IDLE time must be between 30 and %d seconds
Maximum IDLE time set to %d seconds
SITE GROUP %s
SITE GPASS password
SITE NEWER %s
SITE NEWER %s %s
SITE MINFO %s
SITE MINFO %s %s
index %s
STOU %s
UNIX Type: L%d
SIZE %s
MDTM %s
%04d%02d%02d%02d%02d%02d
You have transferred %d bytes in %d files.
Total traffic for this session was %d bytes in %d transfers.
Thank you for using the FTP service on %s.
Goodbye.
RNFR %s
REST %d
Restarting at %ld. %s
Send STORE or RETRIEVE to initiate transfer.
SITE ALIAS
SITE ALIAS %s
SITE GROUPS
SITE CDPATH
SITE CHECKMETHOD %s
SITE CHECKMETHOD
SITE CHECKSUM %s
SITE CHECKSUM
cmd failure - not logged in
`{[*?
../*/..
Arguments too long
Unknown user name after ~
Bad directory components
Pathname too long
Out of memory
/var/adm/wtmpx
wtmpx %s %m
/var/adm/wtmp
wtmp %s %m
/dev/null
%d-%d
%d.%d.%d.%d/%d
%d.%d.%d.%d
%d.%d.%d.%d:%d.%d.%d.%d
%d.%d.%d.*
%d.%d.*.*
%d.*.*.*
cannot open addrglob file %s: %s
guestuser
guestgroup
realuser
realgroup
autogroup
autogroup: set group %s not found
loginfails
private
/usr/local/etc/ftpgroups
compress
commands
anonymous
guest
real
transfers
inbound
outbound
security
syslog
class
limit
nice
defumask
tcpwindow
file-limit
total
data-limit
deny
!nameserved
/var/adm/ftp.pids-%s
cannot open pid file %s: %s
sleeping: fcntl lock of pid file failed: %s
/usr/local/etc/ftpaccess
shutdown
ACCESS DENIED (error reading access file) TO %s
ACCESS DENIED (deny command) TO %s
ACCESS DENIED (not in any class) TO %s
Process nice value adjusted by %d
ACCESS DENIED (user limit %d; class %s) TO %s
%s %d %d %s
email
unlimited
[unknown]
banner
message
login
cwd=
readme
Please read the file %s
  it was last modified on %.24s - %d day%s ago
This is a BINARY file, using ASCII mode to transfer will corrupt it.
%d %d %d %d %d %d %d
%04d%02d%02d%02d%02d%02d
file list
Data connection
Transfer complete.
Bad DATE format
anonymous
guest
real
class=
upload
absolute
relative
calloc error in expand_id
path-filter
REGEX error
%s: Permission denied. (Filename (accept))
%s: Permission denied. (Filename (deny))
Could not determine cwdir
Could not determine pwdir
%s: Permission denied. (Upload dirs)
nodirs
dirs
%s: Permission denied. (Upload)
delete
%s: Permission denied. (Delete)
allow-retrieve
noretrieve
%s is marked unretrievable
throughput
%.0f
malloc error in throughput_adjust
rfc1321
posix
Unrecognized checksum method
Checksum method is now: MD5 (RFC1321)
Checksum method is now: CRC (POSIX)
Current checksum method: MD5 (RFC1321)
Current checksum method: CRC (POSIX)
%s: not a plain file.
/bin/md5sum
/bin/cksum
Pathname too long
%s %s
Nothing transferred yet
$Id: acl.c,v 1.9 1998/07/06 09:13:57 sob BETA-18 sob $
calloc error parsing acl
Too many args (>%d) in ftpaccess: %s %s %s %s %s ...
cannot open access file %s: %s
cannot fstat access file %s: %s
could not malloc aclbuf (%d bytes)
error reading acl file %s: %s
calloc error in parsepriv
cannot open private access file %s: %s
cannot fstat private access file %s: %s
could not malloc passbuf (%d bytes)
error reading private access file %s: %s
Request for access to group %s accepted.
Illegal group name
Give group name with SITE GROUP first.
Group access request incorrect.
repeated group access failures from %s, group %s
Group access enabled.
O_TAR
O_UNCOMPRESS
O_COMPRESS
T_DIR
T_ASCII
T_REG
cannot open conversion file %s: %s
cannot fstat conversion file %s: %s
could not malloc convbuf (%d bytes)
error reading conv file %s: %s
calloc error parsing ftpconversions
/usr/local/etc/ftpconversions
rhost_ok: sethacc failed
anonymous
rhost_ok: endhacc failed
/usr/local/etc/ftphosts
Can't open host access file
malloc error in sethacc
Failed to realloc host access array
deny
allow
Format error in host access file
Line too long
host_access: %s
$Id: sigfix.c,v 1.7 1998/07/06 09:13:57 sob BETA-18 sob $
ERROR allocating memory for index record
Local resource failure: malloc
ERROR allocating memory for port addresses
ERROR allocating memory for vector index
0.0.0.0
ERROR allocating memory for port index
ERROR port index addition, invalid ptr
ERROR ftpaccess port entry<%s> too large
ERROR ftpaccess port entry<%s> invalid
ERROR bad slot count  for port index record
ERROR vector index addition, invalid ptr
ERROR ftpaccess passive entry <%s> to large
ERROR ftpaccess vector entry<%s> to large
ERROR ftpaccess vector entry<%s> invalid
ERROR bad slot count  for passive vectors index record
passive
ports
address
Permission denied.  You are restricted to your account.
Permission denied.  Out of memory.
X-Forgery-By: %s
X-Auth-User: %s
%u , %u
%hd,%hd: USERID :%*[^:]:%400s
@(#) Copyright (c) 1985, 1988, 1990 Regents of the University of California.
 All rights reserved.
@(#)$Id: ftpd.c,v 1.38 1998/07/06 09:13:57 sob BETA-18 sob $ based on ftpd.c
5.40 (Berkeley) 7/2/91
@(#)$Id: ftpcmd.y,v 1.17 1998/07/06 09:13:57 sob BETA-18 sob $ based on
ftpcmd.y    5.24 (Berkeley) 2/25/91
@(#)$Id: glob.c,v 1.13 1998/07/06 09:13:57 sob BETA-18 sob $ from glob.c 5.9
(Berkeley) 2/25/91
@(#)logwtmp.c   5.7 (Berkeley) 2/25/91
@(#)$Id: logwtmp.c,v 1.14 1998/07/06 09:13:57 sob BETA-18 sob $
@(#)$Id: popen.c,v 1.15 1998/07/06 09:13:57 sob BETA-18 sob $
Version wu-2.4.2-academ[BETA-18-VR15](1) Tue Jun 8 12:48:12 EDT 1999
@(#)$Id: access.c,v 1.16 1998/07/06 09:13:57 sob BETA-18 sob $
@(#)$Id: extensions.c,v 1.24 1998/07/06 09:13:57 sob BETA-18 sob $
@(#)$Id: private.c,v 1.13 1998/07/06 09:13:57 sob BETA-18 sob $
@(#)$Id: authenticate.c,v 1.8 1998/07/06 09:13:57 sob BETA-18 sob $
$Id: conversions.c,v 1.8 1998/07/06 09:13:57 sob BETA-18 sob $
;0@(#)$Id: $

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 31 Aug 1999 11:09:43 -0400

> <<425 Can't create data socket (142.148.10.35,20): Address already in use.>>

Upgrade to 2.5.0

ISTM there was a problem in the daemon (I don't _think_ it was a VR-only
problem, but it might have been) .. the PASV port was binding to the wrong
IP Address.

This looks like a data port .. but maybe it's the same problem.

I'd also look for missing vendor patches, or a bad kernel gen (ie., I can
cause this by not enabling some features in Linux).

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 31 Aug 1999 11:20:59 -0400

> <<425 Can't create data socket (142.148.10.35,20): Address already in use.>>

If you're looking for vendor patches, use the keyword SO_REUSEADDR which is
the name of the socket option which enables address/port reuse.  If it's
broken, not present, or denied by some security feature, the daemon won't
be able to do PORT-mode data transfers.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195