Subject: aliasing the host name

From: Stan Brockman <[email-masked]>
Date: Tue, 31 Aug 1999 09:45:06 -0600 (MDT)

I'd like for the wu-ftpd server to show an alias hostname of the
machine it is running on rather than to display the actual host
name of the machine itself.  Eg., at connect time, it should say,

"220 MyFtpSrvr FTP server ready." instead of
"220 MyHstName FTP server ready."

Ditto at disconnect,
"221-Thank you for using the FTP service on MyFtpSrvr." instead 
of
"221-Thank you for using the FTP service on MyHstName."

I cannot find a way do that via the configuration scripts.  Must
I set up a virtual server to accomplish my goal?  I'd rather not
hack the code in ftpd.c and ftpcmd.c..., perhaps other places.

Thanks  --Stan

Stan Brockman, Computer Specialist    303-273-8560 Voice
US Geological Survey                  303-273-8600 Fax
Denver CO 80225                       [email-masked]

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Tue, 31 Aug 1999 18:00:51 +0200

> hack the code in ftpd.c and ftpcmd.c..., perhaps other places.

Sounds like you have an older version of the daemon. Upgrade to the latest
version from ftp.wu-ftpd.org (if not for this reason then for security
reasons!).

In which there is a configuration directive

hostname

which will do what you want.

                                                  Koos

-- 
 Koos van den Hout                    Expertisecentrum Cetis http://cetis.nl/
 [email-masked] (Work)                     Workphonenumber: +31-30-2586287
 [email-masked] (Home)                   Workfaxnumber: +31-30-2586290
 http://www.cetis.hvu.nl/~koos/  PGP keyid RSA/1024 0xCA845CB5 via keyservers