Subject: RE: ftpusers entry in /etc/group file - NIS

From: Magdalena Hewryk <[email-masked]>
Date: Tue, 24 Aug 1999 11:46:43 -0400

Before I do upgrade to v. 2.5 (late afternoon), how can I make it working
correctly now? 
A)
I added to /etc/ftpaccess my new ftpgroup1, ftpgroup2 and ftpgroup3:
# specify which group of users will be treated as "guests".
guestgroup ftpusers,ftpgroup1,ftpgroup2,ftpgroup3

I tested  ftp   and this users are not treated as   "guests" and can go
anywhere.

--Q1 
Is there something else to do?
1. /etc/group file (split ftpusers lines)
2. /etc/ftpaccess file (add new groups to guestgroup)
2. re-start inetd

Magda

> -----Original Message-----
> From: Gregory A Lundberg [mailto:[email-masked]]
> Sent: Tuesday, August 24, 1999 10:15 AM
> To: Magdalena Hewryk
> Cc: [email-masked]
> Subject: Re: ftpusers entry in /etc/group file - NIS
> 
> 
> On Tue, Aug 24, 1999 at 10:00:53AM -0400, Magdalena Hewryk wrote:
> 
> > I had to split ftpusers group since we do have about 500 
> ftpusers and the
> > line was too long.  I split ftpusers and created three groups.
> 
> Upgrade to 2.5.0 if you have not already done soe.
> 
> Delete the ftpusers group.
> 
> Add the following line to your ftpaccess
> 
> guestuser *
> realuser ftp
> 
> Now everyone is a quest.  Except 'ftp' .. who's the anonymous 
> user and due
> to a current oddity of the way the daemon works, needs to be 
> called a 'real'
> user.
> 
> -- 
> 
> Gregory A Lundberg              WU-FTPD Development Group
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 24 Aug 1999 13:51:49 -0400

> guestgroup ftpusers,ftpgroup1,ftpgroup2,ftpgroup3

Lose the commas.

--