Subject: FTP server started without ftpaccess file

From: Magdalena Hewryk <[email-masked]>
Date: Fri, 27 Aug 1999 12:29:01 -0400

The machine which I didn't upgrade to (Version
wu-2.4.2-academ[BETA-18-VR15](1)
and still is running the old (Version wu-2.4.2-academ[BETA-13](1) doesn't
say that FTP Server started without ftpaccess file...

# strings /usr/local/etc/wuftpd  | grep ftpaccess
Too many args (>%d) in ftpaccess: %s %s %s %s %s ...
/etc/ftpaccess

All machines with FTP which I upgraded to v. 18 give me messages about
server started without ftpaccess file.

Please advise,
Magda

> -----Original Message-----
> From: Magdalena Hewryk 
> Sent: Friday, August 27, 1999 12:22 PM
> To: 'Gregory A Lundberg'
> Cc: [email-masked]
> Subject: RE: checking PATHS.......how can I know which ftpaccess is
> checked on my system
> 
> 
> Thanks, I've got it:
> 
> # strings /usr/sbin/in.ftpd | grep ftpaccess
> FTP server started without ftpaccess file
> /usr/local/etc/ftpaccess
> Too many args (>%d) in ftpaccess: %s %s %s %s %s ...
> ERROR ftpaccess port entry<%s> too large
> ERROR ftpaccess port entry<%s> invalid
> ERROR ftpaccess passive entry <%s> to large
> ERROR ftpaccess vector entry<%s> to large
> ERROR ftpaccess vector entry<%s> invalid
> 
> > -----Original Message-----
> > From: Gregory A Lundberg [mailto:[email-masked]]
> > Sent: Friday, August 27, 1999 12:15 PM
> > To: Magdalena Hewryk
> > Cc: [email-masked]
> > Subject: Re: checking PATHS.......how can I know which ftpaccess is
> > checked on my system
> > 
> > 
> > On Fri, Aug 27, 1999 at 10:54:55AM -0400, Magdalena Hewryk wrote:
> > 
> > > I have a questions regarding a location of ftpaccess file.
> > > 
> > > I do have ftpaccess file under /usr/local/etc/ directory 
> > and under /etc
> > > directory.
> > > 
> > > I don't have anymore  directory where I performed 
> > installation of FTP and I
> > > don't have access to /bin/ckconifg file...
> > > 
> > > --Q1.
> > > How can I check PATH_FTPACCESSS:: on my machine?
> > > Other words, how can I know which ftpaccess is checked on 
> my system?
> > > 
> > > To check binary I go to /etc/inetd.conf file and check the 
> > entry but for
> > > ftpaccess I don't know where to go and check it.
> > 
> > Go to the binary exposed in /etc/inetd.conf.  run strings on it:
> > 
> >   strings ftpd | grep ftpaccess
> > 
> > The access file is usually the second line listed.
> > 
> > -- 
> > 
> > Gregory A Lundberg              WU-FTPD Development Group
> > 1441 Elmdale Drive              [email-masked]
> > Kettering, OH 45409-1615 USA    1-800-809-2195
> > 
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 27 Aug 1999 13:01:33 -0400

On Fri, Aug 27, 1999 at 12:29:01PM -0400, Magdalena Hewryk wrote:

> The machine which I didn't upgrade to (Version wu-2.4.2-academ[BETA-18-VR15](1)

One of my changes was to syslog a message if the daemon started without
using an ftpaccess file.

The reason is there was a change some time ago (one of the academ betas)
which switched the default from -a (use ftpaccess) to -A (don't user
ftpaccess).  The reasoning behind the change was the old NET-2 (BSD) ftp
daemon did not have an ftpaccess file, and WU-FTPD is supposed to be a
drop-in replacement for that daemon.

The result was a new FAQ.

To fight that, I added a syslog message in one of the later -VR updates.

The long and the short of it is yo need to be sure the -a option appears on
your inetd.conf line which executes the daemon.  And yo need to be sure the
syntax of that line is correct .. some people on some systems forget to put
'ftpd' for arg0, so the '-a' becomes arg0 (the program name) and the daemon
never sees it.

--