Subject: 421 Service not available, remote server has closed connection

From: Magdalena Hewryk <[email-masked]>
Date: Tue, 31 Aug 1999 11:38:34 -0400

On one machine the last command shows that ftp user is logged on to the
system...
#last
ftp       ftp          localhost        Tue Aug 31 00:14   still logged in

 Since then ftp server is closed:
# ftp 0
Connected to 0.
421 Service not available, remote server has closed connection
ftp> 

ps -ef | grep ftp shows none of processes.

Any hints how to get server back up and running?
I restarted /usr/sbin/inetd but nothing has been changed.

Regards,
Magda

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 31 Aug 1999 11:47:47 -0400

> ftp       ftp          localhost        Tue Aug 31 00:14   still logged in

Noise.  lastlogs are notoriously unreliable for determining what is
running.  Use ps.

> 421 Service not available, remote server has closed connection

Take a look at your ftpaccess.  Does it name a shutdown file?  Delete that
file.

> ps -ef | grep ftp shows none of processes.

See?  You lastlog is wrong.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195