Subject: How to give diff. guest groups diff. access?

From: [email-masked]
Date: Mon, 30 Aug 1999 14:45:32 -0400

Our "guest" community under wu-ftpd-2.4.2/2.5.0 (Tru64 UNIX v4.0D) is
composed of two distinct subcommunities. We'd like to give these subcommunities
different sets of privileges, specifically to have one subcommunity be able 
to use "rename", and the other not. 

How do we set this up? Should I have two guestgroups? What would the 
"rename" clause for the two subgroups look like? What other statements
would be diff. than the standard config? Here's our ftpaccess right
now:
		---------------------------------------
class   local   real,guest,anonymous *

guestgroup      misc
delete          yes     guest
delete          no      anonymous               # delete permission?
overwrite       yes     guest                   # overwrite permission?
overwrite       no      anonymous
rename          no      guest,anonymous         # rename permission?
chmod           no      guest,anonymous         # chmod permission?
umask           no      guest,anonymous         # umask permission?
#
#
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
#
guestgroup misc
log security real,anonymous,guest
		-----------------------------------------

TIA...

-- 
Judith Reed
[email-masked]
(315) 453-2912 x335

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 30 Aug 1999 16:16:32 -0400

Caveat: it's been a while since I played with this, so it may be a little
flaky.

> would be diff. than the standard config? Here's our ftpaccess right

Yes, create two classes.
Remember the defaults for for 2.5.0 are 'no' for anonymous and 'yes' for
guest and real.

class norename guest !10.0.0.0/8
class canrename guest 10.0.0.0/8
class insecure real *
class anyone anonymous *

guestgroup misc
rename no class=norename

Don't forget to read the upload.configuration.HOWTO.  This use of class= is
what the ERRATA is referring to .. it should work as I have it here to get
what you want done.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Stephen Kwan <[email-masked]>
Date: Mon, 30 Aug 1999 16:37:53 -0400

>Remember the defaults for for 2.5.0 are 'no' for anonymous and 'yes' for

Pardon my ignorance, but what do these IP#'s (?) refer to?

--
Stephen Kwan
[email-masked]
(814)863-2975
http://host46.mrl.psu.edu/~skwan

  -- I am Pentium of Borg.  Division is futile.  You will be approximated. --

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 30 Aug 1999 17:46:25 -0400

> >what the ERRATA is referring to .. it should work as I have it here to get

Example numbers.  The Class A network 10 (10.*.*.*) is reserved by the IANA
for use by internal LANs and is not routable (unless your ISP is a fool).

What I'm saying here is "noreanme, not internal users", "rename, people from
my Intr-A-net."

--