Subject: logins fail with 2.5.0, HPUX

From: "Patrick L. Nolan" <[email-masked]>
Date: Tue, 3 Aug 1999 10:36:24 -0700 (PDT)

Yesterday I downloaded 2.5.0.  I installed it on a Solaris 2.5.1 machine and
it works fine.  Today I installed it on an HP-UX 10.20 machine, and it doesn't
work fine.

It rejects logins, both anonymous and regular.  In the error log, the anonymous
login looks like this:
Aug  3 10:24:05 glast ftpd[13056]: FTP LOGIN REFUSED (ftp not in /etc/passwd) FR
OM glast [36.92.0.110], anonymous

The regular login:
Aug  3 10:24:15 glast ftpd[13058]: failed login from glast [36.92.0.110], pln

Here's what I know:

* There is an entry for ftp in /etc/passwd:
ftp:*:103:30:FTP server:/home/ftp:/usr/bin/false
In fact, anonymous ftp works with the HP ftpd.

* /usr/bin/false is in /etc/shells

* ckconfig is happy with my configuration files

* I believe ftpaccess is readable.  It's clear that ftpcount can see it.

* At first I started ftpd with the options -l -a -o.  I took all those out,
and it doesn't help.

* There was some problem compiling.  Since I use gcc, I had to remove some of
the HP-specific compiler flags in the Makefiles.  I just let the script put
the files wherever it wanted to.

* Yes, I did remember to HUP inetd after each change.

* I typed my own password enough times to be confident it's not just a typo.
The anonymous password checking is "trivial", so that's pretty easy to get
right.

* There's not much fancy stuff in my ftpaccess file.  Here it is, just in case:
class   all   real,guest,anonymous  *
guestgroup guest,bloom
limit   all   11   Any              /usr/local/etc/msgs/msg.dead
readme  README*    login
readme  README*    cwd=*
message /welcome.msg            login
message .message                cwd=*
compress        yes             local remote
tar             yes             local remote
delete          no      guest,anonymous 
overwrite       no      guest,anonymous
rename          no      guest,anonymous
chmod           no      anonymous
umask           no      anonymous
log commands real,guest,anonymous
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg
upload /home/ftp *             no
upload /home/ftp /pub/incoming yes ftp guest 0644 nodirs
upload /home/elliott/guest *             no
upload /home/elliott/guest /pub/incoming yes elliott 0644 dirs
passwd-check trivial
email pln

* There's some history I didn't mention.  I had a very old version, which worked
OK.  I don't remember the number.  That's where I developed that ftpaccess.
Months ago I upgraded to one of the 2.4.2-academ versions (14? 18?).  Guest
and anonymous ftp access quit working then.  I can live without those, so I
let it slide.  Now it's worse.

---

From: "K.Y. Lee" <[email-masked]>
Date: Tue, 3 Aug 1999 12:40:12 -0700 (PDT)

I just went through simliar hell for installing 2.5.0 on HPUX 10.20. 
Greg helped me a lot to solve it.  I don't know whether this is same
problem but I sure had trouble logging in; I tested with 'ftp
localhost'

So, here is my 2 cent worth of comments.

One place you might look is whether either /usr/bin/ksh or /usr/bin/sh,
depending on what you use, is in /etc/shells.

> * At first I started ftpd with the options -l -a -o.

According to Greg, you must have '-a' for 2.5.0.

> the files wherever it wanted to.

This is the Makefile.hpx I used.  Notice that I am using bison, instead
of yacc.

-----------------------------------------
#
# Makefile for HPUX
# $Id: Makefile.hpx,v 1.10 1999/02/26 16:09:28 sob RELEASE sob $
#
YACC    = bison -y
CC       = cc
IFLAGS   = -I.. -I../support
LFLAGS   =
CFLAGS   = -Dunix -O ${IFLAGS} ${LFLAGS}
XOBJS    =
LIBES    = ../support/libsupport.a -lsec
LIBC     = /lib/libc.a
LINTFLAGS=
LKERB    = -lauth -lckrb -lkrb -ldes
XLIBS    = ${LIBES}
MKDEP    = ../util/mkdep.hpx 
-----------------------------------------

Good luck!
_____________________________________________________________
Do You Yahoo!?
Free instant messaging and more at http://messenger.yahoo.com