Subject: RE: FTP server started without ftpaccess file

From: Magdalena Hewryk <[email-masked]>
Date: Fri, 27 Aug 1999 14:01:31 -0400

RE:  FTP server starts without ftpaccess file

# strings /usr/sbin/in.ftpd | grep ftpaccess
FTP server started without ftpaccess file
/usr/local/etc/ftpaccess

***I've checked /etc/inetd.conf file and the string with ftp binary.  The
daemon starts with -a option but ftpaccess file seems not to be started?

this is the string:
ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd -L
-a 

> 
> The long and the short of it is yo need to be sure the -a 
> option appears on
> your inetd.conf line which executes the daemon.  And yo need 
> to be sure the
> syntax of that line is correct .. some people on some systems 
> forget to put
> 'ftpd' for arg0, so the '-a' becomes arg0 (the program name) 
> and the daemon
> never sees it.
> 

Magdalena Hewryk

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 27 Aug 1999 14:26:12 -0400

On Fri, Aug 27, 1999 at 02:01:31PM -0400, Magdalena Hewryk wrote:

> ftp stream tcp nowait root /usr/sbin/in.ftpd in.ftpd -L -a 

That should work.  Did you remember to kill -HUP the inetd process if youu
changes the inetd.conf?  Gotta do that.  Won't hurt, so do it again, to be
sure.

Make sure the ftpaccess file is readable and in executable directories.  It
should be (you've been editing it) but check anyway.

Run ckconfig.  What does it have to say?

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195