Subject: glibc.tmp patch problems

From: "Scott I. Remick" <[email-masked]>
Date: Mon, 30 Aug 1999 15:27:36 -0400

The glib.wtmp patch for 2.5.0 isn't going smoothly for me.  Instead of just 
applying, I get prompted for "File to patch:".  What am I doing 
wrong?  Here's the output:

/usr/libexec/ld.so: warning: /usr/lib/libc.so.3.0: minor version 0 older 
than expected 1, using it anyway
Hmm...  Looks like a new-style context diff to me...
The text leading up to this was:
--------------------------
|This reverses an earlier change to src/logwtmp.c.  The original comment was:
|Garry Shtern <[email-masked]> submitted a patch on Fri, 9 Apr 1999, 
which he
|says was needed to support glibc2 on linux.
|
|It turns out this has the effect of breaking wtmp logging on Linux.  The GNU
|libc updwtmp() function cannot find _PATH_WTMP when a guest or anonymous user
|is logging out because the daemon has chroot'd.
|
|Index: logwtmp.c
|===================================================================
|RCS file: /cvsroot/wu-ftpd-stable/src/logwtmp.c,v
|retrieving revision 1.4
|diff -c -r1.4 logwtmp.c
|*** logwtmp.c  1999/05/21 14:15:39     1.4
|--- logwtmp.c  1999/08/03 13:28:08
--------------------------
File to patch:
-----------------------
Scott I. Remick			[email-masked]
Network and Information		(802)388-7545 ext. 236
Systems Manager			FAX:(802)388-3697
Computer Alternatives, Inc.		http://www.computeralt.com

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 30 Aug 1999 16:19:58 -0400

> The text leading up to this was:

You're not doing anything wrong.  Somehow the patch got built wrong (it was
already in the src directory).  Just type in src/logwtmp.c and you will be
fine.

Sorry, the patch has been out for a while, and I just noticed the problem a
couple days ago.  I don't like changing a released file, so I've not
updated it to correct the error.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195