Subject: -DVIRTUAL compile question.

From: Rocke Robertson <[email-masked]>
Date: Wed, 07 Jul 1999 11:37:33 -0700

I am finally getting around to building/installing 2.5.0 on our Solaris
2.6 systems.  The VIRTUAL.FTP.SUPPORT file says to add a -DVIRTUAL to
the makefile, just like we did in the BETAXX releases. It used to work
nicely and build cleanely. But in 2.5.0 I get these error messages, but
it does build the binaries. Is this ok ?

Making ftpd.
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  ftpd.c
In file included from ftpd.c:42:
config.h:48: warning: `VIRTUAL' redefined
*Initialization*:1: warning: this is the location of the previous
definition
yacc  ftpcmd.y
mv y.tab.c ftpcmd.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  ftpcmd.c
In file included from ftpcmd.y:47:
config.h:48: warning: `VIRTUAL' redefined
*Initialization*:1: warning: this is the location of the previous
definition
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  glob.c
In file included from glob.c:42:
config.h:48: warning: `VIRTUAL' redefined
*Initialization*:1: warning: this is the location of the previous
definition
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  logwtmp.c
In file included from logwtmp.c:37:

--
==========================================
Rocke Robertson
PWGSC-GTIS-CPS
Voice (613) 748-4604
Fax   (613) 748-4843
mailto:[email-masked]
==========================================
"Did you know that if you play the Win NT 4.0 CD backwards, it plays a
satanic message!"
"Thats nothing! If you play it forwards, it installs Windows NT!!"

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 7 Jul 1999 14:56:31 -0400

On Wed, Jul 07, 1999 at 11:37:33AM -0700, Rocke Robertson wrote:

> 2.6 systems.  The VIRTUAL.FTP.SUPPORT file says to add a -DVIRTUAL to the
> makefile, just like we did in the BETAXX releases. It used to work nicely
> and build cleanely. But in 2.5.0 I get these error messages, but it does
> build the binaries. Is this ok ?

In 2.5.0, VIRTUAL is the default since all versions of Solaris support it.
Simply ignore the comments about -DVIRTUAL and build the daemon.

> *Initialization*:1: warning: this is the location of the previous definition

If the only messages you get are warning such as the above, ignore them;
the daemon was built correctly.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195