Subject: How to deny ftp subcommands

From: [email-masked]
Date: Thu, 1 Jul 1999 14:44:51 +0000

Hello all,
we have installed an anonymous ftp for simple data exchange with
two separate filesystems for incomming  and outgoing data.
Users are classified and have ReadOnly or WriteOnly access according
to their class. All works well with wu-ftp.
For these users we would like to restrict the ftp subcommands to a
basic set of  about 10 commands, no mput, no mget for example.
For these two I realize it by unix access rights. It works but
the user gets missleading messages like:
  ftp> mget a*
  Bad directory components
  can't find list of remote files, oops
or:
  ftp> nlist
  200 PORT command successful.
  150 Opening ASCII mode data connection for /bin/ls.
  226 Transfer complete.
but the list ist zero.

Is there any way to deny subcommands like I did with delete,
overwrite,...  in the ftpaccess file?

Any hints and ideas are appreciated

Greetings

-- 
Mit freundlichen Gruessen
Ulrike Schmidt

+----------------------------------------------------------------------+
| Ulrike Schmidt                                                       |
| Zentralinstitut fuer Angewandte Mathematik                           |
| Forschungszentrum Juelich GmbH                                       |
| D-52425 Juelich                                                      |
|                                           Phone: +49 02461 61-6577   |
| Email: [email-masked]            Fax:   +49 02461 61-6656   |
+----------------------------------------------------------------------+

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 1 Jul 1999 09:13:49 -0400 (EDT)

On Thu, 1 Jul 1999 [email-masked] wrote:

> we have installed an anonymous ftp for simple data exchange with two
> separate filesystems for incomming and outgoing data. Users are
> classified and have ReadOnly or WriteOnly access according to their
> class. All works well with wu-ftp.

> basic set of about 10 commands, no mput, no mget for example.

mput and mget are client-side commands.  The daemon cannot help you there.

To disable specific FTP commands: "Happy hacking."

> overwrite,...  in the ftpaccess file?

Nope.

BTW, you're asking the wrong question.  What you should be asking is "Why
is this failing?"  Which is a FAQ, "Why does ls not work?".

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195