Subject: newbie having prblem with guest user ftp

From: "Simon" <[email-masked]>
Date: Thu, 8 Jul 1999 22:11:57 +0800

Hi,

I have a Solaris 2.6 running wu-ftpd Version wu-2.4.2-academ[BETA-13]

I would like to setup a guest user ftp for users to upload the webpages.

I followed the GlennFleishman Guide on configuring
but couldn't seem to get it working.

Just  a recap :

In     inetd.conf
ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd -al

1) create  user account with

    abcd:x:30011:5005::/export/home/httpd/htdocs/version2/./:/bin/noshell

    Add      /bin/noshell        in     /etc/shells

    Create     /bin/noshell  containing
    #!/bin/sh
    echo "You don't have login access"

It works cos' when I telnet     it promtps  "You don't have login acces"

2) under root dir

    mkdir bin dev etc usr usr/lib
    chmod  all of above to 0555

    cp /bin/ls to /export/home/httpd/htdocs/version2/bin/.

    cp /etc/passwd /etc/group     to     /export/home/httpd/htdocs/version2

    cp /lib    /export/home/httpd/htdocs/version2/usr/lib

    /export/home/httpd/htdocs/version2/dev
    mknod tcp c  <major> <minor>
    mknod zero  c <major> <minor>

3) setup /etc/ftpaccess

class local real,guest,abcd *
class remote real,guest,abcd *

guestgroup abcd

log commands real,anonymous,guest,abcd
log tranfers guest,anonymous,real,abcd inbound,outbound

delete yes abcd
overwrite yes abcd
rename yes abcd
chmod no anonymous
umask no anonymous

upload /export/home/httpd/htdocs/version2 yes root abcd

When I ftp I still get to

/export/home/httpd/htdocs/version2 which should appears as     "/"
and could still cd up.

Di d I miss any crucial steps or configure any thing wrongly ?

Thankx.

Best Rgds,

Simon

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 8 Jul 1999 11:28:13 -0400

> I have a Solaris 2.6 running wu-ftpd Version wu-2.4.2-academ[BETA-13]

First, you need to upgrade to version 2.5.0; the version you are using is
old and has some severe security problems which are being actively
exploited to gain root access on servers.

> I followed the GlennFleishman Guide on configuring but couldn't seem to
> get it working.

I do not know what the guide you're talking about says.  The information
you need is in the FAQ, the guest HOWTO, and the
upload.configuration.HOWTO.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ted Keller <[email-masked]>
Date: Thu, 8 Jul 1999 12:12:00 -0400 (EDT)

Simon,

Did you also add 

abcd:*:5005:

to your /etc/group file?

ted keller