Subject: Help with linked disks

From: Jack Lampley <[email-masked]>
Date: Fri, 9 Jul 1999 10:32:55 -0700

I have been running the following version of ftp on a sparc 20 running Solaris 5.6.

FTP server (Version wu-2.4.2-academ[BETA-14]

I have added 2 new 34 gig disks to give more disk space. The disks were added
under /data/anon-ftp as links to the new partitions. When I ftp in and try to
cd to the new partitions I get the following error:

ftp> cd 2mass
550 2mass: Number of symbolic links encountered during path name traversal exceeds MAXSYMLINKS.

Can someone tell me if it is possible to use symbolic links within the ftp file
structure as I need to do. Is it just a matter of adding a line like MAXSYMLINKS =
1 or 2 into the ftpaccess file or somewhere?

Thanks for your help,

Jack Lampley, System Administrator
Infrared Processing and Analysis Center (IPAC)
California Institute of Technology (CalTech)
MS 100/22, Pasadena, CA 91125

Telephone : 818-397-9551
Internet  : [email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 9 Jul 1999 13:54:39 -0400

> FTP server (Version wu-2.4.2-academ[BETA-14]

#include "standard-rootshell-warning"

> I have added 2 new 34 gig disks to give more disk space. The disks were
> added under /data/anon-ftp as links to the new partitions. When I ftp in
> and try to cd to the new partitions I get the following error:
> 
> ftp> cd 2mass
> Can someone tell me if it is possible to use symbolic links within the
> ftp file structure as I need to do. Is it just a matter of adding a line
> like MAXSYMLINKS = 1 or 2 into the ftpaccess file or somewhere?

Upgrade to 2.5.0.  If the daemon still complains, look for a loop in the
symlinks (think "inside the chroot" as well as "globally" .. a non-loop,
globally, can be a loop once the daemon chroots).

MAXSYMLINKS is a compile-time constant defined by the OS.  It's probably
big enough; you should never need to change it.

Symlinks, so long as they are consistent with the inside-view after the
daemon chroot's, will work.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195