Subject: No files (LIST/NLST)

From: Claus Larsen <[email-masked]>
Date: 15 Jul 99 14:14:19 +0100

I use wu-ftpd 2.5.0 on aix 4.3.2.

I have the problem with no files listed in browser, other clients working fine, for all my normal user accounts, a LIST/NLST problem I know. I've setup an anonymous ftp account using /usr/samples/tcpip/anon.ftp (a script provided from IBM), and that account is working fine with all clients.
The scripts copies files to /home/ftp, e.g. /bin/ls to /home/ftp/bin/ls, so the files available for the anonymous account and the other account (e.g. root) should be the same. But somehow it doesn't work.
Anyone has the same problem or any good ideas? 
After installing wu-ftpd, in.ftpd, ftpaccess and other files are placed in /etc, could this the reason for my problems? Another thing, the deamon doesn't seem to use the ftpaccess file (and I'm using the -a option in /etc/inetd.conf). I've tried putting the ftpaccess file in /usr/local/lib/ftpd but that doesn't work either.

Thanks

Claus Larsen, webmaster, email: [email-masked]
Herning Folkeblad Internet, Oestergade 25, DK-7400 Herning
Phone: 96263700, Fax: 97213804, URL: http://www.herningfolkeblad.dk

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 15 Jul 1999 08:42:37 -0400

On Thu, Jul 15, 1999 at 02:14:19PM +0100, Claus Larsen wrote:

> I have the problem with no files listed in browser, other clients working
> fine, for all my normal user accounts, a LIST/NLST problem I know. I've
> setup an anonymous ftp account using /usr/samples/tcpip/anon.ftp (a
> script provided from IBM), and that account is working fine with all
> clients.
> 
> The scripts copies files to /home/ftp, e.g. /bin/ls to /home/ftp/bin/ls,
> so the files available for the anonymous account and the other account
> (e.g. root) should be the same. But somehow it doesn't work.
> 
> After installing wu-ftpd, in.ftpd, ftpaccess and other files are placed
> in /etc, could this the reason for my problems? Another thing, the deamon
> doesn't seem to use the ftpaccess file (and I'm using the -a option in
> /etc/inetd.conf). I've tried putting the ftpaccess file in
> /usr/local/lib/ftpd but that doesn't work either.

Check that the ftpaccess file is where the daemon expects it to be.  Be
sure you did a kill -HUP in inetd to tell it to use the new command line.

Your directory listing problem is a FAQ.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195