Subject: RE: ls works but dir does not!!!!

From: "Niesz, Russell" <[email-masked]>
Date: Tue, 27 Jul 1999 08:56:36 -0700

I went through the guest howto and the chroot test works. Not only that, but
I now have a statically compiled ls in ~ftp/bin/ls. When I do "ls" it works
fine, but when I do "dir" or "ls -l" I still get:

> 150 Opening ASCII mode data connection for /bin/ls.
> 226 Transfer complete.

with no files being listed. I touched a file called iamhere in the ~ftp
directory to make sure that I am chrooted where I think that I am.

Any suggestions would be appreciated.

Thanks again
Russ (frustrated in Sacramento)  :)

-----Original Message-----
From: Gregory A Lundberg [mailto:[email-masked]]
Sent: Monday, July 26, 1999 11:14 AM
To: Niesz, Russell
Cc: [email-masked]'
Subject: Re: ls works but dir does not!!!!

On Mon, Jul 26, 1999 at 10:52:50AM -0700, Niesz, Russell wrote:

> I have a user setup in a guestgroup when he logs in he can ls and he gets
> a file listing.  when he does "ls -l" it says: 
> 
> 150 Opening ASCII mode data connection for /bin/ls.
> 226 Trasnfer complete.
> 
> but no files were ever listed. the same thing happens with dir.  I can
> chroot my shell to the users home directory and ls -l works fine.
> 
> Any help would be GREATLEY appreciated. Please respond to me privately
> because I just got on the list and may not get the response until I am
> accepted. I will post a summary of the problem/solution to the list when
> I am on.

Run through the Guest HOWTO.  If the chroot test works, and the user cannot
LIST (ls command), then check the user is chroot'd where you think they
are.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "Niesz, Russell" <[email-masked]>
Date: Tue, 27 Jul 1999 09:02:51 -0700

turns out the problem was that after I moved the static ls to ~/ftp/bin/, I
never set the mode so that it was executable.........argghh!!!!

Thanks to all that helped.
Russ (whew)

-----Original Message-----
From: Gregory A Lundberg [mailto:[email-masked]]
Sent: Monday, July 26, 1999 11:14 AM
To: Niesz, Russell
Cc: [email-masked]'
Subject: Re: ls works but dir does not!!!!

--