Subject: Denies access to real users

From: Carlos Vicente <[email-masked]>
Date: Sun, 25 Jul 1999 17:48:32 -0500

Hello all.
I just compiled wu-ftpd version 2.5.0 on my RedHat 6.0 box.
Kernel version: 2.2.10
gcc version: egcs-2.91.66 (egcs-1.1.2 release)
Using shadow passwords
Using MD5 algorithm for passwords

Everything seems to work fine except for "real" users access.
When I try to log in it keeps saying :
"530 Login incorrect.
Login failed."

Anonymous access works fine.

I'm fear that the problem comes from using MD5 for /etc/shadow
passwords.
I'm just using it because I read it was more secure than standard
crypt() algorithm.

What can I do?

I would appreciate your help on this.
Thank you very much in advance.
-- 
Carlos Vicente
RedINTEC
Instituto Tecnologico de Santo Domingo
Republica Dominicana
PGP Key: http://www.intec.edu.do/~cvicente/pgp.key

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 26 Jul 1999 11:01:47 -0400

On Sun, Jul 25, 1999 at 05:48:32PM -0500, Carlos Vicente wrote:

> Everything seems to work fine except for "real" users access.  When I try
> to log in it keeps saying :
> 	530 Login incorrect.
> I'm fear that the problem comes from using MD5 for /etc/shadow passwords.
> I'm just using it because I read it was more secure than standard crypt()
> algorithm.

Since you're using Redhat, I'd suggest using PAM in the demon and letting
PAm handle the issue.

Otherwise, you need to hack ftpd.c in the pass() function to use MD5
instead of crypt.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Carlos Vicente <[email-masked]>
Date: Mon, 26 Jul 1999 11:08:15 -0500

> Since you're using Redhat, I'd suggest using PAM in the demon and letting

How do I do that?