Subject: More on linked disks

From: Jack Lampley <[email-masked]>
Date: Thu, 15 Jul 1999 10:57:26 -0700

Concerning the problem accessing linked disks within the ftp file structure. There is a
number in front of the error:

ftp> cd /pub/2mass
550 /pub/2mass: No such file or directory.

I did:

cd ~ftp
chroot ~ftp /bin/ls -alR

and the links show up ok:

./pub:
total 12
drwxr-xr-x   4 root     root         512 Jul 14 17:01 .
drwxr-xr-x  10 root     other        512 Jul 14 17:05 ..
lrwxrwxrwx   1 root     other          6 Jul 14 17:01 2mass -> /2mass
lrwxrwxrwx   1 root     other          9 Jul 14 17:01 irsa_ftp -> /irsa_ftp

Any other suggestions?

Thanks,

Jack Lampley, System Administrator
Infrared Processing and Analysis Center (IPAC)
California Institute of Technology (CalTech)
MS 100/22, Pasadena, CA 91125

Telephone : 818-397-9551
Internet  : [email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 15 Jul 1999 14:59:46 -0400

> lrwxrwxrwx   1 root     other          9 Jul 14 17:01 irsa_ftp -> /irsa_ftp

the links show up, but the filesystems didn't .. of course you didn't
notice that.  you should have see

./2mass

but that's not where it is .. that would be ~ftp/2mass and you didn't mount
it there, you mounted it as /2mass

> Any other suggestions?

Sure.  Do it right.

Mount /dev/<2mass> as ~ftp/pub/2mass and forget the symlink.

Or mount it as ~ftp/2mass and 
  cd ~ftp/pub
  ln -s ../2mass 2mass

READ MY LIPS .. you CAN NOT mount /dev/<2mass> as /2mass and symlink to it
from the ~ftp area to it.  It will not work.  It cannot be made to work.

-- 

Gregory A Lundberg              WU-FTPD Development Group
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195