Subject: Server quietly closing connection after large transfer

From: "Douglas C. MacKenzie" <[email-masked]>
Date: Thu, 22 Jul 1999 23:26:43 +0100

I use ftp nightly to retrieve backup files across a firewall
so a secure machine can write them to tape.  This works fine
as long as the files are small.  However, when the files get large
wu-ftpd quietly closes the connection after retrieving one file
in a mget command.
I'm using Red Hat Linux version 5.2 and wu-ftp version 2.5.0
(wu-ftpd-2.5.0-0.5.2-i386.rpm from the wu-ftpd ftpsite).

My ftp script uses mget since the file names change daily.  It looks
like this:
    mget *
    mdel *
(BTW, It would be nice to have a "move" command  which did a get and
then a delete)

This works fine with files in the 2Mbyte range.
However, if the first file is up in the 250Mbyte range
(252,180,365 bytes is one example) the mget quits after retrieving
only the first file.  The get takes around 940 seconds.

This sounds like I am bumping into either the time or byte transfer
limits.
However there are no log messages on the server and no limits set in
ftpaccess.  The ftp login I'm using is a real user account.

Here is a copy of my /etc/ftpaccess file:

-------------------------------------------------------------------------------------------

class emp real  *
class cust guest  *
class anon  anonymous  *

defumask 002

email [email-masked]

noretrieve core
noretrieve /etc/passwd /etc/group

loginfails  3
greeting  brief

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

private    no

compress       yes *
tar            yes *
chmod    no  guest,anonymous
delete   no  anonymous
overwrite  no  anonymous
rename   no  anonymous

log transfers anonymous,real,guest inbound,outbound

shutdown /etc/shutmsg

passwd-check rfc822 warn

#path-filter guest  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$ ^\. ^_

# Users who are members of one of these group in /etc/group will
# be chroot'd the same as anonymous users would be.
guestgroup customer
guestgroup ippost

# Running into problems with backup ftp grabs of 250Meg
byte-limit total 1000000000 real

-------------------------------------------------------------------------------------------

I have the same problem with and without the byte-limit line.

Here is a copy of the session from the clients end:
--------------------------------------------------------------------------------------------

[root@Dot tmp]# s5ftp -i inet1
Connected to inet1.woodlandnet.com.
220 inet1 FTP server ready.
331 Password required for backups.
230 User backups logged in.
cd tars
250 CWD command successful.
binary
200 Type set to I.
mget *.tz
local: inet1_full_1999_07_20.tz remote: inet1_full_1999_07_20.tz
200 PORT command successful.
150 Opening BINARY mode data connection for inet1_full_1999_07_20.tz
(252180365 bytes).
421 Service not available, remote server has closed connection
252180365 bytes received in 9.4e+02 seconds (2.6e+02 Kbytes/s)
local: inet1_inc_1999_07_21.tz remote: inet1_inc_1999_07_21.tz
No control connection for command: Unknown error
local: inet1_inc_1999_07_22.tz remote: inet1_inc_1999_07_22.tz
No control connection for command: Unknown error
Not connected.
quit
-------------------------------------------------------------------------------------------------

If I manually delete the large file from the server after it has been
backup up
everything works fine next time.  However, I tend to forget and get
multiple
backups of the same huge file, while missing the incrementals for a
couple days.

Any suggestions will be appreciated.

    Doug MacKenzie

--
Douglas C. MacKenzie, Ph.D.
Mobile Intelligence Corporation
Voice/Fax: +1 616.554.4639
mailto:[email-masked]
http://www.mobile-intelligence.com

---

From: Ted Keller <[email-masked]>
Date: Thu, 22 Jul 1999 17:48:33 -0400 (EDT)

Douglas,

Verify that your firewall is not shutting down the command port - thus
terminating the session.  Just a thought....

ted keller

---

From: Alan Olsen <[email-masked]>
Date: Fri, 23 Jul 1999 06:50:35 -0700

> wu-ftpd quietly closes the connection after retrieving one file

Do a netstat and see if it is dropping one of the two open ftp ports.  If it 
is, then you need to have a talk with your firewall admin and have him check 
the tcp timeout.  Have him make sure it has not gotten set to 1.

I had this happen on our firewall after an upgrade.  Drove me nuts for a 
couple of weeks until we figured out what happened.