Subject: Virtual interfaces problem.

From: Carles Xavier Munyoz Baldó <[email-masked]>
Date: Tue, 01 Jun 1999 17:58:34 +0200

Hello,

I'm using wu-ftpd in Sun Solaris 2.7
I have one network card with multiple virtual interfaces configured over
it (hme0, hme0:1, hme0:2, hme0:3 and hme0:4).

My problem is:
(*) If I connect to the wu-ftpd using the IP of the interface hme0 all
goes fine.
(*) But, if I connect using the IP of any of the virtual interfaces
(hme0:1, hme0:2, hme0:3 or hme0:4) I experiment several problems.
For example, when I connect apear the message:
Connected to ftp.mydomain.ext.
but must wait 6 seconds for the login prompt to appear.
Another problem, is that when I transfer lot of files using the WS-FTP
client, randomly obtain the error:
Blocking call cancelled

Any solution ?

Many thaks.
---
CTV-JET
Carles Xavier Munyoz Baldó / [email-masked]
http://www.ctv.es/USERS/carles
Dpto. Sistemas / System Department
Clave pública PGP / PGP public KEY
http://www.ctv.es/PGP-STAFF/carles.html
Tel: +34 96 584 52 91 - Fax: +34 96 584 48 96
---

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 1 Jun 1999 12:18:16 -0400 (EDT)

> but must wait 6 seconds for the login prompt to appear.

I'd look for network problesm.  DNS, ARP something like that.  If the
client is a windows box try making sure it has a valid DNS entry for both
forward and reverse lookups.  Also, make sure it does not drop AUTH
packets (just let them be refused).

> client, randomly obtain the error:

Sure.  Switch do Unix.  Windows can't take the load you're asking it to.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195