Subject: More on CWDIR

From: Thomas Neshite <[email-masked]>
Date: Thu, 17 Jun 1999 13:10:36 -0400 (EDT)

Sorry. Something I forgot to mention but may be important:

 Does ftpd run with an effective uid and gid? I set it up to run as
 ftp:data , which is why I thought this directory structure would
 work (since group "data" is in the loop on /home/data/development).

 tjn

>  Good day everyone!
>  
>  How does wuftp determine cwdir?
>  
>  I have a real user (uid=username, gid=users) whose home directory is
>  /usrA/username. When he logs in telnet or ftp, he is placed there.
>  
>  I have a directory elsewhere where he needs to place files:
>  /home/data/development.
>  
>  /home is owned by root:data (i.e., owner:group) with perms 755.
>  /home/data is owned by me:data with perms 751.
>  /home/data/development is owned by username:data with perms 751.
>  
>  When he telnets in, he cd's to /home/data/development . When he
>  does a pwd it returns the full path.
>  He ftps in and then cd's to /home/data/development. If he does a
>  pwd, it returns "." If he tries to uplaid -ooops! freudian slip!-
>  upload a file there he gets:
>  "553 Could not determine cwdir: Permission denied."
>  
>  He is not chrooted (in /etc/passwd), he is not guestgrouped (in
>  ftpaccess).
>  
>  What gives? How does wuftp determine cwdir? Why can he not ftp?
>  BTW, he has no problem in his home directory /usrA/username.
> 
>   Much admiration,
>  
>  tjn
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Jun 1999 08:34:03 -0400 (EDT)

On Thu, 17 Jun 1999, Thomas Neshite wrote:

> ftp:data , which is why I thought this directory structure would work
> (since group "data" is in the loop on /home/data/development).

run the server as root.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195