Subject: failed login using wu-ftpd

From: Giles Richardson <[email-masked]>
Date: Mon, 07 Jun 1999 14:47:49 +0200

Thank you for your swift reply.
The version of wu-ftpd that I am using is wu-ftpd-2.5.0
The OS I am using is Solaris 2.6
As far as I can see no error has been logged to my system logs.
I have edited my inetd.conf to include a `-' before the arguments al
I then restarted inetd using kill -HUP

I get the following when trying to connect via ftp:

ftp .
Connected to ..
ftpd: Unknown flag -a ignored.
ftp> 

I changed inetd.conf back again and ...

ftp .
Connected to ..
220 test-box1 FTP server (SunOS 5.6) ready.
Name (.:ger): ger
331 Password required for ger.
Password:
530 Login incorrect.
Login failed.
ftp> 

Assuming that the build/install went ok, all I need is to configure some 
config files - right?
I think /etc/services is fine
I think /etc/inetd.conf is ok.
	ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd -Aol
I am trying to connect as someone already listed in /etc/passwd.

I have created /etc/shells and filled it up (inc shell used by ger above)

/etc/ftpusers - I have added ger (see above attempoted lpogin)
/etc/ftphosts - I have added the lines
	allow ger xxx.xxx.xxx.xxx - the IP of the machine I am working oin
	allow ger xxx.xxx.xxx.xxx - the IP of another machine I am trying to connect 
from.
/etc/ftpgroups - I will add a line which is in this format
	madeupgroupname:cryptedp/word:entryin /etc/group
The fact that I haven't done this yet shouldn't prevent me from gaining access 
via ftp at the moment though should it?

/etc/ftpaccess - I just copied the file ftpaccess.heavy from doc/examples and 
renamed it.
/etc/conversions - I copied the file ftpconversions.solaris and renamed it.

Anymore ideas would be most welcome and very much appreciated.

-- 
Giles Richardson
Applications Engineer
Value Added Services
Ext. 1031

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 7 Jun 1999 09:52:12 -0400 (EDT)

> 220 test-box1 FTP server (SunOS 5.6) ready.

inetd is running the wrong FTP daemon.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195