Subject: Any patches to add support for name-based virtual ftp servers?

From: "Douglas C. MacKenzie" <[email-masked]>
Date: Thu, 17 Jun 1999 19:14:45 +0100

I'm hosting a few web sites on my machine and I'm trying
to set up multiple anonymous ftp servers, one for each site.
All of the sites are mapped to the same IP address by my DNS.

Apache httpd is able to differentiate the different web sites
using virtual hosting.  You say something like:
    <VirtualHost www.yourcompany.com>
        DocumentRoot  /home/yourcompany/htdocs
    </VirtualHost>
    <VirtualHost www.mycompany.com>
        DocumentRoot  /home/mycompany/htdocs
    </VirtualHost>
and it is able to keep them straight based just on the name.

wu-ftpd has the beginnings of a virtual host facility, but it
is based on having a different IP address for each company.
There is no way I can get that many IP addresses.
So, I would like to be able to say (in ftpaccess):
    virtual ftp.yourcompany.com root /home/yourcompany/ftp
    virtual ftp.mycompany.com /home/mycompany/ftp
and have it work (it doesn't).

Are there any patches available to add this capability?
If not, does anyone have any pointers on where to start hacking?

Thanks,

    Doug
--
Douglas C. MacKenzie, Ph.D.
Mobile Intelligence Corporation
Voice/Fax: +1 616.554.4639
mailto:[email-masked]
http://www.mobile-intelligence.com

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Jun 1999 08:39:57 -0400 (EDT)

On Thu, 17 Jun 1999, Douglas C. MacKenzie wrote:

> I'm hosting a few web sites on my machine and I'm trying to set up
> multiple anonymous ftp servers, one for each site. All of the sites
> are mapped to the same IP address by my DNS.
> 
> Apache httpd is able to differentiate the different web sites using
> virtual hosting.  You say something like:
> wu-ftpd has the beginnings of a virtual host facility, but it is based
> on having a different IP address for each company. There is no way I
> can get that many IP addresses. So, I would like to be able to say (in
> ftpaccess):
> Are there any patches available to add this capability? If not, does
> anyone have any pointers on where to start hacking?

This answer applies to *ALL* FTP servers.  Not just WU-FTPD.

The FTP protocol does *NOT* support name-based virtual hosting.  There are
*NO* patches available to add it.  Such patches are *NOT* possible.

The FTP Working Group is developing a new FTP protocol specification which
will, when adopted, suport name-based virtual hosting.  Currently, there
are only two servers and one client which support this feature; these are
solely for the working gorup members to test the facility and cannot be
used by mortals.

There is no point in telling you where to start hacking since it wouldn't
do you any good.  If you got the server to work you couldn't use the
fature since your customers don't have any software which could make use
of it.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195