Subject: Solaris build help required

From: Giles Richardson <[email-masked]>
Date: Thu, 03 Jun 1999 11:27:30 +0200

I have not installed wu-ftpd before (or done much work on Sun boxes before).
I am having problems doing the build - can anyone please help me?

I have changed the Makefile.sol files so that CC=gcc, I have gcc in my path 
and /usr/ucb removed from my path.

My pathnames.h looks like this:

define _PATH_FTPUSERS  "/etc/ftpusers"
define _PATH_FTPACCESS "/usr/local/etc/ftpaccess"
define _PATH_EXECPATH  "/bin/ftp-exec"
define _PATH_PIDNAMES  "/usr/local/daemon/ftpd/ftp.pids-%s"
define _PATH_CVT       "/usr/local/etc/ftpconversions"
define _PATH_XFERLOG   "/usr/adm/xferlog"
define _PATH_PRIVATE   "/etc/ftpgroups"

ifndef _PATH_UTMP
define _PATH_UTMP      "/etc/utmp"
define _PATH_WTMP      "/usr/adm/wtmp"
define _PATH_LASTLOG   "/usr/adm/lastlog"
endif

define _PATH_BSHELL    "/bin/sh"
define _PATH_DEVNULL   "/dev/null"

ifdef  HOST_ACCESS
define _PATH_FTPHOSTS  "/usr/local/etc/ftphosts"
endif

When I run ./build sol I get the following...

./build sol
make args are : 
make opts are : 

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a

ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
In file included from ftpd.c:83:
pathnames.h:32: parse error before `_PATH_FTPUSERS'
In file included from /usr/include/fcntl.h:19,
                 from ftpd.c:91:
/usr/include/sys/fcntl.h:149: parse error before `}'
/usr/include/sys/fcntl.h:149: warning: data definition has no type or storage 
class
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:180: previous declaration of `realpath'
ftpd.c: In function `main':
ftpd.c:382: `_PATH_DEVNULL' undeclared (first use in this function)
ftpd.c:382: (Each undeclared identifier is reported only once
ftpd.c:382: for each function it appears in.)
ftpd.c: In function `user':
ftpd.c:702: `_PATH_FTPHOSTS' undeclared (first use in this function)
ftpd.c:855: `_PATH_BSHELL' undeclared (first use in this function)
ftpd.c: In function `checkuser':
ftpd.c:896: `_PATH_FTPUSERS' undeclared (first use in this function)
ftpd.c: In function `pass':

ftpd.c:1104: `_PATH_XFERLOG' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o 
-lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
In file included from ftpcount.c:51:
pathnames.h:32: parse error before `_PATH_FTPUSERS'
In file included from ftpcount.c:52:
extensions.h:32: parse error before `}'
ftpcount.c: In function `acl_countusers':
ftpcount.c:193: `_PATH_PIDNAMES' undeclared (first use in this function)
ftpcount.c:193: (Each undeclared identifier is reported only once
ftpcount.c:193: for each function it appears in.)
ftpcount.c: In function `main':
ftpcount.c:284: `_PATH_FTPACCESS' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o 
-lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
In file included from ftpshut.c:50:
pathnames.h:32: parse error before `_PATH_FTPUSERS'
ftpshut.c: In function `main':
ftpshut.c:147: `denyoffset' undeclared (first use in this function)
ftpshut.c:147: (Each undeclared identifier is reported only once
ftpshut.c:147: for each function it appears in.)
ftpshut.c:166: `_PATH_FTPACCESS' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 7771 + 804 + 360 = 8935
Done

If anyone can give me an idea where the problem is then I would be very 
gratefull.

Giles

-- 
Giles Richardson
Value Added Services

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 3 Jun 1999 09:02:07 -0400 (EDT)

You lost the # in front of the C preprocessor commands. I'd suggest
printing off your pathnames.h, restoring the original, and re-editing ..
being a bit more careful this time.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195