Subject: help

From: Simone Sestini <[email-masked]>
Date: Wed, 09 Jun 1999 09:25:36 +0200

Good morning all..

I'm installing a 40Gb FTP site for the ISP where i'm working.
I installed yesterday the wu-ftpd 2.5.0 but i have some troubles to fix.
For that large number of Gb i did an array system via raid then i mounted
the raid system on this way..

/dev/hda3            5809071  221057  5287197      4%   /
/dev/md0             4100100  201796  3686656      5%   /array-0
/dev/md1             8065384      13  7647247      0%   /array-1
/dev/md2             8164119 2822563  4918254     36%   /array-2
/dev/md3             8643828  325676  7871956      4%   /array-3
/dev/md4             8643828 3671936  4525696     45%   /array-4

The FTP root directory is created on /array-0/ftp and i did a link on the
root like
ftp -> /array-0/ftp//

The problem now is..
under the FTP structure i insered various link like for examples..

ftp:/ftp/pub# pwd
/ftp/pub
ftp:/ftp/pub# dir -l
total 8
lrwxrwxrwx   1 root     wheel          14 Jun  8 10:31 Linux -> /array-4/Linux/
drwxr-xr-x   3 root     wheel        4096 Jun  4 12:45 mac/
drwxr-xr-x   3 root     wheel        4096 May 27 15:23 windows98/

When i enter the FTP via anonymous i can't even join to linked directory..
if i enter with root i can.

ftp> cd pub
250 CWD command successful.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 16
drwxrwxr-x   4 root     wheel        4096 Jun  8 08:31 .
drwxr-xr-x  11 root     wheel        4096 Jun  8 10:00 ..
lrwxrwxrwx   1 root     wheel          14 Jun  8 08:31 Linux -> /array-4/Linux
drwxr-xr-x   3 root     wheel        4096 Jun  4 10:45 mac
drwxr-xr-x   3 root     wheel        4096 May 27 13:23 windows98
226 Transfer complete.
ftp> cd Linux
550 Linux: No such file or directory.
ftp> 

Anyone can help me out with this strange problem ?

Another question then.. how can i modify the ftpaccess file for permit to
view the welcome.msg file before the login prompt ? normally it come after
the login to the FTP site.

Thanks in advice for your help.

--------------------------------------------------------
Simone Sestini
ATS-Link Communication
System Administrator
Via G. Ferraris, 216 - 52100 Arezzo 
ITALY

E-Mail: [email-masked]
Tel	+39 (0)575 985619
Fax	+39 (0)575 984268
--------------------------------------------------------

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 9 Jun 1999 08:44:54 -0400 (EDT)

On Wed, 9 Jun 1999, Simone Sestini wrote:

> I'm installing a 40Gb FTP site for the ISP where i'm working. I
> installed yesterday the wu-ftpd 2.5.0 but i have some troubles to fix.
> For that large number of Gb i did an array system via raid then i
> mounted the raid system on this way..
> 
> The problem now is.. under the FTP structure i insered various link
> like for examples..
> 
> ftp:/ftp/pub# pwd
> /ftp/pub
> ftp:/ftp/pub# dir -l
> total 8
> When i enter the FTP via anonymous i can't even join to linked
> directory.. if i enter with root i can.
> 
> ftp> cd pub

Not so strange.

This is an FAQ.  Anonymous FTP is chroot'd (cf: man 2 chroot) so symbolic
links will *NOT* work.

I'd suggest re-evaluating the mount points and anonymous FTP filesystem
layout.

> Another question then.. how can i modify the ftpaccess file for permit
> to view the welcome.msg file before the login prompt ? normally it
> come after the login to the FTP site.

man ftpaccess, search for 'banner'

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195