Subject: 421 Service not available, remote server has closed connection

From: "Kevin P. O'Brien" <[email-masked]>
Date: Wed, 30 Jun 1999 10:07:59 -0700

I am running Linux RedHat 4.2 2.0.36

I had wu-ftpd-2.4.2b15 running fine on my server.

I noticed that 2.5.x was released and went to upgrade.

Now I can't ftp as real users or anonymous.

As Real User I get:

421 Service not available, remote server has closed connection
Login failed.
No control connection for command: No such file or directory

As Anonymous I get:

530 Can't set guest privileges.
Login failed.

Please advise. I several customers getting very irritated, including one Boss.

Any help would be very much appreciated.

Regards,

Kevin P. O'Brien, MCP, CPST <[email-masked]>
System Administrator
Irenyx Data Group, Inc.
(Office) 1.250.334.9641 ext.239
(Fax)     1.250.334.2365
(Toll Free) 1.800.275.4260 ext.239
(Pager) 1.888.813.3605

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 30 Jun 1999 13:25:07 -0400 (EDT)

> 530 Can't set guest privileges.

Sounds like a bad built.  Try

ftp://ftp.wu-ftpd.org/pub/wu-ftpd/binaries/intel/linux/wu-ftpd-2.5.0.linux.i386.tar.gz

I built it on RH 4.2 for a 2.0.3? kernel so it should work fine for you.

If the daemon refuses a login it will give the exact reason in the system
log.  Signal 11 is bad (and I think that's what you're getting).  Other
causes will probably be self-explanatory.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195