Subject: [SOLVED] Madness and BSDI 4.0

From: Alan Olsen <[email-masked]>
Date: Thu, 10 Jun 1999 14:37:11 -0700

Well, I figured it out.  

This is fscking weird!!!

The ftpd line in BSDI looked like:

/usr/lib/siteexec/ftpd -l -a -i

Changing the line to:

/usr/lib/siteexec/ftpd -a -l

resolved the problem!!!

And I thought SCSI was voodoo!

---

From: Alan Olsen <[email-masked]>
Date: Thu, 10 Jun 1999 15:59:16 -0700

> Alan -
> 
> Do us a favor please?  Invert the order of the -a -l and see if it is order
> dependent. I've not looked at the source for parameter parsing, but do know
> that if it does not see the '-a' it is not going to use the ftpaccess file.

The order I quoted before is wrong.  (I was quoting from memory.)

The order that works "-l -a"
The order that does not: "-a -l"

It *is* order dependant. I have tested it and reproduced it with the two 
options under BSDI 4.0.

> 
> Chad
> 
> 
> At 02:37 PM 6/10/1999 -0700, you wrote:
> >Well, I figured it out.  
> >
> >This is fscking weird!!!
> >
> Chad Price
> Systems Manager
> University of Nebraska Medical Center
> 600 S 42nd St
> Omaha, NE 68506-6495
> [email-masked]
> (402) 559-9527 
> (402) 559-4077 (FAX)