Subject: anonymous logins

From: CHRIS WATSON <[email-masked]>
Date: Sat, 19 Jun 1999 15:04:33 -0600 (CST)

hello

let me give you a little more information about that last mail that I sent.

I am running solaris 2.6 with wu 2.4.2 beta 15.   the anonymous account is the
one I am haveing problems with.  all real logins work fine but anonymous
through the web or a gui ftp client will not show any of the files in the ftp
directory.

real users can log in and see their files.  I am lost with the anonymous user
though.

any ideas?

tia

chris

---

From: Gregory A Lundberg <[email-masked]>
Date: Sat, 19 Jun 1999 17:47:43 -0400 (EDT)

On Sat, 19 Jun 1999, CHRIS WATSON wrote:

> I am running solaris 2.6 with wu 2.4.2 beta 15.

Very old and very insecure.  You need to ugrade asap.  Current version is
2.5.0

> the anonymous account is the one I am haveing problems with.  all real
> logins work fine but anonymous through the web or a gui ftp client
> will not show any of the files in the ftp directory.
> 
> real users can log in and see their files.  I am lost with the
> anonymous user though.

This is a FAQ.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ted Keller <[email-masked]>
Date: Sat, 19 Jun 1999 22:20:11 -0400 (EDT)

Chris,

You will need to build a chroot environment under your anonymous ftp tree.
For solaris, you will need the following (if I remember them all.....)

2       ./etc/passwd
2       ./etc/group
2       ./etc/nsswitch.conf
0       ./etc/.name_service_door
8       ./etc
0       ./dev/zero
2       ./dev
36      ./bin/ls
178     ./bin/gzip (if you use this one)
178     ./bin/gunzip (if you use this one also)
394     ./bin
2000    ./usr/lib/libc.so.1
10      ./usr/lib/libdl.so.1
320     ./usr/lib/ld.so.1
54      ./usr/lib/nss_files.so.1
1424    ./usr/lib/libnsl.so.1
38      ./usr/lib/libmp.so.2
3848    ./usr/lib
34      ./usr/platform/sun specific hardware library/lib/libc_psr.so.1
36      ./usr/platform/sun specific hardware library/lib
38      ./usr/platform/sun specific hardware library
40      ./usr/platform
4       ./usr/share/lib/zoneinfo/US/Eastern (or approriate zone info)
6       ./usr/share/lib/zoneinfo/US
8       ./usr/share/lib/zoneinfo
10      ./usr/share/lib
12      ./usr/share
3902    ./usr

Hope this helps

ted keller