Subject: wu-ftpd 2.5.0 & slackware 4

From: Aaron Gray <[email-masked]>
Date: Tue, 01 Jun 1999 23:11:10 -0700

I installed a fresh copy of slackware 4, then installed
a fresh copy of wu-ftpd 2.5.0.  When I use "ftpwho"
it shows something like this...

Service class local:
   -   0 users ( 20 maximum)
Service class remote:
    1 ?        S      0:01 init [3]
   -   1 users ( 10 maximum)

I have other boxes (not running slakware 4) that when
i use ftpwho (running wu-ftpd 2.5.0) it shows the hostname
and waht the user is doing, etc.

Anyone know waht my problem is?

Thanks

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 2 Jun 1999 11:57:06 -0400 (EDT)

On Tue, 1 Jun 1999, Aaron Gray wrote:

> I installed a fresh copy of slackware 4, then installed a fresh copy
> of wu-ftpd 2.5.0.  When I use "ftpwho" it shows something like this...
> 
> Service class local:
>    -   0 users ( 20 maximum)
> Service class remote:
>     1 ?        S      0:01 init [3]
>    -   1 users ( 10 maximum)
> 
> I have other boxes (not running slakware 4) that when i use ftpwho
> (running wu-ftpd 2.5.0) it shows the hostname and waht the user is
> doing, etc.
> 

Nope.

There have been several questions about this for Linux (mostly RH 6.0 ..
you're the first Slackware I've seen).

If Redhat ever decides to ship the RH 6.0 CD I've order, I'll take a look
at it.  My guess though is there's something bunged up in the 'ps'
command.  Tell me: what do you get when you run `ps axwww <pid>` where
<pid> is to PID for some running process?

Also, if someone could, on a Linux system exhibiting this problem, with a
few ftpd daemons active, please send me a `ps axwww` showing all processes
(ie., no PID specified), the output from `ls -al /var/run/ftpd.pid*`, your
entire /etc/ftpaccess, and the raw (binary) /var/run/ftpd.pid* files in
existance at the same time.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195