Subject: RE: Restricting Users

From: Chad Price <[email-masked]>
Date: Tue, 08 Jun 1999 10:58:41 -0500

At 11:18 AM 6/8/1999 -0400, Vincent Aniello wrote:
>Thanks for the advice, but you didn't answer my question.

He did answer the question, but you chose to ignore the answer. Your
question is a FAQ and version 2.4 does have so many security holes that
advertising that you are running it essentially gives a hacker the keys to
your system.

>
>Is what I need to do possible with wu-ftpd?

Yes, but not using the exact methodology you propose; and if you read the
FAQ and the manual pages it will tell you how. Also check Bero ftpd. 

>
>--Vincent
>
>
>-----Original Message-----
>From: Gregory A Lundberg [mailto:[email-masked]]
>Sent: Monday, June 07, 1999 4:45 AM
>To: Vincent Aniello
>Cc: [email-masked]
>Subject: Re: Restricting Users
>
>
>On Sun, 6 Jun 1999, Vincent Aniello wrote:
>
>> I would like to run a second wu-ftpd on a server and use a different
>> port than the standard FTP ports.  I would like to create users that
>> only have the ability login to the second wu-ftpd.  How can this be
>> done?  Does wu-ftpd support multiple passwd files or is this some done
>> through the ftpaccess file?
>> 
>> Also, if this is possible, what version does it require.  I am
>> currently running 2.4, but can upgrade if required.
>
>Upgrading is very strongly recommended.
>
>You are running version 2.4 .. which is another way of saying you have no
>concerns about security.  So why bother?  Anyone who wants it already has
>root access on the machine.
>
>The location of the latest version of wu-ftpd can be found in the 
>directory
> 
>      ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
> 
>wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
>wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
>wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
>
>-- 
>
>The current release has features which will probably do what you want and
>won't cause you all sorts of customer-support headaches by using different
>port numbers.  If the base release does not do enough, consider using
>BeroFTPD instead.
>
>-- 
>
>Gregory A Lundberg              Senior Partner, VRnet Company
>1441 Elmdale Drive              [email-masked]
>Kettering, OH 45409-1615 USA    1-800-809-2195

Chad Price
Systems Manager
University of Nebraska Medical Center
600 S 42nd St
Omaha, NE 68506-6495
[email-masked]
(402) 559-9527 
(402) 559-4077 (FAX)

---

From: "Chip Downs, Webmaster" <[email-masked]>
Date: Wed, 9 Jun 1999 09:10:26 +0900

Has the resource center been moved or hacked?  I went to the landfield.com
site and it currently has a page full of information from the Electronic
Fear Foundation with not a single word about wu-ftpd...The list archive
seems to be intact though..

Chip Downs, Webmaster MoMo2000

---

From: Bob Luckin <[email-masked]>
Date: Tue, 08 Jun 1999 19:20:12 CDT

Chip said :-
> >wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

On 02 June, Kent sent the following email to the list :-
> FYI:
> 
> This is just a note to inform all that over the next few days I
> will be converting the WU-FTPD Resource Center over to information
> pertaining to the wu-ftpd.org generated ftpd server.
> 
> Man pages, examples, dev-corner, patches submission, etc. will be
> documented there.  I'll try to make sure it is apparent as to what
> version I'm referencing but the default documented version is
> changing to wu-ftpd version 2.5.0.
> 
> The original information will be maintained for a while but it
> will require digging a bit more into the site.
> 
> FWIW...

So what you're seeing _could_ be related to this effort...

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "Coder, adapt.  FTP Ada, redo C"