Subject: HELP with chrooted guest account file sharing?!

From: [email-masked]
Date: Thu, 10 Jun 1999 12:27:16 -0400

As users are prone to do, our users are constantly coming up with new and
creative ways to break things. %:^(

Here's the problem.
We have a host (DEC Alpha,DU4.0D,wu-ftpd v2.4.2) with anon. ftp and chrooted
guest accounts. A programmer wants to be able to:
	- ftp in as herself
	- cd to a chrooted guest account directory
	- put files in this directory
	- have these files be available to those who ftp into the chrooted 
	  guest account
	- have the chrooted guest account be able to put files in its directory
Problem seems to be that if I put our programmer in the group that the 
chrooted account has (misc), then when she ftps in she is automatically
chrooted, even though there's nothing in her password entry to cause this.
If the programmer does not share a group with the chrooted guest account, when
she puts files in that area they have her ownership, and guests cannot access
them.

Ownership is:
/usr/local/ftp/guest/[guest_account]	[guest_account] xfer
/usr/local/ftp/guest/[guest_account]/[guest_created_files] [guest_account] misc
/usr/home/[programmer_account]	[programmer_account] staff

/etc/passwd:
[guest_account] guest_uid,misc_gid
[programmer]    programmer_uid,staff

/etc/group:
staff
misc	
xfer	programmer_account

How can we set this up so programmer can ftp in as herself, put files in 
chrooted guest area, and have them be owned by, or at least share a group with,
the chrooted guest account?

Huge TIA!!!

- -- 
Judith Reed
[email-masked]
(315) 453-2912 x335

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 10 Jun 1999 12:54:02 -0400 (EDT)

On Thu, 10 Jun 1999 [email-masked] wrote:

> As users are prone to do, our users are constantly coming up with new
> and creative ways to break things. %:^(
> 
> Here's the problem.
> We have a host (DEC Alpha,DU4.0D,wu-ftpd v2.4.2) with anon. ftp and
> chrooted guest accounts. A programmer wants to be able to:
> 	- ftp in as herself
> chrooted account has (misc), then when she ftps in she is
> automatically chrooted, even though there's nothing in her password
> entry to cause this. If the programmer does not share a group with the
> chrooted guest account, when she puts files in that area they have her
> ownership, and guests cannot access them.
> 
> Ownership is:
> How can we set this up so programmer can ftp in as herself, put files
> in chrooted guest area, and have them be owned by, or at least share a
> group with, the chrooted guest account?

Well, you need to upgrade anyway.

Simple solution: get 2.5.0 and RTFM (hint: real-uid)

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195