Subject: Re: Can't create data socket (0.0.0.0,20)

From: "Pat Hardy" <[email-masked]>
Date: Fri, 30 Apr 1999 11:03:59 -0400

> Hello,
> 
> I'm currently running BETA-13 of the WU-FTPD server. I just started 
> receiving an error I can't seem to find a solution for. The error message 
> is:
> 
> 	425 Can't create data socket (0.0.0.0,20): Bad file number.
> 
> Can anyone tell me what this means and hoe can I fix this problem? I 
> happens every time I try to do an 'ls' in a directory.
> 
> Thanks
> 
> 

Oops. I forgot to mention something:

I'm running Solaris 2.51. Here's some more information:

Generic_103640-24 sun4u sparc SUNW,Ultra-1

----------------
Pat Hardy - Web Developer
Market Guide, Inc (NASDAQ: MARG)          I haven't lost my mind;
Lake Success, Long Island, NY 11042-1011  it's backed up on tape
http://www.marketguide.com                somewhere.
Telephone: 516 327 2400 x228

---

From: Bob Luckin <[email-masked]>
Date: Fri, 30 Apr 1999 12:59:38 CDT

> Generic_103640-24 sun4u sparc SUNW,Ultra-1

Have you checked the section on this in the FAQ ?

   http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html

Look under section 1.10.1.

You may need to make sure you have ~ftp/dev/tcp and ~ftp/dev/zero present,
and with the correct permissions (tcp at least needs to be world writeable
(666) in order to allow passive connections under Solaris).  

Hope this helps !

Cheers, Bob
-- 
On mega data disks, attempt FTP. An inapt FTP; met task's ID a tad. A gem, no ?
Bob Luckin      [email-masked]      [http://www.dhc.net/~luckin/palindromes.html]