Subject: Re: Help compiling WU-FTP on IRIX 6.4

From: [email-masked]
Date: Tue, 27 Apr 1999 13:16:02 PDT

Here is the tail end of what I get when I run the command
"./build CC=gcc sgi"

       int     nisigno;                        
        void    (*nifunc) (sigval_t);           
} notifyinfo_t;

typedef struct sigevent {
        int                     sigev_notify;
        notifyinfo_t            sigev_notifyinfo;
        sigval_t                sigev_value;
        unsigned long           sigev_reserved[13];
        unsigned long           sigev_pad[6];
} sigevent_t;

# 1 "/usr/include/sys/siginfo.h"

# 1 "/usr/include/standards.h"
# 19 "/usr/include/sys/siginfo.h"
# 1 "/usr/include/sys/signal.h"

# 20 "/usr/include/sys/siginfo.h"

# 49 "/usr/include/sys/siginfo.h"

# 63 "/usr/include/sys/siginfo.h"

# 100 "/usr/include/sys/siginfo.h"

# 112 "/usr/include/sys/siginfo.h"

# 183 "/usr/include/sys/signal.h"

typedef struct siginfo {
        int     si_signo;               
        int     si_code;                
        int     si_errno;               
        union {

                int     si_pad[((128 / sizeof(__int32_t)) - 3)];        

                struct {                        
                        pid_t   __pid;          
                        union {
                                struct {
                                        uid_t   __uid;
                                } __kill;
                                struct {
                                        clock_t __utime;
                                        int __status;
                                        clock_t __stime;
                                } __cld;
                        } __pdata;
                } __proc;                       

                struct {        
                        void    *__addr;        
                } __fault;

                struct {                        
                
                        int     __fd;   
                        long    __band;
                } __file;

                union sigval    __value;

        } __data;

} siginfo_t;

# 239 "/usr/include/sys/signal.h"

# 247 "/usr/include/sys/signal.h"

typedef struct {                
        __uint32_t __sigbits[4];
} sigset_t;

typedef union __sighandler {
        void (*__sa_handler)(); 

        void (*__sa_sigaction)(int, siginfo_t *, void *);

} __sighandler_t;

typedef struct sigaction {
        int sa_flags;                   
        __sighandler_t sa_sighandler;   
        sigset_t sa_mask;               
                                        
        int sa_resv[2];
} sigaction_t;

# 294 "/usr/include/sys/signal.h"

                                        

struct sigstack {
        void    *ss_sp;                 
        int     ss_onstack;             
};

typedef struct sigaltstack {
        void    *ss_sp;
        int     ss_size;
        int     ss_flags;
} stack_t;

# 1 "/usr/include/sys/ucontext.h"

# 1 "/usr/include/standards.h"
# 24 "/usr/include/sys/ucontext.h"
# 1 "/usr/include/sys/signal.h"

# 25 "/usr/include/sys/ucontext.h"
# 1 "/usr/include/sgidefs.h"

# 26 "/usr/include/sys/ucontext.h"

# 38 "/usr/include/sys/ucontext.h"

typedef unsigned int greg_t;

typedef greg_t gregset_t[36];

typedef struct __fpregset {
        union {
                double          __fp_dregs[16];
                float           __fp_fregs[32];
                unsigned int    __fp_regs[32];
        } __fp_r;
        unsigned int    __fp_csr;
        unsigned int    __fp_pad;
} fpregset_t;

typedef struct {
        gregset_t       __gregs;        
        fpregset_t      __fpregs;       
} mcontext_t;

typedef struct ucontext {
        unsigned long   uc_flags;
        struct ucontext *uc_link;
        sigset_t        uc_sigmask;
        stack_t         uc_stack;
        mcontext_t      uc_mcontext;
        long            uc_filler[47];
        
        int             uc_triggersave; 
} ucontext_t;

# 130 "/usr/include/sys/ucontext.h"

# 205 "/usr/include/sys/ucontext.h"

# 245 "/usr/include/sys/ucontext.h"

# 340 "/usr/include/sys/signal.h"

# 389 "/usr/include/sys/signal.h"

extern void     (*bsd_signal(int, void (*)(int)))(int);
extern int      killpg(pid_t, int);
extern int      sigstack(struct sigstack *, struct sigstack *);

extern void     (*signal(int,void (*)()))();

typedef struct sigcontext {
        __uint32_t      sc_regmask;     
        __uint32_t      sc_status;      
        __uint64_t      sc_pc;          

        __uint64_t      sc_regs[32];    

        __uint64_t      sc_fpregs[32];  
        __uint32_t      sc_ownedfp;     
        __uint32_t      sc_fpc_csr;     
        __uint32_t      sc_fpc_eir;     
                                        
        __uint32_t      sc_ssflags;     
        __uint64_t      sc_mdhi;        
        __uint64_t      sc_mdlo;

        __uint64_t      sc_cause;       
        __uint64_t      sc_badvaddr;    
        __uint64_t      sc_triggersave; 
        sigset_t        sc_sigset;      
        __uint64_t      sc_fp_rounded_result;   
        __uint64_t      sc_pad[31];
} sigcontext_t;

# 478 "/usr/include/sys/signal.h"

# 490 "/usr/include/sys/signal.h"

# 505 "/usr/include/sys/signal.h"

# 8 "/usr/include/sys/ptimers.h"

# 16 "/usr/include/sys/ptimers.h"

typedef struct itimerspec {
        struct timespec it_interval;    
        struct timespec it_value;       
} itimerspec_t;

typedef struct ptimer_info {
        __int64_t       next_timeout;   
        __int64_t       interval_tick;  
        int             signo;          
        union sigval    value;          
        int             clock_type;     
        toid_t          next_toid;      
        int             overrun_cnt;    
} ptimer_info_t;

# 75 "/usr/include/time.h"

# 86 "/usr/include/time.h"

struct  tm {    
        int     tm_sec;
        int     tm_min;
        int     tm_hour;
        int     tm_mday;
        int     tm_mon;
        int     tm_year;
        int     tm_wday;
        int     tm_yday;
        int     tm_isdst;
};

extern clock_t clock(void);                     
extern double difftime(time_t, time_t);         
extern time_t mktime(struct tm *);              
extern time_t time(time_t *);                   
extern char *asctime(const struct tm *);                
extern char *ctime (const time_t *);            
extern struct tm *gmtime(const time_t *);               
extern struct tm *localtime(const time_t *);    
extern size_t strftime(char *, size_t, const char *, const struct tm *);

extern void tzset(void);
extern char *tzname[2];

struct sigevent;
extern int clock_settime(clockid_t, const struct timespec *);
extern int clock_gettime(clockid_t, struct timespec *);
extern int clock_getres(clockid_t, struct timespec *);
extern int nanosleep(const struct timespec *, struct timespec *);
extern int timer_create(clockid_t, struct sigevent *, timer_t *);
extern int timer_delete(timer_t);
extern int timer_settime(timer_t, int, const struct itimerspec *, struct
itimerspec *);
extern int timer_gettime(timer_t, struct itimerspec *);
extern int timer_getoverrun(timer_t);

extern time_t timezone;
extern int daylight;
extern char *strptime(const char *, const char *, struct tm *);

extern struct tm *getdate(const char *);
extern int getdate_err;

extern int cftime(char *, char *, const time_t *);
extern int ascftime(char *, const char *, const struct tm *);
extern time_t altzone;

extern char *asctime_r(const struct tm *, char *);
extern char *ctime_r(const time_t *, char *);
extern struct tm *gmtime_r(const time_t *, struct tm *);
extern struct tm *localtime_r(const time_t *, struct tm *);

# 213 "/usr/include/sys/time.h"

# 25 "/usr/include/sys/stat.h"

# 51 "/usr/include/sys/stat.h"

struct  stat {
        dev_t   st_dev;
        long    st_pad1[3];     
        ino_t   st_ino;
        mode_t  st_mode;
        nlink_t st_nlink;
        uid_t   st_uid;
        gid_t   st_gid;
        dev_t   st_rdev;
        long    st_pad2[2];     
        off_t   st_size;
        long    st_pad3;        
        timespec_t st_atim;     
        timespec_t st_mtim;     
        timespec_t st_ctim;     
        long    st_blksize;
        blkcnt_t st_blocks;
        char    st_fstype[16];
        long    st_pad4[8];     
};

struct  stat64 {
        dev_t   st_dev;
        long    st_pad1[3];     
        ino64_t st_ino;
        mode_t  st_mode;
        nlink_t st_nlink;
        uid_t   st_uid;
        gid_t   st_gid;
        dev_t   st_rdev;
        long    st_pad2[2];     
        off64_t st_size;
        long    st_pad3;        
        timespec_t st_atim;     
        timespec_t st_mtim;     
        timespec_t st_ctim;     
        long    st_blksize;
        blkcnt64_t st_blocks;
        char    st_fstype[16];
        long    st_pad4[8];     
};

# 113 "/usr/include/sys/stat.h"

# 126 "/usr/include/sys/stat.h"

# 160 "/usr/include/sys/stat.h"

# 168 "/usr/include/sys/stat.h"

int _fxstat(const int, int, struct stat *);
int _xstat(const int, const char *, struct stat *);
int _lxstat(const int, const char *, struct stat *);
int _xmknod(const int, const char *, mode_t, dev_t);

int fchmod(int, mode_t);

extern int chmod(const char *, mode_t);
extern int mkdir(const char *, mode_t);
extern int mkfifo(const char *, mode_t);
extern mode_t umask(mode_t);

# 238 "/usr/include/sys/stat.h"

int fstat(int, struct stat *);
int stat(const char *, struct stat *);

int lstat(const char *, struct stat *);
int mknod(const char *, mode_t, dev_t);

int fstat64(int, struct stat64 *);
int lstat64(const char *, struct stat64 *);
int stat64(const char *, struct stat64 *);

# 39 "ckconfig.c"
# 1 "pathnames.h"

# 44 "pathnames.h"

# 79 "pathnames.h"

# 111 "pathnames.h"

# 145 "pathnames.h"

# 173 "pathnames.h"

# 40 "ckconfig.c"

int
main()
{
  struct stat  sbuf;
  char        *sp;
  char         buf[1024];

  fprintf((&__iob[1]), "Checking _PATH_FTPUSERS :: %s\n", "/etc/ftpusers");
  if ( (stat("/etc/ftpusers", &sbuf)) < 0 )
    printf("I can't find it... look in doc/examples for an example.\n");
  else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_FTPACCESS :: %s\n",
"/etc/ftpaccess");
  if ( (stat("/etc/ftpaccess", &sbuf)) < 0 )
    printf("I can't find it... look in doc/examples for an example.\n");
  else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_PIDNAMES :: %s\n",
"/var/adm/ftp.pids-%s");
  strcpy(buf, "/var/adm/ftp.pids-%s");
  sp = (char *)strrchr(buf, '/');
  *sp = '\0';
  if ( (stat(buf, &sbuf)) < 0 ) {
    printf("I can't find it...\n");
    printf("You need to make this directory [%s] in order for\n",buf);
    printf("the limit and user count functions to work.\n");
  } else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_CVT :: %s\n",
"/etc/ftpconversions");
  if ( (stat("/etc/ftpconversions", &sbuf)) < 0 )
    printf("I can't find it... look in doc/examples for an example.\n");
  else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_XFERLOG :: %s\n",
"/var/adm/xferlog");
  if ( (stat("/var/adm/xferlog", &sbuf)) < 0 ) {
    printf("I can't find it... \n");
    printf("Don't worry, it will be created automatically by the\n");
    printf("server if you do transfer logging.\n");
  } else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_PRIVATE :: %s\n",
"/etc/ftpgroups");
  if ( (stat("/etc/ftpgroups", &sbuf)) < 0 ) {
    printf("I can't find it... look in doc/examples for an example.\n");
    printf("You only need this if you want SITE GROUP and SITE GPASS\n");
    printf("functionality. If you do, you will need to edit the
example.\n");
  } else
    printf("ok.\n");

  fprintf((&__iob[1]), "\nChecking _PATH_FTPHOSTS :: %s\n",
"/etc/ftphosts");
  if ( (stat("/etc/ftphosts", &sbuf)) < 0 ) {
    printf("I can't find it... look in doc/examples for an example.\n");
    printf("You only need this if you are using the HOST ACCESS
features\n");
    printf("of the server.\n");
  } else
    printf("ok.\n");
  return(0);
}
Error(1005): could not open source file "/var/tmp/cca000UN.i"

1 catastrophic error detected in the compilation of "/var/tmp/cca000UN.i".
Compilation terminated.
*** Error code 1 (bu21)

Executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
size: bin/ckconfig: cannot open
Done

Larry Mangum Jr

On Mon, 26 Apr 1999 21:39:00 -0400 (EDT), Gregory A Lundberg wrote:

> So what's the symptom of the problem?  What version of the daemon are you
> trying to compile?  Someone else was having problems a day or two ago;
his
> looks like it's a lame compiler.  Which compiler/version are you
> attempting to use?
> 
> The location of the latest version of wu-ftpd can be found in the 
> directory
>  
>       ftp://ftp.vr.net/pub/wu-ftpd/
>  
> wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
> wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
> wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
> 
> -- 
> 
> Gregory A Lundberg              Senior Partner, VRnet Company
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195
> 

_______________________________________________________
Get your free, private email at http://mail.excite.com/

---

From: [email-masked]
Date: Tue, 27 Apr 1999 18:07:12 PDT

> From: Chad Price <[email-masked]>
> To: [email-masked]
> Subject: Re: Help compiling WU-FTP on IRIX 6.4
> Date: Tue, 27 Apr 1999 16:32:08 -0500
> Message-ID: <[email-masked]>
> 
> At 02:10 PM 4/27/1999 -0700, you wrote:
> >This is all that I get. Im using GNU compilers: gcc g++ and objective-C
> >Version 2.6.3
> 
> (1) Tell the list, not me. I'm not able to help as I have no IRIX but I
am
> able to see that you did not provide enough info to diagnose the problem.
> There are others much more knowledgable than myself on the list.
> 
> (2) tell them which gnu C (there is no c++ code in wu-ftpd).  Provide a
> screen copy of the point on the compile at which things go wrong. Oh.. I
> found it at the bottom of the stuff.  Promise, we don't need to see
copies
> of the source again - just a sampling. The error we need to see is:
> 
> >> >features\n");
> which basically tells me that your compiler is not installed correctly.
> I'd start there unless someone else writes with a more specific solution.
> It looks like the source files are being cat-ted to the screen rather
than
> run through the compiler after the pre-compile (cpp) stage.
> 
> >and wu-ftpd-2.4.2-vr17
> >
> 
> Good. It's the latest and works fine.
> 
> Chad
> 
> Chad Price
> Systems Manager
> University of Nebraska Medical Center
> 600 S 42nd St
> Omaha, NE 68506-6495
> [email-masked]
> (402) 559-9527 
> (402) 559-4077 (FAX)
>

---

From: [email-masked]
Date: Tue, 27 Apr 1999 18:10:21 PDT