Subject: RE: wu-2.4.2-VR17 install

From: Magdalena Hewryk <[email-masked]>
Date: Fri, 30 Apr 1999 10:41:12 -0400

Hi Gael,
I've got an error already:

# ./build install
make args are : 
make opts are : 
installing binaries.
/bin/sh: test: argument expected
make: *** [install] Error 1

Any hints?
...Magda

first I compled on solaris:  - with No problems
./build CC=gcc sol
make args are : 
make opts are :  CC=gcc

Copying Makefiles.

Linking src/config.h

Making support library.
gcc -O -DSOLARIS2  -c fnmatch.c
gcc -O -DSOLARIS2  -c strcasestr.c
gcc -O -DSOLARIS2  -c strsep.c
gcc -O -DSOLARIS2  -c authuser.c
gcc -O -DSOLARIS2  -c snprintf.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o snprintf.o
ranlib libsupport.a

Making ftpd.
gcc -g -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
yacc  ftpcmd.y 
mv -f y.tab.c ftpcmd.c
gcc -g -I.. -I../support -L../support   -c ftpcmd.c -o ftpcmd.o
gcc -g -I.. -I../support -L../support   -c glob.c -o glob.o
gcc -g -I.. -I../support -L../support   -c logwtmp.c -o logwtmp.o
gcc -g -I.. -I../support -L../support   -c popen.c -o popen.o
sh newvers.sh
gcc -g -I.. -I../support -L../support   -c vers.c -o vers.o
gcc -g -I.. -I../support -L../support   -c access.c -o access.o
gcc -g -I.. -I../support -L../support   -c extensions.c -o extensions.o
gcc -g -I.. -I../support -L../support   -c realpath.c -o realpath.o
gcc -g -I.. -I../support -L../support   -c acl.c -o acl.o
gcc -g -I.. -I../support -L../support   -c private.c -o private.o
gcc -g -I.. -I../support -L../support   -c authenticate.c -o authenticate.o
gcc -g -I.. -I../support -L../support   -c conversions.c -o conversions.o
gcc -g -I.. -I../support -L../support   -c hostacc.c -o hostacc.o
gcc -g -I.. -I../support -L../support   -c sigfix.c -o sigfix.o
gcc -g -I.. -I../support -L../support   -c routevector.c -o routevector.o
gcc -g -I.. -I../support -L../support   -c restrict.c -o restrict.o
gcc -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o
access.o extensions.o realpath.o acl.o private.o authenticate.o
conversions.o hostacc.o sigfix.o routevector.o restrict.o  -lsupport
-lsocket -lnsl -lgen 

Making ftpcount.
gcc -g -I.. -I../support -L../support   -c ftpcount.c -o ftpcount.o
gcc -L../support -o ftpcount ftpcount.o vers.o

Making ftpshut.
gcc -g -I.. -I../support -L../support   -c ftpshut.c -o ftpshut.o
gcc -L../support -o ftpshut ftpshut.o vers.o

Making ckconfig.
gcc -g -I.. -I../support -L../support   -c ckconfig.c -o ckconfig.o
gcc -L../support -o ckconfig ckconfig.o

Executables are in bin directory:
bin/ftpd: 221323 + 7084 + 26704 = 255111
bin/ftpcount: 12139 + 1136 + 896 = 14171
bin/ftpshut: 10403 + 1000 + 376 = 11779
bin/ftpwho: 12139 + 1136 + 896 = 14171
bin/ckconfig: 7803 + 792 + 364 = 8959
Done

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 30 Apr 1999 11:16:58 -0400 (EDT)

> make: *** [install] Error 1

Solaris doesn't know the -e option on test ( implicit test in the makefile
is the braces [] ).

check -e to -d everywhere in the Makefile.  This will be n the next
version.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195