Subject: RE: 425 Can't create data socket (142.148.10.35,20): Address alre ady in use - after upgrade from Solaris 2.5 to Solaris 2.6

From: Magdalena Hewryk <[email-masked]>
Date: Thu, 29 Apr 1999 09:01:29 -0400

Hi Johan,
Our wu-ftpd is configured to run via inetd (inetd.conf).
 
I have already checked inetd.conf, search for ftp and found only one ftp
service running:
ftp     stream  tcp     nowait  root    /usr/local/etc/wuftpd   wutftpd -ald

This happens for all users not only for anonymous.  We have more then 100
users constantly ftp to our system and they getting this error message only
when the volume of ftp logon's is high. 

Thanks,
...Magda
-----Original Message-----
From: Johan Claesson [mailto:[email-masked]]
Sent: Thursday, April 29, 1999 3:47 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: 425 Can't create data socket (142.148.10.35,20): Address
already in use - after upgrade from Solaris 2.5 to Solaris 2.6

Magdalena Hewryk wrote:
> 
> Hello,
> We getting error message:  <<425 Can't create data socket
> (142.148.10.35,20): Address already in use.>>
> It started on Monday, after we upgraded Solaris 2.5 to Solaris 2.6 (on the
> weekend).
> Before we never had a problem with ftp server.
> 
> I checked /passwd, /group files, and everything is the same... I cannot
see
> any changes...
> Any hints, help?
> ...Magda

Hi Magda,

Is wu-ftpd configured to run via inetd (inetd.conf) or in standalone
mode?

/J

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 29 Apr 1999 09:24:49 -0400 (EDT)

On Thu, 29 Apr 1999, Magdalena Hewryk wrote:

> This happens for all users not only for anonymous.  We have more then
> 100 users constantly ftp to our system and they getting this error
> message only when the volume of ftp logon's is high.
> 
> > We getting error message:  <<425 Can't create data socket (142.148.10.35,20): Address already in use.>>
> > 
> > It started on Monday, after we upgraded Solaris 2.5 to Solaris 2.6
> > (on the weekend).

This message means the daemon attempted to create an outgoing connection
from local port 20 on the interface 142.148.10.35, another application
(probably another instance of WU-FTPD) was using that port, and the REUSE
option was not set.

Given everything you've been saying, I'd suggest either finding a vendor
patch to correct the errors in TCP socket management in your version of
Solaris 2.6, upgrading to 2.7, downgrading to 2.5 or moving to a more
robust and stable operating system (Linux and FreeBSD come to mind).

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Chad Price <[email-masked]>
Date: Thu, 29 Apr 1999 08:26:13 -0500

At 09:01 AM 4/29/1999 -0400, you wrote:
>users constantly ftp to our system and 

Do follow Johan's advise and use 'ps -ef|grep ftp' to see just how many ftp
daemons are running.  Look at your system load.....

>they getting this error message only

NOW you tell us.... Look at your system load.  Are you trying to spawn
ftpd's faster than the system is able to?  Do you need to alter the system
boot parameters in /etc/system to allow more processes? Are you filling up
your process table?  Up-ing the max users will allow more processes to run. 

* set:
*
*       Set an integer variable in the kernel or a module to a new value.
*       This facility should be used with caution.  See system(4).
*
*       Examples:
*
*       To set variables in 'unix':
*
*               set nautopush=32
*               set maxusers=40

set maxusers=72

Chad Price
Systems Manager
University of Nebraska Medical Center
600 S 42nd St
Omaha, NE 68506-6495
[email-masked]
(402) 559-9527 
(402) 559-4077 (FAX)