Subject: VR18 compile for MacOS X server

From: Larry Goodwin <[email-masked]>
Date: Thu, 15 Apr 1999 13:03:08 -0700

Folks,

I am trying to build ftpd vr18 for Apple's MacOS X server. The system is BSD4.4.

I get malloc errors shown below. I can get rid of them by removing the
definitions in ftw.c I am not sure if that is a good thing to do.

Making support library.
cc -O -DDEBUG   -c ftw.c
ftw.c: In function `chwalk':
ftw.c:195: conflicting types for `malloc'
/System/Library/Frameworks/System.framework/Headers/bsd/stdlib.h:100:
previous declaration of `malloc'
make: *** [ftw.o] Error 1

The next error is:

MMaking support library.
rm -f libsupport.a
ar cq libsupport.a strcasestr.o authuser.o ftw.o
ranlib libsupport.a

Making ftpd.
make: *** No rule to make target `/usr/lib/libc.a', needed by `ftpd'.  Stop.

Any ideas?
Thanks,
-- 
Larry Goodwin              Phone: 408 974-0520
Apple Computer             Fax:   408 974-0800
1 Infinite Loop            Pager: 1-800-539-7517
Cupertino, CA

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 15 Apr 1999 16:40:26 -0400 (EDT)

> I am trying to build ftpd vr18 for Apple's MacOS X server. The system

Hmm.  guess I should start coding it if you're compiling it already.  You
must mean VR17. :)

> make: *** No rule to make target `/usr/lib/libc.a', needed by `ftpd'.  Stop.

first off, it's possible that nobody's done a port for wu-ftpd on MacOS.
Is it really BSD or is it MacOS which looks a lot like BSD?  You may be
charting new groupnd here.

Some specific things to do:

ftw.c error: add the following line to the end of your
src/config/config.<os> file where <os> is whatever you're saying to the
build command:

#define NO_MALLOC_PROTO

make error: try changeing src/makefiles/Makefile.<os> where it reads

LIBC     = /usr/lib/libc.a

make it say simply

LIBC     =

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195