Subject: complex directory permissions with wu-ftp (ACL ?) ?

From: Gildas PERROT <[email-masked]>
Date: Thu, 22 Apr 1999 08:49:12 +0200

Hi,

I would like to set different FTP file access permissions for several 
groups on directories.

Suppose I have 2 directories dir1 and dir2 and I want to create :

- group1 who has W access to dir1 and dir2
- group2 who has W access to dir1 only
- group3 who has R access to dir1 and dir2
- group4 who has R access to dir1 only
- group5 who has R&W access to dir1 and dir2
- group6 who has R&W access to dir1 only

Is it possible to implement that with WU-FTP (with ACL since I am using 
Solaris ?) or do I need another package ?

Thanks in advance for your help.			Gildas.
-- 
Gildas PERROT, [email-masked]         __o
FranceNet, 28 rue Desaix, 75015 Paris ---_ \<,_
http://www.francenet.fr            ---- (_)/ (_)

---

From: Chad Stewart <[email-masked]>
Date: Wed, 21 Apr 1999 21:26:47 -0400

I'm trying to configure the ability for anonymous users to upload
to a 'private' pre-established directory, in other words from
the parent dir, anonymous can *not* see the child(ren).  Once
in the child they can only put files, they can't see or read
what others might have put (aka blind put).  Below are the 
entries from my /etc/ftpaccess and the output from a 
ls -al from the parent, i.e. incoming.  Right now this
errors with permission denied (Upload).

upload   /ftp                       *      no
upload   /ftp/pub/incoming          *      no 
upload   /ftp/pub/incoming/prv      *      yes       ftp    daemon   0200
   nodirs

incoming#
drwxr-x--x   3 root     root         1024 Apr 21 13:34 .
dr-xr-sr-x   4 root     root         1024 Apr 22 18:42 ..
drwx-wx-wx   2 root     root         1024 Apr 21 13:34 prv

FTP server (Version wu-2.4.2-academ (1)
from the file wu-ftpd-2.4.2.tar.Z.

Is that the latest version?  What's the difference between
that version and the VR series?

TIA,
Chad

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 23 Apr 1999 11:35:12 -0400 (EDT)

On Wed, 21 Apr 1999, Chad Stewart wrote:

> Is that the latest version?

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.vr.net/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

> What's the difference between that version and the VR series?

Main difference: a maintainer who fixes the code, an answers questions.

Other differences: about a year and a half of coding, correcting and
bugfixing.  For details, read the FIXES* files.

Most important difference from youre point of view: it fixes the bug
you're fighting.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195