Subject: RE: 425 Can't create data socket (142.148.10.35,20): Address alre ady in use - after upgrade from Solaris 2.5 to Solaris 2.6

From: "Callaway, John" <[email-masked]>
Date: Wed, 28 Apr 1999 19:07:17 -0400

I think you will find that Solaris is starting up an FTP server for you
(awfully nice of you).  Do a 'ps -ef' (or 'ps aux', I don't know Solaris),
and grep for 'ftp', and you will probably find it running someplace.

Getting rid of it is a different story.  I am an HP and Linux tech-head, not
a Solaris one.

-----Original Message-----
From: Magdalena Hewryk [mailto:[email-masked]]
Sent: Wednesday, April 28, 1999 4:10 PM
To: [email-masked]
Subject: 425 Can't create data socket (142.148.10.35,20): Address
already in use - after upgrade from Solaris 2.5 to Solaris 2.6

Hello,
We getting error message:  <<425 Can't create data socket
(142.148.10.35,20): Address already in use.>>
It started on Monday, after we upgraded Solaris 2.5 to Solaris 2.6 (on the
weekend).  
Before we never had a problem with ftp server.

I checked /passwd, /group files, and everything is the same... I cannot see
any changes...

Any hints, help?
...Magda

Magdalena Hewryk
FundSERV Inc.
416 362-2400 ext. 237

---

From: Magdalena Hewryk <[email-masked]>
Date: Thu, 29 Apr 1999 09:04:58 -0400

John:
We do have more then one ftp session running because we have lot's of users
log in to our site.  This is normal for our site:

ndependence [/u1/magda] $ ps -ef | grep ftp
   
    root 10157   213  0 09:03:30 ?        0:00 wutftpd -ald
b9502t01 22019   213  0 12:00:40 ?        0:00 wutftpd -ald
    
 zsMSSIb 10151   213  0 09:03:28 ?        0:00 wutftpd -ald

Any hints? ....Magda

-----Original Message-----
From: Callaway, John [mailto:[email-masked]]
Sent: Wednesday, April 28, 1999 7:07 PM
To: [email-masked]'; [email-masked]
Subject: RE: 425 Can't create data socket (142.148.10.35,20): Address
alre ady in use - after upgrade from Solaris 2.5 to Solaris 2.6

-----Original Message-----
From: Magdalena Hewryk [mailto:[email-masked]]
Sent: Wednesday, April 28, 1999 4:10 PM
To: [email-masked]
Subject: 425 Can't create data socket (142.148.10.35,20): Address

Hello,

Any hints, help?
...Magda

Magdalena Hewryk
FundSERV Inc.
416 362-2400 ext. 237

---

From: Magdalena Hewryk <[email-masked]>
Date: Thu, 29 Apr 1999 10:22:27 -0400

Chad:
I have checked  compared set nautopush=32 & set maxusers=40 on both
machines, the one we upgraded and the one we left alone.  Both have the same
setting.  The one which is NOT  upgraded doesn't give us ANY problems and
the one which we upgraded has a socket problem.

No, I am not trying to spawn ftpd's faster than the system is able to :-)

Any suggestions?
...Magda

-----Original Message-----
From: Chad Price [mailto:[email-masked]]
Sent: Thursday, April 29, 1999 9:26 AM
To: [email-masked]
Cc: [email-masked]'; [email-masked]
Subject: RE: 425 Can't create data socket (142.148.10.35,20): Address

At 09:01 AM 4/29/1999 -0400, you wrote:
>Hi Johan,
>Our wu-ftpd is configured to run via inetd (inetd.conf).
> 
>I have already checked inetd.conf, search for ftp and found only one ftp
>service running:
>ftp     stream  tcp     nowait  root    /usr/local/etc/wuftpd   wutftpd
-ald
>
>This happens for all users not only for anonymous.  We have more then 100
>users constantly ftp to our system and 

Do follow Johan's advise and use 'ps -ef|grep ftp' to see just how many ftp
daemons are running.  Look at your system load.....

>they getting this error message only
>when the volume of ftp logon's is high. 

NOW you tell us.... Look at your system load.  Are you trying to spawn
ftpd's faster than the system is able to?  Do you need to alter the system
boot parameters in /etc/system to allow more processes? Are you filling up
your process table?  Up-ing the max users will allow more processes to run. 

* set:
*
*       Set an integer variable in the kernel or a module to a new value.
*       This facility should be used with caution.  See system(4).
*
*       Examples:
*
*       To set variables in 'unix':
*
*               set nautopush=32
*               set maxusers=40

set maxusers=72

Chad Price
Systems Manager
University of Nebraska Medical Center
600 S 42nd St
Omaha, NE 68506-6495
[email-masked]
(402) 559-9527 
(402) 559-4077 (FAX)

---

From: "Callaway, John" <[email-masked]>
Date: Fri, 30 Apr 1999 08:31:42 -0400

Opps.  Sorry -- didn't quite think that one through.  Had a similar type of
problem when I upgraded a machine for the web because the upgrade installed
a webserver and inserted it into the startup script without telling anyone.
So when I installed my webserver, I got the above error.

Brain cramp...never mind

-----Original Message-----
From: Magdalena Hewryk [mailto:[email-masked]]
Sent: Thursday, April 29, 1999 9:05 AM
To: [email-masked]'; [email-masked]
Subject: RE: 425 Can't create data socket (142.148.10.35,20): Address

John:

    

Any hints? ....Magda

-----Original Message-----
From: Magdalena Hewryk [mailto:[email-masked]]
Sent: Wednesday, April 28, 1999 4:10 PM
To: [email-masked]
Subject: 425 Can't create data socket (142.148.10.35,20): Address

Hello,

Any hints, help?
...Magda

Magdalena Hewryk
FundSERV Inc.
416 362-2400 ext. 237