Subject: Re: your mail

From: "bwoods" <[email-masked]>
Date: Fri, 9 Apr 1999 00:24:25 +0100

I have being trying to set up a guest ftp account for a user to be able to
drop files into a directory on a linux machine.

When I ftp to the machine I get the directory specified as root( chroot'ed
into it ).

But I get no list of the files in the ( remote ) directory. 
I have placed ls in a bin directory in this 'root' directory.

I have done an ldd of ls and copied the files shown from /lib 
into a lib  directory in this 'root' directory.

Anu ideas as to what I am doing wrong ( or omitting )

Brian Woods

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 8 Apr 1999 19:42:04 -0400 (EDT)

On Fri, 9 Apr 1999, bwoods wrote:

> I have being trying to set up a guest ftp account for a user to be
> able to drop files into a directory on a linux machine.
> 
> When I ftp to the machine I get the directory specified as root(
> chroot'ed into it ).
> 
> But I get no list of the files in the ( remote ) directory.  I have
> placed ls in a bin directory in this 'root' directory.
> 
> I have done an ldd of ls and copied the files shown from /lib into a
> lib directory in this 'root' directory.
> 

Punt.  There's statically linked precompiled support binaries in my FTP
site: ftp://ftp.vr.net/pub/wu-ftpd/binaries/intel/linux/

The example site is a working Linux site since, with static binaries,
Linux is also a minimum installation.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195