Subject: Some news of BeroFTP author and its mailing list ?

From: Gildas PERROT <[email-masked]>
Date: Thu, 29 Apr 1999 08:54:45 +0200

Hi,

I am still trying to contact them with [email-masked] and 
[email-masked] without answers.

BeroFTP (ftp://ftp.bero.x5.net/pub/) is a great replacement of Wu-FTP but I 
have the following problems :

1) I would to limit the scale of passive data ports with the directive :

passive ports 193.149.97.0/24 60000 80000

I try to connect from 193.149.97.10 and I have :
Passive mode refused.

and in the logs :

Apr 15 16:55:57 antonomase ftpd[27197]: command: PASV
Apr 15 16:55:57 antonomase ftpd[27197]: PASV
Apr 15 16:55:57 antonomase ftpd[27197]: <--- 425 Can't open passive 
connection: Resource temporarily unavailable.

2) Furthermore, how can I limit the ports for all IPs ? Is it 0.0.0.0/0  for 
all IPs ? If I put :

passive ports 0.0.0.0/0 60000 80000

the directive doesn't seem to be valid since allocated data ports in passive 
mode are still not between 60000 adn 80000. Any idea about that problem ?

3) I would like to set different FTP file access permissions for several 
groups
on directories.

Suppose I have 2 directories dir1 and dir2 and I want to create :

- group1 who has W access to dir1 and dir2
- group2 who has W access to dir1 only
- group3 who has R access to dir1 and dir2
- group4 who has R access to dir1 only
- group5 who has R&W access to dir1 and dir2
- group6 who has R&W access to dir1 only

Is it possible to implement that with BeroFTP or do I need another package ?

Thanks in advance.			Gildas.
-- 
Gildas PERROT, [email-masked]         __o
FranceNet, 28 rue Desaix, 75015 Paris ---_ \<,_
http://www.francenet.fr            ---- (_)/ (_)

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 29 Apr 1999 10:03:34 -0400 (EDT)

On Thu, 29 Apr 1999, Gildas PERROT wrote:

> I am still trying to contact them with [email-masked]
> and [email-masked] without answers.

Maybe he should change the domain name to 'German.ISPs.suck.eu.org'?  He's
there but his ISP is so badly managed you cannot find him.

> 1) I would to limit the scale of passive data ports with the directive
> 

> mode are still not between 60000 adn 80000. Any idea about that problem ?

This won't work.  Port numbers MUST be in the range 1 to 65534
(inclusive) or you're not talking TCP/IP.

> 3) I would like to set different FTP file access permissions for
> several groups on directories.
> 

No, BeroFTPD won't do it.  No, another package won't help.  What you need
is a book on Unix.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195