Subject: guest logins annot do "ls"

From: Lawrence Fan <[email-masked]>
Date: Wed, 03 Mar 1999 19:16:12 -0500

I've setup a guest login named "motorola".  Its /etc/passwd entry
is as follows:
motorola:x:10000:20000:Motorola ftp
access:/extra1/ftpguest/./motorola:/bin/bash

It belongs to the ftpguest group and ftpguest is setup as a guest group.

The following line is in the /etc/group file:
ftpguest:x:20000:

The /etc/ftpaccess file is as follows:
-------------------------------------------------
# cat /etc/ftpaccess
class   all   real,guest,anonymous  *

email root@localhost

loginfails 5

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             all
tar             yes             all
chmod           no              guest,anonymous
delete          no              guest,anonymous
overwrite       no              guest,anonymous
rename          no              guest,anonymous

log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

passwd-check rfc822 warn

guestgroup ftpguest
-------------------------------------------------

The login "motorola" has no problem logging in and get or put
files but it cannot list the directory:

$ ftp ftpsrv
Connected to ftpsrv.viagate.com.
220 ftpsrv.viagate.com FTP server (Version wu-2.4.2-academ[BETA-18](1)
Mon Jan 18 22:33:28 EST 1999) ready.
Name (ftpsrv:lawf): motorola
331 Password required for motorola.
Password:
230 User motorola logged in.  Access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pwd
257 "/motorola" is current directory.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> put hello
local: hello remote: hello
200 PORT command successful.
150 Opening BINARY mode data connection for hello.
226 Transfer complete.
18 bytes sent in 0 secs (0.018 Kbytes/sec)
ftp> put foo
local: foo remote: foo
200 PORT command successful.
150 Opening BINARY mode data connection for foo.
226 Transfer complete.
92 bytes sent in 0 secs (0.09 Kbytes/sec)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> get hello
local: hello remote: hello
200 PORT command successful.
150 Opening BINARY mode data connection for hello (18 bytes).
226 Transfer complete.
18 bytes received in 0 secs (0.018 Kbytes/sec)
ftp> get foo
local: foo remote: foo
200 PORT command successful.
150 Opening BINARY mode data connection for foo (92 bytes).
226 Transfer complete.
92 bytes received in 0 secs (0.09 Kbytes/sec)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> quit
221 Goodbye.

Please help me get my directory listing back.  Thanks a million.

-------------------------------------------------------------------------
Lawrence Fan                                   Phone: (908)595-6400
x3978
ViaGate Technologies                             Fax:      
(908)595-6410
757 Route 202/206, Bridgewater, NJ 08807      E-mail:   
[email-masked]

---

From: James McMahon <[email-masked]>
Date: Thu, 04 Mar 1999 11:32:40 +1100

Assuming that you are running wu-ftpd Beta 18 VR15 ....

With motorola being a guest, it is automatically chrooted to the users home
directory.  At a rough guess you haven't correctly set up a chroot
environment, including a working version of ls and any library files
required, and hence /bin/ls is not able to list any files.

I believe there are entries in the FAQ on how to set up a chroot environment
if you need help with this.

Hope this helps,

James McMahon
[email-masked]

Disclaimer:  This is the first time I have posted advice to this list, so if
I managed to stuff it up, please be nice to me.