Subject: 425 Couldn't open data connection. w/VR14

From: "Robertson, Rocke" <[email-masked]>
Date: Tue, 02 Mar 1999 10:51:03 -0500

I have installed beta18VR14. And now one client out of many gets this
when he connects from behind a Borderware firewall.I have gone over the
FAQ, and archives and seen all sorts of mention of this. In this scenario
its just one client. I believe the firewall does address translation.

Symptoms: User connects using ws_ftp, can download 1 or 2 files.... then
on 2nd or 3rd operation of some kind, he gets the 425 error.

Has anyone configured a Borderware firewall to work with the new version
of wu-ftpd with pasv connections?

Thanks

> 227 Entering Passive Mode (198,103,98,192,121,18)
> connecting to 198.103.98.192:30994
> - -
> connecting to 198.103.98.192:30994
> Connected to 198.103.98.192 port 30994
> STOR nta-srch.fr
> 425 Couldn't open data connection
> ! Receive error: Blocking call cancelled
>
> PWD
> 425 Can't open data connection.
> TYPE A
> 257 "/u1/sites/internet/cta/htdocs/eng" is current directory.
> PASV
> 200 Type set to A.
> ! Unable to parse info 200 Type set to A.
> PORT 10,10,4,20,4,143
> 425 Couldn't open data connection
> ! Failed "port":
> ! Retrieve of directory listing failed (0)
>
> ______________________________________________________
> Get Your Private, Free Email at http://www.hotmail.com

--
Rocke Robertson
PWGSC/GTIS
(613)991-2604
[email-masked]

---

From: John-Paul Pagano <[email-masked]>
Date: Tue, 02 Mar 1999 11:54:22 -0500

>of wu-ftpd with pasv connections?

Out of curiosity, I wonder whether or not there is some sort of encryption
taking place somewhere along the line.  I know that SOCKS 4 had a lot of
problems with its rftp client, which, strangely, is a little documented,
but really annoying bug...

--
John-Paul Pagano
Unix Systems Administrator
Voice: (212) 208-0828
Fax: (212) 825-1040

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 2 Mar 1999 15:28:18 -0500 (EST)

On Tue, 2 Mar 1999, Robertson, Rocke wrote:

> when he connects from behind a Borderware firewall.I have gone over
> the FAQ, and archives and seen all sorts of mention of this. In this
> scenario its just one client. I believe the firewall does address
> translation.
> 
> Symptoms: User connects using ws_ftp, can download 1 or 2 files....
> then on 2nd or 3rd operation of some kind, he gets the 425 error.
> 
> Has anyone configured a Borderware firewall to work with the new
> version of wu-ftpd with pasv connections?
> 
> Thanks
> 

Looks liek the client may be getting confused.  Turn on command logging so
your system logshow the sequence of commands and responses.  If that
doesn't show the cause, try testing with telnet using the same commands.
Help testing with telnet is at
  ftp://ftp.vr.net/pub/wu-ftpd/telnet.testing.HOWTO

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195