Subject: Re: Problem w/ Solaris /var/adm/wtmpx and /usr/bin/last(1) (fwd)

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 8 Mar 1999 22:29:51 -0500 (EST)

Can someone do some regression testing on Solaris?

---------- Forwarded message ----------
Date: Mon, 8 Mar 1999 22:26:58 -0500 (EST)
From: Gregory A Lundberg <[email-masked]>
To: Scott Parmenter <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: Problem w/ Solaris /var/adm/wtmpx and /usr/bin/last(1)

On Mon, 8 Mar 1999, Scott Parmenter wrote:

> > Before I file a bug report I'd like to verify these results with others.
> 
> Hadn't looked before now, but it looks like I get the same thing under
> TSOL 2.5.1. In fact, a quick Netscape connection didn't get recorded
> at all.  The account that was at the top of the list who had logged
> out previous to the Netscape test was still marked as logged in
> afterwards.  Does this have something to do with the duration of the
> connections?

Changes were made to logwtmp.c in the following versions:

(before beta-12, I don't know)

beta-12 changes for SCO
beta-13 backed out SCO from beta-12, changes for FreeBSD
beta-16 name changed internally to wu_logwtmp
beta-18 added logged-in status
beta-18-vr10 changed from specific system test to NO_UTMPX

If this was working before, I'm thinking the change in Beta-18 broke it.

That or the switch to always use the local version of the function in
Beta-16 did.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 8 Mar 1999 22:47:03 -0500 (EST)

> beta-18-vr10 changed from specific system test to NO_UTMPX

Actually, I can see that the utmpx stuff was added after 2.4 and before or
with beta-11.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Bob Luckin <[email-masked]>
Date: Tue, 9 Mar 99 11:12:57 CST

All,

> Actually, I can see that the utmpx stuff was added after 2.4 and before or

The best I can do is confirm that the problem definitely happens running
beta-16 on a Solaris 2.5.1 system which is not trusted Solaris...

As far as wtmp is concerned, every new ftp login automatically closes the
previous one if it was still logged in.  The actual session is not really
logged out of course, and the user sees no problem.

The behaviour does not apear to be related to the userid - I tried with both
my own userid and the anonymous one, with the same effect.

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "Coder adapt.  FTP Ada, redo C"
                                 [http://www.dhc.net/~luckin/palindromes.html"