Subject: Problems in ftpaccess file

From: [email-masked]
Date: Mon, 1 Mar 1999 17:09:33 +0100

Hi everybody,

		I have a problem with my ftpaccess file: I get this error on 
syslog:
		>ftpd[10066]: Too many args (>49) in ftpaccess: class  
users guest,anonymous C-CLASS1 C-CLASS2 ....

		This is because I have restricted my ftp to a C-Class list, 
and this list is up to 49 IP classes.
		How can I setup the ftpaccess file to make this possible?

		Or ... maybe I have to modify a parameter and compile wu-
ftp again?
	
		Thanx a lot!

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 1 Mar 1999 11:22:32 -0500 (EST)

On Mon, 1 Mar 1999 [email-masked] wrote:

> I have a problem with my ftpaccess file: I get this error on syslog:
>  ftpd[10066]: Too many args (>49) in ftpaccess: class users guest,anonymous C-CLASS1 C-CLASS2 ....
> 
> This is because I have restricted my ftp to a C-Class list, and this
> list is up to 49 IP classes. How can I setup the ftpaccess file to
> make this possible?

Multiple class clauses naming the same class with different address blocks
should do it.

> Or ... maybe I have to modify a parameter and compile wu- ftp again?

If not, change MAXARGS in src/extensions.h and be sure to test thoroughly.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195