Subject: VR version

From: Jan Simek <[email-masked]>
Date: Wed, 24 Mar 1999 13:57:09 -0500 (EST)

Hi,

how can I determine what VR series (beta 18, 2.4.2) do I have?

Thanks,

--Jan

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 24 Mar 1999 14:14:31 -0500 (EST)

> how can I determine what VR series (beta 18, 2.4.2) do I have?

I'll use telnet.  An ftp client works fine but you may need to 'quote
stat' instead of 'stat'.

$ telnet localhost ftp
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 ftp.vr.net FTP server ready.

On most systems, the version will appear above.  VR versions can suppress
this, so we need to look deeper.

user ftp
331 Guest login ok, send your complete e-mail address as password.
pass ftp@
230 Guest login ok, access restrictions apply.
stat
211-ftp.vr.net FTP server status:
     Version wu-2.4.2-VR17(1) Wed Mar 10 15:10:40 EST 1999

On all versions, the version and date/time of compile appears in the STAT
response.  ( The number in parenthesis, '(1)' above, is meaningless. )

     Connected to localhost (127.0.0.1)
     Logged in anonymously
     TYPE: ASCII, FORM: Nonprint; STRUcture: File; transfer MODE: Stream
     No data connection
     0 data bytes received in 0 files
     0 data bytes transmitted in 0 files
     0 data bytes total in 0 files
     28 traffic bytes received in 0 transfers
     551 traffic bytes transmitted in 0 transfers
     628 traffic bytes total in 0 transfers
211 End of status
quit
221-You have transferred 0 bytes in 0 files.
221-Total traffic for this session was 738 bytes in 0 transfers.
221-Thank you for using the FTP service on ftp.vr.net.
221 Goodbye.
Connection closed by foreign host.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ted Keller <[email-masked]>
Date: Wed, 24 Mar 1999 14:23:13 -0500 (EST)

Jan,

Simply telnet to your ftp host on port 21

>telnet ftp.xxx.com 21

it will respond with a banner which should indicate both the vendor and
version.

ted keller