Subject: AIX compiling problems (vr16)

From: Alexandre Almeida Wanderley <[email-masked]>
Date: Wed, 24 Mar 1999 17:04:22 -0300

Hi, all

	I'm trying to build (using gcc-2.8.1) vr16 on our AIX (4.x) station. 
Everything builds (almost) ok: ftpcount, ftpshut, ftpwho, ckconfig. Except 
the ftpd... See what i'm getting from gcc:

        gcc -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o authenticate.o conversions.o hostacc.o  sigfix.o routevector.o restrict.o  -lsupport -ls
collect2: ld returned 8 exit status
ld: 0711-317 ERROR: Undefined symbol: .snprintf
ld: 0711-317 ERROR: Undefined symbol: .vsnprintf
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make: The error code from the last command is 1.

	Did any body get the same error? How could I fix it...?
	
NOTE: vr14 was built fine...
	
	Thanks the attention,

	Alexandre Almeida

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 24 Mar 1999 15:19:08 -0500 (EST)

> ld: 0711-317 ERROR: Undefined symbol: .vsnprintf

Dunno when/if I chnaged this, but looking in
support/makefiles/Makefile.aix, I see:

# Pre-AIX 4.2 may need this instead
# SRCS   = getusershell.c fnmatch.c strcasestr.c strsep.c \
#                  authuser.c strdup.c snprintf.c
# OBJS   = getusershell.o fnmatch.o strcasestr.o strsep.o \
#                  authuser.o strdup.o snprintf.o
SRCS   = getusershell.c fnmatch.c strcasestr.c strsep.c \
                 authuser.c
OBJS   = getusershell.o fnmatch.o strcasestr.o strsep.o \
                 authuser.o

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195