Subject: Re: Problem getting numeric username/groups w/ ls

From: Greg Bulman - EST Contractor <[email-masked]>
Date: Tue, 9 Mar 1999 11:07:01 -0800

I've always thought it meant ENOENT
                             ||
                         Error \
                                NoEntity
                                 
In my uses of truss this as always held true and seems to here.  The
file wasn't found (didn't exist), I made it exist and life was good again.
                                 
>From the man intro(2) ...
     2 ENOENT  No such file or directory
 
          A file name is specified and the file should exist
          but  doesn't,  or one of the directories in a path
          name does not exist.
          
-gbulman
           
> On Mon, 8 Mar 1999, Greg Bulman - EST Contractor wrote:
> 
> > One of those, Uh, Oh Yeah, Duh steps.   I had done the first step ...
> >    chroot ~ftp /bin/ls -l /etc
> > which showed me the same bad results.  Taking it a step further (the duh 
step)
> >    truss chroot ~ftp /bin/ls -l /etc
> > quickly gave me the missing library ...
> >    open("/usr/lib/libmp.so.1", O_RDONLY)           Err#2 ENOENT
> > 
> 
> Interesting.  I am confused, because I thought that Err#2 ENOENT was an 
innocuous notification that the process in
> question was simply trying to write to a pseudo-device, rather than a physical 
device.  I didn't think that the
> ENOENT message meant anything was actually wrong.  
> 
> Perhaps this message serendipitously led you to the missing library file, but 
really didn't reflect a problem?

---

From: John-Paul Pagano <[email-masked]>
Date: Tue, 9 Mar 1999 14:18:32 -0500 (EST)

Okay.  You definitely seem right.  I just remember reading a lot of stuff about ENOENT coming up when a process
tries to write to a pseudo device, which, in a sense, is a missing physical device file...

A stretch, yes, but possibly true.