Subject: Permissions for USER and ANONYMOUS ftp

From: "Durham, Kenneth J" <[email-masked]>
Date: Wed, 31 Mar 1999 13:00:20 -0800

I have just got my anonymous ftp and my user ftp working great.  One thing
though my anonymous users can get into my users folders an view everything
within them.  the way i have it setup is

/ftp            the root ftp folder

/ftp/usr       the users ftp folder

what permisions do i have to set to make it so that the anons cant get into
the user folder but the users can still access there folders.?  can someone
please help thank you.

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 31 Mar 1999 16:29:12 -0500 (EST)

On Wed, 31 Mar 1999, Durham, Kenneth J wrote:

> I have just got my anonymous ftp and my user ftp working great.  One
> thing though my anonymous users can get into my users folders an view
> everything within them.  the way i have it setup is
> 
> /ftp the root ftp folder
> 
> what permisions do i have to set to make it so that the anons cant get
> into the user folder but the users can still access there folders.?  
> can someone please help thank you.

1) The user 'ftp' cannot own, or belong to the group owning, /ftp/usr

2) Revoke world permissions on /ftp/usr
     chmod o-r /ftp/usr --> Anonymous cannot list the directory
     chmod o-w /ftp/usr --> Anonymous cannot create files/dirs there
     chmod o-x /ftp/usr --> Anonymous cannot access files/dirs there

3) Reconsider your entire security model: why are real/guest users even in
   the same pew as anonymous users?  (You don't need to justify it to me,
   just yourself.)

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195