Subject: Re: Strange filenames...

From: [email-masked] (Ian Willis)
Date: Wed, 3 Mar 99 20:24:35 GMT

Any system that supports X/Open Regular Expressions should allow the
[:space:] character class expression to be used instead of a space
in the path-filter line.

If your system does support character class expressions then this test
should produce output:
echo "File name1-._z" | grep "^[[:alnum:][:space:]._-]*$"

Ian Willis
SCO Internet Engineering Group, Watford, England

| From: Gregory A Lundberg <[email-masked]>
| Date: Wed, 3 Mar 1999 09:43:33 -0500 (EST)
| To: Richard Allen <[email-masked]>
| Cc: [email-masked]
| Subject: Re: Strange filenames...
| 
| On Wed, 3 Mar 1999, Richard Allen wrote:
| 
| > Is there any way to get wu-ftpd (beta 18) to allow spaces and other
| > wierd characters Crappy M$ OS-lookalikes allow in filenames during an
| > upload ?
| > 
| > Currently uploading "My presentation.ppt" gives a permission denyed
| > error.
| > 
| > When explaining to users that some characters shouldnt be used in
| > filenames I often get "Ahh..  you're running Unix" in a sympothetic
| > voice :)
| 
| Long filenames shouldn't be a problem.
| 
| Spaces in filenames, however, are not allowed by the pathfilter in most
| ftpaccess files.  The daemon's syntax for pathfilter makes it impossible
| to specify spaces on the line.
| 
| There's a workarround in the VR version which will work if you're running
| Linux.
| 
| Non-Linux systems should be able to get it to work if they install the GNU
| regex package.  If you get it working on a non-Linux system, I'd be
| interested in instructions/patches to share your results with others.
| 
| -- 
| 
| Gregory A Lundberg              Senior Partner, VRnet Company
| 1441 Elmdale Drive              [email-masked]
| Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: [email-masked] (Ian Willis)
Date: Thu, 4 Mar 99 19:20:05 GMT

You probably want to use the blank character class rather than
the space character class, in the POSIX locale the blank class
only includes the space and tab characters but the space class
also includes the form feed, newline, carriage return and
vertical tab characters.

Ian