Subject: newest version of wu-ftpd for AIX 4.3.2?

From: [email-masked]
Date: Tue, 30 Mar 1999 15:28:27 -0500

Hello,

I'm trying to run the most recent version of wu-ftpd (or at least more recent
than beta 15, since according to the security folks at my site this has a hole)
on AIX 4.3.2.  When I compile and run beta 18, I get the following error when I
try to get a file in binary mode:

ftp> get bos.compat.usr.4.3.1.
0200 PORT command successful.
150 Opening BINARY mode data connection for bos.compat.usr.4.3.1.0 (0 bytes).
451 Local resource failure: malloc: Error 536880640 occurred..
ftp>

I looked this up in the archives and there is a post where the user simply went
to beta 16 and it worked.  Does anyone know how this is fixed on beta 18, and if
not, where I can get the beta 16 distribution/source?

Thanks for any help.

Matt Newton
IBM Global Services
Center for Scalable Computing Solutions
T.J. Watson Research Center

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 30 Mar 1999 16:00:30 -0500 (EST)

On Tue, 30 Mar 1999 [email-masked] wrote:

> I'm trying to run the most recent version of wu-ftpd (or at least more
> recent than beta 15, since according to the security folks at my site
> this has a hole) on AIX 4.3.2.

The security holes you were told about were NOT fixed by beta-18.  I have
no idea how the AIX problem was fixed, btw.

To review the security information yourself, read

  CERT Advisory CA-99.03 - FTP-Buffer-Overflows
  http://www.cert.org/advisories/CA-99-03-FTP-Buffer-Overflows.html

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.vr.net/pub/wu-ftpd/
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195