Subject: Followed ls and dir advice, but still problem in beta18vr14

From: Michael Schmidt <[email-masked]>
Date: Wed, 3 Mar 1999 14:35:45 +0100 (MET)

Hi,

we are running an HPUX-10.20 machine.

Yes I have looked into the FAQ 
and placed ls in ~ftp/bin and regarding stuff in ~ftp/usr
and undefined HPUX_10_TRUSTED in config.hpx.

In the past we have been running beta15,
today I upgraded to beta18vr14 and installed it and 
did let the rest of structure of ~ftp and the ftpd stuff 
directory the same as before,

But now ftp clients doing a ls and dir get the error message
"421 Service not available, remote server has closed connection"

What's wrong there?
Or which point am I missing?

If possible I need urgent help this afternoon German time.

Thanks in advance
Michael

-- 
                 Michael  Schmidt
              [email-masked]
Mirror of:                              SAMBA:
IPFilter, Ghostscript                   Server for Win95,
Linux-HOWTO                             WinNT, LANManager

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 3 Mar 1999 09:46:30 -0500 (EST)

On Wed, 3 Mar 1999, Michael Schmidt wrote:

> In the past we have been running beta15, today I upgraded to
> beta18vr14 and installed it and did let the rest of structure of ~ftp
> and the ftpd stuff directory the same as before,
> 

Try VR15.  It should have this fixed.  It's an endian/sizeof problem and
not related to ls/dir.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Michael Schmidt <[email-masked]>
Date: Thu, 4 Mar 1999 08:59:13 +0100 (MET)

> From: Gregory A Lundberg <[email-masked]>
> Subject: Re: Followed ls and dir advice, but still problem in beta18vr14
> 

Done that, but the same error still occured!

What's wrong?
Any solution?

Desperated
  Michael

---

From: Michael Schmidt <[email-masked]>
Date: Thu, 4 Mar 1999 11:21:50 +0100 (MET)

> From: Michael Schmidt <[email-masked]>

Just for completeness, 
tried VR16 too, and the same error is still there!
Any solution available?

What about any other HPUX wu-ftpd users out there, 
which effect do you see, how do you run wu-ftpd VR14 or VR15 or VR16?

More desperated
  Michael

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 4 Mar 1999 07:29:07 -0500 (EST)

On Thu, 4 Mar 1999, Michael Schmidt wrote:

> Just for completeness, tried VR16 too, and the same error is still
> there!

I'd be amazed if it had.  What few changes Stan made were had little
effect except for dec and sco builds.

> What about any other HPUX wu-ftpd users out there, which effect do you
> see, how do you run wu-ftpd VR14 or VR15 or VR16?

There were two testers for HP/UX-10.20 on VR15.  The only problem they
reported that was not merged in was a correction to the makefiles so it'd
even compile.  Somehow I lost that patch and it'll be in VR17.  Since
you're compiled, I doubt it'll help (if you're not already using it).

If you look in your system logs, you should see the daemon is dying.
Let's drop off-list and do a little testing.

--

---

From: Michael Schmidt <[email-masked]>
Date: Thu, 4 Mar 1999 13:52:26 +0100 (MET)

> you're compiled, I doubt it'll help (if you're not already using it).

Curious about that as compilation here has been no problem.
Which compilers did the two testers you mentioned use?

I am using GNU gcc here on HPUX and compilation itself went fine.
May be the problem I reported here under the above subject is 
related to GNU gcc.  Does it have to do with gcc? Any idea?

I have no other full C compiler available here.

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 4 Mar 1999 09:11:08 -0500 (EST)

> I have no other full C compiler available here.

GCC should be good.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

-- 

Subject: Re: Build problem on VR15 for HP-UX (resend)

> If these are needed in the general case for HP/UX, send over some
> diffs so I can make the correction for VR16.

here's My old mail ca. 2/17/99 with patches

-- 

Subject: Makefile.hpx patches for 10.20 beta-18-VR15 prerelease

I'd recommend making at least the change below to the Makefiles for HP/UX.

I think this is pretty close to the minimal changes needed to make it
compile under HP/UX 10.20.

You might also consider removing the use of "+DAportable": that may be of
use for building binary releases but doesn't do much for the average user.

More comments below.

this is a diff -c against your beta-18-VR15 prerelease

for src/makefiles
- - cut here - -
*** Makefile.hpx.dist Sat Oct 31 09:58:15 1998
--- Makefile.hpx Wed Feb 17 15:53:26 1999
***************
*** 5,11 ****
  CC       = cc
  IFLAGS   = -I.. -I../support
  LFLAGS   = +DAportable
! CFLAGS   = -Aa -Dunix -D_HPUX_SOURCE -O +Onolimit ${IFLAGS} ${LFLAGS}
  XOBJS    =
  LIBES    = ../support/libsupport.a -lsec
  LIBC     = /lib/libc.a
--- 5,11 ----
  CC       = cc
  IFLAGS   = -I.. -I../support
  LFLAGS   = +DAportable
! CFLAGS   = -Ae -Dunix -O +Onolimit ${IFLAGS} ${LFLAGS}
  XOBJS    =
  LIBES    = ../support/libsupport.a -lsec
  LIBC     = /lib/libc.a
- - cut here - -

for support/makefiles
- - cut here - -
*** Makefile.hpx.dist	Sat Oct 31 09:58:16 1998
--- Makefile.hpx	Wed Feb 17 15:55:42 1999
***************
*** 3,15 ****
  #
  # $Id: Makefile.hpx,v 1.7 1998/07/06 08:55:07 sob BETA-18 $
  #
! CC     = cc -Aa -D_POSIX_SOURCE
  AR     = ar cq
  RANLIB = touch
  LIBC   = /lib/libc.a
  IFLAGS =
  LFLAGS =
! CFLAGS = -O ${IFLAGS} ${LFLAGS}
  INCDIR = /opt/wu_ftpd/include/arpa

  SRCS   = authuser.c fnmatch.c strcasestr.c strsep.c getusershell.c snprintf.c
--- 3,15 ----
  #
  # $Id: Makefile.hpx,v 1.7 1998/07/06 08:55:07 sob BETA-18 $
  #
! CC     = cc
  AR     = ar cq
  RANLIB = touch
  LIBC   = /lib/libc.a
  IFLAGS =
  LFLAGS =
! CFLAGS = -Ae -O ${IFLAGS} ${LFLAGS}
  INCDIR = /opt/wu_ftpd/include/arpa

  SRCS   = authuser.c fnmatch.c strcasestr.c strsep.c getusershell.c snprintf.c
- - cut here - -

When I just did a build "out of the box" I got the errors below:
= =
[1]  + Done                   ./build hpx >& build.hpx.out.1
pubweb 60#
pubweb 60# more build.hpx.out.1
make args are :
make opts are :

Copying Makefiles.

Linking src/config.h

Making support library.
        cc -Aa -D_POSIX_SOURCE -O   -c authuser.c
cc: "authuser.c", line 95: error 1574: Unknown size for "sa".

[snip .. lots of compile errors]