Subject: FTP User problem

From: "Durham, Kenneth J" <[email-masked]>
Date: Sun, 28 Mar 1999 11:04:14 -0800

Im trying to get my ftp to alow anonymous as well as users to logon.  The
anonymous works great but Im still having a bit of a problem with my user
account logon.  I have followed the FAQ as closely as possible but still
nothing. I also folowed the one at
http://www.landfield.com/wu-ftpd/guest-howto.html#example
<http://www.landfield.com/wu-ftpd/guest-howto.html#example >   . The user
can logon just fine but is not chroot'ed to the dir that I specified.  This
is the setup that I have.  If someone can see anything that I can change for
security reasons or anything else please let me know.
/ftp                              ftp dir for anonymous
/ftp/bin
/ftp/etc
/ftp/incoming                for incoming files
/ftp/pub    
/ftp/lib                          all lib files for ls
/ftp/usr/username          ftp dir users
 
what I want to be able to do is to have each user have there own dir in
/ftp/usr and i want them not to be able to leave there home dir.
/etc/passwd looks like this
 
test:password here:500:503::/ftp/usr/./test:/bin/ftponly
ftponly is the script that i got from the directions on the page.
/etc/group
 
ftpguest:*:92:
this is what i read from the mailing list
/etc/ftpaccess 
email root@localhost
 
loginfails 5
 
readme  README*    login
readme  README*    cwd=*
 
message /welcome.msg            login
message .message                cwd=*
 
compress        yes             all
tar             yes             all
chmod           no              guest,anonymous
delete          no              guest,anonymous
overwrite       no              guest,anonymous
rename          no              guest,anonymous
log transfers anonymous,real inbound,outbound
 
guestgroup ftpguest
shutdown /etc/shutmsg
 
passwd-check rfc822 warn
 
i got this also from the mailing list.  I cant think of anything else that
could be causing the problem.  Can someone please help.  thank you for yoiur
help

---

From: Gregory A Lundberg <[email-masked]>
Date: Sun, 28 Mar 1999 14:53:28 -0500 (EST)

> ftpguest:*:92:

ftpguest:*:92:test

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195