Subject: Loopback Mounts???

From: "Barton Hodges" <[email-masked]>
Date: Mon, 1 Mar 1999 14:07:58 -0600

Hello,
	I found the following the FAQ, and it is essentially what I want to do.  I
have many files
on a drive that I would like to be available from my chrooted FTP directory
without copying them
over.  I realize that a symbolic link does not work, can anyone explain how
I can setup a
loopback mount?  I am using RedHat Linux 5.1.

Thanks.

Barton

> I made a symbolic link within the anonymous tree and it doesn't work for
the anonymous users.

> Symbolic links are relative to your active root. If you want to access
files/directories/diskspace outside your chrooted
> environment, you'll have to import it using loopback mounts. These are
available on at least Solaris and Linux.

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 1 Mar 1999 15:58:38 -0500 (EST)

On Mon, 1 Mar 1999, Barton Hodges wrote:

> I found the following the FAQ, and it is essentially what I want to
> do.  I have many files on a drive that I would like to be available
> from my chrooted FTP directory without copying them over.  I realize
> that a symbolic link does not work, can anyone explain how I can setup
> a loopback mount?  I am using RedHat Linux 5.1.

man losetup

you may need to rebuild your kernel

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195