Subject: Opie Looks Broken in VR15

From: wuftpd <[email-masked]>
Date: Tue, 2 Mar 1999 06:55:29 -0500 (EST)

Hi there...

Anyone using OPIE on VR15?

I up to the point where I enter the response and then I get
bumped out. Anonymous works fine but any user using OPIE doesn't.
It does seem to be getting past the OPIE tho , because the
next time the seed is one less which one would expect
on a successful login.

Error messages spit out like lost connection, and I get

Mar  1 22:47:06 tyrex ftpd[32723]: exiting on signal 11
Mar  1 22:48:02 tyrex ftpd[32762]: exiting on signal 11
Mar  1 22:49:20 tyrex ftpd[40]: exiting on signal 11
Mar  1 22:51:20 tyrex ftpd[116]: exiting on signal 11
Mar  1 23:11:13 tyrex ftpd[1515]: exiting on signal 11
Mar  1 23:20:12 tyrex ftpd[2023]: exiting on signal 11
Mar  1 23:26:07 tyrex ftpd[2217]: exiting on signal 11
Mar  1 23:27:23 tyrex ftpd[2463]: exiting on signal 11

in the messages...(I gave up...Even tried it in daemon mode...Same
result.!)

I undefined OPIE in the config.h and rebuilt and it works like a champ.
I can login in just fine but I have to use the normal password and
not use OPIE...

I went back to a working copy of VR13 that does work with OPIE.

Any thoughts???

SystemInfo:
RedHat 5.2
Linux 2.0.36
Opie 2.32

Later
David

---

From: Alain ENOUT <[email-masked]>
Date: Thu, 04 Mar 1999 11:53:31 +0100 (CET)

> Anyone using OPIE on VR15?

Yes it works for me on linux 2.0.34, debian 2.0

> Mar  1 23:27:23 tyrex ftpd[2463]: exiting on signal 11

This is a segmentation fault, just try to get a core dump and then debug it
post mortem. You'll see where it crashes.

> I went back to a working copy of VR13 that does work with OPIE.

Did you try the precompiled version for linux ?

> David

---
Alain ENOUT                     Research Engineer, Mobile Communications Dpt
[email-masked]                                 Phone: +33 (0)4 93 00 26 65
EURECOM, 2229 rte des cretes, BP 193, F-06904 Sophia Antipolis Cedex, France