Subject: Re: Problem getting numeric username/groups w/ ls

From: Greg Bulman - EST Contractor <[email-masked]>
Date: Mon, 8 Mar 1999 18:51:02 -0800

One of those, Uh, Oh Yeah, Duh steps.   I had done the first step ...
   chroot ~ftp /bin/ls -l /etc
which showed me the same bad results.  Taking it a step further (the duh step)
   truss chroot ~ftp /bin/ls -l /etc
quickly gave me the missing library ...
   open("/usr/lib/libmp.so.1", O_RDONLY)           Err#2 ENOENT

Many thanks to Bob Luckin for his quick and correct reply.
I was missing libmp.so.1 in ~ftp/usr/lib.  I copied it over and ls -l
correctly  yields alpha usernames/groups.

Thanks in Advance to any other replies.  Help is always very welcome.
-gbulman

> From: Bob Luckin <[email-masked]>
> Subject: Re: Problem getting numeric username/groups w/ ls
> 
> Greg said :-
> > I'm running wu-ftpd 2.4.2, under Solaris 2.5.1.  We also have several
> > running instances of various wu-ftpd 2.4 - 2.4.2Beta15 running on
> > Solaris 2.5.1 behaving the same.  I've used the Solaris provided man
> > page in.ftpd script for setting up the ftp directory.
> > 
> > I cannot figure out how to get the username rather than the userid
> > (and groups too) when doing an "ftp> ls -l" (or a dir BTW).
> > 
> > I've read through the FAQ and nothing really seemed to point to the
> > problem.  I've triple checked my ~ftp/etc/passwd,group files and they
> > appear to be what's expected.
> > 
> > Any other pointers folks?
> 
> If you're not seeing the names which are in your ~ftp/etc/passwd, then my
> guess is that you're missing a library from ~ftp/usr/lib, which ls needs
> to map the id to the name in the file.
> 
> I had this problem a couple of years ago - unfortunately, I can't remember
> which library I had to copy over to fix the problem.  But you can try running
> chrooted under truss to see what shows up.  (libnsl.so comes to mind for
> some reason, but it could have been one of the others.)
> 
> Cheers, Bob
> -- 
> Bob Luckin      [email-masked]      "Coder, adapt.  FTP Ada, redo C"
>                                  [http://www.dhc.net/~luckin/palindromes.html]

---

From: John-Paul Pagano <[email-masked]>
Date: Tue, 9 Mar 1999 13:46:14 -0500 (EST)

>    open("/usr/lib/libmp.so.1", O_RDONLY)           Err#2 ENOENT

Interesting.  I am confused, because I thought that Err#2 ENOENT was an innocuous notification that the process in
question was simply trying to write to a pseudo-device, rather than a physical device.  I didn't think that the
ENOENT message meant anything was actually wrong.  

Perhaps this message serendipitously led you to the missing library file, but really didn't reflect a problem?