Subject: Problem compiling 2.4.2 Final on Linux

From: Patrick Shoaf <[email-masked]>
Date: Tue, 16 Mar 1999 12:50:04 -0500

I have RedHat 5.2 and the new 2.4.2 wu-ftpd source.  I am trying to compile
and I am getting errors, and am unsure as to what they mean.  Attached
below is the output from the command

./build lnx >file1 2>file2

*gcc-libs are installed from RedHat 5.2 rpm
*string.h is located at /usr/src/linux-2.0.36/include/string.h and at
/usr/src/linux-2.0.36/asm-i386/string.h

=========FILE1================
make args are : 
make opts are : 
Linking Makefiles.
Making support library. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -c strcasestr.c
Making ftpd. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -c ftpd.c -o ftpd.o
Making ftpcount. 
bison -y ftpcmd.y 
Making ftpshut. 
bison -y ftpcmd.y 
Making ckconfig. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -o ckconfig ckconfig.c
Links to executables are in bin directory:Done 

============FILE2===================
strcasestr.c:27: string.h: No such file or directory 
strcasestr.c: In function `strcasestr': 
strcasestr.c:42: syntax error before `len' 
strcasestr.c:45: `len' undeclared (first use this function) 
strcasestr.c:45: (Each undeclared identifier is reported only once 
strcasestr.c:45: for each function it appears in.) 
strcasestr.c:49: `NULL' undeclared (first use this function) 
make: *** [strcasestr.o] Error 1 
In file included from ftpd.c:42: 
config.h:5: features.h: No such file or directory 
In file included from
/usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/syslimits.h:7, 
from /usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/limits.h:11, 
from config.h:43, 
from ftpd.c:42: 
/usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/limits.h:112: limits.h:
No such file or directory 
In file included from ftpd.c:42: 
config.h:53: stdlib.h: No such file or directory 
config.h:54: unistd.h: No such file or directory 
ftpd.c:44: sys/types.h: No such file or directory 
ftpd.c:45: sys/param.h: No such file or directory 
ftpd.c:46: sys/stat.h: No such file or directory 
ftpd.c:47: sys/ioctl.h: No such file or directory 
ftpd.c:48: sys/socket.h: No such file or directory 
ftpd.c:49: sys/file.h: No such file or directory 
ftpd.c:50: sys/wait.h: No such file or directory 
ftpd.c:61: netinet/in.h: No such file or directory 
ftpd.c:62: netinet/in_systm.h: No such file or directory 
ftpd.c:63: netinet/ip.h: No such file or directory 
ftpd.c:67: arpa/inet.h: No such file or directory 
ftpd.c:68: arpa/telnet.h: No such file or directory 
ftpd.c:70: ctype.h: No such file or directory 
ftpd.c:71: stdio.h: No such file or directory 
ftpd.c:72: signal.h: No such file or directory 
ftpd.c:73: pwd.h: No such file or directory 
ftpd.c:74: setjmp.h: No such file or directory 
ftpd.c:75: netdb.h: No such file or directory 
ftpd.c:76: errno.h: No such file or directory 
ftpd.c:77: string.h: No such file or directory 
ftpd.c:106: syslog.h: No such file or directory 
ftpd.c:108: time.h: No such file or directory 
ftpd.c:124: fcntl.h: No such file or directory 
ftpd.c:147: dirent.h: No such file or directory 
ftpd.c:177: parse error before `*' 
ftpd.c:181: parse error before `*' 
ftpd.c:183: parse error before `FILE' 
ftpd.c:183: warning: data definition has no type or storage class 
ftpd.c:184: parse error before `*' 
ftpd.c:185: parse error before `*' 
ftpd.c:204: parse error before `restart_point' 
ftpd.c:204: warning: data definition has no type or storage class 
ftpd.c:215: `MAXPATHLEN' undeclared here (not in a function) 
ftpd.c:216: `MAXPATHLEN' undeclared here (not in a function) 
ftpd.c:220: parse error before `errcatch' 
ftpd.c:221: warning: data definition has no type or storage class 
ftpd.c:255: parse error before `file_size' 
ftpd.c:255: warning: data definition has no type or storage class 
ftpd.c:256: parse error before `byte_count' 
ftpd.c:256: warning: data definition has no type or storage class 
ftpd.c:262: parse error before `defumask' 
ftpd.c:262: warning: data definition has no type or storage class 
ftpd.c:290: `MAXPATHLEN' undeclared here (not in a function) 
ftpd.c:297: `NULL' undeclared here (not in a function) 
ftpd.c:318: parse error before `*' 
ftpd.c:319: parse error before `off_t' 
ftpd.c:319: warning: data definition has no type or storage class 
ftpd.c:336: parse error before `block_sigmask' 
ftpd.c:336: warning: data definition has no type or storage class 
ftpd.c:339: `BUFSIZ' undeclared here (not in a function) 
ftpd.c:362: parse error before `*' 
ftpd.c: In function `main': 
ftpd.c:399: storage size of `virtual_addr' isn't known 
ftpd.c:408: `LOG_PID' undeclared (first use this function) 
ftpd.c:408: (Each undeclared identifier is reported only once 
ftpd.c:408: for each function it appears in.) 
ftpd.c:408: `LOG_NDELAY' undeclared (first use this function) 
ftpd.c:408: `LOG_DAEMON' undeclared (first use this function) 
ftpd.c:424: sizeof applied to an incomplete type 
ftpd.c:426: `LOG_ERR' undeclared (first use this function) 
ftpd.c:431: sizeof applied to an incomplete type 
ftpd.c:444: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:444: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:516: `stderr' undeclared (first use this function) 
ftpd.c:731: warning: assignment makes pointer from integer without a cast 
ftpd.c:732: `NULL' undeclared (first use this function) 
ftpd.c:733: dereferencing pointer to incomplete type 
ftpd.c:747: dereferencing pointer to incomplete type 
ftpd.c:747: warning: passing arg 2 of `strcmp' makes pointer from integer
without a cast 
ftpd.c:749: `LOG_NOTICE' undeclared (first use this function) 
ftpd.c:750: dereferencing pointer to incomplete type 
ftpd.c:755: dereferencing pointer to incomplete type 
ftpd.c:756: sizeof applied to an incomplete type 
ftpd.c:756: `AF_INET' undeclared (first use this function) 
ftpd.c:756: warning: assignment makes pointer from integer without a cast 
ftpd.c:758: dereferencing pointer to incomplete type 
ftpd.c:778: `LOG_INFO' undeclared (first use this function) 
ftpd.c: In function `randomsig': 
ftpd.c:847: `LOG_ERR' undeclared (first use this function) 
ftpd.c:850: `SIGIOT' undeclared (first use this function) 
ftpd.c:850: `SIG_DFL' undeclared (first use this function) 
ftpd.c:851: `SIGILL' undeclared (first use this function) 
ftpd.c: In function `lostconn': 
ftpd.c:865: `LOG_DEBUG' undeclared (first use this function) 
ftpd.c: In function `sgetsave': 
ftpd.c:884: `NULL' undeclared (first use this function) 
ftpd.c: In function `sgetpwnam': 
ftpd.c:903: storage size of `save' isn't known 
ftpd.c:939: warning: assignment makes pointer from integer without a cast 
ftpd.c:939: `NULL' undeclared (first use this function) 
ftpd.c:949: dereferencing pointer to incomplete type 
ftpd.c:951: dereferencing pointer to incomplete type 
ftpd.c:961: dereferencing pointer to incomplete type 
ftpd.c:996: dereferencing pointer to incomplete type 
ftpd.c:997: dereferencing pointer to incomplete type 
ftpd.c:998: dereferencing pointer to incomplete type 
ftpd.c: In function `user': 
ftpd.c:1085: `LOG_NOTICE' undeclared (first use this function) 
ftpd.c:1108: `NULL' undeclared (first use this function) 
ftpd.c:1154: warning: assignment makes pointer from integer without a cast 
ftpd.c:1171: dereferencing pointer to incomplete type 
ftpd.c:1179: warning: assignment makes pointer from integer without a cast 
ftpd.c:1184: dereferencing pointer to incomplete type 
ftpd.c:1190: dereferencing pointer to incomplete type 
ftpd.c:1252: dereferencing pointer to incomplete type 
ftpd.c: In function `checkuser': 
ftpd.c:1338: syntax error before `*' 
ftpd.c:1340: `BUFSIZ' undeclared (first use this function) 
ftpd.c:1342: `fd' undeclared (first use this function) 
ftpd.c:1342: `NULL' undeclared (first use this function) 
ftpd.c:1344: warning: assignment makes pointer from integer without a cast 
ftpd.c: In function `end_login': 
ftpd.c:1370: `uid_t' undeclared (first use this function) 
ftpd.c:1370: parse error before `0' 
ftpd.c:1372: dereferencing pointer to incomplete type 
ftpd.c:1373: `NULL' undeclared (first use this function) 
ftpd.c: In function `pass': 
ftpd.c:1480: `NULL' undeclared (first use this function) 
ftpd.c:1483: dereferencing pointer to incomplete type 
ftpd.c:1521: dereferencing pointer to incomplete type 
ftpd.c:1525: dereferencing pointer to incomplete type 
ftpd.c:1537: `LOG_NOTICE' undeclared (first use this function) 
ftpd.c:1540: `LOG_INFO' undeclared (first use this function) 
ftpd.c:1607: `mode_t' undeclared (first use this function) 
ftpd.c:1607: parse error before `oldmask' 
ftpd.c:1608: `oldmask' undeclared (first use this function) 
ftpd.c:1609: `O_WRONLY' undeclared (first use this function) 
ftpd.c:1609: `O_APPEND' undeclared (first use this function) 
ftpd.c:1609: `O_CREAT' undeclared (first use this function) 
ftpd.c:1612: `LOG_ERR' undeclared (first use this function) 
ftpd.c:1640: `gid_t' undeclared (first use this function) 
ftpd.c:1640: parse error before `pw' 
ftpd.c:1644: dereferencing pointer to incomplete type 
ftpd.c:1644: dereferencing pointer to incomplete type 
ftpd.c:1658: dereferencing pointer to incomplete type 
ftpd.c:1672: dereferencing pointer to incomplete type 
ftpd.c:1673: dereferencing pointer to incomplete type 
ftpd.c:1674: dereferencing pointer to incomplete type 
ftpd.c:1679: dereferencing pointer to incomplete type 
ftpd.c:1679: warning: assignment makes pointer from integer without a cast 
ftpd.c:1680: dereferencing pointer to incomplete type 
ftpd.c:1686: dereferencing pointer to incomplete type 
ftpd.c:1721: `uid_t' undeclared (first use this function) 
ftpd.c:1721: parse error before `pw' 
ftpd.c:1682: label `bad' used but not defined 
ftpd.c: At top level: 
ftpd.c:1727: parse error before `if' 
ftpd.c:1744: parse error before `230' 
ftpd.c:1745: conflicting types for `lreply' 
ftpd.c:323: previous declaration of `lreply' 
ftpd.c:1745: warning: data definition has no type or storage class 
ftpd.c:1746: parse error before `230' 
ftpd.c:1747: warning: data definition has no type or storage class 
ftpd.c:1752: parse error before `230' 
ftpd.c:1752: warning: data definition has no type or storage class 
ftpd.c:1753: parse error before `230' 
ftpd.c:1753: warning: data definition has no type or storage class 
ftpd.c:1766: parse error before `230' 
ftpd.c:1766: conflicting types for `reply' 
ftpd.c:322: previous declaration of `reply' 
ftpd.c:1766: warning: data definition has no type or storage class 
ftpd.c:1767: parse error before string constant 
ftpd.c:1770: parse error before string constant 
ftpd.c:1770: conflicting types for `setproctitle' 
ftpd.c:320: previous declaration of `setproctitle' 
ftpd.c:1770: warning: data definition has no type or storage class 
ftpd.c:1777: parse error before string constant 
ftpd.c:1777: warning: data definition has no type or storage class 
ftpd.c:1778: warning: parameter names (without types) in function declaration 
ftpd.c:1778: warning: data definition has no type or storage class 
ftpd.c:1779: parse error before `if' 
ftpd.c:1784: parse error before `->' 
ftpd.c:1784: warning: data definition has no type or storage class 
ftpd.c:1789: conflicting types for `home' 
ftpd.c:202: previous declaration of `home' 
ftpd.c:1789: dereferencing pointer to incomplete type 
ftpd.c:1789: warning: data definition has no type or storage class 
ftpd.c:1790: parse error before `void' 
ftpd.c:1796: redefinition of `xferlog' 
ftpd.c:287: `xferlog' previously defined here 
ftpd.c:1796: warning: data definition has no type or storage class 
ftpd.c:1797: conflicting types for `end_login' 
ftpd.c:1367: previous declaration of `end_login' 
ftpd.c:1797: warning: data definition has no type or storage class 
ftpd.c:1798: parse error before `return' 
ftpd.c: In function `retrieve': 
ftpd.c:1832: `FILE' undeclared (first use this function) 
ftpd.c:1832: `fin' undeclared (first use this function) 
ftpd.c:1833: `dout' undeclared (first use this function) 
ftpd.c:1834: parse error before `struct' 
ftpd.c:1838: `time_t' undeclared (first use this function) 
ftpd.c:1850: `NULL' undeclared (first use this function) 
ftpd.c:1850: `stat_ret' undeclared (first use this function) 
ftpd.c:1850: `st' undeclared (first use this function) 
ftpd.c:1854: `logname' undeclared (first use this function) 
ftpd.c:1858: `cptr' undeclared (first use this function) 
ftpd.c:1870: `fnbuf' undeclared (first use this function) 
ftpd.c:1910: `namebuf' undeclared (first use this function) 
ftpd.c:1912: `junk' undeclared (first use this function) 
ftpd.c:1935: `options' undeclared (first use this function) 
ftpd.c:1938: warning: assignment makes pointer from integer without a cast 
ftpd.c:1941: `LOG_ERR' undeclared (first use this function) 
ftpd.c:1955: `closefunc' undeclared (first use this function) 
ftpd.c:1958: `BUFSIZ' undeclared (first use this function) 
ftpd.c:1973: `S_IFMT' undeclared (first use this function) 
ftpd.c:1973: `S_IFREG' undeclared (first use this function) 
ftpd.c:1986: `EOF' undeclared (first use this function) 
ftpd.c:1993: `L_SET' undeclared (first use this function) 
ftpd.c:2010: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:2012: `start_time' undeclared (first use this function) 
ftpd.c:2013: parse error before `curtime' 
ftpd.c:2060: `curtime' undeclared (first use this function) 
ftpd.c:2069: dereferencing pointer to incomplete type 
ftpd.c: In function `store': 
ftpd.c:2093: `FILE' undeclared (first use this function) 
ftpd.c:2093: `fout' undeclared (first use this function) 
ftpd.c:2093: `din' undeclared (first use this function) 
ftpd.c:2094: parse error before `struct' 
ftpd.c:2101: `time_t' undeclared (first use this function) 
ftpd.c:2115: `mode_t' undeclared (first use this function) 
ftpd.c:2116: `uid_t' undeclared (first use this function) 
ftpd.c:2117: `gid_t' undeclared (first use this function) 
ftpd.c:2123: `open_flags' undeclared (first use this function) 
ftpd.c:2123: `O_RDWR' undeclared (first use this function) 
ftpd.c:2123: `O_CREAT' undeclared (first use this function) 
ftpd.c:2124: `NULL' undeclared (first use this function) 
ftpd.c:2124: `O_APPEND' undeclared (first use this function) 
ftpd.c:2124: `O_TRUNC' undeclared (first use this function) 
ftpd.c:2128: `st' undeclared (first use this function) 
ftpd.c:2129: warning: assignment makes pointer from integer without a cast 
ftpd.c:2141: `entry' undeclared (first use this function) 
ftpd.c:2144: `overwrite' undeclared (first use this function) 
ftpd.c:2145: `O_EXCL' undeclared (first use this function) 
ftpd.c:2159: `match_value' undeclared (first use this function) 
ftpd.c:2159: `uid' undeclared (first use this function) 
ftpd.c:2159: `gid' undeclared (first use this function) 
ftpd.c:2159: `f_mode' undeclared (first use this function) 
ftpd.c:2159: `valid' undeclared (first use this function) 
ftpd.c:2172: `oldmask' undeclared (first use this function) 
ftpd.c:2173: `fdout' undeclared (first use this function) 
ftpd.c:2185: `oldid' undeclared (first use this function) 
ftpd.c:2187: parse error before `0' 
ftpd.c:2208: `closefunc' undeclared (first use this function) 
ftpd.c:2222: `EOF' undeclared (first use this function) 
ftpd.c:2231: `L_INCR' undeclared (first use this function) 
ftpd.c:2235: `L_SET' undeclared (first use this function) 
ftpd.c:2240: `off_t' undeclared (first use this function) 
ftpd.c:2254: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:2257: `start_time' undeclared (first use this function) 
ftpd.c:2258: parse error before `curtime' 
ftpd.c:2305: `curtime' undeclared (first use this function) 
ftpd.c:2314: dereferencing pointer to incomplete type 
ftpd.c: At top level: 
ftpd.c:2327: parse error before `*' 
ftpd.c: In function `getdatasock': 
ftpd.c:2340: warning: return makes pointer from integer without a cast 
ftpd.c:2342: `uid_t' undeclared (first use this function) 
ftpd.c:2342: parse error before `0' 
ftpd.c:2343: `AF_INET' undeclared (first use this function) 
ftpd.c:2343: `SOCK_STREAM' undeclared (first use this function) 
ftpd.c:2346: `SOL_SOCKET' undeclared (first use this function) 
ftpd.c:2346: `SO_REUSEADDR' undeclared (first use this function) 
ftpd.c:2350: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2351: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2351: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2358: sizeof applied to an incomplete type 
ftpd.c:2360: `EADDRINUSE' undeclared (first use this function) 
ftpd.c:2376: parse error before `pw' 
ftpd.c:2396: warning: return makes pointer from integer without a cast 
ftpd.c:2399: parse error before `pw' 
ftpd.c:2404: `NULL' undeclared (first use this function) 
ftpd.c: At top level: 
ftpd.c:2407: parse error before `*' 
ftpd.c:2409: parse error before `off_t' 
ftpd.c: In function `dataconn': 
ftpd.c:2418: `FILE' undeclared (first use this function) 
ftpd.c:2418: `file' undeclared (first use this function) 
ftpd.c:2419: parse error before `int' 
ftpd.c:2424: `size' undeclared (first use this function) 
ftpd.c:2426: `off_t' undeclared (first use this function) 
ftpd.c:2439: storage size of `from' isn't known 
ftpd.c:2475: `NULL' undeclared (first use this function) 
ftpd.c:2491: `LOG_NOTICE' undeclared (first use this function) 
ftpd.c:2492: dereferencing pointer to incomplete type 
ftpd.c:2493: `name' undeclared (first use this function) 
ftpd.c:2497: warning: return makes pointer from integer without a cast 
ftpd.c:2503: warning: return makes pointer from integer without a cast 
ftpd.c:2506: `data_dest' has an incomplete type 
ftpd.c:2507: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2512: warning: passing arg 1 of `getdatasock' makes pointer from
integer without a cast 
ftpd.c:2515: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2516: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2521: sizeof applied to an incomplete type 
ftpd.c:2522: `EADDRINUSE' undeclared (first use this function) 
ftpd.c:2522: `EINTR' undeclared (first use this function) 
ftpd.c:2522: `retry' undeclared (first use this function) 
ftpd.c: At top level: 
ftpd.c:2544: parse error before `*' 
ftpd.c: In function `send_data': 
ftpd.c:2558: `NULL' undeclared (first use this function) 
ftpd.c:2571: `instr' undeclared (first use this function) 
ftpd.c:2571: `EOF' undeclared (first use this function) 
ftpd.c:2575: `outstr' undeclared (first use this function) 
ftpd.c:2593: `u_int' undeclared (first use this function) 
ftpd.c:2593: parse error before `blksize' 
ftpd.c:2601: parse error before `blksize' 
ftpd.c:2616: default label not within a switch statement 
ftpd.c:2585: label `file_err' used but not defined 
ftpd.c:2576: label `data_err' used but not defined 
ftpd.c: At top level: 
ftpd.c:2622: parse error before `:' 
ftpd.c:2624: warning: data definition has no type or storage class 
ftpd.c:2625: parse error before `426' 
ftpd.c:2625: conflicting types for `perror_reply' 
ftpd.c:365: previous declaration of `perror_reply' 
ftpd.c:2625: warning: data definition has no type or storage class 
ftpd.c:2630: parse error before `551' 
ftpd.c:2630: warning: data definition has no type or storage class 
ftpd.c:2640: parse error before `*' 
ftpd.c: In function `receive_data': 
ftpd.c:2654: `NULL' undeclared (first use this function) 
ftpd.c:2667: `BUFSIZ' undeclared (first use this function) 
ftpd.c:2672: `instr' undeclared (first use this function) 
ftpd.c:2673: `outstr' undeclared (first use this function) 
ftpd.c:2697: `EOF' undeclared (first use this function) 
ftpd.c: In function `statfilecmd': 
ftpd.c:2753: `BUFSIZ' undeclared (first use this function) 
ftpd.c:2754: `FILE' undeclared (first use this function) 
ftpd.c:2754: `fin' undeclared (first use this function) 
ftpd.c:2755: parse error before `int' 
ftpd.c:2782: `NULL' undeclared (first use this function) 
ftpd.c:2783: warning: assignment makes pointer from integer without a cast 
ftpd.c: In function `statcmd': 
ftpd.c:2799: `u_char' undeclared (first use this function) 
ftpd.c:2799: `a' undeclared (first use this function) 
ftpd.c:2800: `p' undeclared (first use this function) 
ftpd.c:2806: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:2814: dereferencing pointer to incomplete type 
ftpd.c:2837: parse error before `)' 
ftpd.c:2837: dereferencing pointer to incomplete type 
ftpd.c:2838: parse error before `)' 
ftpd.c:2838: dereferencing pointer to incomplete type 
ftpd.c: In function `vreply': 
ftpd.c:2878: `BUFSIZ' undeclared (first use this function) 
ftpd.c:2894: `LOG_DEBUG' undeclared (first use this function) 
ftpd.c:2902: `stdout' undeclared (first use this function) 
ftpd.c: At top level: 
ftpd.c:2914: conflicting types for `reply' 
ftpd.c:1766: previous declaration of `reply' 
ftpd.c: In function `reply': 
ftpd.c:2917: `NULL' undeclared (first use this function) 
ftpd.c:2921: warning: assignment makes pointer from integer without a cast 
ftpd.c: At top level: 
ftpd.c:2957: conflicting types for `lreply' 
ftpd.c:1747: previous declaration of `lreply' 
ftpd.c: In function `yyerror': 
ftpd.c:3002: `NULL' undeclared (first use this function) 
ftpd.c:3003: warning: assignment makes pointer from integer without a cast 
ftpd.c: In function `delete': 
ftpd.c:3018: storage size of `st' isn't known 
ftpd.c:3031: `S_IFMT' undeclared (first use this function) 
ftpd.c:3031: `S_IFDIR' undeclared (first use this function) 
ftpd.c:3032: `uid_t' undeclared (first use this function) 
ftpd.c:3032: parse error before `uid' 
ftpd.c:3033: `gid_t' undeclared (first use this function) 
ftpd.c:3039: `uid' undeclared (first use this function) 
ftpd.c:3039: `gid' undeclared (first use this function) 
ftpd.c:3054: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3059: `LOG_NOTICE' undeclared (first use this function) 
ftpd.c:3062: dereferencing pointer to incomplete type 
ftpd.c: In function `cwd': 
ftpd.c:3078: `NULL' undeclared (first use this function) 
ftpd.c:3079: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3079: size of array `cdpath' has non-integer type 
ftpd.c: In function `makedir': 
ftpd.c:3122: `uid_t' undeclared (first use this function) 
ftpd.c:3122: parse error before `uid' 
ftpd.c:3123: `gid_t' undeclared (first use this function) 
ftpd.c:3125: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3125: size of array `path' has non-integer type 
ftpd.c:3130: `uid' undeclared (first use this function) 
ftpd.c:3130: `gid' undeclared (first use this function) 
ftpd.c:3140: `EEXIST' undeclared (first use this function) 
ftpd.c: In function `removedir': 
ftpd.c:3165: `uid_t' undeclared (first use this function) 
ftpd.c:3165: parse error before `uid' 
ftpd.c:3166: `gid_t' undeclared (first use this function) 
ftpd.c:3178: `uid' undeclared (first use this function) 
ftpd.c:3178: `gid' undeclared (first use this function) 
ftpd.c:3182: `EBUSY' undeclared (first use this function) 
ftpd.c: In function `pwd': 
ftpd.c:3198: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3198: size of array `path' has non-integer type 
ftpd.c:3210: `NULL' undeclared (first use this function) 
ftpd.c: In function `renamefrom': 
ftpd.c:3231: storage size of `st' isn't known 
ftpd.c: In function `renamecmd': 
ftpd.c:3250: `NULL' undeclared (first use this function) 
ftpd.c: In function `dolog': 
ftpd.c:3310: dereferencing pointer to incomplete type 
ftpd.c:3311: sizeof applied to an incomplete type 
ftpd.c:3311: `AF_INET' undeclared (first use this function) 
ftpd.c:3311: warning: assignment makes pointer from integer without a cast 
ftpd.c:3321: dereferencing pointer to incomplete type 
ftpd.c:3321: warning: assignment makes pointer from integer without a cast 
ftpd.c:3331: dereferencing pointer to incomplete type 
ftpd.c: In function `dologout': 
ftpd.c:3368: `uid_t' undeclared (first use this function) 
ftpd.c:3368: parse error before `0' 
ftpd.c:3369: dereferencing pointer to incomplete type 
ftpd.c:3372: `LOG_INFO' undeclared (first use this function) 
ftpd.c: In function `myoob': 
ftpd.c:3400: `stdin' undeclared (first use this function) 
ftpd.c:3400: `NULL' undeclared (first use this function) 
ftpd.c:3420: `off_t' undeclared (first use this function) 
ftpd.c: In function `passive': 
ftpd.c:3459: `AF_INET' undeclared (first use this function) 
ftpd.c:3459: `SOCK_STREAM' undeclared (first use this function) 
ftpd.c:3464: `pasv_addr' has an incomplete type 
ftpd.c:3465: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:3467: `uid_t' undeclared (first use this function) 
ftpd.c:3467: parse error before `0' 
ftpd.c:3468: sizeof applied to an incomplete type 
ftpd.c:3469: parse error before `pw' 
ftpd.c:3473: parse error before `pw' 
ftpd.c:3475: sizeof applied to an incomplete type 
ftpd.c:3480: invalid use of undefined type `struct sockaddr_in' 
ftpd.c:3481: invalid use of undefined type `struct sockaddr_in' 
ftpd.c: At top level: 
ftpd.c:3505: warning: type mismatch with previous external decl 
ftpd.c:2129: warning: previous external decl of `gunique' 
ftpd.c:3505: warning: type mismatch with previous implicit declaration 
ftpd.c:2129: warning: previous implicit declaration of `gunique' 
ftpd.c:3505: warning: `gunique' was previously implicitly declared to
return `int' 
ftpd.c: In function `gunique': 
ftpd.c:3506: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3507: storage size of `st' isn't known 
ftpd.c:3508: warning: initialization makes pointer from integer without a cast 
ftpd.c: At top level: 
ftpd.c:3546: conflicting types for `perror_reply' 
ftpd.c:2630: previous declaration of `perror_reply' 
ftpd.c: In function `send_file_list': 
ftpd.c:3562: syntax error before `*' 
ftpd.c:3563: syntax error before `*' 
ftpd.c:3566: storage size of `st' isn't known 
ftpd.c:3583: `dout' undeclared (first use this function) 
ftpd.c:3583: `NULL' undeclared (first use this function) 
ftpd.c:3584: `dirp' undeclared (first use this function) 
ftpd.c:3601: `ENOENT' undeclared (first use this function) 
ftpd.c:3638: `S_IFMT' undeclared (first use this function) 
ftpd.c:3638: `S_IFREG' undeclared (first use this function) 
ftpd.c:3640: `off_t' undeclared (first use this function) 
ftpd.c:3649: `S_IFDIR' undeclared (first use this function) 
ftpd.c:3655: warning: assignment makes pointer from integer without a cast 
ftpd.c:3656: `MAXPATHLEN' undeclared (first use this function) 
ftpd.c:3661: dereferencing pointer to incomplete type 
ftpd.c:3661: dereferencing pointer to incomplete type 
ftpd.c:3668: dereferencing pointer to incomplete type 
ftpd.c:3668: dereferencing pointer to incomplete type 
ftpd.c:3669: dereferencing pointer to incomplete type 
ftpd.c:3673: dereferencing pointer to incomplete type 
ftpd.c: At top level: 
ftpd.c:3801: `NULL' undeclared here (not in a function) 
ftpd.c:3805: `NULL' undeclared here (not in a function) 
ftpd.c: In function `initsetproctitle': 
ftpd.c:3828: `NULL' undeclared (first use this function) 
ftpd.c:3839: warning: assignment makes pointer from integer without a cast 
ftpd.c: At top level: 
ftpd.c:3890: conflicting types for `setproctitle' 
ftpd.c:1778: previous declaration of `setproctitle' 
ftpd.c: In function `setproctitle': 
ftpd.c:3955: `NULL' undeclared (first use this function) 
ftpd.c: At top level: 
ftpd.c:207: storage size of `ctrl_addr' isn't known 
ftpd.c:208: storage size of `data_source' isn't known 
ftpd.c:209: storage size of `data_dest' isn't known 
ftpd.c:210: storage size of `his_addr' isn't known 
ftpd.c:211: storage size of `pasv_addr' isn't known 
make: *** [ftpd.o] Error 1 
make: bison: Command not found 
make: *** [ftpcmd.c] Error 127 
make: bison: Command not found 
make: *** [ftpcmd.c] Error 127 
In file included from ckconfig.c:32: 
config.h:5: features.h: No such file or directory 
In file included from
/usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/syslimits.h:7, 
from /usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/limits.h:11, 
from config.h:43, 
from ckconfig.c:32: 
/usr/lib/gcc-lib/i386-redhat-linux/2.7.2.3/include/limits.h:112: limits.h:
No such file or directory 
In file included from ckconfig.c:32: 
config.h:53: stdlib.h: No such file or directory 
config.h:54: unistd.h: No such file or directory 
ckconfig.c:36: stdio.h: No such file or directory 
ckconfig.c:37: sys/types.h: No such file or directory 
ckconfig.c:38: sys/stat.h: No such file or directory 
ckconfig.c: In function `main': 
ckconfig.c:44: storage size of `sbuf' isn't known 
ckconfig.c:49: `stdout' undeclared (first use this function) 
ckconfig.c:49: (Each undeclared identifier is reported only once 
ckconfig.c:49: for each function it appears in.) 
make: *** [ckconfig] Error 1 
size: bin/ftpd: No such file or directory 
size: bin/ftpcount: No such file or directory 
size: bin/ftpshut: No such file or directory 
size: bin/ftpwho: No such file or directorysize: bin/ckconfig: No such file
or directory 
===============================================

Patrick J. Shoaf, Systems Engineer
<mailto:[email-masked]>[email-masked]

A & S Enterprises 
449 Knox Ave 
Monessen, PA 15062-1532
Phone: 724-684-8270  or 888-638-6963 in PA only
Fax: 724-684-8274 
Check out our web site at http://www.midmon.com 
or you can e-mail us at <mailto:[email-masked]>[email-masked]

---

From: Alex Yu <[email-masked]>
Date: Tue, 16 Mar 1999 13:12:19 -0500

>and I am getting errors, and am unsure as to what they mean.  Attached

The default include dir is /usr/include.  Make sure that you have 2 links
in /usr/include from /usr/src/linux.  

/usr/src/linux/include/linux -> /usr/include/linux
/usr/src/linux/include/asm -> /usr/include/asm

Best Regards,

Alex Yu
PGP Fingerprint: 1F23 3045 9F92 E856 3967  ACB3 5354 2CC0 7AA7 19FA
  
"What should you do when you see an 
endangered animal that is eating an endangered 
plant?"  
                                 -- George Carlin

---

From: Patrick Shoaf <[email-masked]>
Date: Tue, 16 Mar 1999 14:06:09 -0500

>/usr/src/linux/include/asm -> /usr/include/asm

I just checked, those links are already in place...any other suggestions???

A & S Enterprises 
449 Knox Ave 
Monessen, PA 15062-1532

---

From: "Roeland Th. Jansen" <[email-masked]>
Date: Tue, 16 Mar 1999 19:05:34 +0000 (GMT)

> I just checked, those links are already in place...any other suggestions???

you did also install the kernel header files ?

-- 
Grobbebol's Home                       |  Don't give in to spammers.   -o)
MCSE: Must Consult Someone Experienced | Use your real e-mail address   /\
Linux 2.2.3 on an i586/64 MB           |        on Usenet.             _\_v

---

From: Patrick Shoaf <[email-masked]>
Date: Tue, 16 Mar 1999 14:12:40 -0500

>you did also install the kernel header files ?

YES...I used CUSTOM config and select all items under Kernel...Source,
Headers, etc.

A & S Enterprises 
449 Knox Ave 
Monessen, PA 15062-1532

---

From: "Roeland Th. Jansen" <[email-masked]>
Date: Tue, 16 Mar 1999 19:12:33 +0000 (GMT)

> YES...I used CUSTOM config and select all items under Kernel...Source,

I already zapped your first mail, please e-mail me personally again what
your problem is.

---

From: "Roeland Th. Jansen" <[email-masked]>
Date: Tue, 16 Mar 1999 19:22:15 +0000 (GMT)

> YES...I used CUSTOM config and select all items under Kernel...Source,

I start to think that you forgot to install a package, like a complete gcc
setup.

---

From: Patrick Shoaf <[email-masked]>
Date: Tue, 16 Mar 1999 15:02:04 -0500

>I start to think that you forgot to install a package, like a complete gcc
I checked...
	INSTALLED			NOT INSTALLED
	gcc-2.7.2.3-14.i386.rpm
	glib-1.06.6-3.i386.rpm
	glibc-2.0.7-29.i386.rpm
					glibc-debug-2.0.7-29.i386.rpm
					glibc-devel-2.0.7-29.i386.rpm
					glibc-profile-2.0.7-29.i386.rpm

I just installed the uninstalled items, and am trying to compile
again....different errors were reported...reporting problem with
"bison"...(not installed)...trying compile again...different errors, see
output from "./build lnx >err  2>err2" below...I may need to check and
install some other rpm's....ANY IDEAS????

==================ERR=======================
make args are : 
make opts are : 
Linking Makefiles.
Making support library. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -c strcasestr.c 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -c authuser.c 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -c snprintf.c 
rm -f libsupport.a 
ar cq libsupport.a strcasestr.o authuser.o snprintf.o 
ranlib libsupport.a
Making ftpd. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c ftpd.c -o ftpd.o 
bison -y ftpcmd.y 
mv -f y.tab.c ftpcmd.c 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c ftpcmd.c -o ftpcmd.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c glob.c -o glob.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c logwtmp.c -o logwtmp.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c popen.c -o popen.o 
sh newvers.sh 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c vers.c 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c access.c -o access.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c extensions.c -o extensions.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c realpath.c -o realpath.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c acl.c -o acl.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c private.c -o private.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c authenticate.c -o authenticate.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c conversions.c -o conversions.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c hostacc.c -o hostacc.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -c sigfix.c -o sigfix.o 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -o ftpd ftpd.o ftpcmd.o glob.o
logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o private.o
authenticate.o conversions.o hostacc.o sigfix.o -lsupport -lcrypt
Making ftpcount. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -o ftpcount ftpcount.c vers.o
-lsupport -lcrypt
Making ftpshut. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -o ftpshut ftpshut.c vers.o
-lsupport -lcrypt
Making ckconfig. 
gcc -O3 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s -static -DSHADOW_PASSWORD -o ckconfig ckconfig.c
Links to executables are in bin directory: 
text data bss dec hex filename 
88169 2744 2152 93065 16b89 bin/ckconfigDone 

=======================ERR2============================
ftpd.c: In function `dataconn': 
ftpd.c:2463: warning: passing arg 5 of `select' from incompatible pointer type 
ftpd.c: In function `initsetproctitle': 
ftpd.c:3839: warning: assignment makes pointer from integer without a cast 
popen.o: In function `ftpd_popen': 
popen.o(.text+0xce): undefined reference to `___strtok' 
popen.o(.text+0x13b): undefined reference to `___strtok' 
access.o: In function `hostmatch': 
access.o(.text+0x296): undefined reference to `___strtok' 
access.o(.text+0x306): undefined reference to `___strtok' 
access.o(.text+0x332): undefined reference to `___strtok' 
access.o(.text+0x39f): more undefined references to `___strtok' follow 
make: *** [ftpd] Error 1 
/tmp/cca040861.o: In function `acl_getlimit': 
/tmp/cca040861.o(.text+0x239): undefined reference to `___strtok' 
/tmp/cca040861.o(.text+0x2a8): undefined reference to `___strtok' 
/tmp/cca040861.o(.text+0x2ae): undefined reference to `___strtok' 
/tmp/cca040861.o(.text+0x31b): undefined reference to `___strtok' 
/tmp/cca040861.o(.text+0x34b): undefined reference to `___strtok' 
/tmp/cca040861.o(.text+0x3b8): more undefined references to `___strtok' follow 
make: *** [ftpcount] Error 1 
/tmp/cca040971.o: In function `main': 
/tmp/cca040971.o(.text+0x459): undefined reference to `___strtok' 
/tmp/cca040971.o(.text+0x4c8): undefined reference to `___strtok' 
/tmp/cca040971.o(.text+0x4ce): undefined reference to `___strtok' 
/tmp/cca040971.o(.text+0x53b): undefined reference to `___strtok' 
make: *** [ftpshut] Error 1 
size: bin/ftpd: No such file or directory 
size: bin/ftpcount: No such file or directory 
size: bin/ftpshut: No such file or directorysize: bin/ftpwho: No such file
or directory 

A & S Enterprises 
449 Knox Ave 
Monessen, PA 15062-1532

---

From: "Roeland Th. Jansen" <[email-masked]>
Date: Tue, 16 Mar 1999 20:44:23 +0000 (GMT)

> I just installed the uninstalled items, and am trying to compile

I assume the devel package has caused your start of compiling problems. for

> "bison"...(not installed)...trying compile again...different errors, see

install bison and retry. if it still fails, post the failed messages.

---

From: Patrick Shoaf <[email-masked]>
Date: Wed, 17 Mar 1999 14:07:26 -0500

>install bison and retry. if it still fails, post the failed messages.
After installing bison, these are the messages I receive...
output from "./build lnx >err 2>err2" below...

A & S Enterprises 
449 Knox Ave 
Monessen, PA 15062-1532

---

From: "Roeland Th. Jansen" <[email-masked]>
Date: Wed, 17 Mar 1999 19:05:52 +0000 (GMT)

ok basically it bouls down to :

> undefined reference to `___strtok' 

anyone who knows where strtok is put in  (which lib)

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 17 Mar 1999 14:34:16 -0500 (EST)

> anyone who knows where strtok is put in  (which lib)

libc

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195