Subject: RE: Class restrictions

From: [email-masked]
Date: Wed, 3 Mar 1999 12:40:13 -0500 (EST)

Gregory A Lundberg [SMTP:[email-masked]]:
> Thinking more on the problem, reordering may not help.  Try this:
> 
> The default for guest users is 'yes', form a class= for the 'no' and let
> the default case handle the 'yes'.  The code really is too simplistic.

Your support is unbelievable!! I want to thanks your big effort in the wuftpd developement, maintenance and support.

I tried several configurations more, and the class restriction option seems a little erratic. The problem appears when there are a rejection by type (ie. guest) and an approval by class (ie class=myguest). I got a valid configuration establishing both rules by class (with different classes).

Best regards,

	David Jorrin.
= = =

David Jorrin <[email-masked]>>

----------------------------------------------------------------
Get your free email from AltaVista at http://altavista.iname.com

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 3 Mar 1999 13:02:15 -0500 (EST)

On Wed, 3 Mar 1999 [email-masked] wrote:

> Your support is unbelievable!! I want to thanks your big effort in the
> wuftpd developement, maintenance and support.
> 
> I tried several configurations more, and the class restriction option
> seems a little erratic. The problem appears when there are a rejection
> by type (ie. guest) and an approval by class (ie class=myguest). I got
> a valid configuration establishing both rules by class (with different
> classes).

Like I said, the code handling it is way too simplistic.  I'll rewrite it
to be more 'as expected' .. got a couple other things to do first.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195