Subject: xferlog doesn't work

From: Daniel Fong <[email-masked]>
Date: Mon, 01 Mar 1999 10:21:56 -0800

Hello,

I am able to log into the ftp server fine and do uploads and downloads, but
nothing is recorded in the xferlog. How do I get it to do that?

This is what I have in /usr/local/etc/ftpaccess:

log commands real,guest
log transfers anonymous,real,guest inbound,outbound

I assume it should create the xferlog file so I haven't created one in
/var/adm/ or /var/log/

Thanks.

-Dan

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 1 Mar 1999 13:56:52 -0500 (EST)

On Mon, 1 Mar 1999, Daniel Fong wrote:

> I am able to log into the ftp server fine and do uploads and
> downloads, but nothing is recorded in the xferlog. How do I get it to
> do that?
> 

Add -l to the command line and don't forget to -HUP inetd after you do.
Also, check that the daemon is really using the ftpaccess file (chconfig
may help, I suggest a test which ensures you're using the right
ftpaccess).

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Daniel Fong <[email-masked]>
Date: Mon, 01 Mar 1999 11:27:42 -0800

Hello,

I've added the -l but that doesn't seem to help.

ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd      in.ftpd -l

Here is the output from the ckconfig command:

Checking _PATH_FTPUSERS :: /etc/ftpusers
I can't find it... look in doc/examples for an example.
 
Checking _PATH_FTPACCESS :: /etc/ftpaccess
ok.
 
Checking _PATH_PIDNAMES :: /var/adm/ftp.pids-%s
ok.
 
Checking _PATH_CVT :: /etc/ftpconversions
I can't find it... look in doc/examples for an example.
 
Checking _PATH_XFERLOG :: /var/adm/xferlog
ok.
 
Checking _PATH_PRIVATE :: /etc/ftpgroups
I can't find it... look in doc/examples for an example.
You only need this if you want SITE GROUP and SITE GPASS
functionality. If you do, you will need to edit the example.
 
Checking _PATH_FTPHOSTS :: /etc/ftphosts
I can't find it... look in doc/examples for an example.
You only need this if you are using the HOST ACCESS features
of the server.

Thanks.

-Dan

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 1 Mar 1999 14:48:10 -0500 (EST)

> I can't find it... look in doc/examples for an example.

You will probably want to create this file unless you're using the new
features of the VR version and don't need it.

> Checking _PATH_FTPACCESS :: /etc/ftpaccess

Um ... you did see this didn't you?

--

---

From: Ted Keller <[email-masked]>
Date: Mon, 1 Mar 1999 17:24:01 -0500 (EST)

Daniel,

I don't see the -a options on the inetd entry.  Therefore, it's not
reading the ftpaccess file.    This may be a cause of your logging
problems.

ted keller - bfg.com