Subject: Re: [VR16] WU-FTPD-2.4.2-VR16 Released (fwd)

From: [email-masked]
Date: Sun, 7 Mar 1999 10:29:46 +0800 (HKT)

Sorry for my stupid.
Does you mean I can just use only one vr-patch (wu-ftpd-2.4.2-vr16.patch) to pat
ch final release version of wuftpd(wu-ftpd 2.4.2) ?
And I do not need to use vr-patch from (VR-3 to VR-16) to patch wu-ftpd-2.4.2 be
ta-18 version to get the same patch result ?

KK

Forwarded message:
> From [email-masked] Thu Mar  4 20:17:54 1999
> Message-Id: <[email-masked]>
> Date: Thu, 4 Mar 1999 07:13:51 -0500 (EST)
> Reply-To: [email-masked]
> Sender: [email-masked]
> From: Gregory A Lundberg <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [VR16] WU-FTPD-2.4.2-VR16 Released (fwd)
> In-Reply-To: <[email-masked]>
> MIME-Version: 1.0
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> X-Listprocessor-Version: 8.0 -- ListProcessor(tm) by CREN
> Content-Length: 793
> 
> On Thu, 4 Mar 1999 [email-masked] wrote:
> 
> > Does it is enough that using wu-ftpd-2.4.2-vr16.tar.Z to patch wu-ftpd
> > 2.4.2 (final release) to get the same effect from using all previous
> > vr-patch to patch wu-ftpd Beta 18 ?
> 
> To patch from VR15 to VR16, there's a patch set at
>   ftp://ftp.vr.net/pub/wu-ftpd/attic/wu-ftpd-2.4.2-beta-18-vr16.patch
> 
> Except for a change to the setproctitle() code, there's no significant
> difference.   A couple of one-line bug fixes.  The only reason I
> recompiled is, well heck, I'm its maintainer; I told the people who build
> binaries for me not to bother unless they _really_ want to.
> 
> -- 
> 
> Gregory A Lundberg              Senior Partner, VRnet Company
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195
> 
>

---

From: Jason Mills <[email-masked]>
Date: Sat, 6 Mar 1999 20:21:29 -0800 (PST)

i need to know where to find the latest patch .. to fix the recently
released exploit

---

From: Gregory A Lundberg <[email-masked]>
Date: Sat, 6 Mar 1999 23:55:47 -0500 (EST)

On Sun, 7 Mar 1999 [email-masked] wrote:

> Does you mean I can just use only one vr-patch
> (wu-ftpd-2.4.2-vr16.patch) to pat ch final release version of
> wuftpd(wu-ftpd 2.4.2) ? And I do not need to use vr-patch from (VR-3
> to VR-16) to patch wu-ftpd-2.4.2 be ta-18 version to get the same
> patch result ?

When I rolled VR16, I rolled a single patch file which encompasses all
changes.

First off, the full V16 changes are already applied in the tarballs
  wu-ftpd-2.4.2-vr16.tar.gz and wu-ftpd-2.4.2-vr16.tar.Z
so all you need to do is download one file and you're all set to go.

The intention of the patch files being available is so that people can see
exactly what's changed.  I do it because, whenever I get a new release
(say, of Sendmail) the first thing _I_ do after importing it into my CVS
is to run a diff to see what was done.  Sometimes I find changes which
conflict with changes I've made locally, or which I disagee with.

If you wish to apply the patches yourself, take the wu-ftpd-2.4.2.tar.Z
tarball and apply the wu-ftpd-2.4.2-vr16.patch; you will get the same
thing as the pre-patched tarballs.  This patch file is HUGE because it
encompasses ALL changes from (Beta 18) to the present, including the
(relatively minor) changes from Academ's (Beta 18) to (Release).

If you have 2.4.2 (Beta 18), through 2.4.2 (Beta 18) VR15, and wish to
apply the patches yourself to move to VR16, look in the attic directory ay
my FTP site.  In there you will find each patch file.  Apply them in
order.  VR3 is the first patch file against Beta-18.  The final patch file
wu-ftpd-2.4.2-beta-18-vr16.patch will produce results identical to the
pre-patched tarballs or to applying wu-ftpd-2.4.2-vr16.patch against
wu-ftpd-2.4.2.tar.Z.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: [email-masked] (Martin Puaschitz)
Date: Sun, 7 Mar 1999 12:30:46 +0100

i wanna unsubscripe on this list.

please tell me how to do this !

thanx,
martin

--