Subject: Re: Problem w/ Solaris /var/adm/wtmpx and /usr/bin/last(1)

From: James McMahon <[email-masked]>
Date: Tue, 09 Mar 1999 14:21:46 +1100

I just did a quick test on a system running Solaris 2.6 and wu-ftpd 2.4.2 beta
18 VR 11 and found the same.  Last indicated that the existing connection had
been closed and left one connection open when there were definately 2.

James

Scott Parmenter wrote:

> [email-masked] wrote:
>
> > Before I file a bug report I'd like to verify these results with others.
>
> Hadn't looked before now, but it looks like I get the same thing under TSOL
> 2.5.1.
> In fact, a quick Netscape connection didn't get recorded at all.  The
> account that
> was at the top of the list who had logged out previous to the Netscape test
> was
> still marked as logged in afterwards.  Does this have something to do with
> the
> duration of the connections?
>
> Scott

---

From: Tommaso Centro <[email-masked]>
Date: Tue, 09 Mar 1999 10:03:45 +0100

> > duration of the connections?

I don't know if it matters but i'm using ftpd (default daemon) with
Solaris 2.7 and i get exactly the same problem with "last".

Tommaso

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 9 Mar 1999 10:41:52 -0500 (EST)

On Tue, 9 Mar 1999, Tommaso Centro wrote:

> Date: Tue, 09 Mar 1999 10:03:45 +0100
> From: Tommaso Centro <[email-masked]>
> To: [email-masked]
> Subject: Re: Problem w/ Solaris /var/adm/wtmpx and /usr/bin/last(1)
> 
> James McMahon wrote:
> > 

One of my testers reports no problems at all with 'last' on 2.6 _or_ 2.7
for VR15/VR16.  Scott and (IIRC) [email-masked] are both using
"Trusted Solaris" which my tester could not test on.

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Bob Luckin <[email-masked]>
Date: Tue, 9 Mar 99 11:23:08 CST

Tommaso wrote :-

> Solaris 2.7 and i get exactly the same problem with "last".

Right !  I just ran a similar test with the vendor ftpd running on a
Solaris 2.5.1 system and I see the same behaviour that wu-ftpd shows.
So either the same problem is coded into both servers, or it is somewhere else
in the OS.

The fact that the wu-ftpd daemon does not exhibit this problem on other OS's
makes me wonder...

Cheers, Bob

---

From: "Robertson, Rocke" <[email-masked]>
Date: Tue, 09 Mar 1999 12:46:35 -0500

My 2 cents worth.

I have beta18VR16 running on 7 Solaris 2.6 systems, and 1 Solaris 2.5.1 system,
and I do not have this problem.

~rocker

--
Rocke Robertson
PWGSC/GTIS
(613)991-2604
[email-masked]

---

From: "Robertson, Rocke" <[email-masked]>
Date: Tue, 09 Mar 1999 14:42:09 -0500

Sorry, I jumped the gun, I am suffering from the same symptoms too.

~rocker