Subject: help with pathmsg syntax

From: "Pomerance, Debbie" <[email-masked]>
Date: Mon, 22 Mar 1999 16:01:42 -0500

I am curretnly using wu beta 18

The default pathmsg allowable syntax is 

path-filter guest /etc/pathmsg ^[-A-Za-z0-9._]*$ ^\. ^-

The above allows a-z, A-Z, and 0-9, and . and _; but disallows . in the
first character and - in the
first character.

I have modified it so that a tilde is allowed, as in 

path-filter guest /etc/pathmsg ^[-A-Za-z0-9._ ~]*$ ^\. ^-

What I really want to do though is allow a tilde in first charcter position
only.

Does anyone have any suggestions.

Any help is appreciated.

Debbie Pomerance  

-------------------------------------------------------------
Deborah Pomerance         (202) 226-6255
mailto:[email-masked]
Unix System Administration
U.S. House of Representatives  /  House Information Resources

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 22 Mar 1999 16:16:35 -0500 (EST)

On Mon, 22 Mar 1999, Pomerance, Debbie wrote:

> What I really want to do though is allow a tilde in first charcter
> position only.

I'd have to play with it a bit, but I'd start by trying the following:

path-filter guest /etc/pathmsg ^~?[-A-Za-z0-9._]*$ ^\. ^-

Sayeth man grep:

A regular expression matching a single character may be followed by one of
several repetition operators:
  ?      The preceding item is optional and matched at most once.

What I'd have to play with is whether the regexp functions in the daemon
support the ? operator (they should) and whether the character would need
to be in [] braces ( [~]? ).

-- 

Gregory A Lundberg              Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195