Subject: ftpwho

From: [email-masked] (Luiz Antonio de Souza)
Date: Fri, 12 Feb 1999 11:21:13 -0200

Hi users!

How I can known ftpusers (connections) during a download/upload?
I known only userid (nobody) grpid(nobody), but, wich files no...
Only after this operation I can see in xferlog...

Any hints??

Thanks

Souza
-----------------------------------------------------------
Luiz Antonio de Souza        Tel.: (011) 215-2455 Ramal 235
Coord. Suporte Servidores - SUs  Fac-simile: (011) 273-4384
SID INFORMATICA S/A.              E-mail:  [email-masked]
Sun's Partner                     URL:http://www.sid.com.br
-----------------------------------------------------------

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 12 Feb 1999 09:52:28 -0500 (EST)

On Fri, 12 Feb 1999, Luiz Antonio de Souza wrote:

> How I can known ftpusers (connections) during a download/upload? I
> known only userid (nobody) grpid(nobody), but, wich files no... Only
> after this operation I can see in xferlog...

One of the problems with ftpwho is it doesn't attempt to adjust to your
screen/window width.  I get arround the problem by doing basically the
same thing as ftpwho by hand.  Usually I wrap it in a look so it repeats
periodically as well:

#!/bin/sh
#This is for Linnux, you may need to adjust things for your system
while true; do
  clear
  uptime
  ftpcount
  echo
  ps axw | grep ftpd
  echo
  sleep 10
done

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195