Subject: BeroFTPD 1.2.3 internal ls problem?

From: Roger Hanke <[email-masked]>
Date: Tue, 16 Feb 1999 17:36:11 -0500

Dear All,
 Was wondering if anyone else has seen the below behavior
when listing out the device files in a guest or anonymous
users area. The size is reported incorrectly for the 
ls -l command when the builtin ls is being used.
Went back and checked the Beta 13 version I had been
using which kicked to an external ls of course for this
command and it does list the major minor numbers as
expected.
	Roger Hanke

BeroFTPD 1.2.3
ftp> cd dev
250 CWD command successful.
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for directory listing.
total 0
crw-rw-rw-   1 root     sys      2147483647 Jul 23  1997 tcp
crw-rw-rw-   1 root     sys             0 Jul 23  1997 zero
226 Transfer complete.
remote: -l
132 bytes received in 0.0043 seconds (30 Kbytes/s)
ftp>

Beta 13
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 0
crw-rw-rw-   1 root     sys       11,  42 Jul 23  1997 tcp
crw-rw-rw-   1 root     sys       13,  12 Jul 23  1997 zero
226 Transfer complete.
remote: -l
130 bytes received in 0.0023 seconds (56 Kbytes/s)
ftp>
-----------------------------------------------------
 Roger A. Hanke         AT&T Web Site Services
 (732)576-5738          [email-masked]
 FAX (732)576-6041      http://lynxhub.att.com/~rah/
-----------------------------------------------------

---

From: "Scott R. Every" <[email-masked]>
Date: Tue, 16 Feb 1999 17:47:24 -0500

It does the same for me, I asked about this a couple weeks ago, but 
received no answer.

s

--
Scott R. Every        "Everything is controlled by a small evil group to 
 EMJ Internet          which, unfortunately, no one we know belongs."
 voice : 1-800-548-2319  fax : 1-919-363-4423  mailto:[email-masked]
 WWW - http://www.emji.net   

Do you believe in Macintosh? Learn how to help the cause by 
subscribing to the "EvangeList" listserver! Send email to:
<[email-masked]> or go to: 
<http://www.lists.apple.com/>