Subject: RE: shutdown command w/newvirt virtual servers

From: Roger Hanke <[email-masked]>
Date: Fri, 12 Feb 1999 07:09:28 -0500

Gregory,
 Found some more notes from my past conversations
with Kent and came across a couple of the problems
we touched on below.

 First bug I had reported and he had been able to
reproduce is the ftpshut core dumps that you also
were able to reproduce it sounded like. 
He had found they were caused when it encountered
a ftpaccess file without a shutdown line in it. This 
was true once again in my case since I leave one 
server up at all times to serve my local administrators
who are working on the server. I had put a shutdown
line in all external ftpaccess files that customers can
access. By adding in a dummy shutdown line the
core dumps stopped and I was able to use ftpshut.
Turns out the ftprestart gives a number of complaints
but did actually remove all the files that ftpshut had
created. So I am able to use both of these utilities
now, with WUFTPD Beta 13 version, or BeroFTPD 1.2.3 
version.

The only thing I am still confused on was that Kent
at the time also confirmed another problem I had
reported, that he was not tearing down 
guest class connections, just real and anonymous.
This was with the Beta 15 newvirt 040 version and
he had claimed that not only would ftpshut be corrected
but he was planning to make sure the server would 
tear down all classes of connections. From my notes
this would imply that both real and anonymous classes
were getting ripped down. So not sure
why it appears when virtual servers with multiple ftpaccess
files are being used that no connections of any class
type (well I didnt test real actually, just guest and anonymous)
are being torn down. I noticed Kent put out a Beta 18 version 
of his newvirt last August. But dont know when Bernhard
picked up Kent's newvirt stuff, possibly prior to this?
Or since Kent has been tied up with real world stuff that
perhaps BeroFTPD newvirt is Kent's latest stuff and Kent
just never got to this?
	Roger 

>-----Original Message-----
>From:	Gregory A Lundberg [SMTP:[email-masked]]
>Sent:	Thursday, February 11, 1999 11:50 AM
>To:	Roger Hanke
>Cc:	WU-FTPD Discussion List; 'Kent Landfield'
>Subject:	Re: shutdown command w/newvirt virtual servers
>
>On Thu, 11 Feb 1999, Roger Hanke wrote:
>
>> When I create the shutdown file specified in each of them, access is
>> refused to new connections at the specified time. But any existing
>> connection is not taken down at the specified time (default is 5
>> minutes before shutdown time). This is regardless of whether this
>> connection was established before or after the shutdown file was put
>> into place. So no existing connections are ever ripped down. All new
>> connections after the specified time (default is 10 minutes before
>> shutdown time) are denied access until the shutdown file is removed,
>> just as expected.
>
>I believe this problem is endemic to all versions of Wu-FTPD.  I fixed
>some problems with the handling of the shutdown file(s) some time ago
>(don't remember which VR version).  As I recall, the problem was similar
>to what you've described.
>
>> Reading Kent's virtual server descriptions and mailing list mail I had
>> assumed all standard shutdown capabilities had been included in the
>> newvirt work. But now I am wondering if connections are supposed to be
>> ripped down by the server when newvirt virtual servers are being used
>> with multiple ftpaccess files?
>
>If I have fixed it and Bernard hasn't grabbed it yet blame (1) workload
>and (2) draconian pricing for telephone and Internet services in Europe.
>
>> Also had trouble getting either Beta 15 newvirt ftpshut or BeroFTPD
>> 1.2.3 ftpshut command to work properly for multiple ftpaccess files.
>> Would end up core dumping with segmentation fault after complaining:
>> Couldn't open shutdown file: No such file or directory Looking into
>> the code, which is essentially the same logic for both versions, it
>> appears if dont have permission to open file for writing would get
>> this error. But ftpshut is running as root so it should have
>> sufficient permissions. Even opened up permissions on directory to be
>> written to, to be absolutely certain. But same errors kept occurring.
>> So anyone have an idea if newvirt enhanced ftpshut ever worked
>> properly for multiple ftpaccess files?
>
>I rather doubt it since I don't think the base daemon, up to and including
>beta-18, handles shutdown correctly.  Yes, I was able to segfault and dump
>core when I was testing.  your description of debuggin sounds like what I
>went through.
>
>-- 
>
>Gregory A Lundberg		Senior Partner, VRnet Company
>1441 Elmdale Drive              [email-masked]
>Kettering, OH 45409-1615 USA    1-800-809-2195
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 12 Feb 1999 08:00:44 -0500 (EST)

Bernard used NEWVIRT-050 for BeroFTPD.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195