Subject: BeroFTPD 1.3.3 under Solaris 2.5 ...

From: The Hermit Hacker <[email-masked]>
Date: Mon, 8 Feb 1999 11:54:19 -0400 (AST)

If you do a configure --enable-pam, the configure 'check' is broken.  The
following patch fixes it...just got 'test' in the wrong place...

*** configure.in.orig	Mon Feb  8 11:06:17 1999
--- configure.in	Mon Feb  8 11:06:48 1999
***************
*** 263,269 ****
  fi
  if test "$pam" = "yes"; then
    AC_CHECK_HEADER(security/pam_appl.h)
!   if ! test "$ac_cv_header_security_pam_appl_h" = "yes"; then
      AC_MSG_ERROR(You either do not have PAM libraries or you are using incompatible ones.)
    else
      AC_DEFINE(USE_PAM)
--- 263,269 ----
  fi
  if test "$pam" = "yes"; then
    AC_CHECK_HEADER(security/pam_appl.h)
!   if test ! "$ac_cv_header_security_pam_appl_h" = "yes"; then
      AC_MSG_ERROR(You either do not have PAM libraries or you are using incompatible ones.)
    else
      AC_DEFINE(USE_PAM)

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Tue, 16 Feb 1999 15:57:11 +0100 (CET)

> following patch fixes it...just got 'test' in the wrong place...

Works both ways on most systems...
Will be fixed in 1.3.4.

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.