Subject: Do not see anything when using ls or dir on guest accounts

From: Martin Reinsprecht <[email-masked]>
Date: Fri, 19 Feb 1999 11:08:37 +0100

I am using wuftpd Version Beta 15 on a Linux System

I tried to get up running guest ftp access. I used the guest howto to get
this running.

Logging in works fine for guest user but executing ls or dir shows nothing
in the directory although there is something in.
I can also upload doenload files and create and change directories 

nlist command shows directory contents up correctly

i created a lib directory although not necessary for static links as i
understand that group FAQ and a bin directory with static link on /bin/ls
Using the ELF binaries i copied also ld.so.x into lib directory.

Thanks in advance
Martin R.

----------------------------------------------------------------------------
---------
Dipl. Ing. Dr. Martin Reinsprecht
MERLIN Dienstleistungs- und Handels- GmbH
Durisolstrasse 7
A-4600 Wels
Tel +43 7242  777870
Fax +43 7242 7778717
http://www.merlin.at
mailto://[email-masked]

---

From: "Karsten Koepp" <[email-masked]>
Date: Fri, 19 Feb 1999 11:44:45 +0100

>Using the ELF binaries i copied also ld.so.x into lib directory.

Yesterday I set up a WU-FTPd on a Solaris System, it was tricky enough for me.
Your problem is certainly that ls doesn't work within the guest chroot
environment.
Be aware that you must not use soft links to create the files in bin, etc,
dev and
usr within the guestusers home. Even for linked files the root will change.
As well it looks as if you did not copy all necessary libraries.

I will attach a listing of my copied libraries and devices, it may differ a
bit
as I use WUftp on Solaris.

# ls -lR
.:
total 10
drwxr-xr-x   2 root     other        512 Feb 19 11:12 bin
drwxr-xr-x   2 root     other        512 Feb 19 11:21 dev
drwxr-xr-x   2 root     other        512 Feb 19 11:22 etc
drwxr-xr-x   3 root     other        512 Feb 19 11:25 usr
 
./bin:
total 36
---x--x--x   1 root     other      17500 Feb 19 11:12 ls
 
./dev:
total 0
cr--r--r--   1 root     other     13,  2 Feb 19 11:21 null
cr--r--r--   1 root     other     11, 42 Feb 19 11:21 tcp
cr--r--r--   1 root     other    105,  1 Feb 19 11:21 ticoltsord
cr--r--r--   1 root     other     11, 41 Feb 19 11:21 udp
cr--r--r--   1 root     other     13, 12 Feb 19 11:21 zero
 
./etc:
total 4
-r--r--r--   1 root     other         61 Feb 19 11:23 group
-r--r--r--   1 root     other        158 Feb 19 11:23 passwd
 
./usr:
total 4
lrwxrwxrwx   1 root     other          6 Feb 19 11:25 bin -> ../bin
drwxr-xr-x   2 root     other        512 Feb 19 11:28 lib
 
./usr/lib:
total 4176
-rwxr-xr-x   1 root     other      24576 Feb 19 11:26 ld.so
-rwxr-xr-x   1 root     other     143968 Feb 19 11:26 ld.so.1
-rwxr-xr-x   1 root     other    1013232 Feb 19 11:26 libc.so.1
-rwxr-xr-x   1 root     other       4348 Feb 19 11:26 libdl.so.1
-rwxr-xr-x   1 root     other       2468 Feb 19 11:26 libintl.so.1
-rwxr-xr-x   1 root     other      19304 Feb 19 11:27 libmp.so.2
-rwxr-xr-x   1 root     other     719592 Feb 19 11:27 libnsl.so.1
-rwxr-xr-x   1 root     other      53656 Feb 19 11:27 libsocket.so.1
-rwxr-xr-x   1 root     other       6708 Feb 19 11:27 libw.so.1
-rwxr-xr-x   1 root     other       9804 Feb 19 11:28 nss_dns.so.1
-rwxr-xr-x   1 root     other      27000 Feb 19 11:28 nss_files.so.1
-rwxr-xr-x   1 root     other      30348 Feb 19 11:28 nss_nis.so.1
-rwxr-xr-x   1 root     other      35772 Feb 19 11:28 nss_nisplus.so.1
-rwxr-xr-x   1 root     other      10696 Feb 19 11:28 straddr.so.2

This configuration works for our system.

Karsten Koepp

******************************************************
Karsten Koepp			[email-masked]
SB Internet/Intranet		www.lausitznet.de

LausitzNET			Tel: 0355 / 355-1238
Lausitzer Str. 1-7		Fax: 0355 / 355-1400
03046 Cottbus