Subject: shutdown command w/newvirt virtual servers

From: Roger Hanke <[email-masked]>
Date: Thu, 11 Feb 1999 11:28:03 -0500

For those of you using or familiar with Kent's newvirt
virtual servers have a shutdown question.

Am running BeroFTPD 1.2.3 but have reproduced the
same behavior with Beta 15 newvirt version, so does
not appear to be a version issue (OS is Solaris 2.5.1).
Have a number of ftpaccess files, one for each virtual
server being run. 
When I create the shutdown file specified in each of
them, access is refused to new connections at the
specified time. But any existing connection is not
taken down at the specified time (default is 5 minutes
before shutdown time). This is regardless of whether
this connection was established before or after the
shutdown file was put into place. So no existing 
connections are ever ripped down. All new connections
after the specified time (default is 10 minutes before
shutdown time) are denied access until the shutdown 
file is removed, just as expected. 

 Reading Kent's virtual server descriptions and 
mailing list mail I had assumed all standard shutdown
capabilities had been included in the newvirt work.
But now I am wondering if connections are supposed
to be ripped down by the server when newvirt virtual
servers are being used with multiple ftpaccess files?

Also had trouble getting either Beta 15 newvirt ftpshut
or BeroFTPD 1.2.3 ftpshut command to work properly
for multiple ftpaccess files. Would end up core dumping
with segmentation fault after complaining:
Couldn't open shutdown file: No such file or directory
Looking into the code, which is essentially the same
logic for both versions, it appears if dont have
permission to open file for writing would get this error.
But ftpshut is running as root so it should have 
sufficient permissions. Even opened up permissions
on directory to be written to, to be absolutely certain.
But same errors kept occurring. So anyone have 
an idea if newvirt enhanced ftpshut ever worked properly 
for multiple ftpaccess files?

	Thanx,
	Roger
---------------------------------------------------------------
 Roger A. Hanke         AT&T Web Site Services
 (732)576-5738          [email-masked]
 FAX (732)576-6041      http://lynxhub.att.com/~rah/
---------------------------------------------------------------

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 11 Feb 1999 11:49:54 -0500 (EST)

On Thu, 11 Feb 1999, Roger Hanke wrote:

> When I create the shutdown file specified in each of them, access is
> refused to new connections at the specified time. But any existing
> connection is not taken down at the specified time (default is 5
> minutes before shutdown time). This is regardless of whether this
> connection was established before or after the shutdown file was put
> into place. So no existing connections are ever ripped down. All new
> connections after the specified time (default is 10 minutes before
> shutdown time) are denied access until the shutdown file is removed,
> just as expected.

I believe this problem is endemic to all versions of Wu-FTPD.  I fixed
some problems with the handling of the shutdown file(s) some time ago
(don't remember which VR version).  As I recall, the problem was similar
to what you've described.

> Reading Kent's virtual server descriptions and mailing list mail I had
> assumed all standard shutdown capabilities had been included in the
> newvirt work. But now I am wondering if connections are supposed to be
> ripped down by the server when newvirt virtual servers are being used
> with multiple ftpaccess files?

If I have fixed it and Bernard hasn't grabbed it yet blame (1) workload
and (2) draconian pricing for telephone and Internet services in Europe.

> Also had trouble getting either Beta 15 newvirt ftpshut or BeroFTPD
> 1.2.3 ftpshut command to work properly for multiple ftpaccess files.
> Would end up core dumping with segmentation fault after complaining:
> Couldn't open shutdown file: No such file or directory Looking into
> the code, which is essentially the same logic for both versions, it
> appears if dont have permission to open file for writing would get
> this error. But ftpshut is running as root so it should have
> sufficient permissions. Even opened up permissions on directory to be
> written to, to be absolutely certain. But same errors kept occurring.
> So anyone have an idea if newvirt enhanced ftpshut ever worked
> properly for multiple ftpaccess files?

I rather doubt it since I don't think the base daemon, up to and including
beta-18, handles shutdown correctly.  Yes, I was able to segfault and dump
core when I was testing.  your description of debuggin sounds like what I
went through.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195