Subject: Re: LOTS of TIME_WAIT

From: [email-masked] (Albert Lunde)
Date: Tue, 02 Feb 1999 14:46:53 CST

>  I had a problem for quite a while regarding TCP connections not
>  closing properly. Mine was hanging in FIN_WAIT_2 state. Running
>  HPUX, finally tracked down a patch released by HP that allowed you to 
>  configure a  kernel memory value (the "FIN_WAIT timer"). If a
>  connection was stuck in FIN_WAIT_2 for more than the timeout value
>  the connection was automatically terminated. There were times when
>  I had hundreds of finwaits, they finally ate up all the network
>  sockets and no one else could connect. Once I installed the vendor
>  os patch everything worked great.

There's some discussion of related issues in the context of the 
apache web server at:

http://www.apache.org/docs/misc/fin_wait_2.html

--
    Albert Lunde                      [email-masked]

---

From: "James B. Byrne" <[email-masked]>
Date: Thu, 4 Feb 1999 13:06:31 -0500

Can anyone help me with this?  I am trying to configure Bero on HP-UX 11.00
with gcc 2.8.1 and I am getting this error with "wtmpx".  I have 
tried to look wtmpx up with the man docs and references to it 
don't exist on my system.  What is the work around?

I have already sent this to Beroftpd-Bugs but I haven't received 
any reply.

#./configure \
>--disable-standalone \
>--enable-chmod-lim \
>--enable-internal-ls \
>--enable-passwd \
>--enable-ratios \
>--enable-transfer-cnt \
>--enable-transfer-lim \
>--enable-throughput \
>--prefix=/usr/local \
>--with-confdir=/usr/local/etc/ftpd \
>--with-logdir=/usr/local/log \
>--with-piddir=/usr/local/pid 

loading cache ./config.cache
checking host system type... hppa1.1-hp-hpux11.00
checking target system type... hppa1.1-hp-hpux11.00
checking build system type... hppa1.1-hp-hpux11.00
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for POSIXized ISC... no
checking for ranlib... ranlib
checking for bison... bison -y
checking for a BSD compatible install... ./install-sh -c
checking for ar... ar
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for usercmp... no
checking for fnmatch... yes
checking for ftw... yes
checking for getusershell... yes
checking for setuid... yes
checking for snprintf... yes
checking for strcasestr... no
checking for strdup... yes
checking for strerror... yes
checking for strsep... no
checking for strstr... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for syslog... yes
checking for glob.h... yes
checking for fnmatch.h... yes
checking for glob... yes
checking type of qsort... void
checking for pid_t... yes
checking for vfork.h... no
checking for working vfork... yes
checking for dirfd... no
checking for flock... no
checking for getcwd... yes
checking for getdtablesize... yes
checking for getrlimit... yes
checking for sysinfo... yes
checking for sysconf... yes
checking for memcpy... yes
checking for memmove... yes
checking for sigemptyset... yes
checking for regexec... yes
checking for regex... yes
checking for setreuid... yes
checking for seteuid... no
checking for setegid... no
checking for setgrent... yes
checking for strtoul... yes
checking for setcompat... no
checking for fgetpwent... yes
checking for fgetspent... no
checking for lstat... yes
checking for fchdir... yes
checking for unistd.h... yes
checking for stdlib.h... yes
checking for fcntl.h... yes
checking for dirent.h... yes
checking for ftw.h... yes
checking for regex.h... yes
checking for shadow.h... yes
checking for grp.h... yes
checking for alloca.h... yes
checking for sys/termio.h... yes
checking for sys/statvfs.h... yes
checking for sys/statfs.h... no
checking for sys/vfs.h... yes
checking for sys/systeminfo.h... no
checking for syslog.h... yes
checking for sys/syslog.h... no
checking for sys/param.h... yes
checking for limits.h... yes
checking for values.h... yes
checking for bsd/bsd.h... no
checking for posix1_lim.h... no
checking for xopen_lim.h... no
checking for confname.h... no
checking for sys/file.h... yes
checking for utmpx.h... yes
checking for sac.h... no
checking for strings.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for ndir.h... no
checking for sys/ndir.h... no
checking for sys/dir.h... yes
checking for config.h... no
checking for libgen.h... yes
checking for arpa/ftp.h... yes
checking whether time.h and sys/time.h may both be included... yes
checking how to printf an off_t... off_t is just a long - using %d
checking if openlog requires 3 arguments... yes
checking which facility openlog understands... LOG_DAEMON
checking if there is a ut_host field in the utmp structure... yes
checking if there is a ut_pid field in the utmp structure... yes
checking if there is a ut_id field in the utmp structure... yes
checking if there is a ut_name field in the utmp structure... yes
checking if there is a ut_type field in the utmp structure... yes
checking if there is a ut_exit.e_termination field in the utmp structure... yes
checking if there is a ut_syslen field in the utmpx structure... no
checking how to determine wtmpx file... configure: error: Cannot find out how to
 locate wtmpx file. Contact [email-masked].
# 

---
James B. Byrne                Harte & Lyne Limited
vox: +1 905 561 1241          9 Brockley Drive
fax: +1 905 561 0757          Hamilton, Ontario
mailto:[email-masked]  Canada L8E 3C3

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Sun, 7 Feb 1999 16:09:37 +0100 (CET)

>  locate wtmpx file. Contact [email-masked].

The configure script assumes any system with <utmpx.h> also has a wtmpx
file (which is true for almost all systems).

Try finding out if you have a wtmpx file (find / -name "wtmpx"), and tell
me where it is (of if it's missing).

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.