Subject: umask setting not possible ?

From: Timpie <[email-masked]>
Date: Thu, 04 Feb 1999 13:51:19 +0100

Hey there,

I've set up an ftp server and puzzled with the following problem.
I need users from a certain class with type guest umasked to 777
for all the files they upload to their chrooted dirs.  Unfortunately
>From what I understand only Anonymous type users can be setup
this way ... or am I mistaken ?

Any of you know something I don't, coz right now I have a cron
job scheduled every 15 minutes to chmod the files in the specific
dirs ...  Stoopid but hey at least I get the job done for now

.... anyone

--
Tim Schelfhout
Alcanet
Sys admin

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 4 Feb 1999 08:04:06 -0500 (EST)

On Thu, 4 Feb 1999, Timpie wrote:

> I've set up an ftp server and puzzled with the following problem. I
> need users from a certain class with type guest umasked to 777 for all
> the files they upload to their chrooted dirs.  Unfortunately >From
> what I understand only Anonymous type users can be setup this way ...
> or am I mistaken ?

guestgroup.  read the FAQ.

> Any of you know something I don't, coz right now I have a cron job
> scheduled every 15 minutes to chmod the files in the specific dirs ...  
> Stoopid but hey at least I get the job done for now

The VR and BeroFTPD versions also have additional umask and permission
features.  They are available from my ftp site:
ftp://ftp.vr.net/pub/wu-ftpd/

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195