Subject: FreeBSD and wuftpd

From: "J Peterson" <[email-masked]>
Date: Wed, 3 Feb 1999 11:37:29 -0500

Hi there, I'm using FreeBSD and was wondering if wuftpd will work on that
OS?
I tried build bsd but it came up with a million errors (ok, maybe half a
mil)
Any input would be appreciated.. following is the error set..

Thanks!

# build bsd
make args are :
make opts are :

Linking Makefiles.

Making support library.
cc -O -DDEBUG   -c fnmatch.c
cc -O -DDEBUG   -c strcasestr.c
cc -O -DDEBUG   -c authuser.c
In file included from authuser.c:7:
/usr/include/arpa/inet.h:71: warning: parameter has incomplete type
/usr/include/arpa/inet.h:74: warning: parameter has incomplete type
/usr/include/arpa/inet.h:78: warning: parameter has incomplete type
cc -O -DDEBUG   -c ftw.c
In file included from ftw.c:28:
/usr/include/sys/dir.h:41: warning: #warning "The information in this file
should be obtained from <dirent.h>"
/usr/include/sys/dir.h:42: warning: #warning "and is provided solely (and
temporarily) for backward compatibility."
ftw.c: In function `chwalk':
ftw.c:187: conflicting types for `malloc'
/usr/include/stdlib.h:100: previous declaration of `malloc'
*** Error code 1

Stop.

Making ftpd.
cc -O -DDEBUG -I.. -I../support -L../support -c ftpd.c
In file included from ftpd.c:116:
/usr/include/sys/dir.h:41: warning: #warning "The information in this file
should be obtained from <dirent.h>"
/usr/include/sys/dir.h:42: warning: #warning "and is provided solely (and
temporarily) for backward compatibility."
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:166: previous declaration of `realpath'
*** Error code 1

Stop.

Making ftpcount.
cc -O -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport
cc: vers.o: No such file or directory
*** Error code 1

Stop.

Making ftpshut.
cc -O -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c
vers.o -lsupport
cc: vers.o: No such file or directory
*** Error code 1

Stop.

Making ckconfig.
cc -O -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex
4096    4096    0       8192    2000    bin/ckconfig
Done

---

From: Coranth Gryphon <[email-masked]>
Date: Wed, 03 Feb 1999 12:08:42 -0800

> Hi there, I'm using FreeBSD and was wondering if wuftpd will work on 

I'm running wu-2.4.2-Beta-18 (plus the Daemon patch) quite happily
on FreeBSD 2.2.8-Release.

It compiled clean out of the box for me (except for some tweaks
to make some names in the Daemon patch not conflict).

If you like, I can make the source tarball I use available.

-coranth

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 3 Feb 1999 11:59:38 -0500 (EST)

Version numbers would help.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Wed, 3 Feb 1999 18:30:32 +0100 (CET)

> Any input would be appreciated.. following is the error set..

Any recent version should work - if it doesn't, try BeroFTPD (main
development platforms for this are Linux and FreeBSD, so it'll
definately work on FreeBSD).

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.