Subject: RE: Bero 1.3.2 login problem/ Solaris 2.4

From: Chad Price <[email-masked]>
Date: Tue, 02 Feb 1999 15:09:52 -0600

At 02:34 PM 1/29/1999 -0500, [email-masked] wrote:
>
>You show WUFTPD 2.4.2. So not any Beta version?
>If not, a lot has changed since the original WUFTPD 2.4.2
>version and that is why you are having a problem, not
>due to any BeroFTPD change. Check your ftpaccess
>specifications against the latest man page and make sure
>you have -a on ftpd command line so that you are 
>invoking ftpaccess file to begin with. 

>From inetd.conf:
#
# Sun's daemon
#ftp	stream	tcp	nowait	root	/usr/sbin/in.ftpd	in.ftpd
#  wu-ftpd 2.4.2
#ftp	stream	tcp	nowait	root	/usr/local/daemon/ftpd/ftpd	ftpd -a -u077 -l -L
# 2.4.2-beta18
ftp	stream	tcp	nowait	root	/usr/local/daemon/sbin/in.ftpd	in.ftpd -a -u077
-l -L
# Bero ftpd
#ftp	stream	tcp	nowait	root	/usr/local/sbin/BeroFTPD -a -i
telnet	stream	tcp	nowait	root	/usr/sbin/in.telnetd	in.telnetd

>Check in your
>system log file why you are being denied access.
It's not being logged.
>Pick up Beta 18 of WUFTPD if you want to test with 
>the latest WUFTPD version.

I've just had a chance to install and (very briefly) test beta-18 (not the
VR release), and it was a drop-in replacement for 2.4.2. I compiled it,
installed it, changed inetd.config to point to it, and was able to login
with no problem.  

I am using the same config files with 2.4.2, Bero, and beta-18, all of
which are the sample files shipped with Bero and 'locallized'

Any further hints would be welcome as to why, with either of the 2 most
recent Bero releases running, I am unable to login, either as a real user,
or as anonymous.  Reminder (as this is a much delayed response): System is
Solaris 2.4 with patches, compiler is gcc 2.8.1

molbio /usr/local/etc> sudo cat ftpaccess|grep -v '\#'
 
class   all   guest,anonymous  *
class   local real      *
limit   all   5   Any              /etc/msgs/msg.dead
limit   local   20 Any                  /etc/msgs/msg.dead
readme  README*    login
readme  README*    cwd=*
message /welcome.msg            login
message .message                cwd=*
compress        yes             all
tar             yes             all
log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg
email [email-masked]

Any further hints would be welcome.

Chad

Chad Price
Systems Manager
University of Nebraska Medical Center
600 S 42nd St
Omaha, NE 68506-6495
[email-masked]
(402) 559-9527 
(402) 559-4077 (FAX)

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Tue, 2 Feb 1999 23:11:43 +0100 (CET)

> >system log file why you are being denied access.

Never seen a problem like that; usually you at least get some reason in
the syslog. (Do you really get absolutely nothing? Not even a "process
12345 died with signal 11" or something?)

Is there anything odd about your system? (Updated libraries or such)
What is the exact message you get when you're told you may not login?

> System is Solaris 2.4 with patches

which patches?

> compiler is gcc 2.8.1

That should work. Nothing wrong with your ftpaccess file or inetd.conf
either.

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.