Subject: Problems with guest ftp

From: [email-masked]
Date: Fri, 12 Feb 1999 15:53:22 +0100

Hi
I´ve got a little Problem which may be has been encountert by someone else.

I´d like to configure a guest-ftp-account on an rs6000 using wu-ftp.

OS-Version is 4.2.1.0,
ftp-version is wu-ftpd-2.4.2-beta-18
and I used gnu-gcc-2_8_1_0
for building the binarys

I invoke the ftpd by
ftp     stream  tcp     nowait  root    /usr/sbin/ftpd         ftpd -a
which is working fine for an anonymous access

After reading the "guest_how_to" from Michael Brennen I created a user
ftptest looking like this:
"ftptest:!:209:201::/home/ftp/./:/etc/ftponly"
and also the directory-structure described in the how-to.
I include this user in the /etc/group
"dummy:!:201:ftptest"

I created a /etc/ftpaccess -File like this
class   all     real,guest,anonymous  *
readme  README*    login
readme  README*    cwd=*
message /welcome.msg            login
message .message                cwd=*
compress        yes             all
tar             yes             all
log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg
guestgroup      dummy

Still when trying to connect to the ftp-Server I get the following
response:
ftp 150.1.0.42
Verbunden zu 150.1.0.42.
220 dewenv01 FTP server (Version wu-2.4.2-academ[BETA-18](1) Thu Feb 11
17:38:13
 NFT 1999) ready.
Benutzer (150.1.0.42:(none)): ftptest
530 User ftptest access denied.
Anmeldung fehlgeschlagen.
Ftp>

I have to admit that I´ve got no experience at all in the ftp-business.

Maybe someone has experienced the same problems and can help me out.

Thanx´s in advance

Greetings
Elmar Handke

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 12 Feb 1999 10:32:16 -0500 (EST)

First guess: did you remember to kill -HUP the inetd process so your
changes would take effect?

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195