Subject: My guest users don't get chroot'ed

From: Omar Keblawi <[email-masked]>
Date: Wed, 13 Jan 1999 19:00:35 -0800

I'm just setting things up using (Version wu-2.4.2-academ[BETA-18].

The Anonymous ftp user seems to work fine and is chrooted.  But my
guest users are not chrooted.  

I've included the notation "/./" and put the tree structure in place.  
I used hard links under ~ftp to link to the tree under
/export/home/ftphome 
for all the dev, bin, and lib files.  And I'm starting in.fptd with "-a"
option.

How do I get the guest users to be chroot'ed?

ncdesign:x:400:400:FTP
account:/export/home/ftphome/./ncdesign:/bin/false
nrcatest:x:401:401:NRCA TEST:/export/home/ftphome/./nrcatest:/bin/false
ftp:x:500:500:Anonymous FTP:/export/home/ftphome/ftp/./pub:/bin/false

ftpsrvr# pwd
/export/home/ftphome

./ncdesign
./ncdesign/.rhosts
./ncdesign/.forward
./ncdesign/dns.info
./nrcatest
./nrcatest/.forward
./nrcatest/.rhosts
./ftp
./ftp/bin
./ftp/bin/ls
./ftp/dev
./ftp/dev/tcp
./ftp/dev/zero
./ftp/etc
./ftp/etc/group
./ftp/etc/passwd
./ftp/usr
./ftp/usr/lib
./ftp/usr/lib/ld.so
./ftp/usr/lib/ld.so.1
./ftp/usr/lib/libc.so.1
./ftp/usr/lib/libdl.so.1
./ftp/usr/lib/libintl.so.1
./ftp/usr/lib/libw.so.1
./ftp/pub
./ftp/incoming
./etc
./etc/passwd
./etc/group
./bin
./bin/ls
./dev
./dev/tcp
./dev/zero
./lib
./lib/ld.so
./lib/ld.so.1
./lib/libc.so.1
./lib/libdl.so.1
./lib/libintl.so.1
./lib/libw.so.1

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 14 Jan 1999 03:22:55 -0500 (EST)

> guest users are not chrooted.

Add -a to the command line and kill -HUP inet.  You're not using the
ftpaccess file, most likely.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195