Subject: permitting real user access from localhost and anon access from everywhere

From: Dan Roscigno <[email-masked]>
Date: Wed, 27 Jan 1999 16:18:08 -0500 (EST)

I would like to allow "real" users access to ftp from
localhost only ( actually tunnelling through ssh so the
connections appear to be from localhost).  I would like to
allow anonymous access from any host.

Can someone help me with the config files?

Thanks,
Dan
---------------------------------------------------------
Dan Roscigno [email-masked] (352)392-4028
Physics Dept. University of Florida 2122 New Physics Building

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 27 Jan 1999 16:37:21 -0500 (EST)

On Wed, 27 Jan 1999, Dan Roscigno wrote:

> I would like to allow "real" users access to ftp from localhost only (
> actually tunnelling through ssh so the connections appear to be from
> localhost).  I would like to allow anonymous access from any host.

Define a class for local real and another for anon everywhere:

class localreal real localhost
class anyanon anonymous *

guests will be refused (not in any class)
real users from anywhere other than 'localhost' will be refused as well
(not in any class either).
anonymous from anywhere will be allowed.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195