Subject: Anonymous rootdir problem with BeroFTPD 1.2.3

From: Roger Hanke <[email-masked]>
Date: Tue, 26 Jan 1999 22:21:18 -0500

Hello All,
 Successfully upgraded from WUFTPD Beta 13 with 
Kent's newvirt patch to BeroFTPD 1.2.3 and everything
worked fine except one thing.
 I use the full virtual server setup with ftpservers directing
different IPs to different ftpaccess files. These unique
ftpaccess files all have unique root and logfile directives
in them so each different IP is chrooted to different 
area. Guest accounts that are also unique to each ftpaccess
file work fine. Also know I am getting to the correct 
ftpaccess file since each has a unique banner line in 
it. Only problem is when I use ftp or anonymous to 
access the same IP I end up being chrooted to 
the home directory of ~ftp as taken from the /etc/passwd
file. Instead of being chrooted to the root location specified
in that directive (root /home/testftp/anonymous).
 These files were not changed at all when I converted
servers and they still work fine with patched Beta 13 
version. So I suspect there is some other difference 
in the later versions that I need to compensate for.
Does this type of problem ring any bells with anyone?
	Thanx,
	Roger Hanke

---------------------------------------------------------------
 Roger A. Hanke         AT&T Web Site Services
 (732)576-5738          [email-masked]
 FAX (732)576-6041      http://lynxhub.att.com/~rah/
---------------------------------------------------------------

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Wed, 27 Jan 1999 13:38:21 +0100 (CET)

On Tue, 26 Jan 1999, Roger Hanke wrote:

> Only problem is when I use ftp or anonymous to 
> file.

Use the anonymous-root directive in your virtual ftpaccess files. (man
ftpaccess).

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.