Subject: allowing clients to create symlinks. Not working.

From: "Robertson, Rocke" <[email-masked]>
Date: Thu, 28 Jan 1999 16:13:42 -0500

I have moved ln to the ftp root. It has permissions of 555. I have added
these lines to /etc/ftpaccess,

ln     yes local
ln     no remote

Here is what the log says is happening.

Jan 28 16:10:29 woody ftpd[28218]: SITE EXEC (lines: 0): ln -s it ftpd
Jan 28 16:10:29 woody ftpd[28218]: SITE EXEC (lines: 0): ln -s it ftpd

But nothing is happening. Has anyone tried this before, or am I just
waisting my time.
THanks

--
Rocke Robertson
PWGSC/GTIS
(613)991-2604
[email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 28 Jan 1999 17:22:57 -0500 (EST)

On Thu, 28 Jan 1999, Robertson, Rocke wrote:

> I have moved ln to the ftp root. It has permissions of 555. I have
> added these lines to /etc/ftpaccess,
> 
> ln     yes local
> ln     no remote

These won't do anything.  There are not 'ln' clauses in the ftpaccess
file.  Read the manpage for what you can put in there.

> But nothing is happening. Has anyone tried this before, or am I just

SITE EXEC? Yeah, I've used it to test that it really does work.

Are you wasting your time?  Probably.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195