Subject: debugging pasv ports usage

From: Roger Hanke <[email-masked]>
Date: Thu, 14 Jan 1999 20:12:46 -0500

Gregory,
 Thank you for your help with the new passive ports
directive. So now I believe I have the correct range of
ports specified to be used for pasv client commands.

 But with WUFTPD Beta 13 I had been using debug 
mode and looking for the pasv command in the syslog
to verify what port was actually being returned and that
it really was in the valid range expected.
Using the same exact system, and debug settings
I can not get those debug statements showing up in
the syslog using BeroFTPD 1.2.3.
For instance below I show just a short sequence from 
the syslog first showing just a logon to Beta 13 then a
logon to BeroFTPD 1.2.3. Both of them are using the
same command line options, just running on different
ports on the same box: -adlLu007
Even tried turning d to v option on command line for 
BeroFTPD but still no debug statements.
Finally added log commands to my ftpaccess files and
this again produced more statements for both versions
but the BeroFTPD just said PASV and did not show the
port number like the Beta 13 did:

Jan 14 20:09:44 hdpst01 ftpd[12370]: PASV
Jan 14 20:09:44 hdpst01 ftpd[12370]: PASV
Jan 14 20:09:44 hdpst01 ftpd[12370]: PASV trying 27828
Jan 14 20:09:44 hdpst01 ftpd[12370]: PASV got 27828
Jan 14 20:09:44 hdpst01 ftpd[12370]: <--- 227
Jan 14 20:09:44 hdpst01 ftpd[12370]: Entering Passive Mode
(135,25,216,12,108,180)

 So has anything changed in this area, in terms of
getting debug statements out?
	Thanx,
	Roger Hanke

Jan 14 19:55:18 hdpst01 ftpd[11882]: <--- 331
Jan 14 19:55:18 hdpst01 ftpd[11882]: Password required for ew3ftp.
Jan 14 19:55:21 hdpst01 ftpd[11882]: command: PASS password
Jan 14 19:55:21 hdpst01 ftpd[11882]: <--- 230
Jan 14 19:55:21 hdpst01 ftpd[11882]: User ew3ftp logged in.  Access
restrictions apply.
Jan 14 19:55:21 hdpst01 ftpd[11882]: FTP LOGIN FROM lynxhub
[135.25.204.10], ew3ftp
Jan 14 19:55:21 hdpst01 ftpd[11882]: FTP LOGIN FROM lynxhub
[135.25.204.10], ew3ftp
Jan 14 19:55:59 hdpst01 ftpd[11882]: command: QUIT
Jan 14 19:55:59 hdpst01 ftpd[11882]: <--- 221
Jan 14 19:55:59 hdpst01 ftpd[11882]: Goodbye.
Jan 14 19:55:59 hdpst01 ftpd[11882]: FTP session closed
Jan 14 19:55:59 hdpst01 ftpd[11882]: FTP session closed
Jan 14 19:56:22 hdpst01 ftpd[11920]: VirtualFTP Connect to:
135.25.216.12
Jan 14 19:56:22 hdpst01 ftpd[11920]: VirtualFTP Connect to:
135.25.216.12
Jan 14 19:56:22 hdpst01 ftpd[11920]: VirtualFTP Connect to:
135.25.216.12
Jan 14 19:56:31 hdpst01 ftpd[11920]: FTP LOGIN FROM lynxhub
[135.25.204.10], ew3ftp
Jan 14 19:56:31 hdpst01 ftpd[11920]: FTP LOGIN FROM lynxhub
[135.25.204.10], ew3ftp 
---------------------------------------------------------------
 Roger A. Hanke         AT&T Web Site Services
 (732)576-5738          [email-masked]
 FAX (732)576-6041      http://lynxhub.att.com/~rah/
---------------------------------------------------------------

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 15 Jan 1999 07:20:43 -0500 (EST)

On Thu, 14 Jan 1999, Roger Hanke wrote:

> But with WUFTPD Beta 13 I had been using debug mode and looking for
> the pasv command in the syslog to verify what port was actually being
> returned and that it really was in the valid range expected. Using the
> same exact system, and debug settings I can not get those debug
> statements showing up in the syslog using BeroFTPD 1.2.3.

> So has anything changed in this area, in terms of getting debug
> statements out?

You'l have to ask Bernard directly if he changed anything.  I'll take a
look at the base code later today to see if anything changed from beta 13
to 18.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195