Subject: static ls

From: Morvan Daniel Muller <[email-masked]>
Date: Tue, 19 Jan 1999 16:38:23 -0200 (EDT)

Hello!

I follow this page http://www.wildheart.org/wu-ftpd/#tips SECTION:Compiling a static version of "ls"

get fileutils-3.16 from ftp.gnu.org/ganu/fileutils          (/usr/local/src/fileutils-3.16)
get http://www.phix.com/~minerva/wu-ftpd/static-ls.patch    (/usr/local/src/static-ls.patch)
#  cd /usr/local/src
# gzip -d fileutils-3.1.tar.gz
# tar -xvf fileutils-3.16.tar
# cd fileutils-3.16
# ./configure 

# patch < static-ls.patch
  Looks like a new-style context diff.
File to patch: static-ls.patch
Hunk #1 failed at line 68.
Hunk #2 failed at line 87.
Hunk #3 failed at line 136.
3 out of 3 hunks failed: saving rejects to static-ls.patch.rej
  The next patch looks like a new-style context diff.
Malformed patch at line 293:
patch: Line must begin with '+ ', '  ', or '! '.

what I can do?

[]'s

Morvan Daniel Muller          
[email-masked]
Santa Cruz do Sul - RS

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 19 Jan 1999 14:34:32 -0500 (EST)

On Tue, 19 Jan 1999, Morvan Daniel Muller wrote:

> I follow this page http://www.wildheart.org/wu-ftpd/#tips
> SECTION:Compiling a static version of "ls"
> 

That depends upon the platform you're running on.  I'd recommend starting
with the FAQ.  Also, many of those "make a static ls" patches are
platform-specific (usually Solaris is what I've seen them for), so you may
not have even needed the patch.  For instance on Linux all you'd need to
is `make LDFLAGS=-static ls` and you'd have a statically linked 'ls'
command.

And you'd have a statically linked 'ls' command.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195