Subject: DU4 compiled successfully but fail to login

From: "Zbigniew" <[email-masked]>
Date: Mon, 11 Jan 1999 07:36:17 -0600

wu-ftpd compiles fine, but I can't login.  I am using Digital Unix 4.0D-C2 Security with wu-ftpd-vr12.

****syslog output

Jan 11 07:20:16 trans-sit1 ftpd[7800]: USER zbigniew
Jan 11 07:20:20 trans-sit1 ftpd[7800]: PASS password
Jan 11 07:20:20 trans-sit1 ftpd[7800]: failed login from trans-sit1 [XXX.XXX.XXX.XXX], zbigniew
Jan 11 07:20:20 trans-sit1 ftpd[7800]: cmd failure - not logged in
Jan 11 07:20:20 trans-sit1 ftpd[7800]: SYST
Jan 11 07:20:21 trans-sit1 ftpd[7800]: QUIT
Jan 11 07:26:30 trans-sit1 ftpd[7853]: failed login from trans-sit1 [128.126.167.195], zbigniew

**** I wanted to install wu-ftpd into /usr/local so I changed the Makefile.du4

BINDIR=         /usr/local/sbin
ETCDIR=         /etc
MANDIR=         /usr/local/man
MANEXT=         8
INSTALL=        /usr/ucb/installbsd

**** My inetd.conf entry.  I had used the -a, but that didn't work either.

ftp     stream  tcp     nowait  root    /usr/local/sbin/tcpd    /usr/local/sbin/ftpd -d

**** Here is the actual build.

root@trans-sit1:/usr/local/wu-ftpd-2.4.2-beta-18-vr12> ./build du4
make args are : 
make opts are : 

Copying Makefiles.

Linking src/config.h

Making support library.
cc -O   -DDEC -c getusershell.c
cc -O   -DDEC -c fnmatch.c
cc -O   -DDEC -c strcasestr.c
cc -O   -DDEC -c strerror.c
cc -O   -DDEC -c strsep.c
cc -O   -DDEC -c authuser.c
cc -O   -DDEC -c snprintf.c
rm -f libsupport.a
ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strerror.o  strsep.o authuser.o snprintf.o
ranlib libsupport.a

Making ftpd.
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c ftpd.c
cc: Warning: ftpd.c, line 502: Strict ANSI C extension: The declaration of the "main" function has more than two parameters.
int
^
yacc  ftpcmd.y
mv  y.tab.c ftpcmd.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c ftpcmd.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c glob.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c logwtmp.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c popen.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c vers.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c access.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c extensions.c
cc: Warning: extensions.c, line 1853: In this statement, the referenced type of the pointer value "&quota" is "struct dqblk", which is not compatible with "char".
  quotactl(fs,QCMD(Q_GETQUOTA,USRQUOTA),uid,&quota);
--^
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c realpath.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c acl.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c private.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c authenticate.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c conversions.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c hostacc.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c sigfix.c
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c routevector.c
cc -std1 -L../support -s -x -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o authenticate.o conversions.o hostacc.o  sigfix.o routevector.o  -lsupport

Making ftpcount.
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c ftpcount.c
cc -std1 -L../support -s -x -o ftpcount ftpcount.o vers.o

Making ftpshut.
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c ftpshut.c
cc -std1 -L../support -s -x -o ftpshut ftpshut.o vers.o

Making ckconfig.
cc -std1 -O -I.. -I../support -Olimit 1000 -DVIRTUAL -L../support -s -x -c ckconfig.c
cc -std1 -L../support -s -x -o ckconfig ckconfig.o

Executables are in bin directory:
text    data    bss     dec     hex
180224  40960   38096   259280  3f4d0   bin/ftpd
16384   8192    0       24576   6000    bin/ftpcount
16384   8192    0       24576   6000    bin/ftpshut
16384   8192    0       24576   6000    bin/ftpwho
8192    8192    0       16384   4000    bin/ckconfig
Done

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 11 Jan 1999 09:25:17 -0500 (EST)

> [XXX.XXX.XXX.XXX], zbigniew

This is from pass() in ftpd.c and occurs after the password entered fails
to match the password on file.  You're not in CAPS LOCK are you?

Some systems have magical incantations you need to invoke when you create
a new user or install a new privileged program, did you do all that?

> Jan 11 07:20:20 trans-sit1 ftpd[7800]: cmd failure - not logged in

This is from VR12 and was caused by the SYST command being sent after the
PASS failed.  It can be ignored in this case.

> cc: Warning: ftpd.c, line 502: Strict ANSI C extension: The
> declaration of the "main" function has more than two parameters.

I don't think anything can be done about this.  It is safely ignored.

> cc: Warning: extensions.c, line 1853: In this statement, the
> referenced type of the pointer value "&quota" is "struct dqblk", which
> is not compatible with "char".

This is safely ignored.  Maybe one of you DU4 people can take a look at
the code and correct things.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: 襄樊热线 <[email-masked]>
Date: Tue, 12 Jan 1999 14:16:39 +0800

Hello all:

    Could you tell me how to make WU-FTPD support Resume
downloading,Resume uploading!

Thanks!

xfonline/99.1.12

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 12 Jan 1999 07:11:07 -0500 (EST)

On Tue, 12 Jan 1999, [gb2312] �差���� wrote:

> downloading, Resume uploading!

Easy enough.  Install it.

--

---

From: Brett Goldstock <[email-masked]>
Date: Tue, 12 Jan 1999 10:27:55 -0500

So am I to assume from this response that this is built into WU-FTPD? 
Is there any detail available on this?

At 7:11 AM -0500 1/12/99, Gregory A Lundberg wrote:
> On Tue, 12 Jan 1999, [gb2312] ¦Â…Æ»»¦þ wrote:
>

|Brett M. Goldstock                               [email-masked]|
|Senior Technical Analyst/Sys Admin          http://www.tvdata.com|
|TVData                                               800/833-9581|
|                "We tell the world what's on TV."                |

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 12 Jan 1999 12:24:27 -0500 (EST)

> >> downloading, Resume uploading!

RFC 959

I have a copy at ftp://ftp.vr.net/pub/wu-ftpd/rfc0959.txt or you get get
your own copy from http://www.rfc-editor.org/

--