Subject: wuftpd in client under nisplus

From: Priron <[email-masked]>
Date: Fri, 22 Jan 1999 21:19:35 +0800 (HKT)

I have a problem to login to home directory with login, but there is no problem for anonymous user.
My machine is solairs 2.6. and it is a client under nisplus tree (not root machine and not replica machine).
I go through the source in ftpd.c file. There is no code to get authentication from root or replica machine under nisplus environment.
Any suggest that can help me to configure ?

Priron

---

From: Jason Spears <[email-masked]>
Date: Fri, 22 Jan 1999 17:25:45 -0500 (EST)

AFAIK nisplus should be invisible to wu-ftpd.  Make sure your FTP server
machine has the correct settings in /etc/nsswitch.conf, should probably be:

  passwd:  files nisplus

and maybe also:

  group:  files nisplus

If you can telnet into the machine using an account that exists in
nisplus but not in your passwd file, the configuration problem may
be in config.h in the wu-ftpd distribution; make sure you have
the line

  #undef ANON_ONLY

otherwise real users won't be able to login to the machine via FTP.

Hope this helps,

Jason Spears