Subject: Troubles compiling ftpd on Solaris 2.6

From: [email-masked]
Date: Mon, 18 Jan 1999 12:39:45 -0600

I am unable to succesfully run the "build sol" command on a Solaris
     2.6 system.  When I run the same command on a Solaris 2.5.1 system
     there are no errors.

     I have ran the build with the original ftp.h and with the ftp.h that
     came with the wu-ftpd tar file and both failed.  I am not a
     programmer, so any help you can give me would be very much appricated.

     This is the first time I have sent a request to this address.  If I
     should be sending it to another address, please let me know.

     Scott

     ************************
     Output from the "build sol" command.
     ************************

     sunsi:390:/tmp/ftp/wu-ftpd-2.4# ./build sol
     make args are :
     make opts are :

     Linking Makefiles.
     ln: makefiles/Makefile.sol and Makefile are identical
     ln: config/config.sol and config.h are identical
     ln: makefiles/Makefile.sol and Makefile are identical

     Making support library.
     rm -f libsupport.a
     ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o touch
     libsupport.a

     Making ftpd.
     cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
     ftpd.c:143: conflicting types for `realpath'
     /usr/include/stdlib.h:180: previous declaration of `realpath' make:
     *** [ftpd.o] Error 1

     Making ftpcount.
     cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
     vers.o -lsupport -lsocket -lnsl -lgen
     cc: vers.o: No such file or directory
     make: *** [ftpcount] Error 1

     Making ftpshut.
     cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c
     vers.o -lsupport -lsocket -lnsl -lgen
     cc: vers.o: No such file or directory
     make: *** [ftpshut] Error 1

     Making ckconfig.
     make: `ckconfig' is up to date.
     ln: ../src/ckconfig and ckconfig are identical

     Links to executables are in bin directory:
     size: bin/ftpd: No such file or directory
     size: bin/ftpcount: No such file or directory
     size: bin/ftpshut: No such file or directory
     size: bin/ftpwho: No such file or directory
     text       data    bss     dec     hex     filename
     7283       560     372     8215    2017    bin/ckconfig
     Done

     *********************
     End of output file.
     *********************

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 18 Jan 1999 14:04:46 -0500 (EST)

On Mon, 18 Jan 1999 [email-masked] wrote:

> Date: Mon, 18 Jan 1999 12:39:45 -0600

I believe this is an FAQ.  Add the following line to the end of
src/config/config.sol on the 2.6 system:

#define realpath realpath_on_steroids   /* hack to work around unistd.h */

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195