Subject: Problems with wu-ftpd

From: FATHI BEN NASR <[email-masked]>
Date: Mon, 25 Jan 1999 14:05:12 +0100

I am trying to build an Intranet. I have, successfully, installed
wu-ftpd-2.4.2-beta-18 and I can get to my server with ftp://193.94.6.200
for another Linux machine and in ms-dos mode from windows95. I can also
get the welcome message from msie3.0 or communicator4.5 when typing the
IP adress in the title bar.
Things go bad when I try to go to ftp://ftp.sfa.com (wich has an entry
in my DNS files). So I get the following message from a windows95
workstation:

msie3.0's message:
220 server.sfa.com FTP server () ready.
500 'GET ftp://ftp.sfa.com/ HTTP/1.0': command not understood.
500 'PRAGMA: No-Cache': command not understood.
500 'USER-AGENT: Mozilla/2.0 (compatible; MSIE 3.0; Windows 95)':
command not understood.
500 'HOST: ftp.sfa.com': command not understood.
500 'PROXY-CONNECTION: Keep-Alive': command not understood.
500 '': command not understood.

communicator 4.5 gives me a time out error message when asked for
ftp://ftp.sfa.com or the index.html file of www.sfa.com when apache
1.3.4 is running.

I am using slackware 3.3.0 with a kernel patched to 2.0.36.

I enclosed all my rc and nemed files - and some others -  to give, who
wants to help me, more information about my configuration.

The wu-ftp deamon seems to be started from inetd.conf, but I get no ftp
entry from a ps command.

Fathi Ben Nasr.
Sorry for hopping your mailboxes with all this files.

directory	/etc
primary		0.0.127.IN-ADDR.ARPA		named.local
primary		sfa.com				named.hosts
primary		006.094.193.IN-ADDR.ARPA	named.rev

@	IN	SOA	sfa.com.	root.sfa.com.	(
	1999012001
	3600
	300
	3600000
	14400	)
IN	NS	server.sfa.com.
www	IN	A	193.094.006.200
mail	IN	A	193.094.006.200
news	IN	A	193.095.006.200
ftp	IN	A	193.094.006.200
server	IN	A	193.094.006.200

@	IN	SOA	sfa.com.	root.sfa.com.	(
	1999012001
	3600
	300
	3600000
	14400	)
IN	NS	server.sfa.com.
1	IN	PTR	localhost.

@	IN	SOA	sfa.com.	root.sfa.com.	(
	1999012001
	3600
	300
	3600000
	14400	)
IN	NS	www.sfa.com.
200	IN	PTR	www.sfa.com.
200	IN	PTR	ftp.sfa.com.
200	IN	PTR	mail.sfa.com.
200	IN	PTR	news.sfa.com.
200	IN	PTR	server.sfa.com

#! /bin/sh
#
# rc.6		This file is executed by init when it goes into runlevel
#		0 (halt) or runlevel 6 (reboot). It kills all processes,
#		unmounts file systems and then either halts or reboots.
#
# Version:	@(#)/etc/rc.d/rc.6	1.50	1994-01-15
#
# Author:	Miquel van Smoorenburg <[email-masked]>
# Modified by:  Patrick J. Volkerding, <[email-masked]>
#

  # Set the path.
  PATH=/sbin:/etc:/bin:/usr/bin

  # Set linefeed mode to avoid staircase effect.
  stty onlcr

  echo "Running shutdown script $0:"

  # Find out how we were called.
  case "$0" in
	*0)
		message="The system is halted."
		command="halt"
		;;
	*6)
		message="Rebooting."
		command=reboot
		;;
	*)
		echo "$0: call me as \"rc.0\" or \"rc.6\" please!"
		exit 1
		;;
  esac

  # Kill all processes.
  # INIT is supposed to handle this entirely now, but this didn't always
  # work correctly without this second pass at killing off the processes.
  # Since INIT already notified the user that processes were being killed,
  # we'll avoid echoing this info this time around.
  if [ "$1" != "fast" ]; then # shutdown did not already kill all processes
    killall5 -15 
    killall5 -9
  fi

  # Try to turn off quota and accounting.
  if [ -x /usr/sbin/quotaoff ]
  then
	echo "Turning off quota."
	/usr/sbin/quotaoff -a
  fi
  if [ -x /sbin/accton ]
  then
	echo "Turning off accounting."
	/sbin/accton
  fi

  # Before unmounting file systems write a reboot or halt record to wtmp.
  $command -w

  # Save localtime
  [ -e /usr/lib/zoneinfo/localtime ] && cp /usr/lib/zoneinfo/localtime /etc

  # Asynchronously unmount any remote filesystems:
  echo "Unmounting remote filesystems."
  umount -a -tnfs &

  # Turn off swap, then unmount local file systems.
  echo "Turning off swap."
  swapoff -a
  echo "Unmounting local file systems."
  umount -a -tnonfs
  # Don't remount UMSDOS root volumes:
  if [ ! "`mount | head -1 | cut -d ' ' -f 5`" = "umsdos" ]; then
    mount -n -o remount,ro /
  fi

  # See if this is a powerfail situation.
  if [ -f /etc/power_is_failing ]; then
    echo "Turning off UPS, bye."
    /sbin/powerd -q
    exit 1
  fi

  # Now halt or reboot.
  echo "$message"
  [ ! -f /etc/fastboot ] && echo "On the next boot fsck will be FORCED."
  $command -f

#! /bin/sh
#
# rc.4		This file is executed by init(8) when the system is being
#		initialized for run level 4 (XDM)
#
# Version:	@(#)/etc/rc.d/rc.4	2.00	02/17/93
#
# Author:	Fred N. van Kempen, <[email-masked]>
#

# Tell the viewers what's going to happen...
echo "Starting up the X Window System V.11 R.6..."

# Call the "xdm" program.
exec /usr/X11R6/bin/xdm -nodaemon

# All done.

#! /bin/sh
#
# rc.6		This file is executed by init when it goes into runlevel
#		0 (halt) or runlevel 6 (reboot). It kills all processes,
#		unmounts file systems and then either halts or reboots.
#
# Version:	@(#)/etc/rc.d/rc.6	1.50	1994-01-15
#
# Author:	Miquel van Smoorenburg <[email-masked]>
# Modified by:  Patrick J. Volkerding, <[email-masked]>
#

  # Set the path.
  PATH=/sbin:/etc:/bin:/usr/bin

  # Set linefeed mode to avoid staircase effect.
  stty onlcr

  echo "Running shutdown script $0:"

  # Find out how we were called.
  case "$0" in
	*0)
		message="The system is halted."
		command="halt"
		;;
	*6)
		message="Rebooting."
		command=reboot
		;;
	*)
		echo "$0: call me as \"rc.0\" or \"rc.6\" please!"
		exit 1
		;;
  esac

  # Kill all processes.
  # INIT is supposed to handle this entirely now, but this didn't always
  # work correctly without this second pass at killing off the processes.
  # Since INIT already notified the user that processes were being killed,
  # we'll avoid echoing this info this time around.
  if [ "$1" != "fast" ]; then # shutdown did not already kill all processes
    killall5 -15 
    killall5 -9
  fi

  # Try to turn off quota and accounting.
  if [ -x /usr/sbin/quotaoff ]
  then
	echo "Turning off quota."
	/usr/sbin/quotaoff -a
  fi
  if [ -x /sbin/accton ]
  then
	echo "Turning off accounting."
	/sbin/accton
  fi

  # Before unmounting file systems write a reboot or halt record to wtmp.
  $command -w

  # Save localtime
  [ -e /usr/lib/zoneinfo/localtime ] && cp /usr/lib/zoneinfo/localtime /etc

  # Asynchronously unmount any remote filesystems:
  echo "Unmounting remote filesystems."
  umount -a -tnfs &

  # Turn off swap, then unmount local file systems.
  echo "Turning off swap."
  swapoff -a
  echo "Unmounting local file systems."
  umount -a -tnonfs
  # Don't remount UMSDOS root volumes:
  if [ ! "`mount | head -1 | cut -d ' ' -f 5`" = "umsdos" ]; then
    mount -n -o remount,ro /
  fi

  # See if this is a powerfail situation.
  if [ -f /etc/power_is_failing ]; then
    echo "Turning off UPS, bye."
    /sbin/powerd -q
    exit 1
  fi

  # Now halt or reboot.
  echo "$message"
  [ ! -f /etc/fastboot ] && echo "On the next boot fsck will be FORCED."
  $command -f

#
# /etc/rc.d/rc.cdrom
# This script searches for a CD-ROM on the known Linux CD devices.
# If one is found, it is mounted under $MOUNTPOINT.
#
# It can make some darn annoying error messages though, so it's no
# longer executable by default.  If you want it on, do this:
#
#   chmod 755 rc.cdrom
#

MOUNTPOINT="/cdrom"
unset SKIP
if mount | fgrep "on $MOUNTPOINT " 1> /dev/null 2> /dev/null ; then
  SKIP=1
elif [ ! -d $MOUNTPOINT ]; then
  SKIP=1
fi
if [ ! "$SKIP" = "1" ]; then
  unset MOUNT
  echo -n "Checking for a CD... "
  for device in cdrom scd0 scd1 hdd hdc hdb hda hde hdf hdg hdh \
  sonycd cdu535 mcd sbpcd aztcd cm206cd gscd0 mcdx0 mcdx1 optcd0 \
  sjcd lmscd ; do # check for a CD-ROM drive with a disc in it.
    if mount -t iso9660 -o ro /dev/$device $MOUNTPOINT 1> /dev/null 2> /dev/null ; then
      MOUNT=1
      if [ ! "$device" = "cdrom" ]; then
        rm -f /dev/cdrom
        ln -sf /dev/$device /dev/cdrom
      fi
      break;
    fi
  done
  if [ "$MOUNT" = "1" ]; then # mount successful
    echo "found on /dev/$device."
    if [ -d /cdrom/rootdsks.144 -o -d /cdrom/rootdsks ]; then # Slackware CD-ROM is mounted.
      echo "    Mounting Slackware Linux CD-ROM under $MOUNTPOINT."
    else
      echo "    Mounting unknown ISO9660 CD-ROM under $MOUNTPOINT."
    fi
  else
    echo "no CD found."
  fi
fi

#! /bin/sh
#
# rc.inet1	This shell script boots up the base INET system.
#
# Version:	@(#)/etc/rc.d/rc.inet1	1.01	05/27/93
#

HOSTNAME=`cat /etc/HOSTNAME`

# Attach the loopback device.
/sbin/ifconfig lo 127.0.0.1
/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo

# IF YOU HAVE AN ETHERNET CONNECTION, use these lines below to configure the 
# eth0 interface. If you're only using loopback or SLIP, don't include the
# rest of the lines in this file.

# Edit for your setup.
IPADDR="193.94.6.200"	# REPLACE with YOUR IP address!
NETMASK="255.255.255.0"	# REPLACE with YOUR netmask!
NETWORK="193.94.6.0"	# REPLACE with YOUR network address!
BROADCAST="193.94.6.255"	# REPLACE with YOUR broadcast address, if you
			# have one. If not, leave blank and edit below.
GATEWAY="193.94.6.100"	# REPLACE with YOUR gateway address!

# Uncomment the line below to configure your ethernet card.
/sbin/ifconfig eth0 ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}

# If the line above is uncommented, the code below can also be uncommented.
# It sees if the ethernet was properly initialized, and gives the admin some
# hints about what to do if it wasn't.
if [ ! $? = 0 ]; then
  cat << END
Your ethernet card was not initialized properly.  Here are some reasons why this
may have happened, and the solutions:
1. Your kernel does not contain support for your card.  Including all the 
   network drivers in a Linux kernel can make it too large to even boot, and
   sometimes including extra drivers can cause system hangs.  To support your
   ethernet, either edit /etc/rc.d/rc.modules to load the support at boottime,
   or compile and install a kernel that contains support.
2. You don't have an ethernet card, in which case you should comment out this
   section of /etc/rc.d/rc.inet1.  (Unless you don't mind seeing this error...)
END
fi

# Uncomment these to set up your IP routing table.
/sbin/route add -net ${NETWORK} netmask ${NETMASK} eth0
if [ ! "$GATEWAY" = "" ]; then
 /sbin/route add default gw ${GATEWAY} netmask 0.0.0.0 metric 1
fi

# End of rc.inet1

#!/bin/sh
#
# rc.inet2	This shell script boots up the entire INET system.
#		Note, that when this script is used to also fire
#		up any important remote NFS disks (like the /usr
#		distribution), care must be taken to actually
#		have all the needed binaries online _now_ ...
#
# Author:	Fred N. van Kempen, <[email-masked]>
#

# Constants.
NET="/usr/sbin"
IN_SERV="lpd"
LPSPOOL="/var/spool/lpd"

# At this point, we are ready to talk to The World...
echo "Mounting remote file systems..."
/sbin/mount -a -t nfs		# This may be our /usr runtime!!!

echo -n "Starting daemons:"

# Start the SYSLOGD/Klogd daemons.  These must come first.
if [ -f ${NET}/syslogd ]; then
  echo -n " syslogd"
  ${NET}/syslogd & # Backgrounded to avoid an ugly notice from bash-2.0
  echo -n " klogd"
  ${NET}/klogd
fi

# Start the SUN RPC Portmapper.
if [ -f ${NET}/rpc.portmap ]; then
   echo -n " portmap"
   ${NET}/rpc.portmap
fi

# Start the INET SuperServer
if [ -f ${NET}/inetd ]; then
  echo -n " inetd"
  ${NET}/inetd
else
  echo "no INETD found.  INET cancelled!"
  exit 1
fi

# # Start the NAMED/BIND name server.
if [ -f ${NET}/named ]; then
  echo -n " named"
  ${NET}/named
fi

# # Start the ROUTEd server.
# if [ -f ${NET}/routed ]; then
#   echo -n " routed"
#   ${NET}/routed -g -s
# fi

# # Start the RWHO server.
# if [ -f ${NET}/rwhod ]; then
#   echo -n " rwhod"
#   ${NET}/rwhod -t -s
# fi

# Start the various INET servers.
for server in ${IN_SERV} ; do
  if [ -f ${NET}/${server} ]; then
    echo -n " ${server}"
    ${NET}/${server}
  fi
done

# # Start the various SUN RPC servers.
if [ -f ${NET}/rpc.portmap ]; then
  # Start the NFS server daemons.
  if [ -f ${NET}/rpc.mountd ]; then
    echo -n " mountd"
    ${NET}/rpc.mountd
  fi
  if [ -f ${NET}/rpc.nfsd ]; then
    echo -n " nfsd"
    ${NET}/rpc.nfsd
  fi
#  # Fire up the PC-NFS daemon(s).
#  if [ -f ${NET}/rpc.pcnfsd ]; then
#    echo -n " pcnfsd"
#    ${NET}/rpc.pcnfsd ${LPSPOOL}
#  fi
#  if [ -f ${NET}/rpc.bwnfsd ]; then
#    echo -n " bwnfsd"
#    ${NET}/rpc.bwnfsd ${LPSPOOL}
#  fi
fi # Done starting various SUN RPC servers.

# The 'echo' below will put a carriage return at the end
# of the list of started servers.
echo

# # Setting up NIS:
# # (NOTE: For detailed information about setting up NIS, see the
# #  documentation in /usr/doc/yp-clients and /usr/doc/ypserv)
# #
# # First, we must set the NIS domainname.  NOTE: this is not
# # necessarily the same as your DNS domainname, set in 
# # /etc/resolv.conf!  The NIS domainname is the name of a domain
# # served by your NIS server.
#
# if [ -r /etc/defaultdomain ]; then
#   nisdomainname `cat /etc/defaultdomain`
# fi
#
# # Then, we start up ypbind.  It will use broadcast to find a server.
#
# if [ -d /var/yp ] ; then
#   echo "Running ypbind..."
#   /usr/sbin/ypbind 
# fi

# Done!

#! /bin/sh
#
# rc.K 		This file is executed by init when it goes into runlevel
#		1, which is the administrative state. It kills all
#		deamons and then puts the system into single user mode.
#		Note that the file systems are kept mounted.
#
# Version:	@(#)/etc/rc.d/rc.K	1.50	1994-01-18
# Version:	@(#)/etc/rc.d/rc.K	1.60	1995-10-02 (PV)
#
# Author:	Miquel van Smoorenburg <[email-masked]>
# Modified by:  Patrick J. Volkerding <[email-masked]>
#

  # Set the path.
  PATH=/sbin:/etc:/bin:/usr/bin

  # Kill all processes.
  echo
  echo "Sending all processes the TERM signal."
  kill -15 -1
  echo -n "Waiting for processes to terminate"
  for loop in 0 1 2 3 4 5 6 7 ; do
    sleep 1
    echo -n "."
  done
  echo

  # Try to turn off quota and accounting.
  if [ -x /usr/sbin/quotaoff ]
  then
	echo "Turning off quota.."
	/usr/sbin/quotaoff -a
  fi
  if [ -x /sbin/accton ]
  then
	echo "Turning off accounting.."
	/sbin/accton
  fi

  # Now go to the single user level
  echo "Telling INIT to go to single user mode (if not already there)..."
  telinit -t 1 1

  # This has to happen last because it could kill itself, because of
  # the way init works.
  echo "Sending all processes the KILL signal."
  kill -9 -1

#!/bin/sh
/usr/bin/loadgzkeys azerty.map

#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here:
# Running gpm
echo "Running gpm..."
gpm -t ps2 
clear

#!/bin/sh
#
# rc.M		This file is executed by init(8) when the system is being
#		initialized for one of the "multi user" run levels (i.e.
#		levels 1 through 6).  It usually does mounting of file
#		systems et al.
#
# Version:	@(#)/etc/rc.d/rc.M	2.02	02/26/93
#
# Author:	Fred N. van Kempen, <[email-masked]>
#		Heavily modified by Patrick Volkerding <[email-masked]>
#

# Tell the viewers what's going to happen...
echo "Going multiuser..."
clear

# Screen blanks after 15 minutes idle time.
/bin/setterm -blank 15
clear

# Look for a CD-ROM in a CD-ROM drive, and if one is found,
# mount it under /cdrom.  This must happen before any of the
# binaries on the CD are needed.
#
# If you don't have a CD-ROM and want to disable this, set the
# /etc/rc.d/rc.cdrom permissions to non-executable: chmod 644 /etc/rc.d/rc.cdrom
# 
if [ -x /etc/rc.d/rc.cdrom ]; then
  . /etc/rc.d/rc.cdrom
fi
clear

# If there's no /etc/HOSTNAME, fall back on this default:
if [ ! -r /etc/HOSTNAME ]; then
 echo "server.sfa.com" > /etc/HOSTNAME
fi
clear

# Set the hostname.  This might not work correctly if TCP/IP is not 
# compiled in the kernel.
/bin/hostname `cat /etc/HOSTNAME | cut -f1 -d .`
clear

# Initialize the NET subsystem.
if [ -x /etc/rc.d/rc.inet1 ]; then
  . /etc/rc.d/rc.inet1
  . /etc/rc.d/rc.inet2
else
  if [ -x /usr/sbin/syslogd ]; then
    /usr/sbin/syslogd & # Backgrounded to avoid an ugly notice from bash-2.0
    /usr/sbin/klogd
  fi
  if [ -x /usr/sbin/lpd ]; then
    /usr/sbin/lpd
  fi
fi
clear

# Start crond (Dillon's crond):
# If you want cron to actually log activity to /var/adm/cron, then change
# -l10 to -l8 to increase the logging level.
/usr/sbin/crond -l10 >>/var/adm/cron 2>&1

# Remove stale locks and junk files (must be done after mount -a!)
/bin/rm -f /var/spool/locks/* /var/lock/* /var/spool/uucp/LCK..* /tmp/.X*lock /tmp/core /core 1> /dev/null 2> /dev/null
clear

# Remove stale hunt sockets so the game can start.
if [ -r /tmp/hunt -o -r /tmp/hunt.stats ]; then
  echo "Removing your stale hunt sockets from /tmp..."
  /bin/rm -f /tmp/hunt*
fi
clear

# Ensure basic filesystem permissions sanity.
chmod 755 /
chmod 1777 /tmp /var/tmp
clear

# Update all the shared library links automatically
/sbin/ldconfig
clear

# Start the sendmail daemon:
if [ -x /usr/sbin/sendmail ]; then
  echo "Starting mail daemon..."
clear
  /usr/sbin/sendmail -bd -q15m
fi
clear

# Load a custom screen font if the user has an rc.font script.
if [ -x /etc/rc.d/rc.font ]; then
  . /etc/rc.d/rc.font
fi
clear

# iBCS Emulation for Linux
# The Intel Binary Compatibility Specification, or iBCS, specifies the
# interfaces between application programs and the surrounding operating
# system environment for i386 based systems. There are however several
# flavours of iBCS in use - SVR4, SVR3 plus several vendor specific
# extensions to SVR3 which are slightly different and incompatible. The
# iBCS emulator for Linux supports all flavours known so far.
if [ -x /etc/rc.d/rc.ibcs2 ]; then
  . /etc/rc.d/rc.ibcs2
fi
clear

# Start Web server:
#if [ -x /etc/rc.d/rc.httpd ]; then
#  . /etc/rc.d/rc.httpd
#fi

# Load a custom keymap if the user has an rc.keymap script.
if [ -x /etc/rc.d/rc.keymap ]; then
  . /etc/rc.d/rc.keymap
fi
clear

# Start the local setup procedure.
if [ -x /etc/rc.d/rc.local ]; then
  . /etc/rc.d/rc.local
fi
clear

# All done.

#!/bin/sh
# rc.modules 1.11  Tue Jun 25 14:29:34 PDT 1996 pjv <[email-masked]>
#
# This file loads extra drivers into the Linux kernel.
# The modules will be looked for under /lib/modules/<kernel version number>
#
# Most Linux kernel modules will accept extra options such as IRQ or base
# address, or to set various modes (such as 10baseT or BNC, etc).  The Linux
# kernel source is the best place to look for extra documentation for the
# various modules.  This can be found under /usr/src/linux-2.0 if you've
# installed it.  Also, the kernel source docs are present on the Slackware
# CD in the /docs/kernel.20 directory.
#
# NOTE:  If any problems arise loading or using these modules, try compiling
# and installing a custom kernel that contains the support instead.  That
# always works. ;^)
#

clear
# Update module dependencies:
echo "Updating module dependencies:"
/sbin/depmod -a
clear

# Automatic module loading.  To load and unload kernel modules
# automatically as needed, uncomment the lines below to run kerneld.
# In some cases, you'll need to create aliases to load the correct
# module. For more information, see the docs in /usr/doc/modules.

#if [ -x /sbin/kerneld ]; then
#  /sbin/kerneld
#fi

# These modules add CD-ROM drive support.  Most of these drivers will probe
# for the I/O address and IRQ of the drive automatically if the parameters
# to configure them are omitted. Typically the I/O address will be specified 
# in hexadecimal, e.g.: cm206=0x300,11
# 
#/sbin/modprobe aztcd aztcd=<I/O address>
#/sbin/modprobe cdu31a cdu31a_port=<I/O address> cdu31a_irq=<interrupt>
#/sbin/modprobe cm206 cm206=<I/O address>,<IRQ>
#/sbin/modprobe gscd gscd=<I/O address>
#/sbin/modprobe mcd mcd=<I/O address>,<IRQ>
#/sbin/modprobe mcdx mcdx=<I/O address>,<IRQ>
#/sbin/modprobe optcd optcd=<I/O address>
# Below, this last number is "1" for SoundBlaster Pro card, or "0" for a clone.
#/sbin/modprobe sbpcd sbpcd=<I/O address>,1
#/sbin/modprobe sonycd535 sonycd535=<I/O address>
#/sbin/modprobe sjcd sjcd=<I/O address>

# Parallel port (printer) support:
/sbin/modprobe lp
clear

# Cyclades multiport serial card support:
#/sbin/modprobe cyclades

# Serial line IP support (SLIP/CSLIP/PPP):
# This module is for SLIP/CSLIP support:
/sbin/modprobe slip
clear
# This module is for PPP support:
/sbin/modprobe ppp
clear
# This module provides BSD compression for PPP (optional):
#/sbin/modprobe bsd_comp

# Sound support:
# (The sound module included with Slackware is configured for a SoundBlaster 16
# or AWE32 at I/O 0x220 IRQ 5.  If you need a different configuration you'll
# need to compile your own module from the Linux kernel source)
#/sbin/modprobe sound

# Network device support:
# Most of these drivers will probe automatically for the card if you don't
# specify an I/O address and IRQ.  But, the NE2000 driver needs at least the
# I/O.  For complete information, see the net-modules.txt file that comes
# with the Linux 2.0.0 source code.  This file can also be found on the
# Slackware CD-ROM in the /docs/kernel.20 directory.
#
# Ethernet cards based on the 8390 chip.
#/sbin/modprobe 3c503 
#/sbin/modprobe ac3200
#/sbin/modprobe e2100
#/sbin/modprobe hp-plus
#/sbin/modprobe hp
#/sbin/modprobe ne io=0xNNN
#/sbin/modprobe smc-ultra
#/sbin/modprobe wd
#
# Other ethernet card drivers:
#/sbin/modprobe 3c501
#/sbin/modprobe 3c503
#/sbin/modprobe 3c505
#/sbin/modprobe 3c507
#/sbin/modprobe 3c509
#/sbin/modprobe 3c59x
#/sbin/modprobe apricot
#/sbin/modprobe arcnet
#/sbin/modprobe at1700
#/sbin/modprobe de4x5
#/sbin/modprobe de600
#/sbin/modprobe de620
#/sbin/modprobe depca
#/sbin/modprobe dgrs
#/sbin/modprobe eepro
#/sbin/modprobe eexpress
#/sbin/modprobe eth16i
#/sbin/modprobe ewrk3
#/sbin/modprobe fmv18x
#/sbin/modprobe hp100
#/sbin/modprobe ibmtr
#/sbin/modprobe ni52
#/sbin/modprobe smc9194
#/sbin/modprobe tulip
#/sbin/modprobe wavelan
#
# Parallel port IP:
#/sbin/modprobe plip
#
# Serial line load balancing support:
#/sbin/modprobe eql
#
# A dummy IP driver.  Essentially a loopback device.  Can be useful --
# see the Network Administrator's Guide from sunsite.unc.edu:/pub/Linux/docs/LDP
#/sbin/modprobe dummy

# Binary format/filesystem support.
#/sbin/modprobe binfmt_elf
#/sbin/modprobe ext
#/sbin/modprobe ext2
#/sbin/modprobe hpfs
#/sbin/modprobe isofs
#/sbin/modprobe minix
#/sbin/modprobe msdos
#/sbin/modprobe nfs
#/sbin/modprobe smbfs
#/sbin/modprobe sysv
#/sbin/modprobe umsdos
#/sbin/modprobe xiafs

# SCSI controller support:
#/sbin/modprobe 53c7,8xx
#/sbin/modprobe NCR53c406a
#/sbin/modprobe aha152x
#/sbin/modprobe aha1542
#/sbin/modprobe aha1740
#/sbin/modprobe aic7xxx
#/sbin/modprobe eata
#/sbin/modprobe eata_dma
#/sbin/modprobe eata_pio
#/sbin/modprobe fdomain
#/sbin/modprobe in2000
#/sbin/modprobe qlogic
#/sbin/modprobe scsi_mod
#/sbin/modprobe scsi_syms
#/sbin/modprobe sd_mod
#/sbin/modprobe seagate
#/sbin/modprobe sg
#/sbin/modprobe sr_mod
#/sbin/modprobe st
#/sbin/modprobe u14-34f
#/sbin/modprobe ultrastor
#/sbin/modprobe wd7000

# Mouse support:
#/sbin/modprobe atixlmouse
#/sbin/modprobe busmouse
#/sbin/modprobe mouse
#/sbin/modprobe msbusmouse
#/sbin/modprobe psaux

# Floppy drive support:
# (Most Linux kernels should already contain this)
#/sbin/modprobe floppy

#!/bin/sh
#
# /etc/rc.d/rc.S:  System initialization script.
#
# Mostly written by:  Patrick J. Volkerding, <[email-masked]>
#

PATH=/sbin:/usr/sbin:/bin:/usr/bin

# enable swapping
/sbin/swapon -a

# Start update.
/sbin/update &

# Automatic module loading.  To load and unload kernel modules
# automatically as needed, uncomment the lines below to run kerneld.
# In some cases, you'll need to create aliases to load the correct
# module. For more information, see the docs in /usr/doc/modules.
if [ -x /sbin/kerneld ]; then
  /sbin/kerneld
fi

# Test to see if the root partition is read-only, like it ought to be.
READWRITE=no
if echo -n >> "Testing filesystem status"; then
 rm -f "Testing filesystem status"
 READWRITE=yes
fi

# Check the integrity of all filesystems
if [ ! $READWRITE = yes ]; then
 /sbin/fsck -A -a
 # If there was a failure, drop into single-user mode.
 if [ $? -gt 1 ] ; then
  echo
  echo
  echo "**************************************"
  echo "fsck returned error code - REBOOT NOW!"
  echo "**************************************"
  echo
  echo
  /bin/login 
 fi
 # Remount the root filesystem in read-write mode
 echo "Remounting root device with read-write enabled."
 /sbin/mount -w -n -o remount /
 if [ $? -gt 0 ] ; then
  echo
  echo "Attempt to remount root device as read-write failed!  This is going to"
  echo "cause serious problems...  "
  echo 
  echo "If you're using the UMSDOS filesystem, you **MUST** mount the root partition"
  echo "read-write!  You can make sure the root filesystem is getting mounted "
  echo "read-write with the 'rw' flag to Loadlin:"
  echo
  echo "loadlin vmlinuz root=/dev/hda1 rw   (replace /dev/hda1 with your root device)"
  echo
  echo "Normal bootdisks can be made to mount a system read-write with the rdev command:"
  echo
  echo "rdev -R /dev/fd0 0"
  echo
  echo "You can also get into your system by using a bootkernel disk with a command"
  echo "like this on the LILO prompt line:  (change the root partition name as needed)"
  echo 
  echo "LILO: mount root=/dev/hda1 rw"
  echo
  echo "Please press ENTER to continue, then reboot and use one of the above methods to"
  echo -n "get into your machine and start looking for the problem. " 
  read junk; 
 fi
else
 echo "Testing filesystem status: read-write filesystem"
 if [ ! -d /DOS ]; then # no warn for UMSDOS (kind of a bad test, but...)
  cat << EOF

*** ERROR: Root partition has already been mounted read-write. Cannot check!

For filesystem checking to work properly, your system must initially mount
the root partition as read only. Please modify your kernel with 'rdev' so that
it does this. If you're booting with LILO, add a line:

   read-only

to the Linux section in your /etc/lilo.conf and type 'lilo' to reinstall it.

If you boot from a kernel on a floppy disk, put it in the drive and type:
  rdev -R /dev/fd0 1

If you boot from a bootkernel disk, or with Loadlin, you can add the 'ro' flag.

This will fix the problem *AND* eliminate this annoying message. :^)

EOF
  echo -n "Press ENTER to continue. "
  read junk;
 fi
fi

# remove /etc/mtab* so that mount will create it with a root entry
/bin/rm -f /etc/mtab* /etc/nologin /etc/shutdownpid 

# mount file systems in fstab (and create an entry for /)
# but not NFS because TCP/IP is not yet configured
/sbin/mount -avt nonfs

# Clean up temporary files on the /var volume:
/bin/rm -f /var/run/utmp /var/run/*.pid

# Looks like we have to create this.
cat /dev/null > /var/run/utmp

# This can be changed if your system keeps GMT.
if [ -x /sbin/clock ]; then
  /sbin/clock -s
fi

# Setup the /etc/issue and /etc/motd to reflect the current kernel level:
# THESE WIPE ANY CHANGES YOU MAKE TO /ETC/ISSUE AND /ETC/MOTD WITH EACH
# BOOT. COMMENT THEM OUT IF YOU WANT TO MAKE CUSTOM VERSIONS.
#echo > /etc/issue
#echo Welcome to Linux `/bin/uname -a | /bin/cut -d\  -f3`. >> /etc/issue
#echo >> /etc/issue
#echo "`/bin/uname -a | /bin/cut -d\  -f1,3`." > /etc/motd

# This loads any kernel modules that are needed.  These might be required to
# use your CD-ROM drive, bus mouse, ethernet card, or other optional hardware.
if [ -x /etc/rc.d/rc.modules ]; then
  . /etc/rc.d/rc.modules
fi

# Initialize PCMCIA devices:
#
# NOTE: This had been closer to the top of this script so that PCMCIA devices
# could be fsck'ed along with the other drives.  This had some unfortunate
# side effects, however, since root isn't yet read-write, and /var might not
# even be mounted the .pid files can't be correctly written in /var/run and
# the pcmcia system can't be correctly shut down.  If you want some PCMCIA
# partition to be mounted at boot (or when the card is inserted) then add
# the appropriate lines to /etc/pcmcia/scsi.opts.
#
if [ -x /etc/rc.d/rc.pcmcia ] ; then
  . /etc/rc.d/rc.pcmcia start
fi

# Run serial port setup script:
# (CAREFUL! This can make some systems hang if the rc.serial script isn't
# set up correctly. If this happens, you may have to edit the file from a
# boot disk)
#
# . /etc/rc.d/rc.serial

#!/bin/sh
#
# /etc/rc.serial 
#	Initializes the serial ports on your system
#
#	Version 2.01
#
# Without uncommenting some of the lines in this script, you'll be unable to
# use ports other than the first two, and those only if they use "standard"
# IRQ values (whatever those are... :^)  The rc.serial script made a couple
# machines I tested this on hang at this point in the boot process, so it's
# commented out by default. However, if you need to set up extended serial
# ports, it's a very good starting point. It usually works great.
# More info that will be useful: I did some testing and found that the lines
# in /etc/rc.d/rc.serial that are most likely to make the machine hang are the
# one that sets up /dev/cua3, and the last time, which causes a report to be
# issued to the console about how the ports were configured. This tries to
# report on *every* port... if you change it so it only lists the ports you're
# going to use (/dev/cua0 /dev/cua1 /dev/cua2 for example) that it probably
# won't cause a hang. Also, the "wild" interrupt detection used for auto-
# configuration can cause problems as well. I highly recommend using the
# manual configuration lines to avoid trouble.
#

cd /dev

SETSERIAL="/bin/setserial -b"
PORTS=`echo cua? cua??`

echo -n "Configuring serial ports...."

# Do wild interrupt detection (uncomment if you're brave enough to
# attempt auto-configuration... )
#
# ${SETSERIAL} -W ${PORTS}

###############################################################
#
# AUTOMATIC CONFIGURATION 
#
# Uncomment the appropriate lines below to enable auto-configuration
# of a particular board.  Or comment them out to disable them....
#
###############################################################

# Do AUTOMATIC_IRQ probing
#
AUTO_IRQ=auto_irq

# These are the standard COM1 through COM4 devices
#
# If you have an internal modeme with a Rockwell Chipset, add a "skip_test"
# to the /dev/cua3 line below.  (It's not added by default because it will
# screw up people with 8514 displays).
#
# ${SETSERIAL} /dev/cua0 ${AUTO_IRQ} skip_test autoconfig
# ${SETSERIAL} /dev/cua1 ${AUTO_IRQ} skip_test autoconfig
# ${SETSERIAL} /dev/cua2 ${AUTO_IRQ} skip_test autoconfig
# ${SETSERIAL} /dev/cua3 ${AUTO_IRQ} autoconfig

# These are for the first AST Fourport board (base address 0x1A0)
#
# ${SETSERIAL} /dev/cua4 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua5 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua6 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua7 ${AUTO_IRQ} autoconfig

# These are for the second AST Fourport board (base address 0x2A0)
#
# ${SETSERIAL} /dev/cua8 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua9 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua10 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua11 ${AUTO_IRQ} autoconfig

# These are the 3rd and 4th ports on the Accent Async board.
#
# ${SETSERIAL} /dev/cua12 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua13 ${AUTO_IRQ} autoconfig
 
# Usenet Serial Board II (base address 0x100)
#
# ${SETSERIAL} /dev/cua16 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua17 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua18 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua19 ${AUTO_IRQ} autoconfig

# BocaBoard 4 port (BB-1004) (base address 0x100)
# 
# ${SETSERIAL} /dev/cua16 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua17 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua18 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua19 ${AUTO_IRQ} autoconfig

# BocaBoard 8 port (BB-1008) (base address 0x100),
# or two BB-1004's (base addresses 0x100 and 0x120)
#
# ${SETSERIAL} /dev/cua16 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua17 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua18 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua19 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua20 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua21 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua22 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua23 ${AUTO_IRQ} autoconfig

# BocaBoard 16 port (BB-1008), (base address 0x100),
# or two BB-1008's (base addresses 0x100 and 0x140),
# or four BB-1004's (base address 0x100, 0x120, 0x140, and 0x160)
#
# Warning --- some of these ports may conflict with the Future Domain
# SCSI controller.  If you want to run both the BocaBoards and the 
# Future Domain controller, you may need to change the port assignment
# of the Bocaboards -- see below in the section on manual configuration.
#
# ${SETSERIAL} /dev/cua16 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua17 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua18 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua19 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua20 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua21 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua22 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua23 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua24 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua25 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua26 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua27 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua28 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua29 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua30 ${AUTO_IRQ} autoconfig
# ${SETSERIAL} /dev/cua31 ${AUTO_IRQ} autoconfig

###############################################################
#
# MANUAL CONFIGURATION 
#
# If you want to do manual configuration of one or more of your 
# serial ports, uncomment and modify the relevant lines.
#
###############################################################

# These are the standard COM1 through COM4 devices
#
# ${SETSERIAL} /dev/cua0 uart 16450 port 0x3F8 irq 4
# ${SETSERIAL} /dev/cua1 uart 16450 port 0x2F8 irq 3
# ${SETSERIAL} /dev/cua2 uart 16450 port 0x3E8 irq 4
# ${SETSERIAL} /dev/cua3 uart 16450 port 0x2E8 irq 3

# These are the first set of AST Fourport ports
#
# ${SETSERIAL} /dev/cua4 uart 16450 port 0x1A0 irq 9 fourport
# ${SETSERIAL} /dev/cua5 uart 16450 port 0x1A8 irq 9 fourport
# ${SETSERIAL} /dev/cua6 uart 16450 port 0x1B0 irq 9 fourport
# ${SETSERIAL} /dev/cua7 uart 16450 port 0x1B8 irq 9 fourport

# These are the second set of AST Fourport ports
#
# ${SETSERIAL} /dev/cua8 uart 16450 port 0x2A0 irq 5 fourport
# ${SETSERIAL} /dev/cua9 uart 16450 port 0x2A8 irq 5 fourport
# ${SETSERIAL} /dev/cua10 uart 16450 port 0x2B0 irq 5 fourport
# ${SETSERIAL} /dev/cua11 uart 16450 port 0x2B8 irq 5 fourport

# These are the 3rd and 4th ports on the Accent Async board.
#
# ${SETSERIAL} /dev/cua12 uart 16450 port 0x330 irq 4
# ${SETSERIAL} /dev/cua13 uart 16450 port 0x338 irq 4

# These are two spare devices you can use to customize for 
# some board which is not supported above....
# ${SETSERIAL} /dev/cua14 uart XXXXX port XXXX irq X
# ${SETSERIAL} /dev/cua15 uart XXXXX port XXXX irq X

# These are the ports used for either the Usenet Serial II
# board, or the Boca Board 4, 8, or 16 port boards.
#
# Uncomment only the first 4 lines for the Usenet Serial II board,
# and uncomment the first 4, 8, or all 16 lines for the
# Boca Board BB-1004, BB-1008, and BB-2016 respectively.
#
# ${SETSERIAL} /dev/cua16 uart 16550A port 0x100 irq 12
# ${SETSERIAL} /dev/cua17 uart 16550A port 0x108 irq 12
# ${SETSERIAL} /dev/cua18 uart 16550A port 0x110 irq 12
# ${SETSERIAL} /dev/cua19 uart 16550A port 0x118 irq 12
# ${SETSERIAL} /dev/cua20 uart 16550A port 0x120 irq 12
# ${SETSERIAL} /dev/cua21 uart 16550A port 0x128 irq 12
# ${SETSERIAL} /dev/cua22 uart 16550A port 0x130 irq 12
# ${SETSERIAL} /dev/cua23 uart 16550A port 0x138 irq 12
# ${SETSERIAL} /dev/cua24 uart 16550A port 0x140 irq 12
# ${SETSERIAL} /dev/cua25 uart 16550A port 0x148 irq 12
# ${SETSERIAL} /dev/cua26 uart 16550A port 0x150 irq 12
# ${SETSERIAL} /dev/cua27 uart 16550A port 0x158 irq 12
# ${SETSERIAL} /dev/cua28 uart 16550A port 0x160 irq 12
# ${SETSERIAL} /dev/cua29 uart 16550A port 0x168 irq 12
# ${SETSERIAL} /dev/cua30 uart 16550A port 0x170 irq 12
# ${SETSERIAL} /dev/cua31 uart 16550A port 0x178 irq 12

###########################################################
#
# Print the results of the serial configuration process
#
###########################################################

echo "done."

${SETSERIAL} -bg ${PORTS}

domain sfa.com
nameserver 193.94.6.200

#
# hosts		This file describes a number of hostname-to-address
#		mappings for the TCP/IP subsystem.  It is mostly
#		used at boot time, when no name servers are running.
#		On small systems, this file can be used instead of a
#		"named" name server.  Just add the names, addresses
#		and any aliases to this file...
#
# By the way, Arnt Gulbrandsen <[email-masked]> says that 127.0.0.1
# should NEVER be named with the name of the machine.  It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#

# For loopbacking.
127.0.0.1	localhost
193.94.6.200	 	server.sfa.com server

# End of hosts.

# See "man 8 inetd" for more information.
#
# If you make changes to this file, either reboot your machine or send the
# inetd a HUP signal:
# Do a "ps x" as root and look up the pid of inetd. Then do a
# "kill -HUP <pid of inetd>".
# The inetd will re-read this file whenever it gets that signal.
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
# The first 4 services are really only used for debugging purposes, so
# we comment them out since they can otherwise be used for some nasty
# denial-of-service attacks.  If you need them, uncomment them.
#echo   	stream	tcp	nowait	root	internal
#echo   	dgram	udp	wait	root	internal
#discard	stream	tcp	nowait	root	internal
#discard	dgram	udp	wait	root	internal
#daytime	stream	tcp	nowait	root	internal
#daytime	dgram	udp	wait	root	internal
#chargen	stream	tcp	nowait	root	internal
#chargen	dgram	udp	wait	root	internal
time	stream	tcp	nowait	root	internal
time	dgram	udp	wait	root	internal
#
# These are standard services.
#
ftp	stream	tcp	nowait	root	/usr/sbin/tcpd	wu.ftpd -l -i -a
telnet	stream  tcp     nowait  root    /usr/sbin/tcpd	in.telnetd
#
# Use this one instead if you want to snoop on telnet users (try to use this
# for ethical purposes, ok folks?) :
# telnet stream  tcp     nowait  root    /usr/sbin/tcpd  /usr/sbin/in.telnetsnoopd
#
# If you want to read NNTP news via TERM, comment out the nntp
# line below, and use a command like this once the TERM
# connection is up:  tredir 119 my.nntp.host:119
# You'll also want to do this: set NNTPSERVER my.nntp.host ; export NNTPSERVER
#nntp	stream	tcp	nowait	root	/usr/sbin/tcpd	in.nntpd
#
# This is for BSD sendmail:
# smtp  stream  tcp     nowait  root    /usr/sbin/tcpd    sendmail -v
# This is set up for running Smail:
# smtp  stream  tcp     nowait  root    /usr/sbin/tcpd  /usr/bin/rsmtp  -bs
#
# The comsat daemon notifies the user of new mail when biff is set to y:
comsat        dgram   udp     wait    root    /usr/sbin/tcpd  in.comsat
#
# Shell, login, exec and talk are BSD protocols.
#
shell	stream	tcp	nowait	root	/usr/sbin/tcpd	in.rshd -L
login	stream	tcp	nowait	root	/usr/sbin/tcpd	in.rlogind
# exec	stream	tcp	nowait	root	/usr/sbin/tcpd	in.rexecd
# talk	dgram	udp	wait	root	/usr/sbin/tcpd	in.talkd
ntalk	dgram	udp	wait	root	/usr/sbin/tcpd	in.talkd
#
# Kerberos authenticated services
#
# klogin	stream	tcp	nowait	root	/usr/sbin/tcpd	rlogind -k
# eklogin	stream	tcp	nowait	root	/usr/sbin/tcpd	rlogind -k -x
# kshell	stream	tcp	nowait	root	/usr/sbin/tcpd	rshd -k
#
# Services run ONLY on the Kerberos server
#
# krbupdate	stream	tcp	nowait	root	/usr/sbin/tcpd	registerd
# kpasswd	stream	tcp	nowait	root	/usr/sbin/tcpd	kpasswdd
#
# Pop et al
#
# pop2	stream	tcp	nowait	root	/usr/sbin/tcpd	in.pop2d
pop3	stream	tcp	nowait	root	/usr/sbin/tcpd	in.pop3d
imap2   stream  tcp     nowait  root    /usr/sbin/tcpd  imapd
#
# The Internet UUCP service.
#
# uucp	stream	tcp	nowait	uucp	/usr/sbin/tcpd	/usr/lib/uucp/uucico	-l
#
# Tftp service is provided primarily for booting.  Most sites
# run this only on machines acting as "boot servers." 
#
# tftp	dgram	udp	wait	nobody	/usr/sbin/tcpd	in.tftpd
# bootps	dgram	udp	wait	root	/usr/sbin/in.bootpd	in.bootpd
#
# Finger, systat and netstat give out user information which may be
# valuable to potential "system crackers."  Many sites choose to disable 
# some or all of these services to improve security.
# Try "telnet localhost systat" and "telnet localhost netstat" to see that
# information yourself!
#
finger	stream	tcp	nowait	nobody	/usr/sbin/tcpd	in.fingerd -w
systat	stream	tcp	nowait	nobody	/usr/sbin/tcpd	/bin/ps	-auwwx
netstat	stream	tcp	nowait	root	/usr/sbin/tcpd	/bin/netstat	-a
#
# Ident service is used for net authentication
auth	stream	tcp	wait	root	/usr/sbin/in.identd	in.identd -w -t120 -l
#
# These are to start Samba, an smb server that can export filesystems to
# Pathworks, Lanmanager for DOS, Windows for Workgroups, Windows95, Lanmanager
# for Windows, Lanmanager for OS/2, Windows NT, etc.  Lanmanager for dos is
# available via ftp from ftp.microsoft.com in bussys/MSclient/dos/. Please read
# the licensing stuff before downloading. Use the TCP/IP option in the client.
# Add your server to the \etc\lmhosts (or equivalent) file on the client.
netbios-ssn     stream  tcp     nowait  root    /usr/sbin/smbd  smbd
netbios-ns      dgram   udp     wait    root    /usr/sbin/nmbd  nmbd
#
# Sun-RPC based services.
# <service name/version><sock_type><rpc/prot><flags><user><server><args>
#
# rstatd/1-3	dgram	rpc/udp	wait	root	/usr/sbin/tcpd	rpc.rstatd
# rusersd/2-3	dgram	rpc/udp	wait	root	/usr/sbin/tcpd	rpc.rusersd
# walld/1		dgram	rpc/udp	wait	root	/usr/sbin/tcpd	rpc.rwalld
#
# End of inetd.conf.

order bind, hosts
multi on

  PID TTY STAT  TIME COMMAND
    1  ?  S    0:03 init [3] 
    2  ?  SW   0:00 (kflushd)
    3  ?  SW<  0:00 (kswapd)
    9  ?  S    0:00 /sbin/update 
   10  ?  S    0:00 /sbin/kerneld 
   84  ?  S    0:00 /usr/sbin/klogd 
   85  ?  S    0:00 /usr/sbin/syslogd 
   89  ?  S    0:00 /usr/sbin/inetd 
   91  ?  S    0:00 /usr/sbin/named 
   93  ?  S    0:00 /usr/sbin/rpc.mountd 
   95  ?  S    0:00 /usr/sbin/rpc.nfsd 
   99  ?  S    0:00 /usr/sbin/crond -l10 
  116  ?  S    0:00 sendmail: accepting connections on port 25                 
  134  ?  S    0:00 gpm -t ps2 
  139   1 S    0:00 -bash 
  140   2 S    0:00 /sbin/agetty 38400 tty2 linux 
  141   3 S    0:00 /sbin/agetty 38400 tty3 linux 
  142   4 S    0:00 /sbin/agetty 38400 tty4 linux 
  143   5 S    0:00 /sbin/agetty 38400 tty5 linux 
  144   6 S    0:00 /sbin/agetty 38400 tty6 linux 
  257   1 R    0:00 ps -ax 
   87  ?  S    0:00 /usr/sbin/rpc.portmap

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 25 Jan 1999 12:03:07 -0500 (EST)

On Mon, 25 Jan 1999, FATHI BEN NASR wrote:

> Date: Mon, 25 Jan 1999 14:05:12 +0100
> From: FATHI BEN NASR <[email-masked]>
> To: [email-masked]
> Subject: Problems with wu-ftpd
> 

Um .. GET, PRAGMA, USER-AGENT and the like are HTTP not FTP.  Looks like
the problem is a bad proxy setup.  It appears the proxy thinks the FTP
site is a web server.

Also, if you didn't hack the source, or edit your email, the FTP daemon
running is not 2.4.2 (beta 18).

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195