Subject: RE: My guest users don't get chroot'ed

From: Omar Keblawi <[email-masked]>
Date: Mon, 18 Jan 1999 10:26:21 -0800

I'm back at setting up the ftp server.....

Yes, the ftpd is started with -a, but it still doesn't chroot me to the
users directory.  So What else could cause the ftpaccess file to NOT be
read?  

ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd
-a 

Thanks, 

Omar

Gregory A Lundberg wrote:
> 
> On Wed, 13 Jan 1999, Omar Keblawi wrote:
> 
> > I'm just setting things up using (Version wu-2.4.2-academ[BETA-18].
> >
> > The Anonymous ftp user seems to work fine and is chrooted.  But my
> > guest users are not chrooted.
> 
> Add -a to the command line and kill -HUP inet.  You're not using the
> ftpaccess file, most likely.
> 
> --
> 
> Gregory A Lundberg              Senior Partner, VRnet Company
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 18 Jan 1999 13:00:07 -0500 (EST)

On Mon, 18 Jan 1999, Omar Keblawi wrote:

> Yes, the ftpd is started with -a, but it still doesn't chroot me to
> the users directory.  So What else could cause the ftpaccess file to
> NOT be read?
> 
> ftp stream tcp nowait root /usr/sbin/in.ftpd in.ftpd -a

File permissions and, on some systems, mis-interpretation of the format
for the inetd.conf line.  Yours looks OK, btw.

Perhaps ftpaccess is being used.  In that case check that the user is
explicitly listed in the group in /etc/group:

/etc/passwd:
lundberg:*:101:101::/home/./lundberg:/bin/sh

/etc/group
ftpguest:*:92:lundberg

/etc/ftpaccess:
guestgroup ftpguest

--

---

From: Omar Keblawi <[email-masked]>
Date: Mon, 18 Jan 1999 16:30:27 -0800

Thank YOU!

That was it.  I needed the /etc/group and /etc/ftpaccess entries.

I'm still new at setting this up.....  more questions may follow.

Thanks!

Omar