Subject: Bero 1.3.2 login problem

From: Chad Price <[email-masked]>
Date: Thu, 28 Jan 1999 15:36:09 -0600

I've got and installed 1.3.2 (I'm aware that 1.2.x is the official stable
version). I'm replacing an old version of wu-ftpd (2.4(2)).  I cannot login
using Bero and can login using wu-ftpd with the same configuration files.
Details below.

I have the wu-ftpd working correctly and have installed the appropriately
altered Bero ftpaccess and other config files and tested the configuration
by (1) using the wu-ftpd server which works fine and (2) using the
configuration test programs in sbin which only give warnings - no errors.
The warnings are:

molbio /usr/local/stow-dir/bero-ftp> sbin/ckconfig
Checking _PATH_FTPUSERS :: /usr/local/etc/ftpusers
ok.
 
Checking _PATH_FTPSERVERS :: /usr/local/etc/ftpservers
I can't find it... look in doc/examples for an example.
 
Checking _PATH_FTPACCESS :: /usr/local/etc/ftpaccess
ok.
 
Checking _PATH_PIDNAMES :: /var/adm/ftp.pids-%s
ok.
 
Checking _PATH_CVT :: /usr/local/etc/ftpconversions
ok.
 
Checking _PATH_XFERLOG :: /var/log/xferlog
I can't find it... 
Don't worry, it will be created automatically by the
server if you do transfer logging.
 
Checking _PATH_PRIVATE :: /usr/local/etc/ftpgroups
ok.
 
Checking _PATH_FTPHOSTS :: /usr/local/etc/ftphosts
I can't find it... look in doc/examples for an example.
You only need this if you are using the HOST ACCESS features
of the server.

molbio /usr/local/stow-dir/bero-ftp> sudo sbin/ftpck
Password:
WARNING: ftpservers file /usr/local/etc/ftpservers missing.
        Only needed if you're using virtual hosts.
WARNING: ftphosts file /usr/local/etc/ftphosts missing.
        Only needed if using BeroFTPD HOST ACCESS features.
WARNING: xferlog file /var/log/xferlog missing.

I cannot login using Bero and I can login using wu-ftpd.  The only changes
I make in the interim are to inetd.conf to start Bero with
	-a -i
The wu parameters are:
	 -a -u077 -l -L

System: solaris 2.4 patched, gcc

Installation was with configure --prefix and then 'stow' to link to the
desired official location.

So: Is this a bug, or am I missing something?

Chad

Chad Price
Systems Manager
University of Nebraska Medical Center
600 S 42nd St
Omaha, NE 68506-6495
[email-masked]
(402) 559-9527 
(402) 559-4077 (FAX)

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Fri, 29 Jan 1999 00:41:47 +0100 (CET)

> using Bero and can login using wu-ftpd with the same configuration files.

Try recompiling with --disable-passwd. Some systems apparently have
problems with the alternate getpwnam() implementation.

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.

---

From: Chad Price <[email-masked]>
Date: Fri, 29 Jan 1999 11:33:24 -0600

>problems with the alternate getpwnam() implementation.

1.3.2 compiled with --disable-passwd produced the same failure to login.

I also retried with 1.2.3, and get the same results. I have not compiled it
with 
	--disable-passwd
So it's at least not something that was introduced with 1.3.  

Any other Solaris 2.4 users have any suggestions? What parameters did you
compile with? and are you using stow to install stuff into a common tree?

molbio /usr/local/src/wuftp/BeroFTPD-1.3.2> /bin/ps -ef|grep inet
    root   188     1 80 09:56:18 ?        0:02 /usr/sbin/inetd -s
  cprice  6152  2071  8 11:32:19 pts/3    0:00 grep inet
molbio /usr/local/src/wuftp/BeroFTPD-1.3.2> sudo kill -HUP 188
molbio /usr/local/src/wuftp/BeroFTPD-1.3.2> ftp molbio
Connected to molbio.unmc.edu.
220 molbio.unmc.edu FTP server (BeroFTPD 1.2.3(1) Fri Jan 29 11:22:56 CST
1999) ready.
Name (molbio:cprice): 
331 Password required for cprice.
Password:
530 Login incorrect.
Login failed.
ftp> 221 Goodbye.
molbio /usr/local/src/wuftp/BeroFTPD-1.3.2> sudo kill -HUP 188
molbio /usr/local/src/wuftp/BeroFTPD-1.3.2> ftp molbio
Connected to molbio.unmc.edu.
220 molbio FTP server (Version wu-2.4(2) Thu Aug 20 15:20:09 CDT 1998) ready.
Name (molbio:cprice): 
331 Password required for cprice.
Password:
230 User cprice logged in.
ftp> 

Chad Price
Systems Manager

---

From: Andreas de Pretis <[email-masked]>
Date: Fri, 29 Jan 1999 20:39:27 +0100

hi,

i'm wondering what the regular expression for disallowing .php3-files
within path-filter could be. (^.php3 doesn't work). Are there more than 3
expressions allowed ?

thx in advance for help and sorry for asking such a stupid newbie-question :)

greets
 
      Andreas