Subject: Re: wu port (again)

From: Konrad Kokoszkiewicz <[email-masked]>
Date: Tue, 12 Jan 1999 13:41:36 +0100 (EET)

On Tue, 12 Jan 1999, Konrad Kokoszkiewicz wrote:

> okay it turned over that problems under MiNT were caused by a bug in libc.
> So summa summarum I've ported the beta 14 to MiNT and can send config
> files, if anyone interested.

Errata: read "beta 15".

--
Konrad M.Kokoszkiewicz
|mail: [email-masked]                  | Atari Falcon030/TT030/65XE |
|http://www.obta.uw.edu.pl/~draco/
|http://draco.atari.org

** Ea natura multitudinis est,
** aut servit humiliter, aut superbe dominatur (Liv. XXIV,25)
*************************************************************
** U pospolstwa normalne jest, ze albo sluzy ono unizenie,
** albo bezczelnie sie panoszy.

---

From: Konrad Kokoszkiewicz <[email-masked]>
Date: Tue, 12 Jan 1999 13:40:11 +0100 (EET)

Hi,

Used gcc 2.8.1.

I have problem with beta 18 though, because it contains a call to
vsnprintf() and my libs don't seem to support that function. Can I ask for
any suggestion, how to replace?

Thanks,

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 12 Jan 1999 08:48:51 -0500 (EST)

On Tue, 12 Jan 1999, Konrad Kokoszkiewicz wrote:

> vsnprintf() and my libs don't seem to support that function. Can I ask
> for any suggestion, how to replace?

Beta 18 includes vsnprintf.c in the support directory.  Just add it to the
makefile for your port.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Konrad Kokoszkiewicz <[email-masked]>
Date: Thu, 14 Jan 1999 19:02:41 +0100 (EET)

> Beta 18 includes vsnprintf.c in the support directory.  Just add it to the

Thanks. However, it doesn't compile right on my system (gcc 2.8.1), I'd
suggest looking at the variable declarations, because 'str' looks to be
doubly defined:

int
#ifdef __STDC__
vsnprintf(char *str, ... )
#else
vsnprintf(....)
...
#endif
{
	char *str;
	...

To compile that I for now just changed #ifdef __STDC__ to
#if defined(__STDC__) && !defined(__MINT__) in case that was correct
for a system.

Cu,