Subject: RE: Installing wu-ftpd on FreeBSD

From: Shilpa Patel <[email-masked]>
Date: Wed, 9 Dec 1998 11:04:52 -0500

I allocated new ports for wu-ftd and restarted the inetd process again. Even, I rebooted the system. But didn't work.

> Shilpa Patel

-----Original Message-----
From:	Cameron Lemon [mailto:[email-masked]]
Sent:	Wednesday, December 09, 1998 11:03 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Re: Installing wu-ftpd on FreeBSD

 << File: Cameron.Lemon.vcf >> 
Did you send the inetd a -HUP signal to have it re-read /etc/inetd.conf?  Did you allocate new ports for both the control and data ports?

Shilpa Patel wrote:

> Hi,
>
> I had installed wu-ftpd on FreeBSD. I edited the inetd.conf file and made wu-ftpd pint to a different port. But if I try to telnet to that port from remote workstation, I can't connect. Can anybody please let me know where I have to make the changes ?
>
> Thanks,
> > Shilpa Patel

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 9 Dec 1998 13:55:49 -0500 (EST)

On Wed, 9 Dec 1998, Shilpa Patel wrote:

> I allocated new ports for wu-ftd and restarted the inetd process
> again. Even, I rebooted the system. But didn't work.
> 
> > I had installed wu-ftpd on FreeBSD. I edited the inetd.conf file and
> > made wu-ftpd pint to a different port. But if I try to telnet to
> > that port from remote workstation, I can't connect. Can anybody
> > please let me know where I have to make the changes ?

In /etc/services, add a line, for instance:

wuftpd-data	200/tcp		# Data port for WU-FTPD
wuftpd		201/tcp		# WU-FTPD testing

Notice you need two ports for FTP.  This may, or may not, work to allocate
the data port since the daemon has a long-standing issue on the mailing
list about that.  There's a feature in VR11 which allows you to specify
the ports on the command line.  I believe BeroFTPD also has this feature.

In /etc/inetd.conf, add a line, for instance:

wuftpd stream tcp nowait root /pathto/wuftpd/bin/ftpd -l -a

The exact syntax for the inetd.conf line caries from system to system.
The above works for Redhat 4.2

Tell inetd to reload inetd.conf:

killall -HUP inetd

TELNET to the new control port and test it out in raw FTP:

telnet localhost wuftpd
220 ftp.vr.net FTP server ready.
USER ftp
331 Guest login ok, send your complete e-mail address as password.
PASS root@
230 Guest login ok, access restrictions apply.
STAT
211-ftp.vr.net FTP server status:
     Version wu-2.4.2-academ[BETA-18-VR10](1) Fri Oct 30 14:34:21 EST 1998
     Connected to localhost (127.0.0.1)
     Logged in anonymously
     TYPE: ASCII, FORM: Nonprint; STRUcture: File; transfer MODE: Stream
     No data connection
     0 data bytes received in 0 files
     0 data bytes transmitted in 0 files
     0 data bytes total in 0 files
     28 traffic bytes received in 0 transfers
     567 traffic bytes transmitted in 0 transfers
     644 traffic bytes total in 0 transfers
211 End of status
QUIT
221-You have transferred 0 bytes in 0 files.
221-Total traffic for this session was 754 bytes in 0 transfers.
221-Thank you for using the FTP service on ftp.vr.net.
221 Goodbye.
Connection closed by foreign host.

The command line FTP client which came with my Radhat 4.2 doesn't
understand named ports on the command line, but does understand numeric
ports.

ftp localhost 201
Connected to localhost.
220 ftp.vr.net FTP server ready.
Name (localhost:lundberg): ftp
331 Guest login ok, send your complete e-mail address as password.
Password:
230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 8
dr-xr-xr-x   7 root     root         1024 Nov 13 15:13 .
dr-xr-xr-x   7 root     root         1024 Nov 13 15:13 ..
-r--r--r--   1 root     root           13 Jun  9  1998 .forward
-r--r--r--   1 root     root            0 Jun  9  1998 .notar
-r--r--r--   1 root     root            0 Jun  9  1998 .rhosts
d--x--x--x   3 root     root         1024 Sep 14 16:40 bin
d--x--x--x   2 root     root         1024 Nov 13 15:13 etc
drwxrws-wx   2 vrnet    vrnet        1024 Oct  8 00:43 incoming
drwxrws--t   9 vrnet    vrnet        1024 Aug 18 21:30 private
drwxrwsr-t   4 vrnet    vrnet        1024 Aug 15 15:04 pub
226 Transfer complete.
ftp> quit
221-You have transferred 0 bytes in 0 files.
221-Total traffic for this session was 996 bytes in 1 transfers.
221-Thank you for using the FTP service on ftp.vr.net.
221 Goodbye.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195