Subject: guestgroup and chroot

From: Keith Oborn <[email-masked]>
Date: Tue, 22 Dec 1998 11:04:03 +0000

I came across this problem a coupel of years back on a SCO system:
it didn't matter then and I put it down to SCO. Now I have the
same problem under Solaris 2.6, and it does matter.

The setup is:

wu-2.4.2-academ[BETA-18]

/etc/ftpaccess has a line:

	guestgroup      customer

/etc/group has the relevant entry:

	customer::100:testuser

and /etc/passwd has:
	
	testuser:x:3000:100:Testuser:/home1/sonyadm/htdocs/testuser/./:/bin/false

/bin/false is in /etc/shells.

So, when testuser arrives he is correctly dropped in his home directory
(the requirement is that each such user should be isolated in his
own ~home, so the chdir part of the /etc/passwd entry is set to /./,
and the root part to ~home.

BUT, there doesn't seem to have been a chroot - testuser can cd .. and
roam around to his heart's content.

What's happening here, does anyone know?
  
-- 
Keith Oborn      Sony Communication Network       0171 426 8655
15th Floor, Commercial Union Tower, 1, Undershaft, London EC3A 8NP
                    [email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 22 Dec 1998 10:44:05 -0500 (EST)

> roam around to his heart's content.

Let's check the easy stuff first.  Make sure you're using -a on the ftpd
command line and test that the ftpaccess file is actually being used.  I'd
add a noretrieve for a file the user can see and download and ensure I get
a 'is marked unretrievable' message.  Then I'd run through the FAQ:

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195