Subject: wu-ftpd (BETA-18) doesn't know users?

From: [email-masked] (M. Schmidt)
Date: Mon, 21 Dec 1998 16:39:54 +0100 (MET)

Hi,

the machine I'm trying to run wu-ftpd (BETA-18) on is a HP-UX.
I have looked into the configuration files, but I don't know
what I'm doing wrong.

Every time I try to ftp to the ftpd, whether anonymous or real users
doesn't matter, I get back an error message after typing the user name,
e.g. "530 User ftp unknown.".

The ~ftp/etc/group and ~ftp/etc/passwd files have been setup 
as recommended. Nevertheless:
What's going wrong there?

Please be so nice to send me your help as soon as possible.
Thanks in advance.

Have a nice day
Michael

-- 
                 Michael  Schmidt
              [email-masked]
Mirror of:                              SAMBA:
IPFilter,                               Server for Win95,
Linux-HOWTO, XEmacs-beta                WinNT, LANManager

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 21 Dec 1998 12:00:40 -0500 (EST)

On Mon, 21 Dec 1998, M. Schmidt wrote:

> the machine I'm trying to run wu-ftpd (BETA-18) on is a HP-UX. I have
> looked into the configuration files, but I don't know what I'm doing
> wrong.
> 
> doesn't matter, I get back an error message after typing the user
> name, e.g. "530 User ftp unknown.".

This message means there is no user named 'ftp' in the *real* /etc/passwd
file.  check that the user exists.  On some systems (ie., DEC, I believe)
you may have to wave your hands a bit to get the system to accept the
newly created user.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ted Keller <[email-masked]>
Date: Mon, 21 Dec 1998 12:15:01 -0500 (EST)

Michael,

I believe you have to also create a file /etc/shells and add your users
shell into this file....

/bin/sh
/bin/csh
/bin/true

or whatever your OS requires. Note, not all shells are required, only the
ones for those users who will use your ftp daemon.

Hope this helps.

ted keller - bfg.com

---

From: Aris Yannopoulos <[email-masked]>
Date: Mon, 21 Dec 1998 13:49:45 -0500 (EST)

Is all ftp virtual hosting automatically IP based or can it also be name
based?

	Ari(=

  -= Madness is not an illness... it's a privilege... =-

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 21 Dec 1998 14:51:16 -0500 (EST)

On Mon, 21 Dec 1998, Aris Yannopoulos wrote:

> Is all ftp virtual hosting automatically IP based or can it also be
> name based?

All FTP hosting is IP-number based.  The protocol specifications do not
provide for name-based FTP.

There is an IETF-Draft-Specification for name-based FTP using a new
feature, the HOST command.  BeroFTPD has support for the HOST command, but
you should consider that *VERY* experimental and you will probably have to
write a client which uses it since there are currently no known clients
supporting the HOST command.

--

---

From: [email-masked] (M. Schmidt)
Date: Tue, 22 Dec 1998 16:02:13 +0100 (MET)

> From: Gregory A Lundberg <[email-masked]>
> Subject: Re: wu-ftpd (BETA-18) doesn't know users?
> 
[...]

Hi,

the user ftp has been there (really!).
But there must ne a difference between BETA-18 and BETA-15,
with the same setup and configuration BETA-18 doesn't work
here under HP-UX, but BETA-15 does work. 
Curious, isn't it?
So I have built wu-ftpd BETA-15.

An other problem:
It isn't really 100% wuftpd related, but does anybody on 
this list run a HP-UX-10.20 machine?
I have GNU gcc and GNU binutils on our HP-UX-10.20 machine.
As it's recommended to have a statically linked ls in ~ftp/bin I tried
to build one, but I can't build a static version of GNU ls as a curious 
error message occurs. Just for testing an other program could be build
statically.  Please, any help available here??

Thanks in advance.

Have a nice day
Michael

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 22 Dec 1998 12:06:55 -0500 (EST)

On Tue, 22 Dec 1998, M. Schmidt wrote:

> But there must ne a difference between BETA-18 and BETA-15, with the
> same setup and configuration BETA-18 doesn't work here under HP-UX,
> but BETA-15 does work.  Curious, isn't it? So I have built wu-ftpd
> BETA-15.

You really don't want to live in beta-15 for very long.  Some important
security errors were fixed on the way to beta-18.

Hmm .. let's see .. between beta-16 and beta-18 there were

 - a lot of documentation changes
 - a change in 'build' for an error message
 - lots and lots of manpage corrections

 New features added

 - ALTERNATE_CD compile-time added
 - UNRESTRICTED_CHMOD compile-time option added
 - NO_PRIVATE compile-time option added

   ( Strange, isn't it, Stan Barber's avowed policy is not to add new
   features and yet ... )

 ( Ah .. here's the meat ... )

 in the base Makefile:

 - changes for permissions when installing

 in access.c:

 - off-by-one fix for LIMIT clause start-stop times
 - umask 0 wrapped arround open for PID files
 - casting 0 to (off_t)0 for lseek (duh, ok)

 added auth.c for BSDI

 in extensions.c:

 - change %M cookie so -1 displays aas unlimited instead of 0
 - enhance %U cookie to not claim [unknown] user so often for LOG_FAILED
 - change 553 responses to 550

 in ftpcmd.y

 - trivial whitespace changes
 - ensure RNTO has a target pathname before proceeding
 - UNRESTRICTED_CHMOD added
 - make sure we don't free NULL pointers

 in ftpcount.c

 - fix some parsing errors
 - trivial casts probably to support a lame compiler somewhere
 - more whitespace changes

 in ftpd.c

 - added support for SecureWare under SECUREOSF
 - added support for HPUX_10_TRUSTED
 - fixed selection of 'ls' for AIX and Solaris 2
 - fixed S/Key for BSD (BSD_AUTH, auth.c added)
 - wrapped umask 0 arround open for log files
 - added parameter to wu_logwtmp() function
 - some fixes for directory modes on UPLOAD clauses
 - log PASV conections which don't match control
 - reset timeout signal for SIGURG
 - fix some error handling
 - some fixes for the STAT command
 - more response code/format changes for RFC correctness
 - move the RENAME check to a more appropriate location
 - cleanup setproctitle
 - claim we're ftpd not sendmail on setproctitle

 in ftpshut.c

 - die on errors

 in glob.c

 - some support for ALTERNATE_CD (?)

 in hostacc.c

 - changes in error handling and memory management

 in logwtmp.c

 - add 4th parameter (int login)
 - whitespace prettied up

 in pathnames.h

 - support for SOLARIS_2
 - support for USE_LOCAL_ETC
 - support for USE_OPT_FTPD

 in popen.c

 - handle SIGCHLD
 - use /dev/null for stderr

 in src/config (misc changes)

 - config.aix
 - config.bdi
 - config.dec
 - config.fbs
 - config.hpx
 - config.lnx
 - config.nbs

 in src/makefiles (misc changes)

 - Makefile.aix
 - Makefile.bdi
 - Makefile.dec
 - Makefile.gen
 - Makefile.hpx
 - Makefile.lnx
 - Makefile.nbs

 in support/authuser.c

 - corrections for authenticating remote user via RFC 931, something to do
   with trying to bind a port (0=any?) early in the game.

 added support/ftruncate.c

 in support/snprintf.c

 - added support for Solaris 2 and Solaris 2.6

 in support/syslog.c

 - added support for DEC

 added support/vsnprintf.c

 in support/makefiles (misc changes)

 - Makefile.dec
 - Makefile.lnx
 - Makefile.nbs
 - Makefile.sol

 in util/xferstats

 - change default domain from wustl.edu to academ.com
 - move default logfile location

> It isn't really 100% wuftpd related, but does anybody on this list run
> a HP-UX-10.20 machine?

I have two but due to contractual requirements I cannot run any test
builds on them.

> I have GNU gcc and GNU binutils on our HP-UX-10.20 machine. As it's
> recommended to have a statically linked ls in ~ftp/bin I tried to
> build one, but I can't build a static version of GNU ls as a curious

What is the curious message?

Statically linked programs are a help and a hinderance.  They help make
the site easier to set up, but they can be a pain if the lilibrary updates
since you'd need to rebuild the binaries rather than replace the
libraries.  If your site works with shared libraries, stay with them and
don't worry about statically linked.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195