Subject: the ftp user can note delete files he has transferred

From: Anne Sauvage <[email-masked]>
Date: Sat, 05 Dec 1998 19:27:18 +0100

I am using wu-2-4-2 (beta 18) on Solaris.

drwxrwxr-x   3 ftpmap   ftpgroup     512 Oct 30 18:30 incoming

The ftpaccess file contains the line :
upload  /usr/people/ftpwu  /incoming     yes     ftpmap    ftpgroup
0600 dirs
and the line
guestgroup ftp ftpgroup

My user ftpmap (group ftpgroup) transfers the file error.wav for example
(using the software fetch or ws_ftp) :
-rwxrwx---   1 ftpmap   ftpgroup   10008 Dec  5 18:38 error.wav

But he can not delete or rename it (error : permission denied).

Any idea?
--

                 Anne Sauvage
                 GAMSAU - MAP
        Ecole d'Architecture de Marseille
 184 av de Luminy - 13288 Marseille Cedex 09
tel : 04 91 82 71 62/70 - fax : 04 91 82 71 71

---

From: Gregory A Lundberg <[email-masked]>
Date: Sat, 5 Dec 1998 16:57:36 -0500 (EST)

> But he can not delete or rename it (error : permission denied).

The user is 'ftp' and ftp doesn't own the file.  The permission denied
message means your ftpaccess is too loose.  It should have prevented the
_attempt_ to delete the file.  Add

delete no anonymous

And live with the restriction.

To allow anonymous delete is possible (change the upload statement) but
means your security just bye-bye! so don't do that.

If it's a specific user, look at 'guest' access (guestgroup) in the FAQ

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195