Subject: help setup Solaris 2.6

From: [email-masked]
Date: Tue, 29 Dec 1998 10:49:05 -0800

Hello,

I've downloaded the wu-ftpd-2.4.2-beta-18.tar.Z version on my Solaris 2.6
machine and am having trouble with the ./build CC=gcc sol command.  I get a
bunch of errors.  Below is the output.  Anywhere I can look for a
step-by-step setup procedure?

Help is much appreciated!

/Jim Martinez

***************************************************************************
***
./build CC=gcc sol
make args are :
make opts are :  CC=gcc

Linking Makefiles.
Makefile already present in root directory
Makefile already present in src directory
config.h already present in src directory
Makefile already present in support directory

Making support library.
gcc -O -DSOLARIS2  -c authuser.c
In file included from /usr/include/sys/turnstile.h:12,
                 from /usr/include/sys/t_lock.h:20,
                 from /usr/include/sys/vnode.h:37,
                 from /usr/include/sys/stream.h:21,
                 from /usr/include/netinet/in.h:38,
                 from /usr/include/netdb.h:96,
                 from authuser.c:17:
/opt/GCC2721/lib/gcc-lib/sparc-sun-solaris2.5/2.7.2.1/include/sys/param.h:1
85: warning: `NBBY' redefined
/usr/include/sys/select.h:45: warning: this is the location of the previous
 definition
In file included from /usr/include/sys/stream.h:26,
                 from /usr/include/netinet/in.h:38,
                 from /usr/include/netdb.h:96,
                 from authuser.c:17:
/usr/include/sys/model.h:32: #error "No DATAMODEL_NATIVE specified"
*** Error code 1
make: Fatal error: Command failed for target `authuser.o'

Making ftpd.
gcc -g -I.. -I../support -L../support  -c  ftpd.c
In file included from ftpd.c:54:
/opt/GCC2721/lib/gcc-lib/sparc-sun-solaris2.5/2.7.2.1/include/sys/param.h:1
85: warning: `NBBY' redefined
/usr/include/sys/select.h:45: warning: this is the location of the previous
 definition
In file included from /usr/include/sys/stream.h:26,
                 from /usr/include/netinet/in.h:38,
                 from ftpd.c:70:
/usr/include/sys/model.h:32: #error "No DATAMODEL_NATIVE specified"
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
gcc -g -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsupport -lsocket -lnsl -lgen
In file included from /usr/include/sys/turnstile.h:12,
                 from /usr/include/sys/t_lock.h:20,
                 from /usr/include/sys/file.h:17,
                 from ftpcount.c:49:
/opt/GCC2721/lib/gcc-lib/sparc-sun-solaris2.5/2.7.2.1/include/sys/param.h:1
85: warning: `NBBY' redefined
/usr/include/sys/select.h:45: warning: this is the location of the previous
 definition
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors. No output written to ftpcount
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport
 -lsocket -lnsl -lgen
In file included from /usr/include/sys/turnstile.h:12,
                 from /usr/include/sys/t_lock.h:20,
                 from /usr/include/sys/file.h:17,
                 from ftpshut.c:47:
/opt/GCC2721/lib/gcc-lib/sparc-sun-solaris2.5/2.7.2.1/include/sys/param.h:1
85: warning: `NBBY' redefined
/usr/include/sys/select.h:45: warning: this is the location of the previous
 definition
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors. No output written to ftpshut
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: cannot create ckconfig: File exists

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 4272 + 332 + 332 = 4936
Done

---

From: "Ramachandramurthy Sivakumar" <[email-masked]>
Date: Tue, 29 Dec 1998 15:08:27 -0500 (EST)

Jim, 

Compiled binaries for Solaris 2.6 is available from 
ftp://ftp.vr.net/pub/wu-ftpd/binaries/sun/solaris.

I have installed it successfully on solaris 2.5.1.

--
Rama Sivakumar
[email-masked]
Georgia Institute of Technology

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 29 Dec 1998 15:24:49 -0500 (EST)

those binaries are not pure beta-18 .. they include the VR patches .. just
so you know.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "Gjermund Sørseth" <[email-masked]>
Date: Wed, 30 Dec 1998 01:41:22 +0100 (MET)

> Help is much appreciated!

It looks like you are running a gcc that was installed for Solaris 2.5
on your 2.6 machine.  This often causes trouble since OS include
files change between OS versions and gcc keeps it's private copies of them.

-- 
Gjermund Sørseth