Subject: libc.a and values-Xa.o ....?

From: Omar Keblawi <[email-masked]>
Date: Thu, 31 Dec 1998 10:19:30 -0800

Hello again...

I'm making some progress.  

1.  I don't have /lib/libc.a but I to have /usr/lib/libc.so
    How would I modify the "Makefile" to use libc.so instead of libc.a?
    Would it be find just to replace "/lib/libc.a" with
"/usr/lib/libc.so"?
    Can I do that?
    
make: *** No rule to make target `/lib/libc.a', needed by `ftpd'.  Stop.

2.  How do I fix this?  I'm missing values-Xa.o, but I don't know where
    it's reference.
	
	ld: fatal: file values-Xa.o: open failed: No such file or directory

3.  Is the the "gen" library necessary?

		ld: fatal: library -lgen: not found

Much Appreciated.
Omar

........Details  below........

ftpsrvr# ./build sol
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o 
touch libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
yacc  ftpcmd.y 
mv -f y.tab.c ftpcmd.c
gcc -g -DDEBUG -I.. -I../support -L../support   -c ftpcmd.c -o ftpcmd.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c glob.c -o glob.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c logwtmp.c -o
logwtmp.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c popen.c -o popen.o
sh newvers.sh
gcc -g -DDEBUG -I.. -I../support -L../support -c vers.c
gcc -g -DDEBUG -I.. -I../support -L../support   -c access.c -o access.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c extensions.c -o
extensions.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c realpath.c -o
realpath.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c acl.c -o acl.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c private.c -o
private.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c authenticate.c -o
authenticate.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c conversions.c -o
conversions.o
gcc -g -DDEBUG -I.. -I../support -L../support   -c hostacc.c -o
hostacc.o
make: *** No rule to make target `/lib/libc.a', needed by `ftpd'.  Stop.

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen 
ld: fatal: file values-Xa.o: open failed: No such file or directory
ld: fatal: library -lgen: not found
ld: fatal: File processing errors. No output written to ftpcount
make: *** [ftpcount] Error 1

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 31 Dec 1998 13:55:25 -0500 (EST)

1) On 'realpath', the correct solution is to #define it to something else

2) On 'libc.a', sounds like you're using the wrong version compiler

3) On 'values-Xa.o', sounds like something in the runtime

4) On '-lgen', depends upon the system you're running

It sounds to me like

 - you may be building an old, old version.  The current version of the
   ftp daemon is 2.4.2 (Beta-18) and is available from the site below.

 - you may be building using old GNU gcc or libraries

 - you need to read the FAQ

There's a site with just referenced on this list which handles free
software for Sun systems.  Also, there's a pre-compiled version with the
VR patches available at my ftp site.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Omar Keblawi <[email-masked]>
Date: Thu, 31 Dec 1998 12:48:22 -0800

Gregory,

Thanks for your help.  I downloaded the latest one and you are right
there where no problems with the "realpath".  But the other problems
still
do appear.  The gcc I'm using is a pkg installed that I downloaded from
www.sunfreeware.com.

ftpsrvr# gcc -v
Reading specs from
/usr/local/lib/gcc-lib/sparc-sun-solaris2.6/2.8.1/specs
gcc version 2.8.1

Omar

Making ftpd.

Making ftpcount.
gcc -g -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsupport -lsocket -lnsl -lgen  
ld: fatal: file values-Xa.o: open failed: No such file or directory
ld: fatal: library -lgen: not found
ld: fatal: File processing errors. No output written to ftpcount
make: *** [ftpcount] Error 1