Subject: When a unique user can't DIR

From: "Gwend'" <[email-masked]>
Date: Fri, 18 Dec 1998 15:12:53 +0100

Hi

I have a little problem, which should not be very nasty. Sorry if I'm a
new wu-ftpd user...

Well,
I've created an user, and averyting is OK : he sees only what he needs
to see, he's restricted to the needed area, he gets, puts, etc.

BUT nor LS nor DIR commands work properly. They both answer :

ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.

Many files should appear, and they don't.

Consider that this is the only user rising such a problem. Other ones
can LS and DIR normally.

What could be the difference between he and them ?

Thank you.
Gwendal Roué

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Dec 1998 10:05:31 -0500 (EST)

> Many files should appear, and they don't.

Missing libraries, programs or other glue.  Check the FAQ.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "Gwend'" <[email-masked]>
Date: Fri, 18 Dec 1998 16:13:38 +0100

> Missing libraries, programs or other glue.  Check the FAQ.

Well, thank you, but I'm not sure this is the solution. Remember only
ONE user raises the problem...

I won't install multiple libraries for multiple users...

Gwendal Roué
Publicis Technology

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Dec 1998 11:31:17 -0500 (EST)

> I won't install multiple libraries for multiple users...

then you need to re-think your security model.

Here, I use the following general rules:

 - anonymous ftp chroot'd to its own area, gets a copy of the glue.

 - all users are guests and chroot'd to a common point with a copy of the
   glue shared between them all

 - each virtual host chroot's to its own area and gets a copy of the glue

 - guest and anonymous users for the virtual hosts chroot to the host's
   area and share that glue instead of the general-user area's

To assist in copying the glue, I have the parts needed in loop-back mount
filesystems which I mount read-only into each chroot area so I'm really
only paying for the files once.

All this _IS_ covered in the FAQ, but may require some thinking to see how
to apply it.

--

---

From: Ghent <[email-masked]>
Date: Fri, 18 Dec 1998 12:37:48 -0500 (EST)

I would say it's a permission problem, most likely on the directory.  That
may seem a little easy, but you didn't mention what the permissions were,
so that's what I would check first

 - Ryan

[===================================================]
[- Ryan McLean - Network/System Administrator       ]
[-- Starshadow Communications                       ]
[--- Calgary, Alberta, Canada - Cleveland, Ohio USA ]
[---- http://www.starshadow.com                     ]
[===================================================]

---

From: "Paul F. Williams" <[email-masked]>
Date: Fri, 18 Dec 1998 11:54:21 -0600 (CST)

I ran into what may be a similar problem.
The 'ls' command would work but 'dir' did
not produce any file listing.

It was caused by the ./lib entries

I don't understand how it works but there is some critical
libraries such as
  libc.a       libcurses.a
that must be the correct versions. 
The FAQ makes an off comment about library files but
it was not obvious to me what was happening.
When I put in the correct lib files the 'dir'
command started working.

This may be what is happening on your system.
(Perhaps not)

paulw

> so that's what I would check first

------------------------------------------------------------
Paul F. Williams, Network Administrator, Information Systems
UW-Extension, 432 N. Lake St.,  Madison, WI 53706
[email-masked], 608-262-6011, FAX 608-262-2343
------------------------------------------------------------