Subject: Re: Can not login after ftpd -A to ftp -a

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 17 Nov 1998 07:09:37 -0500 (EST)

On Tue, 17 Nov 1998, Henry Leung wrote:

> 530 User author access denied...
> Login failed.
> 
> What happend??

You tell me.  The answer's in your system log.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Henry Leung <[email-masked]>
Date: Tue, 17 Nov 1998 14:17:23 +0800

Hi, all:

I have just set up anonymous ftp on my testing on solaris 2.6. It works.

But when I ( follow "A How-to Guide for wu-ftpd on Solaris 2.x ")
    1.create a user "author" in /etc/passwd;
    2.a group "webauth" in /etc/group;
    3.create directories like anonymous;
    4.create ftpaccess in /opt/WUftp/etc/;
        class   all   real,guest,anonymous *

        delete          no      guest,anonymous         # delete
permission?
        overwrite       no      guest,anonymous         # overwrite
permission?
        rename          no      guest,anonymous         # rename
permission?
        chmod           no      guest,anonymous         # chmod
permission?
        umask           no      guest,anonymous         # umask
permission?

        guestgroup webauth
    5.change ftpd -A -> ftpd -a in /etc/inet/inet.conf
    6.restart inetd

It still gave me message below:
****************************
530 User author access denied...
Login failed.
ftp>
****************************

What happend??
:-(

---

From: Henry Leung <[email-masked]>
Date: Wed, 18 Nov 1998 11:28:18 +0800

Dear Sir:

thank you for your help firstly.

>From the system log file, I do find something wrong. I corrected the
mistake.

Now , All real, anonymous user can login, but guest ( author ) still can
't.

What should I do next? :-)

Here is the tail of system log file :
Nov 18 10:21:42 dev2 ftpd[3304]: USER author
Nov 18 10:22:25 dev2 ftpd[3304]: QUIT
Nov 18 10:22:25 dev2 ftpd[3304]: FTP session closed
Nov 18 10:22:45 dev2 ftpd[3308]: USER author
Nov 18 10:22:50 dev2 ftpd[3308]: QUIT
Nov 18 10:22:50 dev2 ftpd[3308]: FTP session closed

Here is the ftpaccess file:
class   local   real,guest,anonymous *

delete          no      guest,anonymous         # delete permission?
overwrite      no      guest,anonymous         # overwrite permission?
rename        no      guest,anonymous         # rename permission?
chmod         no      anonymous                  # chmod permission?
umask         no      anonymous                  # umask permission?

guestgroup      webauth

Here is the ftp login dialog:
Connected to ...................
220 dev2 FTP server (Version wu-2.4(2) Mon Jun 2 12:37:12 EDT 1997)
ready.
Name (..................:henry): author
530 User author access denied...
Login failed.
ftp>

Best Regards

> You tell me.  The answer's in your system log.

  Leung wrote:
Hi, all:

        guestgroup webauth

What happend??
:-(

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 17 Nov 1998 23:26:33 -0500 (EST)

On Wed, 18 Nov 1998, Henry Leung wrote:

> Now , All real, anonymous user can login, but guest ( author ) still
> can 't.

>     2.a group "webauth" in /etc/group;

"author" should be a member, explicity shown, in "webauth" so the
guestgroup makes him a guest.

>     4.create ftpaccess in /opt/WUftp/etc/;

The FAQ should cover all this.  I'd look in the system log for a reason
like 'not in any class' or 'bad shell' from ftpd when "author" tries to
log in.  Response '530 User %s access denied' can mean any of the
following:

 - Remote host access denied, listed in /etc/ftphosts, see syslog
 - Anonymous login but 'ftp' or 'anonymous' in /etc/ftpusers, see syslog
 - Real/guest login, user in /etc/ftpusers or has a bad shell in
   /etc/passwd, see syslog
 - General access denied, see syslog, one of the following:
   - Cannot read /etc/ftpaccess
   - Host denied by 'deny' in /etc/ftpaccess
   - not in any 'class' in /etc/ftpaccess
   - user 'limit' in /etc/ftpaccess reached

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

--