Subject: ls Returns nothing for guest users

From: "Tom deLombarde" <[email-masked]>
Date: Fri, 27 Nov 1998 13:27:15 -0500

I know this has been discussed - and have tried all of the tests
that I have seen suggested.

Problem: Neither 'ls' nor 'dir' deliver any text for users in the
guest group. ls works fine for both real users and anonymous.

I have tried:
1. Copying ls from /home/ftp/bin into users' bin directory
    instead of /bin/ls (they are different on my system,
    and both work the same).

2. Directly invoking the /home/test/bin/ls copy of ls 
   ($ /home/test/bin/ls - it works)

3. The chroot test. (chroot /home/test sh -c "/bin/ls" 
    - it works).

The system is:
Redhat Linux 5.0
Stronghold 2.3 (Apache 1.2.6)
wu-ftp (not sure how to get version,
           /usr/lib/linuxconf/modules/wuftpd.so.1.11.11)

If anyone can point me in the right direction it will be
very much appreciated.

Tom deLombarde
[email-masked]
http://www.blackflute.com/

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Fri, 27 Nov 1998 22:30:41 +0100 (CET)

> guest group. ls works fine for both real users and anonymous.

You very probably don't have an ls command (or the libraries it requires)
in the root directory for your guest users.
Either get BeroFTPD (which implements ls internally, and therefore doesn't
need the files), or read the FAQ.

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.