Subject: User ending up in root dir

From: Maribeth Miguel <[email-masked]>
Date: Fri, 6 Nov 1998 13:43:33 -0800

Hello,

We're running wu-ftpd v2.4(20) on a Solaris 2.5.1 machine.  The 
authentication is done via NIS+.  We are having problems with people that 
are able to log in successfully because they have a NIS+ account, but if 
they don't have a physical home directory on the box, they are dropped into 
the user root home dir ("/").  We want to not let them log in if their home 
directory does not exist on the box they are ftping to.

How can we do that?

Please advise.

Thanks,
Maribeth
------------------
Maribeth Miguel
SBC Internet Services
[email-masked]
(415) 442-4517

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 6 Nov 1998 16:56:32 -0500 (EST)

On Fri, 6 Nov 1998, Maribeth Miguel wrote:

> authentication is done via NIS+.  We are having problems with people
> that are able to log in successfully because they have a NIS+ account,
> but if they don't have a physical home directory on the box, they are
> dropped into the user root home dir ("/").  We want to not let them
> log in if their home directory does not exist on the box they are
> ftping to.
> 
> How can we do that?

ISTR something about this some time ago.  Check the FAQ and the mailing
list archives.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195