Subject: com err

From: "Srikanth A." <[email-masked]>
Date: Mon, 12 Oct 1998 12:43:43 +0530

Hi all
	I have compilation problem on Solaris2.6 machine. Error is
build CC=gcc sol
make args are : 
make opts are :  CC=gcc
 
Linking Makefiles.
 
Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a
 
Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
yacc  ftpcmd.y
mv y.tab.c ftpcmd.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpcmd.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  glob.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  logwtmp.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  popen.c
sh newvers.sh
gcc -g -DDEBUG -I.. -I../support -L../support -c vers.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  access.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  extensions.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  realpath.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  acl.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  private.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  authenticate.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  conversions.c
gcc -g -DDEBUG -I.. -I../support -L../support  -c  hostacc.c
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o
glob.o logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o
private.o authenticate.o conversions.o hostacc.o -lsupport -lsocket
-lnsl -lgen
ld: fatal: file crt1.o: open failed: No such file or directory
ld: fatal: file crti.o: open failed: No such file or directory
ld: fatal: file crtbegin.o: open failed: No such file or directory
ld: fatal: file crtend.o: open failed: No such file or directory
ld: fatal: file crtn.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to ftpd
*** Error code 1
make: Fatal error: Command failed for target `ftpd'

Can some one help me 

thanks
Srikanth A.

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Mon, 12 Oct 1998 09:36:14 +0200 (MET DST)

> ld: fatal: File processing errors. No output written to ftpd

crt1, crti, crtbegin, crtend are all part of the standard C
functionality.  The above errors show that the machine that you are
trying to build wu-ftpd on misses most part of the C development kit
(it's a miracle 'make' is still working).

The solution is to find out which packages of Solaris are needed to
give development support and install these. You need a development
system to be able to compile C programs even if you don't use Solaris
cc.

                                           Koos van den Hout

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Work)                                Fax: +31-30-2586290
  [email-masked] (Home)                      Workphone: +31-30-2586287
  http://web.cetis.hvu.nl/~koos/   Looking for a license plate with "RFC 822"