Subject: BeroFTPD-1.1.14 released

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Fri, 9 Oct 1998 21:26:17 +0200 (CEST)

BeroFTPD 1.1.14 is in the usual places...
ftp://beroftpd.unix.eu.org/pub/BeroFTPD/
ftp://ftp.croftj.net/usr/bero/BeroFTPD/
ftp://ftp.sunet.se/pub/nir/ftp/servers/BeroFTPD/
ftp://sunsite.cnlab-switch.ch/mirror/BeroFTPD/

Changes:
v1.1.14
=======
* Fix uploads for guest users
* SunOS compatibility fixes
* Remove a C++ style ("//") comment that might break some C compilers
* Fix compilation bug with --disable-virtual
* detect ut.* structure members correctly on systems that need time.h
  to be included before utmp.h (FreeBSD 3.0)
* Make HOST implementation more consistant with the draft
+ Make support for old (wu-ftpd)-style virtual hosts optional, disable
  by default
+ Merge VR8 changes (ftp://ftp.vr.net/pub/wu-ftpd):
  * Add SITE CHECKMETHOD and SITE CHECKSUM support
  * ftpconversions sample: add .crc and .md5 support
  * IGNORE_NOOP option
  * site-exec-max-lines ftpaccess clause
  * Bugfixes
  * Add hostname and email option to (old) virtual
  * Add 'greeting' clause

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.

---

From: Amal Phadke <[email-masked]>
Date: Sun, 11 Oct 1998 11:23:32 -1000 (HST)

> ftp://sunsite.cnlab-switch.ch/mirror/BeroFTPD/

I just built BeroFTPD 1.1.14 on my MkLinux box. I must say it builds very
nicely. But I found a harmless bug. I don't currently subscribe to
BeroFTPD mailing lists, so I don't know whether anybody else pointed it
out or not.

I built BeroFTPD with internal-ls-command. But I realized that when
listing the contents of directory, the internal ls command fails to show
user executable permission on subdirectories. eg.

ftp> cd pub/MkLinux/kernels 
250 CWD command successful.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for directory listing.
total 8
drw-r-xr-x   2 root     root         1024 Sep 10 09:47 DR2.1update6
drw-r-xr-x   2 root     root         1024 Sep 15 11:16 DR3
drw-r-xr-x   2 root     root         1024 Sep 10 09:47 DR3alpha1
drw-r-xr-x   2 root     root         1024 Sep 10 09:47 DR3alpha4
226 Transfer complete.
270 bytes received in 0.047 seconds (5.66 Kbytes/s)

The following patch to src/ftpd.c fixes the problem.

--- ftpd.c.orig Fri Oct  9 08:43:50 1998
+++ ftpd.c      Sun Oct 11 11:00:48 1998
@@ -2983,7 +2983,7 @@
                permissions[1]='r';
        if((s.st_mode&S_IWUSR)==S_IWUSR)
                permissions[2]='w';
-       if((s.st_mode&S_IXUSR)==S_IWUSR)
+       if((s.st_mode&S_IXUSR)==S_IXUSR)
                permissions[3]='x';
        if((s.st_mode&S_IRGRP)==S_IRGRP)
                permissions[4]='r';

Thanks.
---
Amal Phadke
Department of Ocean Engineering
University of Hawaii at Manoa

e-mail: [email-masked] (MkLinux DR3)

---

From: Michael Hall <[email-masked]>
Date: Sun, 11 Oct 1998 15:13:58 -0700

> user executable permission on subdirectories. eg.

  Bernhard posted a fix for this, try grabbing:
  
  '/pub/BeroFTPD/BeroFTPD-1.1.14-ls-fix.diff'

  It fixed the problem here.

--
Yellow matter custard dripping from a dead dogs eye...

Mike Hall <[email-masked]>, (MH993)   -    http://www.riverside.org
System Administrator (*nix, Perl, CGI hacker, certified OS/2 Specialist)