Subject: Re: virtual server capabilities?

From: Sergey Mukhin <[email-masked]>
Date: Fri, 9 Oct 1998 00:10:56 +0300

Hi all,

First time writing here.

Looks like there is some common set of features people would like
to have in FTP servers ( as well as in POP3 and others ).

For some time I was slightly rewriting WU-FTPD and now my version
( based on beta 18 ) can handle completely independend users sets
for each virtual server too.

If anybody is interested I can put it on FTP site.

There is another feature, however.  All users data is placed to
database (  for now it is MySQL ), though passwords from /etc/passwd
are valid as well. 

And there also is a way to restrict user's access to his
home directory, merely blocking commands concerned files outside it.

>>>>> "G" == Gregory A Lundberg <[email-masked]> writes:
G> Date: Thu, 8 Oct 1998 13:28:13 -0400 (EDT)
G> To: Dustin Cavanaugh <[email-masked]>
G> Cc: [email-masked]

G> On Thu, 8 Oct 1998, Dustin Cavanaugh wrote:

>> I've got virtual servers up and running on SunOS 2.5. I'd like to have
>> users end up in different directories depending on who they login as
>> and which ip address they login to.
>> 
>> In ftpaccess I specify:
>> virtual 999.999.999.30 root /export/home0
>> virtual 999.999.999.31 root /export/home1
>> (bogus ip just for illustration)
>> 
>> Is there a way for joe-user to login and end up in
>> /export/home0/joe-user
>> /export/home1/joe-user
>> and
>> mary-user to end up in
>> /export/home0/mary-user
>> /export/home1/mary-user
>> respectively for the .30 and .31 address?

G> With base, beta-18:
G>   No

G> With beta-18-vr8:
G>   Almost.  Only one virtual site per user, though.

G> With BeroFTPD:
G>   Yes.  and you can have different passwords on each virtual server as
G>   well.

G> --

G> Gregory A Lundberg		Senior Partner, VRnet Company
G> 1441 Elmdale Drive              [email-masked]
G> Kettering, OH 45409-1615 USA    1-800-809-2195

-- 
------------------------------------------------------------------------
    Sergey Mukhin			|    [email-masked]
    Network Administrator		|    http://violet.rosnet.net/
    Russian Telecommunications Network	|    Tel: + 7 095 206 62 15
    Moscow, Russia			|	  + 7 095 755 85 88
------------------------------------------------------------------------
*     If you can't learn do it well learn to enjoy doing it badly.     *
------------------------------------------------------------------------

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Fri, 9 Oct 1998 00:21:53 +0200 (CEST)

> database (  for now it is MySQL ), though passwords from /etc/passwd

Please put it somewhere then - I'd like to have a look at this.

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.