Subject: RE: Problem with ls -l on Solaris

From: [email-masked]
Date: Wed, 14 Oct 1998 12:38:56 +0300

Hi,

I'm not sure but may be  /dev/zero permissions are not right.
Below is my /~ftp/dev tree:

dev:
total 0
crw-r--r--   1 root     sys       11,  42 Mar 17  1998 tcp
crw-r--r--   1 root     sys       13,  12 May  4  1996 zero

You should run the followings command to create ~ftp/dev with right devices:

cd ~ftp/dev
mknod zero c 13 12
mknod tcp c 11 42
chmod 644 *

That's all. I hope it helps you.

Sincerely,
Alexander Velichko

> ----------
> From: 	Martin Arlt[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	13 ÏËÔÑÂÒÑ 1998 Ç. 21:43
> To: 	[email-masked]
> Subject: 	Problem with ls -l on Solaris
> 
> Hi,
> 
> I compiled and installed WU-FTP 2.4.2-academ[BETA-18] on a
> SUN under Solaris 2.6. I configured it also for anonym. user,
> but I can't get ls to work.
> 
> I setup the server like in a description in the WU-FTP WEB-page
> (with ~ftp/bin; ~ftp/dev; ~ftp/usr/lib; etc.). But ls (or any
> other dynam. program) doesn't work - yes, I copied all the
> libs and setup all the other stuff.
> 
> I tried to run truss with the chroot command:
> 
> sh# truss chroot /var/ftp /bin/ls
> ...
> chroot("/var/ftp")                              = 0
> chdir("/")                                      = 0
> execve("/bin/ls", 0xEFFFFC8C, 0xEFFFFC94)  argc = 1
> open("/dev/zero", O_RDONLY)                     Err#6 ENXIO
> open("/dev/zero", O_RDONLY)                     Err#6 ENXIO
> ld.so.1: internal: malloc failedwrite(2, " l d . s o . 1 :   i n t".., 32)
> = 32
> getpid()                                        = 24744 [24743]
>         *** process killed ***
> ...
> 
> it seems, ls can't open the zero device, which I created with the same
> device numbers like the zero device under /devices/pseudo/...
> Err#6 ENXIO means: No such device or address
> 
> Does anybody have an idea what I have to do, that the program can open
> the device? The permission on the device are 00666 and the device is
> a "c" device chreate with "mknod zero c <maj> <min>" .
> 
> Thanks for any help and suggestions.
> 
> Martin Arlt
>

---

From: Bob Luckin <[email-masked]>
Date: Wed, 14 Oct 98 10:32:19 CDT

> crw-r--r--   1 root     sys       13,  12 May  4  1996 zero

You're correct - they need to be world writeable under Solaris 2...

Here's my Solaris 2.5.1 ~ftp/dev tree :

crw-rw-rw-   1 root     other     11, 42 Mar 26  1998 tcp
crw-rw-rw-   1 root     other    105,  1 Mar 26  1998 ticotsord
crw-rw-rw-   1 root     other     11, 41 Mar 26  1998 udp
crw-rw-rw-   1 root     other     13, 12 Mar 26  1998 zero

There is some mention of this in the WU-FTPD FAQ at
   http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
under question 10.13...

It is also covered in the How-To Guide For Solaris 2.5.x at
   http://www.wildheart.org/wu-ftpd/
in the "Anonymous User Setup" section.

I recommend either of these documents if you have further problems.

Good luck !

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "Coder, adapt.  FTP Ada, redo C"
                                 [http://www.dhc.net/~luckin/palindromes.html]