Subject: how to limit user

From: Yung-Ta Hsu <[email-masked]>
Date: Mon, 26 Oct 1998 16:42:17 +0800

after a normal user conneecting to the machine via ftp, how to make him
can't change directory upper than his home-directory?

adding 'chroot' to ftpd.c? how to do it?

--
Yung-Ta Hsu
LISA Lab of Software Research Center, National Central University
mailto:[email-masked], http://www.me.ncu.edu.tw/~arda/
ICO: 5892252, mailto:[email-masked],
http://wwp.mirabilis.com/5892252

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 26 Oct 1998 07:03:15 -0500 (EST)

> can't change directory upper than his home-directory?

Create a Unix group for such users
Add users to that Unix group
Add guestgroup statement to ftpaccess

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Chris Mooney <[email-masked]>
Date: Mon, 26 Oct 1998 07:23:33 -0500

Use the command <man ftpaccess> to get more information..... and i belive
there is a good how to heer....
http://www.tnt.uni-hannover.de/soft/info/ftp/wu-ftpd/guest-howto

Chris Mooney

--
 _______ ______  ____   ___ _______ ________ ______
|__   __|   ___||    \ |   |__   __|__    __| _____|
 __| |__|  |_---|   |\     |__| |__   |  |  | ____|
|_______|____   |___| \____|_______|  |__|  |______|
             |__|
            ________ __   __ ______
           |__    __|  |_|  | _____|
              |  |  |   _   | ____|
              |__|  |__| |__|______|         ___
   __    __   _____   ______   ___        __|   |
  \  \/\/  //   _   \|    _  \|   |     /   _   |
   \  /\  /|   (_)   |   |_) /|   |___ |  ( _|  |
    \/  \/  \_______/|___|\___\_______| \ ______|

---

From: Yung-Ta Hsu <[email-masked]>
Date: Thu, 29 Oct 1998 10:15:17 +0800

as you describe, setup 'ftpaccess' file can done it.
but if I want every one of my user can't change directory upper than their
home diectory, I need to copy 'bin/ls', 'lib, 'etc' files to each user's diectory?

is there other way that I don't need to setup bin, lib, and etc files to users'
home and can limit them can't change directory upper than their home?

Wild Apache Support wrote:

> Hello,
>
> I have it working on my Linux boxes, see if these instructions help
>
> Regards,
>
> Murrah Boswell
> Wild Apache Support <[email-masked]>
>
> Yung-Ta Hsu wrote:
>

--
Yung-Ta Hsu (ARDA), ICO: 5892252, CICQ: 107798
LISA Lab of Software Research Center, National Central University
mailto:[email-masked], http://residence.src.ncu.edu.tw/~arda/

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 29 Oct 1998 11:34:24 -0500 (EST)

On Thu, 29 Oct 1998, Yung-Ta Hsu wrote:

> as you describe, setup 'ftpaccess' file can done it. but if I want
> every one of my user can't change directory upper than their home
> diectory, I need to copy 'bin/ls', 'lib, 'etc' files to each user's
> diectory?
> 
> is there other way that I don't need to setup bin, lib, and etc files
> to users' home and can limit them can't change directory upper than
> their home?

If they're on the same filesystem, you can hard-link the files so you're
only actually paying for one copy.  Otherwise, export the directories with
a loopback mount and mount them read-only into each user's area.

The easiest solution is to put all users in a single directory and chroot
them to that common point:

/home
/home/bin
/home/etc
/home/ftp
/home/ftp/bin
/home/ftp/etc
/home/user01
/home/user02
...

Use permissions to keep the users out of each other's areas.  I have an
example site laid out in ftp://ftp.vr.net/pub/wu-ftpd

One other way is to give up the ability to use on-the-fly tar, compress,
etc., and use the BeroFTPD derivitive of wu-ftpd.  BeroFTPD has a built-in
'ls'.  You'll still need copies of the support stuff (passwd, group, etc)
but avoid copying the external executables.

--