Subject: compile

From: "Srikanth A." <[email-masked]>
Date: Thu, 08 Oct 1998 14:46:19 +0530

Hi all,
	I have a problem while compiling. Error is 
sh build CC=gcc sol
make args are : 
make opts are :  CC=gcc
 
Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical
 
Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a
 
Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:180: previous declaration of `realpath'
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'
 
Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen 
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'
 
Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c
vers.o -lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'
 
Making ckconfig.
gcc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c
 
Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 7387 + 788 + 360 = 8535
Done

Can somebody help me out.

OSver: 5.6(Solaris)
gccver: 2.8.1
wu-ftp: 2.4-academ

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 8 Oct 1998 10:52:27 -0400 (EDT)

> ftpd.c:143: conflicting types for `realpath'

To src/config/config.<os> append the following line:

#define realpath realpath_on_steroids   /* hack to work around unistd.h */

Then run './build clean' and './build <os>'

> wu-ftp: 2.4-academ

Better solution: get the current version.

2.4-academ is VERY old and should not be used unless your computer never
connects to any network or you don't care a bit aobut security.

The current version is wu-ftpd-2.4.2-beta-18.tar.Z

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195