Subject: Normal ftp clients work, Netscape ftp's fail

From: Stephane Robertson <[email-masked]>
Date: Sun, 04 Oct 1998 16:32:05 -0400

Hi Folks,

I have problem with netscape ftp with wu-ftpd 2.4.2 beta 16.
I looked in the faqs and they said to do a chmod of ~ftp/dev/tcp to 666
to make netscape working but it still doesn't work after the changes.

I didn't have the ~ftp/dev directory so I created the directory
Here's a listing of ~ftp/dev in ftp directory
   d--x--x--x   2 root     root         1024 Oct  4 15:58 dev

I also created a file in ~ftp/dev named tcp
Here's a listing of ~ftp/dev/tcp in ~ftp/dev directory
   -rw-rw-rw-   1 root     root            0 Oct  4 16:15 tcp

I'm not certain if it should be a normal file or a device
file like those in /dev so I also tried creating a caracter
file like this one:
    crw-rw-rw-   1 root     root      18,   3 Oct  4 15:58 tcp

but I still have problems with netscape ftp

What's wrong? do i need a tcp file in /dev also?
Can someone help me with this problem??

thanks in advance

Stephane

---

From: Gregory A Lundberg <[email-masked]>
Date: Sun, 4 Oct 1998 17:00:42 -0400 (EDT)

> I have problem with netscape ftp with wu-ftpd 2.4.2 beta 16.

Which platform, OS and version are you running on?

> I looked in the faqs and they said to do a chmod of ~ftp/dev/tcp to
> 666 to make netscape working but it still doesn't work after the
> changes.
> 
> I'm not certain if it should be a normal file or a device file like
> those in /dev so I also tried creating a caracter file like this one:

~ftp/dev should look like /dev.  ~ftp/dev/tcp should look like /dev/tcp

> What's wrong? do i need a tcp file in /dev also?

If you don't have one in /dev, you don't need one in ~ftp/dev

> Can someone help me with this problem??

You'll need to say more the 'it fails' .. what's failing?  Does it
connect?  Can you transfer files?  Is it that you cannot see the directory
contents?

The most likely reason is you've not completely set things up.  It's
extremely rare that the vendor's documentation for anonymous FTP plus the
FAQ don't have the answer.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Stephane Robertson <[email-masked]>
Date: Sun, 04 Oct 1998 18:27:53 -0400

>Which platform, OS and version are you running on?

I'm running redhat 5.1 with linux kernel 2.0.34. Initially
there was no tcp file in /dev and no ~ftp/dev directory.

The problem is that sometimes netscape don't display the
directory contents and if I press the stop button the
directory contents will be displayed and I will be able
to transfer files. I'm running communicator 4.05 for windows.
The linux version of communicator was working well without
the tcp file in ~ftp/dev.

I'm confused !!! May be it's my home computer with the ppp link
that cause this problem. I'll try my business computer tomorrow
and i'll give some feedback..

Can you tell me what the /dev/tcp file do? Is it necessary?

Stephane

---

From: Gregory A Lundberg <[email-masked]>
Date: Sun, 4 Oct 1998 21:46:48 -0400 (EDT)

On Sun, 4 Oct 1998, Stephane Robertson wrote:

> I'm running redhat 5.1 with linux kernel 2.0.34. Initially there was
> no tcp file in /dev and no ~ftp/dev directory.

Linux doesn't need any special devices for the FTP daemon.  The /dev/tcp
information in the FAQ is for other platforms.

> The problem is that sometimes netscape don't display the directory
> contents and if I press the stop button the directory contents will be
> displayed and I will be able to transfer files.

You have an incomplete setup for the external 'ls' command.  Probably
because you're using Redhat's shared-libraries version and are missing the
libraries.

I've an example site layout at ftp://ftp.vr.net/pub/wu-ftpd/examples which
may help you.  It's laid out presuming statically linked programs, so no
libraries are required.  Statically-linked Linux binaries are also
available at my site, if you need them.

> I'm confused !!! May be it's my home computer with the ppp link that
> cause this problem. I'll try my business computer tomorrow and i'll
> give some feedback.

I rather doubt things will be much different.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195