Subject: Ftpaccess question

From: Tulan Shah <[email-masked]>
Date: Mon, 26 Oct 1998 17:45:05 +0000 (GMT)

Hi all,

I have got wu-ftp VR9 running on a solaris 2.6 box all is well.

What I need from the daemon is to allow the upload command in ftpaccess 
to work on folders other than within the ftp users tree.

upload  /var/ftp * no
upload	/var/ftp /incoming yes	root	other	0600

will allow uploads to /var/ftp/incoming which are owned by root/other

what I would like to do is for a guest user "project" in group ftponly
to have something like

upload /users/project * no
upload /users/project /incoming  yes  tulan  staff  0600 

So that project can upload files but the owner will become tulan/staff.

I read the man page for ftpaccess which states that root folder in the 
command must be the same as for the user ftp in the /etc/passwd file. 
Is there anyway of overriding this or hacking the code to allow it to 
work?

Thanks,

Tulan

----------------------
Tulan Shah
Design Information Group
http://www.dig.bris.ac.uk/staff/tulan/

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 26 Oct 1998 13:07:25 -0500 (EST)

> Is there anyway of overriding this or hacking the code to allow it to 

I do it here in two ways; one for a real user (me!) and one for a guest
who owns a virtual ftp-site.  Here's how I do it:

virtual x.x.x.x root     /home/users/owner/ftp
virtual x.x.x.x banner   /home/users/owner/ftp-banner
virtual x.x.x.x hostname ftp.owner.com
virtual x.x.x.x email    [email-masked]
virtual x.x.x.x allow    owner

deny-uid %-99 vrnet
deny-gid %-99 vrnet
allow-uid ftp
allow-gid ftp

guestuser *
realuser ftp
realuser lundberg

anonymous-root /home/ftp

guest-root /home/users
guest-root /home/users/owner/ftp guest

hostname ftp.vr.net

email [email-masked]

upload /home/users/lundberg * no
upload /home/users/lundberg /tmp yes nodirs
upload /home/users/lundberg /home/users/lundberg yes
upload /home/users/lundberg /home/users/lundberg/* yes
upload /home/users/lundberg /home/ftp/incoming yes vrnet vrnet 440 nodirs
upload /home/users/lundberg /home/ftp/incoming/* yes vrnet vrnet 440 nodirs
upload /home/users/lundberg /home/ftp/private/*/incoming yes * * 440 nodirs
upload /home/users/lundberg /home/ftp/private/*/incoming/* yes * * 440 nodirs

upload /home/ftp * no
upload /home/ftp /incoming yes vrnet vrnet 440 nodirs
upload /home/ftp /incoming/* yes vrnet vrnet 440 nodirs
upload /home/ftp /private/*/incoming yes * * 440 nodirs
upload /home/ftp /private/*/incoming/* yes * * 440 nodirs

upload /home/users/owner/ftp * no
upload /home/users/owner/ftp /incoming yes owner guest 400 nodirs
upload /home/users/owner/ftp /incoming/* yes owner guest 400 nodirs

upload /home/users/* / no
upload /home/users/* /bin no
upload /home/users/* /bin/* no
upload /home/users/* /etc no
upload /home/users/* /etc/* no
upload /home/users/* /owner/ftp/bin no
upload /home/users/* /owner/ftp/bin/* no
upload /home/users/* /owner/ftp/etc no
upload /home/users/* /owner/ftp/etc/* no

noretrieve core
noretrieve /boot/ /dev/ /lost+found/ /proc/ /home/lost+found/
noretrieve /home/users/bin/ /home/users/etc/
noretrieve /home/users/owner/ftp/bin/ /home/users/owner/ftp/etc/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195