Subject: ftpconversions don't work :-(

From: Thomas Lademann <[email-masked]>
Date: Tue, 13 Oct 1998 12:38:36 +0200

Hi !

ftpconversions don't work and i read all FAQ's and old archives....
I tried 10000 things..........
WU-ftpd works fine, but noooooo file conversion.....
My idea is to have a ftp-archive for one user.
The uploaded files will be "put" compressed and
the "get" uncompressed automatically.

1) My OS is SOLARIS 2.5.1

2) My wu-ftpd source is a precompiled version from
http://www.sunfreeware.com.

3) cat ftpaccess
class   all    real   185.2.30.52

limit   all   10   Any   /opt/WUftpd/messages/limit.msg

compress   yes   *
tar        yes   *

banner   /opt/WUftpd/messages/banner.msg

message   /opt/WUftpd/messages/login.msg   login
message   /opt/WUftpd/messages/cwd.msg   cwd=*

log   commands    real
log   transfers   real inbound,outbound

4) cat ftpconversions
 :.Z: : :/bin/uncompress %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 : : :.Z:/bin/compress %s:T_REG:O_COMPRESS:COMPRESS

5) pwd; ls
/opt/WUftpd/bin
ckconfig    ftp         ftpcount    ftpwho
compress    ftp-exec    ftpshut     uncompress

What i can do ??????????????

!!!!!!!!!!!!!!!!!!!  H E L P !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Send your e-mail to me, not to the mailing-list.

Regards
           Thomas

--
+----------------------------------------+
| SIEMENS MED                            |
| PZE TS 1                               |
| ECAD-Systemadministration              |
| Thomas Lademann                        |
| Henkestr. 127                          |
| D - 91052 Erlangen                     |
| Tel.049-9131-84-6149                   |
| Fax 049-9131-84-6150                   |
| E-Mail: [email-masked] |
|           \|/                          |
|           @ @                          |
|  -----oOO-(_)-OOo-----                 |
+----------------------------------------+

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 13 Oct 1998 10:57:25 -0400 (EDT)

> ftpconversions don't work and i read all FAQ's and old archives....

Try putting a copy of ftpconversions in the ~ftp/etc directory and make
sure you have all the parts of the tar, compress, gzip and any other
programs (pipe?) needed.  Use the instructions for 'ls' in the FAQ, but
read it as if it were written for each of the other programs.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195