Subject: Re: your mail

From: Jorge <[email-masked]>
Date: Wed, 30 Sep 1998 13:50:53 +0200

Hi all

I want to put 2 passwords for an user:

1 -> for sendmail, telnet, etc.
2 -> for FTPD.

How I configure (if possible) my system (Solaris 2.5.1) in order to accept
2 passwords and depending of which is it , accept or not the user
i.e.:
$telnet machine.com 110
conected blah blah....
user bill
pass lovethelife
OK +
-------------------------------------
$ftp machine.com
conected blah blah....
user: bill
pass: otherPASSWORD
220 - OK
blah blah...

but : otherPASSWORD only have to run under FTP.

Thanks in advance.

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 30 Sep 1998 08:36:15 -0400 (EDT)

> 2 passwords and depending of which is it , accept or not the user

Put the daemon and anything else needed into a directory structure which
has only the parts needed for FTP, write a wrapper script which runs the
daemon itself chroot'd in this area.

#!/bin/sh
exec chroot /rerooted/usr/sbin/wu-ftpd -a -l

It'll take a bit of work to get everything going; for instance you'll
probably need to do some things to get syslog working.  I've done it here
as an experiment and it required hacking a few other daemons (syslogd for
instance) to run in the area as well.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195