Subject: Variable file permissions

From: Patrick Verdon <[email-masked]>
Date: Thu, 24 Sep 1998 13:48:47 +0100

Hi,

I've got several virtual hosts running under Apache 
and I use wu-ftpd to allow clients to manage their
own Web content in a self-contained environment. 
My problem arises with CGI content - I want to 
be able to specify that everything under a chroot'ed 
'/document_root/cgi-bin' directory named *.pl or *.cgi 
gets a mode set of 0775. I've tried something like
this to no avail:

upload	/www	*/document_root/cgi-bin/*.pl	yes	web	web	0775

I'd also like the owner of the files to be the user
that is logged in.

One of our ISPs seems to manage this so that files
with a certain suffix get a certain mode - is this
a function of wu-ftpd or not?

Thanks for any help.

Cheers.

Patrick

-- 

#===============================#
\  KAN Design & Publishing Ltd  /
/  T: +44 (0)1223 511134        \
\  F: +44 (0)1223 571968        /
/  E: mailto:[email-masked]  \ 
\  W: http://www.kan.co.uk      /
#===============================#

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 24 Sep 1998 10:22:41 -0400 (EDT)

> upload /www */document_root/cgi-bin/*.pl yes web web 0775

It seems to me this should work, although I've never tested it.  If it
doesn't I'll put it on the list of things to do for VR9 (if some of the
other things I'm looking to do then don't bring this along for the ride).

> I'd also like the owner of the files to be the user that is logged in.

Loosing the 'web web 0775' should do that.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195