Subject: BeroFTPD

From: Didier Godefroy <[email-masked]>
Date: Fri, 18 Sep 1998 14:40:23 -0400

I've been trying to install BeroFTPD but I get a few errors while doing the
make, so I went to grab the gnu make and installed it, and I still get errors
while doing the make:

# /usr/local/bin/make
(cd support ; /usr/local/bin/make all)
make[1]: Entering directory `/usr/users/dg/BeroFTPD-1.1.11/support'
cc -g -c -o authuser.o authuser.c
cc: Error: authuser.c, line 98: In this declaration, the type of "auth_tcpuser"
is not compatible with the type of a previous declar
ation of "auth_tcpuser" at line number 19 in file authuser.h.
char * auth_tcpuser(register long unsigned int in, register short unsigned int
local, register short unsigned int remote)
-----^
make[1]: *** [authuser.o] Error 1
make[1]: Leaving directory `/usr/users/dg/BeroFTPD-1.1.11/support'
make: *** [all] Error 2

The version of gnu make that I picked up is 3.77 and the BeroFTPD version that
I'm trying to install is 1.1.11

Am I doing something wrong or forgeting something?

-- 
Didier Godefroy
mailto:[email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Sep 1998 15:30:16 -0400 (EDT)

On Fri, 18 Sep 1998, Didier Godefroy wrote:

> cc: Error: authuser.c, line 98: In this declaration, the type of "auth_tcpuser" is not compatible with the type of a previous declaration of "auth_tcpuser" at line number 19 in file authuser.h.
> char * auth_tcpuser(register long unsigned int in, register short unsigned int local, register short unsigned int remote)

> The version of gnu make that I picked up is 3.77 and the BeroFTPD
> version that I'm trying to install is 1.1.11

Bernard's on holiday so I'll take a stab at this .. at least to point out
that I looked into his source kit and the definition matches ..

Once upon a time, I used a C compiler which didn't like 'extern' in
include files when I was going to define the function.  Some lame thing
outa Redmond Washington, I think it was.  It wasn't ANSI, they fixed it.
Maybe that's the problem here?  If you get real literal 'extern char *'
isn't the same as 'char *' although the standard says you gotta handle
that.  Try removing the #include "authuser.h" from authuser.c to see if
the problem goes away .. there's nothing there critical for that module.

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Didier Godefroy <[email-masked]>
Date: Fri, 18 Sep 1998 16:35:40 -0400

> the problem goes away .. there's nothing there critical for that module.

I don't do C, so I'm a bit shy in doing things with the source, and I couldn't
find an authuser.c file in the src folder, is it somewhere else?

But I was thinking, what if I used the latest gcc from gnu?
I'm running Digital Unix 4.0b and I don't have gnu gcc installed right now, I
just installed gnu make 3.77 though...

-- 
Didier Godefroy
mailto:[email-masked]

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Sep 1998 16:59:05 -0400 (EDT)

On Fri, 18 Sep 1998, Didier Godefroy wrote:

> I don't do C, so I'm a bit shy in doing things with the source, and I
> couldn't find an authuser.c file in the src folder, is it somewhere
> else?

It's in the support directory.

> But I was thinking, what if I used the latest gcc from gnu? I'm
> running Digital Unix 4.0b and I don't have gnu gcc installed right
> now, I just installed gnu make 3.77 though...

That ought to fix it.

--