Subject: RE: guest accounts/passwd?

From: "Srinivasan, Ranganathan" <[email-masked]>
Date: Fri, 18 Sep 1998 16:46:51 -0400

A great thanks for your precompiled distribution at your site
(ftp.vr.net) which has reduced my work to half. 

	Now I am running the latest version as per your suggestion. When I
login as a regular user I am able to see the user names on issuing the ls
command but when logged in as anonymous or guest user I am able to see only
the user ids rather than user names.

	The following example below depicts the case.

	Case 1: Regular user

	220 ftp1bh FTP server (Version wu-2.4.2-academ[BETA-18-VR7](1) Tue
Sep 15 15:11:
	42 PDT 1998) ready.
	Name (ftp1bh.rossroy.com:ranga): ranga
	331 Password required for ranga.
	Password:
	230 User ranga logged in.
	Remote system type is UNIX.
	Using binary mode to transfer files.
	ftp> ls
	200 PORT command successful.
	150 Opening ASCII mode data connection for /bin/ls.
	total 12
	drwxr-xr-x   2 ranga staff        512 Sep 18 10:53 .
	drwxr-xr-x  26 root     other        512 Sep 18 10:33 ..
	-rw-r--r--   1 ranga users         36 Aug  5 12:56 .profile
	-rw-------   1 ranga users       1166 Sep 18 14:55 .sh_history
	-rw-r--r--   1 root     other        331 Sep 18 10:15 xxxx.gz
	226 Transfer complete. 

	Case 2: Guest user

	220 ftp1bh FTP server (Version wu-2.4.2-academ[BETA-18-VR7](1) Tue
Sep 15 15:11:
	42 PDT 1998) ready.
	Name (ftp1bh.rossroy.com:ranga): loguser
	331 Password required for loguser.
	Password:
	230 User loguser logged in.  Access restrictions apply.
	Remote system type is UNIX.
	Using binary mode to transfer files.
	ftp> ls
	200 PORT command successful.
	150 Opening ASCII mode data connection for /bin/ls.
	total 6
	drwxr-x---   3 90       19           512 Sep 18 18:07 .
	drwxr-xr-x   9 0        1            512 Sep 18 18:07 ..
	drwxr-xr-x   2 90       19           512 Sep 18 18:07 raw
	226 Transfer complete.

Ranganathan Srinivasan
Ross Roy Communications Inc.
(248)433-6642

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Sep 1998 17:02:11 -0400 (EDT)

On Fri, 18 Sep 1998, Srinivasan, Ranganathan wrote:

> login as a regular user I am able to see the user names on issuing the
> ls command but when logged in as anonymous or guest user I am able to
> see only the user ids rather than user names.

you need etc/passwd and etc/group in the ~ftp directory for anonymous, and
in the chroot'd directory for guest users.  this is a FAQ.  My email a bit
ago with solaris instructions covered it as well .. if you've deleted it
already I'll resent it privately.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195