Subject: Cross-subnet DHCP service

From: "Michael Cook" <[email-masked]>
Date: Wed, 9 Sep 1998 09:45:32 -0400

Hello all,
    I am running ISC DHCP version 2.0b1pl6 on a Sun Ultra Enterprise II with
Solaris 2.5.1. I have 2 interfaces on this box, with only 1 providing DHCP.
Most of the DHCP clients come through virtual LANs over ATM through a Cisco
Catalyst 5500. I use virtual router interfaces to differentiate which
clients get which range of IP's.
    For example, I have a vlan with primary router interface 172.16.1.1, a
secondary interface of 172.16.2.1, and a tertiary interface of 172.16.3.1
which uses an IP helper to pass the UDP traffic to the DHCP server and
return IP's in the 172.16.1.x (range subnetted to a class C by necessity).
Can I also assign IP's in the range 172.16.2.x to DHCP requests coming in
from this interface or would I have to set up a router interface for each
subnet range? For example, I would like to use a statement like:

subnet 172.16.1.0 netmask 255.255.255.0 {
  range 172.16.1.220 172.16.1.225;
  range 172.16.2.2 172.16.2.250;
  range 172.16.3.2 172.16.3.250;
  option routers 172.16.1.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}

    Thanks for the help!!! Please find my configs below,
        Michael

# /etc > ifconfig -a
lo0: flags=849<UP,LOOPBACK,RUNNING,MULTICAST> mtu 8232
        inet 127.0.0.1 netmask ff000000
hme0: flags=863<UP,BROADCAST,NOTRAILERS,RUNNING,MULTICAST> mtu 1500
        inet 192.168.3.1 netmask ffffff00 broadcast 192.168.3.255
        ether 8:0:20:93:6:cb
hme1: flags=863<UP,BROADCAST,NOTRAILERS,RUNNING,MULTICAST> mtu 1500
        inet 172.16.6.183 netmask ffffffc0 broadcast 172.16.6.191
        ether 8:0:20:93:6:cb
# /etc > cat dhcpd.conf
subnet 192.168.3.0 netmask 255.255.255.0 {
}
subnet 172.16.6.0 netmask 255.255.255.0 {
}
subnet 172.16.1.0 netmask 255.255.255.0 {
  range 172.16.1.220 172.16.1.225;
  option routers 172.16.1.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 172.16.2.0 netmask 255.255.255.0 {
  range 172.16.2.2 172.16.2.250;
  option routers 172.16.2.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 172.16.3.0 netmask 255.255.255.0 {
  range 172.16.3.2 172.16.3.250;
  option routers 172.16.3.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 172.17.2.0 netmask 255.255.255.0 {
  range 172.17.2.2 172.17.2.250;
  option routers 172.17.2.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 172.17.3.0 netmask 255.255.255.0 {
  range 172.17.3.2 172.17.3.250;
  option routers 172.17.3.1;
  option subnet-mask 255.255.255.0;
  option domain-name "abc.com";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 208.180.158.0 netmask 255.255.255.0 {
  range 208.180.158.10 208.180.158.250;
  option routers 208.180.158.254;
  option subnet-mask 255.255.255.0;
  option domain-name "xyz.net";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 208.180.159.0 netmask 255.255.255.0 {
  range 208.180.159.10 208.180.159.250;
  option routers 208.180.159.254;
  option subnet-mask 255.255.255.0;
  option domain-name "xyz.net";
  option domain-name-servers 205.80.192.1, 203.147.80.5;
}
subnet 10.0.0.0 netmask 255.0.0.0 {
  range 10.0.5.2 10.0.10.253;
}

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 9 Sep 1998 13:05:21 -0400 (EDT)

Wrong list.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195