Subject: beta 18 on solaris 2.6

From: Becki Kain <[email-masked]>
Date: Mon, 14 Sep 1998 15:09:52 -0400 (EDT)

I am trying to compile wu-ftpd version 2.4.2 beta 18 with patches VR3
through VR 6 applied.  I am using gcc version 2.8.1.  I am trying to build
on Solaris 2.6.

I seem to be having troubles with ftpd.c.  I get the following errors when
I
try to compile...

gcc -g -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
ftpd.c: In function `main':
ftpd.c:471: warning: return type of `main' is not `int'
ftpd.c: In function `deniedgid':
ftpd.c:1855: warning: assignment makes pointer from integer without a cast
ftpd.c:1856: dereferencing pointer to incomplete type
ftpd.c: In function `allowedgid':
ftpd.c:1907: warning: assignment makes pointer from integer without a cast
ftpd.c:1908: dereferencing pointer to incomplete type
make: *** [ftpd.o] Error 1

>From what I can tell, the compiler seems to think that 
        getgrnam(const char *) 
returns int rather than struct group *.  It chokes on the assignment and
on
the dereferenceing of grp.

To make matters more baffling, the other files in the src directory that
use
getgrnam (access.c, extensions.c, and private.c) all compile fine.  Does 
anyone have any idea what is going wrong here?  

thanks

beckers

Becki Kain
[email-masked]
--
  furph, Inc.	WWW/Unix/Windows Solutions	734-513-7763 (voice)
[email-masked]	   http://www.furph.com		734-513-7759 (FAX)

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 14 Sep 1998 15:38:25 -0400 (EDT)

On Mon, 14 Sep 1998, Becki Kain wrote:

> through VR 6 applied.  I am using gcc version 2.8.1.  I am trying to
> build on Solaris 2.6.
> 
> I seem to be having troubles with ftpd.c.  I get the following errors
> when I try to compile...
> 

Non-ANSI-ism in the base beta-18.  It'll be fixed in the VR7 patches.

> ftpd.c: In function `allowedgid':

Missing #include <gid.h> in ftpd.c, also fixed in VR7.

VR7 is ready to roll and scheduled for release September 15th .. hey,
that's tomorrow!

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195