Subject: Compiler errors

From: Lam Hoang <[email-masked]>
Date: Tue, 29 Sep 1998 08:59:51 -0700

I have tried  to compiler wu-ftpd with gcc 2.8.1.
I got the following errors : - Please help . Thanks
==

Making ftpd.
/usr/local/bin/gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:180: previous declaration of `realpath'
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use in this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use in this function)
ftpd.c:1982: `strunames' undeclared (first use in this function)
ftpd.c:1982: `modenames' undeclared (first use in this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
/usr/local/bin/gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount
ftpcoun
t.c ver
s.o -lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'
Making ftpshut.
/usr/local/bin/gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut
ftpshut.
c vers.
o -lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 7435 + 788 + 360 = 8583
Done                
Lam Hoang
IS MANAGER
SYNPLICITY INC.
610 E. Caribbean Dr.
SUNNYVALE, CA 94089
408-548-6058

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 29 Sep 1998 12:29:49 -0400 (EDT)

On Tue, 29 Sep 1998, Lam Hoang wrote:

which version of the daemon are you compiling, and for which platform?

> /usr/include/stdlib.h:180: previous declaration of `realpath'

src/config/config.<os> needs the following line added to the end:
#define realpath realpath_on_steroids

this should already have been done for your platform, unless you're
compiling an old version of the daemon.  Be sure to do './build clean'
before recompiling with './build <os>' or this change won't take effect.

> ftpd.c:1982: `modenames' undeclared (first use in this function)

An old, old FAQ.  I don't remember the fix.  It's in the FAQ:

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Lam Hoang <[email-masked]>
Date: Tue, 29 Sep 1998 09:52:45 -0700

Thanks.
It works.
Lam Hoang
IS MANAGER
SYNPLICITY INC.
610 E. Caribbean Dr.
SUNNYVALE, CA 94089
408-548-6058