Subject: Unable to compile v2.4 on Solaris 2.6

From: Gregor Mosheh <[email-masked]>
Date: Thu, 24 Sep 1998 16:56:04 -0700

I'm still not able to get guestgroups working, despite the guestgroup FAQ. 
So, I decided to rebuild from the newest source. And, I'm unable to get 
WU-FTPD to compile.
OS is Solaris 2.6
FTPD is 2.4 from ftp.academ.edu
A log of the compile attempt is below.

--	Gregor Mosheh
	Novo/Ironlight
	wasteland.ironlight.com

Please note: The correct address for technical support is 
[email-masked]
Please use that address unless you want to contact me specifically.

engr@robin:/tmp/gm/wu-ftpd-2.4 -> ./build sol
make args are :
make opts are :

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
ftpd.c:143: conflicting types for `realpath'
/usr/local/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/stdlib.h:186: 
previous declaration of `realpath'
make: *** [ftpd.o] Error 1

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o 
-lsup
port -lsocket -lnsl -lgen
cc: vers.o: No such file or directory
make: *** [ftpcount] Error 1

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o 
-lsuppo
rt -lsocket -lnsl -lgen
cc: vers.o: No such file or directory
make: *** [ftpshut] Error 1

Making ckconfig.
make: `ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 4176 + 328 + 328 = 4832
Done
real 0:02.64 cpu 81.0%

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 24 Sep 1998 21:59:04 -0400 (EDT)

> FTPD is 2.4 from ftp.academ.edu

2.4 is very old and should not be used.

Get 2.4.2-beta-18 and try again.
After unpackaging, run './build clean' before you './build sol'

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195