Subject: authentication problems on wu-2.4.2 [BETA-18]

From: Amanda Dahl/mail+schedule <[email-masked]>
Date: Fri, 25 Sep 1998 11:00:27 -0700

Hello,
I am running wu-2.4.2 [BETA-18] on Solaris 2.6 on a Sparcstation 20. I have
attempted to recompile and re-install the binaries twice, but this problem
still persists.
I am unable to receive authentication for any user, anonymous or listed in
/etc/passwd.
For a user listed in the /etc/passwd, a session looks like this:

Connected to localhost.
220 machinname FTP server (Version wu-2.4.2-academ[BETA-18](1) Tue Aug 11
14:39:18
 PDT 1998) ready.
Name (localhost:root): username
530 User username access denied.
Login failed.
ftp> bye
221 Goodbye. 

And for anonymous, it looks like this:

Connected to localhost.
220 nitrogen FTP server (Version wu-2.4.2-academ[BETA-18](1) Tue Aug 11
14:39:18
 PDT 1998) ready.
Name (localhost:root): anonymous
530 User anonymous unknown.
Login failed.
ftp> bye
221 Goodbye.

The entry in /etc/inetd.conf looks like this:
ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd -al

I've added the -al option at the moment, but have tried it without, and it
doesn't make a difference.

There is no entry for anonymous or any username I've tested in the ftpusers
file. I have created a file called /etc/shells containing all shells that
any username might need to use. I've checked out the tips for running wu-ftp
on Solaris from the wu-ftp home page, and am doing all of it correctly.
What am I missing?

Thank you very much.
Amanda
[email-masked]

---------------------------------
Amanda K. Dahl
Information Services
BARRA, INC.
2100 Milvia Avenue
Berkeley.CA 94704
[email-masked]
---------------------------------
"UNIX was not designed to stop you from doing stupid things, because that
would also stop you from doing clever things." -- Doug Gwyn

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 25 Sep 1998 15:25:21 -0400 (EDT)

> 530 User username access denied.

possible causees:
  /etc/ftphosts denied access .. look in syslog
  /etc/ftpusers denied access .. also logged
  /etc/ftpaccess denied access (limit, etc) .. logged as well
  Bad shell .. logged with ftpusers
  
> 530 User anonymous unknown.

No user 'ftp' in system's /etc/passwd

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195