Subject: compile problems

From: "Jose Montilla" <[email-masked]>
Date: Fri, 18 Sep 1998 15:18:19 -0700

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
"ftpd.c", line 143: identifier redeclared: realpath
        current : function(pointer to char, pointer to char) returning
pointer to char
        previous: function(pointer to const char, pointer to char)
returning pointer to char : "/usr/include/stdlib.h", line 180
"ftpd.c", line 1446: cannot recover from previous errors
cc: acomp failed for ftpd.c
*** Error code 2
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to ftpcount
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to ftpshut
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'
Hi,

I have downloaded the wuftpd-2.4.tar.Z from wuarchive.wustl.edu and
compiled it to
an SS20 running Solaris 2.6.
I ran
build sol
and I got some errors.....
Can someone help ? Any thoughts ?

Thanks

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 4833 + 584 + 324 = 5741
Done

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 18 Sep 1998 18:28:24 -0400 (EDT)

On Fri, 18 Sep 1998, Jose Montilla wrote:

> compiled it to an SS20 running Solaris 2.6. I ran build sol and I got
> some errors..... Can someone help ? Any thoughts ?

Sure, first go get the right package: wu-ftpd-2.4.2-beta-18.tar.Z from
academ.com.  Run 'sh build clean' then 'sh build sol'.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

-- 

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195