Subject: Re: why ,why

From: Gregory A Lundberg <[email-masked]>
Date: Sat, 1 Aug 1998 10:25:06 -0400 (EDT)

Check your file permissions.  If the ls and its parts are not world
executable, it won't work.  If the target directory isn't world readable,
or at least readable as the ftp user, it won't work.  The chroot/ls test
tells you the pieces and parts are there.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "gf gfd gdf" <[email-masked]>
Date: Sat, 01 Aug 1998 00:45:39 -0700

In FaQ,there was a question:
<9. Programs (ls, gzip, tar) work for real users, 
not for anonymous users, giving errors like 
425 Can't create data socket (0.0.0.0,20): Bad file number 
or simply no output. >

when I do as what faq said,test with "chroot ~ftp /bin/ls -al",
It's work ok,but when I ftp my ftp server,then ls -al,It's
output 
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete
while use ls,It's output

200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
public_html
etc
lib
dev
usr
226 Transfer complete.
38 bytes received in 0.016 seconds (2.4 Kbytes/s)
please tell me why??????????

Now MailCity offers forwarding so you can check your MailCity messages and other e-mail all in one place.  Go to http://www.mailcity.com