Subject: Setting default UMASK

From: Oliver Schoenwald <[email-masked]>
Date: Thu, 06 Aug 1998 16:58:18 +0200

Hello!

How can I set the default UMASK-value for some (or all)
ftp-sessions?
The problem is, that we want a guest access where it is
guaranteed that the group-rights are set to read-write. However,
in the default configuration, any file uploaded to the guest
account has only the user-rights set to rw, the other are
read-only.

Oliver.

--
Oliver Schönwald, Diplom-Informatiker
Projekt Virtuelle Universität

                FernUniversität Hagen
          Lehrstuhl Praktische Informatik I
              Feithstr.140 - 58084 Hagen
Telefon: +49 2331 987 2972 - Telefax: +49 2331 987 314
       EMail: [email-masked]
            WWW: http://vu.fernuni-hagen.de

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 6 Aug 1998 11:12:47 -0400 (EDT)

On Thu, 6 Aug 1998, Oliver Schoenwald wrote:

> How can I set the default UMASK-value for some (or all)  ftp-sessions? 
> The problem is, that we want a guest access where it is guaranteed that
> the group-rights are set to read-write. However, in the default
> configuration, any file uploaded to the guest account has only the
> user-rights set to rw, the other are read-only. 

Use the -u commandline option to set the default umask for all users.  My
VR4 patches include the ability to set the umask for certain classes of
users, if oyu need finer control.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195