Subject: RE: Weird Static LS Problem

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Fri, 21 Aug 1998 13:46:03 -0700

Where is the chroot point?  

I am not sure if I will ultimatly be able to solve this for you, but I
experienced something
very similiar (actually essentially identical).  Do they have a common
chroot point?

> ----------
> From: 	Duncan Sterling[SMTP:[email-masked]]
> Sent: 	Friday, August 21, 1998 1:44 PM
> To: 	Speier, Guy J - CNF
> Cc: 	[email-masked]'
> Subject: 	RE: Weird Static LS Problem
> 
> On Fri, 21 Aug 1998, Speier, Guy J - CNF wrote:
> 
> > I actuall get the same problem with rftp'ing (but not when I just
> ftp)
> > to
> > my ftp server.  I'm curious as to what version of firewall you are
> > using?
> 
> Just standard Cisco stuff, which has never caused any problem that I
> know
> of.
> 
> > Is it possible for you to just ftp (& not rftp) to this machine?
> 
> Yes. Additionally, all my previously installed RFTP accounts are
> working
> fine.
> 
> --Duncan
> 
>

---

From: Emmett Hogan <[email-masked]>
Date: Fri, 21 Aug 1998 13:54:34 -0700 (PDT)

Have you tried running the static "ls" from the command line in the
same chrooted environment:

	/usr/sbin/chroot /var/ftp /bin/ls

This assumes that the rftp account is chrooted to /var/ftp and that
the full path to the statically linked ls is "/var/ftp/bin/ls".

Hope this helps.

-Emmett

-- 
Emmett Hogan
Global Networking and Computing
Home Page: http://www.gnac.com/~hogan
Inet: [email-masked]
ICBM: 38d 47' 27" N, 121d 14' 05" W

---

From: Duncan Sterling <[email-masked]>
Date: Fri, 21 Aug 1998 17:07:28 -0400 (EDT)

> very similiar (actually essentially identical).  Do they have a common

No. Each individual RFTP account has it's own separate directory
structure, though each new acount is identical in structure and chroot
point (within it's own directories) as all the others.

--Duncan

---

From: Duncan Sterling <[email-masked]>
Date: Fri, 21 Aug 1998 17:05:21 -0400 (EDT)

> 	/usr/sbin/chroot /var/ftp /bin/ls

Yes, and oddly enough, this works...

--Duncan