Subject: Access to directiries above home directories.

From: "Flemming Danielsen" <[email-masked]>
Date: Wed, 19 Aug 1998 14:52:41 +0100

Hi

I have not setup the anon-ftp, so this is related to wu-ftpd only. 
When one of my users opens a ftp session it gives them the abbility 
to go one level above there home level eg

/home/user 

he  can then move upto /home and see all the other users names, now 
how do I prevent this so he cant go up one level.

In short terms how to I get /home/user = / in a ftp session ?

Greeting,
Flemming

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 19 Aug 1998 09:51:43 -0400 (EDT)

> In short terms how to I get /home/user = / in a ftp session ?

Read the FAQ, guest howto explains everything you need to know.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: joe turbulencia <[email-masked]>
Date: Wed, 19 Aug 1998 10:00:10 -0400 (EDT)

> how do I prevent this so he cant go up one level.

	this may not be the best way to do it but if your only 
	concern is to prevent users from seeing the other users'
	directories, you can set the permission to the directory
	above to just execute (no read).  they can still get there
	but they can't see anything.

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 19 Aug 1998 10:14:15 -0400 (EDT)

On Wed, 19 Aug 1998, joe turbulencia wrote:

> this may not be the best way to do it but if your only concern is to
> prevent users from seeing the other users' directories, you can set the
> permission to the directory above to just execute (no read).  they can
> still get there but they can't see anything. 

The importance of permissions, even on a properly configured and managed
FTP site cannot be stressed strongly enough.

By using the guestgroup features, you can limit a user's ability to look
through the entire system.  On systems with a large number of users, the
overhead of maintaining the required files on a per-user basis can be
prohibitive.  Careful design of the security system (including both the
guestgroup configuration and permissions) can greatly reduce the overhead
without compromising sensitive information.

----