Subject: Logins Fail

From: [email-masked] (Jerry D. Smith)
Date: Thu, 6 Aug 1998 15:42:05 -0400

I just completed building the HPUX version of wu-ftpd.  I followed the
procedures outlined and checked against the O'Reilly book.

When I try to ftp the ftpaccess is checked properly...ie...I can control
from what machine I will allow.

The login prompt and passwrd prompt I enter the proper info yet it always
says Login Failed.

I double checked this by modifying the inetd.conf to re-initialize using the
standard HPUX ftpd and everything works.

Here are the lines in my inetd.conf..

# HUPUX STD FTP SERVER
#ftp          stream tcp nowait root /usr/lbin/ftpd     ftpd -l -u022
# WASH UNIV ENHANCED FTP SERVER
ftp          stream tcp nowait root /usr/local/bin/ftpd ftpd -a -L -d -o -i

I am signalying the inetd process and the syslog shows that it is restarting
using the correct ftpd server.

The following is a transcript of the failing process

# ftp inca9
Connected to inca9.inca.net.
220 inca9.inca.net FTP server (Version wu-2.4.2-academ[BETA-18](1) Wed Aug 5
11:58:10 EDT 1998) ready.
Name (inca9:jerry): jerry
331 Password required for jerry.
Password:
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

HELP!! What am I doing wrong??

thanks all

-- 
Jerry D. Smith
President and Chief Operating Officer

INCA Corporation - Delivering the Information Age Today!
201 E. Pine Street, Suite 875, Orlando FL 32801
Phone:407.481.2545, Fax:407.481.2541

Web: http://www.inca.net and www.7jaguar.com

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 6 Aug 1998 16:09:35 -0400 (EDT)

> 530 Login incorrect.

this is usually the result of typoing the password.  assuming that's not
the case here, look at the security system you're using and the one
compiled into the daemon.  there's a mismatch somewhere. for instance, if
the system uses shadow passwords and the daemon doesn't, youll get this
error.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195