Subject: Generating passwords for 'ftpgroups' file

From: Yilmaz Oztanir <[email-masked]>
Date: Wed, 19 Aug 1998 16:03:13 +0100

Hi Everyone

Just a quick question. I am using the 'guestgroup' group access
mechanism with wu-ftpd. The problem is that it is pretty tedious to
generate passwords for the 'ftpgroups' file. I use passwd to make a new
password in /etc/shadow and then do a cut and paste into 'ftpgroups'.
Sometimes this doesn't work as wu-ftp doesn't like some encrypted
versions of the same password. Is there a program I can use which
generates encrypted passwords (on the command line say) and which will
always work with wu-ftpd.

Thanks for any help.

Yilmaz

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 19 Aug 1998 11:18:38 -0400 (EDT)

On Wed, 19 Aug 1998, Yilmaz Oztanir wrote:

> Is there a program I can use which generates encrypted passwords (on the
> command line say) and which will always work with wu-ftpd.

Yes, privatepw, available at the Resource Center.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Bob Luckin <[email-masked]>
Date: Wed, 19 Aug 98 11:13:38 CDT

Yilmaz asked :-
> always work with wu-ftpd.

The following short program works for me on SunOS 4, Solaris 2 and HP-UX 9
(ie. all the systems I have easy access to compile on...)

        ===============================================================
#include <unistd.h>

main (argc, argv)
int   argc;
char *argv[];
{
   char *pw = argv[1];
   char *salt = argv[2];
   char *val;

   if (argc < 3) {
      printf("%s: too few arguments\n", argv[0]);
      printf("Usage: %s <key> <salt>\n", argv[0]);
      exit(1);
   }

   val = crypt(pw, salt);
   printf("%s\n", val);
   exit(0);
}
        ===============================================================

Cheers, Bob
-- 
Bob Luckin    [email-masked]    "Many hands make a heavy arm"
                             [http://www.dhc.net/luckin/cgi-bin/misfortune.cgi]