Subject: Re: upload problem

From: Ian Willis <[email-masked]>
Date: Wed, 26 Aug 98 18:40:11 BST

The syntax for upload is:
upload home-dir dirpattern yes|no [owner group mode] [dirs|nodirs]

The upload line applies to users with a home directory of home-dir.
I have tested this using wu-2.4.2-academ BETA-18 and it works as
expected, check your ftp users home directory listed in /etc/passwd
is /hal/ftp.

Assuming the ftp users home directory is /hal/ftp, the following two
lines only allow uploads into /incoming.

upload  /hal/ftp  *             no	nodirs
upload  /hal/ftp  /incoming     yes     ftp     hal     0660 dirs

Your /bin, /etc and /pub lines are unnecessary given the first line.
Note the addition of nodirs to the first line, if nothing is specified
the default is dirs which allows the creation of directories.

If you wish to allow uploads into the subdirectories you allow to be
created under /incoming you also need the line:
upload  /hal/ftp  /incoming/*   yes     ftp     hal     0660 dirs

Ian Willis
SCO Internet Engineering Group, Watford, England

| On Wed, 26 Aug 1998, Harris Kosmidhs wrote:
| > My ftpacess file is:
| > # specify the upload directory information
| > upload  /hal/ftp  *             no
| > upload  /hal/ftp  /incoming     yes     ftp     hal     0660 dirs
| > upload  /hal/ftp  /bin          no
| > upload  /hal/ftp  /etc          no
| > upload  /hal/ftp  /pub          no
| > 
| > But it seems that the user ftp[anonymous] can upload in pub [and in any
| > other dir. I suppose]
| > 
| > What's the problem? I'm using ftp 2.4-beta18
| > my inetd.conf is:
| > ftp     stream  tcp     nowait  root    /usr/sbin/tcpd 
| > /usr/local/sbin/wu.ftpd -l -i -o -t 60 -T 100 -a

On Wed, 26 Aug 1998, Gregory A Lundberg wrote:
| It's a long-standing bug/misunderstanding of how things work/should be.
| 
| There are two ways to fix this:
| 
| - Don't upgrade from beta-18, but fix the upload to read
| 
| upload / * no
| upload / /incoming yes ftp hal 0660 dirs
| 
| - upgrade to my -vr5 patches

---

From: Harris Kosmidhs <[email-masked]>
Date: Wed, 26 Aug 1998 23:38:37 +0300 (EEST)

> upload  /hal/ftp  /incoming     yes     ftp     hal     0660 dirs

No it does the same thing.
Even with upload  / *             no    nodirs
 it's the same. I can upload in pub.
Isn't there a difference in:
upload  / *             no    nodirs
upload  /hal/ftp  *             no    nodirs

Thanks
Harris

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Wed, 26 Aug 1998 23:10:23 +0200 (CEST)

> No it does the same thing.

Did you get the permissions wrong? (Is pub 0777?)

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.

---

From: Harris Kosmidhs <[email-masked]>
Date: Thu, 27 Aug 1998 00:42:10 +0300 (EEST)

No it's 0755