Subject: Re: Sublogins

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 4 Aug 1998 09:20:15 -0400 (EDT)

On Tue, 4 Aug 1998, Yilmaz Oztanir wrote:

> Does anybody know how to enable sublogins in WU-FTPD? 

If you mean guestgroup, read the guest howto in the FAQ.  If you mean SITE
GROUP/SITE GPASS, set 'private yes', create ftpgroups per the manpage.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Yilmaz Oztanir <[email-masked]>
Date: Tue, 04 Aug 1998 13:05:23 +0100

Sorry about mailing this, but I cannot seem to be able to get through to
the archive.

Thanks in advance

Yilmaz

---

From: Yilmaz Oztanir <[email-masked]>
Date: Wed, 05 Aug 1998 17:02:49 +0100

Hi everybody

I was wondering if anybody has any experience with automated FTP uploading
via scripts. Basically, what I want to do is run a script e.g.

putfile <file>

The basic script:

ftp MACHINENAME
cd /pub
bin
put $1
quit

This should log in to a predefined FTP site (using the autologin feature and
.netrc) and then use 'put' commands to do uploads. At present, I have the
logging in bit working, but the FTP prompt doesn't see the rest of the
commands. These are run after FTP is quit manually:

ftp> exit
221 Goodbye.
./putfile: /pub: No such file or directory
./putfile: bin: command not found
./putfile: put: command not found
./putfile: quit: command not found

Therefore, my question is whether FTP can run the commands provided in the
shell script.

Any help would be greatly appreciated.

Yilmaz