Subject: Compliling problem on HPUX 10.20

From: Shyam Raghavan <[email-masked]>
Date: Mon, 31 Aug 1998 18:33:55 -0700

Hi list

When I try to do a bulid of
wu-ftp server ver
2.4.2-beta-18 on hpux 10.20.
It gives the following error.
I am using gcc 2.7.2.3 with
gnu binutils and gnu sed.

Could somebody help me out

Thanks in  advance

Shyam

Error message:
----------------
$ ./build CC=gcc hpx
make args are :
make opts are :  CC=gcc

Linking Makefiles.
Makefile already present in
root directory
Makefile already present in
src directory
config.h already present in
src directory
Makefile already present in
support directory

Making support library.
        rm -f libsupport.a
        ar cq libsupport.a
fnmatch.o strcasestr.o
strsep.o getusershell.o snprin

tf.o
        touch libsupport.a

Making ftpd.
        gcc -Aa -Dunix
-D_HPUX_SOURCE -O +Onolimit
-I.. -I../support +DAportable
  -c ftpd.c
gcc: +Onolimit: No such file
or directory
gcc: +DAportable: No such file
or directory
*Initialization*:1: missing
token-sequence in `#assert'
In file included from
/usr/include/hpsecurity.h:22,
                 from
ftpd.c:249:
/usr/include/values.h:27:
warning: `MAXINT' redefined
/opt/gcc/lib/gcc-lib/hppa1.0-hp-hpux10.20/2.7.2.3/include/sys/param.h:45:
warnin
g: this is the location of the
previous definition
*** Error exit code 1

Stop.

Making ftpcount.
        gcc -Aa -Dunix
-D_HPUX_SOURCE -O +Onolimit
-I.. -I../support +DAportable
  -o ftpcount ftpcount.c
vers.o ../support/libsupport.a
-lsec
gcc: +Onolimit: No such file
or directory
gcc: +DAportable: No such file
or directory
gcc: vers.o: No such file or
directory
*Initialization*:1: missing
token-sequence in `#assert'
*** Error exit code 1
Stop.

Making ftpshut.
        gcc -Aa -Dunix
-D_HPUX_SOURCE -O +Onolimit
-I.. -I../support +DAportable
  -o ftpshut ftpshut.c vers.o
../support/libsupport.a -lsec
gcc: +Onolimit: No such file
or directory
gcc: +DAportable: No such file
or directory
gcc: vers.o: No such file or
directory
*Initialization*:1: missing
token-sequence in `#assert'
*** Error exit code 1

Stop.

Making ckconfig.
`ckconfig' is up to date.
ln: ckconfig exists

Links to executables are in
bin directory:
size: bin/ftpd: No such file
or directory
size: bin/ftpcount: No such
file or directory
size: bin/ftpshut: No such
file or directory
size: bin/ftpwho: No such file
or directory
text    data    bss
dec     hex     filename
10253   1816    8
12077   2f2d    bin/ckconfig
Done
________________________

Also following are the
environment variables
--------------
$ env
_=/usr/bin/env
MANPATH=/usr/share/man/%L:/usr/share/man:/usr/contrib/man/%L:/usr/contrib/man:/u

sr/local/man/%L:/usr/local/man:/opt/pd/share/man/%L:/opt/pd/share/man:/opt/hparr

ay/share/man:/opt/aCC/share/man/%L:/opt/aCC/share/man:/opt/blinklink/share/man:/

opt/langtools/share/man/%L:/opt/langtools/share/man

PATH=/opt/gcc/bin:/opt/sed/bin:/opt/binutils/bin:/usr/bin:/usr/sbin:/usr/local/b

in:/usr/lib
COLUMNS=80
LOGNAME=shyam
MAIL=/var/mail/shyam
ERASE=^H
SHELL=/usr/local/bin/ksh
HOME=/home/shyam
TERM=vt220
PWD=/tmp/wu-ftpd-2.4.2-beta-18

TZ=PST8PDT
LINES=24
_-------------------

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 31 Aug 1998 23:55:40 -0400 (EDT)

On Mon, 31 Aug 1998, Shyam Raghavan wrote:

> When I try to do a bulid of wu-ftp server ver 2.4.2-beta-18 on hpux
> 10.20.  It gives the following error.  I am using gcc 2.7.2.3 with gnu
> binutils and gnu sed. 

> Linking Makefiles.
> Makefile already present in root directory
> Makefile already present in src directory
> config.h already present in src directory
> Makefile already present in support directory

Clean it up by running 'sh build clean' first.

> -D_HPUX_SOURCE -O +Onolimit -I.. -I../support +DAportable -c ftpd.c

The makefile you're running is expecting to find HP's compiler.  GCC
doesn't understand the options meant for that compiler.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195