Subject: Re: fopen warning on AIX (still happening)

From: Carl Hansen <[email-masked]>
Date: Tue, 4 Aug 1998 17:33:36 -0700

On Tue, Aug 04, 1998 at 03:59:44PM -0300, Alexandre Almeida Wanderley wrote:
> 	Hi, All
> 	
> 	
> 	Last week I wrote asking for help about the message:
> 	
> 	"syslog: fopen on /dev/null failed, errno 13"
> 	
> 	That it was sended to my log file after I have created my guest-user
> accounting. (remember that everything gone ok during the compilation and the
> options settings (wu-ftpd2.4.2-beta-17)
> 	Well, I tried every kind of ways to put a /dev/null in the chroot'ed
> directory: creating, linking, copying... (thanks your attention, Gregory)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^

but did you try mknoding?

see man mknod

> But the message still is generated. Maybe it is a AIX incompability? It isn't 
> anything related to the "ls" command, because every command the guest user 
> perform the warning is generated.
> 	Note that everything related to the permissions and actions a guest-user
> must have or can perform is ok. But this warning is flooding my log file...
> 
> 
> 	Alexandre Almeida
> 	
> 	

UNIX: the world's largest Adventure game.

-- 
Carl Hansen
Vividata, Inc.
[email-masked]
510 841 6400 x 117

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 4 Aug 1998 15:20:02 -0400 (EDT)

> "syslog: fopen on /dev/null failed, errno 13"

This doesn't look like a message from wu-ftpd (I just grep'd the source).
Is it comming from your syslog daemon?  I bet so.  Check the configuration
of your syslog daemon (usually /etc/syslog.conf ), see if there's anything
there which could cause this.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Alexandre Almeida Wanderley <[email-masked]>
Date: Tue, 4 Aug 1998 15:59:44 -0300

Hi, All

	

	Alexandre Almeida