Subject: wu-ftpd on HPUX

From: [email-masked] (Jerry D. Smith)
Date: Tue, 11 Aug 1998 11:01:04 -0400

Hello All,

Has anyone successfully installed and using wu-ftpd on HPUX 10.2.  I have been
fighting this problem for about a week now.  One response suggested something
to do with crypt, but that means nothing to me?  All I want is to set this up
to work so I can control the chroot'ed directory of an ftp user.

Any suggestions would be greatly appreciated.

Previous posting...

At the login prompt and passwrd prompt I enter the proper info yet it always
says Login Failed.

I double checked this by modifying the inetd.conf to re-initialize using the
standard HPUX ftpd and everything works.

Here are the lines in my inetd.conf..

# HUPUX STD FTP SERVER
#ftp          stream tcp nowait root /usr/lbin/ftpd     ftpd -l -u022
# WASH UNIV ENHANCED FTP SERVER
ftp          stream tcp nowait root /usr/local/bin/ftpd ftpd -a -L -d -o -i

I am signalying the inetd process and the syslog shows that it is restarting
using the correct ftpd server.

The following is a transcript of the failing process

# ftp inca9
Connected to inca9.inca.net.
220 inca9.inca.net FTP server (Version wu-2.4.2-academ[BETA-18](1) Wed Aug 5
11:58:10 EDT 1998) ready.
Name (inca9:jerry): jerry
331 Password required for jerry.
Password:
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

HELP!! What am I doing wrong??

thanks all

-- 
Jerry D. Smith
President and Chief Operating Officer

INCA Corporation - Delivering the Information Age Today!
201 E. Pine Street, Suite 875, Orlando FL 32801
Phone:407.481.2545, Fax:407.481.2541

Web: http://www.inca.net and www.7jaguar.com

---

From: Christopher Caldwell <[email-masked]>
Date: Tue, 11 Aug 1998 13:21:19 -0400

Jerry, 

I've successfully built/installed wu-ftpd-2.4.2-beta-18 on trusted HP-UX
10.20.
The stock build worked, though I added the -DVIRTUAL directive and muck'd
about with where the installer put things (pathnames.h) & ~Makefile. 

We need a little more info here ... are you running HP-UX in trusted or
non-trusted mode?

Also, make sure you have at least one class defined in ftpaccess.

-C