Subject: upload problem

From: Harris Kosmidhs <[email-masked]>
Date: Wed, 26 Aug 1998 17:09:20 +0300 (EEST)

My ftpacess file is:
# specify the upload directory information
upload  /hal/ftp  *             no
upload  /hal/ftp  /incoming     yes     ftp     hal     0660 dirs
upload  /hal/ftp  /bin          no
upload  /hal/ftp  /etc          no
upload  /hal/ftp  /pub          no

But it seems that the user ftp[anonymous] can upload in pub [and in any
other dir. I suppose]

What's the problem? I'm using ftp 2.4-beta18
my inetd.conf is:
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd 
/usr/local/sbin/wu.ftpd -l -i -o -t 60 -T 100 -a

thanks

Harris

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 26 Aug 1998 10:31:44 -0400 (EDT)

> /usr/local/sbin/wu.ftpd -l -i -o -t 60 -T 100 -a

It's a long-standing bug/misunderstanding of how things work/should be.

There are two ways to fix this:

- Don't upgrade from beta-18, but fix the upload to read

upload / * no
upload / /incoming yes ftp hal 0660 dirs

- upgrade to my -vr5 patches

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195