Subject: Beginner's Questions ...

From: "Jeffery Richards [2667]" <[email-masked]>
Date: Wed, 26 Aug 1998 14:54:35 -0700 (PDT)

Hi there,

I've just set up wu-ftpd and I'm noticing some odd behaviour that I don't
understand.  I'm wondering if anyone can explain why I might be encountering
the following:

   - when I sign on as a real user I can do "ls -la" or "ls" and get results
     but if I sign on as a guest "ls" works but "ls -la" gives nothing back.

   - when I sign on as a real user I get the initial message displayed to me
     but if I sign on as a guest I don't.

   - I can't make logging of commands occur for real or guest users but
     logging of transfers I think is ok

   - how do I prevent certain real users from being able to logon via ftp
     (e.g. root)

Here is the contents of my ftpaccess file:

-------------------------------------------------------------------------------
class all real,guest *
guestgroup ftp
limit all 2 Any /opt/WUftpd/etc/msg.too-many-users
loginfails 5
passwd-check rfc822 enforce
path-filter anonymous /opt/WUftpd/etd/msg.bad-filename ^[-A-Za-z0-9\._]*$ ^\. ^-
path-filter guest     /opt/WUftpd/etd/msg.bad-filename ^[-A-Za-z0-9\._]*$ ^\. ^-
banner /opt/WUftpd/etc/msg.before-login
message /opt/WUftpd/etc/msg.after-login LOGIN
message .message CWD=*
readme README* LOGIN
readme README* CWD=*
log commands  real,guest
log transfers real,guest inbound,outbound
compress   yes   all local remote real
gzip       yes   all local remote real
tar        yes   all local remote real
gtar       yes   all local remote real
email [email-masked]
-------------------------------------------------------------------------------

I'm running Solaris 2.5.1 on a Sun Sparc.

If anyone can shed any light on this I would be very appreciative.

Thanks in advance.

-- 
+------------------------------------+----------------------------------------+
| Jeff Richards - Unix Sys Admin     | Phone: (604) 231-2667                  |
| MacDonald Dettwiler Ltd.           | FAX:   (604) 278-3786                  |
| 13800 Commerce Parkway             +----------------------------------------+
| Richmond, BC  CANADA  V6V 2J3      | Email: [email-masked]                 |
+------------------------------------+----------------------------------------+

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Thu, 27 Aug 1998 00:27:45 +0200 (CEST)

>      but if I sign on as a guest "ls" works but "ls -la" gives nothing back.

This is because a real user gets the real ls command; an anonymous user is
chrooted, and so the ls program executed by him is actually ~ftp/bin/ls.

>      but if I sign on as a guest I don't.

Check the permissions, and check if the message file is in a directory
that can be accessed after the chroot().

>    - how do I prevent certain real users from being able to logon via ftp

man ftpusers

LLaP
bero

-- 
Windows 98 supports real multitasking - it can boot and crash simultaneously.
***
Anyone sending unwanted advertising e-mail to this address will be charged
$25 for network traffic and computing time. By extracting my address from
this message or its header, you agree to these terms.

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 26 Aug 1998 18:57:55 -0400 (EDT)

> chrooted, and so the ls program executed by him is actually ~ftp/bin/ls.

this is covered in the FAQ

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195