Subject: wu-ftpd_2_4 problem compiling on AIX 4.2.1

From: [email-masked]
Date: Thu, 27 Aug 1998 10:43:13 +0900

Hi,

I had a bit of problem compiling the above on my AIX 4.2.0.0 RS/6000
machine.

The output upon typing "./build aix" is :

+++++++++++++++++++++++++++++++++++
make args are :
make opts are :

Linking Makefiles.
ln: 0653-421 Makefile exists.
    Specify -f to remove Makefile before linking.
ln: 0653-421 config.h exists.
    Specify -f to remove config.h before linking.
ln: 0653-421 Makefile exists.
    Specify -f to remove Makefile before linking.

Making support library.
        rm -f libsupport.a
        ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strsep.o
authuser.o strdup.o
        ranlib libsupport.a

Making ftpd.
        cc -O -DDEBUG -I.. -I../support -L../support -c ftpcmd.c
"ftpcmd.y", line 371.18: 1506-045 (S) Undeclared identifier cmdtab.
"ftpcmd.y", line 383.26: 1506-045 (S) Undeclared identifier sitetab.
"ftpcmd.y", line 1057.36: 1506-280 (W) Function argument assignment between
 types "void(*)(int)" and "void(*)()" is not allowed.
"ftpcmd.y", line 1519.1: 1506-343 (S) Redeclaration of print_groups differs
 from previous declaration on line 683 of "ftpcmd.y".
"ftpcmd.y", line 1519.1: 1506-050 (I) Return type "void" in redeclaration
is not compatible with the previous return type "int".
make: 1254-004 The error code from the last command is 1.

Stop.

Making ftpcount.
Target "ftpcount" is up to date.

Making ftpshut.
Target "ftpshut" is up to date.

Making ckconfig.
Target "ckconfig" is up to date.
ln: 0653-421 ftpwho exists.
    Specify -f to remove ftpwho before linking.
ln: 0653-421 ckconfig exists.
    Specify -f to remove ckconfig before linking.

Links to executables are in bin directory:
size: 0654-304 Cannot open bin/ftpd.
bin/ftpcount: 4644 + 796 + 4 + 1636 = 7080
bin/ftpshut: 2976 + 936 + 0 + 1169 = 5081
bin/ftpwho: 4644 + 796 + 4 + 1636 = 7080
bin/ckconfig: 1456 + 1444 + 0 + 554 = 3454
Done
+++++++++++++++++++++++++++++++++++++++++++++++++

I ran the above a few times.....Obviously some of the code modules compiled
successfully (ie. ftpcount, ftpshut, ftpwho, ckconfig) except for ftpd.

Any help will be appreciated.....

rgds and thks in advance

Victor Tan

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 27 Aug 1998 06:56:07 -0400 (EDT)

>     Specify -f to remove Makefile before linking.

For some reason the tarball comes preconfiged for a particular Unix
flavor.  Try running 'sh build clean' then rebuilding the package.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195