Subject: Re: your mail

From: [email-masked] (Jerry D. Smith)
Date: Tue, 11 Aug 1998 17:43:35 -0400

Hello all,

Looks like I re-read the O'Reilly book enough times. I FINALLY have wu-ftpd
with guest logins working to allow web master wannabes to ftp to their webpage
and make update without being able to go anywhere else.  The only outstanding
issue is with the ls command.  It exists in the ~bin directory of the chroot'ed
directory of the user.

the ls command does not list the files.. as discussed on page 60 of the
O'Reilly book the SUN needs some libraries, however those libraries do not seem
to exist on the HPUX??

Anybody solved this one??

Notes:

1. this user is a REGULAR user not anonymouse,

2. the ftpaccess file is used to restrict him as a guest user,

3. when I login as myself (not root) all works as it should

thanks for any assistance.

jerry

-- 
Jerry D. Smith
President and Chief Operating Officer

INCA Corporation - Delivering the Information Age Today!
201 E. Pine Street, Suite 875, Orlando FL 32801
Phone:407.481.2545, Fax:407.481.2541

Web: http://www.inca.net and www.7jaguar.com

---

From: Michael Brennen <[email-masked]>
Date: Tue, 11 Aug 1998 17:08:10 -0500 (CDT)

The single most FAQ, I think.  The guest howto, FAQ and other
resources all have answers. 

   -- Michael

On Tue, 11 Aug 1998, Jerry D. Smith wrote:

> the ls command does not list the files.. as discussed on page 60 of
> the O'Reilly book the SUN needs some libraries, however those
> libraries do not seem to exist on the HPUX?? 

This is the location for the latest wu-ftpd.  You can't see the
directory contents on the academ.com site, , but get the file anyway.
It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-18.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Christopher Caldwell <[email-masked]>
Date: Wed, 12 Aug 1998 10:03:05 -0400

In the chroot'd directory, try this:

cp REALROOT/sbin/ls to CHROOT/bin/ls.

The s[TATIC]bin version is statically built.

# ll /sbin/ls
-r-xr-xr-x   1 bin        bin         278528 Dec 12  1997 /sbin/ls
# ll /bin/ls
-r-xr-xr-x   6 bin        bin         356352 Dec 12  1997 /bin/ls
# ll /usr/bin/ls
-r-xr-xr-x   6 bin        bin         356352 Dec 12  1997 /usr/bin/ls

-C