Subject: Re: /etc/ftponly

From: [email-masked]
Date: Tue, 4 Aug 1998 21:40:07 +0200

On 4 Aug 98, at 11:25, Gregory A Lundberg wrote:

> Now you know why I detest RPM.  Who knows what you're getting?

You get an easy install, but later you don't know anything about how it was 
compiled. This is sometimes a pain and can use more time than RPM saves.

> I'm not sure what your problem is (telnet access, ftp access, whatever).
> 
> In the example, 'mort' desires ftp access but is not allowed telnet
> access.

Just what was the meaning and how it has been running until know. When 
"mort" are logging in using telnet, he get a message and are kicked out.
This has until now worked fine...!

> If it's different between one RPM and another, then RedHat changed
> something.  What?  Who knows.  Just install beta 18 and fix whatever they
> messed up, or ignore the config error for beta 16 .. whichever case fits
> whatever the RPM has wrong.

This is just the problem. Using the RPM install (beta-16) it worked as it should, 
but trying to get rid of the pain using RPM, I took a "real" source and compiled 
it...   ...BUT...!

Now "mort" is being kicked out *also* when he logs in using FTP. Why...?
It has something to do with the compile flags. Sure, but which "flag".

Just changing the binary file back to the beta-16 solves the problem. But this 
was not why I downloaded beta-18... :-(

Regards:
Ole Braad-Sorensen

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 4 Aug 1998 11:25:50 -0400 (EDT)

On Tue, 4 Aug 1998 [email-masked] wrote:

> > > If I change the "/etc/ftponly" to "/bin/bash" he has access again...
> > >
> > > If I install the "old" beta-16 (using RPM) "mort" has access again even I use the
> > > "/etc/ftponly".
> 
> *This* it the question... Why does "mort" have access using beta-16 and not 
> using beta-18. Using the same configuration files...!

In the example, 'mort' desires ftp access but is not allowed telnet
access.   We create a file '/etc/ftponly' which is an executable script
displaying a message and exiting (chmod a=rx /etc/ftponly).  We add the
line to /etc/shells so the ftp daemon will accept it as a valid Unix
shell; otherwise the use is not allowed ftp access.  When the user logs in
(locally or via telnet) their shell, /etc/ftponly, kicks 'em out.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "Steffen Gehring, MS/E, 58b/1/12, 47978" <[email-masked]>
Date: Tue, 04 Aug 1998 13:46:54 +0200

[email-masked] wrote:

> I have just installed the beta-18 on my system (Linux RedHat 5.0) which is set
> up using Michael Brennen's manual about setting up "real FTP" users. I have in
> my /etc/passwd the line as recommended:
>
> mort:*:403:400:Mortimer Snerd:/home/web/./:etc/ftponly
>

/etc/ftponly does'nt exist, so it's only comment, to avoid the user to "login".
u can use another  "login"
mort:*:403:400:Mortimer Snerd:/home/web/./:
mort:*:403:400:Mortimer Snerd:/home/web/./:-
mort:*:403:400:Mortimer Snerd:/home/web/./:nothing
mort:*:403:400:Mortimer Snerd:/home/web/./:what_ever_u_want_but_no_login_shell

remark:
in /etc/shells are your valid shells

that's what, ftponly is used for.
mort is only valid as a ftpd user, a guest, but no login user with a shell like
"bash"

>
>
>
> Everything is working fine until "mort" is logging on. Then the system say that
> "mort" is not allowed to log on.
>
> Sure I have set something wrong in the beta-18. But *What* ... ?
>
> Regards:
> Ole Braad-Sorensen
>

---

From: [email-masked]
Date: Tue, 4 Aug 1998 17:06:38 +0200

Thanks to Steffen and Oliver for your answer. BUT:
You did not read my message... :-(

> u can use another  "login"

I *know* what "ftponly" is and it *does* exist. It is a file displayed to users who 
are trying to telnet to the system and then kicked of because the file does not 
do anything else than showing the message: 
"You have no telnet access to this system - Bye!"

> that's what, ftponly is used for.

Read above that it *is* used for anything (if it exist).

Regards:
Ole Braad-Sorensen