Subject: wu-ftpd syslog.c for HPUX

From: [email-masked]
Date: Wed, 8 Jul 1998 22:02:06 -0700

I am working with Beta 18 compiling for HP-UX 9 and HP-UX 10.
Although I can use the standard HP-UX syslog functions, I have been
trying to use the alternates in syslog.c because ultimately I want to
make modifications.  I cannot get the alternate syslog functions to work.
In the function openlogfd(), the statement:
        if (err = connect(logfd, (struct sockaddr *)&ad, sizeof ad))
connect() fails with the error: Socket operation on non-socket.

Has anyone else had this problem with the wu-ftpd syslog.c; any
suggestions how to fix it?

-- 
Roger Wells
Sr. Project Engineer, Network Usage Measurement
[email-masked]

---

From: "Kinsman, Simon C. (SCKI)" <[email-masked]>
Date: Thu, 9 Jul 1998 07:29:23 -0700

Did you create the sockect with something like:
 logfd = socket( PF_INET, SOCK_STREAM, protocol);
If not, you will need to create the socket before using it in a connect
call.
Simon Kinsman,   

Email: [email-masked];  Phone 510-842-1950; Fax 510-328-2009

> ----------
> From: 	[email-masked][SMTP:[email-masked]]
> Sent: 	Wednesday, July 08, 1998 10:02 PM
> To: 	[email-masked]
> Subject: 	wu-ftpd syslog.c for HPUX
>