Subject: compiling in beta17

From: Tan Jian <[email-masked]>
Date: Thu, 02 Jul 1998 17:02:21 +0900

Hi,

 I attempt to compile wu-ftpd-2.4.2-beta-17 on solaris 2.5.1

but something always go es wrong when making ftpd,

warning mssage shown below.

    any effort would be appreciated.

# PATH=$PATH:.:/usr/ccs/bin:/usr/local/bin
# build CC=gcc sol
make args are :
make opts are :  CC=gcc

Linking Makefiles.

Making support library.
gcc -O -DSOLARIS2  -c fnmatch.c
gcc -O -DSOLARIS2  -c strcasestr.c
gcc -O -DSOLARIS2  -c strsep.c
gcc -O -DSOLARIS2  -c authuser.c
gcc -O -DSOLARIS2  -c snprintf.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o snprintf.o

ranlib libsupport.a

Making ftpd.
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  ftpd.c
yacc  ftpcmd.y
mv y.tab.c ftpcmd.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  ftpcmd.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  glob.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  logwtmp.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  popen.c
sh newvers.sh
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  vers.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  access.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  extensions.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  realpath.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  acl.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  private.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  authenticate.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  conversions.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  hostacc.c
gcc -g -I.. -I../support -L../support -DVIRTUAL  -c  sigfix.c
gcc -g -I.. -I../support -L../support -DVIRTUAL -o ftpd ftpd.o ftpcmd.o
glob.o logwtmp.o popen.o vers.o access.o  extensions.o  realpath.o acl.o
private.o authenticate.o conversions.o hostacc.o  sigfix.o -lsupport
-lsocket -lnsl -lgen
Undefined   first referenced
 symbol         in file
snprintf                            ftpd.o
vsnprintf                           ftpd.o
ld: fatal: Symbol referencing errors. No output written to ftpd
*** Error code 1
make: Fatal error: Command failed for target `ftpd'

Making ftpcount.
gcc -g -I.. -I../support -L../support -DVIRTUAL -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen

Making ftpshut.
gcc -g -I.. -I../support -L../support -DVIRTUAL -o ftpshut ftpshut.c
vers.o -lsupport -lsocket -lnsl -lgen

Making ckconfig.
gcc -g -I.. -I../support -L../support -DVIRTUAL -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: cannot open
bin/ftpcount: 7764 + 716 + 860 = 9340
bin/ftpshut: 6460 + 564 + 340 = 7364
bin/ftpwho: 7764 + 716 + 860 = 9340
bin/ckconfig: 3928 + 316 + 332 = 4576
Done

regards
kevin

---

From: [email-masked]
Date: Thu, 2 Jul 1998 13:25:07 +0400

You should edit support/snprintf.c
Add the following line

#undef    _SYS_VA_LIST_H

before this block

#ifdef SOLARIS2
#ifdef    _SYS_VA_LIST_H
#define SOLARIS26
#endif
#endif

Alexander Velichko,
System Engineer, ICB,
[email-masked]

> ----------
> From: 	Tan Jian[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	2 ÉÀÌÑ 1998 Ç. 12:02
> To: 	[email-masked]
> Subject: 	compiling in beta17
> 
> Hi, 
> 
> šI attempt to compile wu-ftpd-2.4.2-beta-17 on solaris 2.5.1 
> 
> ššš any effort would be appreciated. 
> 
> make opts are :š CC=gcc 
> gcc -O -DSOLARIS2š -c fnmatch.c 
> gcc -O -DSOLARIS2š -c strcasestr.c 
> gcc -O -DSOLARIS2š -c strsep.c 
> gcc -O -DSOLARIS2š -c authuser.c 
> gcc -O -DSOLARIS2š -c snprintf.c 
> rm -f libsupport.a 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš ftpd.c 
> yaccš ftpcmd.y 
> mv y.tab.c ftpcmd.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš ftpcmd.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš glob.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš logwtmp.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš popen.c 
> sh newvers.sh 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš vers.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš access.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš extensions.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš realpath.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš acl.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš private.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš authenticate.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš conversions.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš hostacc.c 
> gcc -g -I.. -I../support -L../support -DVIRTUALš -cš sigfix.c 
> glob.o logwtmp.o popen.o vers.o access.oš extensions.oš realpath.o acl.o
> private.o authenticate.o conversions.o hostacc.oš sigfix.o -lsupport
> -lsocket -lnsl -lgen 
> Undefinedšš first referenced 
> šsymbolšššššššš in file 
> snprintfššššššššššššššššššššššššššš ftpd.o 
> vsnprintfšššššššššššššššššššššššššš ftpd.o 
> š