Subject: Errors compiling wu-ftpd on HP-UX 10.20 trusted system

From: "Fernandez, Elena" <[email-masked]>
Date: Wed, 8 Jul 1998 12:24:32 -0400

I am compiling with gcc. And getting this errors .

# ./build hpx
make args are :
make opts are :

Linking Makefiles.
ln: makefiles/Makefile.hpx and Makefile are identical
ln: config/config.hpx and config.h are identical
ln: makefiles/Makefile.hpx and Makefile are identical

Making support library.
        rm -f libsupport.a
        ar cq libsupport.a fnmatch.o strcasestr.o strsep.o
        touch libsupport.a

Making ftpd.
Making vers.o
`vers.o' is up to date.

        yacc  ftpcmd.y
Make: Cannot load yacc.  Stop.
*** Error exit code 1

Stop.

Making ftpcount.
`ftpcount' is up to date.

Making ftpshut.
`ftpshut' is up to date.

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ftpcount and ftpwho are identical
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size:  bin/ftpd:  cannot open
bin/ftpcount: 9322 + 624 + 36 = 9982
bin/ftpshut: 9073 + 488 + 32 = 9593
bin/ftpwho: 9322 + 624 + 36 = 9982
bin/ckconfig: 7029 + 312 + 32 = 7373
Done
#

Thanks in advance.

---

From: "James B. Byrne" <[email-masked]>
Date: Wed, 8 Jul 1998 15:31:57 -5

On 8 Jul 98, at 12:24, Fernandez, Elena wrote:

> vers.o' is up to date.

yacc is either not on your system or not in your path statement. 
 If the latter then fix your path environment.  If the former then 
get bison as a replacement from GNU, build it, and then edit the 
hpx makefile to use bison rather than yacc.  Use one of the 
makefiles that use bison rather than yacc as a guide to which 
flags to set to make bison behave like yacc.  

Regards,
Jim
---
James B. Byrne                Harte & Lyne Limited
vox: +1 905 561 1241          9 Brockley Drive
fax: +1 905 561 0757          Hamilton, Ontario
mailto:[email-masked]  Canada L8E 3C3