Subject: Re: build problems.

From: "Peter.Serwe" <[email-masked]>
Date: Tue, 14 Jul 1998 15:15:34 -0400 (EDT)

I was wondering, after having gads of problems trying to build wu-ftpd on Irix 
6.2, if anyone has some hints or has built wu-ftpd on irix, I'd love some 
input.

TIA,

Peter Serwe <[email-masked]> <http://mcnet06.med.nyu.edu/serwep01>
Network Services / NYU Medical Center 
"I think the surest sign that intelligent life exists elsewhere is that none
of it has tried to contact us yet." - Calvin

---

From: [email-masked]
Date: Tue, 14 Jul 1998 15:27:47 -0400 (EDT)

I've built some older versions of wuftpd on irix. I think they have a
build option in the top level make file for irix where you can say
make irix or make sgi or maybe its build irix. Anyway what kind of 
problems are you running into

Doug

-- 
Doug Courtney
[email-masked]
(732)576-5572

---

From: "Peter.Serwe" <[email-masked]>
Date: Tue, 14 Jul 1998 15:41:48 -0400 (EDT)

On Tue, 14 Jul 1998 15:27:47 -0400 (EDT) [email-masked] wrote:

# I've built some older versions of wuftpd on irix. I think they have a
# build option in the top level make file for irix where you can say
# make irix or make sgi or maybe its build irix. Anyway what kind of 
# problems are you running into
# 
# Doug
# 

Here's what I saw, I tried to use the generic build, but it looks like I'm not 
getting the support libraries properly built, so I need to track that down, as 
that seems to be why the (ftpd, ftpcount, ftpshut, and ftpwho) are not 
building, either.

I'm also going to try 'build sgi' just to double check, but that's for a 
really old version of Irix. 

43# ./build xxx
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
gcc -O2   -c getusershell.c
gcc -O2   -c fnmatch.c
gcc -O2   -c strcasestr.c
gcc -O2   -c strerror.c
gcc -O2   -c strsep.c
gcc -O2   -c authuser.c
gcc -O2   -c ftw.c
ftw.c: In function `chwalk':
ftw.c:195: conflicting types for `malloc'
/usr/local/lib/gcc-lib/mips-sgi-irix5.3/2.7.2.3/include/stdlib.h:154: previous 
declaration of `malloc'
make: *** [ftw.o] Error 1

Making ftpd.
gcc -O2 -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
ftpd.c:1658: parse error
ftpd.c:2059: parse error
ftpd.c:2304: parse error
ftpd.c:2435: parse error
make: *** [ftpd.o] Error 1

Making ftpcount.
yacc  ftpcmd.y 
mv -f y.tab.c ftpcmd.c
sh newvers.sh
gcc -O2 -I.. -I../support -L../support -c vers.c
gcc -O2 -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport
collect2: ld returned 1 exit status
/usr/bin/../lib/ld:
Can't locate file for: -lsupport
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -O2 -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport
collect2: ld returned 1 exit status
/usr/bin/../lib/ld:
Can't locate file for: -lsupport
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -O2 -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex     filename
2016    3515    16      5547    15ab    bin/ckconfig