Subject: [Fwd: problem building wu-ftpd on solaris 2.x]

From: Korry Nguyen <[email-masked]>
Date: Wed, 08 Jul 1998 09:50:22 -0700

Subject: problem building wu-ftpd on solaris 2.x
From: Korry Nguyen <[email-masked]>
To: [email-masked]
Date: Tue, 07 Jul 1998 12:22:26 -0700

Hi,

Can you help me with this problem??? Thanksss....

compiling error messages on solaris2.6:

make args are :
make opts are :

Linking Makefiles.

Making support library.
cc -g -DDEBUG   -c fnmatch.c
cc -g -DDEBUG   -c strcasestr.c
cc -g -DDEBUG   -c strsep.c
cc -g -DDEBUG   -c authuser.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
"ftpd.c", line 143: identifier redeclared: realpath
        current : function(pointer to char, pointer to char) returning
pointer to char
        previous: function(pointer to const char, pointer to char)
returning pointer to char : "/usr/include/stdlib.h", line 180
"ftpd.c", line 1446: cannot recover from previous errors
cc: acomp failed for ftpd.c
make: *** [ftpd.o] Error 2

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to ftpcount
make: *** [ftpcount] Error 1

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to ftpshut
make: *** [ftpshut] Error 1

Making ckconfig.
cc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex     filename
4781    396     328     5505    1581    bin/ckconfig
Done
---------------------
compiling error messages on solaris 2.5.1:

make args are :
make opts are :

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
"ftpd.c", line 1972: undefined symbol: typenames
"ftpd.c", line 1972: cannot dereference non-pointer type
"ftpd.c", line 1974: undefined symbol: formnames
"ftpd.c", line 1974: cannot dereference non-pointer type
"ftpd.c", line 1982: undefined symbol: strunames
"ftpd.c", line 1982: cannot dereference non-pointer type
"ftpd.c", line 1982: undefined symbol: modenames
"ftpd.c", line 1982: cannot dereference non-pointer type
cc: acomp failed for ftpd.c
make: *** [ftpd.o] Error 2

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file; errno=2
ld: fatal: File processing errors.  No output written to ftpcount
make: *** [ftpcount] Error 1

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupport -lsocket -lnsl -lgen
ld: fatal: file vers.o: cannot open file; errno=2
ld: fatal: File processing errors.  No output written to ftpshut
make: *** [ftpshut] Error 1

Making ckconfig.
make: `ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex     filename
4781    396     328     5505    1581    bin/ckconfig
Done
-------------------

--
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Korry Nguyen               email:  [email-masked]  +
+ Ampex Data System          voice:  (415)367-4186           +
+ 500 Broadway, MS 2101      fax  :  (415)367-4134           +
+ Redwood City,              www  :  http://www.ampex.com    +
+ California, 94063-3199                                     +
+      my site:  http://www.angelfire.com/mi/sillyg00se      +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

---

From: Oleg Semenyuk <[email-masked]>
Date: Wed, 8 Jul 1998 21:00:55 +0400 (MSD)

Oh, the same problem (I wrote about it 10 minutes ago), but
I fix it, removed stdlib.h in src/config.h - IT IS MY ERROR,
do not do it!!

After this changes ftpd compiled successfilly, but crash after
any connection.

Oleg.

-----------------------------------------------------------
Hi,

make args are :
make opts are :

Linking Makefiles.

Making support library.

Making ftpd.

---

From: Korry Nguyen <[email-masked]>
Date: Thu, 09 Jul 1998 15:16:41 -0700

I still have problem building ftpd....

error messages:

make args are :
make opts are :

Linking Makefiles.

Making support library.
rm -f libsupport.a

Making ftpd.

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 10 Jul 1998 10:03:23 -0400 (EDT)

> "ftpd.c", line 1982: cannot dereference non-pointer type

mv /usr/include/ftp.h /usr/include/ftp.h.orig
cp wu-ftpd/support/ftp.h /usr/include/ftp.h

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195