Subject: guest-access

From: "S�ren Nielsen" <[email-masked]>
Date: Thu, 09 Jul 1998 18:36:18 +0000

I have followed your how-to on guest-accouns, and i run into the
same problem all the time: the user does not seem to have access
to a /bin/ls, the result: no files viewed. I can see that the user
is in the right dir (mput works) but no files are listed to the user.
I have in my pass the following:

student:x:630:100::/web/www.student.dk/html/./:/bin/noshell

(noshell is a homemade shell, like ftponly)

/html contains:

a bin dir
a etc dir

both with chmod 111.

ls is in the /bin with a chmod 111 also.

in /etc:

the files passwd and group look like this:

root:x:0:0::/:/bin/noshell
student:fjbXmb0ZLmbn6:630:100::/web/www.student.dk/html/./:/bin/noshell 

and group:

root::0:root
users::100:student

What could be wrong?

Regards and in forward thanks..

Soren Nielsen

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 9 Jul 1998 14:44:45 -0400 (EDT)

> I have in my pass the following:

This is a FAQ.  You're missing part of the required setup for ls; what
exactly is missing depends upon the system you're using.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195