Subject: Re: Weird wu.ftpd

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 15 Jul 1998 07:23:06 -0400 (EDT)

On Wed, 15 Jul 1998, Harry Brueckner wrote:

> I'm running a wu-ftpd 2.4.2b18 (tried b16 as well) on my linux machine
> which I just upgraded from kernel 2.0.33 to 2.0.34.  Since the new
> kernel is in place ftp users can't use the "list" command any more. 
> Doing a strace on the ftpd shows that it gets 'EACCES (Permission
> denied)' for the execve call. 
> 
> With 2.0.33 it worked fine and I didn't touch the ftpd configuration nor
> the /bin, /lib or /etc permissions in the ftp tree. 
> 
> Any idea why? Thanks.

Dunno why, but download and recompile the ls command from GNU fileutils
and it should work fine.  Happens to me every time I upgrade my kernel
too.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Harry Brueckner <[email-masked]>
Date: Wed, 15 Jul 1998 12:29:11 +0200 (MET DST)

Hi there,

I'm running a wu-ftpd 2.4.2b18 (tried b16 as well) on my linux machine which I
just upgraded from kernel 2.0.33 to 2.0.34.
Since the new kernel is in place ftp users can't use the "list" command any
more.
Doing a strace on the ftpd shows that it gets 'EACCES (Permission denied)' for
the execve call.

With 2.0.33 it worked fine and I didn't touch the ftpd configuration nor the
/bin, /lib or /etc permissions in the ftp tree.

Any idea why? Thanks.

Harry

 -------------------------------------------------------------------
  PGP fingerprint: B9 EE 83 0C 1F 48 54 50  9F A7 7A 00 6C 94 36 02
  PGP public key available by fingering [email-masked]