Subject: Re: Fine-grained ownership & permission Control

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 15 Jul 1998 10:01:09 -0400 (EDT)

On Wed, 15 Jul 1998, Wayne Farmer wrote:

> I have been using beta 13 & beta 15 in a production environment for some
> time with virtual servers.  I have encountered a situation where guest
> users from different virtual servers want competing functionality.
> 
> (1) In one case, each user wants own the files that he/she creates, group
> ownership is to be the same but file permissions must be 664
> 
> (2) In another case, users want 644
> 
> How does one retain the owner as the logged in guest user but alter the
> permissions ?
> 
> Of course, there is another case where multiple guest users on 1 virtual
> site want different groups based on the directories as well.
> 
> Can the upload directive do this ?
> e.g. upload /"ftproot" * yes * group dirs 664
>                              -
> where the underlined * says don't change (the above case assigns owner to
> root)
> 
> Wayne
> 
> PS I have tested beta 18 & see no specific additional capability like this.
>  (Can I not see the wood for the trees ?)

You might want to check out the NEWVIRT patches at the Resource Center; it
may offer what you're looking for.

In answer to your question about 'upload': No, what you're looking for is
not part of the current daemon.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "James B. Byrne" <[email-masked]>
Date: Wed, 15 Jul 1998 14:24:59 -5

> may offer what you're looking for.

Do these patches give b18 the same functionality as NEWVIRT 
040?

Regards,
Jim
---
James B. Byrne                Harte & Lyne Limited
vox: +1 905 561 1241          9 Brockley Drive
fax: +1 905 561 0757          Hamilton, Ontario
mailto:[email-masked]  Canada L8E 3C3

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 15 Jul 1998 14:35:19 -0400 (EDT)

On Wed, 15 Jul 1998, James B. Byrne wrote:

> Do these patches give b18 the same functionality as NEWVIRT 040? 

I say 'NEWVIRT patches' because in my mind that's what NEWVIRT 040 is, a
set of patches to the base daemon.

Last I heard, 040 was it.  You'll have to wait for Kent to get them up to
snuff for beta 18 or do it yourself.

----

---

From: Kent Landfield <[email-masked]>
Date: Wed, 15 Jul 1998 14:05:31 -0500 (CDT)

# 
# On Wed, 15 Jul 1998, James B. Byrne wrote:
# 
# > > You might want to check out the NEWVIRT patches at the Resource Center; it
# > > may offer what you're looking for.
# > > 
# > 
# > Do these patches give b18 the same functionality as NEWVIRT 040? 
# 
# I say 'NEWVIRT patches' because in my mind that's what NEWVIRT 040 is, a
# set of patches to the base daemon.
# 
# Last I heard, 040 was it.  You'll have to wait for Kent to get them up to
# snuff for beta 18 or do it yourself.

Newvirt patches will be out shortly. I'm swamped with work for the next
couple days.

-- 
Kent Landfield                        Phone: 1-817-545-2502             
Email: [email-masked]             http://www.landfield.com/
Email: [email-masked]                   http://www.nfr.net/
Please send comp.sources.misc related mail to [email-masked]
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/

---

From: "James B. Byrne" <[email-masked]>
Date: Wed, 15 Jul 1998 15:12:26 -5

> Newvirt patches will be out shortly. I'm swamped with work for the next

Thank you for the information.  I can wait, patiently.

Regards,
Jim
---

---

From: Wayne Farmer <[email-masked]>
Date: Wed, 15 Jul 1998 23:42:44 +1000

Wayne