Subject: Build of b17 failed

From: KHOO Guan Chen <[email-masked]>
Date: Wed, 1 Jul 1998 19:06:24 +0800 (SGT)

I have a Red Hat 4.2.

When I tried to build wu-ftpd-2.4.2-beta-17 today, it failed with the
following :-

>Making ftpd.
>gcc -O6 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
>-L../support -s   -c ftpd.c -o ftpd.o
>ftpd.c: In function `statcmd':
>ftpd.c:2719: `bytesize' undeclared (first use this function)
>ftpd.c:2719: (Each undeclared identifier is reported only once
>ftpd.c:2719: for each function it appears in.)
>make: *** [ftpd.o] Error 1

any help would be greatly appreciated.

Thanks

Richard KHOO Guan Chen

---

From: Kevin Hoffer <[email-masked]>
Date: Wed, 1 Jul 1998 08:25:26 -0400 (EDT)

Real Easy.. Go in to src/config/config.lnx and change this group of lines.
Take out the "#if LINUX_VERSION_CODE < 13104"
and take out a "#endif" at the bottom.

do a make clean before you do this and then recompile and it should be
fine.

#define __USE_POSIX
#include <limits.h>
#if LINUX_VERSION_CODE < 131104
#define NBBY 8
#ifndef NCARGS
#ifdef _POSIX_ARG_MAX
#define NCARGS _POSIX_ARG_MAX
#endif
#endif
#endif

---

From: Antonino Iannella <[email-masked]>
Date: Fri, 03 Jul 1998 12:28:08 +0930

Has anyone had any experience in compiling wu-ftpd with digital unix 4.0,
using C2 security? I followed the instructions in the FAQ, but did not
manage to get the bicrypt function to work....
-- 
Antonino Iannella - Ph 8259 6956 Fax 8259 5537 Mobile 0418 841 739
[email-masked]
Corporate Information Services, DSTO Salisbury