Subject: Compression on the fly

From: Robin S Levine <[email-masked]>
Date: Mon, 13 Jul 1998 15:01:44 -0400

Ver: wu-2.4.2-academ[BETA-18](1)
Op Sys: Sun Solaris

I'm brand new to wu-ftp and have just installed the above
version on a sun solaris. I've been having some  
difficulities with the on the fly compression.

I've gotten the compress to work on a get to itself
But Im really more interested in getting it to work on  
a put (send). Is this possible or am I just missing
something ?

Thanks
Robin S Levine
[email-masked]

$ ftp 0
Connected to 0.
220 padsun FTP server (Version wu-2.4.2-academ[BETA-18](1) Fri Jul 10
15:58:10 EDT 1998) ready.
Name (0:rlevine):  
331 Password required for rlevine.
Password:
230 User rlevine logged in.
ftp> binary
200 Type set to I.
ftp> ls -l          
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 2
-rw-r--r--   1 rlevine  staff         35 Jul 13 14:43 foo.bar
226 Transfer complete.
remote: -l
72 bytes received in 0.011 seconds (6.3 Kbytes/s)
ftp> get foo.bar.Z
200 PORT command successful.
150 Opening BINARY mode data connection for /bin/compress.
226 Transfer complete.
local: foo.bar.Z remote: foo.bar.Z
38 bytes received in 0.026 seconds (1.4 Kbytes/s)
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 4
-rw-r--r--   1 rlevine  staff         35 Jul 13 14:43 foo.bar
-rw-r--r--   1 rlevine  staff         38 Jul 13 14:43 foo.bar.Z
226 Transfer complete.
remote: -l
137 bytes received in 0.025 seconds (5.3 Kbytes/s)
ftp> quit
221 Goodbye.
$

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 13 Jul 1998 16:06:17 -0400 (EDT)

On Mon, 13 Jul 1998, Robin S Levine wrote:

> Date: Mon, 13 Jul 1998 15:01:44 -0400
> From: Robin S Levine <[email-masked]>
> To: [email-masked]
> Cc: Robin S Levine <[email-masked]>
> Subject: Compression on the fly
> 

  [NON-Text Body part not included]

Grr.  Quick vote: how many people appreciate the mess MS made of email?
Here's what he said:

----

Content-Type: text/plain; charset=ISO-8859-1; name="BDY.RTF"
Content-Disposition: inline; filename="BDY.RTF"
Content-Transfer-Encoding: quoted-printable

I'm brand new to wu-ftp and have just installed the above
version on a sun solaris. I've been having some =20
difficulities with the on the fly compression.
I've gotten the compress to work on a get to itself
But Im really more interested in getting it to work on =20
a put (send). Is this possible or am I just missing
something ?

Thanks
Robin S Levine

$ ftp 0
Connected to 0.
Name (0:rlevine): =20
ftp> ls -l         =20
=2Drw-r--r--   1 rlevine  staff         35 Jul 13 14:43 foo.bar
=2Drw-r--r--   1 rlevine  staff         35 Jul 13 14:43 foo.bar
=2Drw-r--r--   1 rlevine  staff         38 Jul 13 14:43 foo.bar.Z
$ =20

----

Short answer to the question:L sorry can't do that.

Longer answer: you can put together something whic you could SITE EXEC to
get the job done.  ISTR someone posted something about it a few weeks ago.
----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "David L. Aldridge" <[email-masked]>
Date: Mon, 13 Jul 1998 15:59:44 -0500

Perhaps that is because they are accustomed to the concept of a beta in the MS
world.
Most betas from quality groups like FreeBSD, Apache and Wu-ftp would be third
generation production releases.

--
David L. Aldridge
The Aldridge Company 281.368.0166 (fax: 281.368.0381)
http://www.aldridge.com/
Powered by Pentium/FreeBSD/Apache - Because it works.