Subject: How to setup anonymous ftp chroot to different directories using using aliased domains?

From: "Fernandez, Elena" <[email-masked]>
Date: Fri, 10 Jul 1998 11:43:15 -0400

I will like to setup our anonymous users to chroot to specific directories.
We will alias our ip address to several domains and will like that anonymous
users could chroot directly to their own and could not browse to the other
directories. Example (notice exact ip address)

Domain1.com      163.154.234.60
Domain2.com       163.154.234.60
Domain3.com        163.154.234.60

I will have 3 directories example: /ftp/domain1 
                                                    /ftp/domain2
                                                    /ftp/domain3

And we will like users to be able to extract information from this
directories as anonymous users chrooting directly on their own directories,
also they should not be able to see information of the other directories.

Any ideas on how to accomplish this?

Thanks in advance

Elena

Note: This is all fictional information.

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 10 Jul 1998 12:04:55 -0400 (EDT)

> Any ideas on how to accomplish this?

Read wu-ftpd-2.4.2-beta-18/VIRTUAL.FTP.SUPPORT

If you need finer control, check out NEWVIRT at the resource center

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195