Subject: Re: there are %M connections allowed in banner....

From: Rocke Robertson 991-2604 UNTS <[email-masked]>
Date: Wed, 8 Jul 1998 13:01:44 -0400 (EDT)

> Quoting Rocke Robertson 991-2604 UNTS, who wrote :
> 
> > Why does %M produce (Max unlimited) on the login banner?
> > 
> > Stats Solaris 2.5.1/BETA 18.......
> > 
> > Part of what the sever generates for the welcome banner..
> > 220---------------------------------------------------------------------
> > 220-Hello localhost, there are 0 (max unlimited) users logged in at the 
moment.
> > 220-Local time is: Wed Jul  8 12:02:24 1998
> > 220---------------------------------------------------------------------
> 
> > Part of the banner....
> > 
> > Hello %R, there are %N (max %M) users logged in at the moment.
> > 
> > Am I missing something obvious ?
> 
> Yes, sort of. All counts and maximums depend on which class the user is
> in, and the class is unknown before login (since wu-ftpd takes
> realuser/anonymous/guestuser as a variable for calculating which class a
> user is in).
> 
>                                              Koos
> 
> -- 
>   Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
>   [email-masked] (Work)                                Fax: +31-30-2586290
>   [email-masked] (Home)                      Workphone: +31-30-2586287
>   http://web.cetis.hvu.nl/~koos/   Looking for a license plate with "RFC 822"

I thought of this too. But I dont know how it could be confused by my class. Here 
is the part of my /etc/ftpaccess file. Sorry, I should have added my ftpaccess 
entries in my original posting.

loginfails 3

#class   local   real,guest,anonymous *.gc.ca 0.0.0.0
class   local   real,guest *.gc.ca 127.0.0.1
class   remote  real,guest *

#limit   remote  100 SaSu|Any1800-0600   /etc/msg/msg.toomany
limit   local   30  Any                 /etc/msg/msg.toomany
limit   remote  60  Any                 /etc/msg/msg.toomany

Now, if I ftp localhost... I still get the symptom. 

Thanks

_/_/_/_/_/_/_/_/_/_/_/_/_/_/
Rocke Robertson
350 King Edward
(613) 991-2604
Ottawa, Ontario
[email-masked]
_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Wed, 8 Jul 1998 19:51:19 +0200 (MET DST)

> entries in my original posting.

To reiterate: Since wu-ftpd *can* base class distinctions on the login you
use, it does *not* figure out which class you're in until you have given
it the login.

There is no artificial intelligence in wu-ftpd (for as far as I know) so
it can't second-guess that it already has enough information to determine
what class you're in.

                                              Koos