Subject: Re: process problem

From: [email-masked] (Jim Campbell)
Date: Tue, 7 Jul 1998 11:24:43 -0400

> Could anybody help me with the following question?
> 
> I found some children processes can not automately dispear in time ,
> 
> when  enter "ps -ef |grep ftp " ,I find some processes in the process
> table
> 
> has been obsolete, but they still stay there,
> 
> $ps -ef |grep ftp
>  ftp  4997  3572  0   Jun 28 ?        0:36 ftpd
>      ftp 14369  3572  0   Jul 01 ?        0:00 ftpd
>      ftp 24326  3572  0 12:58:24 ?        0:01 ftpd
>      ftp   678  3572  0   Jun 26 ?        0:00 ftpd
>      ftp 24134  3572  0 12:07:48 ?        0:00 ftpd
>      ftp  6127  3572  0   Jun 28 ?        0:00 ftpd
>      ftp 15078  3572  0   Jul 02 ?        0:00 ftpd
>      ftp  4846  3572  0   Jun 28 ?        0:00 ftpd
>      ftp  5777  3572  0   Jun 28 ?        0:47 ftpd
>      ftp  8743  3572  0   Jun 29 ?        0:00 ftpd
>      ftp 22531  3572  0   Jul 05 ?        0:00 ftpd
>      ftp 18062  3572  0   Jul 03 ?        0:00 ftpd
>      ftp 16397  3572  0   Jul 02 ?        0:00 ftpd
>      ftp 14359  3572  0   Jul 01 ?        0:00 ftpd
>      ftp 28898  3572  0   Jun 26 ?        0:00 ftpd
>      ftp 21812  3572  0   Jul 05 ?        0:01 ftpd
> 
> do anybody know why?

These do not look like "defunct" processes, since they are showing 
recent start times, not 1/1/70 GMT.  I would tend to think these are
FTP sessions that are left hanging.  How is your FTP service being used?

Jim Campbell  | [email-masked]  (W) 716/253-0294 (F) 716/253-5959
CI/DPS        | http://dpsnet.dpspps.kodak.com/jimc (Kodak only)
Eastman Kodak | Lotus Notes: Jim Campbell/484675/DAI/EKC@Kodak

---

From: [email-masked]
Date: Tue, 7 Jul 1998 19:02:08 -0400 (EDT)

There is a known problem with where the ftp process does not die. There has
been a patch or two to that imbed alarms in the transfer code. Many of us
including myself use a simple shell script that cleans up the processes some
number of times a day. I do it once a day.

Doug

-- 
Doug Courtney
[email-masked]
(732)576-5572