Subject: Re: chroot without wasting few Mo??????

From: Dan Stromberg <[email-masked]>
Date: Wed, 15 Jul 1998 08:18:53 -0700

This sounds like a good use for "loopback mounts", as found on Solaris
2.

Gilles Ciselet wrote:
> 
> You may also create a special FS that holds all things that are common to all
> your users i.e. libs, bins, ... You mount this FS over all users directories.
> 
> The question is "over how many directories can I mount my FS?"
> 
> To: [email-masked]
> cc: [email-masked]
> Subject: Re: chroot without wasting few Mo??????
> 
> On Wed, 15 Jul 1998, Stephane Robert wrote:
> 
> > I'm quite a newbie and I've problem with chroot and wu-ftp....
> >
> > I set up wu-ftpd to prevent all of our users to see other users directory.
> > My trouble is that to allow this, i had to put /bin /etc /dev and /lib in
> > each directory. These files represent more than 2 Mo, multiplied by
> > thousands of users, it makes a few gigas wasted...
> > Any turn-around??????
> 
> Hard links.
> 
> Or re-design your security scheme to use permissions to keep users apart
> and chroot them all to a common point.  That's what I do here.
> 
> ----
> 
> Gregory A Lundberg  Senior Partner, VRnet Company
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Gilles Ciselet <[email-masked]>
Date: Wed, 15 Jul 1998 14:51:18 +0000

To: [email-masked]

Hard links.

----