Subject: Problems with SITE EXEC

From: Ralf Kruedewagen <[email-masked]>
Date: Wed, 01 Jul 1998 16:09:49 +0200

Hello everyone,

I have just installed precompiled wu-ftpd 2.4(2) (Solaris 2.5.1) from
http://www.sunfreeware.com.

Whenever I try (as anonymous) to use SITE EXEC commands the systems
seems to do nothing.

Example:

ftp> site exec tar xvf test.tar
200-tar xvf test.tar
200  (end of 'tar xvf test.tar')
ftp> 

There is no error message in the system log file and I think I have set
it up correctly (tar is placed in ~ftp/bin/ftp-exec).

I have tried the same with guest account with the same result.

Is there something I could do ? I have checked the FAQ and mailing list
archives.

Thanks in advance.
Ralf Kruedewagen
-- 
Ralf Kruedewagen                  | Email: [email-masked] 
o.tel.o communications GmbH & Co. |        [email-masked] 
- Multimedia Operations -         | Tel:   +49-211-5602-8518
Zollhof 13, 40221 Duesseldorf     | Fax:   +49-211-5602-8443

---

From: Paulo Goncalves <[email-masked]>
Date: Wed, 1 Jul 1998 18:10:41 +0200 (MET DST)

did you check the /etc/ftpaccess part ???
if it allows tar ??? :)

compress        yes             local remote
tar             yes             local remote

maybe this is the prob :)

################################################
# System Administator        [email-masked] #
# Webmaster                   [email-masked]       #
# CCL Admin                  [email-masked]       #
################################################
Darkness its all u see when you look at me !!!!!

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 1 Jul 1998 13:55:17 -0400 (EDT)

> > 200  (end of 'tar xvf test.tar')

Not what you want.  Use GET instead for this, assuming test is a
directory:

GET test.tar

or 

GET test.tar.gz

or

GET test.Z

etc

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Ralf Kruedewagen <[email-masked]>
Date: Thu, 02 Jul 1998 08:46:05 +0200

On the fly compression and tar work fine (enabled in ftpaccess).

I want to untar the file test.tar on the ftp server after an upload.
The ftp (guest)account should be used for maintaining web pages.

---

From: Ralf Kruedewagen <[email-masked]>
Date: Thu, 02 Jul 1998 08:48:38 +0200

Gregory A Lundberg wrote:
I want to untar the file test.tar on the ftp server after an upload.
The ftp (guest)account should be used for maintaining web pages.

---

From: Ralf Kruedewagen <[email-masked]>
Date: Thu, 02 Jul 1998 08:51:32 +0200

Sorry, the first line of my last posting was incorrect.

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 2 Jul 1998 21:07:32 -0400 (EDT)

> The ftp (guest)account should be used for maintaining web pages.

You'll need to write a special-purpose program for this and put that
program into the chroot'd (you are chroot'd I hope) area.  Beyond that,
I've never used SITE EXEC myself, so I'm unsure.  There was quite a bit of
discussion on index commands way back (94 or 95) on the mailing list; you
should be able to figure out how to do what you want from the discussion
back then.

----

---

From: Ralf Kruedewagen <[email-masked]>
Date: Fri, 03 Jul 1998 10:44:36 +0200

> Kettering, OH 45409-1615 USA    1-800-809-2195

Hi,

I have solved the problem by compiling the package myself.
SITE EXEC works now fine.

Thanks for your response.
Best Regards
Ralf Kruedewagen