Subject: verifying ftpaccess use: was ACCESS DENIED (not in any class)

From: David Schlussel <[email-masked]>
Date: Fri, 19 Jun 1998 13:26:56 -0700 (PDT)

things i've noticed since my last message

i built the libraries directories as the ftpd man page suggested, and
noticed:

- on these x86 machines there is no libd.so
- when i remove the guestgroup line and kill -HUP inetd, it still fails
- when i added my group to a guestgroup line and kill -HUP, it still
	allowed me, maybe becuase my path was not changed.

how do i verify it's using the ftpaccess file? (it's started with the -a
option)?

am i not restarting it properly?  

-david

--------------- begin orignal message -----------------------

Howdy folks, I'm running wu-ftpd-2.4-b16 on Solarisx86

the people in my guest group are getting the following message

Jun 17 16:53:55 janus ftpd[12741]: ACCESS DENIED (not in any class) TO
gossomer.nuance.com [209.24.199.200]
Jun 17 16:53:55 janus ftpd[12741]: FTP LOGIN REFUSED (access denied)
FROM gossomer.nuance.com [209.24.199.200], dschluss

- we have no anonymous class established (though i tried adding it
and     it didn't help, so i removed it)
- when "real" users have their group changed to the guestgroup group, 
  they are denied access
- when guestgroup users have their group changed to another group,
  they are allowed access
- all the user's chroot directories have been setup properly
- the server is started as such:
        ftptest stream tcp nowait root /usr/sbin/in.wuftpd in.wuftpd -a
        (the "ftptest" is an alternate port, and, yes, i'm ftp-ing to
         that port, everything works at the regular port)
- i've poured over this site: http://www.wildheart.org/wu-ftpd/,and
as                      much of the 'suggested reading' as i could stomach
- hmmm, when i remove the guestgroup line, i still get denied.
- when i change the shell, i get denied
- when i change a real user's shell to /ftpshell (the guest user's 
        shell), i am accepted
- i am stumped

so please help me out if you can.  i'm not on the mailing list at the 
moment, so please respond directly.  thanks so very much.

oh, and following is the /etc/ftpaccess file:

-----begin /etc/ftpaccess-------------
class   all   real,guest *
 
limit   all   10   Any              /etc/msgs/msg.dead
 
readme  README*    login
readme  README*    cwd=*
 
message /welcome.msg            login
message .message                cwd=*
 
compress        yes             all
tar             yes             all
 
private         yes
 
log commands real
log transfers anonymous,real inbound,outbound
 
shutdown /etc/shutmsg
 
guestgroup anonftp
 
email user@hostname
-------------------end /etc/ftpaccess------------------

---

From: David Schlussel <[email-masked]>
Date: Fri, 19 Jun 1998 14:56:53 -0700 (PDT)

a-ha.  it turns out that the person who installed the package configured
it to look for /usr/local/etc/ftpaccess

thanks to those who put some thought into it.

-david