Subject: simple linux compile problem

From: "James Orwell" <[email-masked]>
Date: Mon, 22 Jun 1998 14:27:23 +0100

hello -

annoyingly simple problem here; unrelated to FAQ 5.4.

compiling wu-ftp 2.4 on redhat linux 5.0 (2.0.32 kernel),
the process falls over right at the start:

||
|| [root@mymachine wu-ftpd-2.4]# ./build lnx
|| make args are :
|| make opts are :
||
|| Linking Makefiles.
||
|| Making support library.
|| Makefile:13: *** missing separator.  Stop.
||
||

make version: GNU 3.67

the support/Makefile used is the standard .lnx one, quoted below:

|| CC     = gcc
|| AR     = ar cq
|| RANLIB = ranlib
|| LIBC   = /lib/libc.a
|| IFLAGS =
|| LFLAGS =
|| CFLAGS = -O -DDEBUG ${IFLAGS} ${LFLAGS}
||
|| SRCS   = getusershell.c fnmatch.c strcasestr.c strerror.c authuser.c ftw.c
|| OBJS   = getusershell.o fnmatch.o strcasestr.o strerror.o authuser.o ftw.o
||
|| all: $(OBJS)
||         -rm -f libsupport.a           <<<<< LINE 13
||         ${AR} libsupport.a $(OBJS)
||         ${RANLIB} libsupport.a
||
|| clean:
||         -rm -f *.o libsupport.a
||
|| ftp.h:
||         install -c -m 444 ftp.h /usr/include/arpa
||
|| paths.h:
||         install -c -m 444 paths.h /usr/include
||
|| fnmatch.o: fnmatch.c
||         ${CC} ${CFLAGS} -c fnmatch.c
||
|| getusershell.o: getusershell.c
||         ${CC} ${CFLAGS} -c getusershell.c
||
|| strerror.o: strerror.c
||         ${CC} ${CFLAGS} -c strerror.c
||
|| strdup.o: strdup.c
||         ${CC} ${CFLAGS} -c strdup.c
||
|| strcasestr.o: strcasestr.c
||         ${CC} ${CFLAGS} -c strcasestr.c
||
|| strsep.o: strsep.c
||         ${CC} ${CFLAGS} -c strsep.c
||
|| authuser.o: authuser.c
||         ${CC} ${CFLAGS} -c authuser.c
||
|| ftw.o: ftw.c
||         ${CC} ${CFLAGS} -c ftw.c

any help greatly appreciated.

James Orwell

-- 
-- 
James Orwell                                   email: [email-masked]
Image Processing Group                         phone: 0171 873 2894
Physics Department,                            fax:   0171 873 2716
Kings College London.
WC2R 2LS

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 22 Jun 1998 07:58:59 -0400 (EDT)

> || Makefile:13: *** missing separator.  Stop.

This usually happens when someone replaces the tab at the start of a line
with spaces.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "James Orwell" <[email-masked]>
Date: Mon, 22 Jun 1998 15:56:24 +0100

hi all,

> This usually happens when someone replaces the tab at the start of a line

yes, I've got the makefile to work. it *looked* like it had tabs in before, but
an explicit replace did the trick.
-------------------------------------------------------------------------------
next problem: where can i get bsd.h ?

|| Making support library.
|| gcc  -O -DDEBUG   -c getusershell.c
|| In file included from getusershell.c:25:
|| ../src/config.h:22: bsd.h: No such file or directory
|| make: *** [getusershell.o] Error 1
||

a 'build lnx' asks for that file, yet it's not present on a machine with
'everything' from redhat 5.0 installed.

searched wu-ftpd mail archive but nothing on exactly this.

thanks,

james

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 22 Jun 1998 08:53:34 -0400 (EDT)

> 'everything' from redhat 5.0 installed.

I can think of three possible causes:
- the Makefile isn't the Linux makefile
- you edited the Makefile and made a mistake
- there's a problem with the Linux version string tested for vs what
  RedHat shipped on 5.0; don't ask me why RedHat changed the version when
  there was no version change.  Maybe they're thinking the GNU libs are
  part of Linux?

----