Subject: Re: FTP GUI Software

From: " M. Nour" <" nourmha"@statcan.ca>
Date: Fri, 05 Jun 1998 12:09:03 -0400

Hi

     According the FAQ:     IRIX 6.2 needs ~/ftp/dev/zero and libraries. I
want to copy /lib/libc.so.1 to ~ftp/lib/libc.so.1 and /lib/rld to
~ftp/lib/rld.

Question: I want to know where to put these files exactly?

    what is this directory:  ~ftp/lib ?
    is it /usr/local/ftp/lib?

Thanks.

Gregory A Lundberg wrote:

> On Fri, 5 Jun 1998,  M. Nour wrote:
>
> > I have installed the wu-ftpd-2.4.2-beta-16, Do you recommend me to
> > re-install wu-ftpd-2.4-academ or wu-ftpd-2.4.?
>
> I'd suggest beta-17.  Under no circumstances should you install either of
> those old versions.
>
> ----
>
> Gregory A Lundberg              Senior Partner, VRnet Company
> 1441 Elmdale Drive              [email-masked]
> Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 5 Jun 1998 13:05:04 -0400 (EDT)

>     is it /usr/local/ftp/lib?

~ftp is shorthand for the home directory of the anonymous ftp user 'ftp'
look in /etc/passwd for where it is on your system.  If ~ftp is
/usr/local/ftp then /usr/local/ftp/lib is where you want the files.

----

---

From: " M. Nour" <" nourmha"@statcan.ca>
Date: Fri, 05 Jun 1998 14:16:06 -0400

I don't have anonymous ftp user.
I have setup guestusers only. All my users are under /home.
So I have created a directory /home/lib and put libc.so.1 and rld but
dir command still not working for my guest users

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 5 Jun 1998 14:31:39 -0400 (EDT)

Your userss ALL need the libs and devices in their directories.

Look in /etc/passwd .. see the '/./' in the home directory names?  If yes,
the part to the left is the directory where you'll have to put the stuff.
If no, the entire home directory name is where you'll need to put 'em

On Fri, 5 Jun 1998,  M. Nour wrote:

> Date: Fri, 05 Jun 1998 14:16:06 -0400
> From: " M. Nour" <" nourmha"@statcan.ca>
> Reply-To: [email-masked]
> To: ",[email-masked]" <[email-masked]>
> Subject: Re: FTP GUI Software
> 

----

---

From: " M. Nour" <" nourmha"@statcan.ca>
Date: Mon, 08 Jun 1998 10:15:57 -0400

The problem still there.

I have a user nourmha, his home directory is defined is /etc/passwd as
following:
/home/well/./
I have created the following directories:
/home/well/etc    /home/well/bin   /home/well/lib    /home/well/dev
I copied  /lib/libc.so.1 and    /lib/rld    to /home/well/lib
I copied /lib/ls   to /home/well/bin
I copied and modified /etc/passwd and /etc/group  to /home/well/etc

I tried to copy /dev/zero to /home/well/dev {cp /dev/zero /home/well/dev}and I
get the following message:
bad write to /home/well/dev/zero - No space left on device.

The problem still there.
All my users cannot execute the dir command.

Thanks.
Mhamed

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 8 Jun 1998 10:17:53 -0400 (EDT)

> All my users cannot execute the dir command.

This is covered in the FAQ.  Your ENTIRE problem has been covered in the
FAQ.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

Your problem now is that you've copied a special device file so of course
it won't work.  The FAQ contains precise instructions on how to set up
your machine, please READ it.

----