Subject: Errors at executing Build hpx

From: "Fernandez, Elena" <[email-masked]>
Date: Wed, 3 Jun 1998 12:49:42 -0400

Could someone provide input on regard to this errors.

I am compiling using gcc. I have modified Makefile to reflect this info .
Also modified files on /src/config.h
I am trying to install it on HPUX 10.20 trusted system.

Using version wu-ftpd 2.4.2

This  are the erros that I get when running build hpx:

make args are :
make opts are :

Linking Makefiles.
ln: makefiles/Makefile.hpx and Makefile are identical
ln: config/config.hpx and config.h are identical
ln: makefiles/Makefile.hpx and Makefile are identical

Making support library.
        cc -Aa -D_POSIX_SOURCE -O -DDEBUG   -c fnmatch.c
(Bundled) cc: warning 480: The -A option is available only with the C/ANSI C
pro
duct; ignored.
(Bundled) cc: warning 480: The -O option is available only with the C/ANSI C
pro
duct; ignored.
(Bundled) cc: "fnmatch.c", line 54: error 1705: Function prototypes are an
ANSI
feature.
(Bundled) cc: "fnmatch.c", line 80: error 1705: Function prototypes are an
ANSI
feature.
*** Error exit code 1

Stop.

Making ftpd.
        /usr/local/bin/gcc -Aa -Dunix -D_HPUX_SOURCE -O -DDEBUG -I..
-I../suppor
t -L../support -c ftpd.c
*Initialization*:1: missing token-sequence in `#assert'
In file included from /usr/include/hpsecurity.h:22,
                 from ftpd.c:53:
/usr/include/values.h:27: warning: `MAXINT' redefined
/usr/local/lib/gcc-lib/hppa1.1-hp-hpux10.20/2.7.2.1/include/sys/param.h:45:
warn
ing: this is the location of the previous definition
*** Error exit code 1

Stop.

Making ftpcount.
        /usr/local/bin/gcc -Aa -Dunix -D_HPUX_SOURCE -O -DDEBUG -I..
-I../suppor
t -L../support -o ftpcount ftpcount.c vers.o -lsupport -lc -lPW -lsec
gcc: vers.o: No such file or directory
*Initialization*:1: missing token-sequence in `#assert'
*** Error exit code 1

Stop.

Making ftpshut.
        /usr/local/bin/gcc -Aa -Dunix -D_HPUX_SOURCE -O -DDEBUG -I..
-I../suppor
t -L../support -o ftpshut ftpshut.c vers.o -lsupport -lc -lPW -lsec
gcc: vers.o: No such file or directory
*Initialization*:1: missing token-sequence in `#assert'
*** Error exit code 1

Stop.

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size:  bin/ftpd:  cannot open
size:  bin/ftpcount:  cannot open
size:  bin/ftpshut:  cannot open
size:  bin/ftpwho:  cannot open
bin/ckconfig: 5864 + 1704 + 8 = 7576
Done

Thanks in advance ,

Elena

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 3 Jun 1998 13:13:02 -0400 (EDT)

On Wed, 3 Jun 1998, Fernandez, Elena wrote:

> I am compiling using gcc.

No, you're not.  check the setup for the compiler.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195