Subject: Solaris 2.5.1 beta 17 problems

From: Brian Vandivier <[email-masked]>
Date: Mon, 15 Jun 1998 10:01:11 -0400

I'm having the problem where after one down load the server closes the 
connection like a previous problem.  The suggested solution was:

>You might try turning off the setproctitle code.  That seemed to cause a
>similar problem in the past for Solaris.  Also, as always, check the FAQ:
>there could be help there for this problem (I know it was very frequently
>asked in the past).

Nothing is in the FAQ about this, or that I saw.  How does one turn off 
setproctitle?  Or is there another solution?

Thanks

--Brian Vandivier

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 15 Jun 1998 10:33:50 -0400 (EDT)

> setproctitle?  Or is there another solution?

First off, this is a wild guess at what's causing the problem, please post
back if it solves your download problem.

In config.h, change #define SPT_TYPE to set SPT_TYPE to SPT_NONE The SPT_*
types are defined and used in ftpd.c, config.h selects the method
approriate for your flavor of Unix. 

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Brian Vandivier <[email-masked]>
Date: Mon, 15 Jun 1998 11:05:36 -0400

> approriate for your flavor of Unix. 

That didn't seem to work.  This is the session that I just ran:

230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> get ls-lR.Z
local: ls-lR.Z remote: ls-lR.Z
200 PORT command successful.
150 Opening BINARY mode data connection for ls-lR.Z (qd bytes).
226 Transfer complete.
757573 bytes received in 1.15 seconds (645.10 Kbytes/s)
ftp> dir
No control connection for command: Bad file number
ftp> 

The "qd bytes" thing also makes me wonder if there is something else going on.

Thanks
--Brian

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 15 Jun 1998 11:25:37 -0400 (EDT)

On Mon, 15 Jun 1998, Brian Vandivier wrote:

> Date: Mon, 15 Jun 1998 11:05:36 -0400
> From: Brian Vandivier <[email-masked]>
> To: Gregory A Lundberg <[email-masked]>
> Cc: [email-masked], [email-masked]
> Subject: Re: Solaris 2.5.1 beta 17 problems 
> 

This looks like a typo, but could be a porting issue.  First, make sure
you compiled using ./build <systemtype> where <systemtype> is the
appropriate choice for your OS; see the INSTALL file for a listing. 

> The "qd bytes" thing also makes me wonder if there is something else going on.

The problem with the 'dir' command most likely is an incomplete setup.
check the FAQ, which includes a special section for Solaris.

----

---

From: Brian Vandivier <[email-masked]>
Date: Mon, 15 Jun 1998 12:41:35 -0400

> appropriate choice for your OS; see the INSTALL file for a listing. 

I did use "build sol" and had no problems.

> check the FAQ, which includes a special section for Solaris.

Will check on this one.

--Brian

---

From: Brian Vandivier <[email-masked]>
Date: Tue, 16 Jun 1998 10:07:13 -0400

Apperently there is a problem with the Solaris Compiler.  When compiled with 
gcc all was fixed..

--Brian