Subject: Connection broken !!

From: Daniel Ley <[email-masked]>
Date: Tue, 16 Jun 1998 16:06:07 -0500

Hi everyone !!

I had just compiled and installed wu-ftp 2.4.2 beta 17 in a solaris 2.6
box. When I
open an ftp session from that box it gets pretty slow to transfer files
from any other site. I am trying a regular multiple files retrieve, here
I attach a copy of the session:

ftp> mget *
200 PORT command successful.
150 Opening BINARY mode data connection for PKZIPFIX.EXE (7687 bytes).
#
226 Transfer complete.
local: PKZIPFIX.EXE remote: PKZIPFIX.EXE
7687 bytes received in 22 seconds (0.34 Kbytes/s)
200 PORT command successful.
150 Opening BINARY mode data connection for ar32e301.exe (4018104
bytes).
##
netin: Connection reset by peer
421 Service not available, remote server has closed connection
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
No control connection for command: No such file or directory
ftp> 

I hope anybody can give some help in this.

TIA,
Daniel Ley

-- 
Daniel Ley Cheung			Tel: (011) 52 358 2000 Ext. 6905
Soporte Tecnologico 			Fax: (011) 52 328 4129 
Direccion de Informatica		[email-masked]
Universidad Virtual - ITESM

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 16 Jun 1998 17:14:57 -0400 (EDT)

> 421 Service not available, remote server has closed connection

Check the FAQ, there's a special section for Solaris referenced fro mit.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "David C. Kovar" <[email-masked]>
Date: Tue, 16 Jun 1998 23:19:02 -0700

I am running Version wu-2.4.2-academ[BETA-17] on a Sun Sparc running
Solaris 5.6. Built it with gcc and it's running correctly.

But it's not logging anything. /var/adm is set up correctly (ie, stock
permissions, and identical to other machines.) 

ftpaccess has: log transfers anonymous,real inbound,outbound

xferlog isn't getting created, nor at the ftp-pid files.

I've checked the FAQ and all the recent messages on the mailing list.

Any pointers would be most welcome.

-David

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 17 Jun 1998 07:08:50 -0400 (EDT)

> I've checked the FAQ and all the recent messages on the mailing list.

Check the inetd.conf line.  Does the user you're running the daemon as
have write permissions to the directories where the files will be created?
Does the command-line have a '-a' to tell the daemon to use the ftpaccess
file?

----

---

From: "David C. Kovar" <[email-masked]>
Date: Wed, 17 Jun 1998 04:41:42 -0700

Bingo. I was missing the "-a". Many thanks!! It's off and logging now.

-David