Subject: port problem?

From: "Brian Van Pelt" <[email-masked]>
Date: Fri, 19 Jun 1998 14:20:38 -0400

Any advice on how to approach this problem would be appreciated.

Real user login works but commands like
ls and get fail with

500 Illegal PORT Command
500 Can't build data connection: no PORT specified

There is no firewall in the way.

However, something like:
quote port 0,0,0,0,11,23
is successful. But, something like:
quote port <client-ip>,11,23
also fails.

I am using version 2.4.2 beta 17 with AIX 4.3

-Brian

---

From: Gregory A Lundberg <[email-masked]>
Date: Fri, 19 Jun 1998 14:58:51 -0400 (EDT)

> I am using version 2.4.2 beta 17 with AIX 4.3

sounds like an incomplete setup,  read the INSTALL instructions and the
FAQ.  Look for AIX-specific information in the FAQ, if any.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: "Michael Niksch" <[email-masked]>
Date: Mon, 22 Jun 1998 12:56:59 +0200

Sounds as if you might have a problem with tcp vs. tcp6. Try with tcp
if your inetd.conf entry is now specifying tcp6 for ftp.

-- 
Michael Niksch                     /Zurich/IBM @ Zurich @ IBM_Internal
IBM Zurich Research Laboratory     [email-masked] (NIK at ZURICH)
Saeumerstrasse 4                   http://www.zurich.ibm.com/~nik/
CH-8803 Rueschlikon / Switzerland  P: +41-1-724-8913 F: +41-1-724-8959

---

From: "Brian Van Pelt" <[email-masked]>
Date: Mon, 22 Jun 1998 08:58:13 -0400

> if your inetd.conf entry is now specifying tcp6 for ftp.

inetd.conf was specifying tcp but restarting inetd with IPV6 turned off
solved the problem.  Thank you and Mr. Lundberg for your suggestions.

-Brian