Subject: class directive questions

From: Dave Wreski <[email-masked]>
Date: Wed, 17 Jun 1998 04:34:06 -0400 (EDT)

The man page for ftpd says the 'class' directive is configured as follows:

class <class> <typelist> <addrglob> [<addrglob> ... ]

Is the variable given to the <class> have any significance?

Surely it must have some reason, yet any name I give it seems to work just
fine...

Thanks,
Dave Wreski

---

From: FTP Administrator <[email-masked]>
Date: Wed, 17 Jun 1998 10:18:22 +0200 (MET DST)

> Surely it must have some reason, yet any name I give it seems to work just
Of course. You can create for example two access classes, specified by 
IP addresses, users of your subnet, who can get "unlimited" access, and
rest of the world, who can get access limited only to some time slices...
Maybe your problems depends on which order you write the classes. 

Regards,

Massimo Gais
----
FTP Administrator                                        <[email-masked]>
C.D.S. - University "Federico II" of Naples (Italy)

                          "640K ought to be enough for anybody." 
                                           --  Bill Gates, 1981

---

From: Antonino Iannella <[email-masked]>
Date: Wed, 17 Jun 1998 18:23:19 +0930

would anyone know on the best way to configure an ftpaccess directive
such that for every user in the guestgroup

 - they cannot perform any actions (eg upload) to their root directory
 - can perform all actions in a subdirectory thereof, such as 'pub'.

What I am thinking of is something like

upload  <homedirectory>       *       no
upload  <homedirectory>/pub    yes     <username>     <usergrp>

plus

what is the best way of preventing files from being deleted from
the anonymous ftp account's upload directory?

-- 
Antonino Iannella - Ph 8259 6956

---

From: FTP Administrator <[email-masked]>
Date: Wed, 17 Jun 1998 11:34:05 +0200 (MET DST)

> the anonymous ftp account's upload directory?
This is how I configured our ftpserver (extract from our ftpaccess file)
  
upload  /ftp *    
upload  /ftp /pub/uploads               yes     ftpadmin ftp     0700 nodirs

When anonymous people uploads their files (only to /pub/uploads directory)
they lose ownership of files (see "ftpadmin"/"ftp" uid/gid combination);
the ftpserver perform also a "chmod 0700" (see 0700) for better security.

Regards,

Massimo Gais
----