Subject: Re: compilation error ?

From: Peter Evstatiev <[email-masked]>
Date: Tue, 09 Jun 1998 12:16:31 +0300

Hi ,
now everything is ok! :-)

The reason of some of errors is that in my file config.lnx haven't line
"#define HAVE_REGEX_H" and that's why my regex.h was not included ( apropos
rx.h ) .
After that I saw that  patch  wu-ftpd-2.4.2-beta-17-vr1.patch was modified this
config.lnx and added missing line ,but I wasn't move config.lnx in config.h :-)

The only change that I made is in config.h
#if LINUX_VERSION_CODE < 131104
 to ->
#if LINUX_VERSION_CODE < 131106

because in my /usr/include/linux/version.h LINUX_VERSION_CODE is  131105 ?!

Thank you for your help!

Best regards
Peter Evstatiev

p.s. sorry for my terrible english :-)

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 9 Jun 1998 06:56:35 -0400 (EDT)

> because in my /usr/include/linux/version.h LINUX_VERSION_CODE is  131105 ?!

Stan? Is this a porting issue?

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: [email-masked] (Stan Barber)
Date: 13 Jun 1998 03:01:10 GMT

>Stan? Is this a porting issue?

It's a difference between the RedHat 5.0 release and all other releases 
involving the same kernel version.

That's why I posted a work around to this problem sometime ago to the
wu-ftpd bugs page at http://www.academ.com/academ/wu-ftpd/bugs.html.

There will be a fix in beta-18, which I will have to test by building up
a Linux machine running another distribution to insure that the fix I 
will include works.
-- 
Stan   | Director of Technology, VERIO     | Work Email: [email-masked]
Olan   | Phone: +1-713-793-0222            | Personal Email: [email-masked]
Barber | Fax:   +1-713-793-0221            | Opinions expressed are only mine.