Subject: setproctitle problem with Digital Unix 4.0

From: FTP Administrator <[email-masked]>
Date: Thu, 11 Jun 1998 16:06:27 +0200 (MET DST)

Hello,
I dunno if this is a well-known problem but I had problem to receive this
mailing list. i just re-subscribed so now I post it.
When I type "ps -ef" or also use "ftpwho", I only see something like

ftp       30862    472  0.0 15:54:09 ??           0:00.06 ftpd: pe
ftp       31188    472  0.0 15:47:49 ??           0:00.12 ftpd: pp
ftp       31542    472  0.0 15:56:17 ??           0:00.07 ftpd: 19

etc.
I also checked in the sources that the "setproctitle" is working, and all
I could see is that the string is correctly build.
At last I solved this and now I'm able to get this:

ftp       30862    472  0.0 15:54:09 ??           0:00.06 ftpd:pegaso.edp-progetti.it:
anonymous/IE40user@: RETR /pub/Amiga/aminet/game/wb/arcanoid.lha
ftp       30972    472  0.0 15:53:27 ??           0:00.13 ftpd:lisas7-p15.telepac.pt: 
anonymous/[email-masked]: RETR /pub/Other/docs/rfc-unsorted/rfc1232.txt
root      31320    472  0.0 15:54:56 ??           0:00.03 ftpd:lisas7-p15.telepac.pt: 
connected: IDLE

but with a not-so-nice hack. Now my /etc/inetd.conf look like this:

ftp     stream  tcp     nowait  root    /usr/local/sbin/ftpd thisisaverydummystringmeantonlytomakespacefortheargv0sothatwuftpdsetproctitlehasspacetoputheretheneededdata -a

(yes is a really long line).

Did somebody work on this problem and solved it in a better way?

Thnak you in advance

Massimo Gais
 ----
FTP Administrator                                        <[email-masked]>
C.D.S. - University "Federico II" of Naples (Italy)

                          "640K ought to be enough for anybody." 
                                           --  Bill Gates, 1981

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 11 Jun 1998 10:18:05 -0400 (EDT)

What version of wu-ftpd are you running?  The current version is
2.4.2-beta-17.  I believe the problem is fixed in that.  There's a lot of
discussion in the list archives about setproctitle problems on older
versions.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

On Thu, 11 Jun 1998, FTP Administrator wrote:

> Date: Thu, 11 Jun 1998 16:06:27 +0200 (MET DST)
> From: FTP Administrator <[email-masked]>
> To: WuFftpd mailing list <[email-masked]>
> Subject: setproctitle problem with Digital Unix 4.0
> 
> Hello,

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: FTP Administrator <[email-masked]>
Date: Thu, 11 Jun 1998 16:55:42 +0200 (MET DST)

> wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
No, I just installed 2.4.2 beta 17 and it makes the same problem.
Anyway I'll look for the old archive entries.

Regards,

Massimo Gais 
----

---

From: Randy Norton <[email-masked]>
Date: Thu, 11 Jun 1998 12:27:55 -0700 (PDT)

Does this beta have virtual domaining? The version I cant get to build is
the virtual-wu.ftpd 2.4  its a hack I know but need the virtual ability. I
untared again and got the same error ftpd.- Error 1 again.
Any ideas?
Thanks
Randy

---
Hot City Internet				       [email-masked]
Network Operations Center	Unlimited usage SLIP starting at $20/month
Voice/Fax 408 848-6012 Serving South Santa Clara & South Santa Cruz County

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 11 Jun 1998 15:35:53 -0400 (EDT)

On Thu, 11 Jun 1998, Randy Norton wrote:

> Does this beta have virtual domaining? The version I cant get to build
> is the virtual-wu.ftpd 2.4 its a hack I know but need the virtual
> ability. I untared again and got the same error ftpd.- Error 1 again. 

The current beta inlucdes one form of virtual domain support.  Another
version 'newvirt' is available at the resource center but needs to be
brought forward to beta-17. 

----

---

From: FTP Administrator <[email-masked]>
Date: Fri, 12 Jun 1998 08:23:26 +0200 (MET DST)

> untared again and got the same error ftpd.- Error 1 again.
Yes, Ive been able to compile with VIRTUAL support.
I tested it and it's working. I wait it will be useful for me.
You need only to add -DVIRTUAL to the compilation CFLAGS.

If you need more help, I can e-mail you my configs.

Regards,

Massimo Gais 
----

---

From: " M. Nour" <" nourmha"@statcan.ca>
Date: Mon, 15 Jun 1998 09:29:17 -0400

Hi,
Would you please answer to this question:

I want to run  a unix script which will move files from the home directory of any user to another directory.
I want to be sure that the put process of any file finished before moving any file.

Are there any way to detect files already transferred and these still in the process to be transferred?

Thanks.