Subject: Problem with ls -l

From: Nadine Olivier <[email-masked]>
Date: Thu, 18 Jun 1998 18:35:48 +0200 (MET DST)

I installed wuftpd (beta-17) on a Sun running Solaris2.6.
In the ftpaccess file, I initialize guestgroup with a "ftponly"
groupname and put the real user "dietz" in the ftponly group.
The user's home directory is properly set when logged in.
ls is OK, but ls -l is not working

ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp>

What is wrong?
Thanks a lot

Nadine OLIVIER

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 18 Jun 1998 12:50:22 -0400 (EDT)

> ls is OK, but ls -l is not working

Incomplete setup, read the FAQ, especially the section on Solaris

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195

---

From: Kevin Hoffer <[email-masked]>
Date: Thu, 18 Jun 1998 12:52:17 -0400 (EDT)

I get this message when it goes to compile it. any clues as to why this is
going on? I tried to look at the code but I know c about as good as I know
spanish.

Kevin

oak:/usr/src/wu-ftpd-2.4.2-beta-17# ./build lnx
make args are :
make opts are :

Linking Makefiles.

Making support library.
gcc  -O6 -fomit-frame-pointer -fno-strength-reduce -pipe   -c strcasestr.c
gcc  -O6 -fomit-frame-pointer -fno-strength-reduce -pipe   -c authuser.c
gcc  -O6 -fomit-frame-pointer -fno-strength-reduce -pipe   -c snprintf.c
rm -f libsupport.a
ar cq libsupport.a strcasestr.o authuser.o snprintf.o
ranlib libsupport.a

Making ftpd.
gcc -O6 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../support -s   -c ftpd.c -o ftpd.o
ftpd.c: In function `statcmd':
ftpd.c:2719: `bytesize' undeclared (first use this function)
ftpd.c:2719: (Each undeclared identifier is reported only once
ftpd.c:2719: for each function it appears in.)
make: *** Deleting file `ftpd.o'
make: *** [ftpd.o] Interrupt

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 18 Jun 1998 13:01:00 -0400 (EDT)

> make: *** [ftpd.o] Interrupt

Once upon a time, the INSTALL file had instructions to fix this.  Dunno if
it's in the FAQ.  It's in the mailing list archives from way-back '94 or
so and I posted something about it a couple weeks ago, too.

----

---

From: " M. Nour" <" nourmha"@statcan.ca>
Date: Thu, 18 Jun 1998 13:16:07 -0400

Hi Nadine,
Comment ca va le coupe du Monde?

 I had this problem for 3 weeks.
this is the fix for that.

1. Check the permission of the directories bin, etc, dev, lib.
chmod o+rx bin,etc,dev,lib
2.  Inside lib
   chmod o+rx libc.so.1 rld
3. inside dev
   chmod o+r zero
4. inside etc
    chmod o+r passed group
4. inside bin
    chmod a+x ls

that all.

Mhamed Nour

---

From: Dan Stromberg <[email-masked]>
Date: Thu, 18 Jun 1998 13:18:18 -0700

I just saw this myself.

Apparently part of config.lnx is conditionalized to only be used on
older versions of linux.

But to compile on redhat 4.2, I needed those defines.

Hunt for NBBY in config.lnx.  Move all that stuff outside the ifdef (or
just remove the #if... and #endif).  Recompile.

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 18 Jun 1998 17:39:53 -0400 (EDT)

> Apparently part of config.lnx is conditionalized to only be used on

Oh, yeah .. now I remember .. Redhat 5.0 bumped the Linux version number
for some reason .. all you need to do is cat /usr/include/linux/version.h
and change the #if in src/config.h from

#if LINUX_VERSION_CODE < 131104

to whatever you need (131105 or 131106 or something like that)

----