Subject: Compilation problem under solaris 2.5.1

From: David Berard <[email-masked]>
Date: Fri, 5 Jun 1998 09:35:06 +0200 (MET DST)

Hello,

I have a compilation problem with wu-ftpd 2.4.2 beta 17 under solaris
2.5.1 and gcc 2.8.1 :

The problem is during the linking of ftpd. I obtain :

gcc -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o  extensions.o  realpath.o acl.o private.o authenticate.o conversions.o hostacc.o  sigfix.o -lsupport -lsocket -lnsl -lgen
Undefined                       first referenced
 symbol                             in file
snprintf                            ftpd.o
vsnprintf                           ftpd.o
ld: fatal: Symbol referencing errors. No output written to ftpd
*** Error code 1
make: Fatal error: Command failed for target `ftpd'

I have found 2 similar questions in the archive, but no response.

Could you help me ?

--

David Berard                 | Tel : 04 50 66 60 87
CRIR / ESIA                  | Fax : 04 50 66 60 20
Universite de Savoie         |

---

From: Emil Isberg <[email-masked]>
Date: Mon, 8 Jun 1998 19:58:22 +0200 (MET DST)

>Undefined                       first referenced

According to the NOTES file, snprintf.o should be created by the support
dir .. But you might want to check the makefiles to be sure ..

The one you want to check is support/makefiles/Makefile.sol ..

-- 
/Emil