Subject: compile error ftpd.o

From: Randy Norton <[email-masked]>
Date: Wed, 10 Jun 1998 23:50:31 -0700 (PDT)

the ftpd is failing and I tried changing the path but that does not help.
anyone have an idea how I can get it to compile. I have Linix 2.0.33 
Thanks
Randy

make args are : 
make opts are : 
Linking Makefiles.

Making support library.
rm -rf libsupport.a
gcc  -O2 -I/usr/include/bsd  -m486 -pipe -c getusershell.c fnmatch.c strcasestr.c strerror.c authuser.c ftw.c 
ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strerror.o authuser.o ftw.o
ranlib libsupport.a

Making ftpd.
gcc -O2 -I.. -I../support -I/usr/include/bsd -I/usr/include/netinet -L../support -DDIRENT_ILLEGAL_ACCESS   -c ftpd.c -o ftpd.o
fpt.c:58: netinet/in_system.h: no such file or directory
make:*** [ftpd.0 Error 1
Making ftpcount.
make: `ftpcount' is up to date.

Making ftpshut.
make: `ftpshut' is up to date.

Making ckconfig.
make: `ckconfig' is up to date.

Links to executables are in bin directory:
text	data	bss	dec	hex	filename
2772   	2607   	104    	5483   	156b   	bin/ftpcount
2452   	2220   	108    	4780   	12ac   	bin/ftpshut
2772   	2607   	104    	5483   	156b   	bin/ftpwho
1060   	1819   	88     	2967   	b97    	bin/ckconfig
Done

---
Hot City Internet				       [email-masked]
Network Operations Center	Unlimited usage SLIP starting at $20/month
Voice/Fax 408 848-6012 Serving South Santa Clara & South Santa Cruz County

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 11 Jun 1998 06:42:46 -0400 (EDT)

> anyone have an idea how I can get it to compile. I have Linix 2.0.33 

Load a clean source kit from the tarball, cd into it, then
  ./build lnx
and see if the problem still occurs.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195