Subject: bug with "upload.*nodirs" flag?

From: David Carmean <[email-masked]>
Date: Tue, 12 May 1998 13:54:38 -0700

Greetings.  Just signed on; don't know if this list 
is active or not :o)  Couldn't find archives on listproc.

Been using wu-ftpd for three years or so, but today is 
the first time I've tried to use the "upload" directives 
in the ftpaccess file.  I added the following line, which 
I would think would apply to anonymous users only:

 upload  /home1/ftp  /* yes  nobody  users   0060  nodirs

Well, anonymous uploads /do/ get created as user "nobody", 
group "users", mode 0600, and MKDIR is disallowed.

However, the "nodirs" flag is restricting "real" users from 
creating directories as well, although the rest of 
the line has no effect (i.e. permissions/ownership are those 
of the real user).

I thought that ftpd looked up the supplied username 
in /etc/passwd, and if that user's home directory matched 
that given above (e.g. /home1/ftp) then that "upload" line 
would apply?  That would seem to restrict the above to the 
user "ftp" (and "anonymous") only.  Am I reading the 
manpage wrong?

This is wu-ftpd-2.4.2-academ[BETA-11](3).

Thanks.

-- 
David Carmean                                           <[email-masked]>
Avtel Communications, Santa Barbara, CA			+1-805-730-7740
  PGP fingerprint =  B1 57 EB A8 1D B9 87 86  5F 5C 51 A4 F2 5E ED FD

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 12 May 1998 18:04:19 -0400 (EDT)

On Tue, 12 May 1998, David Carmean wrote:

> Couldn't find archives on listproc.

Archives are at the Resource Center.

> user "ftp" (and "anonymous") only.  Am I reading the 

No, wu-ftpd simply matches the path and file name for the uploaded file.
Real users will need to upload into another area.

> This is wu-ftpd-2.4.2-academ[BETA-11](3).

The current version is 2.4.2 beta 17, you should upgrade due to serious
security issues resolved in versions following beta 11.

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              [email-masked]
Kettering, OH 45409-1615 USA    1-800-809-2195