Subject: web ftp

From: Kevin Clancy PhD <[email-masked]>
Date: Wed, 27 May 1998 16:32:52 -0600 (MDT)

Dear All

I am running wu-2.4(2) on a Sun Sparc station with Solaris 2.4. I am
using the netscape Enterprise 2.0 web server for web hosting. I want to
make my ftp archive visible to web browser users. Currently when I access
the ftp archive with netscape/internet exploder, I see nothing - no
folders, no directories, nothing. 

Accessing the site by anonymous ftp or as a registered user works fine.

This is the permissions for the ftp folder:
dr-xr-xr-x  11 root     other        512 Dec 11 15:43 ftp

This is a listing of the folders under the ftp directory and their
permissions:

dr-xr-xr-x  11 root     other        512 Dec 11 15:43 .
drwxr-xr-x  20 clancy   other       2048 Apr 23 17:47 ..
-rw-r--r--   1 root     other        170 Dec 10 17:06 .contents
-rw-r--r--   1 root     other        170 Dec 11 15:43 .message
-rw-r--r--   1 root     other        170 Dec 10 17:08 README
d--x--x--x   2 root     other        512 Dec 10 14:48 bin
dr-xr-xr-x   2 root     other        512 Dec 10 12:48 dev
d--x--x--x   2 root     other        512 Dec  9 16:22 etc
drwx-wx-wt   2 root     other        512 Dec 10 17:09 incoming
dr--r--r--   2 root     other        512 Dec 10 14:48 info
dr-xr-xr-x   2 root     other        512 Dec 10 14:48 lib
dr--r--r--   3 root     other        512 Dec 10 14:48 man
drwxr-xr-x   5 clancy   other        512 May 19 17:33 pub
dr-xr-xr-x   3 root     other        512 Nov 17  1996 usr

This is the situation under the pub directory:
total 132
drwxr-xr-x   5 clancy   other        512 May 19 17:33 .
dr-xr-xr-x  11 root     other        512 Dec 11 15:43 ..
-rwxr-xr-x   1 root     other        170 Dec 10 17:09 README
drwxr-xr-x   2 clancy   other        512 Dec 10 16:34 chrom21
drwxr-xr-x   8 clancy   other        512 Dec 18 12:12 chrom3
drwxr-xr-x   6 clancy   users        512 Feb  9 20:40 consortium
-rw-r--r--   1 root     other      59484 May 19 17:28 druid_stuff.tar.Z.uu

What is the problem here? Do I have a permissions problem? What do I need
to do to make these files and folders visible to web browsers? 

Thanks for the help.

Sincerely

Kevin Clancy
Eleanor Roosevelt Institute
1899 Gaylord St.,
Denver, CO 80206

[email-masked]
http://www-eri.uchsc.edu

---

From: Bob Luckin <[email-masked]>
Date: Wed, 27 May 98 18:07:42 CDT

Kevin said :-
> Accessing the site by anonymous ftp or as a registered user works fine.
...snip...
> to do to make these files and folders visible to web browsers? 

I'm not sure if it is true for Solaris 2.4, but under 2.5 if you don't have
the permissions on ~ftp/dev/tcp set to 666, then passive connections don't
work.  Many web browsers use passive connections (not sure about MSIE), so
this could be the cause of the problem.

FYI, my Solaris 2.5 settings are :-
   ls -l ~ftp/dev
   total 0
   crw-rw-rw-   1 root     other     11, 42 Mar 13  1996 tcp
   crw-rw-rw-   1 root     other    105,  1 Oct 25  1996 ticotsord
   crw-rw-rw-   1 root     other     11, 14 Oct 25  1996 udp
   crw-rw-rw-   1 root     other     13, 12 Mar 13  1996 zero
but I expect the major and minor numbers may vary for 2.4

The original Solaris man page for ftpd should list the files and settings
you need for anonymous access.  Check that your system conforms to these.

If you still see a problem after that, then the WU-FTPD FAQ is at
   http://www.hvu.nl/~koos/wu-ftpd-faq.html
the Solaris 2.5 how-to (may be similar enough to be relevant) is at
   http://www.wildheart.org/wu-ftpd/
and Kent Landfield's on-line resource center is at
   http://www.landfield.com/wu-ftpd/
Hopefully one of these will have some suggestions to help you find the
problem.

I hope this helps - good luck !

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "Coder, adapt.  FTP Ada, redo C"
                                 [http://www.dhc.net/~luckin/palindromes.html]