Subject: compiling problems with HP10.20

From: [email-masked]
Date: Tue, 5 May 1998 16:32:01 -0400

I'm trying to build wu-ftpd-2.4.2-beta-16 with gcc-2.8.1on HP-UX b.10.20 A
  with
build CC=gcc hpx. Can anybody point me to what is wrong.

Any assistance would be greatly appreciated.
Thanks, in advance, for your help.

Andre

$ build CC=gcc hpx
make args are :
make opts are :  CC=gcc

Linking Makefiles.

Making support library.
gcc -O   -c fnmatch.c
gcc -O   -c strcasestr.c
gcc -O   -c strsep.c
gcc -O   -c getusershell.c
gcc -O   -c snprintf.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o getusershell.o
snprintf.o
touch libsupport.a

Making ftpd.
gcc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support    -c ftpd.c -o ftpd.o
*Initialization*:1: missing token-sequence in `#assert'
make: *** [ftpd.o] Error 1

Making ftpcount.
gcc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpcount ftpcount.c
vers.
o ../support/libsupport.a
gcc: vers.o: No such file or directory
*Initialization*:1: missing token-sequence in `#assert'
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpshut ftpshut.c
vers.o
../support/libsupport.a
gcc: vers.o: No such file or directory
*Initialization*:1: missing token-sequence in `#assert'
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ckconfig ckconfig.c
*Initialization*:1: missing token-sequence in `#assert'
make: *** [ckconfig] Error 1

Links to executables are in bin directory:
size:  bin/ftpd:  cannot open
size:  bin/ftpcount:  cannot open
size:  bin/ftpshut:  cannot open
size:  bin/ftpwho:  cannot open
size:  bin/ckconfig:  cannot open
Done

---

From: John McDermon <[email-masked]>
Date: Wed, 6 May 1998 20:47:26 -0600

The clue is here:

    ^^^

The -A option in gcc is an assertion which is looking for more options, but
in the HP-UX C compiler -Aa is the switch for ansi source. It looks like
the Makefile is "tuned" for the HP-UX compilers.

Try replacing the -Aa in the Makefile with -ansi which is the ansi switch
for gcc.

--John