Subject: RE: Setting up co-existing ftp/http

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Thu, 30 Apr 1998 09:35:39 -0700

yup!
what version of frewall (if any) are you running?

> ----------
> From: 	Timothy J
> Luoma[SMTP:luomat+Lists/[email-masked]]
> Reply To: 	luomat+Lists/[email-masked]
> Sent: 	Thursday, April 30, 1998 5:38 AM
> To: 	[email-masked]; [email-masked]
> Subject: 	Setting up co-existing ftp/http
> 
> 
> Say I wanted to setup a joint http and ftp archive (ie one which could
> be  
> accessed by either ftp or http and get at the same files, using apache
> and  
> wu-ftp).
> 
> 1) anything to be aware of as far as security, unexpected 'gotchas',
> etc?
> 
> 2) I want to have one directory not available to anon-ftp users, but
> only to 
> 	folks who have the right password.
> 	
> Would it be better to:
> 	make a directory owned by the UID which apache
> 	runs as, chmod 700, and password protect it (using htaccess?
> 	or should I be running SSLeay?)
> 	
> 	or
> 	
> 	make a special directory under ~ftp owned by 'guest2' and make
> 	guest2 a password protected account? (can this be done and still
> 	have guest2 logins chroot to ~ftp ?  I think I remember
> something
> 	like this in the wu-ftp docs but can't seem to remember what it
> 	was called)
> 
> Just looking for advantages/disadvantages either way, esp. from
> someone who  
> might have done this.
> 
> TjL
>

---

From: Timothy J Luoma <luomat+Lists/[email-masked]>
Date: Thu, 30 Apr 98 12:52:18 -0400

Author:        "Speier, Guy J - CNF" <[email-masked]>
	Original-Date: Thu, 30 Apr 1998 09:35:39 -0700
	Message-ID:    <[email-masked]>

> yup!

Yup what?

> what version of frewall (if any) are you running?

I'm using tcp_wrappers, that's about all..

TjL