Subject: Problem building wu-ftpd-2.4.2-beta-16

From: WITTOECK Christine <[email-masked]>
Date: Fri, 03 Apr 1998 13:40:24 +0200

Hi, 

I want to install wu-ftpd-2.4.2-beta-16 on HPUX 10.20 and with the build
I get folloing errors:

.........

Making ftpd.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c ftpd.c
(Bundled) cc: warning 480: The -A option is available only with the
C/ANSI C pro
duct; ignored.
(Bundled) cc: warning 480: The -O option is available only with the
C/ANSI C pro
duct; ignored.
(Bundled) cc: "ftpd.c", line 3767: warning 5: "const" will become a
keyword.
(Bundled) cc: "ftpd.c", line 3767: error 1000: Unexpected symbol:
"const".
*** Error exit code 1

Stop.

.Making ftpcount.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpcount
ftpcount.
c vers.o ../support/libsupport.a
(Bundled) cc: warning 480: The -A option is available only with the
C/ANSI C pro
duct; ignored.
(Bundled) cc: warning 480: The -O option is available only with the
C/ANSI C pro
duct; ignored.
/usr/ccs/bin/ld: Can't open vers.o
/usr/ccs/bin/ld: No such file or directory
*** Error exit code 1

Stop.

Making ftpshut.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpshut
ftpshut.c
vers.o ../support/libsupport.a
(Bundled) cc: warning 480: The -A option is available only with the
C/ANSI C pro
duct; ignored.
(Bundled) cc: warning 480: The -O option is available only with the
C/ANSI C pro
duct; ignored.
/usr/ccs/bin/ld: Can't open vers.o
/usr/ccs/bin/ld: No such file or directory
*** Error exit code 1

Stop.

Making ckconfig.
`ckconfig' is up to date.
ln: ckconfig exists

Links to executables are in bin directory:
size:  bin/ftpd:  cannot open
size:  bin/ftpcount:  cannot open
size:  bin/ftpshut:  cannot open
size:  bin/ftpwho:  cannot open
bin/ckconfig: 5917 + 1852 + 8 = 7777
Done

.........

What am I missing to do the build correctly ?

-- 
Christine Wittoeck              email: [email-masked]
Alcanet International Benelux   tel:    +32 3 4503444
De Villermontstraat 38          fax:    +32 3 4503038
B 2550 Kontich
Belgium

---

From: Marc Baudoin <[email-masked]>
Date: Fri, 3 Apr 1998 14:22:33 +0200

> (Bundled) cc: "ftpd.c", line 3767: error 1000: Unexpected symbol:

The cc shipped with HP-UX is braindead and is of no use.  The
only thing you can do with it is compile a real C compiler such
as GNU gcc.  wu-ftpd compiles fine with gcc.

-- 
Marc Baudoin   -=-   <[email-masked]>
Security On-Line Software (Solsoft) SA

---

From: "James B. Byrne" <[email-masked]>
Date: Fri, 3 Apr 1998 11:31:22 -5

> as GNU gcc.  wu-ftpd compiles fine with gcc.

The C compilier that comes bundled with HP-UX is a full function 
K&R C compilier.  It just isn't an ANSI C compilier.  

Many programs, such as sendmail, do not use ANSI C programming 
constructs and so do not require an ANSI C compilier.  Many, 
like WU-FTPD, do.

You have two choices:

1.	Get and build gcc 2.8.1 from the GNU archives at 
ftp://ai.prep.mit.edu.  You will also need some items from the 
binsutil package located at the same site.

2.	Purchase from HP the ANSI C and C++ developers kit.

If you go with gcc then in addition you will require either YACC 
or BISON on your system to build wu-ftpd.  BISON is available 
from the same place as gcc. I don't know where to get yacc for 
the HP-UX OS.  It may form part of the CDK.

If you are going to build many other packages you may as well 
obtain lex or flex while you are about it.  FLEX is available 
from the GNU repositories as well.

If you build your own tool kit you will suffer a significant 
delay in getting the final product (wu-ftpd) up and running, but 
you will learn what you need to build other packages for your 
system.

Regards,
Jim

---
James B. Byrne                Harte & Lyne Limited
vox: +1 905 561 1241          9 Brockley Drive
fax: +1 905 561 0757          Hamilton, Ontario
mailto:[email-masked]  Canada L8E 3C3