Subject: IBM (EBCDIC) to Unix (ASCII)

From: Steve Maraglia <[email-masked]>
Date: Mon, 13 Apr 1998 09:23:27 -0700

I'm using wu-ftp version 2.4 on Solaris 2.6

Are there any special considerations when an IBM mainframe
(client) put's and EBCDIC file to a Unix host (server).

The user is selecting ASCII mode before the "put" however
on a 860 byte record about 6-8 bytes, at random, are not
being translated into valid  ascii characters. The octel values
are outside the ascii character set.

The mainframe (client) is also getting a
"command not recognized" after all the data has
been transferred.

Any pointers would be appreciated!

Thanks for your time!!

Steve Maraglia
System/Network Engineer
MCI Telecommunications - State Government & University Markets
[email-masked]
work  800-288-2624  ext. 6240

---

From: Bill Campbell <[email-masked]>
Date: Mon, 13 Apr 1998 19:54:34 -0700

>(client) put's and EBCDIC file to a Unix host (server).

I would take the info direct from the mainframe in EBCDIC and do the
conversion on the Unix side with the ``dd'' command.

There are some characters in EBCDIC that are ambiguous which is why the
Unix ``dd'' command has multiple conversion options.

Bill
--
INTERNET:   [email-masked]  Bill Campbell; Celestial Systems, Inc.
UUCP:               camco!bill  PO Box 820; 2835 82nd Avenue S.E. S-100
FAX:            (206) 232-9186  Mercer Island, WA 98040-0820; (206) 236-1676
URL: http://www.celestial.com/