Subject: dir problem under solaris

From: ye <[email-masked]>
Date: Thu, 30 Apr 1998 11:37:03 +0800

Hello everyone!
    I installed a wu-ftpd (version 2.4(3)) under my solaris 2.51
 system. I have configured it so I can use anonymous to ftp it.
 When I ftp to it as a anonymous user,I can't list files in long
 format,I  type "dir" and "ls -l",and no result.
 anyone can help me with it? thanks!
 below is from the ftp command and the result.

   ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
pub
incoming
etc
lib
usr
dev
226 Transfer complete.
40 bytes received in 0.021 seconds (1.9 Kbytes/s)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.

---

From: Tatsuya Kawasaki <[email-masked]>
Date: Thu, 30 Apr 1998 13:13:07 +0900 (JST)

Hello Ye,
Two questions.

1. ls -al works on regular users?
2. which ls are you doing? 

FYI, I use one that came with Solaris 2.5 and works just fine.

regards,

Tatsuya

= = = = = =
電話 03-3239-0607 fax 03-3239-2609
business network telecom
http://www.giganet.net

---

From: Tatsuya Kawasaki <[email-masked]>
Date: Thu, 30 Apr 1998 15:09:32 +0900 (JST)

Ye,

Okay, can you show me the following

1. ls -al ~ftp/dev 
2. ls -al ~ftp/usr/lib

where ftp is the anonymous user.

regards,

tatsuya

= = = = = =

On Thu, 30 Apr 1998, ye wrote:

> Hello Tatsuya,
> thanks your email.
> the answers to your question.
> 1.yes,both ls -al  and dir works fine on regular users,both have long
> format result.
> 2.  /usr/bin/ls  ,and in my system, dir:    aliased to ls -alF|more
> 
> 
> 
> TK> Hello Ye,
> TK> Two questions.
> 
> TK> 1. ls -al works on regular users?
> TK> 2. which ls are you doing? 
> 
> TK> FYI, I use one that came with Solaris 2.5 and works just fine.
> 
> TK> regards,
> 
> TK> Tatsuya
> 
> 
> Best regards,
>  Ye                            mailto:[email-masked]
> 
>

---

From: ye <[email-masked]>
Date: Thu, 30 Apr 1998 15:52:59 +0800

Hello Tatsuya,

I have solved the problem!
The reason is that I didn't set the right permissions with ~ftp/dev
and ~ftp/usr/lib.After I set them to 555,it's ok!
I forget where  I get the I idea that permissions should be set to
770, that produced the problem!
Tatsuya,thank you very much for your advice.

TK> Ye,

TK> Okay, can you show me the following

TK> 1. ls -al ~ftp/dev 
TK> 2. ls -al ~ftp/usr/lib

TK> where ftp is the anonymous user.

TK> regards,

TK> tatsuya

---

From: ye <[email-masked]>
Date: Thu, 30 Apr 1998 12:34:26 +0800

Hello Tatsuya,
thanks your email.

TK> Hello Ye,
TK> Two questions.

TK> regards,

TK> Tatsuya

Best regards,