Subject: 500 Illegal Port Command

From: Juha Nevalainen <[email-masked]>
Date: Thu, 9 Apr 1998 08:02:59 +0000

Hi

I am having trouble issuing port against wu-ftpd (beta-15) when my client
is coming over socks firewall.  Here's a sample session:

rftp moomin
...
230 Guest login ok, access restrictions apply.
ftp> quote pasv
227 Entering Passive Mode (9,180,180,214,10,200)
ftp> quote port 0,0,0,0,7,28
500 Illegal PORT Command

This works against many other ftp servers, and would be very useful
for mirror.   Is there any way to overcome this problem, either from client
or server side?   Other than dropping socks or wu-ftpd of course!!

Cheers,
Juha
-------------------------------------------------------
EMEA Internet Centre of Competence
IBM UK Ltd, Hursley Park, SO21 2JN
[email-masked]
http://w3.hursley.ibm.com/inet
+44-1962-818026, fax -818191, tl 24-8026

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 9 Apr 1998 11:33:48 -0400 (EDT)

> is coming over socks firewall.  Here's a sample session:

wu-ftpd requires that the IP address in the PORT command exactly match the
IP address of the client machine.  Since you're using SOCKs, that'll be
the IP address of the proxy machine.

> or server side?   Other than dropping socks or wu-ftpd of course!!

For more information on why this is see the relavent CERT security
advisories at http://www.cert.org/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653