Subject: Small Incoming Anon files empty

From: "Gregory A. Parmer" <[email-masked]>
Date: Mon, 13 Apr 1998 10:54:15 -0500 (CDT)

Has anyone seen this before???

My entire ftp structure (/bin, /dev, /pub, /incoming, ...) is 
temporarily being mounted via NFS from a machine besides
the actual FTP server machine.  When a *small* (55k or less) incoming 
anon ftp file is placed in the /incoming directory it becomes empty and
I get an "NFS write error....yadiyadiyadi...Permission denied" message
in the message log (/var/adm/messages). From the client side all reports
are of a successful upload.
The transfer works fine if the file is 117k (or greater) or if I do not
use anonymous.

I'm going to be moving the filesystem back to the server, but
I'd like to know whether this is an OS problem, FTPD
problem, or another of my config problems.  I'm guessing it's
cache or timing related, but haven't been able to find the
culprit.

Some particulars:
NFS server and FTP server are running Solaris 2.5.
NFS server is SS1000 with Disksuite (concat/stripe) and 
 the FTP server is an LX.
The wu-ftpd was beta15 and is now beta16--same error.
User "root" and "ftp" were able to successfully copy 
 small (and large) files to the NFS mounted /incoming.
Shell for "ftp" has been tried as "/bin/sync",
 "/bin/false", and even as "/bin/csh".

The ftpaccess file contains
   upload /public/ftp /incoming yes guest other 0640 nodirs
   log commands anonymous
   log transfers real,anonymous inbound,outbound
as well as the usual stuff.

-greg

Greg Parmer
Network Engineer
Cooperative Extension & College of Ag
Auburn University, AL

---

From: "Gregory A. Parmer" <[email-masked]>
Date: Mon, 13 Apr 1998 11:25:26 -0500 (CDT)

'Tis in the FAQ under SunOS!....no reference
to why large files work, though.

Someone also offered that the filesystem could
be exported with root priveleges to the FTP server,
which hadn't worked here.

Thanks all,
-greg