Subject: RE: group and user change on files when uploaded

From: "Marxen, Sara" <[email-masked]>
Date: Thu, 9 Apr 1998 08:31:46 -0700

I should have been more specific, I need the group and user
permissions to be changed only when uploading to a particular 
directory outside of their home directory (they are allowed to 
upload to 2 seperate directories).  When they upload to 
their home dir they can keep their own user and group perms.
I was under the impression the upload clause only worked within 
a real users own home dir.  (as specified in the passwd file?)

> ----------
> From: 	Gregory A Lundberg[SMTP:[email-masked]]
> Sent: 	Thursday, April 09, 1998 10:29 AM
> To: 	Marxen, Sara
> Cc: 	[email-masked]'
> Subject: 	Re: group and user change on files when uploaded
> 
> On Wed, 8 Apr 1998, Marxen, Sara wrote:
> 
> > I am wondering if there is anyway to change the group and owner
> > of a file when it is uploaded into a directory using wu-ftpd?
> 
> Use the 'upload' clause in your ftpaccess file.
> 
> ----
> 
> Gregory A Lundberg		Senior Partner, VRnet Company
> 1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
> Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 9 Apr 1998 11:37:44 -0400 (EDT)

> a real users own home dir.  (as specified in the passwd file?)

Wrong impressions.  It's relative to the chroot'd root, which from what
you've said, doesn't appear to be the user's home directory.

Try using two or more upload clauses.  Look at the examples on the man
page for ftpaccess.

----