Subject: max number of characters in a filename

From: Jack Lampley <[email-masked]>
Date: Thu, 9 Apr 1998 09:53:31 -0700

One more try at getting an answer on this. I didn't get one reply. I have had files
rejected because the name was too long and the error is of a nature that it isn't
readily apparent what the problem is. If anyone knows or can point me to where I 
can find out I'd appreciate it. I've checked the FAQ and found nothing there or in
documentation.

Thanks,

Jack Lampley, System Administrator
Infrared Processing and Analysis Center (IPAC)
California Institute of Technology (CalTech)
MS 100/22, Pasadena, CA 91125

Telephone : 818-397-9551
Internet  : [email-masked]

Original message:

What is the maximum number of characters allowed in a file name before ftp
rejects upload? Can this be set higher and what are disadvantages of doing 
so, if any?

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 9 Apr 1998 13:33:11 -0400 (EDT)

> can find out I'd appreciate it. I've checked the FAQ and found nothing there or in

The source code is a good place to look.

> rejects upload? Can this be set higher and what are disadvantages of doing 

By my reading of the source code, I'd say the answer is "whatever your
operating system limit is", which is what I'd hoped.  On most Unix
systems, the answer is "pretty big" so I'd suggest looking for another
cause. 

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653