Subject: compile problem on Solaris 2.6

From: "Gamblin, Barry" <[email-masked]>
Date: Thu, 23 Apr 1998 16:23:52 -0600

I am trying to build wu-ftpd-2.4 on Solaris 2.6 with gcc.  This is
what I get.  I don't see anything about this in the FAQ. Any help
would be greatly appreciated

# ./build sol CC=gcc
make args are : 
make opts are :  CC=gcc

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:180: previous declaration of `realpath'
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c
vers.o -lsupport -lsocket -lnsl -lgen 
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c
vers.o -lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 7435 + 788 + 360 = 8583
Done
# 

  ________________/\__    Barry S. Gamblin, [email-masked]
 (_______________/__\_)   National Renewable Energy Laboratory
                /    \    1617 Cole Blvd., Golden CO 80401
  GO BRAVES!   /______\   303-275-4068 - voice 303-275-4119 - fax

---

From: "Michael Jamet" <[email-masked]>
Date: Fri, 24 Apr 1998 09:26:30 -0400

Barry,

If you look at ftpd.c and /usr/include/stdlib.h, you will see a slight (but
insignificant) difference in the realpath definitions.  Change ftpd.c to match
stdlib.h and you should be fine.

Michael (normally reachable at [email-masked])