Subject: Re: FTP outbound traffic logging

From: "Michael Lightfoot" <[email-masked]>
Date: Thu, 09 Apr 98 01:41:58 +1100

On Wed, 8 Apr 1998 12:48:18 +0100, Peter Chiu RAL SSD EODG Computer
Section wrote:

>Dear all,
>
>We have a requirement of recording all outbound
>ftp activities on our DEC Unix (V4.0) server.
>This is not implemented by the DEC Unix ftp client.
>
Typical!  ;-)

>Could someone enlightens me if wu-ftpd or any
>package includes a ftp client that records all the 
>ftp transfers initiated by users logged on the DEC 
>Unix server?
>
It certainly does.  I use it at my site to check that users aren't
downloading stuff they aren't supposed to (like /etc/passwd.)  There
are also freeware log processors which give you all sorts of useful
info from the logs.

 ** TagIt/2 v2.0 ** 
 
... LONG JUMPERS do it with a running start 

//------------------------------------------------------------------------
// michael
//===============================
// [email-masked]			[email-masked]
// http://www.canb.auug.org.au/~michal

---

From: Bill Wyatt <[email-masked]>
Date: Wed, 08 Apr 1998 12:00:00 -0400

[...]
> are also freeware log processors which give you all sorts of useful

Stuff that users aren't supposed to download should be blocked using
the NORETRIEVE line in the ftpaccess file.

Bill Wyatt ([email-masked])
    Smithsonian Astrophysical Observatory  (Cambridge, MA, USA)

---

From: Bob Luckin <[email-masked]>
Date: Wed, 8 Apr 98 11:46:41 CDT

> >ftp transfers initiated by users logged on the DEC 
Michael Lightfoot replied :-
> are also freeware log processors which give you all sorts of useful

There seems to be some confusion here - wu-ftpd is an FTP server, not a
client.  It does not include any FTP client software, let alone any that
does logging.

However, the wu-ftpd server does have the ability to log both outbound and
inbound transfers, at your choice.  So if you replace the DEC Unix server
with wu-ftpd, you should be able to get what you seem to be asking for.

If you really want your FTP _clients_ to log transfers, then I'm afraid you
need to look elsewhere...

Cheers, Bob
-- 
"On mega data disks, attempt FTP. An inapt FTP; met task's ID a tad. A gem, no?"
Bob Luckin      [email-masked]      [http://www.dhc.net/~luckin/palindromes.html]