Subject: RE: /bin/false as a shell

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Tue, 10 Mar 1998 09:23:17 -0800

/bin/false is in /etc/shells

> ----------
> From: 	Andreas Sindermann[SMTP:[email-masked]]
> Sent: 	Tuesday, March 10, 1998 9:17 AM
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	Re: /bin/false as a shell
> 
> Guy J. Speier writes:
>  > hello all,
>  > 
>  > I just upgraded to beta 16 (on AIX), but those users who's default
> shell
>  > is /bin/false may no longer ftp into the site.  They could with an
> older
>  > version of wu-ftp though!
>  > 
>  > Is this an 'enhancement', or did I forget something?  Is there a
> fix?
> 
> Check whether /bin/false is in /etc/shells.
> 
> Andreas
>

---

From: [email-masked] (Andy Church)
Date: Tue, 10 Mar 1998 12:32:17 EST

>I just upgraded to beta 16 (on AIX), but those users who's default shell
>is /bin/false may no longer ftp into the site.  They could with an older

     This may be obvious, but did you check /etc/shells to make sure
/bin/false is (or is still) listed there?

  --Andy Church                  | If Bell Atlantic really is the heart
    [email-masked]       | of communication, then it desperately
    www.dragonfire.net/~achurch/ | needs a quadruple bypass.

---

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Tue, 10 Mar 1998 09:46:13 -0800

well ...
	yes, /bin/false is in /etc/shells
	but here is the kicker:
	/usr/bin/false is ALSO in /etc/shells
	and seems to work fine as the default login shell.
	AND YES< they have the same perms!

	NOTE: diff /usr/bin/false /etc/shells
	produces null output

	any further advice?

---

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Tue, 10 Mar 1998 12:26:12 -0800

this was the fix!
thank you all very much!

> ----------
> From: 	Rusty Allen[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Tuesday, March 10, 1998 11:26 AM
> To: 	[email-masked]
> AIX!! Check "shells=" in /etc/security/login.cfg
> 
> 
> Your message dated: Tue, 10 Mar 1998 09:03:55 PST
> >Is this an 'enhancement', or did I forget something?  Is there a fix?
> 
> 
> ----
> M.R. Allen  (Rusty)           My comments are my own, not my
> company's.
>        Western Geophysical -  A division of Western Atlas
> International
> Internet Email: [email-masked]  VOICE: 713-963-2756 Fax:
> 713-963-2758
> 
>