Subject: Compilaton on Sol.2.5.1_x86

From: Artur Shnayder <[email-masked]>
Date: Mon, 02 Mar 1998 13:48:00 +0200

Hi,
 I'm trying to compile wu-ftpd-2.4.2-beta-16 on Solaris 2.5.1_x86 and
get the following error message:

Making ftpd.
cc -g -I.. -I../support -L../support  -c  ftpd.c
"/usr/ucbinclude/sys/file.h", line 119: macro L_INCR redefines previous
macro at "./config.h", line 22
"ftpd.c", line 1575:  (in preprocessor if): syntax error
"ftpd.c", line 1963:  (in preprocessor if): syntax error
"ftpd.c", line 2207:  (in preprocessor if): syntax error
"ftpd.c", line 2338:  (in preprocessor if): syntax error
cc: preprocessor failed for ftpd.c
*** Error code 2
make: Fatal error: Command failed for target `ftpd.o'

 On Sparc platform it passed ok.

 Any idea.

 Thanks in advance.

--

--

Artur Shnayder -- System Administrator
---------------------------------------
Voice:  972-3-9348482 ext. 219
Fax:    972-3-9348489
mailto: [email-masked]
URL:    http://www.compugen.co.il

---

From: [email-masked]
Date: Mon, 2 Mar 1998 13:13:43 +0100 (MET)

> From: Artur Shnayder <[email-masked]>
> Subject: Compilaton on Sol.2.5.1_x86
> 

Trying to buil/compile an other software on a HP-UX machine I have 
seen a similar effect. I ended in using GNU sed instead the hosts 
operating systems sed, then it worked okay.

It may not be the same with your problem, but it may be worth to 
have a look there.

Have a nice day
Michael

-- 
Michael Schmidt                    [email-masked]
                    SAMBA Admin
Server fuer / Server for  MS + Win95 + WinNT + LANManager
              Fachhochschule Koblenz