Subject: Re: xferlog inbound only

From: "Stig Isaksson" <[email-masked]>
Date: Wed, 11 Mar 1998 09:44:18 GMT+200

Hi Harshal,

Thanks for your note.

This is what I have by way of logging directives in my ftpaccess:

log commands anonymous
log commands guest
log commands real 
log transfers anonymous inbound, outbound
log transfers guest inbound, outbound
log transfers real inbound, outbound

I tried earlier to have all three types on the same line but that 
only took care of the first type. I mean, if I had something like

log transfers  real,guest,anonymous  inbound,outbound

I got logging only for real, not for guest and anonymous. What I'm 
talking about now isn't xferlog but the logins logs.

I wonder, is there some kind of conflict between the xferlog logging 
and the other logs? Anyhow, the log directives as they stand in my 
ftpaccess now does not give any outbound logging in xferlog.

Best Regards,
Stig

> I am facing  similar type of problem.  I had sent a mail on this
> yesterday itself.  But nobody replied to it!
> 
> Check  your  ftpaccess  file  and look  for the  directive  "log
> transfers".  I think it will be something like this
> 
> log transfers  real,guest,anonymous,ftp  inbound
> 
> as in your case it is logging only  incoming  transfers.  I have
> experienced  that  until you  specify  this  directive  for both
> inbound and outbound  there is no effect of command line options
> "-i" and "-o". So modify it as below :
> 
> log transfers  real,guest,anonymous,ftp  inbound,outbound
> 
> I don't know whether this is a correct  solution, but atleast it
> works for me.  Please let me know after you solve your problem.

------------------------------------------------------------
Stig Isaksson
Dialekt- och ortnamnsarkivet
Helgonabacken 14
S-223 62 LUND
S W E D E N
tel.: +46 46 222 74 68   fax: +46 46 15 23 81
e-mail: [email-masked]
http://www.dal.lu.se/

<Forstaor MIME    Understands MIME>
------------------------------------------------------------

---

From: Harshal Savalia <[email-masked]>
Date: Wed, 11 Mar 1998 14:27:41 +0500 (IST)

Hi Stig,

	OK, it seems that problem is in your directive itself.
	I think there should not be space between inbound and
	outbound keyword.

> log transfers anonymous inbound, outbound
				~~~~
  Try instead this
  log transfers anonymous inbound,outbound

> log transfers guest inbound, outbound
			    ~~~~
> log transfers real inbound, outbound
			   ~~~~

	Let me know your reply.

Regards,
Harshal

-- 
-------------------------------------------------------------------------------
Harshal Savalia					email : [email-masked]
Hewlett Packard - ISO				Phone : (91)(80)2251554 x 1424
30C, Cunningham Road				Fax   : (91)(80)2200196
Bangalore 560 052				Telnet: 847-1424
India.
-------------------------------------------------------------------------------