Subject: wu-ftpd not chrooting

From: Todd Freese <[email-masked]>
Date: 26 Mar 98 08:44:47 +0000

I just setup wu-ftpd running on IRIX 6.2. Everything is working except for the
chroot. Real users can cd up past the ftp root area. Anonymous users are getting
chroot correctly. Any ideas here? 
Here is the /etc/passwd entry:
engineer:mypasswd:115:100:FWC Eng FTP Acct:/var/ftpdir/./:/bin/true

Here is the ~ftp/etc/passwd entry:
engineer:*:115:100:FWC Eng FTP Acct::

Here is my ftpaccess file:
class   all   real,anonymous  *

limit   all   10   Any              /etc/msgs/msg.dead

message /welcome.msg            login
message .message                cwd=*

compress        no             local remote
tar             no             local remote

log commands real,anonymous
log transfers anonymous,real inbound,outbound

shutdown /etc/msg/welcome.msg

Todd Freese

---

From: Gregory A Lundberg <[email-masked]>
Date: Thu, 26 Mar 1998 10:06:51 -0500 (EST)

> chroot correctly. Any ideas here? 

Read the guest howto ...

The location of the latest version of wu-ftpd can be found in the 
directory
 
      ftp://ftp.academ.com/pub/wu-ftpd/private/
 
You can't see the directory contents, so read the message informing you
of the actual filename to retrieve. It's there.
 
wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd FAQ:              http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653