Subject: RE: problem with guest users

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Thu, 19 Mar 1998 16:55:52 -0800

I've tried this recomended advice, but to no avail!
Do you have any other advice?

> ----------
> From: 	Koos van den Hout _U nix and we
> all_[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Thursday, March 19, 1998 12:48 PM
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	Re: problem with guest users
> 
> Quoting Speier, Guy J - CNF, who wrote :
> 
> > 	ftp> ls   
> > 	425 Can't open passive connection: No such file or directory.
> 
> The chrooted environment for the guest users needs several device
> files.
> Look in the man page of the Solaris ftpd to see which (look for the
> files
> needed in the anonymous area).
> 
> > 	200 PORT command successful.
> > 	425 Can't create data socket (0.0.0.0,20): No such file or
> > directory.
> 
> This and others in the faq for wu-ftpd at
> 
> http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
> 
>                                                  Koos
> 
> -- 
> It'd be real easy to complete half the job of writing a M$ admin
> manual;
> just make all the odd-numbered steps "reboot the system".  Coming up
> with
> the even-numbered ones would be the only tedious part.
>                                              - Anthony DeBoer in a.s.r
>

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Sat, 21 Mar 1998 20:52:32 +0100 (MET)

> Do you have any other advice?

Next step is attaching with truss or gdb to see which open fails with no
such file or directory. Look in the man pages for truss and/or gdb.

And start looking where in the code passive connections are opened and
how.

> > > 	425 Can't create data socket (0.0.0.0,20): No such file or

This error has it's own special chapter in the wu-ftpd-faq.

                                       Koos

-- 
It'd be real easy to complete half the job of writing a M$ admin manual;
just make all the odd-numbered steps "reboot the system".  Coming up with
the even-numbered ones would be the only tedious part.
                                             - Anthony DeBoer in a.s.r