Subject: problem with guest users

From: "Speier, Guy J - CNF" <[email-masked]>
Date: Thu, 19 Mar 1998 11:52:37 -0800

hello all!

	I recently compiled beta 16 on sol 2.5.0,
	and everything works well except for 2 things:

	1st the major problem:
	1) guest users can log in, but trying to do an
	ls (in any directory) produces the following result:

	230 User username logged in.  Access restrictions apply.
	ftp> ls   
	425 Can't open passive connection: No such file or directory.
	200 PORT command successful.
	425 Can't create data socket (0.0.0.0,20): No such file or
directory.
	ftp> 

	could anybody offer some assistance

	now the minor one:
	2) times are all incorrect (and also are for central, not
pacific time, as I need).

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Thu, 19 Mar 1998 21:48:56 +0100 (MET)

> 	425 Can't open passive connection: No such file or directory.

The chrooted environment for the guest users needs several device files.
Look in the man page of the Solaris ftpd to see which (look for the files
needed in the anonymous area).

> 	425 Can't create data socket (0.0.0.0,20): No such file or

This and others in the faq for wu-ftpd at

http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html

                                                 Koos

-- 
It'd be real easy to complete half the job of writing a M$ admin manual;
just make all the odd-numbered steps "reboot the system".  Coming up with
the even-numbered ones would be the only tedious part.
                                             - Anthony DeBoer in a.s.r