Subject: beta 16 build errors/warnings on RedHat 5.0

From: "Chris J. Magnuson" <[email-masked]>
Date: Mon, 23 Mar 1998 15:17:42 -0700

I got an error during the link of of ftpd, I must be missing some
command-lin library?  I did a ./build lnx to start this.

gcc -O6 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../
support -s -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o
exte
nsions.o realpath.o acl.o private.o authenticate.o conversions.o hostacc.o
sigfi
x.o -lsupport
ftpd.o: In function `pass':
ftpd.o(.text+0x156e): undefined reference to `crypt'
private.o: In function `priv_gpass':
private.o(.text+0x385): undefined reference to `crypt'
make: *** [ftpd] Error 1

I also got build warnings when trying to compile on Linux 5.0, is this
normal? There are others, just thought I'd mention these for now (these
same ones occur multiple times).

Making ftpshut.
gcc -O6 -fomit-frame-pointer -fno-strength-reduce -pipe -I.. -I../support
-L../
support -s -o ftpshut ftpshut.c vers.o -lsupport
In file included from ftpshut.c:48:
/usr/include/sys/param.h:29: warning: `NBBY' redefined
config.h:13: warning: this is the location of the previous definition
/usr/include/sys/param.h:35: warning: `NCARGS' redefined
config.h:49: warning: this is the location of the previous definition

Thanks,
Chris

---

From: Theo Van Dinter <[email-masked]>
Date: Tue, 24 Mar 1998 22:42:04 -0500 (EST)

On Mon, 23 Mar 1998, Chris J. Magnuson wrote:

| I got an error during the link of of ftpd, I must be missing some
| command-lin library?  I did a ./build lnx to start this.
| 
[snip]
| private.o(.text+0x385): undefined reference to `crypt'
| make: *** [ftpd] Error 1

Redhat 5.0 uses glibc instead of linux libc.  glibc has a libcrypt instead of
having it inside the C library, so you have to add a '-lcrypt' to the config.

-- 
Randomly Generated Tagline:
Gunpowder and alcohol DO mix - but it tastes awful!