Subject: preventing directories from being made

From: Timothy J Luoma <[email-masked]>
Date: Mon, 9 Feb 98 16:51:42 -0500

I have an incoming directory:

drwxrwxrwt   2 root     nogroup      1024 Feb  9 16:49 ~ftp/pub/incoming/

Is there any way to prevent *any* directories from being made in it?

Thanks

TjL

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Mon, 9 Feb 1998 23:37:58 +0100 (MET)

> drwxrwxrwt   2 root     nogroup      1024 Feb  9 16:49 ~ftp/pub/incoming/

That one is readable for other ftp visitors so they can see what others
leave there. It's better if they can't like :

# ls -lad incoming 
drwx-wx-wt   2 root     69           1024 Dec 12 12:04 incoming/

> Is there any way to prevent *any* directories from being made in it?

upload  /ftp/ftp        /pub/incoming   yes     root    daemon  0600 nodirs

ownership to something else then ftp/ftp, not readable for ftp clients and
the 'nodirs' keyword.

Sofar, this setup has kept my ftp site clean.

                                         Koos

-- 
Life sucks. And I am [email-masked]

---

From: Timothy J Luoma <[email-masked]>
Date: Mon, 9 Feb 98 17:58:11 -0500

Thank you, that worked perfectly.

I keep forgetting there's a separate manpage for 'ftpaccess'... my apologies  
for not RTFM

TjL

---

From: Michael Brennen <[email-masked]>
Date: Mon, 9 Feb 1998 18:58:11 -0600 (CST)

The 'upload' directory allows you to specify nodirs.

   -- Michael