Subject: Compile Help on IRIX

From: Todd Freese <[email-masked]>
Date: 03 Feb 98 09:03:55 +0000

I am trying to compile wu-ftpd on IRIX 6.2. I have tried the Makefiles posted in the archives and I get the following errors when I "build sgi":

build sgi
make args are : make opts are : 
Linking Makefiles.
May not unlink existing Makefile  - Error 0
config/config.sgi and config.h are identical
makefiles/Makefile.sgi and Makefile are identical

Making support library.
        rm -f libsupport.a
        ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strsep.o authuser.o
        touch libsupport.a

Making ftpd.
        cc -O -DDEBUG -I.. -I../support -L../support -c ftpd.c
cfe: Warning 581: /usr/include/stdarg.h:134: Macro va_start redefined.
cfe: Warning 581: /usr/include/stdarg.h:141: Macro _VA_ALIGN redefined.
cfe: Warning 581: /usr/include/stdarg.h:147: Macro __va_stack_arg redefined.
cfe: Warning 609: ftpd.c: 2021: The number of arguments in the macro invocation does not match the definition
cfe: Warning 609: ftpd.c: 2072: The number of arguments in the macro invocation does not match the definition
cfe: Warning 609: ftpd.c: 2699: The number of arguments in the macro invocation does not match the definition
cfe: Error: ftpd.c, line 2021: Syntax Error
     (ap = ((char *)& + sizeof())) ;
 ------------------------------^
cfe: Error: ftpd.c, line 2072: Syntax Error
     (ap = ((char *)& + sizeof())) ;
 ------------------------------^
cfe: Error: ftpd.c, line 2699: Syntax Error
     (ap = ((char *)& + sizeof())) ;
 ------------------------------^
*** Error code 1 (bu21)

Making ftpcount.
        cc -O -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport
ld: FATAL 9: I/O error (vers.o): No such file or directory
*** Error code 1 (bu21)

Making ftpshut.
        cc -O -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport
ld: FATAL 9: I/O error (vers.o): No such file or directory
*** Error code 1 (bu21)

Making ckconfig.
`ckconfig' is up to date.
../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 
        Section              Size        Physical        Virtual
                                         Address         Address

             .interp          19         4194612         4194612               .MIPS.options          96         4194632         4194632                    .reginfo          24         4194728         4194728                    .dynamic         248         4194752         4194752                    .liblist          20         4195000         4195000                     .dynstr         305         4195020         4195020                       .hash         408         4195328         4195328                     .dynsym         576         4195736         4195736                .MIPS.symlib          36         4196312         4196312                       .msym         288         4196348         4196348                 .MIPS.stubs         100         4196636         4196636                       .text        1408         4196736         4196736                       .init          32         4198144         4198144                     .rodata        1376        268439552      !
 268439552                       .got          68        268440928       268440928                       .bss          12        268440996       268440996       3560 + 1444 + 12 = 5016
Done

Any ideas? Also, I will be using wu-ftpd with the Firewall Toolkit. Is there anything I should know in advance of setting this up?

Todd Freese

---

From: Mark Bergstrom <[email-masked]>
Date: Wed, 18 Feb 1998 22:16:34 -0600 (CST)

>I am trying to compile wu-ftpd on IRIX 6.2. I have tried the Makefiles
posted >in the archives and I get the following errors when I "build sgi":

>cfe: Warning 609: ftpd.c: 2021: The number of arguments in the macro
invocation >does not match the definition
>cfe: Warning 609: ftpd.c: 2072: The number of arguments in the macro
invocation >does not match the definition
>cfe: Warning 609: ftpd.c: 2699: The number of arguments in the macro
invocation >does not match the definition
>.....[rest cut out]...
>Any ideas? Also, I will be using wu-ftpd with the Firewall Toolkit. Is
there >anything I should know in advance of setting this up?
>Todd Freese

_______
The difference is in the header files. Your wu is expecting the variable
argument of varargs.h version. The one on your path is probably the
stdlib.h version.

If you want to work with what you have, check for nested includes. My bet
would be you need to fix syslog.h and stdlib.h to get your version to make.

Even if you get through that, the realpath declaration problem will crop up.
______

That being said just by way of explanation, it sounds as if you have a very
old 2.4.2 release that does not have all these fixes.

You should at the very least begin with 2.4.2-academ[BETA-16] to minimize
your time spent.
______
After that you will need to build a static 'ls' for the anonymous and
guestgroups to behave correctly.  For that you first need to install the
speclibs for non-shared benchmarking.  Then from the fileutils source code
(GNU) set the makefiles with -non_shared in CFLAGS and LDFLAGS wherever they
appear.

Mark Bergstrom

_________________________________________________
UNIX TEAM--The spirit behind the dreams