Subject: Anon ftp upload problem

From: Hero Idema <[email-masked]>
Date: Thu, 26 Feb 1998 14:47:20 +0100

Hello,

I have wu-ftpd 2.4.2 beta 16 running on Sun Solaris 2.5.1.
I set up the anonymous ftp directory with script. Now I want to
let people upload to the /pub/incoming dir (/home/ftp/pub/incoming).
It works fine. But when people create dir (they are allowed to), they
can't upload files into that dir, but can create other dirs. Very weird.

these are the upload rules I have in my ftpaccess file:

upload /home/ftp * no
upload /home/ftp /pub/incoming yes ftp ftp 0777 dirs

the ftp user and group do exist in both (even in when chrooted)

Can someone tell me why people can't upload to dirs they have
created in the incoming dir?

ftp clients give this error:

553 autoexec.bat: Permission denied. (Upload)

dir permissions are:

drwxrwxrwx   3 root     other        512 Feb 26 13:30 incoming

and when I create a subdir with my ftp client in the incoming dir (as
anonymous)

drwxr-xr-x   2 ftp      ftp          512 Feb 26 13:30 test

Regards,
Hero Idema

 Hero Idema                       Syntegra Internet Services              
 [email-masked]              http://www.syntegra.nl                  
 +31-(0)79-3682370                [email-masked]

---

From: "Stig Isaksson" <[email-masked]>
Date: Thu, 26 Feb 1998 17:25:51 GMT+200

Hi,

Couldn't that be controlled by the upload line in ftpaccess?

I.e. something like
 
upload /.../.../ftp /pub/incoming yes root sys 0600

being changed to something like

upload /.../.../ftp /pub/incoming yes root sys 0770

or something?

Just a shot in the dark (almost).

Best Regards,
Stig

>  +31-(0)79-3682370                [email-masked]                       

------------------------------------------------------------
Stig Isaksson
Dialekt- och ortnamnsarkivet
Helgonabacken 14
S-223 62 LUND
S W E D E N
tel.: +46 46 222 74 68   fax: +46 46 15 23 81
e-mail: [email-masked]
http://www.dal.lu.se/

<Forstaor MIME    Understands MIME>
------------------------------------------------------------