Subject: User still capable to cruise around

From: [email-masked]
Date: Thu, 26 Feb 1998 13:47:57 +0100

Well, still my user can access every directory, when he logs in comes:
      
     > pwd
      "/var/ftp" is current directory.
     
     and not for example
     
     ftp> pwd
     257 "/" is current directory.
     ftp>
     
     I have tried following:
     
     >Are you sure you didn't forget something like "guestgroup <name of 
     >group>"
     >in the ftpaccess file ????
     
     YES, my ftpaccess - file is here:
     
     class   ftpquest   guest,anonymous  *
     class   ftponly    real
     
     guestgroup ftponly
     limit   ftponly     10    Any
     loginfails    2
     private no
     email  [email-masked]

     #readme  README*    login
     #readme  README*    cwd=*
     log commands quest,real,anonymous
     log transfers quest,real,anonymous
     
     #message /welcome.msg            login
     #message .message                cwd=*
     
     compress       no 
     tar           no 
     chmod  no  quest,real,anonymous
     umask  no  quest,real,anonymous
     
     path-filter quest /etc/ms.path ^[-A-Za-z0-9._]*$ ^\. ^-
     path-filter anonymous /etc/ms.path ^[-A-Za-z0-9._]*$ ^\ ^-

     >exists the homedir with all rights for this user ?
     
     YES 
     
     drwxr-xr-x      6 ftpuser       ftponly 1024 Feb 13 12:30 ftp
     
     OR should it be owned by root ?
     
     HELP, Please......
     
     BR,  Jouni

---

From: [email-masked] (M. Schmidt)
Date: Thu, 26 Feb 1998 14:08:46 +0100 (MET)

> From: [email-masked]
> Subject: User still capable to cruise around
>      

Hi,

I'm still new to this list and am trying to understand the configuration 

>      class   ftpquest   guest,anonymous  *

Isn't there a typo right above, written ftpquest instead of ftpguest, 
which can cause the problems??

Interested in feedback.

Have a nice day
Michael

-- 
Michael Schmidt                    [email-masked]
                    SAMBA Admin
Server fuer / Server for  MS + Win95 + WinNT + LANManager
              Fachhochschule Koblenz