Subject: guest dir creation

From: [email-masked]
Date: Fri, 13 Feb 98 16:37:53 -0500

Hello,

I am using Version wu-2.4(1) of wu-ftpd on a digital
unix machine. I have several guest users setup and an
anonymous area also. Here is an entry in the ftpaccess 
file:

upload  /ftp /incoming/test yes root prd 0660 nodirs

The documentation indicates that the upload lines only
pertain to anonymous users. When a guest user tries to
create a directory in test, this error appears:

530 foo: Permission denied.  (Upload)

The directory test has group write for the guest users.
When I change the upload line from "nodirs" to "dirs",
it works fine. My question is, why can't the guest users
create directories (if the upload line only pertains to
anonymous users)?

Thanks,

Bob Morse
System Administrator
American Mathematical Society

---

From: Michael Brennen <[email-masked]>
Date: Fri, 13 Feb 1998 16:16:29 -0600 (CST)

You should get the latest beta and go over the guest howto carefully; 
that, the FAQ and other resources should get you going.

   -- Michael

> anonymous area also. Here is an entry in the ftpaccess 

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-16.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.