Subject: AW: CA-97.16: ftpd Signal Handling Vulnerability

From: Dirk Rudloff <[email-masked]>
Date: Tue, 24 Feb 1998 16:22:07 +0100

Thanks, but my more important desire was, to get some more information
concerning the basics.
In CA-97.16 there is written:

2.  Impact

    Regular and anonymous users may be able to access arbitrary files
with
    root privileges.  Depending on the configuration, this may allow
    anonymous, as well as regular, users to read or write to arbitrary
    files on the server with root privileges.

I just want to know, when does it happen and under what conditions the
vulnerability could be involved.

In CA-97.16 there is written:

Information involving this vulnerability has been made publicly
available.

My question: where?
Thanks 
Dirk.

>----------
>Von: 	Gregory A Lundberg[SMTP:[email-masked]]
>Gesendet: 	Dienstag, 24. Februar 1998 15:56
>An: 	Dirk Rudloff
>Cc: 	[email-masked]'
>Betreff: 	Re: CA-97.16: ftpd Signal Handling Vulnerability 
>
>You should have READ the advisory instead of just the subject ...
>
>From the body of it I see:
>
>wu-ftpd Academ beta version===========================
>    The current version of wu-ftpd (Academ beta version), wu-ftpd
>    2.4.2-beta-12, does not contain the vulnerability described in this
>    advisory.  Sites using earlier versions should upgrade to the current
>    version immediately.  At the time of writing, the current version can
>    be retrieved from:        ftp://ftp.academ.com/pub/wu-ftpd/private/
>
>On Tue, 24 Feb 1998, Dirk Rudloff wrote:
>
>> Date: Tue, 24 Feb 1998 15:33:27 +0100
>> From: Dirk Rudloff <[email-masked]>
>> To: "[email-masked]'" <[email-masked]>
>> Subject: CA-97.16: ftpd Signal Handling Vulnerability 
>> 
>> hello all,
>> I've just looked at the CA-97.16: ftpd Signal Handling Vulnerability and
>> I'm concerned what this security lack is about and wether it is fixed in
>> wu-ftpd.
>> Is there anyone who can provide me some more information about this
>> security lack and the solution?
>> Thanks
>> Dirk. 
>> 
>
>
>----
>
>Gregory A Lundberg		Senior Partner, VRnet Company
>1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
>Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653
>
>

---

From: Gregory A Lundberg <[email-masked]>
Date: Tue, 24 Feb 1998 10:38:52 -0500 (EST)

> Information involving this vulnerability has been made publicly

I dunno and CERT won't tell you.  Information of this sort is usually
discussed in the appropriate usenet news groups and mailing lists.  I
follow bugtraq for this sort of stuff but I'm sure there are others.

----