Subject: static ls build disaster

From: "Stig Isaksson" <[email-masked]>
Date: Fri, 27 Feb 1998 16:14:26 GMT+200

Good afternoon,

I run wu-ftpd on Sun Solaris 2.5.1.

I tried to build a static ls command for my anonymous login, so I 
tried to follow Darci L. Chapmans excellent Solaris 2.5.x. 
How-To(http://wildheart.org/wu-ftpd/wuftpd.shtml). He states there: 

Get a hold of Emil Isberg's patch; save it (for example) in 
/usr/local/src as fileutils-3.13_static-ls.patch 
Get a hold of the gnu 
file utilities (version 3.13 only) and place it (for example) in 
/usr/local/src 
>From /usr/local/src: gunzip fileutils-3.13.tar.gz 
tar xf fileutils-3.13.tar 
cd fileutils-3.13 
./configure 
cd .. 
patch <fileutils-3.13_static-ls.patch 
cd fileutils-3.13 
make ls 
Copy "ls" to your ~ftp/bin directory and there you have it! 

Yes, there he had it. I didn't. After the configure routine was run I
copied an ls file to the directory where I have the utilities. But I
never got as far as to the make ls part. Here follows a printout of my
session with Emil Isberg's patch script:

# patch <fileutils-3.13_static-ls.patch
  Looks like a new-style context diff.
File to patch: ls
Hunk #1 failed at line 68.
Hunk #2 failed at line 87.
Hunk #3 failed at line 136.
3 out of 3 hunks failed: saving rejects to ls.rej
  The next patch looks like a new-style context diff.
Malformed patch at line 293:
patch: Line must begin with '+ ', '  ', or '! '.
# 
Evidently I misunderstood something. I am not an experienced UNIX
user. I am sure this is a simple question to most of you. Anybody
please help.

Best Regards,
Stig

------------------------------------------------------------
Stig Isaksson
Dialekt- och ortnamnsarkivet
Helgonabacken 14
S-223 62 LUND
S W E D E N
tel.: +46 46 222 74 68   fax: +46 46 15 23 81
e-mail: [email-masked]
http://www.dal.lu.se/

<Forstaor MIME    Understands MIME>
------------------------------------------------------------

---

From: Emil Isberg <[email-masked]>
Date: Fri, 27 Feb 1998 16:47:51 +0100 (MET)

On Fri, 27 Feb 1998, Stig Isaksson wrote:
<cut>
>  Looks like a new-style context diff.
<cut>
>   The next patch looks like a new-style context diff.
<cut>
>user. I am sure this is a simple question to most of you. Anybody
<cut>

No I don't think you misunderstood anything ..
I will need to upgrade that patch.

Hmm .. It could be that the patch needs GNU patch (I got version 2.1) ..
And the diff was made with GNU diff (version 2. something) ..

Please follow up how it goes..

-- 
/Emil
Running on overtime.