Subject: Re: Guest account for local user ??

From: [email-masked] (Andy Church)
Date: Tue, 10 Feb 1998 21:32:28 EST

>Here's the start of /etc/ftpaccess
>
>class   mccc   	anonymous,real	*.mccc.edu 198.133.170.*
>class	nonmccc	anonymous,real	*
>
>
>I have staff members who use our ftp server from on campus
>and -- by IP address -- are members of the "mccc" class.
>When they dial in through our terminal server, they are
>members of the "mccc" class. But if they use an outside ISP
>and ftp from a "foreign" IP address, they become "nonmccc".
[...]
>"Guest" is not for them as it would wreak havoc on their
>normal shell logins -- or have I misread something?

     Guest access shouldn't interfere with anything else (like shells).
The only changes it requires are inserting a "/./" at the appropriate point
in the home directory path where the user should be chrooted to and (if
necessary) changing the group number in /etc/passwd to a group which
includes all and only the users to grant guest access to.  Then add the
line "guestgroup <groupname>" to /etc/ftpaccess and they will be given
guest access (you'll probably want to define a class for them too).  More
detailed info is in the guest HOWTO:

http://www.landfield.com/wu-ftpd/guest-howto.html

  --Andy Church                  | If Bell Atlantic really is the heart
    [email-masked]       | of communication, then it desperately
    www.dragonfire.net/~achurch/ | needs a quadruple bypass.

---

From: Pete Holsberg <[email-masked]>
Date: Tue, 10 Feb 1998 22:02:34 -0500 (EST)

On Tue, 10 Feb 1998, Andy Church wrote:

>      Guest access shouldn't interfere with anything else
> (like shells). The only changes it requires are inserting
> a "/./" at the appropriate point in the home directory
> path where the user should be chrooted to and (if
> necessary) changing the group number in /etc/passwd to a
> group which includes all and only the users to grant
> guest access to.  Then add the line "guestgroup
> <groupname>" to /etc/ftpaccess and they will be given
> guest access (you'll probably want to define a class for
> them too).  More detailed info is in the guest HOWTO:

Can I have multiple groupnames in guestgroup?

Thanks,
Pete

---

From: Michael Brennen <[email-masked]>
Date: Tue, 10 Feb 1998 23:41:49 -0600 (CST)

Yes, space separated.

guestgroup  group1 group2 ... groupn

   -- Michael

---

From: Pete Holsberg <[email-masked]>
Date: Wed, 11 Feb 1998 12:46:36 -0500 (EST)

> them too).  More detailed info is in the guest HOWTO:

But the how-to says that the shell has to be
"/etc/ftponly". Or can it be any valid shell?

Thanks,
Pete

---

From: Michael Brennen <[email-masked]>
Date: Wed, 11 Feb 1998 12:03:23 -0600 (CST)

The howto does not say that it has to be /etc/ftponly, but it also is
not clear because that is the only example I gave.  In general, for
FTP purposes, you can put anything you want as the shell in
/etc/passwd, as long as that string is in /etc/shells. 

   -- Michael

---

From: Pete Holsberg <[email-masked]>
Date: Wed, 11 Feb 1998 13:07:09 -0500 (EST)

On Wed, 11 Feb 1998, Michael Brennen wrote:

> The howto does not say that it has to be /etc/ftponly,
> but it also is not clear because that is the only example
> I gave.  In general, for FTP purposes, you can put
> anything you want as the shell in

Thanks. 

Pete