Subject: Want username instead of [unknown] in banner

From: Geir Johannessen <[email-masked]>
Date: Fri, 27 Feb 1998 16:41:23 +0100 (MET)

Among other things my banner says this:

 Welcome %U from %R.

This translates into

220- Welcome [unknown] from storm.stud.ntnu.no.

Just below this it says

220 storm.stud.ntnu.no FTP server (Version wu-2.4.2.b14-GJ) ready.
Name (ftp:joge): 

So ftpd know I am called joge, but still says [unknown] in the banner.

The [unknown] in banner comes from msg_massage() in extensions.c and look
like this:

case 'U':
  if (pw)
    strcpy(outptr, pw->pw_name);
  else
    strcpy(outptr, "[unknown]");
  break;

This obviously sets %U to [unknown] since pw has not been initialized
yet. But still ftpd know my username since it displays it just below.

The problem is that I just cannot find the source file where the message

Name (ftp:joge):

comes from. My best guess is this line in ftpd.c:

    for (;;)
        (void) yyparse();

What is this line doing?

Are there any way for me to have the banner say 'joge' instead of [unknown]?

--
Geir Johannessen          #  [email-masked]
E B Schieldropsvei 35-25  #  http://www.stud.ntnu.no/~joge/
N-7033 TRONDHEIM, NORWAY  #  Tlf private +47-73888989, job +47-73598048
"Time is an illusion, lunchtime doubly so."

---

From: Emil Isberg <[email-masked]>
Date: Fri, 27 Feb 1998 17:14:20 +0100 (MET)

>220 storm.stud.ntnu.no FTP server (Version wu-2.4.2.b14-GJ) ready.

This is lines from the ftpd ..

>Name (ftp:joge): 

This is a line from the ftp (the client) ..
It needs a username to supply to the USER command ..

This is a line from the ftpd ..

>Are there any way for me to have the banner say 'joge' instead of [unknown]?

No not really .. not with the ftpd source anyway ..

-- 
/Emil
Running on overtime.

---

From: Koos van den Hout _U nix and we all_ <[email-masked]>
Date: Fri, 27 Feb 1998 17:29:50 +0100 (MET)

> No not really .. not with the ftpd source anyway ..

Install identd on storm.stud.ntnu.no :)

                                          Koos

-- 
A Security Clearance level of Confidential is assumed on all email
correspondence. Please deal accordingly.

---

From: Bernhard Rosenkraenzer <[email-masked]>
Date: Fri, 27 Feb 1998 17:13:11 +0100 (CET)

> So ftpd know I am called joge, but still says [unknown] in the banner.

ftpd *doesn't* know you're called joge.
It's a matter of your ftp client.

The standard ftp clients on almost every type of unix OS give your
username as default at the login prompt, without the server program being
aware of anything.

The only way to get rid of the [unknown] would be to add ident lookups,
and that wouldn't work for everyone (Windoze based systems don't have
ident at all, on most Unices it's optional, and it's blocked by some
firewalls).

LLaP
bero

-- [email-masked] - ICQ/UIN 6545964 - http://www.star-trek.ml.org/ --

"Nobody will ever need more than 640k RAM!"
                           -- Bill Gates, 1981
"Windows 95 needs at least 8 MB RAM."
                           -- Bill Gates, 1996
"Nobody will ever need Windows 95."
                           -- logical conclusion