Subject: Help ! - can't get guest users to chroot

From: Bob Whitehouse <[email-masked]>
Date: Sun, 15 Feb 1998 19:06:22 -0000

I've read "guesthowto" and set up everything "by the book", but my guest
users are getting logged in to the root directory (I guess chroot is
failing).

I am running wu-ftpd v2.4(1), compiled from source on a DEC Alpha with Gcc
on Digital Unix 4.0
(I used all default options to build and install).

I want all my guest users to share a common root, so my password entries
look like;

jdoe:*:123:23:John Doe:/usr/guests/./jdoe:/etc/ftponly

my etc/group has entry

ftpguests::23:jdoe,...

I have set up bin and etc dirs under /usr/guests, and copied all relevant
files thereto.

I know that my guests are being seen as such by ftpd because it gives the
message;
(access restrictions apply) after login.

Any ideas ?

---

From: Bob Whitehouse <[email-masked]>
Date: Fri, 20 Feb 1998 07:45:53 -0000

The problem is now fixed. It turned out to be my lack of experience with
Digital Unix. Apparently, one has to type "mkpasswd" after editing the
password file.

Bob

----------
> From: Michael Brennen <[email-masked]>
> To: Bob Whitehouse <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Help ! - can't get guest users to chroot
> Date: Sunday, February 15, 1998 11:21
> 
> 
> Get the latest beta in any case; you're running an old buggy version. 
> See if it still fails to chroot; if so, let us know. 
> 
>    -- Michael
> 
> On Sun, 15 Feb 1998, Bob Whitehouse wrote:
> 
> > I am running wu-ftpd v2.4(1), compiled from source on a DEC Alpha
> > with Gcc on Digital Unix 4.0 (I used all default options to build
> > and install). 
> 
> This is the location for the latest wu-ftpd.  You can't see the
> directory contents, but get the file anyway.  It's there.
> 
> ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-16.tar.Z
> 
> wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
>               OR
>               send mail to [email-masked]
>               with a subject line: send faq
> 
> guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
>               OR
>               send mail to "[email-masked]"
>               (immediate autoresponder; subject does not matter)
> 
> wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
> wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
> 
> There are additional security references in the above docs.