Subject: beta 16 problems on Solaris

From: Shelley A Waltz <[email-masked]>
Date: Thu, 08 Jan 1998 13:41:49 -0500

I just installed beta 16 on Solaris2.5.  I have a couple of problems.

1) inetd.conf
wuftp   stream  tcp     nowait  root    /usr/etc/sbin/wu.ftpd   wu-ftpd -al

In testing wu-ftpd, the above line in inetd.conf does not allow
any options to be specified, in fact if any options are specified,
when tring to connect, the server reports 
"421 Service not available, remote server has closed connection"
If I remove all options, it does work, but I cannot use the ftpaccess
file since I cannot specify -a.

If I change the line to read 
wuftp   stream  tcp     nowait  root    /usr/etc/sbin/wu.ftpd -al
it does work, however, now I have problem 2)

2) Command and and file transfer logging.
I used LOG_LOCAL5 in the config.sol file when compiling and specified
USE_VAR so xfer logging will go to /var/adm/xferlog.  I checked this
after compiling with ckconfig.  I added# anonymous ftpd logging
#
local5.info                     /var/adm/xferlog
local5.notice                   /var/adm/xferlog
local5.debug                    /var/adm/xferlog
to syslog.conf.

I also have in my ftpaccess file
log commands anonymous,real
log transfers anonymous inbound

In testing, no logging whatsoever goes to /var/adm/xferlog.
Only DELE command is logged in /var/adm/messages, not xferlog.

Am I missing something.  Yes, I did restart inetd and syslog, even rebooted
after the changes.

TIA
shelley

---

From: [email-masked] (Josef Siemes)
Date: Thu, 8 Jan 1998 22:09:22 +0100 (NFT)

There was a fix for this posted end december to the list.
The options weren't correctly parsed, and the server coredumped. 

Subject: Re: beta-16 dies with single parm.
Date: Mon, 29 Dec 1997

See the list archives at http://www.landfield.com/wu-ftpd/

> I just installed beta 16 on Solaris2.5.  I have a couple of problems.
[..]
> "421 Service not available, remote server has closed connection"

Josef Siemes,
[email-masked]