Subject: Problems with guest login

From: "Brian Christensen" <[email-masked]>
Date: Tue, 27 Jan 1998 15:20:48 -0700

I have set up a guest group for sysops that need access to a certain directory on our server. I have set it up so they are chrooted to the directory they need access to. When they log in, the chroot functions properly, but they aren't able to execute any commands. Everything they try returns the message "425 Can't create data socket (0.0.0.0,20): No such file or directory."

I have searched through all the documentation I can find and I haven't found a solution for this problem.

Can somebody point me in the right direction?

Thanks

---

From: Michael Brennen <[email-masked]>
Date: Tue, 27 Jan 1998 16:43:06 -0600 (CST)

Covered at the foot of the guest howto, probably the FAQ also.  The
list archives will also give an answer. 

   -- Michael

On Tue, 27 Jan 1998, Brian Christensen wrote:

> I have set up a guest group for sysops that need access to a certain
> directory on our server. I have set it up so they are chrooted to
> the directory they need access to. When they log in, the chroot
> functions properly, but they aren't able to execute any commands.
> Everything they try returns the message "425 Can't create data
> socket (0.0.0.0,20): No such file or directory." 

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-16.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.