Subject: Re: guest groups

From: Allen Walker <[email-masked]>
Date: Thu, 22 Jan 1998 13:40:57 -0600 (CST)

Ok I found the problem. I am setting the shell for the guest users as
"/bin/ftponly", a shell script as follows:

#!/bin/sh
#
#ftponly shell
#
#allows users to login only to ftp and if they telnet to
#the server allows only a passwd change
#
echo " "
echo "You are not allowed to login interactively."
echo "You may, however, change your password."
echo " "
/usr/bin/passwd

When I remove this and use a standard shell like 'bash' it allows users to
login fine. This script used to work on the BSDI system, but for
some reason it's causing problems on the linux machine. 

To reinterate: When I have this set as the user shell, the user cannot
login at all thru ftp, it will say invalid login. Telnet works fine and
the script runs as expected.

Thanks for any help
-allen-

---
Allen Walker               |            University of Texas at Austin
<[email-masked]>    |   http://www.cs.utexas.edu/users/awalker

---

From: [email-masked] (Andy Church)
Date: Thu, 22 Jan 1998 15:41:42 EST

>"/bin/ftponly", a shell script as follows:
[...]
>the script runs as expected.

     Sounds like you didn't put /bin/ftponly in /etc/shells.  (BTW, I'd
recommend using a C program instead of a shell script for the FTP-only
"shell", because a shell script can introduce all sorts of loopholes.)

  --Andy Church                  | If Bell Atlantic really is the heart
    [email-masked]       | of communication, then it desperately
    www.dragonfire.net/~achurch/ | needs a quadruple bypass.