Subject: ftp exploits

From: "Maria L. Giamboi" <[email-masked]>
Date: Thu, 08 Jan 1998 20:50:45 -0500

While testing wu-ftpd-2.4.2-beta-16 I came across a very recent exploit
associated with wu-ftpd at www.rootshell.com. If go there and search for
ftp there are several exploits listed, the most recent date 1/8/98. I
attempted to run that one and it didn't appear to do anything. Are there
patches or ways to protect against these types of exploits?

Maria

---

From: David Greenman <[email-masked]>
Date: Thu, 08 Jan 1998 19:38:29 -0800

>patches or ways to protect against these types of exploits?

   The one with the date of 1/8/98 tries to take advantage of the SIGURG
signal related bug that I discovered about a year ago. I know this one was
fixed (I think in beta-15, but I'm not sure about that).

-DG

David Greenman
Core-team/Principal Architect, The FreeBSD Project

---

From: "Gregory A. Parmer" <[email-masked]>
Date: Sat, 10 Jan 1998 08:36:58 -0600 (CST)

ftp> user
(username) xfer
530 User xfer access denied.
Login failed.
 
Does wu-ftpd deny access to real accounts under uid 100?

Both anon and real ftp are working fine, but this particular
account used only for administrative transfers fails.
The account is setup up with a shell of "/bin/true" as described in the
FAQ. The only thing odd I see is that the uid is one of typical
admin accounts ( <100).

It never asks for a passwd, which is why I suspected a shell 
or uid problem. Any ideas?

TIA,
-greg

---

From: Hermann Heimhardt <[email-masked]>
Date: Sun, 11 Jan 1998 14:07:13 +0100

> Does wu-ftpd deny access to real accounts under uid 100?
Nope.
> FAQ. The only thing odd I see is that the uid is one of typical
Do you have /bin/true listed as a valid shell in /etc/shells ?

cheers

hh
-- 
[email-masked]    HH937-RIPE   http://www.scn.de/~hermann (PGP key available)
Hermann Heimhardt           Siemens Business Services Internet Administration
Van Roy's Law:          An unbreakable toy is useful for breaking other toys.

---

From: "Gregory A. Parmer" <[email-masked]>
Date: Sun, 11 Jan 1998 10:21:31 -0600 (CST)

> Do you have /bin/true listed as a valid shell in /etc/shells ?

Thanks to Jim Davis also.

I misread the FAQ. Duh.

-greg