Subject: Guest Acct Problems

From: "Eduardo B. Fonseca" <[email-masked]>
Date: Tue, 13 Jan 98 20:45:22 -0300

Dear list,

I *really* need some help... Lemme explain... I'm own an ISP here... and 
I used to run Windows NT on the FTP server... everything was nice, users 
uploading their HomePages nicely, and such. But, I'm installing FreeBSD 
on all machines on the network, because UNIX is a much better Network OS 
than NT. And when I was installing the system, a friend of mine 
recommended wu-ftpd, because of it's "Guest Accounts possibilities" (like 
on my old NT system). But, I'm trying to set it up for a week... with no 
success... I've read all faqs, docs, notes... everything about it. No 
success. Even Michael Brennen does not know what the error could be. So I 
ask you, if you are running wu-ftpd with FreeBSD, please, send me an 
e-mail asap. I really need this working until Friday... thanks a lot.

Here is my configuration files...

Thanks.

<SNIP>

/etc/ftpaccess:

loginfails 2

class   local   real,guest,anonymous *.domain 200.250.12.0
class   remote  real,guest,anonymous *

limit   local   20  Any                 /etc/msgs/msg.toomany
limit   remote  100 SaSu|Any1800-0600   /etc/msgs/msg.toomany
limit   remote  60  Any                 /etc/msgs/msg.toomany

banner /etc/banner

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote
# allow use of private file for SITE GROUP and SITE GPASS?
private         no

# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  warn

log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg

# all the following default to "yes" for everybody
delete          no      anonymous         # delete permission?
overwrite       no      anonymous         # overwrite permission?
rename                  no              anonymous                       # 
renam$
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

# specify the upload directory information
upload  /var/ftp  *             no
upload  /var/ftp  /incoming     yes     root    daemon  0600 dirs
upload  /var/ftp  /bin          no
upload  /var/ftp  /etc          no

# directory aliases...  [note, the ":" is not required]
alias   inc:    /incoming

# cdpath
cdpath  /incoming
cdpath  /pub
cdpath  /

# path-filter...
path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

# specify which group of users will be treated as "guests".
guestgroup users

email [email-masked]

<snip>

/etc/passwd: line 32
dudu:*:1005:1109:Dudu:/home/dudu/./:/etc/ftponly 

<snip>

/etc/shells

# List of acceptable shells for chpass(1).
# Ftpd will not allow users to connect who are not using
# one of these shells.

/bin/sh
/bin/csh
/usr/local/bin/bash
/etc/ftponly
/etc/ftpno

<snip>
ls -l /home/dudu

-rw-r--r--  1 dudu  users    466 Jan  4 23:56 .cshrc
-r--------  1 root  daemon     0 Jan  5 00:36 .forward
-rw-r--r--  1 dudu  users    619 Jan  4 23:56 .login
-rw-r--r--  1 dudu  users    290 Jan  4 23:56 .mailrc
-rw-r--r--  1 dudu  users   1203 Jan  4 23:56 .profile
-r--------  1 root  daemon   257 Jan  5 00:36 .rhosts
d--x--x--x  2 root  daemon   512 Jan  5 00:40 bin
d--x--x--x  2 root  daemon   512 Jan  5 00:40 etc
drwxr-xr-x  2 root  users    512 Jan  5 00:41 pub

NOTE: every file listed on the guest-HOWTO is installed 
(ls/passwd/group...)

<snip>

LOG OF THE FTP SESSION:

bash# ftp ftp.fnn.net

220 vanessa.fnn.net FTP server (Version wu-2.4.2-academ[BETA-16](1) Mon 
Jan 5 02
:29:31 EDT 1998) ready.
Name (ftp.fnn.net:root): dudu
331 Password required for dudu.
Password:
550 Can't set guest privileges.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

<snip>

that's it... I hope I didn't miss anything.

Cheers,

____________________________________................
Eduardo Brasao da Fonseca
Technical Director
.........................
The FutureNet Network
www.fnn.net
.........................
[email-masked]
[email-masked]
____________________________________................

---

From: Michael Brennen <[email-masked]>
Date: Tue, 13 Jan 1998 17:15:20 -0600 (CST)

One thing that I thought of yesterday (based on a different problem) 
is that the /home/dudu directory itself must have the low order bit
set for each class of user that needs to access it.  That is,
/home/dudu should be owned by account 'dudu' and group ID 1109
(users), and it should have permissions of something like 0755.  If
permissions are 0644, the chroot and/or chdir will fail. 

   -- Michael

---

From: Allen Walker <[email-masked]>
Date: Tue, 13 Jan 1998 18:03:09 -0600 (CST)

anonymous access works fine. However individual users I set as guests that
chroots to their dir only isn't working. For some reason it's still saying
incorrect password upon login.
in the ~user/etc dir, I have a passwd and group file, but I put the actual
encrypted passwd instead of the '*' you have in your guest howto.

Thanks for any help
-allen-

---
Allen Walker               |            University of Texas at Austin
<[email-masked]>    |   http://www.cs.utexas.edu/users/awalker