Subject: ls problem

From: Massimo Vulpiani <[email-masked]>
Date: Wed, 28 Jan 1998 14:23:49 +0100

Hello,

I downloaded the package (not the source code) of wu-ftpd (2) 
and I installed it on  Solaris 2.5.1,  
I would like to use it with standard users (not anonymous),
this is what happen:

# ftp juliet
Connected to juliet.
220 juliet FTP server (Version wu-2.4(2) Mon Jun 2 12:37:12 EDT 1997) ready.
Name (juliet:root): testftp
331 Password required for testftp.
Password:
230 User testftp logged in.  Access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pwd257 "/testftp" is current directory.
ftp> ls 
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.
ftp> 

Someone can help me ?

Thank you in advance

Massimo Vulpiani

        _____        Massimo Vulpiani
       /    /\       Senior Security Engineer
      /____/  \      Atel Spa
     /    /\   \     Via Caldera, 21 D/3
    /____/  \   \    20153 Milano - Italy
    \    \  /\  /    Phone : +39.2.452701
     \____\/\/\/     Fax   : +39.2.45270299
      \____\/\/      E-mail: [email-masked]
       \____\/       http://<http://www.atel.it/>www.atel.it

---

From: Michael Brennen <[email-masked]>
Date: Wed, 28 Jan 1998 09:18:48 -0600 (CST)

> 220 juliet FTP server (Version wu-2.4(2) Mon Jun 2 12:37:12 EDT 1997) ready.

Questa versione e' gia' vecchissima e contiene bachi e buchi. :) 
Dovresti prendere la beta 16 sotto sia per la funzionalita' che per i
miglioramenti di sicurezza.  Va distribuito solo la sorgente, quindi
dovrai compilarlo te stesso. 

> 425 Can't create data socket (0.0.0.0,20): Bad file number.

Questo si trova in ambedue il FAQ e il guest howto, anche gli archivi.

In bocca al lupo,

   -- Michael

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-16.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Tatsuya Kawasaki <[email-masked]>
Date: Thu, 29 Jan 1998 08:46:29 +0900 (JST)

hello Massimo,

Okay... question
1. so testftp is a real person in /etc/passwd, right?
2. do you put anything on that user directory shown in /etc/passwd
	i.e. ././ or something like that?
  if you do, you MUST put ls command in ~yourname/bin 
  but Solaris ls is "dynamically linked" so it does not work.

When I tried to put my stuff, I checked FAQ, it had special instructions 
for solaris 2.5.x, check it out, if you can not find it, see if I can 
dig it and forward it to you.

thnx
tatsuya

$B$$$D$b$*@$OC$K$J$C$F$*$j$^$9(B $B$+$o$5$-(B@ giganet$B$G$9!#(B

$B$+$o$5$-(B

= = = = = =
$BEEOC(B 03-3239-0607 fax 03-3239-2609
business network telecom
http://www.giganet.net