Subject: 'guestgroup' not work. Please help me.

From: "S.Kajino/梶野晋 " <[email-masked]>
Date: Thu, 29 Jan 1998 14:31:03 +0900

Hello, I'm one of admins of our local domain.

We used 'guestgroup' function of wu-ftpd.
It worked propery untill wu-ftp-2.4.2-beta13 version.
But from the version beta14, it can't work.

Tested follows.
	wu-ftpd-2.4.2-beta13....OK
	wu-ftpd-2.4.2-beta14....NG
	wu-ftpd-2.4.2-beta15....NG
	wu-ftpd-2.4.2-beta16....NG
(Same configuration; exchanged the daemon only.)

Our tested environment is follows:
	1. Sun ULTRA-1 Solaris 2.5.1. 
	2. Sun SS20    SunOS 4.1.4.

Are there any change about configuration from beta14?

Are there HELP?

Yours sincerely.                             S.Kajino.
////////////////////////////////////////////////////////////////
   NEC informatec systems Co.,ltd.           TEL 044-812-8418
   Network SI Div., 2nd SI Dept.                   (S.Kajino)
   [email-masked]         [email-masked]

---

From: Michael Brennen <[email-masked]>
Date: Wed, 28 Jan 1998 23:52:38 -0600 (CST)

What are the specific errors?

   -- Michael

---

From: "S.Kajino/梶野晋 " <[email-masked]>
Date: Thu, 29 Jan 1998 15:05:11 +0900

>>In Article <[email-masked]>
>	Michael Brennen writes:

>What are the specific errors?

Sorry.
The problem with guestgroups is can't chroot.

Perhaps like this.....
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
81 siaew3 kajino> ftp lsisv1
Connected to lsisv1.
220 lsisv1 FTP server (Version wu-2.4.2-lsi[BETA-15](1) Wed Jan 28 17:32:48 JST1998) ready.
Name (lsisv1:kajino): kaji
331 Password required for kaji.
Password:
230 User kaji logged in.
ftp> pwd
257 "/home/kaji" is current directory.
ftp>
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
(beta-13, it works properly.)

---

From: Michael Brennen <[email-masked]>
Date: Thu, 29 Jan 1998 00:30:02 -0600 (CST)

> The problem with guestgroups is can't chroot.
                                          ^^^^^^^^^^^

You are running beta 15 -- I thought you said earlier you were running
13 and 14. I don't know of any outstanding chroot problems with 15; I
for one had no trouble with the transition between 13, 14, and 15.

> 257 "/home/kaji" is current directory.

Have you gone over the guest howto carefully?  I don't mean to
belittle the problem, but it sounds like something is not set up
correctly.

   -- Michael

---

From: "S.Kajino/梶野晋 " <[email-masked]>
Date: Thu, 29 Jan 1998 15:33:31 +0900

>>In Article <[email-masked]>
>	Michael Brennen writes:

>belittle the problem, but it sounds like something is not set up

Thanks a lot.
I check it from now.