Subject: ls problem

From: Alan Halachmi <[email-masked]>
Date: Tue, 20 Jan 1998 09:19:55 -0600 (CST)

I'm running solaris 2.6 (x86) and ls won't work.  I don't get the socket
0,0,0 error.... When I try to ftp in and ls and from the outside it says:
intern:~> ftp montgomerybell.com
Connected to montgomerybell.com.
220 Argus FTP server (Version wu-2.4.2-academ[BETA-13](1) Sun Jul 6 18:35:50 CDT 1997) ready.
Name (montgomerybell.com:halacha):
331 Password required for halacha.
Password:
230-Please read the file README
230-  it was last modified on Wed Aug  6 22:32:03 1997 - 167 days ago
230 User halacha logged in.  Access restrictions apply.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> quit
221 Goodbye.

However, from the inside:
Connected to localhost.
220 Argus FTP server (Version wu-2.4.2-academ[BETA-13](1) Sun Jul 6 18:35:50 CDT 1997) ready.
Name (localhost:halacha): halacha
331 Password required for halacha.
Password:
230-Please read the file README
230-  it was last modified on Wed Aug  6 22:32:03 1997 - 167 days ago
230 User halacha logged in.  Access restrictions apply.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
.profile
.login
.cshrc
.pla
mail
.addressbook.lu
etc
usr
web
dev
bin
226 Transfer complete.
776 bytes received in 0.08 seconds (12.03 Kbytes/s)
ftp> quit
221 Goodbye.

Ideas?

I don't see anything in /etc/ftpaccess regarding local as opposed to
remote.

Alan

Alan Halachmi, Head of Internet Services| UNIX and Networking Consultant
Solaris Administrator/ Web Design       | Ingram Entertainment &
Montgomery Bell Academy                 |       SpeedServe, Inc.
mailto:[email-masked]       | mailto:[email-masked]
http://www.montgomerybell.com           | http://www.speedserve.com

---

From: Dave Wreski <[email-masked]>
Date: Tue, 20 Jan 1998 12:05:32 -0500 (EST)

> 0,0,0 error.... When I try to ftp in and ls and from the outside it says:

[ls is broken from outside, but works from within the local network]

> I don't see anything in /etc/ftpaccess regarding local as opposed to

I'm inclined to think you have your user account set up wrong here.  Be
sure your allowing him access to the ~ftp/usr/lib directory, and the real
/etc/password represents the proper path.

If it happens for all users, this is almost definately your problem.
Consider using the DAEMON facility from syslog to gather more information
on what's happening here.

Dave