Subject: Re: beta 16 problems on Solaris

From: [email-masked] (William L. Sebok)
Date: Thu, 8 Jan 1998 13:59:52 -0500 (EST)

> I just installed beta 16 on Solaris2.5.  I have a couple of problems.
> 
> 1) inetd.conf
> wuftp   stream  tcp     nowait  root    /usr/etc/sbin/wu.ftpd   wu-ftpd -al
> 
> In testing wu-ftpd, the above line in inetd.conf does not allow
> any options to be specified, in fact if any options are specified,
> when tring to connect, the server reports 
> "421 Service not available, remote server has closed connection"
> If I remove all options, it does work, but I cannot use the ftpaccess
> file since I cannot specify -a.

My inetd.conf (Solaris 2.5) is

ftp     stream  tcp     nowait  root    /usr/Local/etc/ftpd     ftpd -l -a

and it works fine.  I am still using beta 15 in case that makes any difference.
The main thing I note about your inetd.conf is that the first entry is wuftp
rather than ftp.  Have you defined wuftp to be something in /etc/services?  Is
there still also an entry for "ftp" (rather than "wuftp") in inetd.conf
pointing to the normal Sun ftp daemon in /usr/sbin/in.ftpd?  If that is the
case maybe you are having a conflict between wu-ftpd and the Sun ftpd.

Bill Sebok      Computer Software Manager, Univ. of Maryland, Astronomy
	Internet: [email-masked]	URL: http://www.astro.umd.edu/~wls/

---

From: "Green, William" <[email-masked]>
Date: Thu, 8 Jan 1998 11:03:24 -0800

I had similar problems with beta 15 on Sun 4.1.
The options were not picked up correctly.
I hard coded the options in the c code and it works great.

> -----Original Message-----
> From:	Shelley A Waltz [SMTP:[email-masked]]
> Sent:	Thursday, January 08, 1998 10:42 AM
> To:	[email-masked]
> Subject:	beta 16 problems on Solaris
> 
> any options to be specified,
>  
> TIA
> shelley
> 
>