Subject: Re: getting <foobar>.gz files

From: Keith Warno <[email-masked]>
Date: Wed, 10 Dec 1997 22:14:28 -0500 (EST)

> # OK, I just realized now that real ftp users can get <yadda>.gz and
> # <yadda>.tar files with no problem.  However, anonymous users cannot get
> # <yadda>.gz and <yadda>.tar files.  They always get zero-length files.  In
> # my ftpaccess file I have the lines:
> # 
> # 	compress yes *
> # 	tar yes *
> 
> Try 
> 
> compress        yes             local remote
> tar             yes             local remote
> 
> instead of the *.
> 
> # Anyone know why anonymous users can't tar and gzip files on the fly with
> # wu-ftpd 2.4.2-[BETA 15]?  Thanks.
> 
> -- 
> Kent Landfield                        Phone: 1-817-545-2502             
> Email: [email-masked]             http://www.landfield.com/
> Email: [email-masked]                   http://www.nfr.net/
> Please send comp.sources.misc related mail to [email-masked]
> Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/
> 

Thanks for the advice, but that didn't work either.  This one has really
got me stumped.  I tried reverting back to the default, distributed
configuration (default ftpaccess, etc), and the same deal: real users can
tar/gzip on the fly, but anonymous users cannot.  Perhaps this is a bug in
2.4.2 BETA-15?  If not, please let me know otherwise and the search will
continue for the solution.

Keith Warno
-----
Please send all personal replies to [email-masked].
Otherwise, the mail you send may be returned to you.

---

From: Kent Landfield <[email-masked]>
Date: Wed, 10 Dec 1997 21:31:53 -0600 (CST)

# Thanks for the advice, but that didn't work either.  This one has really
# got me stumped.  I tried reverting back to the default, distributed
# configuration (default ftpaccess, etc), and the same deal: real users can
# tar/gzip on the fly, but anonymous users cannot.  Perhaps this is a bug in
# 2.4.2 BETA-15?  If not, please let me know otherwise and the search will
# continue for the solution.

It is not a bug in BETA-15. I use it and it works here.  Here is my production copy.  

#
# ftpconversions:
#
#     strip     |    addon     |
# prefix:postfix:prefix:postfix:external command:types:options:description
#
 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/gtar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/gtar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS :   : :.tar.gz:/bin/gtar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
 :   : :.tgz:/bin/gtar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

---

From: [email-masked] (Perry Rovers)
Date: 11 Dec 1997 19:27:18 GMT

Pink elephants with an attitude inspired Kent Landfield <[email-masked]> to tell garfield.mail.wu-ftpd:
: # Thanks for the advice, but that didn't work either.  This one has really
: # got me stumped.  I tried reverting back to the default, distributed
: # configuration (default ftpaccess, etc), and the same deal: real users can
: # tar/gzip on the fly, but anonymous users cannot.  Perhaps this is a bug in
: # 2.4.2 BETA-15?  If not, please let me know otherwise and the search will
: # continue for the solution.

: It is not a bug in BETA-15. I use it and it works here.  Here is my production copy.  
: #
:  :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
:  :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS

I have put the programs in ~ftp/bin/ftp-exec/ and linked them from there to
~ftp/bin. AFAIK some stuff needs to be in the ftp-exec directory. Could be
OS-dependent since it's been over a year that I needed to figure this out :)

-- 
Perry Rovers ([email-masked])