Subject: Re: beta-16 dies with single parm.

From: "Andreas Kerber" <[email-masked]>
Date: 29 Dec 97 19:45:43 +0200

>command-line arguments.  You might try re-testing after changing SPT_TYPE
>from SPT_REUSEARGV to SPT_NONE.  This should disable the feature.  If it
>works, we've at least narrowed down the problem.

I've just tested this but unfortunlately the problem still occurs.

Andreas

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 29 Dec 1997 15:08:21 -0500 (EST)

> I've just tested this but unfortunlately the problem still occurs.

The problem in the initialization is being performed _after_ the function
it's initializing.  The following patch should correct the situation,
apply it against 2.4.2 beta 15 clean sources.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653

----

*** ftpd.c.orig	Mon Dec 29 15:04:03 1997
--- ftpd.c	Mon Dec 29 15:04:36 1997
***************
*** 717,722 ****
--- 717,725 ----
              syslog(LOG_ERR, "ioctl SIOCSPGRP: %m");
      }
  #endif
+ 
+     initsetproctitle(argc, argv, envp);
+ 
      dolog(&his_addr);
      /* Set up default state */
      data = -1;
***************
*** 726,733 ****
      mode = MODE_S;
      tmpline[0] = '\0';
      yyerrorcalled = 0;
- 
-     initsetproctitle(argc, argv, envp);
  
  #ifdef HAVE_SYSINFO
      sysinfo(SI_HOSTNAME, hostname, sizeof (hostname));
--- 729,734 ----

---

From: Gregory A Lundberg <[email-masked]>
Date: Mon, 29 Dec 1997 15:19:08 -0500 (EST)

Oops.  that's again beta 16 clean sources.  While we're at it, we're not
sendmail.

----

----

--- ftpd.c	Mon Dec 29 15:16:36 1997
*** 727,734 ****
      tmpline[0] = '\0';
      yyerrorcalled = 0;
  
  #else
--- 730,735 ----
***************
*** 3786,3792 ****
  	p = buf;
  
  	/* print sendmail: heading for grep */
! 	(void) strcpy(p, "sendmail: ");
  	p += strlen(p);
  
  	/* print the argument string */
--- 3787,3793 ----
  	p = buf;
  
  	/* print sendmail: heading for grep */
! 	(void) strcpy(p, "wu-ftpd: ");
  	p += strlen(p);
  
  	/* print the argument string */