Subject: Build install ERROR

From: [email-masked]
Date: Thu, 11 Dec 1997 12:07:16 -0500

I took your advice and did "pkgrm WU-ftpd" so I could download the source
code instead of using someone else's compiled version and "build sol" went
OK, but I'm have problems with "build install". See errors below & my
"pathnames.h" file:

adams:root> build install
make args are :
make opts are :
mv -f /usr/local/etc/ftpd /usr/local/etc/ftpd-old
mv: cannot access /usr/local/etc/ftpd
*** Error code 2 (ignored)
Installing binaries.
install -o bin -g bin -m 755 bin/ftpd /usr/local/etc/ftpd
usage: install [options] file [dir1 ...]
*** Error code 2
make: Fatal error: Command failed for target `install'
adams:root>

pathnames.h file:
#define _PATH_FTPUSERS  "/etc/ftpusers"
#define _PATH_FTPACCESS "/usr/local/etc/ftpaccess"
#define _PATH_EXECPATH  "/bin/ftp-exec"
#define _PATH_PIDNAMES  "/usr/local/daemon/ftpd/ftp.pids-%s"
#define _PATH_CVT       "/usr/local/etc/ftpconversions"
#define _PATH_XFERLOG   "/usr/adm/ftplog"
#define _PATH_PRIVATE   "/etc/ftpgroups"

#ifndef _PATH_UTMP
#define _PATH_UTMP      "/etc/utmp"
#define _PATH_WTMP      "/usr/adm/wtmp"
#define _PATH_LASTLOG   "/usr/adm/lastlog"
#endif

#define _PATH_BSHELL    "/bin/sh"
#define _PATH_DEVNULL   "/dev/null"

#ifdef  HOST_ACCESS
#define _PATH_FTPHOSTS  "/usr/local/etc/ftphosts"
#endif

---

From: [email-masked] (William L. Sebok)
Date: Thu, 11 Dec 1997 13:54:18 -0500 (EST)

> usage: install [options] file [dir1 ...]

It sounds like it is using /usr/sbin/install rather than the correct
/usr/ucb/install.  Looking at my source: wu-ftpd-2.4.2-beta-15 does this
correctly (i.e. I didn't have to hack on the makefiles in this case).  What
version are you trying to compile?

Bill Sebok      Computer Software Manager, Univ. of Maryland, Astronomy
	Internet: [email-masked]	URL: http://www.astro.umd.edu/~wls/