Subject: Re: Not logging information

From: Kent Landfield <[email-masked]>
Date: Wed, 10 Dec 1997 10:23:30 -0600 (CST)

# I am not logging ftp information to /var/adm/ftplog. Below are my
# associated entries for each file:

# /etc/syslog.conf
# #
# # Added to deal with logging from wu-ftpd
# #
# local5.debug         /var/adm/ftplog

# Do I need to modify the source code to see these changes, or am I missing
# something? TIA.

Check src/config.h and see what you have set as the FACILITY.  syslog()
will log to that facility.  By default it is set to LOG_DAEMON.

(Also make sure there are tabs separating the two columns in syslog.conf
file. Otherwise the entry will be silently ignored.)

-- 
Kent Landfield                        Phone: 1-817-545-2502             
Email: [email-masked]             http://www.landfield.com/
Email: [email-masked]                   http://www.nfr.net/
Please send comp.sources.misc related mail to [email-masked]
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/

---

From: Don Cox <[email-masked]>
Date: Wed, 10 Dec 1997 13:53:33 -0500

> file. Otherwise the entry will be silently ignored.)

Once again, I owe Kent a big "Thank You". Below are the steps that I took with
explanations.
(I am posting to the list rather than replying to those who e-mailed my
individually.)

I needed to:

1) Do a ./build clean from ~wuftpd_home_directory
2) Modify ~wuftpd_home_directory/src/config/config.sol from:
        #define FACILITY LOG_DAEMON
   to
        #define FACILITY LOG_LOCAL5
3) Do a ./build sol
4) Copy the newly generated ~wuftpd_home_directory/src/ftpd
   binary to /usr/sbin/in.ftpd, chown and chgrp to bin.bin.
5) Send a HUP signal to the inetd daemon (probably wasn't necessary)

As stated in the syslog.conf man pages, local0-7 are for local use.  We
picked local5 out of the air
since it was not assigned to any other function (FACILITY). We could have left
config.sol as it was
and change syslog.conf to be:
        daemon.debug            /var/adm/ftplog
but this would have logged information other than ftp stuff to
/var/adm/ftplog.

Note that in the config.sol file it has to be defined in CAPS, but in the
syslog.conf
file it has to be lower case.

Thanks again Kent, you've been a tremendous help.