Subject: Re: Threaded (was Warez)

From: Dave Jevans <[email-masked]>
Date: Wed, 3 Dec 1997 09:55:43 -0800 (PST)

>Well, before multi-thread, having a stand alone version should

Yes.

>I looked into the code lately, the configuration
>files are read for every command.  For a stand-alone server,
>the configuration can be loaded into the memory at startup.

Hmmm.  I thought someone did a patch for this already?
We did this in FileDrive and it improves performance *dramatically*.
Watch out though, if the config files change, be sure
to reread them before forking.

DJ
David Jevans, President
Differential Inc.  -  Software For Extranet Business Communities
[email-masked]
(408) 864-0603
www.differential.com       

  * Try FileDrive EX: Commerce-grade FTP Server And Client Software *

---

From: Kent Landfield <[email-masked]>
Date: Wed, 3 Dec 1997 13:25:18 -0600 (CST)

# >I looked into the code lately, the configuration
# >files are read for every command.  For a stand-alone server,
# >the configuration can be loaded into the memory at startup.
# 
# Hmmm.  I thought someone did a patch for this already?

Done. Take a look a 

http://sunsite.doc.ic.ac.uk/packages/mirror/experimental/wu-2.4.2-upd13.shar

Lee McLoughlin ([email-masked]) has made some nice changes that should be
a part of the baselined wu-ftpd.

-- 
Kent Landfield                        Phone: 1-817-545-2502             
Email: [email-masked]             http://www.landfield.com/
Email: [email-masked]                   http://www.nfr.net/
Please send comp.sources.misc related mail to [email-masked]
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/