Subject: Re: LDAP, comments welcome

From: "Arnaud Ruch" <[email-masked]>
Date: Mon, 8 Dec 1997 17:21:24 +0100

I had a look at this last days. Here is what I began to hack into wu-ftpd :

- I set up a special guestgroup, say "LDAP"

- During authentication, for any user who fails to be anonymous, member of a
guestgroup or UNIX user, I do a LDAP lookup.
If it works, then the user is treated as "LDAP".

- In the chroot phase of the guestgroup login, I chroot the user to his own
directory (ldap/user1, ldap/user2, etc) so that directory trees of the
different "LDAP" users are totally distinct. If the chrooted environment
doesn't exist, I create it for him on the fly (just before the chroot).

Any comments ?

Arnaud Ruch
([email-masked])

-----Message d'origine-----
De : James O'Byrne <[email-masked]>
À : [email-masked] <[email-masked]>
Date : vendredi 5 décembre 1997 21:00
Objet : LDAP

>I was wondering if any of the developers were looking at implementing
>LDAP authentication in future versions of Wu-ftpd.  I am currently
>investigating the possibility of such a venture.
>
>James
>
>--
>mailto:[email-masked]

---

From: "James O'Byrne" <[email-masked]>
Date: Mon, 08 Dec 1997 14:24:09 -0500

Looks good so far.  

I am looking @ some other ideas as well.
-- 
mailto:[email-masked]