Subject: How do I enable site exec

From: Scot Needy <[email-masked]>
Date: Wed, 24 Dec 1997 11:27:27 -0500

Hi;

We are running wu-ftpd for real users with ftp accounts. Anonymous
access denied.
We allow these users to publish their own cgi. With restrictions of
course.

On our Solaris 2.5.1 system site exec has seemed to disappear. How do I
get it
 back?

We are also experiencing a significant slow down in authentication on
our DEC OSF box.
 There are approx. 1200 chrooted ftp accounts and it takes anywhere from
1-2 min just to authenticate. Any ideas?

Latest Beta on both machines.

Thanks
Scot

---

From: Ayamura Kikuchi <[email-masked]>
Date: 25 Dec 1997 05:17:34 +0900

> get it back?

You may want to break CERT suggested fixes. :)

*** popen.c.orig	Fri Sep 12 11:09:30 1997
--- popen.c	Thu Nov 20 20:04:21 1997
***************
*** 172,174 ****
  	/* begin CERT suggested fixes */
! 	close(0); 
          i = geteuid();
--- 172,175 ----
  	/* begin CERT suggested fixes */
! 	if (strcmp(&gargv[0][strlen(gargv[0])-5], "index"))
! 	  close(0); 
          i = geteuid();

--
Ayamura Kikuchi <[email-masked]>