Subject: chroot & guest accounts

From: Didier Godefroy <[email-masked]>
Date: Tue, 23 Dec 1997 14:07:29 -0500

I'm having some troubles figuring out those guest accounts and chroot.

What I need to do is have most real users confined to their own home dir, I
still want to keep more access for a few priviledged users (like me for
example), so I created a group called ftpusers so I could use that group in the
statement:

guestgroup ftpusers

in my ftpaccess file, I also split my class statement like this:

class all real,anonymous *

became:

class   anon    anonymous       *
class   users   real            *
class   guests  guest           *

limit   anon    15      Any     /etc/msgs/msg.dead
limit   users   15      Any     /etc/msgs/msg.dead
limit   guests  15      Any     /etc/msgs/msg.dead

so I could have control over each one individually, the msg.dead file is just
temporary, I'll have an other one made later...

Before I changed the class statement, I couldn't logon with ftp under a user
name that belonged to the ftpusers group, but I could logon as myself as usual,
it was saying access denied or something like that, when I added the guest word
in the class statement, it then worked just like before, but was not chrooted,
even now with the 3 class and limit statements, I can logon as a user in the
group ftpusers but not chrooted, what am I missing?

--
Didier Godefroy
mailto:[email-masked]
mailto:[email-masked]
http://web.ulysium.net/

---

From: Michael Brennen <[email-masked]>
Date: Tue, 23 Dec 1997 13:19:49 -0600 (CST)

If you haven't see it already, the guest howto will walk you through
the configuration.  The other resources are helpful also.

   -- Michael

> I'm having some troubles figuring out those guest accounts and chroot.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-16.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.