Subject: Re: Makefile error in wu-ftpd-2.4.2-beta-15 for OSF/1 ?

From: "Oliver Stoll" <[email-masked]>
Date: Mon, 3 Nov 1997 18:16:01 +0100

Those errors are usually caused by spaces instead of tabs as first
characters in the rules of a makefile. Replace the spaces in the first columns
of line 44 with a tab character and it should compile fine.

Oliver

-----Ursprüngliche Nachricht-----
Von: Kis Zsolt <[email-masked]>
An: wu-ftpd <[email-masked]>
Datum: Montag, 3. November 1997 18:17
Betreff: Makefile error in wu-ftpd-2.4.2-beta-15 for OSF/1 ?

>I downloaded wu-ftpd-2.4.2-beta-15 source code, and tried to build it.
>I obtained the following messages:
>
>make args are :
>make opts are :
>
>Linking Makefiles.
>
>Making support library.
>cc -O   -c getusershell.c
>cc -O   -c fnmatch.c
>cc -O   -c strcasestr.c
>cc -O   -c strerror.c
>cc -O   -c strsep.c
>cc -O   -c authuser.c
>cc -O   -c snprintf.c
>rm -f libsupport.a
>ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strerror.o
>strsep.o authuser.o snprintf.o
>ranlib libsupport.a
>s - creating symbol hash table. Wait...
>
>Making ftpd.
>Make: Makefile: Must be a separator on line 44.  Stop.
>
>Making ftpcount.
>Make: Makefile: Must be a separator on line 44.  Stop.
>
>Making ftpshut.
>Make: Makefile: Must be a separator on line 44.  Stop.
>
>Making ckconfig.
>Make: Makefile: Must be a separator on line 44.  Stop.
>
>Links to executables are in bin directory:
>size: cannot open bin/ftpd
>size: cannot open bin/ftpcount
>size: cannot open bin/ftpshut
>size: cannot open bin/ftpwho
>size: cannot open bin/ckconfig
>Done
>
>What can be the problem? I have OSF/1 v2.0
>Zsolt Kis
>

---

From: Kis Zsolt <[email-masked]>
Date: Mon, 3 Nov 1997 19:29:35 +0100 (MET)

I put \t but nothing happened, the scatch from the Makefile is:
44  vers.o:         vers.c
45                  ${CC} ${CFLAGS} -c vers.c
46
 What is the problem, with these lines?
Zsolt Kis