Subject: Making some procress

From: [email-masked] (Don Cox)
Date: Wed, 12 Nov 1997 08:57:30 -0500

Thanks once again to all who have responded... I have beta-15 compiled
and (almost) working under HPUX 10.20. For some reason, I am not reading
the ftpaccess file. When I go in as a guest, rather than displaying the
welcome message, all I get is:

230 User dcox logged in.
Remote system type is UNIX.
Using binary mode to transfer files.

I ran /bin/ckconfig and discovered that it expects to find ftpaccess in
/usr/local/lib/ftpd. I created the directory, copied over the old ftpaccess
that I was running under Version wu-2.4(10), and tried again. Still no good.
Any ideas why I am not reading ftpaccess (if that is the problem)?

As always, thanks much in advance.

> All,
> 
> as mentioned in my previous posting:
> 
> > I am running Version wu-2.4(10) on HP-UX B.10.20 A. For
> > some reason, my parent process spawns multiple child processes:
> >
> > root 18944   560  0 08:21:26 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd
> > root 18945   560  0 08:21:32 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd
> > root 19195   560  0 08:57:07 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd
> > root 19194   560  0 08:56:59 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd
> 
> and so on. Kent Landfield has been gracious enough to inform me that this bug has been
> fixed in version beta15 (thanks again Kent, you have been most helpful! :=) My next question
> is, has anyone (successfully) compiled beta15 on HP-UX 10.20, and if so, are there any
> "gotcha's" that I should be aware of?

 Don Cox   mailto:[email-masked]   <><
 Phone: (716) 588-4415, KMX: 258-4415
 Pager: (800) SKY-8888, PIN 1989961
 FAX:   (716) 722-3885
 Webpage: http://www.kodak.com

---

From: Don Cox <[email-masked]>
Date: Wed, 12 Nov 1997 09:23:37 -0500

All,

I should have read http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html first... I
needed to add a '-a' in the inetd.conf file. Sorry for not RTM first. Onward!

--

---

From: Jenice Darner <[email-masked]>
Date: Wed, 12 Nov 1997 09:26:17 -0500

> Any ideas why I am not reading ftpaccess (if that is the problem)?

Don't bother with the ckconfig...it didn't help me one bit...
follow this outline:

where you were dumping stuff in /usr/local/lib...try putting them in
/usr/local/etc
total 1398
drwxr-xr-x   2 bin      bin         1024 Sep  9 17:28 .
drwxr-xr-x  10 bin      bin         1024 Oct 14 14:24 ..
-rw-r--r--   1 root     sys         1550 Aug 15 17:10 ftpaccess
-rw-r--r--   1 root     sys         1572 Oct  9  1995 ftpaccess.old
-rwxr-xr-x   1 root     sys          436 Oct  4  1994 ftpconversions
-rwxr-xr-x   1 root     sys        20480 Oct  6  1994 ftpcount
-rwxr-xr-x   1 root     sys       135168 Nov  9  1995 ftpd
-rwxr-xr-x   1 bin      bin       135520 Nov  1  1996 ftpd-old
-rwxrwxr-x   1 root     sys       135168 Apr 12  1995 ftpd.old
-rwxrwxr-x   1 root     sys       135168 May  4  1995 ftpd.old.1
-rwxr-xr-x   1 root     sys           37 Oct  4  1994 ftpgroups
-rwxr-xr-x   1 root     sys          116 Oct  4  1994 ftphosts
-rwxr-xr-x   1 root     sys        20480 Oct  6  1994 ftpshut
-rwxr-xr-x   1 root     sys            5 Oct 29 11:23 ftpusers
-rwxr-xr-x   1 root     sys        20480 Oct  6  1994 ftpwho

As you can see, my Wu ftp client has been in place and running since
1995...and with consecutive upgrades, it's up to patch level (or beta) 6
on this particular machine...the two 10.20 builds I have are running the
latest release and are all set up the exact same way.

put your msgs in /usr/local/msgs
total 12
drwxr-xr-x   2 root     sys         1024 Jun  5 13:45 .
drwxr-xr-x  10 bin      bin         1024 Oct 14 14:24 ..
-rw-r--r--   1 root     sys          774 Oct 20 12:02 banner
-rw-r--r--   1 root     sys          159 Jun 17  1996 offline
-rw-r--r--   1 root     sys           49 Jun  7  1995 shutmsg.old
-rw-r--r--   1 root     sys           98 Dec 15  1995 toomany
-rw-rw-rw-   1 root     sys            0 Oct 30 14:56 welcome

Try it and let me know what happens.

---

From: Don Cox <[email-masked]>
Date: Wed, 12 Nov 1997 11:18:13 -0500

OK folks,

I've read all of the FAQ's, and I couldn't find an answer to my most recent problem. :=(
It's ironic that my reason for upgrading to a newer version was because I was spawning too many
children. Now that I am running beta-15, the inverse is true! That is, the processes die too quickly.
By that I mean, if I ftp in as a guest and remain IDLE for a short amount of time, say 5 minutes, my
session is terminated:

421 Service not available, remote server has closed connection

I even got the following message once when I tried to login:

Name (ftp:dcox): dcox
331 Password required for dcox.
Password:
421 Service not available, remote server has closed connection
Login failed.
No control connection for command: No such file or directory

Is there a parameter in the code that checks to see how long a session is IDLE before it
terminates the process, or is this more likely to be a HP-UX problem?

TIA.