Subject: Is anybody running beta15 on HPUX?

From: [email-masked] (Don Cox)
Date: Tue, 11 Nov 1997 11:55:58 -0500

All,

as mentioned in my previous posting:

> I am running Version wu-2.4(10) on HP-UX B.10.20 A. For
> some reason, my parent process spawns multiple child processes:
>
> root 18944   560  0 08:21:26 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd    
> root 18945   560  0 08:21:32 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd    
> root 19195   560  0 08:57:07 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd    
> root 19194   560  0 08:56:59 ?  0:07 infpsgw1.abnamrona.com: anonymous/IE30User@: RETR /pub/photo-cd

and so on. Kent Landfield has been gracious enough to inform me that this bug has been
fixed in version beta15 (thanks again Kent, you have been most helpful! :=) My next question
is, has anyone (successfully) compiled beta15 on HP-UX 10.20, and if so, are there any
"gotcha's" that I should be aware of? 

BTW, my programming skills leave much to be desired, so forgive me if the following is
obvious to those more knowledgeable. I downloaded beta15, read the INSTALL, and ran
./build hpx. The results follow:

*************************************************************************************
make args are : 
make opts are : 
 
Linking Makefiles.
 
Making support library.
        cc -Aa -D_POSIX_SOURCE -O   -c fnmatch.c
        cc -Aa -D_POSIX_SOURCE -O   -c strcasestr.c
        cc -Aa -D_POSIX_SOURCE -O   -c strsep.c
        cc -Aa -D_POSIX_SOURCE -O   -c getusershell.c
        cc -Aa -D_POSIX_SOURCE -O   -c snprintf.c
        rm -f libsupport.a
        ar cq libsupport.a fnmatch.o strcasestr.o strsep.o getusershell.o snprintf.o
        touch libsupport.a
 
Making ftpd.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c ftpd.c
        yacc  ftpcmd.y
        mv y.tab.c ftpcmd.c
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c ftpcmd.c
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c glob.c
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c logwtmp.c
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -c popen.c
Make: Don't know how to make vers.c.  Stop.
 
Making ftpcount.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpcount ftpcount.c vers.o ../support/libsupport.a
/usr/ccs/bin/ld: Can't open vers.o
/usr/ccs/bin/ld: No such file or directory
*** Error exit code 1
 
Stop.
 
Making ftpshut.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ftpshut ftpshut.c vers.o ../support/libsupport.a
/usr/ccs/bin/ld: Can't open vers.o
/usr/ccs/bin/ld: No such file or directory
*** Error exit code 1
 
Stop.
 
Making ckconfig.
        cc -Aa -Dunix -D_HPUX_SOURCE -O -I.. -I../support  -o ckconfig ckconfig.c
 
Links to executables are in bin directory:
size:  bin/ftpd:  cannot open
size:  bin/ftpcount:  cannot open
size:  bin/ftpshut:  cannot open
size:  bin/ftpwho:  cannot open
bin/ckconfig: 5405 + 1860 + 8 = 7273
*************************************************************************************

Needless to say, my attempts were not successful. Any assistance would be greatly appreciated.
Thanks, in advance, for your help and understanding.  :=)

 Don Cox   mailto:[email-masked]   <><
 Phone: (716) 588-4415, KMX: 258-4415
 Pager: (800) SKY-8888, PIN 1989961
 FAX:   (716) 722-3885
 Webpage: http://www.kodak.com

---

From: Jenice Darner <[email-masked]>
Date: Tue, 11 Nov 1997 14:30:45 -0500

> ./build hpx. The results follow:

I have successfully installed and run the package on 10.20 for about a
month now...And it has been running successfully on HPUX 9.04 and 10.10
for close to a year (9.04 and 10.10 have an older version of WU). 
Something that you should know is that the c compiler that comes
standard with HPs is NOT a normal c compiler...it is a compiler built
SPECIFICALLY for the HPUX kernal compilations ONLY (you should really
read the HPUX FAQ at: http://hpux.cae.wisc.edu/hppd/FAQ/). You will need
(if you haven't already) to go out and get a good c compiler (like
ansic.hp-10.20.tar.gz). If you have trouble finding it on the
'net...call HP. You should have a support contract if you have an HP
machine.
Is this 10.20 machine just an ftp box or is it providing other functions
as well (being a webserver, hosting xterms, etc)? If it is just an FTP
machine, do yourself a favor and remove the X libs...you don't need them
and they take up a LOT of space...they can also geet in the way of some
of your kernal configs (running out of user procs, open files, file
locks, etc).