Subject: ftpaccess "limit" puzzle!

From: Pete Holsberg <[email-masked]>
Date: Wed, 12 Nov 1997 21:26:22 -0500 (EST)

I decided to cut back on the number of non-local ftp-ers
permitted, so I edited ftpaccess to this:

========================================================
class   mccc   	anonymous,real	*.mccc.edu
class	nonmccc	anonymous,real	!(*.mccc.edu)

limit   nonmccc   5   Any	/usr/local/etc/msg.toomany
limit   mccc      35   Any      /usr/local/etc/msg.toomany

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

#shutdown /usr/local/etc/msg.shut

email [email-masked]

passwd-check	rfc822	enforce

banner	/opt/etc/ftp-banner

loginfails 2

tar		no	mccc,nonmccc
compress	no	mccc,nonmccc
chmod		no	mccc,nonmccc
delete		no	mccc,nonmccc
overwrite	no	mccc,nonmccc
rename		no	mccc,nonmccc
umask		no	mccc,nonmccc
=======================================================

I killed all the current ftpd processes and did a kill -HUP
on inetd and waited a few minutes. When I tried ftpwho, it
showed 13/15 non-local users!

So I killed all the ftpd processes, shut down inetd, and
then restarted it.

Waited a few minutes and tried ftpwho again. Darned  if I
didn't have 12/15 non-local users!

What have I done wrong?

Thanks,
Pete

---

From: "Richard L. Goerwitz III" <[email-masked]>
Date: Thu, 13 Nov 1997 09:52:44 -0500

>permitted, so I edited ftpaccess to this:

Will it work if you do it this way:

class   mccc   	anonymous,real	*.mccc.edu
class	nonmccc	anonymous,real

-- 

Richard Goerwitz
PGP key fingerprint:    C1 3E F4 23 7C 33 51 8D  3B 88 53 57 56 0D 38 A0
For more info (mail, phone, fax no.):  finger [email-masked]