Subject: Message no anonymous?

From: Geir Johannessen <[email-masked]>
Date: Thu, 13 Nov 1997 14:39:19 +0100 (MET)

I try to login as anonymous on our ftp-server:

220 storm.stud.ntnu.no FTP server (Version wu-2.4.2.b14-GJ) ready.
Name (ftp.stud.ntnu.no:joge): anonymous
530 User anonymous unknown.
Login failed.

How can I tell the users that we do not allow anonymous logins? The best
would be to have a similare option as with deny !nameserved.

>From syslog:
Nov 13 14:18:37 storm ftpd[7139]: FTP LOGIN REFUSED (ftp not in
/etc/passwd) FROM ild.stud.ntnu.no [129.241.56.15], ftp
Nov 13 14:21:45 storm ftpd[8997]: FTP LOGIN REFUSED (ftp not in
/etc/passwd) FROM ild.stud.ntnu.no [129.241.56.15], anonymous

So if I have a user ftp in /etc/passwd it would allow anonymous logins just
like that? Or am I just misinterpretating the message? I guess it should
demand to have a class anonymous in ftpaccess?

--
Geir Johannessen          #  [email-masked]
E B Schieldropsvei 35-25  #  http://www.stud.ntnu.no/~joge/
N-7033 TRONDHEIM, NORWAY  #  Tlf private +47-73888989, job +47-73598048
"1. Never be first. 2. Never be last. 3. Never volunteer for anything."

---

From: "Roger A. Hanke" <[email-masked]>
Date: Thu, 13 Nov 1997 09:30:06 -0500

Using the banner command in the ftpaccess file would do the trick.
It is the only thing that comes out prior to the anonymous login.
You could just add a statement that they have reached a ftp server
that does not support anonymous login.
	Roger Hanke

----------
From: 	Geir Johannessen[SMTP:[email-masked]]
Sent: 	Thursday, November 13, 1997 8:39 AM
To: 	[email-masked]
Subject: 	Message no anonymous?