Subject: ls -l and dir command displays nothing

From: "Vernie T. Gloria" <[email-masked]>
Date: Thu, 13 Nov 1997 17:41:14 +0800

I have here a copy of our ftpaccess file.  The passwd entry is

test:x:506:100:Linux User:/home/test:/bin/tcsh

The user test belongs to a group called users.
When the user test login via FTP, all restrictions applied as ftpaccess
file stated and his home directory is /home/test with respect to the
system and seen as / whith respect to user test.

The problem is when we issue a command ls -l or dir, theres no list of
files or directories except for ls without any parameter.

We are using Version wu-2.4.2-academ[BETA-12](1) as what the diplay says
when we login.  Our system is running Red Hat Linux.

Is there any idea what's wrong with our setup?

---------ftpaccess file------------

class   all      real,guest,anonymous,root  *

email root@localhost

loginfails 3

deny !nameserved
guestgroup      users webusers
limit   all     10      Any     /etc/msg/.msg.deny
banner /etc/msg/.readme
readme  README*    login
readme  README*    cwd=*

#message /etc/msg/.message      login
#message /etc/msg/.message      cwd=*

compress        yes             all
tar             yes             all
chmod           no              guest,anonymous
delete          no              anonymous
overwrite       no              anonymous
rename          no              anonymous
umask           no              guest,anonymous

log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

passwd-check rfc822 warn

-------end of ftpaccess file-----

-- 
Vernie T. Gloria

---

From: "Vernie T. Gloria" <[email-masked]>
Date: Mon, 17 Nov 1997 00:28:52 +0800

Kent Landfield wrote:
> 
> # The problem is when we issue a command ls -l or dir, theres no list of
> # files or directories except for ls without any parameter.
> 
> # Vernie T. Gloria
> 
> I'd check out the info on the WU-FTPD Resource Center concerning setting
> up an external ls command.  The ls with no parameters is a builtin to wu-ftpd.
> the other ls you are having troubles with is an external ls command that
> needs to be in the ftp bin directory.  Your ftpaccess file does not control
> this.  I suspect that either the ls command itself is missing or one of the
> libraries need is missing.  The FAQ has a pretty good description on how to
> correct this.
> 
> --
> Kent Landfield                        Phone: 1-817-545-2502
> Email: [email-masked]             http://www.landfield.com/
> Email: [email-masked]                   http://www.nfr.net/
> Please send comp.sources.misc related mail to [email-masked]
> Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/

I would like to thank you for answering my email...I got it work now.
I just copied ~ftp/bin, ~ftp/lib and ~ftp/etc directories to the users
chrooted directory.  You were right, its the libraries.

passswd entries now look like:

test:x:506:100:Linux User:/home/./test:/bin/tcsh

the chrooted directory is /home and the user directory is /home/test
with all respect to the system and /test with respect to the user (in
this case the user is test).

-- 
Vernie T. Gloria