Subject: owner/group names not shown in "dir"

From: Roland Holzapfel <[email-masked]>
Date: Fri, 28 Nov 1997 15:30:56 +0100

Hi,

I've problems with basic setup:

I created all the directoories, and configured ftpaccess. Works fine.

I can log in (by ftp ;-), anonymous login accepted, msg.login shown.

The command "dir" works, too, but doesn't show owner and group names:

ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 18
drwxr-sr-x   9 0        3            512 Nov 26 10:22 .
drwxr-sr-x   9 0        3            512 Nov 26 10:22 ..
d--x--s--x   2 0        1            512 Nov 26 09:24 bin
d--x--s--x   2 0        3            512 Nov 26 09:39 dev
dr-xr-sr-x   2 0        3            512 Nov 28 14:19 etc
drwxrwxrwx   2 0        3            512 Nov 26 14:46 incoming
drwxrwxrwx   2 0        3            512 Nov 26 10:22 outgoing
drwxrwsr-x   2 0        290          512 Nov 26 09:20 pub
d--x--s--x   4 0        3            512 Nov 26 09:44 usr
226 Transfer complete.
548 bytes received in 0.0083 seconds (65 Kbytes/s)

Directory setup as following:

court: ftp-home/pub] {22} # ls -lR
.:
total 14
dr-xr-sr-x   2 root     other        512 Nov 26 10:24 bin
dr-xr-sr-x   2 root     sys          512 Nov 26 10:39 dev
dr-xr-sr-x   2 root     sys          512 Nov 28 15:20 etc
drwxrwxrwx   2 root     sys          512 Nov 26 15:46 incoming
drwxrwxrwx   2 root     sys          512 Nov 26 11:22 outgoing
drwxrwsr-x   2 root     grz          512 Nov 26 10:20 pub
dr-xr-sr-x   4 root     sys          512 Nov 26 10:44 usr

./bin:
total 36
-r-xr-xr-x   1 root     sys        17440 Nov 26 10:24 ls

./dev:
total 0
crw-rw-r--   1 root     other     13,  2 Nov 26 10:38 null
crw-rw-r--   1 root     other     11, 42 Nov 26 10:38 tcp
crw-rw-r--   1 root     other    105,  1 Nov 26 10:38 ticotsord
crw-rw-r--   1 root     other     11, 41 Nov 26 10:39 udp
crw-rw-r--   1 root     other     13, 12 Nov 26 10:39 zero

./etc:
total 10
-r--r--r--   1 root     root          70 Nov 26 11:21 group
-r--r--r--   1 root     other        639 Nov 26 12:28 msg.login
-r--r--r--   1 root     root        1064 Nov 26 10:28 netconfig
-r--r--r--   1 root     root         101 Nov 26 10:32 passwd

./incoming:
total 0

./outgoing:
total 0

./pub:
total 0

./usr:
total 6
lrwxrwxrwx   1 root     sys            6 Nov 26 10:44 bin -> ../bin
dr-xr-sr-x   2 root     other        512 Nov 26 10:54 lib
dr-xr-sr-x   3 root     other        512 Nov 26 11:03 share

./usr/lib:
total 4114
-r-xr-xr-x   1 root     other      24576 Jul 16 06:35 ld.so
-r-xr-xr-x   1 root     other     174844 Jul 16 06:36 ld.so.1
lrwxrwxrwx   1 root     root          11 Nov 26 10:54 libc.so -> ./libc.so.1
-r-xr-xr-x   1 root     other    1000252 Jul 16 05:56 libc.so.1
lrwxrwxrwx   1 root     root          12 Nov 26 10:54 libdl.so -> ./libdl.so.1

... continued libs and zoneinfo.

any hints ?

Thanks, Roland.
-- 
           \|/
          (o-o)
------oOO--(_)--OOo------------------------------------------------------
Roland Holzapfel    | Fraunhofer-Institut f. Graphische Datenverarbeitung
                    | Rundeturmstrasse 6       phone: ++49 (0)6151 155315
                    | 64283 Darmstadt          fax:   ++49 (0)6151 155399
[email-masked]| Germany           http://www.igd.fhg.de/~holzapfel/
---------ooO-------------------------------------------------------------
>>      (   ) Ooo      This space intentionally left blank             <<
---------\ (-(   )-------------------------------------------------------
          \_) ) /
             (_/

---

From: Martin Kirscht <[email-masked]>
Date: Fri, 28 Nov 1997 15:57:18 +0100

Hi, 

I have the same problem than Roland, so please answer to the mailing 
list, too.

Martin
-- 
  /| /|                   mailto:[email-masked]
 / |/ | /                 phone: +49-511-762-5305, fax: +49-511-762-5333
/artin|/\irscht           http://www.tnt.uni-hannover.de/~kirscht

Institut f. Theoretische Nachrichtentechnik und Informationsverarbeitung
Universitaet Hannover, Appelstrasse 9A, D-30167 Hannover, Germany

---

From: "H.W.K.Robers" <[email-masked]>
Date: Fri, 28 Nov 1997 17:03:10 +0100

> -r--r--r--   1 root     root         101 Nov 26 10:32 passwd

In etc/passwd a userid -> usermapping is done

Copy your /etc/passwd to ~ftp/etc/passwd
copy your /etc/group to ~ftp/etc/group

Replace the encrypted passwords by a * and cut away field 4 until the rest of 
the line.

i.e. in your /etc/passwd the line:
robers:lPfds432f6EU:500:500:H.W.K.Robers,,015-2578623,,:/home/robers:/bin/bash

in your ~ftp/etc/passwd change it to:
robers:*:500:500

This will prevent remote users from getting your encrypted password and run a 
password cracker on it..

-- 
Herman Robers

  E-mail: [email-masked]
Telefoon: 015-2578623
     WWW: http://www.et.tudelft.nl/~robers

Delftsch Studenten Corps                http://dsc.tudelft.nl
Delftsche Studenten Societeit Phoenix   http://phoenix.tudelft.nl

---

From: Roland Holzapfel <[email-masked]>
Date: Fri, 28 Nov 1997 17:14:26 +0100

Hello Herman,

I'd done this already, except for cutting the passwd entries.
I tried this, but it didn't work, too.

btw, I'm running on Sparc Ultra, Solaris 2.6.

Thanks, Roland.

[email-masked] said:
> Copy your /etc/passwd to ~ftp/etc/passwd copy your /etc/group to ~ftp/
> etc/group

> Replace the encrypted passwords by a * and cut away field 4 until the
> rest of  the line.

> i.e. in your /etc/passwd the line: robers:lPfds432f6EU:500:500:H.W.K.Ro
> bers,,015-2578623,,:/home/robers:/bin/bash 

-- 
-------------------------------------------------------------------------
-------------------------------------------------------------------------