Subject: command line options are not read correctly.

From: "Green, William" <[email-masked]>
Date: Fri, 28 Nov 1997 12:28:41 -0800

I've placed the options -alio in file /etc/inetd.conf
but they are not used correctly in the program.
If I set the options in the c code in file ftpd.c the
program works except for the ftphosts deny.
When I deny user abc on xyz@domain,
users abc on all systems are denied.

I am using a Sun OS 4.1.2 system and Version wu-2.4.2-academ[BETA-15].
The line from /etc/inetd.conf is:
ftp  stream  tcp  nowait  root  /usr/etc/in.tcpd  /usr/etc/in.ftp
in.ftpd -alio

Any thoughts on either of these two problems?
Thankyou for your time.
Bill Green
[email-masked]

---

From: [email-masked] (Albert Lunde)
Date: Fri, 28 Nov 1997 15:02:49 CST

> ftp  stream  tcp  nowait  root  /usr/etc/in.tcpd  /usr/etc/in.ftp

Some inetd versions have a rather short limit on the number of
command-line arguements they support.

I wound up writing a C wrapper program:
= =
/* wrapper for wuftpd to add command line arguments
   that don't fit under inetd */

#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <errno.h>
#include <syslog.h>

int main(argc,argv)
int argc;
char **argv;
{
    char *path="/local-adm/bin/ftpd";
    char *cmd="ftpd";

    fflush(stderr);
    fflush(stdout);
    errno=0;
    execl(path,cmd,"-a","-l","-L","-u002","-t900","-T7200",NULL);

    openlog("wrapftpd",LOG_PID, LOG_LOCAL6);
    syslog(LOG_WARNING,(const char *)strerror(errno));
    closelog();
    exit(EXIT_FAILURE);

}

= =

--
    Albert Lunde                      [email-masked]

---

From: Dusten McKee <[email-masked]>
Date: Fri, 28 Nov 1997 20:07:02 -0600 (CST)

On Fri, 28 Nov 1997, Green, William wrote:

->I am using a Sun OS 4.1.2 system and Version wu-2.4.2-academ[BETA-15].
->The line from /etc/inetd.conf is:
->ftp  stream  tcp  nowait  root  /usr/etc/in.tcpd  /usr/etc/in.ftp
->in.ftpd -alio

I will assume that the line wrapped and you do indeed have these three
entries on the end of that line:

	/usr/etc/in.tcpd  /usr/etc/in.ftp  in.ftpd -alio

This is not a correct entry. Assuming your wu-ftpd is in your /usr/etc
directory, the entry in your inetd.conf file should look like this:

 ftp  stream  tcp  nowait  root  /usr/etc/in.tcpd  /usr/etc/in.ftpd -alio

If your ftp daemon is named in.ftp, then replace the in.ftpd with
in.ftp...you get the idea.

  ..:
 ::.: |,-.|\  |,-- ---        Dusten McKee
 ..:: || || \ ||--  |         System Administrator
 :::: |`-'|  \|`--  |         ioNET, Inc.
 ::.:.....                    [email-masked]
 .:::.::.: INTERNETWORKING    Tel: (405) 270.0999
 ::.::.:.: SERVICES           Fax: (405) 270.7055
 ::.:..:.:
 : :.:..::
  .   :  .
     . .
 . 
     .