Subject: WU-ftpd compilation problem...

From: "Malla, Suman" <[email-masked]>
Date: Thu, 13 Nov 1997 17:12:30 +0100 (MET)

Hi All,

I am trying to compile WU-ftpd on Red Hat 4.2 box and getting the
following error. Could someone pls tell me how to fix them.
Your help will be highly appreciated.

[root@foo wu-ftpd-2.4]# ./build lnx
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
Makefile:13: *** missing separator.  Stop.

Making ftpd.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support   -c ftpd.c -o ftpd.o
In file included from ftpd.c:42:
config.h:25: syntax error before `typedef'
In file included from ftpd.c:46:
/usr/include/sys/stat.h:19: syntax error before `struct'
ftpd.c:227: parse error before `lostconn'
ftpd.c:227: warning: data definition has no type or storage class
ftpd.c:228: parse error before `randomsig'
ftpd.c:228: warning: data definition has no type or storage class
ftpd.c:229: parse error before `myoob'
ftpd.c:229: warning: data definition has no type or storage class
ftpd.c: In function `main':
ftpd.c:301: too few arguments to function `openlog'
ftpd.c:386: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
[snip]...
ftpd.c:469: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c: At top level:
ftpd.c:560: parse error before `randomsig'
ftpd.c:571: parse error before `lostconn'
ftpd.c: In function `pass':
ftpd.c:1002: warning: assignment makes integer from pointer without a cast
ftpd.c: In function `opt_string':
ftpd.c:1226: warning: comparison between pointer and integer
ftpd.c:1228: warning: comparison between pointer and integer
ftpd.c:1230: warning: comparison between pointer and integer
ftpd.c: In function `retrieve':
ftpd.c:1342: warning: comparison between pointer and integer
ftpd.c: At top level:
ftpd.c:2437: parse error before `myoob'
make: *** [ftpd.o] Error 1

Making ftpcount.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support -o ftpcount ftpcount.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpcount.c:32:
config.h:25: syntax error before `typedef'
In file included from /usr/include/libio.h:30,
                 from /usr/include/stdio.h:34,
                 from ftpcount.c:34:
/usr/include/_G_config.h:22: syntax error before `typedef'
ftpcount.c: In function `parsetime':
ftpcount.c:98: warning: comparison between pointer and integer
ftpcount.c:107: warning: comparison between pointer and integer
ftpcount.c: In function `acl_getlimit':
ftpcount.c:159: warning: comparison between pointer and integer
ftpcount.c:162: warning: assignment makes integer from pointer without a cast
ftpcount.c: In function `main':
ftpcount.c:307: warning: comparison between pointer and integer
ftpcount.c:310: warning: assignment makes integer from pointer without a cast
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support -o ftpshut ftpshut.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpshut.c:37:
config.h:25: syntax error before `typedef'
In file included from /usr/include/bsd/errno.h:5,
                 from ftpshut.c:39:
/usr/include/errno.h:30: syntax error before `extern'
ftpshut.c: In function `main':
ftpshut.c:188: warning: comparison between pointer and integer
ftpshut.c:191: warning: assignment makes integer from pointer without a cast
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text	data	bss	dec	hex	filename
992    	1853   	88     	2933   	b75    	bin/ckconfig

[root@foo wu-ftpd-2.4]# ./build install
make args are : 
make opts are : 
make: *** No rule to make target `bin/ftpd', needed by `install'.  Stop.

TIA.

Rgds,
Suman Malla 

Notice: The only person getting his work done by friday was Robinson Crusoe.

---

From: [email-masked]
Date: 14 Nov 1997 13:34:20 GMT

Pink elephants with an attitude inspired "Malla, Suman" <[email-masked]> to tell garfield.mail.wu-ftpd:

: I am trying to compile WU-ftpd on Red Hat 4.2 box and getting the
: following error. Could someone pls tell me how to fix them.
: Your help will be highly appreciated.

: Making support library.
: Makefile:13: *** missing separator.  Stop.

I seem to remember this error being caused by trying to use GNU make
with berkeley style Makefiles. Try pmake (pmake-1.0-5.i386.rpm):

Pmake is a particular version of make which supports some
additional syntax not in the standard make program.  Some
berkeley programs have Makefiles written for pmake.

-- 
Perry Rovers ([email-masked])