Subject: RE: specific port

From: Geoff Terry <[email-masked]>
Date: Thu, 6 Nov 1997 12:19:07 +1100

Ther's something wrong here!
Try editing ftp entries in /etc/services and putting entries similar to the existing ftp entries but using the ports you want.
inetd.conf will not need to be edited (inetd will look for an entry in /etc/services matching ftp at startup and listen on corresponding port). Of course this ignores the fact that no one will actually ever ftp to this 'unknown port'.

Telneting to the ftp daemon, regardless of whether you would want to or not, is independant of which port the daemon runs on or configuration of the daemon or inetd.conf. However, firewalls may prevent you from telneting to port x (where x is the unused port you have selected).

PS dont forget to SIGHUP inetd after the edits.

Regards Geofft
-----Original Message-----
From:	[email-masked] [SMTP:[email-masked]]
Sent:	Thursday, 6 November 1997 10:44
To:	[email-masked]
Subject:	Re: specific port

Pink elephants with an attitude inspired "Hany Morcos (CS)" <[email-masked]> to tell garfield.mail.wu-ftpd:

:      I want to run wu-ftpd on a specific port and to have to worry about
: changing inted.conf and other files. How can I force wu-ftpd to run a
: user allowed port >1024 something like that? 

Why does this sound to me like you're building a warez site by running an
ftpserver on a non-priviledged port? Any particular reason for running it on
a non-standard port apart from 'worry about changing inetd.conf'?

:     I just want to be able to telnet to it. 

:     telnet  osf1.gmu.edu 21 

Why would you want to telnet to an ftp server.. ftping to it makes much more
sense :)

-- 
Perry Rovers ([email-masked])

---

From: "Hany Morcos (CS)" <[email-masked]>
Date: Thu, 6 Nov 1997 09:54:43 -0500 (EST)

I want leave the old version of the ftp running. 
   And test the new version wu-ftp .

    I want run the old version ftp on the same port. 
    and install USER wu-ftp server with NO system special
     priviliges on a different port.
    I will eventually install wu-ftp, but I need to test and
    disable some of the features. 

    Why does this sound crazy to you guys?
    Have not you tried to run a software on a different port to test it
    first?

Thanks 
Hany

---

From: Kent Landfield <[email-masked]>
Date: Thu, 6 Nov 1997 09:45:24 -0600 (CST)

Hany,

#    I want leave the old version of the ftp running. 
#    And test the new version wu-ftp .
# 
#     I want run the old version ftp on the same port. 
#     and install USER wu-ftp server with NO system special
#      priviliges on a different port.
#     I will eventually install wu-ftp, but I need to test and
#     disable some of the features. 
# 
#     Why does this sound crazy to you guys?
#     Have not you tried to run a software on a different port to test it
#     first?

If you really know the insides of the FTP protocol then you should be able
to do it.  Most people put the server on a separate system from a production
system to do the testing.  By putting it on the same system as a production
system you can still be vunerable to certain attack attempts if port scanners
detect the new service.

In order to properly test it you should use the same port numbering as 
will be used in a production environment.  By setting it up to run on a 
non-priviledged port you could be potentially masking the very problems 
you are trying to discover.

That aside, there has been a great deal of security checking of wu-ftpd but
even with that, things have occurred in the past.  We are working to make sure 
it is the most secure version of an ftp server.  As such, I thank you for your 
serious examination in an effort to protect your site.  *Please* give us a 
summary of your finding and anything you did to make it more secure (besides 
compiling #ifdef PARANOID).  We all can benefit from your efforts.

-- 
Kent Landfield                        Phone: 1-817-545-2502             
Email: [email-masked]             http://www.landfield.com/
Email: [email-masked]                   http://www.nfr.net/
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/