Subject: Re: minor problem with guestgroup

From: Dave Jevans <[email-masked]>
Date: Wed, 12 Nov 1997 11:16:00 -0800 (PST)

>   How chdir() responds to a tilde-path is unknown (by the man pages from

chdir on UNIX treats tilde literally.  This is not
what you want.  You want the csh expansion of
tilde.  (eg ~jevans  === /home/gods/jevans).

You must do your own tilde expansion prior to
calling the chdir() function.

I believe you can use the globtilde() routine
from ftpcmd.c

DJ
---
David Jevans                            http://www.differential.com
Email: [email-masked]          Phone: (408) 864-0603

         Secure FTP and Extranet data management.
                      www.filedrive.com

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 12 Nov 1997 14:40:35 -0500 (EST)

> tilde.  (eg ~jevans  === /home/gods/jevans).

Exactly.

> I believe you can use the globtilde() routine

In beta-15 of wu-ftpd?  I just downloaded it and

grep tilde *[ch] -- no hits

grep \~ *[ch] -- expand() in glob.c .. I'll have to study it but on first
glance I'd say this is only good in some cases.  It bears further study,
though.  Tanks.

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [205.133.13.8]
Kettering, OH 45409-1615 USA    voice: +1 (937) 299-7653