Subject: Re: guestonly is not working

From: Serge Bezzubov <[email-masked]>
Date: Sun, 2 Nov 1997 19:21:47 +0300 (MSK)

A guest user is chrooted as anonymous, so you just can't link all that stuff from outside
of chrooted environment.
In order to make sure, copy ~ftp/bin dev etc usr/lib to your test dir, login via ftp and type pwd.
 
> ->> I am trying to set up guestonly accounts based on the FAQ and guest-howto,
> ->> but so far anonymous account works great, but not guestonly account.
> ->> 
> ->> BUT IT DOESN'T WORK, I still have the same problem:
> ->> 
> ->> Name (200.156.50.10:mlu): testuser
> ->> 331 Password required for testuser.
> ->> Password:
> ->> 230 User testuser logged in.  Access restrictions apply.
> ->> ftp> ls -al
> ->> 200 PORT command successful.
> ->> 425 Can't create data socket (0.0.0.0,20): No such file or directory.
> ->> ftp> 
> ->
> ->Hello Ming,
> ->
> ->That doesn't sound like a problem with your guest configuration.  It
> ->sounds like a problem with the dynamically-linked ls you have in ~ftp/bin
> ->
> ->You might want to check for the existences of the devices in ~ftp/dev/zero
> ->and ~ftp/dev/zero.  If they are not there, use mknod to make them.  Also,
> ->make sure you have all the correct libraries in your ~ftp/lib or
> ->~ftp/usr/lib directory.
> ->
> ->I hope that helps.
> ->
> ->Regards,
> ->
> ->_________________________________________________________________
> ->Thomas Fou ([email-masked])
> ->System Administrator			UC Riverside
> ->Office: (909) 787-3954			Vis. & Intel. Systems Lab
> ->Fax:    (909) 787-3188			Bourns Hall, B232
> ->
> 
> 
>

---

From: Ming Lu <[email-masked]>
Date: Mon, 3 Nov 1997 00:48:36 -0500 (EST)

Thanks Serge:

IT WORKED!!! It helped me to understand chroot more...

This raise another question:
if I have a thousand guestonly users, does that mean I have to make a
thousand copies of files in dev/* and usr/lib/*?

Best Regards

_ming

On Sun, 2 Nov 1997, Serge Bezzubov wrote:

->A guest user is chrooted as anonymous, so you just can't link all that stuff from outside
->of chrooted environment.
->In order to make sure, copy ~ftp/bin dev etc usr/lib to your test dir, login via ftp and type pwd.
-> 
->> ->> I am trying to set up guestonly accounts based on the FAQ and guest-howto,
->> ->> but so far anonymous account works great, but not guestonly account.
->> ->> 
->> ->> BUT IT DOESN'T WORK, I still have the same problem:
->> ->> 
->> ->> Name (200.156.50.10:mlu): testuser
->> ->> 331 Password required for testuser.
->> ->> Password:
->> ->> 230 User testuser logged in.  Access restrictions apply.
->> ->> ftp> ls -al
->> ->> 200 PORT command successful.
->> ->> 425 Can't create data socket (0.0.0.0,20): No such file or directory.
->> ->> ftp> 
->> ->
->> ->Hello Ming,
->> ->
->> ->That doesn't sound like a problem with your guest configuration.  It
->> ->sounds like a problem with the dynamically-linked ls you have in ~ftp/bin
->> ->
->> ->You might want to check for the existences of the devices in ~ftp/dev/zero
->> ->and ~ftp/dev/zero.  If they are not there, use mknod to make them.  Also,
->> ->make sure you have all the correct libraries in your ~ftp/lib or
->> ->~ftp/usr/lib directory.
->> ->
->> ->I hope that helps.
->> ->
->> ->Regards,
->> ->
->> ->_________________________________________________________________
->> ->Thomas Fou ([email-masked])
->> ->System Administrator			UC Riverside
->> ->Office: (909) 787-3954			Vis. & Intel. Systems Lab
->> ->Fax:    (909) 787-3188			Bourns Hall, B232
->> ->

---

From: Jim Davis <[email-masked]>
Date: Mon, 3 Nov 1997 07:48:23 -0700 (MST)

> thousand copies of files in dev/* and usr/lib/*?

No.  Isn't this in the FAQ by now?  Use hard links (if everything is on
the same filesystem) or since you're on Solaris, use loopback mounts.  See
the lofs man page for details.