Subject: Re: Guestuser bug fix && newvirt-040 now available.

From: Bill Nugent <[email-masked]>
Date: Sun, 16 Nov 1997 11:49:59 -0500

Kent,

Thank you!!  Very nice!

The C compiler warning message from ftpd.c on line 1644 can be eliminated 
by changing:

        if (virtual_mode && !guest && (*virtual_root != NULL)) {

to:

        if (virtual_mode && !guest && *virtual_root != '\0') {

	Bill

---

From: "Malla, Suman" <[email-masked]>
Date: Mon, 17 Nov 1997 14:57:04 +0100 (MET)

Hi all,

Has someone installed the WU-ftpd on Red Hat Linux 4.2? I am trying to
install it since last week but in vain...getting a lot of errors. I am
sending the outout (from ./build lnx) as an attachment. If you are
interested, have a look. I would be more than happy to get a solution. 

Thank you for your time.

Rgds,
Suman Malla 

Notice: The only person getting his work done by friday was Robinson Crusoe.

----------------------------------------
[root@foo wu-ftpd-2.4]# ./build lnx
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
Makefile:13: *** missing separator.  Stop.

Making ftpd.
gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support -I/usr/include/bsd -L../support   -c ftpd.c -o ftpd.o
In file included from ftpd.c:42:
config.h:25: syntax error before `typedef'
In file included from ftpd.c:46:
/usr/include/sys/stat.h:19: syntax error before `struct'
ftpd.c:227: parse error before `lostconn'
ftpd.c:227: warning: data definition has no type or storage class
ftpd.c:228: parse error before `randomsig'
ftpd.c:228: warning: data definition has no type or storage class
ftpd.c:229: parse error before `myoob'
ftpd.c:229: warning: data definition has no type or storage class
ftpd.c: In function `main':
ftpd.c:301: too few arguments to function `openlog'
ftpd.c:386: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:389: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:392: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:395: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:398: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:401: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:407: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:410: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:413: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:416: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:419: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:422: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:425: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:428: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:431: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:434: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:437: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:440: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:443: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:446: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:449: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:452: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:455: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:458: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:462: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:469: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c: At top level:
ftpd.c:560: parse error before `randomsig'
ftpd.c:571: parse error before `lostconn'
ftpd.c: In function `pass':
ftpd.c:1002: warning: assignment makes integer from pointer without a cast
ftpd.c: In function `opt_string':
ftpd.c:1226: warning: comparison between pointer and integer
ftpd.c:1228: warning: comparison between pointer and integer
ftpd.c:1230: warning: comparison between pointer and integer
ftpd.c: In function `retrieve':
ftpd.c:1342: warning: comparison between pointer and integer
ftpd.c: At top level:
ftpd.c:2430: parse error before `myoob'
make: *** [ftpd.o] Error 1

Making ftpcount.
gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support -I/usr/include/bsd -L../support -o ftpcount ftpcount.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpcount.c:32:
config.h:25: syntax error before `typedef'
In file included from /usr/include/libio.h:30,
                 from /usr/include/stdio.h:34,
                 from ftpcount.c:34:
/usr/include/_G_config.h:22: syntax error before `typedef'
ftpcount.c: In function `parsetime':
ftpcount.c:98: warning: comparison between pointer and integer
ftpcount.c:107: warning: comparison between pointer and integer
ftpcount.c: In function `acl_getlimit':
ftpcount.c:159: warning: comparison between pointer and integer
ftpcount.c:162: warning: assignment makes integer from pointer without a cast
ftpcount.c: In function `main':
ftpcount.c:307: warning: comparison between pointer and integer
ftpcount.c:310: warning: assignment makes integer from pointer without a cast
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support -I/usr/include/bsd -L../support -o ftpshut ftpshut.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpshut.c:37:
config.h:25: syntax error before `typedef'
In file included from /usr/include/bsd/errno.h:5,
                 from ftpshut.c:39:
/usr/include/errno.h:30: syntax error before `extern'
ftpshut.c: In function `main':
ftpshut.c:188: warning: comparison between pointer and integer
ftpshut.c:191: warning: assignment makes integer from pointer without a cast
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support -I/usr/include/bsd -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text	data	bss	dec	hex	filename
992    	1895   	88     	2975   	b9f    	bin/ckconfig
----------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 18 Nov 97 10:00:02 +0100

> gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support
-I/usr/include/bsd -L..
> /support   -c ftpd.c -o ftpd.o
> ftpd.c:386: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:389: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:392: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:395: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:398: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:401: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:407: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:410: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:413: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:416: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:419: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:422: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:425: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:428: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:431: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:434: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:437: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:440: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:443: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:446: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:449: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:452: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:455: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:458: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:462: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> ftpd.c:469: warning: passing arg 2 of `__bsd_signal' from incompatible
pointer t
> ype
> gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support
-I/usr/include/bsd -L..
> /support -o ftpcount ftpcount.c vers.o -lsupport -lbsd
> gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support
-I/usr/include/bsd -L..
> /support -o ftpshut ftpshut.c vers.o -lsupport -lbsd
> gcc -O -DDEBUG -DDIRENT_ILLEGAL_ACCESS -I.. -I../support
-I/usr/include/bsd -L..
> /support -o ckconfig ckconfig.c
> 

Have you made any modifications to the code? If not, why not grab the
latest rpm from redhat and install that? Thats what I did, works fine...

If you want to do something special with it, have you tried the rpm
version of the source?? Often, redhat's versions works best...

/Per