Subject: ftpwho headings???

From: Pete Holsberg <[email-masked]>
Date: Wed, 22 Oct 1997 22:52:09 -0400 (EDT)

Here's a line from the output of ftpwho, split into muliple
lines:

 1)	ftp       
 2)	3485  
 3)	0.0  
 4)	1.1 
 5)	2292 
 6)	1300 
 7)	?
 8)	S 
 9)	20:51:42  
10)	0:00 
11)	ftpd: 
12)	207.61.109.36: 
13)	anonymous/mozilla@: 
14)	RETR 
15)	/pub/netscape/communicator/4.03/shipping/english/windows/windows3.1/base_install/cb16e403.exe

Would someone please supply the headers for the columns?

I can guess at a few:

15) full pathname of program being ftp's
14) it's a retry of a failed download
13) login/password
12) their host IP
11) program I'm running

And the rest???

Thanks,
Pete

---

From: Oskar Pearson <[email-masked]>
Date: Thu, 23 Oct 1997 06:28:13 +0200

Hi

> Here's a line from the output of ftpwho, split into muliple
All of this is actually just the output if the 'ps' command. Look
at the source (specifically at the src/ftpcount.c file) and figure what
command it's actually running. (whenever you see a '%d' it's referring
to the process number)

> 14) it's a retry of a failed download
Not as far as I know - it stands for 'retrieve' rathere than 'retry' IMO

The actual ftp program sets everything after the 'ftpd: ' text. Everything
before that is set by the ps command.

Oskar

-- 
"Haven't slept at all. I don't see why people insist on sleeping. You feel
so much better if you don't. And how can anyone want to lose a minute -
a single minute of being alive?"				-- Think Twice

---

From: Brad Waite <[email-masked]>
Date: Thu, 23 Oct 1997 11:16:56 -0600

I'm running on IRIX 5.3, and all I get in my ftpwho output is:

Service class real: 
    root 27202   184  0 03:33:39 ?        0:29 ftpd -a -t180 -T300 
   -   1 users (  1 maximum)

As I read the source, it's supposed to replace the ftpd command line
with the useful info.  Any suggestions as to why it isn't doing so?

-Brad