Subject: The PASV command

From: [email-masked] (Yale Rosenblatt)
Date: Fri, 10 Oct 1997 10:12:17 -0700

I am running wu-ftpd-2.4.2-beta-13 on a Sun with
Solaris 2.5.1. Certain users log in to my machine and 
through a browser on a web site have problems downloading
files. They seem to access a "PASV" command that stops them.
	Here are some examples:

Oct  5 ftpd[7509]: command: SYST
Oct  5 ftpd[7509]: SYST
Oct  5 ftpd[7509]: <--- 215
Oct  5 ftpd[7509]: UNIX Type: L8
Oct  5 ftpd[7509]: command: PASV
Oct  5 ftpd[7509]: PASV
Oct  5 ftpd[7509]: <--- 425
Oct  5 ftpd[7509]: Can't open passive connection: Permission denied.
Oct  5 18:37:22 proteus ftpd[7509]: command: PORT 202,96,185,49,6,253
Oct  5 18:37:22 proteus ftpd[7509]: PORT

or
 
Oct  7 ftpd[9065]: command: SYST
Oct  7 ftpd[9065]: SYST
Oct  7 ftpd[9065]: <--- 215
Oct  7 ftpd[9065]: UNIX Type: L8
Oct  7 ftpd[9065]: command: PASV
Oct  7 ftpd[9065]: PASV
Oct  7 ftpd[9065]: <--- 425
Oct  7 ftpd[9065]: Can't open passive connection: Permission denied.
Oct  7 ftpd[9065]: <--- 221
Oct  7 ftpd[9065]: You could at least say goodbye.
Oct  7 ftpd[9065]: FTP session closed

 Having done a man on ftpd, one of the following definitions is:

    The  ftp  server  currently  supports  the   following   ftp
     requests; case is not distinguished.

     PASV           prepare for server-to-server transfer
 
Can someone tell me what permissions are not correct, Such that
the above error is happening?

Yale Rosenblatt
System and Networking Manager
Applied Biosystems
[email-masked]

---

From: Bob Luckin <[email-masked]>
Date: Fri, 10 Oct 97 14:33:23 CDT

> files. They seem to access a "PASV" command that stops them.
...

This question is covered in the wu-ftpd FAQ; the best place to find this
and other information on the server is Kent Landfield's excellent WU-FTPD
resource centre on the web at
   http://www.landfield.com/wu-ftpd/

The FAQ itself is available at
   http://www.hvu.nl/~koos/wu-ftpd-faq.html

The question is covered in section 9.13 - basically on Solaris boxes you
need to have world write rights on ~ftp/dev/tcp (where ~ftp is the chrooted
home directory for your anonymous or guest user).   If you set the mode
to 666, this should solve the problem (you may want to make sure the other
files in ~ftp/dev/ have the same permissions as their originals in /dev as
well, just to be safe).

I hope this solves your problem !

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "A man, a plan, a canal, Suez !"