Subject: Problems in data transfer (wu-ftpd-2.4-beta-15)

From: "Nagaraj.J" <[email-masked]>
Date: Thu, 23 Oct 1997 13:59:41 +0530

Hi,

	We have a svr4 based system. (Supermax) I have ported 
wu-ftpd-2.4.2-beta-15) for this (svr4) platform. As per the instructions 
given in the README & INSTALL files, I generated src/makefiles/Makefile.sbs, 
support/makefiles/Makefile.sbs and src/config/config.sbs files from 
Makefile.gen and config.gen files. I have no problem in genarating the 
executables.

	 When I connect to ftp on this m/c from some other system, 
everything goes fine until I do data transfer. i.e, it allows me to login, 
asks for the passwd and gives the ftp prompt. The real problem starts when I 
execute 'ls -l' or 'get filename' or 'put filename'. It prompts with (for eg.)
 
ftp> ls -l
500 Illegal PORT Command
125 Using existing data connection for /bin/ls.

	When I abort this using ctrl-c, it transfers the data line by line for each successive command on the same (command) socket. I mean, it will transfer the data for the first command (ls -l ) on the same socket which it used for 
commands. 

	Any suggestions please. Is it some thing to do with configuration ?

Thanks in advance

Regards
/Raju

PS : I have already posted this question to [email-masked]' and this 
bug is given a id (request number) 513. But so far I didn't get any response. 
Hence I am posting this question again. 
-- 
..------------------------------------------------------------.
|  Nagaraja J,                 (Raju)                        |
|  DDE ORG Systems,            Phone : +91-080-553 8125      | 
|  III Floor, Maruthi Towers,          +91-080-553 9217      |
|  3/4, Hosur Road,            Fax   : +91-080-553 8646      |
|  Madiwala,                   email : [email-masked]  |
|  Bangalore 560 068 INDIA.            [email-masked]        |
`------------------Attitude is Everything--------------------'

---

From: [email-masked] (denise)
Date: Thu, 23 Oct 1997 09:43:13 -0400

>         Any suggestions please. Is it some thing to do with configuration ?

First of all, let me say that it is amazing to me that there is another person in the world who has used a supermax.DDE's Euromax systems are the hardware, not the OS name, so I am going to assume that you are running a DDE version of
unix(SVR4? Are you sure it isn't system 4?).
Second, supermax utilizes bastardized versions of Unix. Therefore, you are going to run into problems using anything that isn't ported just for your system.
I worked for a while on a DDE Supermax system running a proprietary OS known as Euromax, a system 4 release BSDish OS. A number of our problems stemed from the Eromax usage of group permitions.
You'd really have to look carefully at the OS texts that DDE provides you with (if they didn't, you should talk to someone at DDE that handles the documentation) and look for the group permitions documentation specifically. There are
things that I experienced on the Euromax system that I have never seen in any other Unix system.

Hope that helps a little.

Denise