Subject: RE: Chroot'd server denying access to files

From: Leif Sawyer <[email-masked]>
Date: Tue, 7 Oct 1997 16:46:06 -0800

Arg.. of course, as soon as I post, i find the info i'm looking for:

in your ftpaccess file:

noretrieve /etc/passwd 
noretrieve /etc/group 
noretrieve /etc/ftpaccess

etc, etc..

Thanks all who responded anyway!

>-----Original Message-----
>From:	Leif Sawyer 
>Sent:	Tuesday, October 07, 1997 4:44 PM
>To:	[email-masked]
>Subject:	Chroot'd server denying access to files
>
>I'm trying to figure out how to deny user access to certain files.
>
>I've got my system set up as a chroot'd server, and i've killed read
>permissions on all the secured directories.  However, any user
>can still type
>
>> get /etc/passwd
>
>and have the full password list.   Is there a way to secure this?
>
>
>
>
>

---

From: Brian Pape <[email-masked]>
Date: Mon, 08 Sep 1997 08:11:44 -0700

>and have the full password list.   Is there a way to secure this?

Either make /etc/passwd unreadable by users or chroot them somewhere.

Brian Pape
Computer Resource Services
University California Los Angeles
[email-masked]