Subject: Re: ftp daemon with bandwidth limiting feature

From: Laszlo Vecsey <[email-masked]>
Date: Tue, 14 Oct 1997 06:01:21 -0400 (EDT)

On Wed, 1 Oct 1997, Eugeny Kuzakov wrote:

> Dear Sirs !
> Where can I find it ?
> 10tx !

Does anyone else have information on this?

Is there a way to limit bandwidth on the kernel level perhaps, for an
aliased IP on a Linux box used for virtual ftp?

- lv

---

From: Bill Nugent <[email-masked]>
Date: Tue, 14 Oct 1997 07:03:57 -0400

I don't think so.  The most sure fire way I know of is to put the ftp 
host on a subnet by itself and have two routers talking to each other 
over a stub serial line with the clocking set at the rate you want to 
limit the bandwidth at.  Something along the lines of:

ISP<-leased-line->site-router<-ethernet->your normal hosts...
                      ^
                      |
                      +--slow-serial-->throttling router<-ethernet->ftp-host

	Bill

---

From: Suzanne Archibald <[email-masked]>
Date: Tue, 14 Oct 1997 07:21:40 -0400

Actually, I'm fairly sure this IS possible, it would just be a matter of timelimiting the amount of data sent to data connection ports. 

Anyway... My point of replying was to say that I recall using FTP servers in the UK a few years ago that would often greet you with 'Setting data bandwidth to 30K/s max' and if they were heavily loaded, it would occasionally be '300B/s max'. If i recall, funet.fi also used such a scheme once upon a time. Maybe as high bandwidth connections have become more easily available to these heavy servers they have stopped imposing such limits, but it would be useful if we could find such servers again for general use.

Suzanne Archibald

Programmer

<bold>Crysalis Software

</bold>http://www.crysalis.com/

---

From: Eugeny Kuzakov <[email-masked]>
Date: Tue, 14 Oct 1997 21:42:08 +0700

Suzanne Archibald wrote:
> 
> Anyway... My point of replying was to say that I recall using FTP servers in the UK a few years ago that would often >greet you with 'Setting data bandwidth to 30K/s max' and if they were heavily loaded, it would occasionally be '300B/s >max'. If i recall, funet.fi also used such a scheme once upon a time. Maybe as high bandwidth connections have become >more easily available to these heavy servers they have stopped imposing such limits, but it would be useful if we could >find such servers again for general use.
Ok. Fine.
Where can I find it ? Is it freeware patches ?
Thanks for respond !

-- 
	Best wishes, Eugeny Kuzakov
		Laboratory 321 ( Omsk, Russia )
		http://www.lab321.ru/~kev
		[email-masked]