Subject: Virtual Ftp under Solaris and posibly SunOS

From: Mark Rogov <[email-masked]>
Date: Fri, 31 Oct 1997 17:56:31 -0500

Hello!

I set up ftp for Solaris and SunOS using FAQs and Documentation for
wuftd,
however, I still have a question about virtual ftp access.

Lets consider Solaris 2.5.2. I have ftpaccess file and passwd configured
so user directory would be chrooted after login. Works fine.
But every single acct has to have the following structure:
--------------------
/.
/.. -- this dir is getting chrooted
/bin
    -  ls
/dev
    - tcp 
    - zero
/usr/lib
    - ld.so
    - libc.so.1.9    
    - libdl.so.1.0   |  this one, I think, is not nessesary, but it is
not a point now.
/pub
    - whatever customer has in there
---------------------
/bin, /dev, /usr are owned by root (755 permissions)

I'd like to move /bin, /dev, /usr/lib to a permanent location (one place
instead of every ftp acct dir), so everyone would be able to use them,
yet /pub (or in this case /..) would get chrooted.

Is that possible? If yes, how?

Thnk you.
--
Mark Rogov
I-3 Telecom, Inc.
Tel: 212-691-9300
Fax: 212-691-9846
[email-masked]
http://www.i3tele.com/~mark

---

From: Dave Jevans <[email-masked]>
Date: Fri, 31 Oct 1997 16:28:16 -0800 (PST)

>[description of /bin/dev/usr/lib/]

Mark,

This is not possible with wu-ftpd on Solaris.
This can be done with FileDrive EX ftpd (a commercial server
based on wu-ftpd), because it supports "virtual chroot".
This locks users into their home dirs, but does not require
a copy of the O/S directories.

Check it out at http://www.filedrive.com

DJ
---
David Jevans                            http://www.differential.com
Email: [email-masked]          Phone: (408) 864-0603

         Secure FTP and Extranet data management.
                      www.filedrive.com