Subject: Logging to wtmpx

From: Pete Holsberg <[email-masked]>
Date: Mon, 20 Oct 1997 12:22:11 -0400 (EDT)

I'm running the latest beta (having upgraded from plain
2.4) and now all ftp logins -- including those of people
who get denied service for whatever reason -- are logged to
/var/adm/wtmpx (Solaris 2.5).

I hate this! How do I turn it off. ftpd runs with only the
-a switch.

Thanks,
pete

---

From: Jim Davis <[email-masked]>
Date: Mon, 20 Oct 1997 10:51:43 -0700 (MST)

> I hate this! How do I turn it off. ftpd runs with only the

Easy enough: edit src/logwtmp.c.  (Note it picks up WTMPX_FILE from
#include'ing <utmpx>, instead of setting it in src/pathnames.h.)

Though why you'd want to turn that off isn't clear.

---

From: Pete Holsberg <[email-masked]>
Date: Mon, 20 Oct 1997 14:15:06 -0400 (EDT)

On Mon, 20 Oct 1997, Jim Davis wrote:

> Easy enough: edit src/logwtmp.c.  (Note it picks up
> #WTMPX_FILE from include'ing <utmpx>, instead of setting
> it in src/pathnames.h.)

Thanks.
 
> Though why you'd want to turn that off isn't clear.

To keep wtmpx a reasonable size for the "last" command. I
get all the logging I want to xferlog.

Pete