Subject: helpme

From: Yura Skobkaryev <[email-masked]>
Date: Tue, 14 Oct 1997 16:13:55 +1100

Hello !

I am having problems compling Wu-FTP for Linux. I have linux-2.0.9.Here is the log of the build.
make args are :
make opts are :

Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
Makefile:13: *** missing separator.  Stop.

Making ftpd.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support   -c ftpd.c -o
ftpd.o
In file included from ftpd.c:42:
config.h:25: syntax error before `typedef'
In file included from ftpd.c:46:
/usr/include/sys/stat.h:13: syntax error before `struct'
ftpd.c:227: parse error before `lostconn'
ftpd.c:227: warning: data definition has no type or storage class
ftpd.c:228: parse error before `randomsig'
ftpd.c:228: warning: data definition has no type or storage class
ftpd.c:229: parse error before `myoob'
ftpd.c:229: warning: data definition has no type or storage class
ftpd.c: In function `main':
ftpd.c:301: too few arguments to function `openlog'         
ftpd.c:386: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:389: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:392: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:395: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:398: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:401: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:407: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:410: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:413: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:416: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:419: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:422: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:425: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:428: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:431: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:434: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:437: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:440: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:443: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:446: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype                                                                 
ftpd.c:449: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:452: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:455: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:458: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:462: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c:469: warning: passing arg 2 of `__bsd_signal' from incompatible pointer t
ype
ftpd.c: At top level:
ftpd.c:560: parse error before `randomsig'
ftpd.c:571: parse error before `lostconn'
ftpd.c: In function `pass':
ftpd.c:1002: warning: assignment makes integer from pointer without a cast
ftpd.c: In function `opt_string':
ftpd.c:1226: warning: comparison between pointer and integer
ftpd.c:1228: warning: comparison between pointer and integer
ftpd.c:1230: warning: comparison between pointer and integer
ftpd.c: In function `retrieve':
ftpd.c:1342: warning: comparison between pointer and integer
ftpd.c: At top level:
ftpd.c:2430: parse error before `myoob'
make: *** [ftpd.o] Error 1

Making ftpcount.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support -o ftpcount ftp
count.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpcount.c:32:
config.h:25: syntax error before `typedef'
In file included from /usr/include/libio.h:32,
                 from /usr/include/stdio.h:34,
                 from ftpcount.c:34:
/usr/include/_G_config.h:23: syntax error before `typedef'
ftpcount.c: In function `parsetime':
ftpcount.c:98: warning: comparison between pointer and integer
ftpcount.c:107: warning: comparison between pointer and integer      
ftpcount.c: In function `acl_getlimit':
ftpcount.c:159: warning: comparison between pointer and integer
ftpcount.c:162: warning: assignment makes integer from pointer without a cast
ftpcount.c: In function `main':
ftpcount.c:307: warning: comparison between pointer and integer
ftpcount.c:310: warning: assignment makes integer from pointer without a cast
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -O -DDEBUG -I.. -I../support -I/usr/include/bsd -L../support -o ftpshut ftps
hut.c vers.o -lsupport -lbsd
gcc: vers.o: No such file or directory
In file included from ftpshut.c:37:
config.h:25: syntax error before `typedef'
In file included from /usr/include/bsd/errno.h:5,
                 from ftpshut.c:39:
/usr/include/errno.h:30: syntax error before `extern'
ftpshut.c: In function `main':
ftpshut.c:188: warning: comparison between pointer and integer
ftpshut.c:191: warning: assignment makes integer from pointer without a cast
make: *** [ftpshut] Error 1

Making ckconfig.
make: `ckconfig' is up to date.
ln: ckconfig: File exists

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex     filename
1060    1901    96      3057    bf1     bin/ckconfig
Done                                                                  help me,please
Yury V. Skobkarev

---

From: Michael Brennen <[email-masked]>
Date: Tue, 14 Oct 1997 09:43:42 -0500 (CDT)

There are enough different types of errors here (make, include files) that
I don't know where to begin to think your errors are.  Are you running the
build command with "./build" to make sure that you are not running another
system command named build?.  Doesn't seem likely, but worth asking. 

   -- Michael