Subject: Proxy problems

From: Mattias Niklasson <[email-masked]>
Date: Tue, 14 Oct 1997 16:08:52 +0200

Hello,

We are running WUftpd 2.4(2) on a Solaris 2.5.1 system. It works fine
except for a couple of customers running proxy servers. For them, just
about nothing happens. The proxy seems to think the ftp server is down.

There are no communication problems between the proxy and our ftp server,
when we have tried to connect from the actual proxy box whithout problems.

Have anyone seen this problem before?

Best Regards,
Mattias Niklasson

-----------------------------------------------------------
  Marieberg Interactive AB    Tel: 08-459 39 42
  Box 27205                   Fax: 08-661 51 30
  102 53 Stockholm            Mob: 070-620 11 90

---

From: Dieter Meinert <[email-masked]>
Date: Wed, 15 Oct 1997 09:52:03 +0200

-----BEGIN PGP SIGNED MESSAGE-----

 Hi, I also had that problem and tracked it to the communication
 between wu-ftpd and cern-httpd which I ran as a proxy server.
 It appears that the proxy tries to submit a PASV command which
 the ftpd does not allow.
 I'm sorry but I did not find a solution except for either shutting down
 the ftp-proxy or using the solaris ftpd, which does not have
 that problem.

|=>  
|=>  Hello,
|=>  
|=>  We are running WUftpd 2.4(2) on a Solaris 2.5.1 system. It works fine
|=>  except for a couple of customers running proxy servers. For them, just
|=>  about nothing happens. The proxy seems to think the ftp server is down.
|=>  
|=>  There are no communication problems between the proxy and our ftp server,
|=>  when we have tried to connect from the actual proxy box whithout problems.
|=>  
|=>  Have anyone seen this problem before?
|=>  
|=>  Best Regards,
|=>  Mattias Niklasson
|=>  
|=>  -----------------------------------------------------------
|=>    Marieberg Interactive AB    Tel: 08-459 39 42
|=>    Box 27205                   Fax: 08-661 51 30
|=>    102 53 Stockholm            Mob: 070-620 11 90
|=>  

Regards,
						Dieter 
 
  _____________________________*__________________________________
 /                          *       [email-masked]         \
 \ Dieter Meinert    (-      **     http://abrixas.aip.de/~dieter/ \
  \__________________A______*__*___________________________________/
   (public pgp key from http://abrixas.aip.de/~dieter/.Adresse.html)

---

From: Bob Luckin <[email-masked]>
Date: Wed, 15 Oct 97 11:41:02 CDT

Mattias >>>
> |=>  when we have tried to connect from the actual proxy box whithout problems.

Dieter >>>
>  the ftp-proxy or using the solaris ftpd, which does not have

Well, if it _really_ is due to the PASV command, and you are running on
Solaris 2, then you need to check your permissions on the files under
~ftp/dev.  ~ftp/dev/tcp should be set to 666 - it needs to be world-writable
under Solaris 2 to allow passive connections.

If you check the original Solaris 2 man page for ftpd it has instructions
on what device files you need in the FTP root area.  These need to have the
same permissions as the originals under /dev... - in my case they are
all 666.

This is all covered in question 9.13 of the FAQ, which you can find in the
WU-FTPD Resource Center at
   http://www.landfield.com/wu-ftpd/
(the FAQ itself is at http://www.hvu.nl/~koos/wu-ftpd-faq.html)

If the permissions under ~ftp/dev are set correctly, then I think the
problem must lie elsewhere.

Good luck !

Cheers, Bob
-- 
Bob Luckin      [email-masked]      "A man, a plan, a canal, Suez !"

---

From: Mattias Niklasson <[email-masked]>
Date: Wed, 15 Oct 1997 18:59:21 +0200

Hi,

>problem must lie elsewhere.

Thanks, but here is what it looks like, so this shouldn't be the problem.
Any other suggestions?

crw-rw-rw-   1 root     other     11, 42 Aug  4 21:32 tcp
cr--r--r--   1 root     other     13, 12 Aug  4 21:33 zero

Regards,
Mattias Niklasson

-----------------------------------------------------------
  Marieberg Interactive AB    Tel: +46-8-459 39 42
  Box 27205                   Fax: +46-8-661 51 30
  102 53 Stockholm, Sweden    Mob: +46-70-620 11 90

---

From: [email-masked] (Josef Siemes)
Date: Thu, 16 Oct 1997 13:59:51 +0200 (DFT)

> cr--r--r--   1 root     other     13, 12 Aug  4 21:33 zero

It should be like
   0 crw-rw-rw-   1 root     other     11, 42 Sep 18 18:13 tcp
   0 crw-rw-rw-   1 root     other    105,  1 Sep 18 18:13 ticotsord
   0 crw-rw-rw-   1 root     other     11, 41 Sep 18 18:13 udp
   0 crw-rw-rw-   1 root     other     13, 12 Sep 18 18:13 zero

as stated in the man-page for the solaris-ftpd. Did you at least look at it?

Did you also include all libraries in /usr/lib?

Look at the FAQ, there's also a link for Solaris and wu-ftpd, also
what libraries are needed.

Josef

(Josef Siemes, [email-masked])