Subject: [Q] LIST command yields empty list

From: Dieter Meinert <[email-masked]>
Date: Wed, 24 Sep 1997 13:00:36 +0200

-----BEGIN PGP SIGNED MESSAGE-----

I just installed wu-ftpd 2.4 on a Dec Alpha, OSF1 v4.0, using
Digitals cc.
It works fine, except for 1 thing: When an anonymous user submits
a dir command (or ls -la or similars) she gets an empty list returned:

Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
etc
pub
vol
local
226 Transfer complete.
ftp> ls -a
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> 

For a real user the dir command works fine. I suppose there is
some configuration set to deny anonymous long listings, but I
cannot figure out which one, since this happens even for the most
simple possible ftpaccess file. The file permissions are as
recommended, that is r-xr-xr-x for directories, --x--x--x for
progs under /bin and even rwxr-xr-x for incoming.

I'm looking for any hints.

Regards,
						Dieter 
 
  _____________________________*__________________________________
 /                          *       [email-masked]         \
 \ Dieter Meinert    (-      **     http://abrixas.aip.de/~dieter/ \
  \__________________A______*__*___________________________________/
   (public pgp key from http://141.33.192.49/~dieter/.Adresse.html)

---

From: Dieter Meinert <[email-masked]>
Date: Thu, 25 Sep 1997 09:49:38 +0200

-----BEGIN PGP SIGNED MESSAGE-----

Thanks, that works (and I dimly remember having done so on a
sparc a couple of yesars ago).
I solved the Problem by recompiling GNU fileutils and linking
statically.
Since only ls is needed this time I may save the diskspace for
the whole libs.

Thanks.
|=>  
|=>  This refers to a problem solved by micheal brennan for myself and dave roger 
|=>  last week. To quote micheal :-
|=>  
|=>  wuftpd has a simple 'ls' (with no options) built in.
|=>  
|=>  
|=>  Ergo, your external ls for the anonymous setup is broken. In my case the 
|=>  chrooted environment needed some libraries as well as the executable. Try using 
|=>  the chroot command to test your ls, I used ldd to finbd the required libraries,
|=>  
|=>  Martin
|=>  
|=>  ______________________________ Reply Separator _________________________________
|=>  
|=>  
|=>  -----BEGIN PGP SIGNED MESSAGE-----
|=>  
|=>  
|=>  I just installed wu-ftpd 2.4 on a Dec Alpha, OSF1 v4.0, using 
|=>  Digitals cc.
|=>  It works fine, except for 1 thing: When an anonymous user submits
|=>  a dir command (or ls -la or similars) she gets an empty list returned:
|=>  
|=>  Remote system type is UNIX.
|=>  Using binary mode to transfer files. 
|=>  ftp> dir
|=>  200 PORT command successful.
|=>  150 Opening ASCII mode data connection for /bin/ls. 
|=>  226 Transfer complete.
|=>  ftp> ls
|=>  200 PORT command successful.
|=>  150 Opening ASCII mode data connection for file list. 
|=>  bin
|=>  etc
|=>  pub
|=>  vol
|=>  local
|=>  226 Transfer complete.
|=>  ftp> ls -a
|=>  200 PORT command successful.
|=>  150 Opening ASCII mode data connection for /bin/ls. 
|=>  226 Transfer complete.
|=>  ftp> 
|=>  
|=>  For a real user the dir command works fine. I suppose there is 
|=>  some configuration set to deny anonymous long listings, but I 
|=>  cannot figure out which one, since this happens even for the most 
|=>  simple possible ftpaccess file. The file permissions are as 
|=>  recommended, that is r-xr-xr-x for directories, --x--x--x for 
|=>  progs under /bin and even rwxr-xr-x for incoming.
|=>  
|=>  I'm looking for any hints.
|=>  
|=>  Regards,
|=>  						Dieter 
|=>  
|=>    _____________________________*__________________________________
|=>   /                          *       [email-masked]         \ 
|=>   \ Dieter Meinert    (-      **     http://abrixas.aip.de/~dieter/ \
|=>    \__________________A______*__*___________________________________/
|=>     (public pgp key from http://141.33.192.49/~dieter/.Adresse.html)
|=>  
|=>  -----BEGIN PGP SIGNATURE-----
|=>  
|=>  iQCVAgUBNCjy0/YksnFoaQ6JAQECEQQAkh2GfzFKY59UiyeTBmwJlOUlLWTsGnEJ 
|=>  n34zTPQobwYXCKcrsfBf2Un5YwfxZA877vhNoOxuHU2mJwekZfLvB1XN9MYzPK12 
|=>  +u5HK2bLBFirD2li9BT2WrsG6ZIQf6IhuH6k13fK7t2T78mTPopJ83Wt8rO2uEuU 
|=>  lHUKm3PX+os=
|=>  =N4d+
|=>  -----END PGP SIGNATURE-----
|=>  
|=>  
|=>  **********************************************************************
|=>  DST International   Tel:+44 181 390 5000    www.dstinternational.co.uk 
|=>  
|=>  This message and any attachments to it is intended only for the 
|=>  individual or company to which it is addressed and may contain 
|=>  information which is privileged, confidential or prohibited from 
|=>  disclosure or unauthorised use.  If the recipient of this 
|=>  transmission is not the intended recipient, or the employee or agent 
|=>  responsible for delivering such materials to the intended recipient, 
|=>  you are hereby notified that any use, any form of reproduction, 
|=>  dissemination, copying, disclosure, modification, distribution and/or 
|=>  publication of this e-mail message or its attachments other than by 
|=>  its intended recipient is strictly prohibited by the sender.  
|=>  
|=>  If you have received it in error, please notify us immediately by 
|=>  telephone on the number above and destroy the message and all copies 
|=>  in your possession.
|=>  **********************************************************************
|=>  

Tsch|_,
						Dieter 
 
   (public pgp key from http://abrixas.aip.de/~dieter/.Adresse.html)