Subject: SUMMARY:RE: error 425

From: "Hepp, Paul" <[email-masked]>
Date: Tue, 30 Sep 1997 14:08:00 -0400

Thanks Brain, That fits the nail on the head.

> >>  error 425,  "Can't create data socket (0.0.0.0,20): No such file
> or
> >> directory."
> >> 
> >This looks like a permission problem to me. I get this error after I
> >login and then try to do an ls.
> >This is a static ls built from the gnu file utilities.
> >/etc/passwd is chroot'ed like /ftp/guests/./guest1
> >guest1 has a bin (etc,dev), directories are "by the book"
> >
> >also chroot /ftp/guests/guest1 /bin/ls works!
> 
> If bin is in guest1, that's not right...  It looks for /bin, not
> bin, so it should be /ftp/guests/bin if you are chrooting to
> /ftp/guests.
> 
> Brian Pape
> 
The "guest-howto" faq may say it , but I did not see that the etc, dev,
bin,  directories MUST be at the chroot base directory. once I moved
bin, etc and recreated dev at the /ftp/guests base directory, the ls
command worked great. The etc directory with passwd and group supplies
the timestamps for the ls command, and the dev directory must be with
the bin directory. (It does not work to have only the bin directory at
that level, I tried it that way).
Also thanks to Godfrey Nix for the tips about dev directory, but the two
replies together is what turned on the light.

---

From: Michael Brennen <[email-masked]>
Date: Tue, 30 Sep 1997 13:28:32 -0500 (CDT)

> command worked great. The etc directory with passwd and group supplies

It does.  From the howto:

3. Build the directory structure under Mort's account.

cd /home/web/mort
mkdir etc bin [dev lib]   (dev and lib are optional and are OS dependent.)

          ^^^  ^^^ ^^^

4. Build the contents of the ~/bin directory.

                             ^^