Subject: Re: Problem with ls command using beta15

From: [email-masked]
Date: Wed, 24 Sep 97 13:20:19 CST

I have the same problem with Solaris 2.5 on a Sun Sparc 10.  
     dir and ls -l are fine, but ls cuts off the first two characters of 
     the filename!  This causes problems using an mget, since the list of 
     files to retrieve is drawn from the ls command.
     
     Let me know if you find a solution--
     
     thanks!
     Adrian DuPre'
     Applications Engineer
     Sulzer Orthopedics Inc.
     [email-masked]
     (512)432-9330

______________________________ Reply Separator _________________________________
Subject: Problem with ls command using beta15
Author:  [email-masked] at Internet-Mail
Date:    9/22/97 9:52 AM

 I have a problem using beta15 on a Pyramid DC/OSx machine.  This is
the initial port so I may have a setting wrong.
     
 I can do an "ls -l" and the directory looks right.  It also looks
right using "dir".  Using just "ls", the first two characters are dropped 
from each line.  Any idea what is up?

-Earle
-- 
Earle Ake                   MSG/SID                  [email-masked] 
Hassler Communication Systems Technology, Inc.       [email-masked]
HCST: 2332 Grange Hall Road; Beavercreek, OH 45431-2345  Phone: 937-427-9000 
Base: 4375 Chidlaw Rd. Suite 6; WPAFB, OH 45433-5006 937-257-7492 DSN:787-7492

---

From: Jim Davis <[email-masked]>
Date: Wed, 24 Sep 1997 13:39:46 -0700 (MST)

On Wed, 24 Sep 1997 [email-masked] wrote:

>      the filename!

The classic symptoms of comp.unix.solaris FAQ item 6.19:

	Why doesn't readdir work?  It chops the first two characters
	of all filenames.

See http://www.wins.uva.nl/pub/comp/solaris/solaris2.faq for the answer.