Subject: Re: SUMMARY:RE: error 425

From: Brian Pape <[email-masked]>
Date: Tue, 30 Sep 1997 11:37:10 -0700

At 01:28 PM 9/30/97 -0500, you wrote:
>
>> The "guest-howto" faq may say it , but I did not see that the etc, dev,
>> bin,  directories MUST be at the chroot base directory. once I moved
>> bin, etc and recreated dev at the /ftp/guests base directory, the ls
>> command worked great. The etc directory with passwd and group supplies
>
>It does.  From the howto:
>
>3. Build the directory structure under Mort's account.
>
>cd /home/web/mort
>mkdir etc bin [dev lib]   (dev and lib are optional and are OS dependent.)
>
>          ^^^  ^^^ ^^^
>
>4. Build the contents of the ~/bin directory.
>
>                             ^^

Keep in mind, this is only if mort is chroot'ed to /home/web/mort,
not if he is chrooted to /home/web.  Maybe the howto should say
to build the directories under the chroot'ed dir, not the "home"
dir (if you use /home/web/./mort)...  Or maybe it already says this
since I haven't read it.

Brian Pape
Computer Resource Services
University California Los Angeles
[email-masked]

---

From: Michael Brennen <[email-masked]>
Date: Tue, 30 Sep 1997 22:22:08 -0500 (CDT)

On Tue, 30 Sep 1997, Brian Pape wrote:

>mort:*:403:400:Mortimer Snerd:/home/web/./mort/:/etc/ftponly
>                                       ^^^

> I guess this isn't clear enough for some people.  Maybe we can change it
> (whoever maintains it) to:

3. Build the directory structure under Mort's account.
   Create the /etc, /lib, and any other directory you need
   in the directory that the chroot() is done into.

Worth a try.  I ended up putting it in 3.  Thanks....

   -- Michael