Subject: Xferlog problems

From: [email-masked] (Peter Chiu RAL SSD EODG Computer Section)
Date: Fri, 5 Sep 1997 17:02:14 +0100

Hi,

I have just mounted WU-FTPD V2.4(2) on an
AlphaStation running DEC Unix V4.0, with
the hope that I can record all ftp activities.

No errors were reported during the installation.

I then made a copy of the ftpaccess from examples
to /usr/local/etc and restarted inetd.

The ftp are working as expecting, but the logging
of these activites are not quite.

So far, inbound ftp to a real user is logged (on both
put and get), but inbound anonymous access is not logged.

Furthermore, no outbound ftp transfers initiated by
real users are recorded on the xferlog.

Could anyone shed some light to this?

Thanks in advance.
Peter Chiu
**************************************************************************
Peter Chiu                     
Rutherford Appleton Laboratory | E-mail: [email-masked] (Internet)      
Space Science Department       |       : Omni:UK.AC.RL.GDF03::PCMC(19.817)
Building R25 Room 1.27         | Voice : (44)-(0)1235-44-6699
Chilton, Didcot                | Fax   : (44)-(0)1235-44-5848 
Oxfordshire OX11 0QX  UK       
***************************************************************************

---

From: Michael Brennen <[email-masked]>
Date: Fri, 5 Sep 1997 12:27:29 -0500 (CDT)

You need to install the latest version; there are many bug/security fixes.
May cure the log issues also.

   -- Michael

> the hope that I can record all ftp activities.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-14.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.