Subject: Directory listings

From: "Philip Kearney III" <[email-masked]>
Date: Fri, 5 Sep 1997 15:48:40 -0400

I have a question which perhaps someone here can help with.

I am running beta 13 on a Sparc that is running SunOS 4.1.4 and I ma seeing a 
difference in the times being reported back by the server when a user asks for 
a long directory listing.

Example:

0) Here is the "ls" output when I telnet into the box:

d--x--x--x  3 root          512 Jun  9 18:22 bin/
d--x--x--x  2 root          512 Jul 25  1996 dev/
drwxr-xr-x  2 root          512 Jul 17 16:44 etc/
drwxrwx-wx  5 root          512 Sep  3 19:22 incoming/
drwxr-xr-x  2 root          512 Dec  3  1996 lost+found/
drwxrwx--x  2 root          512 Jul 17 18:39 outgoing/
drwxrwxr-x  4 root          512 Jul 21 17:20 public/

1) Here's what I get when I am logged in via FTP as "anonymous":

d--x--x--x  3 root          512 Jun  9 22:22 bin
d--x--x--x  2 root          512 Jul 25  1996 dev
drwxr-xr-x  2 root          512 Jul 17 20:44 etc
drwxrwx-wx  5 root          512 Sep  3 23:22 incoming
drwxr-xr-x  2 root          512 Dec  4  1996 lost+found
drwxrwx--x  2 root          512 Jul 17 22:39 outgoing
drwxrwxr-x  4 root          512 Jul 21 21:20 public

2) Here's what I get when I am logged in via FTP as a real user:

d--x--x--x  3 root          512 Jun  9 18:22 bin
d--x--x--x  2 root          512 Jul 25  1996 dev
drwxr-xr-x  2 root          512 Jul 17 16:44 etc
drwxrwx-wx  5 root          512 Sep  3 19:22 incoming
drwxr-xr-x  2 root          512 Dec  3  1996 lost+found
drwxrwx--x  2 root          512 Jul 17 18:39 outgoing
drwxrwxr-x  4 root          512 Jul 21 17:20 public

It looks like wu-ftpd is converting file dates & times to GMT when I open an 
FTP session as anonymous.  But when I open an FTP session as a real user, it 
seems to report file dates and times using local time instead of GMT.

Is this supposed to be like this?

Shouldn't it always report dates and times in GMT to a remote FTP client, no 
matter if they are a real user or the anonymous user?

Any insight into this behavior would be greatly appreciated.

-phil

----------------------------------------------------------------------------
Philip Kearney III                mailto:[email-masked] 
Sr. Software Engineer             mailto:[email-masked]
System Administrator              finger [email-masked] for my PGP key
Ascend Communications, Inc.       
Client Software Engineering Group             
----------------------------------------------------------------------------

---

From: "Christopher A. Kalin" <[email-masked]>
Date: Sat, 6 Sep 1997 12:26:57 -0500 (CDT)

> I am running beta 13 on a Sparc that is running SunOS 4.1.4 and I ma
> seeing a difference in the times being reported back by the server when
> a user asks for a long directory listing.

[snip]

> seems to report file dates and times using local time instead of GMT.

I can't help you with SunOS, but under Linux I had to duplicate the
appropriate files from /usr/lib/zoneinfo into ~ftp/usr/lib/zoneinfo.  (In
my case, that was Chicago, localtime, and posixrules...there may be more
or fewer files in your case.)

Once I did that, all the times were consistently in the Central time zone 
for anon and real FTP sessions.

Good luck!

Chris Kalin
System Administrator
Axis.net, Inc.