Subject: Restricting Directory Access

From: WebMaster <[email-masked]>
Date: Tue, 16 Sep 1997 14:37:25 +0900

I am in the process of installing wu-ftpd on our machine - a Solaris system.  Is there a
way to restrict ftp access to a various directories.  For example, a user's directory is
located at /usr/home/username

The user starts in the username directory by default, but can change directories to
anything else, including /etc .  I only want the user to be able to see his or her own
directory and not be able to view anything else (i.e., a list of users or cgi scripts).
Any thoughts or suggestions?

   -Chip Downs, Webmaster, Okinawa Online, [email-masked]

---

From: Michael Brennen <[email-masked]>
Date: Tue, 16 Sep 1997 00:48:11 -0500 (CDT)

The guest howto is below.

   -- Michael

> Any thoughts or suggestions?

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-14.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.