Subject: Setup question

From: Harish Pillay <[email-masked]>
Date: Tue, 2 Sep 1997 17:12:35 +0800 (SGT)

Hi.  I have looked over the man pages, and I think all the relevant docs
and still can't seem to get the right answer.

Here's the problem:

a) system is a Linux 2.0.30 machine.
b) compiled 2.4.2 beta 14 and installed fine.
c) got IP alias functioning fine.
d) set up a virtual host (foo.com) on the machine (www.foo.com working fine).
e) set up the virtual ftp and the banner and root works fine.
f) I have the following definitions:

	/etc/passwd:
	foo:<passwd>:509:505:username:/web/./foo.com:/bin/false

	/etc/group:
	foo::509:foo
	client::505:foo

g) Here's the ftpaccess file:

===============ftpaccess==================
class   all   real,guest,anonymous  *
guestgroup client
email root@localhost
loginfails 5
readme  README*    login
readme  README*    cwd=*
message /welcome.msg            login
message .message                cwd=*
compress        yes             all
tar             yes             all
delete          yes             guest,real
chmod           no              guest,anonymous
overwrite       yes             guest
overwrite       no              anonymous
rename          yes             guest
rename          no              anonymous
log transfers anonymous,real,guest inbound,outbound
shutdown /etc/shutmsg
passwd-check rfc822 warn
virtual 1.2.3.4 banner /var/ftp/foo.com.welcome.txt
virtual 1.2.3.4 root /web/foo.com/
===============ftpaccess==================
h) the /web/foo.com is chown foo.client.
i) there is a bin, etc, lib dir in /web/foo.com with all the files
from /home/ftp/xxx copied in.

Problem:
a) When I do a ftp to foo.com, the banner comes up correctly.
b) Now, when I login as foo, I get in fine, but when I do a dir, I see
nothing.  I can put, get, dele and mkdir.  But I cannot see the listing.
c) However, instead of logging in as foo, I login as anonymous, I get
to see the dir listing.  Really bizarre.

Appreciate any help.
-- 
Harish Pillay                             	  [email-masked]
Singapore      *** Ask me about Linux *** http://home.pacific.net.sg/~harish

---

From: Michael Brennen <[email-masked]>
Date: Tue, 2 Sep 1997 08:25:46 -0500 (CDT)

Extremely FAQ.  Your external ls is busted.  See the guest howto and list
archives (below). 

   -- Michael

> to see the dir listing.  Really bizarre.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-14.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.