Subject: Passive Mode Xfers

From: Ade Wilkinson <[email-masked]>
Date: Thu, 28 Aug 1997 02:06:29 +0100 (BST)

Dear All,

Using wu-2.4.2-academ[BETA-13] on a FreeBSD 2.2 system, I have had 
several users report to me that they are able to upload files using
passive transfers, but not download them again.

They are using a program called "FXP" which apparently does direct
data transfers between two FTP servers allowing people to transfer
files at the speeds the two FTP servers are connected instead of 
limiting to their connection speed.

In order to achieve this, FXP uses passive transfers and
(apparently) is happy to transfer up at max. speed
but if they try to transfer -from- my system it uses their
connection speed.

Some people have suggested that it is because wu-ftpd doesn't
allow passive downloads, which sounds a little strange to me.
Could someone please advise me on what is going on and how
to enable passive xfers?

Regards, Ade.

-- 
Ade Wilkinson          |  "We took 70ml of ordinary tap water and placed it
Systems Administrator  |     inside this beaker.  We then took 70ml of rain
-----------------------|  water taken from the labratory roof and placed it
http://www.puffin.org/ |  in this beaker ... don't ask me why, we just did."

---

From: [email-masked] (Albert Lunde)
Date: Wed, 27 Aug 1997 21:21:29 CDT

> limiting to their connection speed.

There's a little used feature in the FTP protocols that allows a client to
set up third-party transfers, but I was under the impression
that it was disabled by security checks in wu-ftpd.

I don't completely understand this but I thought it was distinct
from passive mode transfers.

--
    Albert Lunde                      [email-masked]