Subject: Trouble setting up chroot'ed home directories

From: [email-masked] (Thomas B. Fox)
Date: Mon, 18 Aug 1997 09:24:00 -0700

I have searched all the resources that I can find online but have been
unable to find a difinitive guide to setting up chroot'ed home directories.
Can someone help me out?

I want to restrict my ftponly users to their home directories and not allow
them to browse up the filesystem.

Thanks in advance.

Thomas B. Fox - [email-masked]
  - Systems Administrator and Internet Services Manager
  - Oliver Design, Inc. - 5 Victor Sq. - Scotts Valley, CA 95066
  - (408) 438-0701 x252

---

From: Michael Brennen <[email-masked]>
Date: Mon, 18 Aug 1997 11:46:38 -0500 (CDT)

See the guest howto and other goodies below.

   -- Michael

> them to browse up the filesystem.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-14.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Bruno Rohee <[email-masked]>
Date: Mon, 18 Aug 1997 18:42:29 +0200

> them to browse up the filesystem.

in your ftpaccess file just add the line

guestgroup group to be chrooted

Users in groups "group" "to" "be" and "chrooted" wille be chrooted
in their homedirectory.

-- 
Bruno Rohee | Internet Way NOC