Subject: Re: ftpd , AIX 4.1.4 & timestamp

From: Joseph Matusiewicz <[email-masked]>
Date: 18 Jul 1997 08:52:38 -0400

Philippe,
     
     Perhaps my experience with wu-ftpd may help out.  The SETPROCTITLE 
     definition causes wu-ftpd to destroy all environmental variables in 
     AIX, including the TZ environment variable.  To get mine to give the 
     correct timestamp, I had to recompile after changing the line that 
     says:
     
        #define SETPROCTITLE
     
     TO

        #undef SETPROCTITLE

     I'm assuming that beta 13 will behave the same. 

     Hope this helps....

                                _
                             {(ojo)}
                              |\Q/|
joe matusiewicz               \/-\/
national weather service       | |
silver spring, md 20910       / /
301.713.0864 ext 174           \ \
[email-masked]    /__\

______________________________ Reply Separator _________________________________
Subject: ftpd , AIX 4.1.4 & timestamp
Author:  [email-masked] at EXTERNAL
Date:    7/18/97 7:49 AM

Bonjour a tous!
Hello all!
     
well I have just installed the beta13 version on my AIX 4.1.4 and it works well
 except that  hours and times (displayed by "dir" for instance) are GMT and not 
 NFT-1DFT as the rest of the AIX does.
     
I tried to copy /etc/environment in ~ftp/etc/environment but it was no success.
     
I also tried to set TZ in a .profile in ~ftp but it was the same (in fact I did
 not believe that it could be successful).
     
Thanks for help....
     
Philippe Guyot
CVF    Bordeaux France
+ 33 5 56 01 98 00

---

From: Philippe Guyot <[email-masked]>
Date: Wed, 30 Jul 1997 09:27:45 +-200

>> well I have just installed the beta13 version on my AIX 4.1.4 and it works well except that  hours and 
times (displayed by "dir" for instance) are GMT and not NFT-1DFT as the rest of the AIX does.
>> I also tried to set TZ in a .profile in ~ftp but it was the same (in fact I did not believe that it could 
be successful).

>I believe you need to set TZ in whatever process spawns ftp
>(e.g. in the parent of inetd).

well this is a thing that AIX is supposed to do, no ?????

and the ftpd from AIX does use the right timezone!

any ideas from AIX's users?

Ph. Guyot
C.V.F
Bordeaux (France)

---

From: Gilles Ciselet <[email-masked]>
Date: Wed, 30 Jul 1997 15:02:37 +0000

My beta13 works fine on AIX 4, and I did nothing special.
Try "ps axewww PID" to see theTZ variable.

---------------------- Forwarded by Gilles Ciselet/Belgium/IBM on 30/07/97
16:37 ---------------------------

        [email-masked]
        30/07/97 09:04
Please respond to [email-masked] @ internet

To: [email-masked] @ internet
cc:
Subject: TR: ftpd , AIX 4.1.4 & timestamp

>> well I have just installed the beta13 version on my AIX 4.1.4 and it works
well except that  hours and times (displayed by "dir" for instance) are GMT and
not NFT-1DFT as the rest of the AIX does. >> >> I tried to copy
/etc/environment in ~ftp/etc/environment but it was no success. >> >> I also
tried to set TZ in a .profile in ~ftp but it was the same (in fact I did not
believe that it could be successful).

Ph. Guyot
C.V.F
Bordeaux (France)