Subject: RE: inetd -r options on Solaris 2.5.1

From: "Roger A. Hanke" <[email-masked]>
Date: Sat, 26 Jul 1997 12:06:23 -0400

Dug this old message out after talking to my Sun support person the 
other day. He went into the solaris 2.5.1 source code and checked out
the inetd -r option usage. He confirmed it only applies to connectionless
protocols like UDP, not TCP. He has MR'd the inetd man page to make 
this clearer in the future. Has anyone seen the inetd looping error on
Solaris 2.5.1 to cast any doubts on his research?
	Thanx,
	Roger Hanke
	[email-masked] 

----------
From: 	Alain Magloire
Sent: 	Wednesday, April 30, 1997 5:47 PM
To: 	Trent
Cc: 	[email-masked]
Subject: 	Re: idle timeout

Salut A Vous, O Grand Manitou Trent !!

> 
> correctly.  Every few min (esp with high users) I have to hup inetd to
> keep it going.  I always get 
> inetd[123]: ftp/tcp server failing (looping), service terminated

you have a busy server :-)

on Solaris, and probably others, you can change this interval to
a higher count.

start inetd like this

inetd -r120 60

by default, the man page says 40 per min(-r40 60), grossly
not enough for a busy server.

On SunOS-4.x you have to apply a patch or compile one yourself
You'll find a usable version on GNU(inetutils.tar.gz) or in
the *BSD src.

> and I'm assuming that it is the result of too many requests coming in and

Yes, 

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!

---

From: Jon Stevens <[email-masked]>
Date: Sat, 26 Jul 97 12:37:21 -0700

"Roger A. Hanke" <[email-masked]> said the following at 7/26/97 
9:06 AM:

>Has anyone seen the inetd looping error on

Not sure if this helps at all...

I have seen it on SunOS 4.1.3 as a result of a lot of people checking 
email all at once via popperd. I got a patch (replacement) inetd that 
allowed for the -r option and that fixed the problem.

I haven't seen the problem on any of my 2.5.1 boxes although, we aren't 
using them for mail storage...

-jon

Jon (no h) S. Stevens - [email-masked]
<http://www.clearink.com/>
<http://www.clearink.com/fun_stuff/plugins/ch/>
<http://www.internetweather.com/>