Subject: dir problem with wu-ftp 2.4

From: Mark Rogov <[email-masked]>
Date: Mon, 21 Jul 1997 16:22:07 -0400 (EDT)

Hello!

I am experiencing a big problem/confusion.

I have wu-ftpd 2.4 installed on SunOS using all the regular settings in 
the ftpaccess file. Whenever the customer ftps in his directory is chrooted.
There is a comlete and nessesary structure within that chrooted directory":

drwxrwxr-x  7 mark     staff         512 Jul 18 12:37 ./
drwxrwxr-x 41 root     httpadmi     1536 Jul 20 13:50 ../
dr-xr-xr-x  2 root     ftpadmin      512 Feb  5 12:38 bin/
dr-xr-xr-x  2 root     ftpadmin      512 Jul 18 11:42 dev/
dr-xr-xr-x  2 root     ftpadmin      512 Jul 18 12:41 etc/
dr-xr-xr-x  3 root     ftpadmin      512 Feb  5 13:43 usr/
drwxr-xr-x  2 mark     ftptest       512 Jul 18 17:16 www.i3net.com/

the actual copy of the reglar and working ftp acct.
BUT! when FTP connection is established the dir() command does not work:

230 User mark logged in.  Access restrictions apply.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp>

it doesn't give any mistake, but it doesn't display any files either.
Since dir() doesn't work all my clients with windows ftp programms do not 
get the list of their files when they ftp in. They are all able to upload 
or download a file if the exact name is specified.

I have the latest gnu ls() inside that /bin directory and all other needed
files in usr/lib/

Please help ASAP.
Thank you.

-------------------------------------------------------------------------------
   \|
  --"-------\    Mark Rogov                || E-mail: [email-masked]
    | O      |   "ISDN Made Easy" TM       || HP:     http://idt.net/~marik
    |  \___o/    56 W. 22nd St. 10th Floor || TEL     212/228-7900
    |	|	 New York, NY 10010        || FAX     212/228-1152
    |   |        http://www.i3tele.com     ||  
                            "HEY, LIFE IS FULL OF SURPRISES!!!"  
-------------------------------------------------------------------------------

---

From: Michael Brennen <[email-masked]>
Date: Mon, 21 Jul 1997 15:39:42 -0500 (CDT)

Your external 'ls' is goofed up for some reason, either libraries,
or devices, or something.  See the guest howto and the FAQ for more info.
(below)

You really should consider upgrading to the latest beta for both security
and bug fix reason. 

   -- Michael

> ......

> or download a file if the exact name is specified.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Danny Calamaro <[email-masked]>
Date: Tue, 22 Jul 1997 00:01:57 +0200

Hi all,

Am have exactly the same problem. What ls are you using, the standard OS
one or the fileutils. Am using the fileutils-3.15.gz  It works fine with
ls only but not with ls -l which is what the windows uses. I have read
the FAQ etc, but havn't really seen anything on this. I have got a new
version of fileutils-3.16.gz, I'll try those and see. 

Any further advice would be welcomed  :-)

Danny

---

From: Mark Rogov <[email-masked]>
Date: Mon, 21 Jul 1997 18:45:25 -0400 (EDT)

> version of fileutils-3.16.gz, I'll try those and see. 
I am using fileutils-3.16.gz
No progress... 
However, one of the suggestions that i have got are about the libraries 
in /usr/lib.
I have ld.so and libc.so.1.9

If that is not enough where do I get missing?
Thank you.