Subject: Restricting filesystem to normal users

From: Joao Rochate <[email-masked]>
Date: Thu, 31 Jul 1997 14:23:48 +0100

HI..

I need to make the following:
* About 80 users on my server have $HOME/public_html dirs.
* They will update their Web pages by FTP using wu-ftpd.

The problem is that they have access to all the filesystem, even if it's
only with reading rights.

Is there a way to restrict them only to their $HOME dir or $HOME/public_html ?

Even if it's impossible, please let me know by EMail or by the list.
Thank you for the possible help.

                                Joao Rochate

-------------------------------------------------------
Joao Pedro Rochate         | EMail: [email-masked]
Servicos de Informatica    | URL: w3.ualg.pt/~jrochate
Universidade do Algarve    | Phone: +351 (0)89  800 961
8000 Gambelas - FARO       | ISDN:  +351 (0)89  860 125
P O R T U G A L     (pt)   | Mobile:+351 (0)936 660 662
-=[ http://www.ualg.pt ]=- | Fax:   +351 (0)89  860 129
-------------------------------------------------------
Eng. de Sistemas e Computacao - UCEH - Univ. do Algarve

---

From: Michael Brennen <[email-masked]>
Date: Thu, 31 Jul 1997 11:37:15 -0500 (CDT)

guest FTP; the howto and other resources are below.

   -- Michael

> Is there a way to restrict them only to their $HOME dir or $HOME/public_html ?

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.