Subject: GMT Time problem

From: [email-masked] (Jonathan Curtis)
Date: Tue, 22 Jul 1997 08:04:17 -0700

Hello ,

I recently installed wu-ftpd on an SGI Irix 5.3 server and 
I have found that it is listing files with the GMT and not the Local time
stamp (Eastern Standard Daylight Savings Time).

WU is probably standardized on GMT. But there is probably
some flag or code that can be modified. 

The only code that I found was the gmtime(); function in ~src/ftpcmd.y or .c
after a build. 
I tried changing it to localtime() but was un-successful.

I have version 2.4.2-beta-13.

Any fix for this...

Thanks,
Jonathan

---

From: Ayamura Kikuchi <[email-masked]>
Date: Tue, 22 Jul 1997 21:33:58 +0900

> some flag or code that can be modified. 

Recompile with SPT_TYPE set to SPT_NONE.

src/config/config.sgi:
#define SPT_TYPE SPT_NONE

--
Ayamura Kikuchi (Dept., of Medicine, Keio Univ., Japan)

---

From: Ayamura Kikuchi <[email-masked]>
Date: 22 Jul 1997 23:23:59 +0900

> I am having the same problem on Solaris 2.5.1 but the below solution
> does not have any effect.  Does anyone know what is needed to fix
> this problem on Solaris?

You may need to copy the appropriate zoneinfo file to the
~ftp/usr/share/lib/zoneinfo directory and the init file to the
~ftp/etc/default/init. Please also read the Solaris man page for in.ftpd(1).

FAQ about wu-ftpd
	http://www.hvu.nl/~koos/wu-ftpd-faq.html
WU-FTPD Resource Center
	http://www.landfield.com/wu-ftpd/