Subject: dir command produces no output

From: Rick Sailey <[email-masked]>
Date: Thu, 24 Jul 1997 14:34:48 -0400

I installed wu-ftpd 2.4 on Solaris 2.5.1 and everything works great
except there is no output returned with the dir command.  I used both
the Solaris /bin/ls and GUN ls binaries with the same results.  Anyone
have a possible solution??
-- 
-    -    -    -    -    -    -    -    -    -    -    -    -    -
Richard Sailey  ECS Sustaining Engineering, NASA Langley DAAC
(757) 864-7416  Hughes Information Technology Systems (HITS)
                2 South Wright St. (Bldg 1268C, Room 1306, MS 157D)
                Hampton, Virginia 23681-0001
email: [email-masked]    fax: (757) 864-9882 
-    -    -    -    -    -    -    -    -    -    -    -    -    -

---

From: Michael Brennen <[email-masked]>
Date: Thu, 24 Jul 1997 14:49:42 -0500 (CDT)

See the FAQ and guest howto.  Consider upgrading to the beta for bug and
security fix reasons. 

   -- Michael

> have a possible solution??

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Danny Calamaro <[email-masked]>
Date: Thu, 24 Jul 1997 21:55:46 +0200

I had the same problem a few days, you have to setup up the libs dev
etc, correctly, and it should work with either "ls"

If you use the GUN ls binaries which is how I'm using it you need to
setup the following.

/bin/ls

/dev/zero 		\
/dev/tcp 		 \ These you must create in a special way
/dev/udp 		 / Its described in the FAQ
/dev/ticotsord		/

/usr/lib/ld.so.1 
/usr/lib/libc.so.1
/usr/lib/libdl.so.1

This is what I've installed and its now working. 

Danny

---

From: Vidiot <[email-masked]>
Date: Thu, 24 Jul 1997 15:08:29 -0500 (CDT)

<See the FAQ and guest howto.  Consider upgrading to the beta for bug and
<security fix reasons. 
<
<   -- Michael
<
<On Thu, 24 Jul 1997, Rick Sailey wrote:
<
<> I installed wu-ftpd 2.4 on Solaris 2.5.1 and everything works great
<> except there is no output returned with the dir command.  I used both
<> the Solaris /bin/ls and GUN ls binaries with the same results.  Anyone
<> have a possible solution??
<
<
<This is the location for the latest wu-ftpd.  You can't see the
<directory contents, but get the file anyway.  It's there.
<
<ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z
<
<wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
<              OR
<              send mail to [email-masked]
<              with a subject line: send faq
<
<guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
<              OR
<              send mail to "[email-masked]"
<              (immediate autoresponder; subject does not matter)
<
<wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
<wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/
<
<There are additional security references in the above docs.

If you find the original Sun supplied man page ftpd, you will find a
script that is run that will set up the ftp area with all the necessary
files.  The problem is that the wu-ftpd install overwrites the Sun man page.
Hopefully that has been fixed.  The script will fix the dir problem.

MB
-- 
System Administrator - Finnigan FT/MS - Madison WI. URL:http://www.ftms.com/
e-mail: [email-masked]
phone: (608) 273-8262 ext: 612  fax: (608) 273-8719
Visit - URL:http://www.cdsnet.net/vidiot/  (Your link to Star Trek and UPN)

---

From: Mark Rogov <[email-masked]>
Date: Thu, 24 Jul 1997 15:39:55 -0400

I just had the same problem and it turned to be that one
of the libraries in /usr/lib/ was missing. try 
truss (or if you don't have it trace will work, too) /bin/ls
there you would see which libraries it needs.

>have a possible solution??

---------------------------------------------------------------------------

   \|                                     ||
  --"-------\   Mark Rogov                || E-mail: [email-masked]
    | O      |  "Internet Made Easy" TM   || HP:     http://idt.net/~marik
    |  \___o/   56 W. 22nd St. 10th Floor || TEL     212/228-7900
    |   |       New York, NY 10010        || FAX     212/228-1152
    |   |       http://www.i3tele.com     ||

                           "HEY, LIFE IS FULL OF SURPRISES!!!"
---------------------------------------------------------------------------