Subject: guest files and directories invisible (fwd)

From: Marta Ferreyra <[email-masked]>
Date: Mon, 7 Jul 1997 16:36:20 -0300 (ARST)

I send the mail below the last week and I could resolv the problem but I'm
not sure that is ok.
I had istalled wu-ftpd in a linux slackware 3.1 kernel 2.0.0 from march
distribution, I saw that all was as guest-howto say, so I tought that the
problem was in ls, so I copied the ls from the distribution of dicember
and happened the same ,with ls I couldn't see the files, so I copied in
/home/user/bin the ls from a old distribution that I was in another
computer (linux slackware 3.0 kernel 1.2.13) and now I can see the file, I
don't understand what is happening.
Why I need to copy a old ls in a new distribution to get see the files
with ls in a sesion of ftp???

I need your help

thanks in advance

------------------------------------------------------------------------
this is the mail that I send 

hello!!!

I had installed wu-ftpd-2.4.2-beta-13

User chroot()s correctly, but cannot see any of the files or directories.

when I do

ftp server_name I can see
Name (server:martaf):martaf
Password:
230 User martaf logged in. Access restrictions apply
Remote system type is UNIX
Using binary mode to transfer files.
ftp>ls
200 PORT command seccesful
150 Opening ASCII mode data connection for /bin/ls
226 Transfer Complete.
ftp>

and I can see the files of my directory, but I can get it if I know the
name of the file and I can put any file but I can see the files with ls

I say that chroot() is correctly because if I do for example
ftp>cd /etc
550 /etc: No such file or directory
ftp>cd /usr
550 /usr: No such file or directory
ftp>get /etc/passwd
550 /etc/passwd: No such file or directory

Please can anyone help me???

thanks in advance 

+-------------------------+
|         ARGENET         |
|   Ing. Marta Ferreyra   |
|  [email-masked]  |
+-------------------------+

---

From: Michael Brennen <[email-masked]>
Date: Mon, 7 Jul 1997 15:00:52 -0500 (CDT)

The old ls is probably statically linked.  The guest howto has more
details on this.

   -- Michael

---

From: Daniel Henry <[email-masked]>
Date: Mon, 07 Jul 1997 16:27:39 -0400

Also, check your bin, dev, lib files carefully.  I found in one
installation that I had typed 'Zero' instead of 'zero' when creating the
dev files,  and the only symptom was that 'ls' was producing no output upon
FTP login to the guest account (using WS_FTP).

>> with ls in a sesion of ftp???
Daniel Henry       U.S. Agency for International Development
Ph: 703.875.1207   Internet Data Services
Fx: 703.875.1718   <[email-masked]>