Subject: guest files and directories invisible

From: Marta Ferreyra <[email-masked]>
Date: Fri, 4 Jul 1997 17:27:33 -0300 (ARST)

hello!!!

I had installed wu-ftpd-2.4.2-beta-13

User chroot()s correctly, but cannot see any of the files or directories.

when I do

ftp server_name I can see
Name (server:martaf):martaf
Password:
230 User martaf logged in. Access restrictions apply
Remote system type is UNIX
Using binary mode to transfer files.
ftp>ls
200 PORT command seccesful
150 Opening ASCII mode data connection for /bin/ls
226 Transfer Complete.
ftp>

and I can see the files of my directory, but I can get it if I know the
name of the file and I can put any file but I can see the files with ls

I say that chroot() is correctly because if I do for example
ftp>cd /etc
550 /etc: No such file or directory
ftp>cd /usr
550 /usr: No such file or directory
ftp>get /etc/passwd
550 /etc/passwd: No such file or directory

Please can anyone help me???

thanks in advance 

+-------------------------+
|         ARGENET         |
|   Ing. Marta Ferreyra   |
|  [email-masked]  |
+-------------------------+

---

From: Michael Brennen <[email-masked]>
Date: Fri, 4 Jul 1997 16:18:21 -0500 (CDT)

Sounds like an ls problem.  The guest howto goes over how to set this up. 

   -- Michael

> User chroot()s correctly, but cannot see any of the files or directories.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd Resource Center:  http://www.landfield.com/wu-ftpd/
wu-ftpd list archive:     http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.