Subject: Ultra 5000/ Unknown user name after ~ (fwd)

From: [email-masked]
Date: Mon, 30 Jun 1997 12:10:19 -0700 (PDT)

Hello,

I'm new to this list, so I don't know if this is an old problem that was
already discussed but here it is.

I have installed wu-ftpd-2.4.2-beta-13,
all works as it should, anonymous and real.

but wile testing it I tryed to cd to a fake users account, and this is
what happens.

Connected to platoi.berkeley.edu.
220 platoi FTP server (Version wu-2.4.2-academ[BETA-13](1) Mon Jun 30
11:29:50 PDT 1997) ready.
Name (platoi:jakef): jakef
331 Password required for jakef.
Password:
230 User jakef logged in.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
226 Transfer complete.
251 bytes received in 0.02 seconds (12 Kbytes/s) 

ftp> cd ~jakeff
550 Unknown user name after ~
ftp> ls
421 Service not available, remote server has closed connection
ftp> 

after I get the 550 Unknow user, it sends a sig 11 to the ftpd.

messages shows only 
Jun 30 11:59:42 platoi ftpd[787]: exiting on signal 11

I take the fptd and run it on a Sparc Station5 and it dose not happen.

any one seen any thing like this befor?

TIA,

Jake-F

---

From: Scott Callaway <[email-masked]>
Date: Mon, 30 Jun 1997 12:52:02 -0700

(see below)
>any one seen any thing like this befor?

Dear Sir,

I am guessing that you need to copy /etc/group and /etc/passwd (or
equivalent) to ~ftp/etc/group and ~ftp/etc/passwd .

You can enter the following lines to your /etc/ftpaccess file
to protect these files:  Mine listed below.
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
# Protected files, not to be retrieved at any time!
noretrieve /etc/passwd /etc/group /etc/shadow /etc/pwd.db /etc/spwd.db core
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

If wu-ftpd really uses the /etc/passwd file for 'real' users, then it
is likely that what I am saying above is completely wrong.  But, it
is a place to start.  

(If someone else in the list knows if {or when} wu-ftp uses which files,
could you please let me know?)

Good luck,

-- Scott C.
______________________________________________________________________
  Scott Callaway         [email-masked]          619-231-2600
  Digigami Inc.,   624 Broadway  Suite 200,   San Diego,    CA.  92101
 1:1000               <http://www.digigami.com>
______________________________________________________________________

---

From: [email-masked]
Date: Mon, 30 Jun 1997 13:00:38 -0700 (PDT)

No, I dont think thats it, I have the files in place.

I thinks it's some thing with the ~realuser lookup, but it only happens on
the ultra.

thaks tho

jake