Subject: Re: your mail

From: [email-masked]
Date: Wed, 25 Jun 1997 13:37:15 -0400

I am having trouble compiling and then running beta13 on AIX release 4.1.4.
Below is compile sequence. Notice the WARNING message and then after the
asterics see the resulted try. The wwwtest machine(with the new beta13 ftpd
loaded) asks for a userid and then once that is entered, you get failure
with no intervening ask for a password.. Anyone else seen this, or did I
miss something.   Thanks Jim

make args are :
make opts are :

Linking Makefiles.

Making support library.
     cc -O2   -c getusershell.c
     cc -O2   -c fnmatch.c
     cc -O2   -c strcasestr.c
     cc -O2   -c strsep.c
     cc -O2   -c authuser.c
     cc -O2   -c strdup.c
     rm -f libsupport.a
     ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strsep.o
authuser.o strdup.o snprintf.c
     ranlib libsupport.a

Making ftpd.
     cc -O2 -I.. -I../support -L../support -c ftpd.c
    820  1500-010: (W) WARNING in main: Infinite loop.  Program may not
stop.
     yacc  ftpcmd.y
     mv y.tab.c ftpcmd.c
     cc -O2 -I.. -I../support -L../support -c ftpcmd.c
     cc -O2 -I.. -I../support -L../support -c glob.c
     cc -O2 -I.. -I../support -L../support -c logwtmp.c
     cc -O2 -I.. -I../support -L../support -c popen.c
     sh newvers.sh
     cc -O2 -I.. -I../support -L../support -c vers.c
     cc -O2 -I.. -I../support -L../support -c access.c
     cc -O2 -I.. -I../support -L../support -c extensions.c
     cc -O2 -I.. -I../support -L../support -c realpath.c
     cc -O2 -I.. -I../support -L../support -c acl.c
     cc -O2 -I.. -I../support -L../support -c private.c
     cc -O2 -I.. -I../support -L../support -c authenticate.c
     cc -O2 -I.. -I../support -L../support -c conversions.c
     cc -O2 -I.. -I../support -L../support -c hostacc.c
     cc -O2 -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o
logwtmp.o popen.o vers.o access.o  extensions.o  realpath.o acl.o private.o
 authenticate.o conversions.o hostacc.o  sigfix.c -lsupport -ls

Making ftpcount.
     cc -O2 -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsupport -ls

Making ftpshut.
     cc -O2 -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupport -ls

Making ckconfig.
     cc -O2 -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
bin/ftpcount: 4836 + 780 + 20 + 1551 = 7187
bin/ftpshut: 3088 + 948 + 16 + 1120 = 5172
bin/ftpwho: 4836 + 780 + 20 + 1551 = 7187
bin/ckconfig: 1476 + 1576 + 16 + 517 = 3585
Done

***************************************************************************
****

root@sybb /aixtools/wuftp/2.4.2.13b/wu-ftpd-2.4.2-beta-13 # ftp wwwtest
Connected to wwwtest.lex.lexmark.com.
220 wwwtest.lex.lexmark.com FTP server (Version wu-2.4.2-academ[BETA-13](1)
 Mon
Jun 23 14:46:03 EDT 1997) ready.
Name (wwwtest:root): root
530 User root access denied....
Login failed.
ftp>

---

From: Alexey Lef <[email-masked]>
Date: Wed, 25 Jun 1997 13:55:51 +22324502

Most likely you are missing /etc/shells, it is not there on AIX.

Alexey

---

From: Kent Landfield <[email-masked]>
Date: Wed, 25 Jun 1997 13:35:04 -0500 (CDT)

# Most likely you are missing /etc/shells, it is not there on AIX.

Or the user root is listed in the ftpusers file...

# > root@sybb /aixtools/wuftp/2.4.2.13b/wu-ftpd-2.4.2-beta-13 # ftp wwwtest
# > Connected to wwwtest.lex.lexmark.com.
# > 220 wwwtest.lex.lexmark.com FTP server (Version wu-2.4.2-academ[BETA-13](1)
# >  Mon
# > Jun 23 14:46:03 EDT 1997) ready.
# > Name (wwwtest:root): root
# > 530 User root access denied....
# > Login failed.
# > ftp>

-- 
Kent Landfield                        Phone: 1-817-545-2502             
The Landfield Group                   FAX:   1-817-545-7650             
Email: [email-masked]             http://www.landfield.com/
Please send comp.sources.misc related mail to [email-masked].
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/

---

From: Bill Pemberton <[email-masked]>
Date: Wed, 25 Jun 1997 14:37:52 -0400 (EDT)

> Most likely you are missing /etc/shells, it is not there on AIX.

And if compiled properly, nothing should need it to be there (the beta
has the code to get the valid shells the AIX way).....

-- 
Bill Pemberton                                 [email-masked]
ITC/Unix Systems                               [email-masked]
University of Virginia                         uunet!virginia!wfp5p