Subject: Problems with real login

From: "Tony D. Berry" <[email-masked]>
Date: Wed, 11 Jun 1997 15:10:40 -0500

I have been fighting with my Linux box for days now trying to secure my real FTP access. By real I mean valid users of the box but not shell users.

Everything is working fine except one thing. The users chroot variable, as specified in the /etc/passwd file (:/home/usr/./public_html:) is not working. The user starts in the correct directory (/home/user/public_html) but is allowed to cd /. This is a problem in my eyes. Is there something I am missing in the /etc/ftp* files?

Thank you in advance.

Tony D. Berry
Lafayette, LA

---

From: Henry-Pascal ELDIN <[email-masked]>
Date: Thu, 12 Jun 1997 12:52:34 +0200 (MET DST)

Hello,
> 
> I have been fighting with my Linux box for days now trying to secure my > real FTP access. By real I mean valid users of the box but not shell > users.
> 
> Everything is working fine except one thing. The users chroot variable, > as specified in the /etc/passwd file (:/home/usr/./public_html:) is not > working. The user starts in the correct directory > (/home/user/public_html) but is allowed to cd /. This is a problem in my > eyes. Is there something I am missing in the /etc/ftp* files?
> 

In /etc/ftpaccess add : guestgroup  <group of users>

-- 
Eldin Henry-Pascal	
Administration Systeme et Reseau de la Plateforme Internet du Cheylard
Syndicat Intercommunal à Vocation Unique des Inforoutes de l'Ardèche
		http://www.inforoutes-ardeche.fr