Subject: xferlog and syslog on Digital Unix

From: FTP Administrator <[email-masked]>
Date: Thu, 19 Jun 1997 11:28:30 +0200 (MET DST)

I've compiled the wuftpd 2.4 beta 13 on a Digital Unix 4.0B. 
I compiled it with a 'build osf'.

Everything works without to modify the sources but I have a couple of
problems:
 
1) The daemon.log in syslog.dated directory logs every command, but NOT
   always the xferlog file reports every RETR command. Why ?
2) The ftpwho strips away the most part of the calling hostname, like this:
   23897 ??       IW       0:00.04 ftpd: ht
   22753 ??       I        0:00.06 ftpd: pc
   22469 ??       S        0:00.27 ftpd: ph
   23982 ??       IW       0:00.05 ftpd: pc
How can I fix this ?

Thank you in advance,
  
Massimo Gais
 ----
FTP Administrator                                        <[email-masked]>
C.D.S. - University "Federico II" of Naples (Italy)
 
                           "640K ought to be enough for anybody." 
                                            --  Bill Gates, 1981

---

From: FTP Administrator <[email-masked]>
Date: Thu, 19 Jun 1997 12:10:31 +0200 (MET DST)

On Thu, 19 Jun 1997, Gernot Salzer wrote:

> 
> [email-masked] wrote:
> > 
>                               ^^^
> Maybe you should try "build dec" instead, which is for DU 3.X and higher.
> I don't know whether this will solve your problems, but at least you
> can be sure that you compiled it the right way ...
> 
> Regards, Gernot
> 
'build dec' is meant for  c2 enhanced security. I don't use it.

Massimo Gais
----

---

From: FTP Administrator <[email-masked]>
Date: Fri, 20 Jun 1997 08:13:42 +0200 (MET DST)

On Thu, 19 Jun 1997, Daniel Clar wrote:

> It seems to me that you have to say build dec instead of osf.
> And there is another problem with wu-ftpd for DU : you have to modify the 
> makefile to include syslog.c instaed of using the standard syslog mechanism.
> 
> I've sent a mail on this subject some monthes ago. Perharps you'll find it 
> or send me another e-mail.
> 
> Daniel
> 
Yes, I have it. It's included also in the wuftpd.faq.
But I was thinking that beta13 won't need anymore (because I could see
ftp commands (CWD, RETR, STOR, etc.) logged on syslog.dated/*/daemon.log

About the build dec/osf, beacuse my machine doesn't run C2 security, I was
thinking I should choose 'build osf' (the config file are different only
for a #define SECUREOSF). Any explaination from source authors is welcome.

Thank you in advance,

Massimo Gais
 ----