Subject: dir

From: Wood <[email-masked]>
Date: Tue, 17 Jun 1997 13:49:44 -0700 (PDT)

Hello

I'm new to this list and have just installed wu-ftpd on this SunOS 4.1.3 machine.  I can't get "dir" to work.  While the "ls" command shows the files in the directory, the "dir" command gives the following:
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
Any ideas of what i did wrong in the installation or configuring?

Thanks for any help.

Lee

---

From: Kent Landfield <[email-masked]>
Date: Tue, 17 Jun 1997 16:27:06 -0500 (CDT)

# I'm new to this list and have just installed wu-ftpd on this SunOS 4.1.3 machine.  I can't get "dir" to work.  While the "ls" command shows the files in the directory, the "dir" command gives the following:
# 200 PORT command successful.
# 150 Opening ASCII mode data connection for /bin/ls.
# 226 Transfer complete.
# Any ideas of what i did wrong in the installation or configuring?
# 
# Thanks for any help.
# 
Lee,

The ls command is not configured correctly.  Is there a bin/ls command
in the anonymous ftp directory ?  Are the required shared libraries also
in the same hierarchy ?

There is real information on how to do this in the WU-FTPD Resource Center

	 http://www.landfield.com/wu-ftpd/

-- 
Kent Landfield                        Phone: 1-817-545-2502             
The Landfield Group                   FAX:   1-817-545-7650             
Email: [email-masked]             http://www.landfield.com/
Please send comp.sources.misc related mail to [email-masked].
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/

---

From: "Andre Merten" <[email-masked]>
Date: Wed, 18 Jun 1997 18:28:40 +0200

> Any ideas of what i did wrong in the installation or configuring?
Hi, 

maybe you got the problem with the static-linked "ls". (I had the same
problem only a couply of weeks ago).

What you need is one copy of an static-linked "ls-binary" in evry
home-directory, because the "ls" which is normally used is typically in
a directory above the root directoy of restricted users.

good luck!

Sincerly

Andre  
-- 
Andre Merten, mediaWays, An der Autobahn, 33311 Guetersloh
Tel.: +49 (0) 5241/80-7686
Fax: +49 (0) 5241/80-90561
e-mail: [email-masked]