Subject: Problem compiling beta 13

From: "P. Kearney III" <[email-masked]>
Date: Tue, 17 Jun 1997 20:54:02 -0400

I'm trying to compile 2.4.2b13 on a Sun 4.1.x machine and it won't compile.  
when I di ./build s41, I keep getting:

Making support library.
cc -g  -c snprintf.c
"snprintf.c", line 95: syntax error at or near variable name "size_t"
*** Error code 1
make: Fatal error: Command failed for target `snprintf.o'

Anyone have any ideas?  Do I have a path incorrectly defined maybe?

-phil

----------------------------------------------------------------------------
Philip Kearney III                mailto:[email-masked] 
Sr. Software Engineer             mailto:[email-masked]
System Administrator              finger [email-masked] for my PGP key
Ascend Communications, Inc.       
Client Software Engineering Group             
----------------------------------------------------------------------------

---

From: Mike Garner <[email-masked]>
Date: Wed, 18 Jun 1997 09:44:56 -0400

I had to make two changes to build the vanilla version of wuftpd-2.4.2-beta-13 
on SunOS 4.1.3.
One was to add -Dconst= to CFLAGS in src/Makefile. The other was the following
changes to support/snprintf.c:
 
*** snprintf.c  Mon Mar  3 17:55:01 1997
--- snprintf.c.orig     Tue Mar  4 15:20:53 1997
***************
*** 91,98 ****
  # else
  snprintf(str, count, fmt, va_alist)
        char *str;
!       int count;
!       char *fmt;
        va_dcl
  #endif
  {
--- 91,98 ----
  # else
  snprintf(str, count, fmt, va_alist)
        char *str;
!       size_t count;
!       const char *fmt;
        va_dcl
  #endif
  {

-- 
========================================================================
 Mike Garner                      |  Fax:    301-918-8154
 email: [email-masked] |  Phone:  301-918-1989
   NASA Automated Incident Response Capability (NASIRC)