Subject: RE: Problems with anonymous login

From: "Manley, Jim W" <[email-masked]>
Date: Wed, 11 Jun 1997 10:32:23 -0500

I have two entries in inetd.conf:

#ftp    stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd
ftp     stream  tcp     nowait  root    /usr/local/etc/ftpd     ftpd
-t300 -T300 -u022 -L -o

The entry for in.ftpd is the standard Solaris ftpd.

The other entry is the wu-ftpd.  My ftpaccess file is set up to disallow
incoming
file transfers.

Jim Manley
LMTAS

> ----------
> From: 	Paul S. Bentivegna[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Wednesday, June 11, 1997 10:02 AM
> To: 	[email-masked]'
> Subject: 	Re: Problems with anonymous login
> 
> Take a look at the /etc/inetd.conf file. I have:
> ftp  stream  tcp     nowait  root    /usr/sbin/in.ftpd  in.ftpd
> -liou022
> 
> HTH
> 
> Paul
> 
> /-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\
> - Paul S. Bentivegna -- Road Runner Network Engineer          |
> \ Time Warner Communications -- Columbus, OH                  /
> | Web:      http://www.twcol.com   or http://columbus.rr.com  -
> / E-Mail:   [email-masked]                                    \
> - FTP:      ftp.twcol.com/incoming                            |
> \|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/
> 
> 
> On Wed, 11 Jun 1997, Manley, Jim W wrote:
> 
> > I recently installed the latest version of wu-ftpd on a Solaris
> 2.5.1
> > box.  
> > I followed all the instructions in the README files and the O'Reilly
> > book.  
> > When I attempt to login to the server, it throws me out with an
> error
> > about 
> > the server shutting down.
> > 
> > I've looked at everything I can find but nothing looks wrong.
> > 
> > Any ideas?
> > 
> > Jim Manley
> > LMTAS
> > 
> > 
>

---

From: "Steven K. Buehler" <[email-masked]>
Date: Wed, 11 Jun 1997 13:55:42 -0500

>The other entry is the wu-ftpd.  My ftpaccess file is set up to disallow

If you want to get the ftpaccess file to disallow incoming file transfers, you have to use the file first.  You must change your line in the inetd.conf to use it like this:
ftp     stream  tcp     nowait  root    /usr/local/etc/ftpd     ftpd
-a -t300 -T300 -u022 -L -o
Notice the new addition of "-a"?  Without that, wu-ftpd won't even read the ftpaccess file.

======================================================
Steven K. Buehler
S & B Computers
Rockford Illinois, USA
Phone: 815-398-7169
Fax: 815-398-7266
======================================================