Subject: wuftpd configuration files

From: [email-masked] (Jose Monteiro)
Date: Mon, 16 Jun 1997 08:32:33 GMT

Hi,

I'm having a little problem installing wuftpd in FreeBSD 2.1.7.

urano@cvmicro$ ftp cvmicro 
Connected to cvmicro.telenet.pt.
220 cvmicro.telenet.pt FTP server (Version wu-2.4.2-academ[BETA-13](1)
Fri Jun 6 18:25:53 WET DST 1997) ready.
Name (cvmicro:urano): 
530 User urano access denied...(bad shell)
ftp: Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> 

My /usr/local/etc/ftpaccess file is properly configured to allow real
accounts and user urano is in the ftpusers file.

Can anybody help me with this problem?

Thanks

José Monteiro

*------José Monteiro <[email-masked]>------*
|      TELENET - Serviços de Telecomunicações S.A.      |
|       Tel:+351 1 3139190    Fax:+351 1 3541988        |
| Finger [email-masked] or search key servers |
|                 for my PGP public key                 |
*-------------------------------------------------------*

---

From: "P. Kearney III" <[email-masked]>
Date: Tue, 17 Jun 1997 20:14:57 -0400

On Mon, Jun 16, 1997 at 4:32:33 AM, [email-masked] (Jose 

> I'm having a little problem installing wuftpd in FreeBSD 2.1.7. 

[SNIP]

> Can anybody help me with this problem? 

Ummm...in "INSTALL" right at the beginning of the installation instructions it 
states:

    _PATH_FTPUSERS  "/etc/ftpusers"
        The file that lists users that can never ftp in.  Usually contains
        root and all usernames not connected to a real person (eg. bin, sync,
        nobody, etc.)

If you want urano NEVER to be able to log into the server, then you want him 
in ftpusers, but since you want him to be able to log in, I'd remove him from 
ftpusers and see if that helps.

-phil

----------------------------------------------------------------------------
Philip Kearney III                mailto:[email-masked] 
Sr. Software Engineer             mailto:[email-masked]
System Administrator              finger [email-masked] for my PGP key
Ascend Communications, Inc.       
Client Software Engineering Group             
----------------------------------------------------------------------------