Subject: SITE GROUP problem

From: [email-masked] (Andreas Szameit)
Date: Thu, 12 Jun 1997 15:10:09 +0200

Hi,

I'm using WU-FTP 2.4 in a Solaris 2.5 environment running on a SPARCserver10
and the nameservices is NIS.
All anonymous things work well, but now I've configured the ftp-server
to let the user change the group.

1.  build the ftpaccess:

standard from the WU distribution

2.  build a ftpgroups with one entry:

1234567-890:bhPiFnux0KgeM:ftpusers

2.  build a group in the /etc/group with the appropriated password copied from
    teh /etc/passwd

/etc/group:
ftpusers:bhPiFnux0KgeM:9998:

/etc/passwd:
ftpusers:x:9998:9998:FTP anonymous:/export/ftp/./:/bin/csh

/etc/shadow:
ftpusers:bhPiFnux0KgeM:10022::::::

3.  running ckconfig, all is OK

Checking _PATH_FTPUSERS :: /usr/local/etc/ftpusers
ok.

Checking _PATH_FTPACCESS :: /usr/local/etc/ftpaccess
ok.

Checking _PATH_PIDNAMES :: /usr/local/daemon/ftpd/ftp.pids-%s
ok.

Checking _PATH_CVT :: /usr/local/etc/ftpconversions
ok.

Checking _PATH_XFERLOG :: /usr/adm/xferlog
ok.

Checking _PATH_PRIVATE :: /usr/local/etc/ftpgroups
ok.

Checking _PATH_FTPHOSTS :: /usr/local/etc/ftphosts
ok.

4.  reload the config files with kill -HUP on the inetd

5.  allways I try to "quote site group 1234567-890"
       and           "quote site gpass password"

    I get the following message:

230-
230 Guest login ok, access restrictions apply.
ftp> quote site group 1234567-890
200 Request for access to group 1234567-890 accepted.
ftp> quote site gpass password
530 Group access request incorrect.
ftp> 

6.  a second problem is that no messages are logged in the
    syslog file.

    Here is an except from the trussed ftpd and it shows me that 
    there is a problem opening the /etc/syslog.pid  but if I do
    a 

root@ctbse153 1011# cat /etc/syslog.pid	
22572
root@ctbse153 1012# 

    from the shell I can open it.

4352:   read(0, " Q U I T\r\n", 8192)                   = 6
4352:   alarm(0)                                        = 899
4352:   write(1, " 2 2 1   G o o d b y e .".., 14)      = 14
4352:   seteuid(0)                                      = 0
4352:   fstat(9, 0xEFFFF8B8)                            = 0
4352:   getpid()                                        = 4352 [4351]
4352:   time()                                          = 866120641
4352:   write(9, "\0\0\0\0\0\0\0\0 f t p\0".., 36)      = 36
4352:   time()                                          = 866120641
4352:   getpid()                                        = 4352 [4351]
4352:   open("/etc/syslog.pid", O_RDONLY)               Err#2 ENOENT
4352:   close(10)                                       = 0
4352:   fcntl(7, F_SETLK, 0xEFFFE138)                   = 0
4352:   getpid()                                        = 4352 [4351]
4352:   lseek(7, 0, SEEK_SET)                           = 0
4352:   read(7, "\0\0\0\0\0\0\0\0\0\0\0\0".., 4096)     = 4096
4352:   kill(4352, SIG#0)                               = 0
4352:   lseek(7, 0, SEEK_SET)                           = 0
4352:   write(7, "\0\0\0\0\0\0\0\0\0\0\0\0".., 4096)    = 4096
4352:   fcntl(7, F_SETLK, 0xEFFFE138)                   = 0
4352:   close(7)                                        = 0
4352:   _exit(0)

Where is the error of logic and
have anyone an answer or a solution to my problem?

regards

---------------------------------------------------------------------------
| Andreas Szameit         | Network & System    | Voice: +49 30 6104 5460 |
| Cordless Technology A/S | Administration      | FAX:   +49 30 6104 4234 |
| Branch Office Berlin    |-----------------------------------------------|
| A DeTeWe Group Company  | WWW:        http://www.detewe.de              |
| Koepenicker Str. 180    | E-MAIL:     [email-masked]         |
| D-10997 Berlin          | COMPUSERVE: 100434,1610                       |
| Germany                 | X.400:      --                                |
------------------------\|||/----------------------------------------------
                          O
If a packet hits a pocket on a socket on a port
& the bus is interrupted as a very last resort
& the memory address makes your processes abort
then the socket packet pocket has an error to report!

---

From: [email-masked] (Andreas Szameit)
Date: Fri, 13 Jun 1997 07:06:40 +0200

> From [email-masked] Thu Jun 12 18:02:57 1997
> From: [email-masked]
> Comments: Authenticated sender is <[email-masked]>
> To: [email-masked]
> Date: Thu, 12 Jun 1997 20:01:37 +0300
> MIME-Version: 1.0
> Content-transfer-encoding: 7BIT
> Subject: Re: SITE GROUP problem
> Priority: normal
> X-mailer: Pegasus Mail for Win32 (v2.53/R1)
> 
> > Date:          Thu, 12 Jun 1997 15:10:09 +0200
> > Reply-to:      [email-masked]
> > From:          [email-masked] (Andreas Szameit)
> > To:            [email-masked]
> > Subject:       SITE GROUP problem
> 

Hi,

> Hello there,
> did you restart the demon after the changes were made?

which daemon do you mean, the ftpd will be started bei the inetd and
inetd was restarted after changing the conf-files.

> Did you enable the private directive in the ftpaccess file?
Yes, I added a

privat yes

to the ftpaccess file.

> If you use vanilla wu-ftpd 2.4 I would recommend you to move to the latest
> version, i.e. 2.4.2 beta 13.

Yes, I have wu-ftpd 2.4 running, I wil try the beta version.

> You should start the demon with -d option to enable logging. Refer to ftpd man
> page for details.

Yes, I start the ftpd with -d option, but nothing happend.

> 
> The feature you have problem with DOES work. My users change group passwd with 
> no problem. I'm running Solaris 2.5 as you are.
> 
Do you have the ftpd daemon running permanently or do you start them by the inetd ?

> Let me know if you problem persists.
> 
> Regards,
> Serge Bezzubov <[email-masked]>
> YNC, Yarosalvl, Russia
> Serge Bezzubov <[email-masked]>
> YNC, Yaroslavl, Russia
> 

rgs
                          O