Subject: Re: FTP password cracking

From: "Mona Wong" <[email-masked]>
Date: Mon, 2 Jun 1997 12:47:14 -0700

> # But with Beta 11 version at least (and I strongly suspect all versions) if
you
> # enter a "garbage" user name you get the following response:
> #
> # 530 User garbage access denied....
> # Login failed.
>
> I tried that with the Beta-13 version I run and did not get the same results.
> It was asking for a password every time.

	Hmm, I have Beta-13 and it didn't ask for password when I entered an
invalid account:

Name (alex.ucsd.edu:mona): garbage
530 User garbage access denied....
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.

Mona

-- 
===============================================================
Mona Wong, Programmer & Web Administrator
National Center for Microscopy and Imaging Research
University of California, San Diego
http://www-ncmir.ucsd.edu
===============================================================

---

From: Kent Landfield <[email-masked]>
Date: Mon, 2 Jun 1997 15:15:01 -0500 (CDT)

# > # But with Beta 11 version at least (and I strongly suspect all versions) if
# you
# > # enter a "garbage" user name you get the following response:
# > #
# > # 530 User garbage access denied....
# > # Login failed.
# >
# > I tried that with the Beta-13 version I run and did not get the same results.
# > It was asking for a password every time.
# 
# 	Hmm, I have Beta-13 and it didn't ask for password when I entered an
# invalid account:
# 
# Name (alex.ucsd.edu:mona): garbage
# 530 User garbage access denied....
# Login failed.
# Remote system type is UNIX.
# Using binary mode to transfer files.

This must be a compiled features or configuration "thing".

220 rkive FTP server (Version wu-2.4.2-academ[BETA-13](1) Thu May 15 12:05:17 CDT 1997) ready.
Name (ftp.landfield.com:kent): garbage
331 Password required for garbage.
Password:
530 Login incorrect.
Login failed.
ftp> 

There is no 'garbage' user account here.  I'd really like to see what the
differences are...  Are you using the HOST_ACCESS code ? ANON_ONLY code ?
What systems are you running this on ? If you would not mind sending me
your config.h I'd be willing to investigate this tonight.  Bottom line
is that this is not desirable behavior. 

-- 
Kent Landfield                        Phone: 1-817-545-2502             
The Landfield Group                   FAX:   1-817-545-7650             
Email: [email-masked]             http://www.landfield.com/
Please send comp.sources.misc related mail to [email-masked].
Search the Usenet Hypertext FAQ Archive at http://www.faqs.org/faqs/