Subject: Wu-ftpd installation

From: [email-masked]
Date: Tue, 6 May 1997 14:01:29 -0400

I tried installing wu-ftpd 2.4, on PC running FreeBSD 2.2.1, per the
    INSTALL instructions.  I tried both build bsd and build gen.  Below is the
    output of the build.  Any help would be appreciated.
    
    Bobby Mathis
    Information Technology Group
    
$ ./build bsd
make args are : 
make opts are : 

Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
cc -O -DDEBUG   -c ftw.c
ftw.c: In function `chwalk':
ftw.c:187: conflicting types for `malloc'
/usr/include/stdlib.h:98: previous declaration of `malloc'
*** Error code 1

Stop.

Making ftpd.
cc -O -DDEBUG -I.. -I../support -L../support -c ftpd.c
ftpd.c:143: conflicting types for `realpath'
/usr/include/stdlib.h:167: previous declaration of `realpath'
*** Error code 1

Stop.

Making ftpcount.
cc -O -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsup
port
cc: vers.o: No such file or directory
*** Error code 1

Stop.

Making ftpshut.
cc -O -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsuppo
rt
cc: vers.o: No such file or directory
*** Error code 1

Stop.

Making ckconfig.
`ckconfig' is up to date.
ln: ckconfig: File exists

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex
4096    4096    0       8192    2000    bin/ckconfig
Done

---

From: mbyrne <[email-masked]>
Date: Tue, 06 May 1997 22:20:25 -0400

> 4096    4096    0       8192    2000    bin/ckconfig
You might want to check out www.freebsd.org/ports/.  If you obtain the
Wu-ftpd from this site and follow the "ports" instructions, you should
be all set.   ---mbyrne 
-- 
qeqsxx
q

---

From: Perry Rovers <[email-masked]>
Date: 8 May 1997 14:03:22 GMT

Pink elephants with an attitude inspired [email-masked] to tell garfield.mail.wu-ftpd:
:     
:     I tried installing wu-ftpd 2.4, on PC running FreeBSD 2.2.1, per the
:     INSTALL instructions.  I tried both build bsd and build gen.  Below is the
:     output of the build.  Any help would be appreciated.
     
: $ ./build bsd

Tried ./build fbs instead?

-- 
Perry Rovers ([email-masked])