Subject: Re: syslog on solaris 2.5.1

From: "Sergey A. Mukhin" <[email-masked]>
Date: Wed, 14 May 1997 18:41:35 +0400 (MSD)

I have had the same problem using syslog at 5.5.1.  Looks like
syslogd writes to file only if the file already exists.

Try:

cp /dev/null /var/log/daemon

and then HUP syslogd.

Kind regards,

Sergey.

> Date: Wed, 14 May 1997 10:26:19 -0400
> From: "Roger A. Hanke" <[email-masked]>
> Cc: "'WUFTPD List'" <[email-masked]>
> 
> Darci,
>  I have not tried going to a different file from the standard syslogd one.
> But my understanding is that WUFTPD is just using the system syslogd
> facility so there is nothing that needs to be changed with it.
>  The only thing I can suggest is the usual to make sure that syslogd
> should be able to write to the new location but since it runs as root this
> shouldnt be an issue. Perhaps some of the other list folk who were kind
> enough to send out the original syslogd information which I forwarded
> on to you might have some thoughts on this?
> 	Roger Hanke
> 
> ----------
> From: 	Paradise Cowgirl[SMTP:[email-masked]]
> Sent: 	Tuesday, May 13, 1997 8:20 PM
> To: 	rah@lynxhub
> Subject: 	syslog on solaris 2.5.1
> 
> 
> Roger,
> 
> Darci, here, sometime keeper of the How-To Guide for wu-ftpd on
> Solaris :-)
> 
> I included your entry regarding wu-ftpd logging in that document and now I
> have questions. I'd like to have most daemon messages (info, notice, and
> debug put into any other file BUT /var/adm/messages. I've updated my
> syslog.conf file to include:
> 
> daemon.info;daemon.notice;daemon.debug          /var/log/daemon
> 
> Additional daemon entries (that I have no control over) are:
> 
> *.alert;kern.err;daemon.err;user.none           operator
> daemon.notice                   /dev/console
> daemon.notice                   /nsr/logs/messages
> daemon.notice                   operator
> 
> 
> I've HUPped syslogd and while messages are not longer showing up in
> /var/adm/messages, they don't appear to be showing up in /var/log/daemon
> either. Any suggestions? Any help you could provide would be GREATLY
> appreciated! I'm sure I'm missing something obvious but after reading
> the Solaris FAQ and review the wu-ftpd FAQs, I can't figure out what.
> 
> (Do I need to recompile wu-ftpd with some other PATH defined? The only
> reference I could find was to XFERLOG, which is working fine)
> 
> Thanks!!
> 
> Regards,
> Darci Chapman
> 
> 
> 
> 
> 

-- 
------------------------------------------------------------------------
    Sergey A. Mukhin			|    [email-masked]
    Network Administrator		|    http://violet.rosnet.ru/
    Russian Telecommunications Network	|    Tel: + 7 095 206 62 15
    Moscow, Russia			|	  + 7 095 755 85 88
------------------------------------------------------------------------
*     If you can't learn do it well learn to enjoy doing it badly.     *
------------------------------------------------------------------------

---

From: "Forrest Aldrich" <[email-masked]>
Date: Wed, 14 May 1997 07:59:56 PDT

Look at <sys/syslog.h> for the LOG_LOCAL definitions.  I use one of them to 
place all wuftpd logging into one file.  Works very well.

Forrie

---------------------------------------------------------
Get Your *Web-Based* Free Email at http://www.hotmail.com
---------------------------------------------------------