Subject: guest account

From: "C. Lisboa" <[email-masked]>
Date: Mon, 26 May 1997 03:19:38 +0100

I am trying to setup guestgroup/account but couldn't figure that out. Real
and Anonymous are working ok. What am i doing wrong? I hope you can help me.
Thank you,
Carlos

FTP server (Version wu-2.4.2-academ[BETA-13]
----------------------------------------
/etc/passwd
ftp:*:14:50:FTP User:/home/ftp:
test:RdeA0ny6GNNDI:15:51:Guest:/ftp/./incoming:/etc/ftponly
----------------------------------------
/etc/group
ftp::50:
ftponly::51:
----------------------------------------
/etc/ftpaccess
class   local   real,guest,anonymous  *.edo.net 0.0.0.0
class   remote  real,guest,anonymous  *

guestgroup ftponly
----------------------------------------
[root@ns1 /etc]# ftp edo.net
Connected to edo.net.
220 ns1.edo.net FTP server (Version wu-2.4.2-academ[BETA-13](1) Sun Mar 30
16:46:32 EST 1997) ready.
Name (edo.net:carlos): test
331 Password required for test.
Password:
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> 
----------------------------------------
The passwd (test*passwd) is ok

[root@ns1 /etc]# telnet edo.net
Trying 208.132.225.99...
Connected to edo.net.
Escape character is '^]'.

Red Hat Linux release 4.0 (Colgate)
Kernel 2.0.18 on an i486
login: test
Password: 
Last login: Sun May 25 23:47:22 from ns1
No directory /ftp/./incoming!
Logging in with home = "/".
login: couldn't exec shell script: No such file or directory.
Connection closed by foreign host.

---

From: Michael Brennen <[email-masked]>
Date: Mon, 26 May 1997 07:45:11 -0500 (CDT)

What is the error message shown in the system log after this failure?

   -- Michael

On Mon, 26 May 1997, C. Lisboa wrote:

> ....

---

From: Wensong Zhang <[email-masked]>
Date: Mon, 26 May 1997 23:01:19 +0800 (HKT)

Hi all,

Sorry to ask a novice-sounding questions here. :)

We have SUN Enterprise 5000, which has 22 disks of 4G each. We want to use
a few disks to build a ftp server via wu-ftpd. As with anonymous users, it
is not allowed to cd symbolic links cross devices, and hard links are not
allowed either cross different devices. I don't want to mount the disks to
some points under ftp home directory directly, because there will be some
lost+found directory. I don't want to mount the directories of the disks
to points under ftp home directory via NFS. So, how can i build a ftp
server on different disk partitions?

Any instruction? Thanks a lot in advance,

Wensong

---

From: David Berard <[email-masked]>
Date: Mon, 26 May 1997 17:22:40 +0200 (CEST)

Hello,

> Any instruction? Thanks a lot in advance,

You can use the meta-device under Solaris.
With this, you can concatenate different disk into a logical one.

David.

---

From: "Javier Puche. CSIC RedIRIS" <[email-masked]>
Date: Mon, 26 May 1997 17:45:56 +0200 (MET DST)

Hi,

> server on different disk partitions?

You have to options (with Solaris):

First one: mount the disks wherever you want and then mount some
directories as loopback file systems (read only or whatever option you
want) to other directories under the ftp structure.

Second one: use the Online Disk Suite software that comes with the
Solaris distributions CDs and create a metadevice ....

Regards,

Javier Puche.