Subject: ftp tree ownership and permissions

From: Sara Hopkins <[email-masked]>
Date: Wed, 14 May 1997 19:33:18 +0100

Dear All,

I would like to know the answers to the following:

1) I would like to have a "real user" (ie. not root) maintaining 
my ftp site (ie. uploading files into ~ftp/pub from another machine).  
What should the ownership, group and permissions be on the directories 
in the basic ~ftp directory tree?  What group should this user 
be in?

2) Is it a bad idea to have a real user maintaining the site?  
Should it be maintained by root instead?

I'm sorry if these are FAQs.  My justification is that all the 
documents I can find that address these issues contradict one another 
and are often quite vague.  Please don't misunderstand: I don't want 
to flame those who produced the documentation, but much of it is a 
few years old, and would benefit from being tidied and updated.

Sara

Sara Hopkins                          [email-masked]
3L Ltd                            http://threeL.co.uk
86/92 Causewayside              Tel: +44 131 662 4333
Edinburgh, EH9 1PY, UK.         Fax: +44 131 662 4556

---

From: Alain Magloire <[email-masked]>
Date: Wed, 14 May 1997 15:22:19 -0400 (EDT)

> Dear All,

dear you

> in the basic ~ftp directory tree?  What group should this user 

~ftp should be own by root along with ~ftp/{etc,usr,lib,dev}
with the proper file modes(see the faq, or your man page).

~ftp/pub is not special. It's special from the fact that
is the "standard" place, it's part of the Net community conscious.
You can always chown(1) ~ftp/pub to that user and let him do the maintainance.

The last problem is pub incoming. There is a small race condition
because of the fchow(2). Change ftpaccess and move incoming to
~ftp/incoming or leave with it if you trust the user.

> Should it be maintained by root instead?

IMHO, no.
I have a very large community of users and delegating
tasks is my only way out. Anyway it's much better
to give one a part of the hier. then to share root access
with 30 users .. no ?

> few years old, and would benefit from being tidied and updated.

Don't be too hard there is so much hours in a day
and so few people can afford to spare them.

take a look at:
Archive-name: computer-security/anonymous-ftp-faq
Post-Frequency: monthly
Last-modified: 1996/7/16
Version: 3.0
Web: http://www.iss.net/
Christopher William Klaus 

or the FAQ:
http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!