Subject: Trouble with making ~wu-ftp an NFS mount point.

From: Clinton Fisher <[email-masked]>
Date: Wed, 14 May 1997 13:55:54 -0400

>Two questions,
>1.  Where do I find the FAQ and similar information?
>
>2.  Has anyone set up wu-ftpd where the ftp home directory is nfs mounted
>from another system.  I seem to have trouble creating my device files (tcp,
>udp, zero, tico...) on the nfs mount.
>
>The other system happens to be an SGI system and the one I use mknod on is a
>SUN system.  I run
>
>	mknod tcp c 11 42
>
>I get
>
>	crw-r--r--   1 root     other    511, 42 May 14 13:22 tcp
>
>The error that happens is "cannot create socket, bad file number".  It works
>when the ~ftp/dev is local (I guess this is my solution).
>
>- Clinton Fisher
>
>

---

From: Alain Magloire <[email-masked]>
Date: Wed, 14 May 1997 14:55:55 -0400 (EDT)

: Clinton Fisher
> >1.  Where do I find the FAQ and similar information?

* Contents of the FAQ file for wu-ftpd. The complete file can be found at
http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
Or, send mail to [email-masked] with as subject "send faq"
(without the quotes, body ignored).

> >udp, zero, tico...) on the nfs mount.

Device and libraries cannot be share between different OSes not
even between OS of different Major version
ex:
SunOS-4.x  vs SunOS-5.x

the libs format may differ and the major/minor numbers of the device may differ
etc ....

You can always make ~ftp local and export ~ftp/pub

watch out for SunOS-5.x you may need a handfull of libs because
of the uses of XTI, door and other non document secrets :-)
see your man page

> >when the ~ftp/dev is local (I guess this is my solution).

the mode is wrong it should be 666
see the faq

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!