Subject: logging in two different files

From: "Brian J. Tych" <[email-masked]>
Date: Fri, 9 May 1997 18:21:17 -0400 (EDT)

I'm  running 2.4.2-beta 13 on solaris 2.5.1 OS.  Everything I am
trying to run, runs great (no virtual options).  I am having a problem
with logging.  The uploads are logged in xferlog, which is what I want,
but the deletions are being logged via syslog.  Also, I can't seem to get
"all" the commands issued during a session to be logged (cd,ls,bin, etc).
Are the commands limited to a certain set?
	BTW, I only want the details logged for people in group ftpuser 
(defined as a guest group in ftpaccess).

Here is da config I have:

ftpaccess:

log commands guest  outbound,inbound
log transfers guest outbound,inbound

/etc/inetd.conf:
 
ftp     stream  tcp     nowait  root    /usr/sbin/in.wuftpd     in.wuftpd
-a

confilg.sol (before compiling):

/*
 * config.h for Solaris 2.X 
 *
 * $Id$
 */
#define HAVE_SYMLINK
#undef  F_SETOWN
#define HAVE_DIRENT
#define HAVE_D_NAMLEN
#undef  HAVE_FLOCK
#define HAVE_FTW
#define HAVE_GETCWD
#undef  HAVE_GETDTABLESIZE
#define HAVE_GETRLIMIT
#undef  HAVE_PSTAT
#define HAVE_STATVFS
#define HAVE_ST_BLKSIZE
#define HAVE_SYSINFO
#define HAVE_SYSCONF
#undef  HAVE_UT_UT_HOST
#define HAVE_VPRINTF
#define L_INCR  SEEK_CUR
#define REGEX
#define SHADOW_PASSWORD
#define SOLARIS_2
#define SVR4
#define USG
#undef USE_VAR
#undef USE_TMP
#undef USE_ETC

#include <malloc.h>
#include <stdlib.h>
#include <unistd.h>

#ifndef FACILITY
#define FACILITY LOG_DAEMON
#endif

typedef void    SIGNAL_TYPE;

#include "../config.h"

#define realpath realpath_on_steroids   /* hack to work around unistd.h */

Any help would be appreciated.  Thanks ahead of time...

				-Brian

____________________________________________________________________
Brian Tych				| [email-masked]
Computer Operations Specialist		| PAGER: 954-402-6487
Sportsline - Ft. Lauderdale, Florida    | VOICE: 954-351-2120  ext.252
HTTP://cbs.sportsline.com

---

From: Rick Franchuk <[email-masked]>
Date: Fri, 9 May 1997 15:40:37 -0700 (PDT)

I'm running 2.4.2 beta 13 on Linux (kernel rev 2.0.30) with shadow passwords.

I specify that I want incoming files owned by root.daemon, with a chmod of
0600.

Unfortunately, when people upload, it always comes out owned as ftp.bin and
chmod 0644.

What could be happening? (see attached snippet of FTPACCESS at end of file)

---
  -------------------------------------------
 - Rick Franchuk -   Systems Administration  -
-   Net Nation   - mailto:[email-masked] -
 ---------------------------------------------

upload  /home/ftp  * no
upload  /home/ftp  /incoming yes root daemon 0400 nodirs
upload  /home/ftp  /bin no
upload  /home/ftp  /etc no

---

From: "Steven K. Buehler" <[email-masked]>
Date: Sat, 10 May 1997 06:31:09 -0500

>upload  /home/ftp  /incoming yes root daemon 0400 nodirs

You need to change that first line to the following:
upload /home/ftp  *  no  root daemon 0600 nodirs
the rest of the lines can stay the same.

======================================================
Steven K. Buehler
S & B Computers
Rockford Illinois, USA
Phone: 815-398-7169
Fax: 815-398-7266
======================================================

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Sat, 10 May 1997 19:15:22 +0200 (MET DST)

> Unfortunately, when people upload, it always comes out owned as ftp.bin and

Is the /incoming on an NFS mounted volume by any chance ?

												Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Work)  <-- finger -l for PGPkey      Fax: +31-30-2586290
  [email-masked] (Home)                      Workphone: +31-30-2586287
  http://www.cetis.hvu.nl/~koos/   Looking for a license plate with "RFC 822"
  Microsoft thinks "open systems" means they can leave out security.

---

From: Rick Franchuk <[email-masked]>
Date: Tue, 13 May 1997 19:30:03 -0700 (PDT)

> Is the /incoming on an NFS mounted volume by any chance ?

Nope. It's local.

---

---

From: Rick Franchuk <[email-masked]>
Date: Tue, 13 May 1997 19:29:30 -0700 (PDT)

> the rest of the lines can stay the same.

Tried that... no go. Any other thoughts? 

---

---

From: Rick Franchuk <[email-masked]>
Date: Tue, 13 May 1997 22:25:38 -0700 (PDT)

Okay. I've managed to poke at this beastie and got it uploading things into
thier appropriate directories. Here's an oddball problem perhaps someone
could help me out with. It focuses around inetd and wu.ftpd.

This works:
ftp  stream  tcp   nowait root   /usr/sbin/wu.ftpd -a -u 022

This works:
ftp  stream  tcp   nowait root   /usr/sbin/tcpd  /usr/sbin/wu.ftpd

This DOESN'T work:
ftp  stream  tcp   nowait root   /usr/sbin/tcpd  /usr/sbin/wu.ftpd -a -u 022

When I try the latter, I get this message:

500 pro.netnation.com FTP server shut down -- please try again later.
ftp>

hosts.allow and hosts.deny are both blank, so no problems there. Only seems
to act up with the '-a'. I've included my ftpaccess at the end as a debugging
aid.

Any help would be greatly appreciated!

---

loginfails 2

class   local   real,guest,anonymous *.domain 0.0.0.0
class   remote  real,guest,anonymous *

limit   local   20  Any                 /etc/msgs/msg.toomany
limit   remote  60  Any                 /etc/msgs/msg.toomany

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

# allow use of private file for SITE GROUP and SITE GPASS?
private         yes

# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  warn

log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg

# all the following default to "yes" for everybody
delete          no      guest,anonymous         # delete permission?
overwrite       no      guest,anonymous         # overwrite permission?
rename		no	guest,anonymous		# rename permission?
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

# specify the upload directory information
upload  /home/ftp  * no
upload  /home/ftp  /incoming yes root daemon 0400 nodirs
upload  /home/ftp  /bin no
upload  /home/ftp  /etc no

# directory aliases...  [note, the ":" is not required]
alias   inc:    /incoming

# cdpath
cdpath  /incoming
cdpath  /pub
cdpath  /

# path-filter...
path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

# specify which group of users will be treated as "guests".
guestgroup ftponly

email [email-masked]