Subject: Re: Request for Assistance

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Wed, 21 May 1997 10:55:27 +1000 (EST)

Ken,
the Unix ln cmd errors
>>ln: makefiles/Makefile.sol and Makefile are identical etc etc etc 
I think are because you did not do a make clean before subsequent builds and
therefore the targets of the ln already existed, so you can ignore those.

Does the daemon shutdown when you attempt to establish a session or just
abort your session?

If its shuting down perhaps you have a shutdown directive in ftpaccess file.
If so check to make sure the target file in that directive does not exist
(else it triggers a shutdown).

Cant help with the license thing, since Ive not used that release, but I'm
interested in the answer!

Geofft

>Hi:
>
>I am attempting to compile (Sun complier) and run on Solaris 2.5.1 
>using a SPARC 10.
>
>Running the complier results in:
>
>>boscoe# build sol
>>make args are : 
>>make opts are : 
>
>>Linking Makefiles.
>>ln: makefiles/Makefile.sol and Makefile are identical
>>ln: config/config.sol and config.h are identical
>>ln: makefiles/Makefile.sol and Makefile are identical
>
>>Making support library.
>>Application's Host: boscoe
>>      User@Display: root@boscoe:0
>>    License Status: No License
>>     Server Status: No Connection
>>     Error Message: cannot find license file
>>    Total Licenses: 0
>>Licenses Available: 0
>>Application's Host: boscoe
>>      User@Display: root@boscoe:0
>>    License Status: No License
>>     Server Status: No Connection
>>     Error Message: cannot find license file
>>    Total Licenses: 0
>>Licenses Available: 0
>	(What is is the No License and No Connection status???)
>	(This message repeats for all modules and ends with:
>
>>ln: ../src/ftpcount and ftpwho are identical
>>ln: ../src/ckconfig and ckconfig are identical
>
>>Links to executables are in bin directory:
>>build: size: not found
>>Done
>
>All executables are built, I have modified the inetd.conf (correctly I 
>hope!), run ckconfig - all is okay. But on reboot the deamon doesn't run
>and running it fromt he command line results in the following:
>
>>boscoe% ./ftpd
>>220 boscoe FTP server (Version wu-2.4(5) Wed Apr 2 19:51:51 EST 1997) ready.
>>Abort
>
>Its obvious to say I have done something wrong - but what??
>
>Thank you in advance for your assistance.
>
>/Ken
>716.422.7466
>
>
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594

---

From: Matthew Emmerton <[email-masked]>
Date: Tue, 20 May 1997 21:41:25 -0400 (EDT)

I think that it has nothing to do with ln.

I got similar errors when compiling with SCO OpenServer 5, because I
didn't have the development kit (compiler) properly licenced and
registered, so it wouldn't actually compile anything.  Thus, when you do
the re-make, it keeps the old binaries in place (because it doesn't
actually create new ones!)

I'd check to ensure that all of your compilers and linkers n stuff are
properly installed, and then do a clean build.

(I'm 110% sure that these errors are caused by your OS, and not wu-ftpd)

Matt

-- 
[email-masked]
University of Waterloo - 1B Computer Science
GSI Computer Services - President