Subject: Guest Account

From: Ken Hogan <[email-masked]>
Date: Thu, 15 May 1997 10:56:04 2359

hey all,

I am using (Version wu-2.4(14).  I created a user guest:

/etc/passwd: 	guest:x:1002:666:Guest Account:/export/ftp/pub
/guest/./:/bin/csh
/etc/group: 	ftponly:*:666:guest
/etc/ftpaccess:	guestgroup	ftponly

When I log in as guest it goes to the correct directory but
"ls" doesn't work and I get an error:

ftp> ls
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.

If a put I get same error:

ftp> put R13.ZIP
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.

It creates the file empty.

Thanks in Advance
Ken Hogan

---

From: Clinton Fisher <[email-masked]>
Date: Thu, 15 May 1997 11:13:47 -0400

Ken, I take it that your ftp home directory is on an NFS mount point.  I
ran into the same problem.  It is either that or the ~ftp/dev directory
does not have the device files in them, or it otherwise misconfigured.
The /dev directory does not work well being NFS mounted.

- Clinton Fisher
- System Administrator

>----------
>From: 	Ken Hogan[SMTP:[email-masked]]
>Sent: 	Thursday, May 15, 1997 6:56 AM
>To: 	[email-masked]
>Subject: 	Guest Account
>
>hey all,
>

---

From: [email-masked] (Joseph Plassmann)
Date: Fri, 16 May 1997 13:08:36 -0700

Hi Ken,

	Also make sure that your disk is not mounted "nosuid". Under Sol 2.5.1
( at least ), nosuid mounts also mean "nodev", so no device nodes will work
as device nodes on the partition. That one caught me when my server crashed
over the weekend, and I had forgotten that I was futzing with the vfstab
the week before.

	This is also the common problem with running anon FTP off of
an NFS mounted partition. NFS mounted disks are commonly mounted "nosuid"
for security reasons.

	Cheers,

	Joe 

> From [email-masked]  Thu May 15 15:06:46 1997
> > > >----------