Subject: Re: Help with chroot

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Fri, 9 May 1997 09:15:47 +1000 (EST)

Jil,
test-guest needs to be defined as a member of a guest group to be chrooted.
Just put test-guest in a group of your choice, then define that group in the
ftpacess file as class guest and guestgroup (see the examples in the file
that ship with the distribution).

here's an example of entries in /etc/ftpaccess

class   www             guest           *.some.domain

guestgroup      www    

# grep www /etc/group
www::9999:test 

Geofft

>
>I'm setting up a guest account per the 'howto' instructions but I'm having
>problems with the chroot part.  Here's an example of the line in
>/etc/passwd:
>
>	test-guest:*:16:700:Restricted guest 
>	account:/usr/ftp/pub/30min/./:/etc/ftponly
>                                 ^^^^
>
>When I log in I'm correctly located at /usr/ftp/pub/30min, BUT, I'm able
>to cd all the way up to the root of the system!!!!  What am I doing wrong,
>I shouldn't be able to cd up at all?
>
>Thanks for any suggestions.
>
>Jil
>------------------------------------------------------------------------------
>Jil Godesiabois				Systems Administrator			
>NOAA/ERL/FSL/DD				[email-masked]
>R/E/FS3
>325 Broadway				Phone:  303-497-5635
>Boulder, CO 80303			FAX:	303-497-6014
>
>
>
>
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594

---

From: [email-masked]
Date: Mon, 12 May 1997 08:21:14 -0600 (MDT)

Thanks to everyone for all the help.  I accidentally used the 'user
account name' on the guestgroup line of ftpaccess instead of the 'group
name'.  

Thanks
Jil