Subject: wuftpd falling over

From: iqbal gandham <[email-masked]>
Date: Tue, 29 Apr 1997 16:41:12 +0100

Hi

I have heard rumours that wu-ftpd falls over when you have about 3000
people using it. Is this true. If so what can I use.

Or can I fix it

Thanks

Iqbal

---

From: [email-masked] (Chris Brown)
Date: Tue, 29 Apr 1997 10:04:12 -0700 (PDT)

> people using it. Is this true. If so what can I use.

This is probably true 'cause wuftpd depends on locking a file in order to
get its access information.  With thousands of users I would expect wuftpd
to effectively deadlock.  I had been putting some work into a more reliable
method of doing this but I'm not on the developement team so anything I do
isn't likely to be incorperated into any release.

Chris...

---

From: Alain Magloire <[email-masked]>
Date: Tue, 29 Apr 1997 13:27:25 -0400 (EDT)

Salut A Vous, O Grand Manitou Chris Brown !!
> > I have heard rumours that wu-ftpd falls over when you have about 3000

When he said 'falls over' did he meant ..
machine going to grinding halt because of not enough memory ?
out of swap ?
TCP/IP traffic jam ?
machine can't keep up ?
limited by some system specific constant(file des. # of process, etc ..)
not enough mbufs ?

... or design flaws in the code ?

Before reaching 3000 ftpd processes, I would expect other
break down .. No ?

> to effectively deadlock.

I didn't have to go to thousands to have deadlock, after 100 or more
I got, in syslog, the wonderfully informative:

sleeping: fcntl lock of pid file failed:
and ftpd processes looping cloberring syslog

Probably the fact that /home/ftp was NFS mounted didn't help.

> I had been putting some work into a more reliable

I've patch mine to bail out after 300 iterations, which is eternety
to a normal human.

Curious to hear your approach.

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!

---

From: [email-masked] (Chris Brown)
Date: Tue, 29 Apr 1997 11:21:45 -0700 (PDT)

> Salut A Vous, O Grand Manitou Chris Brown !!

Long time no talk :)  Many thanks for the snprintf stuff!  It's saved me
more time than I can count.

You'll have to wait a bit, but maybe this time next week I'll have a test
setup running.

Chris...