Subject: RE: FTP dropping xfers???!!!

From: Sasha Romanosky <[email-masked]>
Date: Mon, 7 Apr 1997 09:34:14 -0600

After a bit of digging, I think I have found the reason for the dropped
connections.

The following is an excerpt from
ftp.fwi.uva.nl/pub/solaris/solaris2.html:
"5.17) TCP/IP connections time out too soon, especially on slow links. 

The tcp/ip abort interval in Solaris 2.x is too short, the default value
is 2 minutes. The result is that when an ACK isn't received in 2
minutes, the connection is
closed. This is most often seen by sendmail, which will log 

sendmail: SYSERR: collect: read timeout on connection from ...

You can fix this by running following command which increases the
timeout to 8 minutes (unit is millisec), which is the Solaris 2.4+ (and
patched 2.3) default. 

/usr/sbin/ndd -set /dev/tcp tcp_ip_abort_interval 480000"

Fine, it talks about sendmail but tcp is tcp is tcp, yes? Yes.

later,
Sasha Romanosky
Internet Applications Specialist
TELUS Advanced Communications
  403.543.2083
  [email-masked]
   www.tac.telus.com   

>----------
>From: 	Alex Belits[SMTP:[email-masked]]
>Sent: 	Thursday, March 27, 1997 7:54 AM
>To: 	[email-masked]'
>Subject: 	RE: FTP dropping xfers???!!!
>
>On Tue, 25 Mar 1997, Sasha Romanosky wrote:
>
>> 
>> It would seem that we've touched on something here.....
>> 
>> It would also seem that, indeed, this is a symptom of TCP
>> and not necessarily ftp or http. Makes sense to me.
>> 
>> Now, since TCP was born to be (no, not wild) reliable, 
>> how can we stop these dropped connections - regardless
>> of delays or lost packets...???
>> 
>> [Oohh, where's Richard Stevens when you need him??]
>
>  I'm not Stevens, but if I correctly understood what he wrote about TCP
>connection closing, it's caused by RST packet, sent to terminate
>connection on socket that takes "too long" to close properly where "too
>long" is defined in SO_LINGER option. It also depends on how socket
>was closed, with or without shutdown() called. "Cure" will be to let
>socket close by itself without defining SO_LINGER, but that may take long
>time, and still won't save from timeouts in transfer.
>
>--
>Alex
>
>

---

From: Mike Ellwood <[email-masked]>
Date: Mon, 7 Apr 1997 16:52:54 +0100 (BST)

Sounds interesting.
Anyone happen to know if something similar might happen in
AIX, and what the corresponding AIX network option might be?
-- 
[email-masked]