Subject: Re: ftp not in /etc/passwd

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Thu, 17 Apr 1997 15:24:17 +1000 (EST)

Becky

OK 3 things.
1. I dont thing authentication uses the ~ftp/etc/passwd file (its there so
chrooted anonymous sessions get names in lieu of numbers in directory listings).

2. Whats in the ftp hosts file ??????????? /etc/ftphosts (is the default
with the distribution I think) It may conflict with your IP address. Does
the DNS know about the client machine.
You could also try ftp 127.0.0.1 from the server and see if that gets the
same problems.

3. Does root have read access to the ftpaccess file (its a dumb question
but........)

Geofft

>I reported this on arpil 10, and I'm still having this problem.  This is
>beta 13, Digital Unix 4.0, started up in inetd.conf like this:
>
>ftp     stream  tcp     nowait  root    /usr/local/etc/tcpd
>/usr/local/bin/ftpd  -l -d -a
>
>and I get this error when I log in as anonymous:
>
>Apr 16 22:44:34 josephus ftpd[841]: josephus.furph.com FTP server (Version
>wu-2.4.2-academ[BETA-13](1) Wed Apr 16 22:27:03 EDT 1997) ready.
>Apr 16 22:44:37 josephus ftpd[841]: command: USER anonymous^M
>Apr 16 22:44:37 josephus ftpd[841]: <--- 530 
>Apr 16 22:44:37 josephus ftpd[841]: User anonymous unknown.
>Apr 16 22:44:37 josephus ftpd[841]: FTP LOGIN REFUSED (ftp not in
>/etc/passwd) FROM quip.eecs.umich.edu [141.212.99.8], anonymous
>
>and this when I log in as myself:
>
>Apr 16 22:44:42 josephus ftpd[841]: command: USER beckers^M
>Apr 16 22:44:42 josephus ftpd[841]: <--- 331 
>Apr 16 22:44:42 josephus ftpd[841]: Password required for beckers.
>Apr 16 22:44:42 josephus ftpd[841]: USER beckers
>Apr 16 22:44:46 josephus ftpd[841]: command: PASS password^M
>Apr 16 22:44:46 josephus ftpd[841]: PASS password
>Apr 16 22:44:46 josephus ftpd[841]: <--- 530 
>Apr 16 22:44:46 josephus ftpd[841]: Login incorrect.
>
>even though I'm using the right password.
>
>/etc/passwd and ~ftp/etc/passwd are this:
>
>ftp:*:9997:999:anonymous ftp:/usr/users/ftp:/bin/false
>ftp1:*:9998:999:guest ftp:/usr/users/ftp/./:/bin/false
>
>/bin/false is in /etc/shells
>
>ckconfig checks out that ftpaccess is in /usr/local/etc/ftpaccess and in
>it is the following:
>
>class   local   real,guest,anonymous *
>guestgroup      ftp1
>
>
>And it seems like the daemon is just ignoring the -a in the startup.  Any
>ideas, PLEASE!
>
>thanks
>
>beckers
>
>
>
>
>
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594

---

From: "Schramm, Rich" <[email-masked]>
Date: Thu, 17 Apr 1997 14:55:03 -0400

Digital Unix 4.0 does not use /etc/shadow for its shadowed password
files.  With C2 security installed on the system, the /etc/passwd file
is "shadowed" but the encrypted passwords are stored in a series of
files elsewhere on the system.

You can read the DU 4.0 security manuals for more info.

BTW, wouldn't publishing part or all of the /etc/shadow file for
anonymous FTP users kinda ruin the effect of having an /etc/shadow in
the first place?

Cheers,

Richard Schramm
Internet Technical Analyst
The E.W. Scripps Co.
mailto:[email-masked]

>----------
>From: 	Becki Kain[SMTP:[email-masked]]
>Sent: 	Thursday, April 17, 1997 1:24 PM
>To: 	[email-masked]
>Subject: 	Re: ftp not in /etc/passwd
>
>I don't have /etc/shadow.  why would I need it?
>
>thanks
>
>beckers
>
>
>On Thu, 17 Apr 1997, Bernhard Rosenkraenzer wrote:
>
>> On Wed, 16 Apr 1997, Becki Kain wrote:
>> 
>> Are you sure you've created the ftp entry in /etc/shadow as well as
>> /etc/passwd, and are you sure you've compiled wu-ftpd with shadow password
>> support?
>> 
>> LLaP
>> bero
>> 
>> 
>> 
>> 
>
>

---

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Fri, 18 Apr 1997 08:44:34 +1000 (EST)

Richard,
I agree, but I dont think that is suggested.

I dont know Digital Unix and I dont currently run beta13, but unless its
changed since beta11, you dont need to put the passwords (shadowed or not)
in the public ftp directories.
The chroot is done after login authentication (otherwise it knows not where
to chroot to!)
The only reason you put the /etc/passwd file in the ftp tree is for the ftp
daemon to provide names in lieu of unix uids & gids when the client does 'ls'

Regards Geofft