Subject: date/timezone problem

From: Mike Strawbridge <[email-masked]>
Date: Wed, 30 Apr 1997 10:45:52 -0400

I just installed wu-ftpd on our Sun Solaris 2.5 systems. When anonymous
users log into ftpd, the time stamp on files are all off by 4 hours. It
appears to think it's in a different timezone.

When regular (not anonymous) users log on, everything is OK.

What do I need to do to fix this?

Thanks.

Mike

-----------------------------------------------------------------------
NAME:   Michael Strawbridge             	TELE: (301) 975-3852
USMAIL: National Institute of Standards 	ARPA: [email-masked]
		and Technology
        Bldg. 220, Room B127
        Gaithersburg, MD  20899

---

From: Gerald Litteer <[email-masked]>
Date: Wed, 30 Apr 1997 09:04:50 -0600

>> Message-Id: <199704301445.KAA07570@marvin>
>> Date: Wed, 30 Apr 1997 10:45:52 -0400
>> Reply-To: [email-masked]
>> Sender: [email-masked]
>> From: Mike Strawbridge <[email-masked]>
>> To: [email-masked]
>> Subject: date/timezone problem
>> X-Listprocessor-Version: 8.0 -- ListProcessor(tm) by CREN
>> 
>> 

I had this problem also, then I found that you need to include in the ~ftp structure
a copy of /usr/share/lib/zoneinfo.    I just copied the structure from the real side to the
chrooted side for ftp.

hope this helps...

--
------------------------------------------------------------------
Gerald (Jerry) Litteer
Scientific Technical Support      INTERNET:  [email-masked]
Lockheed-Martin Idaho Technologies
Idaho National Engineering Lab.   Phone: (208) 526-9117
POB 1625 M.S. 3640  
Idaho Falls, Id. 83415-3640       FAX:   (208) 526-2641
------------------------------------------------------------------

"Machines were mice and men were lions once upon a time.
 But, now that it's the opposite, it's twice upon a time."

                        -- Moondog (Louis Hardin), 1960's

---

From: Pierre Belanger <[email-masked]>
Date: Wed, 30 Apr 1997 17:46:41 -0400

Hi!

> a copy of /usr/share/lib/zoneinfo.    I just copied the structure from the real side to the
Right and under Solaris you also need the /etc/default/init which tells
the system zonetime:

This is what I have in mine ->

TZ=Canada/Eastern

take care,
Pierre B. - RISQ