Subject: Re: wu-ftpd guest accounts

From: Michael Brennen <[email-masked]>
Date: Wed, 9 Apr 1997 15:51:00 -0500 (CDT)

So uploading does not work without the ~/etc, ~/bin and ~/dev directories
in each guest account?  I've never seen this.  Can anyone else on the list
verify this?  I just don't have time now. 

I use a perl script to build all my guest accounts so all the clumse is
hidden.  I use a statically linked ls that does not need ~/lib, and ~/dev
is not needed on my OS, so I only have ~/bin and ~/etc.  I use hard
(inode) links from each guest account back to a single master copy of ls
or whatever other utilities I need (e.g. chmod) so it takes up less disk
space. 

   -- Michael

On Wed, 9 Apr 1997, Jenny Yu wrote:

>           Hi Michael,
>           
>           I've read your procedure on how to setup the guest account.  
>           I'm trying to setup multiple guest accounts so that each 
>           account will be responsible for maintaining one sub dir 
>           under the root dir /user/ftp.  
>           
>           Here is my setup:
>           
>           (1) ~/etc/passwd 
>           
>           guest1:*:400:400:Posting 1:/user/ftp/./guest1:/etc/false
>           guest2:*:401:400:posting 2:/user/ftp/./guest2:/etc/false
>           guest3:*:402:400:posting 3:/user/ftp/./guest3:/etc/false
>           
>           (2) ~/etc/group:
>           
>           guestgrp::400:guest1,guest2,guest3
>           
>           (3) mkdir /user/ftp/etc; /user/ftp/dev; /user/ftp/bin
>           
>           
>           With the above setup, "upload" does not work.  The only way 
>           I can get it work is to have etc, bin, and dev directory 
>           created under each guest account's home directory. (e.g. 
>           /user/ftp/guest1/etc, /user/ftp/guest2/etc, 
>           /user/ftp/guest3/etc...).
>           
>           This looks very clumsy.  Especially, I have over 100 sub 
>           directories.

---

From: Dale Welch <[email-masked]>
Date: Wed, 09 Apr 1997 16:31:18 -0700

Normal (standard) FTP appears to work on my machine.

However,
  when using the Web Publishing Wizard from Microsoft ftpd exits with a
signal 11.
     Apr 9 16:19:41 teldor  ftpd[17315]: exiting on signal 11

Any ideas?

I am running FreeBSD 2.1.7

---dale welch
'Net Works
208.263.5082