Subject: RE: FTP & Microsoft Web Publishing Wizard

From: "Roger A. Hanke" <[email-masked]>
Date: Thu, 10 Apr 1997 09:08:50 -0400

Dale,
 Wish I could give you some info on using this Wizard but I couldnt even
get as far as you. How did you successfully get your ftp session established.
No matter how I entered the ftp address in the URL box and the rest of the
information prompted it still munged it up some and never connected 
successfully to my server.
 I was trying to do this without that server info file, did you end up using
that? If so would appreciate seeing how a ftp one looks since all their 
examples showed http connectivity to ISP's.
	Thanx,
	Roger Hanke
	[email-masked]

----------
From: 	Dale Welch
Sent: 	Wednesday, April 09, 1997 7:31 PM
To: 	[email-masked]
Subject: 	FTP & Microsoft Web Publishing Wizard

Normal (standard) FTP appears to work on my machine.

However,
  when using the Web Publishing Wizard from Microsoft ftpd exits with a
signal 11.
     Apr 9 16:19:41 teldor  ftpd[17315]: exiting on signal 11

Any ideas?

I am running FreeBSD 2.1.7

---dale welch
'Net Works
208.263.5082

---

From: [email-masked]
Date: Thu, 10 Apr 1997 09:41:03 -0400 (EDT)

If you are seeing Signal 11 in the syslog that usually means the
wuftpd daemon is dumping core or encountering something equally
severe like a segmentation violation etc. Its usually bad news. I
don't have a good way of finding out why its doing this.

Doug

-- 
Doug Courtney
[email-masked]
(908)949-3597

---

From: [email-masked] (Gerhard Gonter)
Date: Thu, 10 Apr 1997 16:17:06 +0200 (MES)

> I am running FreeBSD 2.1.7

On a HP-UX 10.01 machine using wu-ftpd-2.4.2-beta-11 we also had a
ftpd that dumped core and exited with signal 11.  Your problem might
be something completely different, but in our I tracked it down to
a memory allocation problem in popen.c.  I never came around to
investigate the problem in more detail but a quick'n'dirty patch
help me:

In popen.c in the function ftpd_popen (...) disable the release of
possibly unallocated memory near the end of the function body:

  pfree:
    for (argc = 1; argv[argc] != NULL; argc++)
    {
#ifndef __hpux
#ifdef __comment__
GG: 1996-09-13, under HP-UX this seems to fail!!!
More details see: [%afs/etc/userdir/azi.hyx] wu-ftpd Bug 1
#endif /* __comment__ */
        blkfree((char **) argv[argc]);
#endif /* __hpux */
        free((char *) argv[argc]);
    }
    return (iop);

According to my notes (referenced in the source segment above)
this happened right after the client issued
a DIR.  The memory leak cause by not freeing the argument list
seems to be neglible.

+gg
 
--
[email-masked]  Fax: +43/1/31336/702  [email-masked]
Zentrum fuer Informatikdienste, Wirtschaftsuniversitaet Wien, Austria