Subject: Hiding new uploads

From: Colin Young <[email-masked]>
Date: Fri, 11 Apr 1997 14:16:08 -0400

How can I set up anonymous ftp so users can upload to an incoming 
directory, but will not be able to see any files in that directory while still
being able to see files in other directories? Is it possible?

e.g.
/incoming     ->     allows uploads, files not viewable
/pub             ->     no uploads allowed, but files viewable

I've got the upload permissions set okay, I just can't seem to hide files.

Thanks.

Colin Young
[email-masked]

---

From: Alain Magloire <[email-masked]>
Date: Fri, 11 Apr 1997 14:33:42 -0400 (EDT)

> I've got the upload permissions set okay, I just can't seem to hide files.

What don't you read the FAQ ?

in all you messages you claim to have done so 
but all your questions are answered in the document

Maybe you've got the wrong FAQ, let me see if
can dig out one of Michael or Koos email

....
here it is, (from Michael B. email) :

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd list archive:  http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!

---

From: Vidiot <[email-masked]>
Date: Fri, 11 Apr 1997 13:55:58 -0500 (CDT)

<How can I set up anonymous ftp so users can upload to an incoming 
<directory, but will not be able to see any files in that directory while still
<being able to see files in other directories? Is it possible?
<
<e.g.
</incoming     ->     allows uploads, files not viewable
</pub             ->     no uploads allowed, but files viewable

I have the incoming directory set as such:

drwx-wx-wx   2 brown    ftms_dev    2048 Feb  7 15:53 incoming

The owner can be anyone with these permissions.

MB
-- 
System Administrator - Finnigan FT/MS - Madison WI. <URL:http://www.ftms.com/>
e-mail: [email-masked]
phone: (608) 273-8262 ext: 612  fax: (608) 273-8719
Visit - <URL:http://www.cdsnet.net/vidiot/>  (Your link to Star Trek and UPN)

---

From: "Phong Duong" <[email-masked]>
Date: Fri, 11 Apr 1997 13:51:36 -0500

Hello,

Here is how we set our permissions.  Hope this help...

# ls -al ~ftp
total 32
drwxrwxr-x   9 root     ftponly      512 Apr  9 10:51 .
drwxrwxr-x  16 root     other       1024 Apr  9 08:13 ..
d--x--x--x   2 root     other        512 Apr  9 15:57 bin
drwxr-xr-x   2 root     sys          512 Mar 26 11:38 dev
d--x--x--x   2 root     other        512 Apr  2 16:39 etc
d-wx-wx-wx   2 root     other        512 Apr  7 16:29 incoming
drwxrwxrwt   2 root     other        512 Apr  8 13:17 pub
d--x--x--x   3 root     other        512 Apr  2 16:39 usr

Cheers,

-- 
+-------------------------------+----------------------------------+
| Phong D. Duong                |  Enron Capital & Trade Resources |
| Information Technology        |  1400 Smith Street               |
| mailto: [email-masked]  |  Houston, Texas 77002            |
|  voice: (713) 853-1459        |  EB-3416B                        |
+-------------------------------+----------------------------------+

---

From: "Steven K. Buehler" <[email-masked]>
Date: Fri, 11 Apr 1997 14:02:04 -0500

>I've got the upload permissions set okay, I just can't seem to hide files.

These directions are on the FAQ site at:
http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html

7.Somebody uploaded a file with a weird name 

          Somebody is trying to misuse your ftp-site for transferring software (worst case scenario). Check if the directive
          path-filter in the ftpaccess file is something like : 

          path-filter anonymous /etc/paths.msg ^[-A-Za-z0-9\._]*$ ^\. ^-

        8.I want anonymous users to be able to upload files, but in the most secure manner possible 

          In that case, set your path-filter to the one mentioned above. Make the incoming directory owned by something
          else then ftp (root, or nobody) with another group then ftp (nobody). Something like : 

          drwx-wx-wt       root    nobody        incoming

          This will allow ftp to write in the directory, but not read it. Set the upload directive in ftpaccess to something like :

          upload    /home/ftp    /incoming   yes root daemon 0400 nodirs

          One note : files get created as root and changed to the owner mentioned in the upload line. This will fail on some
          secure NFS setups. 

======================================================
Steven K. Buehler
S & B Computers
Rockford Illinois, USA
Phone: 815-398-7169
Fax: 815-398-7266
======================================================