Subject: Option to remove SITE EXEC?

From: "Schramm, Rich" <[email-masked]>
Date: Fri, 18 Apr 1997 09:30:23 -0400

Hello all,

Is there a compile option to remove the SITE EXEC feature in the
non-beta version of 2.4?  I could not find any documentation on compile
options in the instructions - only to modify the pathnames.h.  I have
seen several people on this list talk about compile options.  Is there a
doc I am missing on this?  If there is not a compile option, is there an
option in the ftpaccess?  I could not find anything about this and was
leary of hacking the ftpd.c source to remove the site exec.

Thanks,

Richard Schramm
Internet Technical Analyst
The E.W. Scripps Co.
mailto:[email-masked]

---

From: Alain Magloire <[email-masked]>
Date: Fri, 18 Apr 1997 12:30:42 -0400 (EDT)

> non-beta version of 2.4?  I could not find any documentation on compile

1-
 in config.h 
#define PARANOID

  but PARANOID also disable some interesting/questionnable feature
see FIXES-2.4-HOBBIT

2-
  Just don't put any commands in the directory 
#define _PATH_EXECPATH  "/bin/ftp-exec"

  if there is nothing to execute SITE EXEC will not work

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!