Subject: Re: anonymous set up

From: [email-masked]
Date: Wed, 16 Apr 1997 09:08:16 -0400

read
ftp://rtfm.mit.edu/pub/usenet/news.answers/computer-security/anonymous-ftp-
faq
and check out the man pages on FTPD

     -Anthony

>
>Hi
>
>I have setup wu-ftpd successfully. All the users are limited to there
directories, with chroot etc.
>
>BUT, how do I setup anonymous user, so that they can get access by just
>typing in there email address for the password for example. I am not
>sure if you set this up as you do for a normal user, or do you need
>something different. I have had a look at the FAQ and I can't seem to
>find what i am looking for
>
>Thanks
>
>Iqbal
>

---

From: David Brossard <[email-masked]>
Date: Wed, 16 Apr 1997 12:35:33 -0700 (PDT)

I have set up several guest accounts on Solaris and in all of them
have a /etc/passwd file either containing the pertinent users or the full
passwd table. However in a directory listing, it only shows the UID's and
GID's. I saw this question posed before on the list but never saw the fix.
Any ideas? TIA

------------finger [email-masked] for my public pgp key---------------- 
David Brossard                      e u r o p a  c o m m u n i c a t i o n s
MIS / Techie
[email-masked]                 503.222.9508 MAIN
www.europa.com                      503.796.9134 FACSIMILE
                                    503.222.4244 DATA

---

From: [email-masked] (Claude Scarpelli)
Date: Wed, 16 Apr 1997 23:14:47 +0200

> GID's. I saw this question posed before on the list but never saw the fix.

We discovered this last week, as we upgrade our ftp server to
2.5.1. We fixed this by copying the right libraries to ~ftp/usr/lib,
ie as explain in the ftpd Solaris manpage :

                 ld.so*
                 libc.so*
                 libdl.so*
                 libintl.so*
                 libw.so*
                 libnsl.so*
                 libsocket.so*
                 nss_nis.so*
                 nss_nisplus.so*
                 nss_dns.so*
                 nss_files.so*
                 straddr.so*

You may need other libraries. I remember that our version of gtar
requires /usr/lib/libmp.so.

-- 
------------------------------------------------------------------------------
Claude Scarpelli                        | Defenestrate: to exit a window
INFOBIOGEN ::= INFOrmatique appliquée à | onscreen. (Time International
l'étude des BIOmolécules et des GÉNomes	| Vol 146, No. 20, Nov 13, 1995)

---

From: David Brossard <[email-masked]>
Date: Wed, 16 Apr 1997 15:02:04 -0700 (PDT)

On Wed, 16 Apr 1997, Claude Scarpelli wrote:

-|In a mail dated Apr 16, [email-masked] (David Brossard) wrote:
-|> 	I have set up several guest accounts on Solaris and in all of them
-|> have a /etc/passwd file either containing the pertinent users or the full
-|> passwd table. However in a directory listing, it only shows the UID's and
-|> GID's. I saw this question posed before on the list but never saw the fix.
-|> Any ideas? TIA
-|> 
-|
-|We discovered this last week, as we upgrade our ftp server to
-|2.5.1. We fixed this by copying the right libraries to ~ftp/usr/lib,
-|ie as explain in the ftpd Solaris manpage :
-|
-|                 ld.so*
-|                 libc.so*
-|                 libdl.so*
-|                 libintl.so*
-|                 libw.so*
-|                 libnsl.so*
-|                 libsocket.so*
-|                 nss_nis.so*
-|                 nss_nisplus.so*
-|                 nss_dns.so*
-|                 nss_files.so*
-|                 straddr.so*
-|
-|
-|You may need other libraries. I remember that our version of gtar
-|requires /usr/lib/libmp.so.

	Thanks to everyone who helped on this problem. The solution, in
case anyone is interested is described above. It is also important to
include the /usr/lib/libmp.so.* files. Again, thanks everyone!