Subject: More help. GNU BISON.

From: "Usuario-Mois�s." <[email-masked]>
Date: Wed, 2 Apr 1997 16:16:52 +0100 (NFT)

Hi there.

	Thank you very much for helping me!

	But I need more help.

	Let me explain:

I'm compiling WUFTPD 2.4.2 Beta for AIX 4.x

I've installed GNU BISON.

The next step is './build aix'. Here it fails.

These are the error codes:

ld: 0711-317 ERROR: Undefined symbol: .snprintf
ld: 0711-317 ERROR: Undefined symbol: .vsnprintf

Is it because of 'yacc'?

I haven't found where to change 'yacc' for 'bison -y'?

Perhaps there is no need to change 'yacc' and these errors are due
to something else.

The other commands (ftpwho, ftpshut, ...) are well compiled.

	Here it is.
	Thanks again.

		Moises Navarro Marin.
		IBM Global Services, SPAIN.

---

From: Alain Magloire <[email-masked]>
Date: Wed, 2 Apr 1997 10:16:00 -0500 (EST)

Salut A Vous, O Grand Manitou Usuario-Moisés. !!

> ld: 0711-317 ERROR: Undefined symbol: .vsnprintf

no, I don't know AIX but it looks like the loader
doesn't find snprintf().

can you do 
man snprintf ?

if not version BETA-13 provides a very limited
implementation written by Patrick Powell
support/snprintf.c

link ftpd with it. Surprising that the config file didn't take
care of that. Mr Barber does a very good job in does things...
Are you using the right config file ? config.aix

I also find very suprising that AIX doesn't have a
decent version of yacc.

***** Off Topic ****
For those interested, I've written a full implementation of
snprintf, that can do floating point calculation. I needed
to shut some buffer overrun holes. Most free implementtion
find on the Net don't do floating point, and the one
that does are not portable :-(. So I sat down one day.
It should run on all platforms.

ftp://finnegan.ee.mcgill.ca/pub/alain/snprintf-1.1.tar.gz

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!

---

From: Dan Foster <[email-masked]>
Date: Wed, 2 Apr 1997 11:41:37 -0500 (EST)

Hot Diggety! Alain Magloire was rumored to have said...
> Salut A Vous, O Grand Manitou Usuario-Moisés. !!

:-) Live and learn something new every day, eh? ;-)
 
> Are you using the right config file ? config.aix

Mr. Barber *does* an excellent job of things. Very responsive to reports of
human errors or bugs.
 
> I also find very suprising that AIX doesn't have a

I'm working with the original poster to resolve this issue on my own
without spending extra time on the list for this. Email me if you (whoever)
have a similar problem and wants to know how to fix.

FWIW, wu-ftpd compiles out of the box flawlessly (now, at least ;-) ) for 
AIX 4.2 and 4.1.4 machines we have here, using IBM cc.

> It should run on all platforms.

Interesting, thanks for the FYI.

-Dan Foster
Internet: [email-masked]

---

From: Dan Foster <[email-masked]>
Date: Fri, 4 Apr 1997 07:41:34 -0500 (EST)

> no, I don't know AIX but it looks like the loader

The problem turned out to be due to the fact that beta 13 for AIX had
a slight error in support/makefiles/Makefile.aix, in the OBJS line.

All object files were listed (ie .o) but snprintf was listed as
snprintf.c. Changing that to snprintf.o and doing a build clean, then
build aix takes care of the problem.

Stan Barber fixed that problem within 60 seconds of notification, so it
shouldn't be present in future releases... I don't think it existed in
previous betas, FWIW.

-Dan