Subject: Re: Static-ls

From: [email-masked] (John Attwood)
Date: Wed, 2 Apr 97 17:04:24 BST

>  I used the static-ls patch, posted here the other day, along with fileutils3.16 as suggested
>and it works, except for 1 thing. I use NIS+, and the static-ls patch assumes "/etc/passwd" as
>the source for UID's. Does anyone know where to get a statically linked 'ls' (or source code)
>that supports NIS+ (ie, uses getpwnam instead of scanning the /etc/passwd file) ?

Under Solaris 2.x getpwnam() can't be used without dynamic linking. From
getpwnam(3C):-

     Programs that use the interfaces described  in  this  manual
     page  cannot be linked statically since, the implementations
     of these functions employ dynamic  loading  and  linking  of
     shared objects at run time.

-- 
John Attwood,  Computing Officer,      |  Voice +171 387 7050 X5028
MRC Human Biochemical Genetics Unit,   |  Fax   +171 387 3496
University College London,             |  Email [email-masked]
Wolfson House, 4 Stephenson Way,       |
London NW1 2HE, United Kingdom.        |  http://www.gene.ucl.ac.uk/~john

---

From: Jerry Pendergraft <[email-masked]>
Date: Fri, 4 Apr 1997 12:31:25 -0600 (CST)

Why not just provide a skeleton copy of pw info by running, at your
chosen frequency, the following:

niscat passwd.org_dir | 
awk -F':' '{ 
  printf("%s:*:%d:%d:%s:%s:\n", $1, $3, $4,$5, $6); 
}' > ~ftp/etc/passwd

-- 
Jerry Pendergraft		Internet: [email-masked]
                --------------------------
                | Abusus non tollit usum |
                --------------------------