Subject: which S/KEY code to use?

From: [email-masked]
Date: Fri, 11 Apr 1997 13:56:54 -0400

I am trying to get S/KEY & wuftp 2-4-2 beta 12/13 to work
together.  

I am using the skey code that comes with logdaemon5.3.
Does anyone know of a better version to use?

Right now, the ftp daemon I have compiled works, but
it is flakey.  It currently works only when skey passwords
are used.  It doesn't matter what 'permit' lines I use in
/etc/skey.access, nor if there is an /etc/skey.access file,
ftp doesn't allow unix passwords.

There is strong evidence that this is not a configuration problem.
The message log shows that the ftp daemon catchs signal 11,
segment violation, when any attempt to use unix passwords is made.  

My first guess is that I have a source code version mismatch
between wuftp and s/key, but haven't found anything that could
confirm or deny this.

Are there any configuration or compilation settings I might
have missed that need to be set to allow use of the /etc/skey.access
file and/or to allow using both unix and s/key passwords?

Chris Eastlund

---

From: Michael Brennen <[email-masked]>
Date: Fri, 11 Apr 1997 13:30:11 -0500 (CDT)

#ifdef SKEY
// #include <skey.h>
int pwok = 1;
#endif

....

#ifdef SKEY
/* comment the next line if you REALLY want to allow replayable passwds.
*/
/*  strcpy (xpasswd, "wrongo:spazmoid");  /* disable regular passwds */

These snippets of code are in ~/src/ftpd.c; the pwok=1 must be there to
enable regular passwords.  Comment out the wrongo:spazmoid line also. 
Recompile, reinstall, and try again.  See if that doesn't enable
passwords. 

   -- Michael

---

From: Mike Garner <[email-masked]>
Date: Fri, 11 Apr 1997 14:38:51 -0400

Try using logdaemon-5.6. I've had no problems using it with beta 13.

 Mike Garner