Subject: Re[2]: Windows FTP Client Can't See Directory

From: [email-masked] (Mark Flanagan)
Date: Wed, 9 Apr 1997 16:06:07 -0500

ls looks to be good.  The permissions are OK and ~ftp/bin/ls is the 
     same as ls on the system.  Thanks for the suggestion though.
     
     - Mark

______________________________ Reply Separator _________________________________
Subject: Re: Windows FTP Client Can't See Directory
Author:  [email-masked] at INTERNET
Date:    4/9/97 2:36 PM

Did you check the copy of ls you created under the ~ftp/bin directory? 
Perhaps the permissions on that aren't set properly or you have a bad copy 
of ls -- or it isn't even there.
     
- Tim

At 02:14 PM 4/9/97 -0500, you wrote:
>     I've got a person using a windows-based FTP client that can't see the 
>     list of files in a directory.  She has used Chameleon and WS-FTP, same 
>     problem.  Given a filename, she can download a file.
>     
>     I've checked directory and file permissions, and they appear OK. 
>     
>     She does log in as a guest user. 
>     
>     Any ideas?
>     
>     Sincerely,
>     Mark Flanagan
>     [email-masked]
>
>

---

From: "Aman, Alice" <[email-masked]>
Date: Wed, 9 Apr 1997 16:41:09 -0500

We had a similar experience here. A user was trying to
use Microsoft's ftp.exe in the windows directory. If she
used the "run ftp" and then used 
"open somehostname.somedomainname"
at the ftp prompt, i.e. ">",  she could get in but couldn't
list any files.
 
I had her change to using "run ftp someipnumber.x.y.z", and
she was able to get "dir" to work.  This means it was either
a DNS related problem or an ftp client problem with handling
command line parameters,  we didn't do any more detective
work since we found a working solution so I can't tell
you which it was. Hope this helps.

    --Alice

>----------
>From: 	[email-masked][SMTP:[email-masked]]
>Sent: 	Wednesday, April 09, 1997 2:36 PM
>To: 	[email-masked]

---

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Thu, 10 Apr 1997 10:37:34 +1000 (EST)

Alice,
If the user got to the right machine, it can't be A DNS problem , the name
resolution has been completed and an ftp session exists with a socket to the
TCP/IP stack.
This is somewhat simplified, but basically, the IP stack only ever
communicates with ip addresses (the machine name is communicated as data in
a name resolution request (the ip packet having a destination ip address of
the name server) to the Name server and the name server responds with data
containing the ip address of the target machine. DNS is done once and then
the binding is done, all subsequent ip packets have the ip address of the
target). ftp knows nothing about DNS, it just sees the socket which is
related to the target host session.

Of course if she did not get the right machine, that could be associated
with a DNS problem.

Regards Geofft

>you which it was. Hope this helps.
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594