Subject: RE: Option to remove SITE EXEC?

From: "Schramm, Rich" <[email-masked]>
Date: Fri, 18 Apr 1997 13:20:39 -0400

I seem to be missing something - there is no file named
FIXES-2.4-HOBBIT, only a FIXES-2.4.  Also, there is no PARANOID defined
or undefined in my config.h file.  Where did you come across this info?
Do I have a different version?  And though there is nothing in my exec
dir, I AM paranoid and may want to define myself as such ;-)

I have been to the wuarchives and I seem to have the latest
distribution.

Thanks,

Richard Schramm
Internet Technical Analyst
The E.W. Scripps Co.
mailto:[email-masked]

>----------
>From: 	Alain Magloire[SMTP:[email-masked]]
>Sent: 	Friday, April 18, 1997 12:30 PM
>To: 	[email-masked]
>Subject: 	Re: Option to remove SITE EXEC?
>
>
>> 
>> Is there a compile option to remove the SITE EXEC feature in the
>> non-beta version of 2.4?  I could not find any documentation on compile
>
>1-
> in config.h 
>#define PARANOID
>
>  but PARANOID also disable some interesting/questionnable feature
>see FIXES-2.4-HOBBIT
>
>2-
>  Just don't put any commands in the directory 
>#define _PATH_EXECPATH  "/bin/ftp-exec"
>
>  if there is nothing to execute SITE EXEC will not work
>
>
>-- 
>au revoir, alain
>----
>Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!
>

---

From: Alain Magloire <[email-masked]>
Date: Fri, 18 Apr 1997 13:27:56 -0400 (EDT)

Salut A Vous, O Grand Manitou Schramm, Rich !!
> or undefined in my config.h file.  Where did you come across this info?

ls -l wu-ftpd-2.4.2-beta-13
total 198
-rw-r--r--   1 alainm   vlsi        1421 Mar  3 04:16 ANNOUNCE-13
-rw-r--r--   1 alainm   vlsi        5053 Mar  3 03:54 CLOSED-TICKETS-13
-rw-------   1 alainm   vlsi        6553 Apr 13  1994 FIXES-2.4
-rw-r--r--   1 alainm   vlsi       16027 Jun 11  1995 FIXES-2.4-HOBBIT
....

---

From: James Sneeringer <[email-masked]>
Date: Fri, 18 Apr 1997 13:08:35 -0500 (CDT)

On Fri, 18 Apr 1997, Alain Magloire wrote:
| Salut A Vous, O Grand Manitou Schramm, Rich !!
| > 
| > I seem to be missing something - there is no file named
| > FIXES-2.4-HOBBIT, only a FIXES-2.4.  Also, there is no PARANOID defined
| > or undefined in my config.h file.  Where did you come across this info?
| 
| -rw-------   1 alainm   vlsi        6553 Apr 13  1994 FIXES-2.4
| -rw-r--r--   1 alainm   vlsi       16027 Jun 11  1995 FIXES-2.4-HOBBIT

He was asking about NON-beta releases.

I don't believe the stock distribution has an easy way to disable SITE
EXEC.  You'll either need to muck around in the source code, or migrate to
a 2.4-beta release, available from ftp.academ.com:/pub/wuftpd/private. 

-James