Subject: cd ~ in wu-ftpd

From: [email-masked] (Tony Clark)
Date: Fri, 18 Apr 1997 15:31:35 +0100

when i cd to ~ inside ftp it complains about no such file or directory.

ftp> cd ~    
550 /local/disk1/ftp/./: No such file or directory.
ftp> 

/etc/passwd shows:
ftp:*:100:635:Guest FTP:/local/disk1/ftp/./:/usr/local/bin/nologin

/local/disk1/ftp/etc/passwd shows:
ftp:*NP*:100:634:Guest FTP:/:/usr/local/bin/nologin

I know chroot ~ftp is picking up the passwd and group files because
/bin/ls shows the right information. But something strange is still happening.

Does anyone have any ideas what might be wrong ?
Thanx in advance.

-- 

Tony Clark (Just another hacker)          Mobile Systems International PLC
Tel: +44 (0)171 971 8800                  Systems Administrator

External: [email-masked], [email-masked], [email-masked](personal)

---

From: Alain Magloire <[email-masked]>
Date: Fri, 18 Apr 1997 13:45:53 -0400 (EDT)

Salut A Vous, O Grand Manitou Tony Clark !!
> Does anyone have any ideas what might be wrong ?

the chroot in this case is 
chroot("/local/disk1/ftp")

chdir() reports that there is no dir. in
/local/disk1/ftp call /local/disk1/ftp/./
i.e:
ther is no 
/local/disk1/ftp/local/disk1/ftp/./

in other words create this

mkdir /local/disk1/ftp/local/disk1/ftp

and
cd ~

will work fine

dunno if I was clear enough, english words do not come easy
for a french person, to many if's then :-)

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!