Subject: Re: compiling after download

From: Mark Bergstrom <[email-masked]>
Date: Fri, 4 Apr 1997 18:52:39 -0600 (CST)

At 03:08 PM 4/4/97 -0600, you wrote:
>Hi...
>
>I just down loaded (is this the latest and greatest version?):
>
>  wu-ftpd-2.4.tar.Z 

Nope.  Get the beta-13.

>
>and I'm having some problems compiling it for HPUX.  the compile seems
>to fail at:
>
>  cc: "realpath.c", line 45: error 1711: Inconsistent parameter list  
>declaration for "realpath". 
>
>Here's the declaration in ftpd.c:
>
>  extern char *getline(),*realpath(char *pathname, char *result);
>

The difference is in the header files.  Your wu is expecting the variable
argument of varargs.h version.  The one on your path is probably the
stdlib.h version.

>If I change the declaration to:
>
>  extern char *getline(),*realpath();
>
>it works, but then fails at the function defention:
>
>  cc: "realpath.c", line 45: error 1711: Inconsistent parameter list  
>declaration for "realpath".
>  
>I'd appreciate any help ASAP. =)

The beta-13 may have enough new branches to take care of this for you, but I
don't know about the specific HP-case.

If you want to work with what you have, check for nested includes.  My bet
would be you need to fix syslog.h and stdlib.h to get your version to make.

Mark Bergstrom

>
>Thanks,
>  jeremy
>-- 
>***************************************
> Jeremy Pascual
> Software Engineer
> IT Application InfraStructure
> Development
>
> DHL Airways, Inc.
> 333 Twin Dolphin Drive
> Redwood City, CA 94065-1496
>
> OFFICE: B567
> VOICE:  (415) 802-4955
> FAX:    (415) 593-1689
> EMAIL:  [email-masked]
>***************************************
>
>

---

From: Jeremy Pascual <[email-masked]>
Date: Mon, 07 Apr 1997 09:57:19 -0500

> Nope.  Get the beta-13.

where can I find it? =)
 
> argument of varargs.h version.  The one on your path is probably the

so if I add an include varargs.h to realpath.c, will that fix the
problem...
 
thanks for the info (Mark) and the help. =)  

jeremy  

 DHL Airways, Inc.
 333 Twin Dolphin Drive

 OFFICE: B567
 VOICE:  (415) 802-4955
 FAX:    (415) 593-1689