Subject: Re: Static-ls

From: "Nelson C. L. Pedrozo" <[email-masked]>
Date: Tue, 1 Apr 1997 21:17:23 -0300

Hello!

  I used the static-ls patch, posted here the other day, along with fileutils3.16 as suggested
and it works, except for 1 thing. I use NIS+, and the static-ls patch assumes "/etc/passwd" as
the source for UID's. Does anyone know where to get a statically linked 'ls' (or source code)
that supports NIS+ (ie, uses getpwnam instead of scanning the /etc/passwd file) ?

  Thanks,

			Nelson Pedrozo

---

From: Emil Isberg <[email-masked]>
Date: Wed, 2 Apr 1997 02:48:13 +0200 (MET DST)

> that supports NIS+ (ie, uses getpwnam instead of scanning the /etc/passwd file) ?

Hello, I just wondered one thing .. you want to look up uid->NIS+-login,
right?

But then why don't you copy the needed libraries to ~ftp/usr/lib and the
systems ls to ~ftp/bin ?? That (shared) version should have the
possibility to check NIS+users (if you got some special files in
~ftp/etc) 
.. but a static version of ls with NIS+ check builtin might be
some problem .. because what we did to make the static ls was to create or
own caching of getpwnam (or similar) .. you've got to add checks to
weither NIS (YP) or NIS+ is what you use .. where to get the info
requested and the lots .. But if someone got the time .. do it .. :-)

/Emil