Subject: WU-FTPD Implementation Problem

From: Derek Pizzagoni <[email-masked]>
Date: Tue, 25 Mar 1997 13:50:02 -0800

Hello,

I just installed the 2.4.2 Beta 12 version of the FTPD on a Solaris 2.5
box, and I am having a problem.  Normal users are able to connect,
transfer files, list directories, etc...  Anonymous users can connect,
but then can not do anything other than change directories and PWD.  I'm
sure I haven't tried every command, but I know that they can not PUT,
GET, or LS.

My anonymous tree is set up as follows:

ftp
   bin
      ls (file)
   dev
      tcp (file)
      zero (file)
   etc
      group (file)
      passwd (file)
   incoming
   lib
      libc.so.1 (file)
      libdl.so.1 (file)
      libintl.so.1 (file)
      libw.so.1 (file)
   pub
   usr
      lib
         ld.so (file)
         libc.so.1 (file)

Whenever I try to do an ls, put, or get, I get the following error:

425 Can't create data socket (0.0.0.0,20): Bad file number.

Does anyone have any suggestions?

-- 
Derek R. Pizzagoni
UNIX Network Administrator
Interlink Computer Sciences, Inc.
URL: http://www.interlink.com

---

From: Michael Brennen <[email-masked]>
Date: Tue, 25 Mar 1997 16:26:28 -0600 (CST)

Have you read the FAQ?

   -- Michael

> 425 Can't create data socket (0.0.0.0,20): Bad file number.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-13.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

wu-ftpd list archive:  http://www.landfield.com/wu-ftpd/mail-archive/

There are additional security references in the above docs.

---

From: Jim Davis <[email-masked]>
Date: Tue, 25 Mar 1997 15:54:54 -0700 (MST)

> My anonymous tree is set up as follows:

Missing ticotsord and udp; see the in.ftpd man page.  (I assume by 'file'
you mean 'character special file'.) 

>       passwd (file)

Missing netconfig; see the in.ftpd man page.

>    lib

You don't need ~ftp/lib.

>       lib

Missing scads of stuff; see the in.ftpd man page. 

> Does anyone have any suggestions?

See the in.ftpd man page?

---

From: "Steven K. Buehler" <[email-masked]>
Date: Tue, 25 Mar 1997 20:07:43 -0600

What are the permissions and ownerships of these directories?

>425 Can't create data socket (0.0.0.0,20): Bad file number.

======================================================
Steven K. Buehler
S & B Computers
Rockford Illinois, USA
Phone: 815-398-7169
Fax: 815-398-7266
======================================================