Subject: all users access denied (??)

From: "Haralds Jass" <[email-masked]>
Date: Tue, 4 Mar 1997 13:15:46 -0800

Greetings,

I have set this up many times before, but am now getting strange 
problem with wu-ftpd 2.4.2b11.

Example --
Name (neptune:hjass):
530 User hjass access denied....
Login failed.
ftp> quit

anonymous access does not work as well.

* the shells are in /etc/shells
* ftpd was compiled on the same system (solaris 2.5.1 + SISS 1.0), 
and for other same setups has always worked
* passwords are correct in the /etc/shadow file (as on other servers 
where this is running)
* there is no /etc/ftpusers file
* no deny commands in /usr/local/etc/ftpaccess
* has been compiled with shadow support as far as I am aware of (as 
working on other exactly same config/OS servers!)

What could the problem be?

Thanks,
Haralds

P.S. Please send replies to me directly ([email-masked])

--
Haralds Jass <[email-masked]>
Superb Internet - "Ahead of the Rest."
http://www.superb.net

"I am easily satisfied by the very best"
- Winston Churchill

---

From: "Haralds Jass" <[email-masked]>
Date: Tue, 4 Mar 1997 13:52:21 -0800

On  4 Mar 97 at 14:34, Jim Davis wrote:

> On Tue, 4 Mar 1997, Haralds Jass wrote:
> 
> > Greetings,
> > 
> Grab beta-13 and try that.  A good general thing to try is
> 
> # truss -o /tmp/foo -f -p 123
> 
> where 123 is the PID of the inetd process.  Try logging in while that is
> running, and /tmp/foo should record what the ftp daemon was up to. 
> 
> Hmm.  It's not clear to me from reading the SISS release notes that you
> want to do that.  The tweaks seem pretty specific to http service, and I
> think they warn you may have problems with non-http stuff. 
> 

Thanks. I found that I had forgotten to do ln -s
/usr/local/etc/ftpaccess ftpaccess in /etc (as now it looks for
ftpaccess there, while by default I place in /usr/local/etc)!