Subject: automatic binary mode?

From: Mike Ellwood <[email-masked]>
Date: Tue, 25 Mar 1997 11:38:05 +0000 (GMT)

Is there a way of automatically setting binary mode for
transfers of certain files, e.g. based on file type, 
e.g. filename.exe?

The requirement has come to light for people fetching binary files
by web browsers.

the default seems to be for them go go over in ascii mode.

Can I over-ride this at the server end?

-- 
[email-masked]

---

From: Alex Belits <[email-masked]>
Date: Tue, 25 Mar 1997 04:12:51 -0800 (PST)

> Can I over-ride this at the server end?

  Client should be aware of the transfer mode, and there is no way to
notify client about mode from server in FTP protocol. Some Unix clients
always set image mode if remote system is identified in SYST as Unix, too.

--
Alex

---

From: Mike Ellwood <[email-masked]>
Date: Tue, 25 Mar 1997 12:15:02 +0000 (GMT)

> always set image mode if remote system is identified in SYST as Unix, too.

Thanks for quick reply Alex.

"status" or "type" can return whether its ascii or binary though,
can't it?

However, as I implied, the real problem seems to be people fetching
via netscape, and not a conventional ftp session.

I don't know if it's possible for such a browser to set the mode,
and the way that people normally use browsers would suggest that
the mode should somehow be set automatically.

Regards,
Mike

---

From: "Kevin W. Reed - Mail Admin" <[email-masked]>
Date: Tue, 25 Mar 1997 08:05:29 -0700

Subject: Re: automatic binary mode?
Date: Tue, Mar 25, 1997 at 12:15:02PM +0000

> the mode should somehow be set automatically.

The client is the one requesting the file and needs to request what
type of mode it wants the file to be sent.

I suspect that people using Netscape are left clicking on the tag to
download which I believe Netscape then downloads as ascii.  If they
right click on the tag, they download as binary ??

-- 
==========================================================================
Kevin W. Reed (KWR10)                   TeleSys Development Systems (TNET)
E-Mail: [email-masked]           Disability Systems & Software Development
WEB: http://www.tnet.com        MAJORDOMO - MAILBOT Administration Account
 MUTT Mail Users Agent WEB Archives are Online @ http://www.tnet.com/mutt