Subject: Lingering ftp procs & wu-ftpd-2.4.2-beta-13

From: Scot Needy <[email-masked]>
Date: Wed, 19 Mar 1997 08:59:30 -0500

Hi;

 Just installed wu-ftpd-2.4.2-beta-13 on a dec and 
 noticed I still have a problem with lingering ftp 
 sessions. Should this have been fixed w/ this revision,
 or do I need to patch it. 

 If so could you point me to the patch-HOWTO?

 OSF1 V3.2 41.64 alpha

 Thanks 
 Scot 

ps auxww | grep ftp 

nashnc5   8318  0.0  0.2 1.38M 264K ??       I    08:22:27     0:00.14
ftpd: pa1dsp1.nc5.infi.net: nas
roatimes  8795  0.0  0.3 1.45M 336K ??       I    08:37:21     0:00.43
ftpd: 205.216.36.66: roatimes:
nashnc5   9155  0.0  0.2 1.38M 264K ??       I    08:27:02     0:00.14
ftpd: comp140.bande.com: nashnc
nashnc5   9253  0.0  0.0 1.38M   0K ??       IW   07:48:55     0:00.14
ftpd: pa2dsp20.nc5.infi.net: na
nashnc5   1143  0.0  0.2 1.38M 216K ??       S    07:24:30     0:04.46
ftpd: pa1dsp22.nc5.infi.net: na
nashnc5   1176  0.0  0.0 1.38M   0K ??       IW   07:56:21     0:00.14
ftpd: dial-2.r03.tnsmvl.InfoAve
foto      1724  0.0  0.3 1.52M 328K ??       I    08:08:35     0:01.52
ftpd: pa2dsp23.fay.infi.net: fo
nashnc5  10206  0.0  0.2 1.38M 264K ??       I    08:46:12     0:00.15
ftpd: pa1dsp7.nc5.infi.net: nas
citrus   10346  0.0  0.3 1.46M 344K ??       I    08:47:42     0:00.17
ftpd: pa2dsp20.x31.infi.net: ci
nashnc5  10429  0.0  0.2 1.38M 264K ??       I    08:27:40     0:00.14
ftpd: pa1dsp13.nc5.infi.net: na
nashnc5   2475  0.0  0.2 1.38M 264K ??       I    08:27:48     0:00.14
ftpd: pa1dsp11.nc5.infi.net: na
nashnc5  10705  0.0  0.2 1.38M 264K ??       I    08:39:33     0:00.14
ftpd: 206.228.1.7: nashnc5: IDL
nashnc5  10987  0.0  0.2 1.38M 264K ??       I    08:32:58     0:00.14
ftpd: 170.141.62.11: nashnc5: I
bhplus   11064  0.0  0.3 1.52M 360K ??       I    08:25:35     0:01.24
ftpd: pa2dsp12.pit.infi.net: bh
nashnc5  11269  0.0  0.2 1.38M 264K ??       S    08:47:59     0:00.14
ftpd: 170.141.62.15: nashnc5: I
nashnc5  11327  0.0  0.2 1.38M 264K ??       I    08:38:56     0:00.14
ftpd: 170.180.189.34: nashnc5:
nashnc5  11609  0.0  0.2 1.38M 264K ??       I    08:45:35     0:00.17
ftpd: nas-tn3-23.ix.netcom.com:
nashnc5  11991  0.0  0.2 1.38M 264K ??       I    08:43:57     0:00.14
ftpd: 170.141.62.23: nashnc5: I
nashnc5  28687  0.0  0.0 1.38M   0K ??       IW   08:03:28     0:00.15
ftpd: host-207-53-16-17.bna.bel
nashnc5   4509  0.0  0.2 1.38M 248K ??       I    08:20:34     0:00.15
ftpd: 170.180.189.38: nashnc5:
nashnc5   5626  0.0  0.2 1.38M 264K ??       I    08:42:37     0:00.15
ftpd: FRUIT.COM: nashnc5: IDLE
nashnc5   6642  0.0  0.0 1.38M   0K ??       IW   07:53:59     0:00.14
ftpd: 170.middletown-017.va.dia
jax      32010  0.0  0.3 1.52M 352K ??       I    08:28:15     0:00.54
ftpd: pa1dsp23.jax.infi.net: ja

---

From: Alain Magloire <[email-masked]>
Date: Thu, 20 Mar 1997 11:13:24 -0500 (EST)

Salut A Vous, O Grand Manitou Scot Needy !!

>  If so could you point me to the patch-HOWTO?

I've seen a lot of patches on this list but
did not encounter this one :-)

> ftpd: comp140.bande.com: nashnc
.....

Beta-13 took care of some problems but not all.

One of the reasons is that in TCP/IP it's not easy to detect when a peer die.
Another was deadlocking, but it was seldom.

Solution was propose , but I don't know if Mr Barber
was listening or how easy is it to implement( in a portable way ).

1- use a global timer
2- use keepalive
3- use a probe

-- 
au revoir, alain
----
Aussi haut que l'on soit assis, on est toujours assis que sur son cul !!!