Subject: wuftpd on solaris 2.5

From: Faisal Hameed (KR) <[email-masked]>
Date: Wed, 12 Mar 1997 22:24:50 -0500

can't get ls to work in anonymous ftp :-

I have tried copying all the libs that ls needs by using ldd
in to ~ftp/usr/lib.

Also I have tried statically compiling ls from the source code
but no luck:-

Any help is appreciated ...

thanks

---

From: Dave Goldsmith <[email-masked]>
Date: Wed, 12 Mar 1997 21:05:20 -0800

> Any help is appreciated ...

I just experienced the same problem on Solaris 2.3.

The solution was to make all of the files in ~ftp/usr/lib EXECUTABLE.
I don't know why these need to executable but that solved the problem.

On my Linux box, the files are not executable and it works so this must
be Solaris specific.

Dave Goldsmith
[email-masked]

---

From: Vidiot <[email-masked]>
Date: Thu, 13 Mar 1997 00:21:48 -0600 (CST)

<can't get ls to work in anonymous ftp :-
<
<I have tried copying all the libs that ls needs by using ldd
<in to ~ftp/usr/lib.
<
<Also I have tried statically compiling ls from the source code
<but no luck:-
<
<Any help is appreciated ...

Read the original Sun in.ftpd man page.  It has a script for installing
the necessary files for ftp.  It worked for me.

MB
-- 
System Administrator - Finnigan FT/MS - Madison WI. <URL:http://www.ftms.com/>
e-mail: [email-masked]
phone: (608) 273-8262 ext: 612  fax: (608) 273-8719
Visit - <URL:http://www.cdsnet.net/vidiot/>  (Your link to Star Trek and UPN)