Subject: Can't get ftpconversions to work, all simple checks performed....

From: Albert Brouwer <[email-masked]>
Date: Mon, 10 Mar 1997 17:09:36 +0100

Hi folks,

I hope that somebody can help me out here, because I'm really
getting mad ......

I have a wu-ftpd-2.4 running on Solaris 2.4. I have a guest group
set up with chroot-ed accounts, this all works fine. Now I would
like to start using ftpconvesions (compress, gzip, tar, just the
simple things). The relevant ftpaccess lines are:

class local 	real,guest,anonymous <file>
class remote	guest,anonymous <file> (file contains '*')
guestgroup guest (this is not the real groupname ;-) )
compress	yes	local,remote
tar		yes	local,remote
gzip		yes	local,remote
log commands	guest,real,anonymous
log transfers	guest,real,anonymous inbound, outbound

Test 'group' account in /etc/passwd looks like:
test:x:<uid>:<gid>:Test FTP Guest
user:/<home-dir>/./data:/bin/sh

Test 'group' account's bin, lib and dev directories look like:

bin:
---x--x--x  24 root  other    14696 Jan   9  1996  compress
---x--x--x  24 root  other    72668 Jan   9  1996  gzip
---x--x--x  24 root  other    20040 Oct    5  1995  ls
---x--x--x  24 root  other  448080 Jan   9  1996  tar

lib:
-r-xr-xr-x  24 root  other    24576 Oct    5  1995  	ld.so
.....						ls.so.1
.....						libc.so.1
.....						libdl.so.1
.....						libintl.so.1
.....						libnsl.so.1
.....						libw.so.1
.....						nss_compat.s0.1
.....						nss_dns.so.1
.....						nss_files.so.1
.....						nss_nis.so.1
.....						nss_nisplus.so.1
.....						straddr.so

dev:
crw-r--r--  24 root   other    11, 42  Oct  5  1995  tcp
crw-r--r--  24 root   other  105,   1  Oct  5  1995  ticotsord
crw-r--r--  24 root   other    11, 41  Oct  5  1995  udp
crw-r--r--  24 root   other    13, 12  Oct  5  1995  zero

the ftpconversion file looks like:
 :.Z:  :  :/bin/compress -d -c
%s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :  :  :.Z:/bin/compress -c
%s:T_REG|T_ASCII:O_COMPRESS:COMPRESS
 :.gz:  :  :/bin/gzip -cd
%s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :  :  :.gz:/bin/gzip -9 -c %s:T_REG|T_ASCII:O_COMPRESS:GZIP
 :  :  :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :  :  :.tar.Z:/bin/tar -c -Z -f -
%s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :  :  :.tar.gz:/bin/tar -c -z -f -
%s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

The server is started with options "-a -l".

Whenever I try to get a compressed file by adding the extention
".Z" or ".gz" I get the error:
550 <file>.Z: No such file OR directory.

Even when I start the server with the "-d" flag, I can't see it even
trying to compress the file !!!!!

HELP ME OUT PLEASE, WHAT AM I DOING WRONG ?!?!?!?!?!

Any help will be greatly appreciated.....

PS.: I have looked in the FAQ but could not find any hints there !

Thanks for any help in advance,
Albert Brouwer.

***********************************************
Albert Brouwer
+++++++++++++++++++++++++++++++
Elsevier Science, Molenwerf 1, P.O. Box 211, 1000 AE 
Amsterdam, NL
Tel.: +31-20-4853555, Fax: +31-20-4853400
E-Mail: [email-masked]
+++++++++++++++++++++++++++++++
CMG AT-I B.V., Kralingseweg 241-249, P.O. Box 8566, 3009 AN 
Rotterdam, NL
Tel.: +31-10-2421111, Fax.: +31-10-2421333
E-Mail: [email-masked]
+++++++++++++++++++++++++++++++
   "Where there are choices there is chaos,
    where there is clarity, there are no choices."
***********************************************

---

From: James Hawtin <[email-masked]>
Date: Tue, 11 Mar 1997 19:32:06 +0000 (GMT)

My ftp conversions...

 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -cf - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -cZf - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -czf - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

You sure your ftpconversions is in the right place?

if you are in any doubt...

strings ftpd | grep ftpconversions

where ftpd is the what ever file your ftpd is stored under it could be

in.ftpd for example.

James
--
No dinosaurs please we're goffik!  http://plant-eng.lboro.ac.uk/~cgjwh

So all I wanted in the end, was world domination, and a whole lot of money
to spend.  - New Model Army.

Lifes a Joke and Deaths the End, Live in Misery - Net.Goth