Subject: dir not working in solaris 2.5.1

From: Faisal Hameed (KR) <[email-masked]>
Date: Sat, 22 Mar 1997 20:51:28 -0500

I have installed the wuftp the newest version one more time and 
still I am not able to get the dir listing with the user names
and group names instead it gives me the listing of the id numbers.

I have tried to resolve this problem by reading man pages of wuftpd
but it does not mention this issue.

Any help is appreciated ...

fh@face:/home/face3/ftp/etc> ftp tec
Connected to tec.ufl.edu.
220 face FTP server (Version wu-2.4.2-academ[BETA-13](1) Sat Mar 22 20:29:58 
EST 1997) ready.
Name (tec:fh): ftp
331 Guest login ok, send your complete e-mail address as password.
Password:
230 Guest login ok, access restrictions apply.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 22
drwxr-xr-x   6 400      1            512 Mar 23 01:09 .
drwxr-xr-x   6 400      1            512 Mar 23 01:09 ..
-rw-r--r--   1 0        1             40 Mar 23 01:09 .welcome
lrwxrwxrwx   1 0        1              7 Mar 13 20:51 Obin -> usr/bin
lrwxrwxrwx   1 0        1              7 Mar 13 22:02 bin -> usr/bin
dr-xr-xr-x   2 0        1            512 Mar 13 22:02 dev
dr-xr-xr-x   3 0        1            512 Mar 13 03:44 etc
-rw-r--r--   1 0        1             10 Mar 13 22:06 message
drwxrwxr-x   5 400      1            512 Mar 23 01:13 pub
drwxr-xr-x   5 0        1            512 Mar 13 20:53 usr
-rw-r--r--   1 0        1             40 Mar 13 04:06 welcome.msg
226 Transfer complete.
696 bytes received in 0.14 seconds (5 Kbytes/s)
ftp>

---

From: James Hawtin <[email-masked]>
Date: Mon, 24 Mar 1997 09:05:37 +0000 (GMT)

If you want all the user names to be listed in you annoymous ftp archive
you need to copy the full /etc/passwd and /etc/groups files 

However this does pose security problems... Personally, I live with the 
numbers.

James