Subject: RE: FTP dropping xfers???!!!

From: Sasha Romanosky <[email-masked]>
Date: Tue, 25 Mar 1997 14:25:04 -0700

It would seem that we've touched on something here.....

It would also seem that, indeed, this is a symptom of TCP
and not necessarily ftp or http. Makes sense to me.

Now, since TCP was born to be (no, not wild) reliable, 
how can we stop these dropped connections - regardless
of delays or lost packets...???

[Oohh, where's Richard Stevens when you need him??]

Cheers,
Sasha Romanosky

>----------
>From: 	Bob Luckin[SMTP:[email-masked]]
>Sent: 	Tuesday, March 25, 1997 2:08 PM
>To: 	[email-masked]
>Subject: 	Re: FTP dropping xfers???!!!
>
>Kent Landfield said :-
>[Re "Connection reset by peer" problems...]
>> This is not a wu-ftpd problem I'll bet...
>
>Agreed.  In my posting, I said :-
>> Incidentally, we didn't just have this problem with the wustl server - it
>> happened with the machines' native FTP servers too.
>
>Since it appears that more than one of us have seen it also with non-wustl
>servers, it does seem to indicate a more generic problem.
>
>(Good war stories / advice, too, Kent.)
>
>Cheers, Bob
>-- 
>Bob Luckin      [email-masked]      "Able was I ere I saw Waterloo"
>

---

From: Alex Belits <[email-masked]>
Date: Thu, 27 Mar 1997 05:54:11 -0800 (PST)

> [Oohh, where's Richard Stevens when you need him??]

  I'm not Stevens, but if I correctly understood what he wrote about TCP
connection closing, it's caused by RST packet, sent to terminate
connection on socket that takes "too long" to close properly where "too
long" is defined in SO_LINGER option. It also depends on how socket
was closed, with or without shutdown() called. "Cure" will be to let
socket close by itself without defining SO_LINGER, but that may take long
time, and still won't save from timeouts in transfer.

--
Alex