Subject: RE: wuftpd on solaris 2.5

From: "Cox, Terry" <[email-masked]>
Date: Thu, 13 Mar 1997 10:39:33 -0600

Try copying these files into ~ftp/lib instead.  I had the same problem,
and this fix worked for me.

>----------
>From: 	Faisal Hameed[SMTP:[email-masked]]
>Sent: 	Wednesday, March 12, 1997 9:24 PM
>To: 	[email-masked]
>Subject: 	wuftpd on solaris 2.5
>
>
>can't get ls to work in anonymous ftp :-
>
>I have tried copying all the libs that ls needs by using ldd
>in to ~ftp/usr/lib.
>
>Also I have tried statically compiling ls from the source code
>but no luck:-
>
>Any help is appreciated ...
>
>thanks
>
>

---

From: James Hawtin <[email-masked]>
Date: Thu, 13 Mar 1997 20:01:46 +0000 (GMT)

I copyed all the libraries to /usr/lib then symlinked /usr/lib /lib just to be
safe.

James

Ps: As to the person who could not get wuftpd to work on solaris 2.4 question 
has been answered already this month, its in the mail archives. I guess we 
need someone to write a step by step faq.

Pps: have you changed your inetd.conf, have you created the ftp user and have
you installed the appropriate /etc files?

---

From: Faisal Hameed (KR) <[email-masked]>
Date: Thu, 13 Mar 1997 15:20:37 -0500

After much struggle I got the ls to work by statically recompiling
the ls command but now I can't seem to get in. I was able to
get in one time but now I have no ftpaccess file to disallow
any users for testing and I have tried "kill -HUP pid of inetd"
to restart it but it just won't let anyone in.

fh@face:/home/face1/fh/tmp1/wu-ftpd-2.4/doc/examples> ftp face.tec.ufl.edu
Connected to face.
220 face FTP server (Version wu-2.4(2) Wed Mar 12 15:46:52 EST 1997) ready.
Name (face.tec.ufl.edu:fh): fh
530 User fh access denied....
Login failed.
ftp> quit
221 Goodbye.

---

From: Donald Ball <[email-masked]>
Date: Thu, 13 Mar 1997 15:37:24 -0500 (EST)

We're running beta12 on Solaris 2.5.1 and I just noticed a _lot_ of these
messages in syslog. Any clue what's up?

Mar 13 13:57:48 calzone ftpd[17849]: sleeping: fcntl lock of pid file
failed: Resource temporarily unavailable

- donald

---

From: [email-masked] (Chris Brown)
Date: Thu, 13 Mar 1997 12:47:25 -0800 (PST)

> failed: Resource temporarily unavailable

It's normal.  The code deals with this problem by sleeping.  You may want to
mask it out of your log files with a filter though.

Chris...

---

From: Alain Magloire <[email-masked]>
Date: Thu, 13 Mar 1997 16:09:50 -0500 (EST)

Salut A Vous, O Grand Manitou Chris Brown !!

> It's normal.

I wouldn't not say normal if you have _a lot_ of this from the same process
It's probably 'stuck', you'll have to kill the process by hand.

>  The code deals with this problem by sleeping.

IMHO deals with it the wrong way

>  You may want to mask it out of your log files with a filter though.

it also a good sign that something is wrong i.e too many connections
NFS going bezerk .. what ever. In breif once a while is fine but
clobbering syslog is worth investigating.

-- 
au revoir, alain
----
Teamwork is essential -- it allows you to blame someone else.

---

From: "Jake Cunningham" <[email-masked]>
Date: Thu, 13 Mar 1997 16:24:17 -0500 (EST)

I've had the same problem, It's not something to be ignored.
The ftp service locks up and no-one is able to ftp in.
The only way I can get it to stop is to kil the active ftp processes
and kill -HUP the init daemon. 
Has anyone found a work around ??? 

					Jake

* -  -  -  -  * -  -  -  - * -  -  -  -  * -  -  -  -  * -  -  *  -   -  *
| Jake Cunningham                                                        | 
  System Administrator                           Phone: (413) 577-0450      
* Five College Radio Astronomy Department        Fax :  (413) 545-4223   * 
  University of Massachusetts, Amherst         Office:  LGRC Room 517P  
| [email-masked]                                             |
* -  -  -  - * -  -  -  -  * -  -  -  -  * -  -  -  - *  -  -  *  -  -   *

---

From: Alain Magloire <[email-masked]>
Date: Thu, 13 Mar 1997 16:38:35 -0500 (EST)

Salut A Vous, O Grand Manitou Jake Cunningham !!

> Has anyone found a work around ??? 

it's not exactly a work around, I've change the code
to allow a fix number of iterations, about 300 secs which
is infinity to any normal human :-) then  give up and bail out.
_PATHPIDNAMES may be in a funny state .i.e wrong count
of limit

---

From: Donald Ball <[email-masked]>
Date: Thu, 13 Mar 1997 16:49:34 -0500 (EST)

> It's probably 'stuck', you'll have to kill the process by hand.

About 150 an hour, from lots of different processes, not the same one over
and over. Typically we handle 150,000 transactions per day, so only a
small fraction of the ftpds run into this problem. Just curious, it
doesn't seem to be harming anything.

- donald

---

From: James Hawtin <[email-masked]>
Date: Thu, 13 Mar 1997 22:22:21 +0000 (GMT)

> Any help is appreciated ...

create a /etc/ftpaccess file or, run in.ftpd without the -a option
in your inetd.conf

For more information se my solaris 2 installation guide just posted

James

---

From: Alain Magloire <[email-masked]>
Date: Thu, 13 Mar 1997 18:47:38 -0500 (EST)

Salut A Vous, O Grand Manitou Donald Ball !!

> doesn't seem to be harming anything.

- if you have a class limit.
  let say you have a limit of 10
  Those zombies deny access to valid connection
- clobbering syslog
- invalid entry in your process table  

If you allow 400 connections and xfer 10 GIG a day
seeing this message is not alarming, unless it came
from the same process again and again
And it that situation I would change the code
and notice syslog at every 60 iterations.

---

From: [email-masked] (Chris Brown)
Date: Thu, 13 Mar 1997 16:30:59 -0800 (PST)

> and notice syslog at every 60 iterations.

Perhaps some work should be put into serving the information in a sane way
to get rid of this problem?  I'm currently writing a 'bandwidth' server
which could double as a ftpaccess server...  This would also probably be
handy in a standalone version of wuftpd since the communication method would
already be in place.  Any comments from developers (of which I'm not one :)?

Chris...

---

From: Alain Magloire <[email-masked]>
Date: Fri, 14 Mar 1997 17:21:27 -0500 (EST)

> to get rid of this problem? 

you have a suggestion ?

> I'm currently writing a 'bandwidth' server 
> which could double as a ftpaccess server...

I don't see what you mean, how will those processes communicate ?
IPC ? file sharing ?

>  This would also probably be
> already be in place.

standalone as is not start by inetd ?

> Any comments from developers (of which I'm not one :)?

neither am i :-)