Subject: Problem with automatic compression

From: "Thomas Bruckbauer" <[email-masked]>
Date: Wed, 5 Mar 1997 18:24:20 -0500

Hi,

thanks to everybody how showed me were the FAQ is!

Unfortunately the FAQ did not help me... so:

I am having trouble with the automatic compression/decompression:

I always get file not found errors!
This is for real users and anon-ftp!

SunOS 4.1.4
(Version wu-2.4(1))
ckconfig says everything is ok. (I did not change the default paths)

wu-ftpd itself is working (dir, ls, get...)
chroot ~ftp /bin/compress something works too (so all libraries/devices are
there)

contents of ftpacces: (as in doc/examples)
exp96_04con:62> cat ftpaccess
class   all   real,guest,anonymous  *

limit   all   10   Any              /etc/msgs/msg.dead

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

email user@hostname

contents of ftpcobcversions: (as in doc/examples)
 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

I guess I am missing something... But what?

Thomas

-- 
//--------------------------------------------------------//
Thomas Bruckbauer                [email-masked]                  
CTI Pet Systems Inc              Phone:  (423) 966-7539         
810 Innovation Drive             Direct: (423) 966-0072x424     
Knoxville, TN 37932              Fax:    (423) 966-8955         
//--------------------------------------------------------//

---

From: Kent Landfield <[email-masked]>
Date: Wed, 5 Mar 1997 17:47:48 -0600 (CST)

# I always get file not found errors!
# This is for real users and anon-ftp!
# 

# contents of ftpcobcversions: (as in doc/examples)

Well, besides the name of the file being a problem.... ;-)

Have you checked the permissions on the ~ftp/bin directory and
executables and make sure they are inplace and executable by your
ftp user ?

#  :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
#  :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
#  :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
#  :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
#  :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
#  :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
#  :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

-- 
Kent Landfield                        Phone: 1-817-545-2502             
The Landfield Group                   FAX:   1-817-545-7650             
Email: [email-masked]             http://www.landfield.com/
Please send comp.sources.misc related mail to [email-masked].
Search the Usenet Hypertext FAQ Archive at http://www.landfield.com/faqs/

---

From: "Thomas Bruckbauer" <[email-masked]>
Date: Thu, 6 Mar 1997 10:19:50 -0500

On Mar 5,  5:47pm, Kent Landfield wrote:
> Subject: Re: Problem with automatic compression

Well, sometimes my brain is faster than my fingers... or vice versa ;-)

> executables and make sure they are inplace and executable by your

I checked. compress has the same permissions as ls and ls works...

Thomas