Subject: Re: timezone wrong under IRIX

From: [email-masked] (Jerry Trummer)
Date: Thu, 6 Mar 1997 17:18:06 -0500

> 
> > 
> > 
> > Has anyone gotten wu-ftpd to work under IRIX 5.3 or IRIX 6.2 --AND--
> > have the correct time entered in the SYSLOG?  
> > 
> > The fixes referenced in the wu-ftpd FAQ (#7 and #8) don't seem to 
> > work for IRIX.
> > 
> > Thanks...
> 
> Change SPT_TYPE in your config file to SPT_NONE.  SPT_REUSEARGV is not
> applicable to IRIX unfortunately.
> 

Chris,
Thanks for responding, but there is no SPT_TYPE in any config.h file
nor is it referenced in any of the software in my wu-ftpd-2.4 release.

I did try adding the SPT_NONE definition to the config.h and it didn't
solve the problem.  It records syslog entries in Greenwich Mean Time,
which is +5 hours from all other syslog entries.

If you have encountered this problem on IRIX 5.3 OR IRIX 6.2 and 
resolved it, please let me know how you did it.  Was it wu-ftpd-2.4
or some earlier release?

Thanks...
--
------------------------------------------------------------------------
Jerry Trummer,  Contractor - Ohio Aerospace Institute (OAI)
WL/FIMC Bldg 450
2645 Fifth St Ste 7
Wright-Patterson AFB  OH  45433-7913

[email-masked]
voice:(937)255-2455  fax:(937)656-4210
------------------------------------------------------------------------

---

From: [email-masked] (Chris Brown)
Date: Thu, 6 Mar 1997 14:52:03 -0800 (PST)

> resolved it, please let me know how you did it.  Was it wu-ftpd-2.4

For Irix, you should use a beta release of wu-ftpd (beta-12 is what I
prefer) since somewhere during beta they fixed the hanging process problem
with wu-ftpd on IRIX and Solaris.  It may be that SPT_TYPE was a config
which was added during this period too, but I'm not sure about that.

Chris...

---

From: [email-masked]
Date: Thu, 6 Mar 1997 17:57:20 -0500 (EST)

Jerry,
In the config file if you undef the SETPROC something or other that
should do it. Irix 6.? doesn't give the right timezone of the
variable is defined.

Doug

-- 
Doug Courtney
[email-masked]
(908)949-3597

---

From: Ayamura Kikuchi <[email-masked]>
Date: Fri, 07 Mar 1997 07:39:10 +0900

From: [email-masked] (Jerry Trummer)
Subject: Re: timezone wrong under IRIX
Date: Thu, 6 Mar 1997 17:18:06 -0500
Message-ID: <[email-masked]>

> resolved it, please let me know how you did it.  Was it wu-ftpd-2.4

Change your config file "src/config/config.sgi".

% diff config.sgi config.sgi.orig
21c21
< #define SPT_TYPE SPT_NONE
---
> #define SPT_TYPE SPT_REUSEARGV

--
Ayamura Kikuchi

---

From: [email-masked] (Winfried Magerl)
Date: Fri, 7 Mar 1997 10:13:23 +0100 (CET)

> nor is it referenced in any of the software in my wu-ftpd-2.4 release.

Looks like you have an older release. Maybe SETPROCTITLE is set in
this release.
Undefine this and your time should be right.
reason: SETPROCTITLE removes removes the environment (including $TZ)

regards

	winfried

-- 
Winfried Magerl - Internet Administration
Siemens Business Services, 81739 Munich, Germany
Internet-Mail: [email-masked]