Subject: Re: Installing over the top of manufacturer's version

From: [email-masked] (Nathan Berry)
Date: Mon, 10 Feb 1997 10:46:02 -0700

John,

If you use the installpatch script that comes with Sun's patches the checksum 
information will be different and the upgrade of the patch should fail.

      _/          _/_/_/_/_/_/        Nathan Berry
     _/_/        _/          _/       6501 E Belleview Ave.
    _/  _/      _/          _/        Englewood, CO  80111
   _/    _/    _/_/_/_/_/_/           Phone: (303) 889-8816
  _/      _/  _/          _/          Fax:   (303) 889-8805
 _/        _/_/          _/           Email: [email-masked]
_/          _/_/_/_/_/_/              

> From [email-masked] Mon Feb 10 10:10:12 1997
> Date: Mon, 10 Feb 1997 17:08:18 GMT
> From: [email-masked] (Mr J. Attwood)
> To: [email-masked]
> Cc: [email-masked]
> Subject: Installing over the top of manufacturer's version
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> I'm trying to upgrade from 2.4 to 2.4.2-beta-12, and find that the default
> install (for Solaris 2.5) installs ftpd as /usr/sbin/in.ftpd and the man
> pages under /usr/share/man.
> 
> Can anyone reassure me as to how resiliant this would be if the system were
> to be patched, say to cope with the latest CERT scare. Would install_patch
> notice that /usr/sbin/in.ftpd was not as originally installed, or that its
> manpage had been replaced, or might it blithely overwrite the wu-ftpd version
> with a patched but nowhere near as good Solaris version?
> 
> Thanks in advance,
> 
> John Attwood.
> [email-masked]

---

From: Michael Helm <[email-masked]>
Date: Mon, 10 Feb 1997 09:52:59 -0800

Michael Helm writes:
> Based on my experiences with sendmail, it would most likely 
> blithely overwrite the rogue wu-ftpd binary it found.

I should have added that the behavior of the solaris installation
programs depends on what you're doing, or "can depend".

installpatch will probably act as I described.  A fresh re-install
will probably act as I described.  An "upgrade" install is a little
unpredictable.  It may replace.  It may replace & complain.
It _may_  skip this ftpd binary, or even blow up & refuse to finish the
upgrade (this happens sometimes when something about the patch
set you have installed causes it problems).  These things shouldn't
really happen, but I'm warning you anyway because I don't want
anyone closing in on me with lawyers!