Subject: Virtual FTP????

From: Mike <[email-masked]>
Date: Sat, 22 Feb 1997 18:29:49 -0500

Someone told me about an FTP daemon called "Virtual FTP" This daemon is
supposed to allow you to make differant anonymous FTP home directories for
differant domain names/IP's on a system. Has anyone come accross this
daemon, or know what I am talking about?

                                Thanks
                                [email-masked]

---

From: Michael Brennen <[email-masked]>
Date: Sat, 22 Feb 1997 19:53:57 -0600 (CST)

Look at the info below, and read the VIRTUAL howto.

   -- Michael

> daemon, or know what I am talking about?

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-12.tar.Z

wu-ftpd FAQ:  http://www.cetis.hvu.nl/~koos/wu-ftpd-faq.html
              OR
              send mail to [email-masked]
              with a subject line: send faq

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
              OR
              send mail to "[email-masked]"
              (immediate autoresponder; subject does not matter)

There are additional security references in the above docs.

---

From: "James L. McGill" <[email-masked]>
Date: Mon, 24 Feb 1997 10:04:01 -0600 (CST)

I have a problem with Virtual FTP and I think I need advice before I 
go hacking the code.

I have been using "Guest" users.  All users are guests.

I now enable "virtual" ftp and it works.  Except that 
the users who log in with their username and password 
are chrooted to the (virtual) anonymous directory.

It would appear that the check for "virtual" happens before
the check for guest.  Since these guest users will be coming
in the same address as the corresponding virtual address, I
guess I need to make the check that looks up the virtual
stuff in ftpaccess *only* for anonymous users.  I notice that
when this decision is made in ftpd.c, is before the username
has been taken.

------------------------+----------------------------------------------
   James L. McGill      |              NETCOM  Interactive
 Programmer / Analyst   |                 Dallas, Texas  
 <[email-masked]>  | -=[ http://www.conservatory.com/~fishbowl ]=-
------------------------+----------------------------------------------