Subject: Running ftpd as a non-root user

From: Glen Raynor <[email-masked]>
Date: Mon, 03 Feb 1997 11:27:09 -0800

Is it possible to run the wu-ftpd from within inetd as some user other than
root?
---
Glen Raynor <[email-masked]> 674-2246
Progressive Networks, Inc.
http://www.RealAudio.com/
Network Technician and all around fun guy

---

From: [email-masked] (Brian Cully (Personal))
Date: Mon, 3 Feb 1997 17:24:30 -0500

> Is it possible to run the wu-ftpd from within inetd as some user other than

I don't think so, given a lot of the things it does while in passive
mode.

-- 
Brian Cully						[email-masked]
``It's such a sad old feeling, the fields are soft and green,
  and it's memories that I'm stealing, but you're innocent when you dream.''
		-- Innocent When You Dream (Tom Waits, Frank's Wild Years)

---

From: Alain Magloire <[email-masked]>
Date: Tue, 4 Feb 1997 09:29:40 -0500 (EST)

> Is it possible to run the wu-ftpd from within inetd as some user other than

Probably, but not without some change to the src code.
Non-anonymous will not work, the server would not be able to
reset is uid.
So for anonymous without UPLOADING, PASV on ports > 1024
get rid of all the setuid(0), ... it should work ;-)

In brief, get rid of all the fun part and it should be fine ;-)

-- 
Bonne anne'e, alain