Subject: wu-ftpd 2.4 errors on Solaris 2.5

From: Mohammed Ali <[email-masked]>
Date: Fri, 28 Feb 1997 10:08:46 -0600 (CST)

Hi,
 
I have posted this question earlier, but, got no answer from 
anybody, so, I am posting it again.

I am experiencing a wierd problem on my Solaris 2.5 machine using 
wu-ftpd 2.4. Periodically, I am getting the following error messages
on my console and /var/adm/messages:
 
Feb 25 07:54:27 xxxx ftpd[17762]: setsockopt (SO_OOBINLINE): Broken pipe
Feb 25 07:54:27 xxxx ftpd[17762]: fcntl F_SETOWN: Broken pipe
Feb 25 07:55:29 xxxx inetd[130]: accept: Protocol error
Feb 25 08:02:44 xxxx last message repeated 7 times
Feb 25 08:03:47 xxxx inetd[130]: accept: Protocol error
 
where xxxx is the hostname.
 
I have already searched in the wu-ftpd mailing list archives but, I could 
not find an answer. If someone has any suggestions or solutions 
please let me know. your response is appreciated.
 
Thanks in advance.
--Mohammed Ali.

---

From: [email-masked] (Chris Brown)
Date: Fri, 28 Feb 1997 09:24:58 -0800 (PST)

> where xxxx is the hostname.

Sounds like someone has a broken client.  I'm assuming that people are
getting on to your site succesfully?  If this is the case, these messages
are probably generated by a client which is disconnecting without saying the
friendly 'quit' which tells ftpd to close the socket before the client does.

Chris...