Subject: Re: Virtual FTP????

From: [email-masked] (Bob Myers)
Date: Mon, 24 Feb 1997 12:57:34 -0800

On Feb 24, 10:04, "James L. McGill" wrote:
} Subject: Re: Virtual FTP????
> I have a problem with Virtual FTP and I think I need advice before I 
> go hacking the code.
> 
> I have been using "Guest" users.  All users are guests.
> 
> I now enable "virtual" ftp and it works.  Except that 
> the users who log in with their username and password 
> are chrooted to the (virtual) anonymous directory.
> 
> It would appear that the check for "virtual" happens before
> the check for guest.  Since these guest users will be coming
> in the same address as the corresponding virtual address, I
> guess I need to make the check that looks up the virtual
> stuff in ftpaccess *only* for anonymous users.  I notice that
> when this decision is made in ftpd.c, is before the username
> has been taken.

Yes, this is true.  Personally, I don't like this behavior, and I've
hacked my copy of the code to do the reverse.  It's an easy fix; just
put the anonymous check before the virtual check.

I think guest users chroot should supercede virtual chroot, rather
than the other way around.

-- 
Bob Myers                              InteleNet Communications, Inc.
Email: [email-masked]               30 Executive Park, Suite 150
Phone: 714-851-8250                    Irvine, CA 92714
Fax:   714-851-1088                    http://www.intelenet.net/

---

From: "Roger A. Hanke" <[email-masked]>
Date: Mon, 24 Feb 1997 17:22:07 -0500

OK now I have to ask how is Virtual FTP supposed to work with respect
to real, guest and anonymous class users. The way mine was working
(Beta 12, Solaris 2.5.1) seemed to be different than Bob and James
description.

I could only get my virtual root line recognized when logging in as
anonymous or ftp. When I logged in as a real or guest class id then I 
was put into the proper home dir based on /etc/passwd entry.
So which way is how it is currently written to work?
	Thanx,
	Roger Hanke

----------
From: 	Bob Myers
Sent: 	Monday, February 24, 1997 3:57 PM
To: 	[email-masked]; [email-masked]
Cc: 	Mike
Subject: 	Re: Virtual FTP????