Subject: chroot() guestt accounts, Linux 2.0.28 and wuftpd-2.4.2-beta-11

From: Gregory Youngblood <[email-masked]>
Date: Tue, 4 Feb 1997 01:20:45 -0600 (CST)

Here's the scoop:
	linux 2.0.28
	libc-5.3.12
	wu-ftpd-2.4.2-beta-11 -or-
	wu-ftpd-2.4(1)

When using wu.ftpd-2.4(1) my guest accounts chroot() to the right place 
and things are pretty good, working as expected.

No other changes, just doing a 'build lnx' after applied dirent fix and 
then install. ftp into account, cd / and now I have access to the full 
server directory structure.

Now, my question: Why does the old ftpd work and the new ftpd doesn't?

Any clues?

Thanks
Greg

---

From: Tim Yocum <[email-masked]>
Date: Tue, 4 Feb 97 12:28 CST

test

---

From: Steve Lee <[email-masked]>
Date: Thu, 6 Feb 1997 23:58:58 GMT

> > 
> > Yes,  leave the chroot part but remove the home dir part of the
> > password entries for the accounts that stopped working.  IE:
> > 
> > stlee:x:1200:14:Steve Lee:/public/./pub/stlee:/bin/csh
> > becomes:
> > stlee:x:1200:14:Steve Lee:/public:/bin/csh
> > 
> > Let me know if it helped.
> 
> I tried it.  Again, 2.4 worked fine, 2.4.2-beta12 failed again. Log in to 
> ftp with a guest account, do a dir, get the right dir, do a "cd /" and 
> then a "dir" again. 2.4 gives the same directory as the first time, beta 
> 12 gives the actual "/" root directory.
> 
> greg
> 

You are having a different problem than I had.  I am not completely set
up yet I hope I do not run your problem too.

It does however look like the chroot part of wu-ftp_2.4-beta_12 is a
bit broken.  I found I could not use the /./cd2dir feature and you are
finding that you can cd out of the chrooted path.  I wonder how long
before a fix is out?

Thanks
Steve Lee
[email-masked]