Subject: How to prevent real users from ftping in

From: LES MAYEDA TECH SUPPORT/ISS X6656 <[email-masked]>
Date: Fri, 28 Feb 1997 09:31:24 -0700 (PDT)

Hello,

I'm running wu-ftp2.4 and need to know how to prevent
real users from ftping in.

I removed 'real' from the class option but it appears
that real users can still ftp in.

Is there something else I need to set?

ftpaccess file:
# cat ftpaccess
class   all   guest,anonymous  *

limit   all   10   Any              /etc/msgs/msg.dead

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

email user@hostname
------------------------

Thanks in advance.

Les Mayeda
[email-masked]
Cedars-Sinai Medical Center

---

From: [email-masked] (Chris Brown)
Date: Fri, 28 Feb 1997 09:55:40 -0800 (PST)

> Is there something else I need to set?

try adding this:

class noaccess real *

limit noaccess 0 Any /etc/msgs/noaccess.txt

Chris...

---

From: "Gregory S. Youngblood" <[email-masked]>
Date: Fri, 28 Feb 1997 14:32:40 -0500

Here's how i did something like that, but for anon instead of real..

class   local   real,guest 127.0.0.1
class   remote  real,guest *
class   anonrmt anonymous  *

limit   local   20  Any                 /etc/msgs/msg.toomany
limit   remote  100 SaSu|Any1800-0600   /etc/msgs/msg.toomany
limit   remote  60  Any                 /etc/msgs/msg.toomany
limit   anonrmt 0   Any                 /etc/msgs/msg.toomany

For your system I'd suggest adding the following lines:

class	other	real	*

limit	other	0	Any	/etc/msgs/msg.dead

That should do the trick for you.

Greg