Subject: Re: SIGSEGV in ftpd.c

From: Michael Bracewell <[email-masked]>
Date: Mon, 24 Feb 1997 11:59:18 -0500 (EST)

Michael Brennen sez:
| 
| 
| Good show, but this did not fix the specific problem -- I was able to
| duplicate it after installing this patch. 
| 
| It is easy to duplicate -- just try to login as a nonexistent user.  Looks
| like I won't be able to get to it for a couple of days at least; somehow
| closing new business seems more important than finding this critter. :) 
| 
|    -- Michael

Hmm, curious -- on my BETA-12 under SunOS 5.5 (Solaris 2.5) if I give
a nonexistent username (one not in the system passwd file), I don't see
anything out of the ordinary -- here's a snippet:

	% ftp 127.1
	Connected to 127.1.
	220 FTP.PeachNet.EDU FTP server (Version wu-2.4.2-academ[BETA-12](1) Tue Feb 11 14:03:23 EST 1997) ready.
	Name (127.1:myusername): nonexist
	331 Password required for nonexist.
	Password: boguspw
	530 Login incorrect.
	Login failed.
	ftp> quit
	221 Goodbye.
	%

Did I misunderstand or is this different behaviour than you're seeing?

-- 
Michael Bracewell <[email-masked]>
Office of Information and Instructional Technology
Technology Support Services
Board of Regents of the University System of Georgia

---

From: Michael Brennen <[email-masked]>
Date: Mon, 24 Feb 1997 12:52:19 -0600 (CST)

Feb 24 12:48:45 ns1 ftpd[17045]: USER foo
Feb 24 12:48:47 ns1 ftpd[17045]: PASS password
Feb 24 12:48:47 ns1 ftpd[17045]: exiting on signal 11

where foo does not exist on the system (linux 2.0.27).  I'm on the latest
2.7.2.1 gcc, libc-5.4.23.  Anyone else seeing anything like this????

   -- Michael