Subject: How to prevent real users from ftping in. Question (2)

From: LES MAYEDA TECH SUPPORT/ISS X6656 <[email-masked]>
Date: Fri, 28 Feb 1997 12:09:20 -0700 (PDT)

Hello Chris,

Thanks for your response.

A couple more question:

1)  There are some real users that need ftp access.
    How do I code the ftpaccess so that a small group
    of users can have access to ftp?

2)  Should I just disallow real user access altogether 
    and force them to use special ftp accounts (ftp1, ftp2, etc...) 
    modeled after the anonymous ftp setup?

Thanks,

Les
Cedars-Sinai Medical Center
[email-masked]

-----------------
From:	IN%"[email-masked]" 28-FEB-1997 10:12:11.37
To:	IN%"[email-masked]"
CC:	
Subj:	RE: How to prevent real users from ftping in

> I'm running wu-ftp2.4 and need to know how to prevent
> real users from ftping in.
> 
> I removed 'real' from the class option but it appears
> that real users can still ftp in.
> 
> Is there something else I need to set?

try adding this:

class noaccess real *

limit noaccess 0 Any /etc/msgs/noaccess.txt

Chris...

> ftpaccess file:
> # cat ftpaccess
> class   all   guest,anonymous  *
> 
> limit   all   10   Any              /etc/msgs/msg.dead
> 
> readme  README*    login
> readme  README*    cwd=*
> 
> message /welcome.msg            login
> message .message                cwd=*
> 
> compress        yes             local remote
> tar             yes             local remote
> 
> log commands real
> log transfers anonymous,real inbound,outbound
> 
> shutdown /etc/shutmsg
> 
> email user@hostname
> ------------------------
> 
> 
> Thanks in advance.
> 
> Les Mayeda
> [email-masked]
> Cedars-Sinai Medical Center
> 

Date: Fri, 28 Feb 1997 09:55:40 -0800 (PST)
From: [email-masked] (Chris Brown)
Subject: Re: How to prevent real users from ftping in
Sender: [email-masked]
To: [email-masked]
Reply-to: [email-masked]

---

From: [email-masked] (Chris Brown)
Date: Fri, 28 Feb 1997 12:48:37 -0800 (PST)

>     of users can have access to ftp?

If you've installed ftpd properly, try 'man 5 ftphosts' and it should
explain how to restrict certain users and not others.

Example ftphosts file:
allow  anonymous       *
allow  chrisb          *.iceonline.com 127.0.0.1
deny   *               *

>     modeled after the anonymous ftp setup?

That depends.  Normally real users can access anything anywhere on the your
file system as if it was them.  If this isn't okay then you need to use
guest access as you suggest.  Any comments, anyone else?  I've never used
wuftpd's guest features.

Chris...

---

From: "Gregory S. Youngblood" <[email-masked]>
Date: Fri, 28 Feb 1997 16:43:26 -0500

>    of users can have access to ftp?

How many users on your system and how many users need to be allowed ftp
access?
How do new users get added (via script or other means)?

I don't know if this is the best way or not, but it is an option. 

You could always list the real users who are not allowed ftp access in
/etc/ftpusers (or whatever your _PATH_FTPUSERS is set to when you
compiled). Those users will not be allowed to log in via ftp.