Subject: strange logging problems

From: Yanni <[email-masked]>
Date: Wed, 5 Feb 1997 18:44:22 -0800

Solaris 2.5.1, b12...etc

syslog.conf:

daemon.emerg    /usr/adm/syslogs/daemon.emerg
daemon.debug    /usr/adm/syslogs/daemon.debug
daemon.alert    /usr/adm/syslogs/daemon.alert
daemon.crit     /usr/adm/syslogs/daemon.crit
daemon.err      /usr/adm/syslogs/daemon.err
daemon.warning  /usr/adm/syslogs/daemon.warning
daemon.notice   /usr/adm/syslogs/daemon.notice
daemon.info     /usr/adm/syslogs/daemon.info

with a tab in between fields and the files exist and other apps such as 
sendmail are logging properly.

inetd.conf:
ftp     stream  tcp     nowait  root    /products/ftpd/sol/etc/in.ftpd  
in.ftpd -a -l -L -d

the Makefile for ftpd has -DDEBUG in it.

I'm getting download info in /usr/adm/xferlog without problems, but 
nothing else is getting logged through syslog.

I have HUP'd the inetd daemon and the syslog daemon numerous times.

Any ideas?

thanks,

-jon

Jon (no h) S. Stevens     [email-masked]
ClearInk WebMagus         http://www.clearink.com/
finger [email-masked] for pgp pub key
ClearlyHome - MultiHoming for Mac WebServers
http://www.clearink.com/fun_stuff/plugins/
The Internet Weather Report
http://www.internetweather.com/
Jobs! - http://www.clearink.com/

---

From: [email-masked] (Mark S. Tremblay)
Date: Thu, 6 Feb 1997 11:06:50 -0500 (EST)

According to Yanni:
> ...
> ...

In a shoe what un-related theme - I'm running on Solaris 2.5 and 2.5.1
with wuftp2.4 and there are times that syslog just stops logging.  I'm
not sure if it is getting over-run from my ftp stuff, or if there are
bugs in syslogd.  

Anyone else see this behavior where syslog just simply stops logging?
For me, a simple stop and re-start fixes the problem, but no
indication as to why it stopped.

-- 
-Mark S. Tremblay
 Eastman Kodak - Elmgrove Plant
 [email-masked]
 (716) 253-0102

---

From: Jim Davis <[email-masked]>
Date: Thu, 6 Feb 1997 09:40:20 -0700 (MST)

> Anyone else see this behavior where syslog just simply stops logging?

Have you installed patch 103291-02 (for 5.5) or 103738-02 (for 5.5.1)?

---

From: Jim Davis <[email-masked]>
Date: Thu, 6 Feb 1997 09:46:53 -0700 (MST)

> daemon.info     /usr/adm/syslogs/daemon.info

That's an odd setup -- 'daemon.debug' will also log stuff at higher
priorities, so /usr/adm/syslogs/daemon.debug will get all the stuff also
in /usr/adm/syslogs/daemon.info, for instance. 

> I have HUP'd the inetd daemon and the syslog daemon numerous times.

Install patch 103783-02, if you haven't already. 

A generally helpful thing to try with syslog problems is to kill the
running syslogd, then start it again with the -d flag:  if you run

# /usr/sbin/syslogd -d

then it will print out a verbose account of what it thinks it's doing.

---

From: [email-masked] (Mark S. Tremblay)
Date: Thu, 6 Feb 1997 12:21:40 -0500 (EST)

> in /usr/adm/syslogs/daemon.info, for instance. 

You can also try 

	# logger -p daemon.info "Testing" 

And see if anything appears in /usr/adm/syslog/daemon.info.  Might
help determine if it is syslog or ftpd that is wacky...

---

From: James Sneeringer <[email-masked]>
Date: Thu, 6 Feb 1997 14:36:58 -0600 (CST)

On Thu, 6 Feb 1997, Jim Davis wrote:
| On Wed, 5 Feb 1997, Yanni wrote:
| > daemon.emerg    /usr/adm/syslogs/daemon.emerg
| > daemon.debug    /usr/adm/syslogs/daemon.debug
| > daemon.alert    /usr/adm/syslogs/daemon.alert
| > daemon.crit     /usr/adm/syslogs/daemon.crit
| > daemon.err      /usr/adm/syslogs/daemon.err
| > daemon.warning  /usr/adm/syslogs/daemon.warning
| > daemon.notice   /usr/adm/syslogs/daemon.notice
| > daemon.info     /usr/adm/syslogs/daemon.info
| 
| That's an odd setup -- 'daemon.debug' will also log stuff at higher
| priorities, so /usr/adm/syslogs/daemon.debug will get all the stuff also
| in /usr/adm/syslogs/daemon.info, for instance. 

Each log level should be prefixed by a '=' for the desired effect:

   daemon.=emerg        /usr/adm/syslogs/daemon.emerg
   daemon.=debug        /usr/adm/syslogs/daemon.debug
   ...

You should also make sure that there aren't any other across-the-board
settings for a given log level, as that may be overriding the daemon.*
settings.

-James