Subject: aix build

From: chip carman <[email-masked]>
Date: Sun, 9 Feb 1997 07:35:08 -0800

Several of you reported successful builds on AIX 4.1.4.  Any clues why I
might be getting these compiler errors ?
- strdup.c:48: conflicting types for `strdup'
- extensions.c:104: conflicting types for `realpath'

build aix results below:
-----------------------

# ./build aix

Linking Makefiles.

Making support library.
        cc -O2   -c getusershell.c
In file included from getusershell.c:155:
/usr/include/usersec.h:88: warning: `struct userpw' declared inside
parameter li
st
/usr/include/usersec.h:88: warning: its scope is only this definition or
declara
tion,
/usr/include/usersec.h:88: warning: which is probably not what you want.
        cc -O2   -c fnmatch.c
        cc -O2   -c strcasestr.c
        cc -O2   -c strsep.c
        cc -O2   -c vsnprintf.c
        cc -O2   -c authuser.c
        cc -O2   -c strdup.c
strdup.c:48: conflicting types for `strdup'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.1.4.0/2.7.2/include/string.h:146:
previo
us declaration of `strdup'
make: The error code from the last command is 1.

Stop.

Making ftpd.
        cc -O2 -I.. -I../support -L../support -c ftpd.c
        yacc  ftpcmd.y
        mv y.tab.c ftpcmd.c
        cc -O2 -I.. -I../support -L../support -c ftpcmd.c
        cc -O2 -I.. -I../support -L../support -c glob.c
        cc -O2 -I.. -I../support -L../support -c logwtmp.c
        cc -O2 -I.. -I../support -L../support -c popen.c
        sh newvers.sh
        cc -O2 -I.. -I../support -L../support -c vers.c
        cc -O2 -I.. -I../support -L../support -c access.c
        cc -O2 -I.. -I../support -L../support -c extensions.c
extensions.c:104: conflicting types for `realpath'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.1.4.0/2.7.2/include/stdlib.h:428:
previo
us declaration of `realpath'
make: The error code from the last command is 1.

#

-------------------------------------------------------
          chip carman,Web Administrator Macworld Online
                  [email-masked]
                    http://www.macworld.com

---

From: Dan Foster <[email-masked]>
Date: Sun, 9 Feb 1997 11:07:40 -0500 (EST)

Hot Diggety! chip carman was rumored to have said...
> might be getting these compiler errors ?

I get builds just dandy with IBM's C compiler (cc). I don't use gcc
primarily because cc builds a more suitable loader that runs on more
different AIX boxes, among other reasons.

-Dan Foster
Internet: [email-masked]