Subject: Re: Wrong timezone in output of 'ls -l' (fwd)

From: [email-masked] (Mark S. Tremblay)
Date: Mon, 17 Feb 1997 09:36:31 -0500 (EST)

According to Bob Luckin:
> From [email-masked] Fri Feb 14 23:03:45 1997
> Date: Fri, 14 Feb 97 21:51:59 CST
> Subject: Re: Wrong timezone in output of 'ls -l'
> 
> Mark Galbraith said :-
> > Server: Sun Sparc-20/Solaris 2.4
> > WU-FTP: 2.4
> > 
> > When viewing the output of an 'ls -l' command, the date/time shown
> > appears to be GMT.  I would like this to be my local timezone
> > (US/Pacific).  I tried setting the TZ environment variable in ftpd, but
> > it didn't seem to have any effect on the execution of ~ftp/bin/ls.
> > 
> > Is there anyway to do this?  If so, how?
> 
> You are probably missing the /usr/share/lib/zoneinfo directory from your
> FTP root - ie. ~ftp/usr/share/lib/zoneinfo...

My experience is that you _also_ need to have ~ftp/etc/default/init as
well.  You only need to pupulate the zoneinfo hierarchy with the
information pointed to by the init file.

-- 
-Mark S. Tremblay
 Eastman Kodak - Elmgrove Plant
 [email-masked]
 (716) 253-0102

---

From: Mark Galbraith <[email-masked]>
Date: Tue, 18 Feb 1997 12:25:49 -0800 (PST)

>>>>> "Mark" == Mark S Tremblay <[email-masked]> writes:

>> FTP root - ie. ~ftp/usr/share/lib/zoneinfo...

Mark> My experience is that you _also_ need to have ~ftp/etc/default/init as
Mark> well.  You only need to pupulate the zoneinfo hierarchy with the
Mark> information pointed to by the init file.

Through a combination of answers provided, I've now solved my problem.
Thanks to all that helped.

-- 
Mark Galbraith                   Member of The HTML Writers Guild
Engineer, Internet Services	              http://www.hwg.org/
Triad Systems Corporation
(PGP Fingerprint=1CB9 7481 AD5C 5709  690B AC09 7F65 D6F6)