Subject: Re: client problems

From: Alain Magloire <[email-masked]>
Date: Thu, 13 Feb 1997 18:02:40 -0500 (EST)

hello

: 
:     if (!anonymous) {    /* "ftp" is only account allowed no password */
:         if (*passwd == '-')
:             passwd++;
: 

It also means that if your passwd start with '-'
you will never be able to loggin as a real user.

Amusing don't you think :-)
Especially, when you have a student bugging you
by the fact that he can't FTP, poor kid.

-- 
au revoir, alain
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
POIRE: Premature Optimization Is the Root Of all Evil
                      D.K or is it B.K ? maybe A.M ;-)

---

From: Emil Isberg <[email-masked]>
Date: Fri, 14 Feb 1997 00:19:33 +0100 (MET)

> by the fact that he can't FTP, poor kid.

Well not really .. if you've got you're password as '-qwer1'  you just got
to type '--qwer1'
:-) It is as easy as that ..

hmm .. but he will never see those nifty messages that other will see as
they move around the tree ..

:-(

/Emil

---

From: Konstantin Eftaxias <[email-masked]>
Date: Fri, 14 Feb 1997 09:52:04 +0100 (MET)

> you will never be able to loggin as a real user.
I guess, in that case you could type '-'passwd, and you are in !?

------------------------------------------------------------------------------
Konstantin Eftaxias 					Tel.: ++49 711 701 756
Eftaxias EDV Beratung					Fax.: ++49 711 701 339
Bernhauser Hauptstr. 6a					eMail [email-masked]
70794 Filderstadt					eMail [email-masked]
------------------------------------------------------------------------------

---

From: Alain Magloire <[email-masked]>
Date: Fri, 14 Feb 1997 10:31:56 -0500 (EST)

> I guess, in that case you could type '-'passwd, and you are in !?

No,
see Emil's posting, for clarification