Subject: Beta-12 compiled under OSF

From: FTP Administrator <[email-masked]>
Date: Wed, 22 Jan 1997 15:59:44 +0100 (MET)

I tried to compile the new beta-12 version, but compiler stopped with an
error

cc: Error: ftpd.c, line 2272: In this declaration, "timeout" has no
linkage and is of an incomplete type.
        struct timeval timeout;
-----------------------^

I fixed it simply adding a 
#include <sys/time.h>
after the first list of #include in ftpd.c

After I fixed that, no other problem occurred, only a warning reported:
cc: Warning: access.c, line 355: In this statement, & before array "class"
is ignored.
    memset((void *)&class, 0, sizeof(class));
-------------------^

Massimo Gais
----
FTP Administrator                                        <[email-masked]>
C.D.S. - University "Federico II" of Naples (Italy)

                          "640K ought to be enough for anybody." 
                                           --  Bill Gates, 1981

---

From: Scot <[email-masked]>
Date: Thu, 23 Jan 1997 08:41:51 -0500 (EST)

Ditto:

 Linking Makefiles.
Makefile already present in root directory
Makefile already present in src directory
config.h already present in src directory
Makefile already present in support directory

Making support library.
rm -f libsupport.a
ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strerror.o
strsep.o authuser.o vsnprintf.o
ranlib libsupport.a

Making ftpd.
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c ftpd.c
/usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: storage size for
'timeout' isn't known
         struct timeval timeout;
 -----------------------^
/usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: Reference an expression
of void type or an incomplete type.
         struct timeval timeout;
 -----------------------^

 And many more 

 q: Is there a patch for lingering ftp sessions in here?

 TIA 
 Scot 

On Wed, 22 Jan 1997, Vidiot wrote:

> <I tried to compile the new beta-12 version, but compiler stopped with an
> <error
> <
> <cc: Error: ftpd.c, line 2272: In this declaration, "timeout" has no
> <linkage and is of an incomplete type.
> <        struct timeval timeout;
> <-----------------------^
> <
> <I fixed it simply adding a 
> <#include <sys/time.h>
> <after the first list of #include in ftpd.c
> <
> <After I fixed that, no other problem occurred, only a warning reported:
> <cc: Warning: access.c, line 355: In this statement, & before array "class"
> <is ignored.
> <    memset((void *)&class, 0, sizeof(class));
> <-------------------^
> <
> <Massimo Gais
> 
> Interesting, under Solaris 2.5.1 and GNU GCC 2.7.2, there are no such errors.
> It compiles up just fine and installed just fine.  Even works too.
> 
> MB
> -- 
> System Administrator - Finnigan FT/MS - Madison WI. <URL:http://www.ftms.com/>
> e-mail: [email-masked]
> phone: (608) 273-8262 ext: 612  fax: (608) 273-8719
> Visit - <URL:http://www.cdsnet.net/vidiot/>  (Your link to Star Trek and UPN)
>