Subject: Unable to compile on Digital Unix v3.2g

From: John Brunelle <[email-masked]>
Date: Mon, 27 Jan 1997 18:11:55 -0500

Hi Folks,

Trying to install the lastest WU-FTPD beta 12.  When I excute the
./build osf, I receive the following errors...

Making ftpd.
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c
ftpd.c
/usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: storage size for
'timeout' isn't known
         struct timeval timeout;
 -----------------------^
/usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: Reference an
expression of void type or an incomplete type.
         struct timeval timeout;
 -----------------------^
/usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: Reference an
expression of void type or an incomplete type.
         struct timeval timeout;
 -----------------------^
*** Exit 1
Stop.

Any ideas ?

John

-- 

John Brunelle - Digital Internet Management Center
		Phone: (603)880-6590  Fax: (603)598-0181
		Internet: [email-masked]

---

From: FTP Administrator <[email-masked]>
Date: Wed, 29 Jan 1997 15:54:30 +0100 (MET)

> /usr/lib/cmplrs/cc/cfe: Error: ftpd.c, line 2271: storage size for

Just add a #include "sys/time.h" after the #include list in ftpd.c.

Massimo Gais
----
FTP Administrator                                        <[email-masked]>
C.D.S. - University "Federico II" of Naples (Italy)

                          "640K ought to be enough for anybody." 
                                           --  Bill Gates, 1981