Subject: Re: NFS and Linked directories

From: Chris Auron <[email-masked]>
Date: Tue, 14 Jan 97 17:15:55 MST

Along the same lines does anyone know how I can use the
"GUEST" settings and ALSO allow to change to linked directories???

TIA

--- On Wed, 15 Jan 1997 10:01:02 +1100 (EST)  Geoff Terry Systems & Net supt 064 923677 
<[email-masked]> wrote:

>Colin,
>Does your OS use statis libs for ls etc
>If so did you move/create the necessary files/links for the ls libraries on
>the NFS mointpoint.
>
>try tracing the calls made by ls to see which libraries get called (and
>which calls fail from the chrooted directory).
>
>I also recall someone on the list talking about specific configs necessary
>for wuftpd using NFS partitions but I ditched the mail and cant recall the
>content.
>
>
>>After moving our nfs server from one machine to another I get the
>>following errors from wu-ftpd. The ftpd binaries are local to the machine
>>all the rest of the files are mounted via nfs. Anyone else seen anything
>>like this before?
>>
>>hatch 20 % ftp mongoose
>>Connected to mongoose.cs.unm.edu.
>>220 mongoose FTP server (Version wu-2.4(5) Tue Jan 7 11:34:44 MST 1997) ready.
>>Name (mongoose:colinj): ftp
>>331 Guest login ok, send your complete e-mail address as password.
>>Password:
>>230 Guest login ok, access restrictions apply.
>>Remote system type is UNIX.
>>Using binary mode to transfer files.
>>ftp> ls
>>200 PORT command successful.
>>425 Can't create data socket (0.0.0.0,20): Bad file number.
>>
>>
>>Why must I feel like that? Why must I chase the cat? 
>>Colin E. Johnson | [email-masked] | http://www.unm.edu/~colinj/
>>NeXTMail, MIMEmail, textmail, send it all, I'm easy.
>>
>>
>>
>Geoff Terry
>Systems & Network Support
>ACR Net
>Sapphire Coast NSW 2550
>Australia
>Ph 064 923677
>Mobile 015 668 227
>Fax 064 924594
>
>

-----------------End of Original Message-----------------

---------------------------------------
   _____  ___________   ______  _______
  / __/ |/_/_  __/ _ \ / __/  |/  / __/
 / _/_>  <  / / / _, // _// /|_/ / _/
/___/_/|_| /_/ /_/ |_/___/_/  /_/___/

Chris Auron
[email-masked]

Extreme Communications            602-368-4638 Voice
8655 E. Via De Ventura G181       602-368-4637 Fax
Scottsdale AZ 85258

Your perception is our reality:

This is our promise;
At Extreme your perception of service
becomes the reality we must meet and exceed.
-------------------------------------

---

From: Chris Auron <[email-masked]>
Date: Tue, 14 Jan 97 18:56:08 MST

I guess I should have been more specific.

I have the guest settings set for ftp users. When the ftp in to the
system the root directory becomes there own. so;

/	/username

Now if I want to add a anonymous ftp, I have a nfs mounted an
ftp machine. Now to link to their directory on the ftp server
I do

/public_ftp -> /usr/ftp/c/chris

Unfortunately when they ftp into their account and try to
CD to that directory it says it does not exist! It will
list it but not allow CD's. I disable the guest option
or change their group and it works fine but then leaves
access to the whole system open

So ......

--- On Wed, 15 Jan 1997 12:28:57 +1100 (EST)  Geoff Terry Systems & Net supt 064 923677 
<[email-masked]> wrote:

>Chris,
>There is an excellent FAQ (I cut the following from someone else's post)
>
>It is available several ways:
>via FTP ftp.cetis.hvu.nl/pub/koos/wu-ftpd-faq.txt
>via WWW www.hvu.nl/~koos/wu-ftpd-faq.html
>via e-mail [email-masked] with a subject line of "send faq"
>
>I'm not sure what you mean by "allow to change to linked directories???"
>
>Regards Geofft

-----------------End of Original Message-----------------

Chris Auron
[email-masked]

This is our promise;