Subject: Netscape doesn't show right login-dir (no dir - Problem!)

From: Kai Krebber <[email-masked]>
Date: Mon, 13 Jan 1997 11:58:59 +0100

Howdy!

After setting up wuftpd for guest-logins, a connection with command-line-ftp brings me exact to the login-dir as stated in the passwd (e.g. "\export\home\guest1\.\sub1")
Unfortenately trying to ftp via Netscape shows the root-dir of the guest to which the chroot changed, not the sub1. Clicking there at sub1 brings me to the desired directory. 
How do I tell netscape to directly show the contents of sub1, like the text-oriented ftp does?

Thanx 4 suggestions,
	Kai Krebber

---

From: Bob Myers <[email-masked]>
Date: Thu, 16 Jan 1997 01:52:59 -0800

Kai Krebber wrote:
> 
>       ...
>       >> >ftp://user@host/sub1/
> >>
> >> Yeah, that'll do it. But it's only a workaround. Then you can spare
> >> the right part after /./ in passwd at all. The information given here
> >> should be used by netscape, like with a 'normal' ftp-client.
> >
> >Nope.  No can do.  FTP URLs need to be set up this way - otherwise
> >there's no way to get to directories above the home directory.
> 
>       Sure there would be a way to get to those directories: Just clicking
>       the 'parent-dir' link. Remember that the chroot-dir from wuftpd is not
>       nessecarily the dir, it initially takes you after logging in via ftp. In my
>       case you would be able to get exactly one level up.

Think about it in URL terms.  What URL would "clicking on the
'parent-dir' link" give you?
Ok, now what would the root directory URL be?

The only way to make this work might be to have a special syntax like
ftp://user@host/~/ or something that would go into the home directory,
do a pwd to find out where you are, and then change the URL in the
browser to what it really is - ftp://user@host/home/dir/ or whatever.

And you'd have to get this hack accepted by the URL standards
committee...

---

From: [email-masked] (Kai Krebber)
Date: Thu, 16 Jan 1997 11:53:25 +0100

... 
>Ok, now what would the root directory URL be?

OK - now I think, I understand, what you mean: because the user tells his Browser 
to visit ftp.mydomain.de, it should bring him to ftp.mydomain.de and not to 
ftp.mydomain.de/sub1.
But sometimes you put an URL in your Browser and end up somewhere else without 
intervening. I was thinking of s.th. like that: contacting ftp.mydomain.de ports you to 
ftp.mydomain.de/sub1 (with an automateted update of the displayed URL in the 
Browser), 'cause there is nothing of interest for the guest in his root-dir - that's, why
ftp ftp.mydomain.de from the command-line brings him directly to /sub1 and not to /
due to a clever interpretation of the passwd by the wuftpd. 

>browser to what it really is - ftp://user@host/home/dir/ or whatever.

I think, I like that as little, as you do. In the end, I wanted to make the user's life 
easier (without clicking through the tree until you finaly are at the interesting stuff
or without extending the nessecary URL.