Subject: Re: questions

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Fri, 31 Jan 1997 19:51:19 +1100 (EST)

OK,
700 is fine if the files are owned by a trusted user account (trouble if the
user uploading them owns them though). Depends on what commands &
capabilities you are going to allow to ftp clients (by default the file will
be owned by the client I think, so they could upload an executable and run
it perhaps).

Use the -u flag in the ftpd command line options in inetd.conf eg
ftp     stream  tcp     nowait  root    /local/sbin/in.tcpd
/whatever/in.ftpd -a -u133

the umask is ftpd wide! the mode is system wide obviously.
your ftpaccess upload directive looks fine

Geofft

>> Sorry about this.
>> Let's have another go at it.
>> Try making the directory writable and executable only and not readable. 
>
>done..
> 
>> That way people can ftp it up but no-one can see it or download it.
>> Make the default umask 333 so the files end up with rrr access so that cant
>> be execd by anyone with shell access.
>
>Hrmm, well i couldnt figure this part out. How do you set the default
>umask to 333? I was told to make it 077 to be safer (so stuff is 700). But
>i have no idea. What do i do? Is this systemwide or ftpwide?
>
>hrmm.. any idea?
>
>my ftpaccess has this line :
>
>upload  /home/ftp  /incoming     yes    root    daemon  0600 dirs
>
>us the 0600 the umask? just change to 0333?
>
>help! reply via private mail please.
>
> .%$$s.
>  `$$'      +----------------------------------------+ --  -
>   $$    ._ |         [ Liquid Insanity! ]
>  `#$.  !s$s.        [email-masked]
>   $$s._.ss! +------------------------------------+ -- -
>    '`~ ~'$'  !_.+( http://neon.netlite.com/ )+._!
>
>
>
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594

---

From: Liquid Insanity <[email-masked]>
Date: Fri, 31 Jan 1997 06:29:54 -0500 (EST)

> /whatever/in.ftpd -a -u133

Hmm, you changed it from umask 033 to umask 133.

I want the most secure method.

 .%$$s.