Subject: Re: [ACADEM-SW-SUPPORT #154] Re: Status of 2.4.2-academ[BET

From: "Randy A. Katz" <[email-masked]>
Date: Thu, 16 Jan 1997 22:30:30 +0000

Is it going to be possible to have a non-IP based VirtualFTP host 
like non-IP based VirtualWWW hosts in Apache?

I posed this question before but nobody seemed interested in 
answering it...please correct me if I'm being flamboyant in any way.

Thanx,
Randy Katz

> Date:          Thu, 16 Jan 1997 14:00:20 -0600 (CST)
> Reply-to:      [email-masked]
> From:          Alan Halachmi <[email-masked]>
> To:            wu-ftpd list <[email-masked]>
> Subject:       Re: [ACADEM-SW-SUPPORT #154] Re: Status of 2.4.2-academ[BETA-12] release (fwd)

> I received this letter from Academ.com after submitting that I thought it 
> would be a good idea for guestgroup to be different on VirtualFTP and the 
> regular FTP...  They same that everyone must come to a `unified` stand.  
> Well, here's my two sense... If they are different, you can have a user 
> access ftp.server1.com to interact with thier own web page (for exaple.) 
> and then, they could have ftp.server2.com to manipulate an ftp archive... 
> The point is, if the are seperate then there is more flexability.  
> Secondly, for me at least, I want all of my uses to access via the 
> VirtualFTP because I don't want to have to start letting people into my 
> `main` machine for access.  It really comes down to flexiblity and the 
> fact that not every system administrator is going to want people to have 
> access to the name or the dir on the "actual" ftp server... It's hard to 
> explain, so I hope somebody understands.
> 
> Thanks,
> Alan
> 
> ---------- Forwarded message ----------
> Date: Thu, 16 Jan 1997 13:26:18 CST
> From: Stan Barber <[email-masked]>
> To: Alan Halachmi <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Subject: Re: [ACADEM-SW-SUPPORT #154] Re: Status of 2.4.2-academ[BETA-12] release
> 
> Guestgroups will work in the context of a virtual connection. But, 
> all guestgroups work the same on a per server, not a per connection, basis.
> 
> Folks need to have a complete and concrete idea of how they want virtual
> servers to work for us implementors to work against. I have seen no
> unified specification in this area and I won't implement everyone's 
> different ideas for doing the same thing.
> 
> -- 
> Stan   | Academ Consulting Services        |internet: [email-masked]
> Olan   | For more info on academ, see this |uucp: {mcsun|amdahl}!academ!sob
> Barber | URL- http://www.academ.com/academ |Opinions expressed are only mine.
> 
> 
> 
---------------------------------------------------------
Randy A. Katz
---------------------------------------------------------
Computer Consultation & Sales
505 S. Beverly Drive, Suite 472, Beverly Hills, CA  90212
(213) 307-9581
[email-masked]
http://www.ccsales.com
---------------------------------------------------------

---

From: Jon Lewis <[email-masked]>
Date: Fri, 17 Jan 1997 02:31:54 -0500 (EST)

> like non-IP based VirtualWWW hosts in Apache?

I would guess no, since the client does not tell the server what name it
used to get to the server.  That is the trick, I think, they use for
non-IP virtual WWW.  

------------------------------------------------------------------
 Jon Lewis <[email-masked]>  |  Unsolicited commercial e-mail will
 Network Administrator       |  be proof-read for $199/hr.
________Finger [email-masked] for PGP public key_______

---

From: [email-masked] (Pedro Melo)
Date: Fri, 17 Jan 1997 11:45:24 GMT

>like non-IP based VirtualWWW hosts in Apache?

I dont think the protocol support's it.
HTTP 1.1 has a Host: header. No such think in FTP AFAIK.

Melo
--
************** Pedro Melo ([email-masked]) BOFH ******************
*   TELENET, Servicos de Telecomunicacoes, SA - Tel +351 1 3139190   *
* finger [email-masked] or search key servers for PGP key *
*           It's management's job to support the geniuses,           *
*                      not to tell them what to do                   *
**********************************************************************