Subject: Re: questions

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Wed, 22 Jan 1997 17:12:14 +1100 (EST)

Sorry about this.
Let's have another go at it.
Try making the directory writable and executable only and not readable. 

That way people can ftp it up but no-one can see it or download it.
Make the default umask 333 so the files end up with rrr access so that cant
be execd by anyone with shell access.

Regards Geofft
>
>>everything seems to work fine on my Linux 2.0.28 machine running wu.ftpd
>>2.4 beta 12.
>>
>>just one thing, how can i set up a safe incoming to allow people to upload
>>to incoming.. but safe so nobody can fuq w/ it and hax0r my machine. any
>>ideas.. i would appreciate it, since i would like to have an incoming dir.
>>
>> .%$$s.
>>  `$$'  ~'! +------------------------------------------+ --  -
>>   $$    ._ |         [ Liquid Insanity! ]
>>  `#$.  !`$s.      [email-masked]
>>   $$s._.s $$ +-------------------------------------+ -- -
>>    '`~ ~'s$'  !_.+( http://turnon.netlite.com/ )+._!
>>
>>
>>
>Geoff Terry    Systems & Network Support
>ACR Net        Sapphire Coast NSW 2550
>Australia
>Ph 064 923677  Mobile 015 668 227 Fax 064 924594
>
>
>
Geoff Terry    Systems & Network Support
ACR Net        Sapphire Coast NSW 2550
Australia
Ph 064 923677  Mobile 015 668 227 Fax 064 924594

---

From: Liquid Insanity <[email-masked]>
Date: Thu, 30 Jan 1997 22:31:40 -0500 (EST)

> Try making the directory writable and executable only and not readable. 

done..
 
> be execd by anyone with shell access.

Hrmm, well i couldnt figure this part out. How do you set the default
umask to 333? I was told to make it 077 to be safer (so stuff is 700). But
i have no idea. What do i do? Is this systemwide or ftpwide?

hrmm.. any idea?

my ftpaccess has this line :

upload  /home/ftp  /incoming     yes    root    daemon  0600 dirs

us the 0600 the umask? just change to 0333?

help! reply via private mail please.

 .%$$s.
  `$$'      +----------------------------------------+ --  -
   $$    ._ |         [ Liquid Insanity! ]
  `#$.  !s$s.        [email-masked]
   $$s._.ss! +------------------------------------+ -- -
    '`~ ~'$'  !_.+( http://neon.netlite.com/ )+._!