Subject: What is "Can't create data socket." ?

From: "Y.Hariyama" <[email-masked]>
Date: Wed, 25 Dec 1996 07:16:41 +0900

I installed wu-FTP-2.4.2-beta11 on Solaris 2.5.1, and edited ftpaccess
to availeable guestgoup.

In case of guestgroup login, I don't use "ls" "put" "get" command.
Please check my progress.

.A part of /etc/passwd
 canon-cs:x:100:1000:Canon-CS:/www/docs/csip/./web:/bin/csh

.A part of /etc/group
  ftponly::1000:canon-cs

.add "guestgoup ftponly" to /etc/ftpaccess.

.mkdir /www/docs/csip/bin and etc.

.cp /bin/ls /www/docs/csip/bin, cp /etc/passwd /www/docs/csip/etc
 cp /etc/group /www/docs/csip/etc

### Phenomenon ###
  CSSUN3# !!
  ftp 202.228.128.226
  Connected to 202.228.128.226.
  220-FTP test
  220-#
  220-
  220-
  220 CSSUN1 FTP server (Version wu-2.4.2-academ[BETA-11](1)
  1996 12 24 20:59:26: JST) ready.
  Name (202.228.128.226:fastnet): canon-cs
  331 Password required for canon-cs.
  Password:
  230 User canon-cs logged in.  Access restrictions apply.
  ftp> ls
  200 PORT command successful.
  425 Can't create data socket (0.0.0.0,20): Bad file number.
  ftp>pwd
  257 "/web" is current directory

pwd or cd command is available, but ls or put, get is unavailable.
What's mean "Can't create data socket (0.0.0.0,20): Bad file number." ?
Please teach me to solve this problem.

Thank you.

**********************************************************************
針山 欣之 ( Yoshiyuki Hariyama ) | E-Mail : [email-masked]
FastNet, Inc.  INTERNET Project  | URL    : http://www.fine.ad.jp
TEL     : +81-45-476-5261        | Meguro Build. 3-22-5, Sin-yokohama
FAX     : +81-45-476-3489(G4/G3) | Kouhoku-ku,  Yokomaha  222, Japan
**********************************************************************

---

From: "Y.Hariyama" <[email-masked]>
Date: Fri, 27 Dec 1996 19:37:37 +0900

> > But, "dir" command is seemed working strange.
> > 
> > Phenomena)
> > .It takes about 30 second to return "dir" result.
> > .UID, GID appear numeric.
> 
> Check that you have 'files' in /etc/nsswitch.conf for passwd and group,
> and that ~/ftp/passwd and ~/ftp/group have the values you want in them. If
> you have nis or nis+ listed instead of files for passwd and group, then
> the 30 second delay probably is a nameservice timeout. 
> 
> Also check the ftpd man page again, for anything else you've missed. 
> 
I saw man page and copied /etc/nsswitch.conf to ~ftp/etc.
But, It seems works strange.

Please check nsswitch.conf.

passwd:     files
group:      files
hosts:      files       dns
networks:   files
protocols:  files
rpc:        files
ethers:     files
netmasks:   files
bootparams: files
publickey:  files
# At present there isn't a 'files' backend for netgroup;  the system will
#   figure it out pretty quickly, and won't use netgroups at all.
netgroup:   files
automount:  files
aliases:    files
services:   files
sendmailvars:   files

Is it true ?

Thank you.

          ( Yoshiyuki Hariyama ) | E-Mail : [email-masked]