Subject: server using system passwd for cd ~user commands

From: Tom Lojewski <[email-masked]>
Date: Fri, 20 Dec 1996 18:31:09 -0800 (PST)

Dear wu-ftpd user,

I've built wu-ftpd-2.4 under Solaris 2.5.1 (libc patches installed)
using gcc gcc-2.7.2.1.

There is a user named "username" defined in the system passwd file but
not in the ~ftp/etc/passwd file.  His home directory is
"/home/username".

When an anonymous ftp client logs into the machine and types
"cd ~username" wu-ftpd responds "/home/username" no such file or
directory.  The chroot is working, the client itself doesn't have
access to the system passwd file.

The problem is that it lets anon users probe to see what accounts are
defined.

I suspect this is a cacheing problem with nscd.  Truss shows calls to
"door_info" and "door_call".

Has anyone experienced a similar problem?  Any help would be
appreciated.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Tom Lojewski  ([email-masked])   =+=     ProNet Consulting  Alameda, CA +
+                                   =+=                                    +
+ phone: (510)864-8633              =+=                  fax:(510)864-8637 +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

---

From: Alain Magloire <[email-masked]>
Date: Sun, 22 Dec 1996 00:06:08 -0500 (EST)

> Has anyone experienced a similar problem?  Any help would be

The expand of "~" is done by wu-ftpd
On my SunOS4 boxes the behaviour is right
if you loggin anonymous and try to do 
cd ~username
and username is not defined in ~ftp/etc/passwd
you'll get the "550 ..Unknow user.." error
Eventhough username is a real user.

Now i didn't try this on Solaris.
but If you find it to be a nuisance
you can disable the behaviour by
recompiling.

in ftpcmd.y, look for pathname:
and get rid of the strncmp(..,"~")
this will stop the globbing for ~

--
au revoir, alain