Subject: Re: Faq doesnt help much

From: [email-masked] (Richard Fancher)
Date: Fri, 06 Dec 1996 14:47:09 -0800

At 02:32 PM 12/6/96 -0500, you wrote:
>You can use the last command. ie
>
># last | grep still
>iqsystem ftp26405                           Fri Dec  6 14:24   still 
>logged in
>dkaufman ftp25581                           Fri Dec  6 14:13   still
>logged in
>#
>
Umm sorry but you can get that same info from w or who or finger due to you
are querying from the login ports...NOT who is logged into the ftpd.

===============================================
= Windjammer Communications, LLC              =
= 2100 21st Sacramento CA 95818               =
= TEL: (916) 454-2114                         =
= FAX: (916) 454-2121                         =
= Richard Fancher (Sys-Admin)                 =
= [email-masked]                         =
= http://www.windjammer.net                   =
===============================================

---

From: James Sneeringer <[email-masked]>
Date: Fri, 6 Dec 1996 18:12:28 -0600 (CST)

On Fri, 6 Dec 1996, Richard Fancher wrote:
| Umm sorry but you can get that same info from w or who or finger due to you
| are querying from the login ports...NOT who is logged into the ftpd.

Different systems may vary.

On my Linux system, anonymous ftp logins are accessible from `last'.  The
`w' and `who' and `finger' commands only display users using a tty, which
ftp users do not.

Isn't there an `ftpwho' program included with wu-ftpd?

-James

--
// James Sneeringer :: [email-masked]
// System Administrator, Oberlander Communications Systems, Inc.

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Sun, 8 Dec 1996 00:01:57 +0100 (MET)

(very bad choice of subject in my not very humble opinion, but to keep up
the thread).

> Isn't there an `ftpwho' program included with wu-ftpd?

There is, which works perfectly, *IF* :

- ftpd is started with the -a parameter
- the directory for the pids-files exists
- And is writable for root (ie : not NFS mounted)

On ftp.cetis.hvu.nl, a Linux system, ftpcount and ftpwho work nicely and
I even use ftpcount in the screen with tourist information.

					     Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"

---

From: [email-masked] (Keith Iverson)
Date: Sat, 7 Dec 1996 16:45:04 -0800 (PST)

Anyone out there get 'zip' and 'unzip' to work on a sunOS 4.1.3 platform?
I've made all the appropriate entries in the ftpconversions file and the 
binaries in ~ftp/bin do work outside of ftp.  Would be real nice to be able 
to support (un)zip from ftp.
(un)compress and g(un)zip work just fine, can't seem to get (un)zip to work.
Is it even supported?

-Keith

<======================================================>
Keith A. Iverson        Iverson Financial Systems, Inc.
New Product Research and Development
E-mail - [email-masked]
Voice - (408)522-9900               Fax - (408)522-9911
<======================================================>

---

From: Alain Magloire <[email-masked]>
Date: Thu, 12 Dec 1996 22:16:37 -0500 (EST)

> (un)compress and g(un)zip work just fine, can't seem to get (un)zip to work.

I don't think it will work .. at least not without some
serious work 

1- won't work

 the reason is zip/unzip(at least my old versions) can not do
 zipping and unziping to stdout.

 for exemple if I want to tar a directory and send this on stdout:

 tar -cf - foo

 can't do that with zip i.e.:

 zip -r - foo # won't work

 For the compression an tarring on the fly to work, the
 programm must be able to send the result on stdout.

2- work arounds
  a-
   If you know zip well enough, you could change the src code
   and send the result on stdout.

  b-
   _ I DIDN'T TRY THIS__
   #include "disclaimer.h"
   you've been warn.

   It's possible to write a small wrapper to zip, it will take one argument
   zip the directory and send the result to stdout. Wu-ftp will not even be 
   aware of it, something like:
 :   : :.zip:/bin/wrap_sip %s:T_REG|T_DIR:O_TAR:TAR

   ---wrap_zip(pseudo code)-----
   get the directory name
   zip the directory
   send the result to stdout
   ---------------------------

3- dunno
  Merry Chrisma !! ;-)

--
Joyeux Noe:l, alain

---

From: Mike Loewen <[email-masked]>
Date: Fri, 13 Dec 1996 11:20:31 -0500 (EST)

>  zipping and unziping to stdout.

   I think you need to get a newer version of zip: mine is version 2.1,
dated 04/27/1996, and supports output to STDOUT.  Unzip is version 5.20
from 04/30/1996. I copied zip to ~ftp/bin and added the entry: 

 :  :  :.zip:/bin/zip -r - %s:T_REG|T_DIR:O_TAR:TAR

   to the ftpconversions file, and was able to successfully GET a zipped
version of a directory.

Mike Loewen			Center for Academic Computing
Email:	[email-masked]		The Pennsylvania State University
Phone:	(814) 863-4356		University Park, PA  16802
Office:	17 Willard Bldg.	http://ripsaw.cac.psu.edu/mloewen.html

---

From: Vidiot <[email-masked]>
Date: Fri, 13 Dec 1996 13:30:02 -0600 (CST)

<   I think you need to get a newer version of zip: mine is version 2.1,
<dated 04/27/1996, and supports output to STDOUT.  Unzip is version 5.20
<from 04/30/1996. I copied zip to ~ftp/bin and added the entry: 
<Mike Loewen			Center for Academic Computing

So please post to the list where you obtained the latest version.

Thanks.

MB
-- 
System Administrator - Finnigan FT/MS - Madison WI. <URL:http://www.ftms.com/>
e-mail: [email-masked]
phone: (608) 273-8262 ext: 612  fax: (608) 273-8719
Visit - <URL:http://www.cdsnet.net/vidiot/>  (Your link to Star Trek and UPN)

---

From: Alain Magloire <[email-masked]>
Date: Fri, 13 Dec 1996 15:47:45 -0500 (EST)

According to `Mike Loewen':
> 
> > According to `Alain Magloire':
> > 

Congrat. !! (ye !! party ! rejoice ;-)
keith will be happy to see this, certainly will make 
is chrismas a little brighter.

thanks for the correction
--
Joyeux Noe:l, alain

---

From: Mike Loewen <[email-masked]>
Date: Fri, 13 Dec 1996 16:03:11 -0500 (EST)

> So please post to the list where you obtained the latest version.

   The Info-ZIP home page may be found at:

http://quest.jpl.nasa.gov/Info-ZIP/