Subject: Re: chroot problem..

From: "Ali Davachi" <[email-masked]>
Date: Tue, 24 Dec 1996 12:46:42 +0000

> 
> Ali, read the FAQ  and the guess howto:
> 
> ----Quote From M. B.-----
>  This is the location for the latest wu-ftpd.  You can't see the
>  directory contents, but get the file anyway.  It's there.
> 
>  ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z
> 
>  WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html
> 
>  guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
> 
>  There are additional security references in the above docs.
> ----Quote From M. B.-----
> 
> I'm guessing that you're using some SYSVr4 OS(Solaris?)
> If you do a chroot you must provide in all the directories that
> do a chroot() all the necessary lib, dev, etc..
> 
> lib/*
> dev/*
> etc/*
> 
> also for solaris
> 
> ~ftp/dev/tcp must be 666
> 
> If not, the ftpd server will not be able to open the Data socket
> hence the "425 Can't..."
> 
Thanks for the speed reply... I tried to determine the libraries 
required, but I was unable to do so.. :(  You were correct when you 
guessed that I was running Solaris 2.5 :) .. Any pushes in the right 
direction would be greatly appreciated..

Regards,

Ali

P.S. The problem is still the 425 data connection ...

---

From: "Ali Davachi" <[email-masked]>
Date: Tue, 24 Dec 1996 14:30:15 +0000

> Date:          Tue, 24 Dec 1996 12:29:45 -0600
> Reply-to:      [email-masked]
> From:          "Karl O. Pinc" <[email-masked]>
> To:            [email-masked]
> Subject:       Re: chroot problem..

Karl,

> 
> A) There's a gnu utility, I think it's ldd, that will tell you the
> libraries required by an executable binary.
> 
> B) Give up and use the libraries that come in your standard anonymous ftp
> /lib directory.  These can usually be examined at your typical anonymous
> ftp site.  Maybe pick one running the same OS you are.
> 
> C) Poke at it with a stick.  Start with the standard C library, libc, and
> use the chroot command to test from there.
> 
Been there done that... :)  Placed all of the proper libs in the 
proper places, created the dev/tcp and dev/zero files in the users 
dir, now the connection is established, and then boom core dump.. 
yet i am able to upload to the user's dir.. just no ls..  I have also 
tried the JEDIPATCH which implements an internal ls.. with the same 
results.. any more ideas.. 

Thanks,

Ali