Subject: Re: inetd wrapper for ftpd

From: Jens Hamisch <[email-masked]>
Date: Thu, 19 Dec 1996 15:32:57 +0100 (MET)

Hi,

> Now that my new ftp server is up and running i need to let people
> using the old server know what the new address is. The old system
> is using SunOS 4.1.3 ftpd and does not have the option of banner.msg.
> Instead of taking the time to setup wuftpd on this system i want
> to setup a quick wrapper called from inetd.conf that displays a message
> and then launches ftpd.
> 
> any ideas???????

Use the tcp_wrappers package and issue an TWIST command on the FTP
port.
This is described in detail in the tcpd manuals.

Good luck
-- Jens

--------------------------------------------------------------------------------
     /
 +##+|##+   STRAWBERRY                     Jens Hamisch
+v#+v v##+  EDV-Systeme GmbH               Managing director
/ v    v\v
| . .  . |  Brauneckweg 2                  Car (Voice):  (+49 172) 81 04 162
|     .  |  D-82549 Koenigsdorf            Voice:        (+49 8179) 9305-50
 | .     |                                 Fax:          (+49 8179) 9305-38
 \   .  /   Tel./Fax: (+49 8179) 9305-50   Email:        [email-masked]
  \____/    [email-masked]                    [email-masked]

---

From: [email-masked] (Gerhard Gonter)
Date: Thu, 19 Dec 1996 16:02:29 +0100 (MEZ)

> to setup a quick wrapper called from inetd.conf that displays a message

Interesting idea, you don't want to install any new program on the
maschine?

I just tried this:

/etc/inetd.conf:
# ftp   stream  tcp     nowait  root    /usr/local/lib/ftpd/bin/ftpd ftpd -a
ftp     stream  tcp     nowait  root    /etc/noftpd noftpd

/etc/noftpd:
#!/bin/sh
cat <<EOX
220-This FTP Server is down, use ftp.wu-wien.ac.at
220-bye bye...
EOX
# /usr/afsws/local/bin/nvt ftp 21
telnet ftp 21

This seems to do the trick.  If you have a glass telnet or a TCP relay
like nvt at hand, use this instead of the telnet.

+gg
 
--
[email-masked]     Fax: +43/1/31336/702     [email-masked]

---

From: Perry Rovers <[email-masked]>
Date: 21 Dec 1996 20:22:48 GMT

A hoard of pink elephants inspired Gerhard Gonter <[email-masked]> to tell garfield.mail.wu-ftpd:
: According to Neal S. Pressman ex 2317:
: > Now that my new ftp server is up and running i need to let people
: > using the old server know what the new address is. The old system

: /etc/noftpd:
[snip]

You can also use something like:
guestserver ftp.wu-wien.ac.at
in the ftpaccess file though this will not launch an ftp session.
It will give a similar message, namely saying the user should connect to 
the guestservername.

-- 
Perry Rovers ([email-masked])