Subject: Re: [PATCH] built-in 'ls'

From: Luc Desrosiers <[email-masked]>
Date: Mon, 16 Dec 1996 15:22:42 -0500

> 	The problem with me using an external ls is that I run Solaris
> 	2.5.1, therefore I run into the nice problem of a static 'ls'
> 	binary (which is making me want to pull my hair out). Anyone know
> 	where I can obtain a Solaris 2.5.1 sparc4u (Ultrasparc 1) static
> 	'ls' binary?

http://www.eng.auburn.edu/users/doug/second.html#Misc

-- 
Luc Desrosiers
Analyste de systèmes
RISQ, CRIM 1801 McGill College, suite 800
Montréal, Québec H3A 2N4, (514) 840-1235 ext 8951
[email-masked]

---

From: "Peter C. Norton" <[email-masked]>
Date: Mon, 16 Dec 1996 15:22:45 -0500 (EST)

On Mon, 16 Dec 1996, Yoshi wrote:
> 	GNU ls would be a nice add-on, in patch form of course. Possibly
> 	a simple -DEXTERNAL_GNU_LS define switch would be best.
> 

I'm sure someone will correct me if I'm wrong, but isn't it possible to
put copies, or hard links to your /lib/libc*.so.* into your ~ftp/lib?

-Peter

---

From: Yoshi <[email-masked]>
Date: Mon, 16 Dec 1996 12:40:44 -0800 (PST)

> put copies, or hard links to your /lib/libc*.so.* into your ~ftp/lib?

	Of course.

	But when you have 400 to 800 users who want this feature, so
	customers can pull their newest file distributions, you start
	to notice most of your disk consists of libraries for anonymous
	FTPs. A static 'ls' binary is much more suiting for what we
	need :-)

--
| Jeremy Chadwick                                        [email-masked] |
| System/Network/Security Administrator                        541-330-0435 |
| http://yoshi.parodius.com                                                 |

---

From: Alain Magloire <[email-masked]>
Date: Mon, 16 Dec 1996 15:56:06 -0500 (EST)

According to `Yoshi':
[deleted]
> 	where I can obtain a Solaris 2.5.1 sparc4u (Ultrasparc 1) static

A- Static-ls

(Solaris FAQ:You'll find pointers)
http://www.fwi.uva.nl/pub/solaris/solaris2.html

I don't want to delve into this, but providing static bins may
help in certain cases, however it's not|rarely recommended.

For solaris because sockets implementation is build over
STREAMS, you still need to provide

~ftpd/dev/tcp(666)
and maybe some other stuff under ~ftp/etc and ~ftp/lib

But all that said, I agree with you
it's still simpler and less error prone with static bins.

B- Share OS(platforms)

Maybe my previous post was misleading.
In fact I use dynamic bins for wu-ftpd, under solaris with no problem.

My real problem was that ~ftp is share across OS (SunOS and Solaris)
Although it's allright for ``real'' users
things will break for ``anonymous''.

There's no clean way to deal with this:
  1- playing with the mount entries, passwd file(ftp home) etc..
     is very messy.
  2- providing built_in ls seems a good idea but to quote
     `Michael Brennen ' :
     " I would not want to burden an already overbig
     server with yet more baggage."

My network is coming more heterogenous, it's allright
for the others services, it's a problem with wu-ftpd because of
the chroot().
There are some interesting patches posted, I look a them after
the X-mas break.

C- workaround
 For now I'm using the ``guestserver'' to redirect ``anonymous''
 to one central server were ~ftp is setup right.

--
Joyeux Noe:l, alain