Subject: Path-filter in ftpaccess file

From: Cassandra Perkins <[email-masked]>
Date: Fri, 27 Dec 1996 12:55:18 -0800 (PST)

I'm trying to prevent real users from uploading files with spaces and 
characters beginning with . or -.  Using the command below prevents any 
file from being uploaded. 

path-filter    real    /usr/local/etc/pathmsg  ^[A-Za-z0-9]*$ ^. ^- \ 
							             ^
							          (a space)

Can someone please tell me what I'm doing wrong.

Thanks.

----------------------------------------------------------------------------
| Cassandra M. Perkins		     | People usually get what's coming to |
| Network Operations		     | them... unless it's been mailed.    |
| The Loop Internet Switch Co., LLC  |		-fortune		   |
----------------------------------------------------------------------------

---

From: Alain Magloire <[email-masked]>
Date: Fri, 27 Dec 1996 16:53:52 -0500 (EST)

> Can someone please tell me what I'm doing wrong.

primo)
  this "^." will match anything and everything 
  try:
    ^\.
  or
    ^[-.].*$

secondo)
  ^[A-Za-z0-9]*$  is plain wrong

try:
  ^[-A-Za-z0-9]*$ 

tertio)
  Browse the archive or the FAQ for more exemples

quatro)
  Happy new year, ;-)
  #if _female_
    kisses and hugs
  #else
    strong handshake
  #endif
--
Bonne anne'e, alain

---

From: Michael Brennen <[email-masked]>
Date: Fri, 27 Dec 1996 15:56:36 -0600 (CST)

These work for me; note the \ before the . in mine.

path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  real       /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

   -- Michael    ([email-masked])