Subject: links and real users...Please ! real answers

From: Thierry LOUVEL <[email-masked]>
Date: Sat, 14 Dec 1996 10:59:07 +0100

well,

it's my xxxxxxxx same questions for the same problem, in mailist
or newsgroup...
i receive for the SAME question: "IT'S NOT POSSIBLE", "IT'S POSSIBLE"
"NO", "YES", and so...

The question (simple no?) is:
"is it possible to use Symbolic links and not realpath for
 real users with wu-ftpd ?"

now for the xxxx time (:_o ):

OS: Linux 1.2.13
FTPD: wu-ftpd-2.4.2b11

#df
/dev/hda2	/
/dev/hda1	/files
/dev/hdb1	/disk2

#cat /etc/passwd
[../..]
ftp:*:404:100:  :/disk2:/etc/ftponly
guest:*:405:100:  :/disk2:/etc/ftponly
userX:xxxx:406:100:  :/disk2/users/userX:/bin/bash
[../..]

#cat /etc/group
[../..]
wheel::10:root
ftp::16:ftp
users::100:root
[../..]

in /disk2 i have:
 /disk2/bin/ls (static)
 /disk2/etc    (with *.msg, no "passwd", no "group")
                
The /etc/ftpaccess is the origin file 

in /disk2/users/userX i have:
#ls -l /disk2/users/userX
[../..]
lrwxrwxrwx	root	root	dir1 -> /disk2/dir1
lrwxrwxrwx	root	root	docs -> /files/docs
lrwxrwxrwx	root	root	job  -> /usr/local/job
[../..]

The "userX" can go in all of these directory (great !!)
BUT ! when he would like to come back ("cd ..") in the
$HOME directory the result is:
/disk2 for dir1/
/files for docs/
/usr/local for job/

stupid no ?
with "telnet" the result is ok.

so:
- wu-ftpd CAN'T use Symbolic ? 
  []YES []NO 
  []other....
- Must i change something ?
  [] go to windows95
  [] job
- How can i do to make it ok ? 
  [] use another ftpd 
  [] do what ftp want not what you want
  [] kill users
- With guest account is it big crazy ?
- Do you want pizza ?

Please, if you have a think like this show me
how you make it...

Thank's !!!!

Thierry, 

--
 L.C.I (Etudes, Conseils & Developpement Independant)
 Sous DOS/WINDOWS en SGBD, COMMUNICATION, RESEAU...
 TEL: (33)01.47.89.18.00    mailto:[email-masked]  
 FAX: (33)01.41.16.07.53    DATA/PPP: (33)01.41.16.07.53

---

From: "Keith Smith" <[email-masked]>
Date: Mon, 16 Dec 1996 13:24:43 +1300

> real users with wu-ftpd ?"

Yes, users that are not chroot()ed can follow symbolic links.

> [cut]
> [cut]

WUFTPD is correct.  You have followed the link and have a new
working directory.

The reason Telnet works for you is because your user has bash for 
their shell.  One of the nicer features of bash is the ability to 
cd.. back through a symbolic link.  If you try a different shell (sh 
for example) you would see that you can no longer cd.. back through a 
symbolic link.

Regards,
Keith.

------------
Keith Smith                                 [email-masked]
Paradigm Technology Limited                 Senior Software Engineer
PO Box 10-268                               +64 (4) 495-1000 (voice)
Wellington, New Zealand                     +64 (4) 405-1003 (fax)
             Finger [email-masked] for PGP key
                  [all required disclaimers apply]