Subject: Separate permissions for files and dirs

From: [email-masked] (William Ellis-Support)
Date: Wed, 11 Dec 1996 01:43:01 -0800

For security purposes I need to be able to set different
upload permissions for files and dirs.  Basically, all
uploaded files need to be 644, no problem I have got 
this to work both in the ftpaccess file and using the
ftpd -u option.  Unfortunately, the uploaded dirs 
also take on these permissions which means if a user
uploads his/her webpage with subdirs, the dirs created
also have permission 644, or drw-r--r-- .  Then the 
user can't cd into the new dirs to put the files there
because it isn't executable.   An obviously I would like
to stay away from making all files/dirs 744 if possible.
Is there anything I missed?
TIA, Bill

---

From: [email-masked] (William Ellis-Support)
Date: Wed, 11 Dec 1996 02:05:03 -0800

This is RE: to my own message a few minutes ago.
I kept trying different combinations and this one 
seems to work thought doesn't make 100% sense...

To make dirs 755  drwxr-xr-x  reasonable for web
and files    644  -rw-r--r--      "       "   "

use ftpd with the -u022

I thought this meant everything made would be
755, but it seems wuftpd doesn't like to create files
executable, so it strips off the the last bit and 
you get files 644 by default.  - Which is nice because
user can up their pages with working subdirs and other
users can't edit their pages ;) 

-Nice work again wuftpd!