Subject: Re: What is "Can't create data socket." ?

From: "Y.Hariyama" <[email-masked]>
Date: Fri, 27 Dec 1996 09:56:37 +0900

Thank you for your advice.
I solved "Can't create data socket." problem, but I found another
problem.....

At 18:37 96/12/26 +0300, Serge Bezzubov wrote:
> 
> It seems you've missed dev directory. You should create tcp and zero devices
> as same as in system dev derictory.
> My ~ftp/dev contains the following devices:

I used mknod commnad and made device file to ~/ftp/dev directory.
ls, put and get command works well !!  :-)

But, "dir" command is seemed working strange.

Phenomena)
.It takes about 30 second to return "dir" result.
.UID, GID appear numeric.

Example)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 53844
drwxr-xr-x   8 100      1             512 Dec 26 17:19 .
drwxr-xr-x   8 100      1             512 Dec 26 17:19 ..
drwxrwxr-x   2 100      1000          512 Dec 25 17:10 Testcont
dr-xr-xr-x   2 0        1             512 Dec 25 16:06 bin
drwxr-xr-x   2 0        1             512 Dec 25 16:42 dev
dr--r--r--   2 0        1             512 Dec 26 14:12 etc
drwxr-xr-x   5 0        1             512 Dec 25 10:00 usr
drwxr-xr-x  13 0        1            4608 Dec 27 03:15 web
226 Transfer complete.
625 bytes received in 40 seconds (0.015 Kbytes/s)

.I copyed /etc/passwd, /etc/group, /etc/netconfig, /nsswitch.conf
 to ~ftp/etc/ directory.
 UID=100 and 0, GID=1000 and 1 is written in ~ftp/etc/passwd, group.

Question)
.Why is numeric UID and GID appeared ?
.Why does it take about 30 seconds to return "dir" result ?

Please inform me to solve this problem.

Thank you.

**********************************************************************
          ( Yoshiyuki Hariyama ) | E-Mail : [email-masked]
FastNet, Inc.  INTERNET Project  | URL    : http://www.fine.ad.jp
TEL     : +81-45-476-5261        | Meguro Build. 3-22-5, Sin-yokohama
FAX     : +81-45-476-3489(G4/G3) | Kouhoku-ku,  Yokomaha  222, Japan
**********************************************************************

---

From: Jim Davis <[email-masked]>
Date: Thu, 26 Dec 1996 20:12:02 -0700 (MST)

> ls, put and get command works well !!  :-)

(Just as the ftpd man page told you to...)

> .UID, GID appear numeric.

Check that you have 'files' in /etc/nsswitch.conf for passwd and group,
and that ~/ftp/passwd and ~/ftp/group have the values you want in them. If
you have nis or nis+ listed instead of files for passwd and group, then
the 30 second delay probably is a nameservice timeout. 

Also check the ftpd man page again, for anything else you've missed.