Subject: Re: help!, No one can login, even anon

From: [email-masked] (Albert Lunde)
Date: Fri, 6 Dec 1996 08:50:37 -0600 (CST)

A "generic" problem to beware of is that many (all?) implementations
of inetd silently drop command line arguments after some small
number (4 or 5?). (In this context, the fact I was running tcpd/tcp_wrappers
may have counted for an extra argument.)

I wrote a c wrapper program to exec the wuftopd to get around this:
= =
/* wrapper for wuftpd to add command line arguments
   that don't fit under inetd */

#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <errno.h>
#include <syslog.h>

int main(argc,argv)
   int argc;
   char **argv;
{
   char *path="/local-adm/bin/ftpd";
   char *cmd="ftpd";

   fflush(stderr);
   fflush(stdout);
   errno=0;
   execl(path,cmd,"-a","-l","-L","-u022",NULL);

   openlog("wrapftpd",LOG_PID, LOG_LOCAL6);
   syslog(LOG_WARNING,(const char *)strerror(errno));
   closelog();
   exit(EXIT_FAILURE);

}
= =

Season to taste ;)

-- 
    Albert Lunde                      [email-masked]

---

From: [email-masked] (Clyde Hurst)
Date: Fri, 6 Dec 1996 07:12:49 -0600

Alex, 

I am having the same problem.  With me, it is when I use the /etc/ftpaccess
file.  When I give ftpd the -A switch (which tells ftpd not to use the
/etc/ftpaccess file) everything works fine.  Of course, without the use
of the /etc/ftpaccess file, it is just like normal ftp daemons.  If anyone
has any ideas, please let me know.

Clyde Hurst

---

From: Ashura <[email-masked]>
Date: Fri, 6 Dec 1996 15:44:23 -0500 (EST)

> has any ideas, please let me know.

I used -a but nothing happen for me.. then again I'm using the same
ftpaccess file as the defult

      _____________________________________________________
      |							  |
      | Alex Lee					  |
      | Ashura ([email-masked])			  |
      |	Micro Consultant				  |
      | These words represent my views and opinions only  |
      | and does not reflect UCS or my employer.   	  |
      |	_________________________________________________ |
      |							  |
      | "Asobiwa Owarida!"  -Iori 			  |
      |	'Play time is over'				  |
      |							  |
      \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/

---

From: Ashura <[email-masked]>
Date: Sat, 7 Dec 1996 18:19:50 -0500 (EST)

I still seem to be stuck on this problem, I tried everything I was advised
to do... but everytime I tried to login it gives me a access denied prompt
for everyone including anon. I dont know, to me it seems that it doesnt
read the ftpaccess file, and I do have the ftpd -a on...