Subject: Problem Compiling on Solaris 2.5.1

From: Thom Dunaway <[email-masked]>
Date: Fri, 13 Dec 1996 10:04:43 -0600

I suspect this has been addressed many times, but I could not find a
solution via usenet.  I am using gcc and have changed the Makefile.sol to
reflect "gcc" and "libgcc.a"  I am new to Unix so I was not able to
decipher the error messages.  Below is the output.  Thanks for your help!

sws5# build sol CC=gcc
make args are :
make opts are :  CC=gcc

Linking Makefiles.

Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
In file included from authuser.c:7:
/usr/include/arpa/inet.h:46: warning: `struct in_addr' declared inside
parameter
 list
/usr/include/arpa/inet.h:46: warning: its scope is only this definition or
decla
ration,
/usr/include/arpa/inet.h:46: warning: which is probably not what you want.
/usr/include/arpa/inet.h:46: warning: parameter has incomplete type
/usr/include/arpa/inet.h:49: warning: parameter has incomplete type
/usr/include/arpa/inet.h:50: warning: parameter has incomplete type
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use this function)
ftpd.c:1982: `strunames' undeclared (first use this function)
ftpd.c:1982: `modenames' undeclared (first use this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsu
pport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupp
ort -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
gcc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 3904 + 312 + 328 = 4544
Done
sws5#

*******************************
"A man can receive only what is given him from heaven."
thom dunaway
[email-masked]
*******************************

---

From: [email-masked] (Nathan Berry)
Date: Fri, 13 Dec 1996 12:24:33 -0700

In the install instructions it tells you that you might experience the problem 
you are having.  In the support directory there is a file, ftp.h, that you need 
to copy into /usr/include/arpa.  Your compile errors will go away.  I have 
compiled this on Solaris 2.5.1 with no problem.

      _/          _/_/_/_/_/_/        Nathan Berry
     _/_/        _/          _/       6501 E Belleview Ave.
    _/  _/      _/          _/        Englewood, CO  80111
   _/    _/    _/_/_/_/_/_/           Phone: (303) 889-8816
  _/      _/  _/          _/          Fax:   (303) 889-8805
 _/        _/_/          _/           Email: [email-masked]
_/          _/_/_/_/_/_/              

> From [email-masked] Fri Dec 13 12:18:21 1996
> Date: Fri, 13 Dec 1996 10:04:43 -0600
> From: Thom Dunaway <[email-masked]>
> To: [email-masked]
> Subject: Problem Compiling on Solaris 2.5.1
> Mime-Version: 1.0
> X-Sender: [email-masked]
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
>