Subject: upload directory matcher

From: "Yacine Kheddache" <[email-masked]>
Date: Thu, 12 Dec 1996 12:48:12 +0100

I create many guest group and I just want to know if it was
possible to use some matcher in the root directory of a upload
information.

Example I have :

upload  /arch6a/home/ftp/home/yacine     /guest/for_root        yes     root    root      0700 nodirs
upload  /arch6a/home/ftp/home/yacine     /guest/exchange        no
upload  /arch6a/home/ftp/home/yacine     /guest/exchange/*      yes     root    ftponly   0550 dirs
upload  /arch6a/home/ftp/home/toto    /guest/for_root        yes     root    root      0700 nodirs
upload  /arch6a/home/ftp/home/toto    /guest/exchange        no
upload  /arch6a/home/ftp/home/titi    /guest/exchange/*      yes     root    ftponly   0550 dirs
.../...

and some others with the same directory.
I try to creat a generic expression with no success :

upload  /arch6a/home/ftp/home/*    /guest/for_root        yes     root    root      0700 nodirs
upload  /arch6a/home/ftp/home/*    /guest/exchange        no
upload  /arch6a/home/ftp/home/*    /guest/exchange/*      yes     root    ftponly   0550 dirs

Any idea will be great appreciate.

Regards Yacine.

-- 
=====================================================
mailto:[email-masked]	        NORTEL EUROPE	    
Systems/Network Admin	    Parc Leonard de Vinci
			    15, av A. Graham Bell
Voice : 01 64 76 77 96        Bussy St Georges 
Fax   : 01 64 76 76 20	77608 Marne La Vallee Cedex 3 
http://www.nortel.com/		   FRANCE  
=====================================================

---

From: Alain Magloire <[email-masked]>
Date: Mon, 16 Dec 1996 23:35:31 -0500 (EST)

> possible to use some matcher in the root directory of a upload

[deleted]

> upload  /arch6a/home/ftp/home/*    /guest/exchange/*      yes     root    ftponly   0550 dirs

No this will not work, the matching(globing) is only done on 
the second argument(dir-glob) of the `uplaod' directive, not
on the root-dir.

NOTE:
And it me be a suprise for you, but for example for this
line to work properly

> upload  /arch6a/home/ftp/home/*    /guest/exchange        no
          ^^^^^^^^^^^^^^^^^^^^^^^^
the first argument(root-dir) __must__ match exactly the HOME field in
the passwd file, if not so, then people will be able to upload
even if you specified "no".

> Any idea will be great appreciate.

IMHO
Don't be to smart with the matching expression. The
regex in wu-ftpd is ok... but it's not perl. Better
a couple of lines more, but at least you're sure
of the behaviour

--
Joyeux Noe:l, alain