Subject: Re: chroot problem..

From: "Ali Davachi" <[email-masked]>
Date: Tue, 24 Dec 1996 10:56:01 +0000

Alan,

If it's any consolation, I am seeing the same problem on my end when 
I activate chrooting <g> .. If I remove work around the chroot, it 
works fine.  Looks to me like the remote IP is getting clobbered 
somewhere..

Regards,

Ali
> If it helps any, I tried to log onto the `real` ftp server and got the 
> message:
> 425 Can't create data socket (0.0.0.0,20): Bad file number.
> 
> Help!,
> Alan
> 
> On Tue, 24 Dec 1996, Alan Halachmi wrote:
> 
> > I setup a virtual ftp site and it works great.  However, I need a user to 
> > be able to access his own dir and manipulate its contents.  I seem to 
> > have set everything up correctly because when he logs in it says `User 
> > hisusername logged in.  Access Restrictions Apply`.  However, the server 
> > isn't doing a chroot!  I have the passwd files that say /his/dir/./ but 
> > that isn't working.  I've built the appropriate bin and etc dirs... 
> > What's not working...I'm happy to field questions as to certain 
> > configurations, but I think I've done it all correctly... Is there a bug 
> > in the beta-11 verion?
> > 
> > Alan Halachmi
> > [email-masked]
> > 
> 
>

---

From: Alain Magloire <[email-masked]>
Date: Tue, 24 Dec 1996 11:20:56 -0500 (EST)

> > 425 Can't create data socket (0.0.0.0,20): Bad file number.

[... deleted..]

Ali, read the FAQ  and the guess howto:

----Quote From M. B.-----
 This is the location for the latest wu-ftpd.  You can't see the
 directory contents, but get the file anyway.  It's there.

 ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z

 WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html

 guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto

 There are additional security references in the above docs.
----Quote From M. B.-----

I'm guessing that you're using some SYSVr4 OS(Solaris?)
If you do a chroot you must provide in all the directories that
do a chroot() all the necessary lib, dev, etc..

lib/*
dev/*
etc/*

also for solaris

~ftp/dev/tcp must be 666

If not, the ftpd server will not be able to open the Data socket
hence the "425 Can't..."

--
Joyeux Noe:l, alain

---

From: Alain Magloire <[email-masked]>
Date: Tue, 24 Dec 1996 11:26:24 -0500 (EST)

According to `Ali Davachi':
[..deleted...]

OOPS !!!

sorry about that ``Ali'', the previous was for ``Alan''

``Ali'', ``Alan'', ``Alain'', !!!!
All Beautifull names ;-)

Allez, je vais me coucher
--
Joyeux Noe:l, alain