Subject: Re: problem with "user" command

From: [email-masked]
Date: Fri, 27 Dec 1996 16:51:12 -0700 (MST)

Hi all,

I was recently having problems using the "user" command to switch to
a different user when already logged in.  To fix this, I commented
out the following lines from the source code for wu-ftpd-2.4.2b11
(ftpd.c):

/* H* fix: if we're logged in at all, we can't log in again.
    if (logged_in) {
        reply(530, "Already logged in.");
        return;
    }  */

Works fine now.

Pete Ruprecht

---

From: Alain Magloire <[email-masked]>
Date: Fri, 27 Dec 1996 19:21:46 -0500 (EST)

>         reply(530, "Already logged in.");

Pardon me, but ... I believe this was
one of the many security fixes done by
Hobbit(H*): to disallow "re-login", port fix, pasv fix, etc ..
see FIXES*-HOBBIT

There was a healthy thread on bugtraq|best-of-security
on this issues and the exploits.

Well if you know what you're doing ... that's fine.
Just wanted to bring it to your attention, no
malice intended.

bye, bye
--
Bonne anne'e, alain