Subject: Guest Groups on NeXT 3.3

From: "Matthew B. Thomson" <[email-masked]>
Date: Mon, 09 Dec 1996 12:03:42 -0500

Running wu-ftpd 2.4 on NeXTSTEP 3.3, using the "guest" mode FTP, that
chroot's the directory to the login directory, ls is not returning a full
directory listing.  I am aware that library requirements probably exist, so
I'm wondering if anyone has done this under NeXT?  The ldd/truss commands
do not seem to have a NeXT equivalent for determining which libraries ls
requires.  Neither the wu-ftpd FAQ, or the guest-howto make any mention of
any special NeXT requirements.  If anyone has done this under NeXT, I would
appreciate some pointers.

Thank You Much,
Matthew

----------------------------------------------------------------
- Matthew B. Thomson                                           -
- Network Support Specialist                                   -
- Cleveland State University Information Services & Technology -
- [email-masked]  -  216-687-9217  -  Fax 216-687-9200  -
----------------------------------------------------------------

---

From: "Matthew N. Reichman" <[email-masked]>
Date: Tue, 10 Dec 96 09:27:00 -0800

On Mon, 09 Dec 1996 at 12:03:42
"Matthew B. Thomson" <[email-masked]> wrote:
____________________

> Running wu-ftpd 2.4 on NeXTSTEP 3.3, using the "guest" mode FTP,
> that chroot's the directory to the login directory, ls is not
> returning a full directory listing. I am aware that library
> requirements probably exist, so I'm wondering if anyone has done
> this under NeXT? The ldd/truss commands do not seem to have a
> NeXT equivalent for determining which libraries ls requires.
> Neither the wu-ftpd FAQ, or the guest-howto make any mention of
> any special NeXT requirements. If anyone has done this under
> NeXT, I would appreciate some pointers.

Here's my setup:

midnight/#: ls -l /Users/guest/
-rw-r--r--  1 root           0 Oct 25 02:36 .forward
-rw-r--r--  1 root           0 Oct 25 02:36 .rhosts
drwxr-xr-x  2 guest       1024 Nov 10 15:08 .ssh
-rw-r--r--  1 root          97 Nov  4 10:54 .zshenv
-rw-r--r--  1 root        4346 Nov  4 10:54 .zshrc
d--x--x--x  3 root        1024 Oct 26 15:38 bin
d--x--x--x  2 root        1024 Nov  2 22:14 etc
dr-xr-sr-x  4 root        1024 Oct 22 13:07 pub
d-wx--x--x  3 root        1024 Oct 31 14:05 usr

midnight/#: ls -l /Users/guest/usr/shlib/
---x--x--x  3 root     1008704 Jun  2  1995 libsys_s.B.shlib

---
Be well

Matthew Reichman <[email-masked]>
NeXTMAIL, SUN Mail & MIME welcome
PGP key --> email w/ subject "request_PGP"