Subject: Re: [PATCH] built-in 'ls'

From: [email-masked] (Karl O. Pinc)
Date: Mon, 16 Dec 1996 17:10:44 -0600

Various people have written:
>> In a previous message, Yoshi said:
>> >     But when you have 400 to 800 users who want this feature, so
>> >     customers can pull their newest file distributions, you start
>> >     to notice most of your disk consists of libraries for anonymous
>> >     FTPs. A static 'ls' binary is much more suiting for what we
>> >     need :-)
>>
>> In any case, let me throw imho.
>>
>> You can accomplish getting ls to work in any of a number of ways:
>>
>> 1) Put a shared ls into ~ftp/bin along with all the shared libraries
>> it's linked against into ~ftp/lib (don't forget the dynamic linker).
>
>        For 400-800 accounts? I think not.

Why not?  If you use hard links you don't take up any more disk space (just
one copy per file system is required.)  So, what's wrong with this method?

Karl

May the Legos (TM) always be swept from your path in the night.

---

From: Hannu Laurila <[email-masked]>
Date: Wed, 25 Dec 1996 12:13:43 +0200 (EET)

> one copy per file system is required.)  So, what's wrong with this method?

Less files, less administration, easier upgrades, simpler setups --> less
security risks

As you can guess, I'm in favor of builtin ls. Of course, as an option,
those who would still like to use an external ls could define
-DEXTERNAL_LS.

---
Hannu Laurila - [email-masked], JAPO ylläpito    * gsm (050) 592 6400
Alajärven Puhelinosuuskunta, tel (06) 557 2209 * fax  (06) 557 2788
"kuulen jo lokkien kirkunan ja tunnen suolan tuoksun" -- mkoponen

---

From: Michael Brennen <[email-masked]>
Date: Wed, 25 Dec 1996 10:46:24 -0600 (CST)

I disagree.  Adding a bunch more code to an already overcomplex daemon is
not a good thing to do.  It makes porting just that more complex, as well
as adding yet another glob of code on top of everything else.  There is no
way that makes things more secure. 

   -- Michael    ([email-masked])

---

From: "Peter C. Norton" <[email-masked]>
Date: Thu, 26 Dec 1996 00:54:42 -0500 (EST)

> way that makes things more secure. 

I agree that a built-in ls provides less for most of us then it allows.  I
wonder how much it would take to make that built-in ls into a seperate,
minimal, staticly-linkable, standalone ls.  That should satisfy 
everyone's requirements, right?

Any thoughts?

-Peter

---

From: Alain Magloire <[email-masked]>
Date: Fri, 27 Dec 1996 01:19:13 -0500 (EST)

> everyone's requirements, right?

yes, /home/ftp is in the NIS map and shared across platforms.
This will make it unworkable for anonymous.

I could :

1-
  overide the mount points and override NIS locally
  for each platforms
2-
  Builtin ls. 
  Althougth I agree, wu-ftpd is a monster
3-
  a hardcoded path for a statical link ls(from Karl Pinc)
  "/bin/ls.ostype"

I've already got rid of 1), I'm looking at 2) and 3)
If you have any comments/suggestions I'll be happy
to hear them.

NOTE:
I don't wanna here about loosing gzip/tar etc ...
it's nonsense!! must packages are allready tarred and
gunzip... It's a waste of CPU cycles, especially when
two of my main Ftp servers are xferring 2 GIG a day.

--
bonne anne'e, alain