Subject: Re: chroot problem..

From: "Karl O. Pinc" <[email-masked]>
Date: Tue, 24 Dec 1996 12:29:45 -0600

>>
>> Ali, read the FAQ  and the guess howto:
>>
>> ----Quote From M. B.-----
>>  This is the location for the latest wu-ftpd.  You can't see the
>>  directory contents, but get the file anyway.  It's there.
>>
>>  ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z
>>
>>  WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html
>>
>>  guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
>>
>>  There are additional security references in the above docs.
>> ----Quote From M. B.-----
>>
>> I'm guessing that you're using some SYSVr4 OS(Solaris?)
>> If you do a chroot you must provide in all the directories that
>> do a chroot() all the necessary lib, dev, etc..
>>
>> lib/*
>> dev/*
>> etc/*
>>
>> also for solaris
>>
>> ~ftp/dev/tcp must be 666
>>
>> If not, the ftpd server will not be able to open the Data socket
>> hence the "425 Can't..."
>>
>Thanks for the speed reply... I tried to determine the libraries
>required, but I was unable to do so.. :(  You were correct when you
>guessed that I was running Solaris 2.5 :) .. Any pushes in the right
>direction would be greatly appreciated..

A) There's a gnu utility, I think it's ldd, that will tell you the
libraries required by an executable binary.

B) Give up and use the libraries that come in your standard anonymous ftp
/lib directory.  These can usually be examined at your typical anonymous
ftp site.  Maybe pick one running the same OS you are.

C) Poke at it with a stick.  Start with the standard C library, libc, and
use the chroot command to test from there.

Karl

May the Legos (TM) always be swept from your path in the night.

---

From: Ahmad F Misron <[email-masked]>
Date: Tue, 24 Dec 1996 20:08:27 +0000 (GMT)

Hi,

  I just upgraded to beta 11 and now both the files
welcome.msg and README are not being read anymore.
I'm running it on a Linux box kernel 2.1.7
Can anyone please help?

Here's my ftpaccess file:

#######################################################
class   all   real,guest,anonymous  *

limit   all   10   Any              /etc/msgs/msg.dead

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

email user@hostname
###################################################

Thanks in advance,

Ahmad