Subject: Re: Solaris 2.5.1 & 'dir'

From: Jim Davis <[email-masked]>
Date: Tue, 10 Dec 1996 10:26:55 -0700 (MST)

On Mon, 9 Dec 1996, Hal Wine wrote:

>     # ls -l /etc/.name_service_door
>     -r--r--r--   1 root     root           0 Aug  1 12:52 
>     /etc/.name_service_door
>     # cp -p /etc/.name_service_door .
>     cp: /etc/.name_service_door: read: Operation not applicable
> 
> Thoughts?  (Again, Solaris 2.5.1, wu-ftpd 2.4)

That's normal.  The door(2) manpage has some (sketchy) information about
what's going on there.  Apparently that interface will be documented a
little more completely in 2.6.

---

From: Bob Luckin <[email-masked]>
Date: Tue, 10 Dec 96 12:37:57 CST

Hal Wine said :-
> I have a problem where 'dir' only shows uid/gid numbers instead of 
> names for anon users.  (SunOS 5.5.1, wu-ftp 2.4.)
> 
> [email-masked] said:
> > If this is the case, you should be able to figure out which ones you 
> > need using the truss command.  Alternatively, you can look at Sun's 
> > ftpd man page and just copy all of the recommended files across, 
> > which may be more than you need to solve the problem, but shouldn't 
> > hurt. 
> 
> Done.
> 
> [email-masked] said:
> > You've got to copy one of 4 libs to ~ftp/usr/lib according to the 
> > name resolving system you use. Those libs are: /usr/lib/nss_dns.so.1 /
> > usr/lib/nss_files.so.1 /usr/lib/nss_nis.so.1 /usr/lib/
> > nss_nisplus.so.1 
> 
> Done.
> 
> Well, I've got these across now, even though truss doesn't show them 
> being used, but still have the problem (no group/user names on dir 
> command for anon users).
> 
> There are 2 files in the truss report that don't show in the ~ftp 
> hierarchy:
>     # truss  /bin/ls -l 2>&1 >/dev/null | grep '^open'
>     open("/usr/platform/SUNW,SPARCstation-10/lib/libc_psr.so.1", 
> 	O_RDONLY) Err#2 ENOENT
>     open("/etc/.name_service_door", O_RDONLY)       = 3
> Since the first isn't found during normal operations, I'm not worried 
> about it. However, I can't copy the 2nd:

Hmm.  I'm running on Solaris 2.5, and I have not copied the
/etc/.name_service_door file across to the FTP root.  My guess is your
problem lies elsewhere...

If it isn't a missing dynamic library, the only other thing I can think of
is that you could be missing the relevant entries in the copy of the
etc/group file under your FTP root.  I can't be sure, but I think I remember
that you said you'd checked this already ?  If you haven't done this, do
so - if you have checked it then I'm stumped for the moment.

The best I can offer right now is to email you a listing of how my
~ftp/usr/lib is set up so that you can see if I have anything there which you
don't...  Let me know if you want this, and I'll email direct to save
inflicting it on the rest of the list members.

Cheers, Bob
-- 
Bob Luckin                   "A man, a plan, a canal, Suez !"
Texas Instruments
P O Box 650311, MS 3937      [email-masked]
Dallas, TX 75265   U.S.A.    Tel: (972) 917 5081    Fax: (972) 917 7966

---

From: Hal Wine <[email-masked]>
Date: Mon, 09 Dec 1996 17:11:36 -0800

Done.

Done.

-- 
Hal Wine <[email-masked]>				DTOR Consulting