Subject: Re: wu-ftpd and ftpaccess

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Fri, 15 Nov 1996 15:28:31 +1100 (EST)

Krishna,
Check you dont have a typo in the path-filter.

Regards Geofft
>Bob,
>
>You are right, I am running the wu-2.4.2-academ[BETA-11] version. 
>What version should I use? Hopefully there is one that does not have these
problems!
>
>By the way, I made a mistake in my original posting - when I try to set up
a path-filter entry, 
>users are prevented from creating files (not just directories, as I said
before) and the 
>path-filter message file is printed out.
>
>Thanks
>Krishna Panyam
>
>--- On Wed, 13 Nov 1996 17:56:45 -0800  Bob Myers <[email-masked]> wrote:
>Krishna Panyam wrote:
>> 
>> I recently 'inherited' a mess of an FTP server, and I am learning
everything the hard way.
>> I have a few questions that I hope someone can and will answer.
>> 
>> 1. We seem to be running the well known wu-ftpd 2.4 ftpd, but how to I
know that is true? Is
>> there a way to find out ?
>
>When you connect to the server, it should give the version number:
>
>% ftp foobar.intelenet.net
>Connected to foobar.intelenet.net.
>220 foobar.intelenet.net FTP server (Version wu-2.4.2-academ[BETA-11])
>Thu Sep 26 11:00:07 PDT 1996) ready.
>
>> 2a. I have a few 'upload' entries for 'incoming' directories specifying
the owner/group and
>> permissions on files put here. When I add 'nodirs' to these lines, nobody
(including local
>> users) is able to create a directory anywhere under the FTP home directory.
>
>This is a bug in at least some versions of ftpd, including
>wu-2.4.2-academ[BETA-11], the latest release.
>
>> 2b. When I try to add restrictions for the file names using the
path-filter command, it seems 
>to
>> restrict all users from creating any directories at all!
>
>Sounds like the 'nodirs' problem to me - you're sure it's the
>path-filter that makes the difference?
>
>> 3. All file transfers are being logged. Is this the default ? I tried to
add an entry in the
>> ftpaccess file to log user commands, but it is not doing anything that I
can see.
>
>It apparently logs user commands to the daemon syslog, not the xfer_log.
>
>
>-- 
>Bob Myers                              InteleNet Communications, Inc.
>Email: [email-masked]               30 Executive Park, Suite 150
>Phone: 714-851-8250 x227               Irvine, CA 92614
>Fax:   714-851-1088                    http://www.intelenet.net/
>
>---------------End of Original Message-----------------
>
>
>
Geoff Terry
Systems & Network Support
ACR Net
Sapphire Coast NSW 2550
Australia
Ph 064 923677
Mobile 015 668 227
Fax 064 924594

---

From: Krishna Panyam <[email-masked]>
Date: Fri, 15 Nov 96 14:36:21

Thanks to those who responded.

I got hold of the right version of wu-ftpd (from 1994 !!?), and that seems to fix most of my 
problems, including nodirs on upload, setting the path-filter, etc.

Krishna Panyam

--- On Fri, 15 Nov 1996 15:28:31 +1100 (EST)  Geoff Terry Systems & Net supt 064 923677 
<[email-masked]> wrote:
Krishna,
Check you dont have a typo in the path-filter.

Regards Geofft
problems!
a path-filter entry, 
before) and the 
everything the hard way.
know that is true? Is
the owner/group and
(including local
add an entry in the
can see.
Geoff Terry

---------------End of Original Message-----------------