Subject: SUMMARY: Compiling WUFTP 2.4.2 B11 on Digital Unix

From: "Andrew C. Saylor" <[email-masked]>
Date: Wed, 6 Nov 1996 08:54:13 -0600 (CST)

Ok,
  Here is everything I had to do to compile WUFTPD 2.4.2 Beta 11 on a
Digital Unix machine running the C2 security.

Make these changes to ./src/config/config.osf

#define SecureWare
#include <sys/secdefines.h>
#include <sys/security.h>
#include <sys/audit.h>
#include <prot.h>

and the following to ./src/makefiles/Makefile.osf

LIBES = -lsupport -lsecurity -laud

and change all occurances of crypt() to bicrypt()
(found in ftpd.c and private.c - lets hear it for GREP!!)

Once that was done, the program compiled correctly. I have both anonymous
and authenticated FTP logins working.

Thanks For Everyone's Help!!

-Andy Saylor, ComSource Inc  [email-masked]

---

From: "James's" <[email-masked]>
Date: Wed, 6 Nov 1996 19:29:17 -0300 (CDT)

> -Andy Saylor, ComSource Inc  [email-masked]
but, .. NOT COMPILED Correctly !!!
because ?

(Iam have one Alpha DEC3000 osf2.0)

mv  y.tab.c ftpcmd.c
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c
ftpcmd.c
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c glob.c
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c
logwtmp.c
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -c popen.c
Make: Don't know how to make vers.c.  Stop.

Making ftpcount.
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -o
ftpcount ftpc
ount.c vers.o -lsupport -lsecurity -laud
ld:
Can't open: vers.o (No such file or directory)
*** Exit 1
Stop.

Making ftpshut.
cc -O -DDEBUG -I.. -I../support -Olimit 1000 -L../support -s -x -o ftpshut
ftpsh
ut.c vers.o -lsupport -lsecurity -laud
ld:
Can't open: vers.o (No such file or directory)
*** Exit 1
Stop.

jaime.