Subject: Re: pid error

From: John Nemeth <[email-masked]>
Date: Thu, 14 Nov 1996 18:45:26 -0800

On Nov 14,  3:27pm, Alain Magloire wrote:
}
} > I am getting a " Sleep: fcntl lock of pid file failed: resource
} > Temporarily Unavailable  error.  Can anyone help me figure out a remedy
} > for this?  Any ideas?  The Archives touch on some pid errors but not this
} 
} With inetd spawning ftpd proccesses left, right and center
} they must be a way to have accounting.
} 
} Wu-ftpd does that by a file _PATH_PIDNAMES (check pathnames.h
} or ckconfig for the location).
} 
} On every connection ftpd will put a lock on the file
} and add an entry and if the total number is over limit(in ftpaccess)
} send a message back, release the lock and exit(it's a bit more than that
} but you got the idea).
} 
} If ftpd can not have LOCK_EX(exclusive lock) it will send
} a mesage to syslog sleep a while and try again.
} 
} The scheme is simple but many things could go wrong.
}  a- a runaway process that still hold the lock
}  b- a _VERY_ busy site
}  c- a malicous user that had put a lock(U must have O_RDWR to the file)
}  d- lots I mean _LOTS_ of connection from Web Browsers
}  e- a script or a cron job using ftp{count,who}
}  f- in ftpaccess you have lot of classes
}  g- etc ...

     You forgot h- _PATH_PIDNAMES is on an NFS volume that doesn't
have locking, or has imcompatible locking

}  ....
} 
}-- End of excerpt from Alain Magloire

---

From: Alain Magloire <[email-masked]>
Date: Fri, 15 Nov 1996 10:39:23 -0500 (EST)

> have locking, or has imcompatible locking

don't believe my eyes !!!
did I over look this one ?
The mother of sys adm. and prog. system headaches !!!
This should be bump to item a-
:-)

--
ciao, alain