Subject: WU-FTPD-BETA-11

From: "D. Chiodo" <[email-masked]>
Date: Thu, 14 Nov 1996 13:43:52 -0500 (EST)

Trying to install on linux with shadow passwords..

Compile runs fine, users cannot log in.

Have followed instructions in NOTES file regarding shadow passwords, up to
this point:

---------------------------------------------------------
NOTES:
---------------------------------------------------------
<...>
And then modify src/ftpd.c in line 1061 to read :

        xpasswd = pw_encrypt(passwd, salt);
Finally:
- Rebuild wu-ftpd
<...>
---------------------------------------------------------

Can I get some file context for this modification? My line 1061 in ftpd.c
is as follows, and I don't think this is the right line to modify. 

---------------------------------------------------------
src/ftpd.c:
---------------------------------------------------------
<...>
1055:        reply(530, "User %s access denied..", name);
1056:        syslog(LOG_NOTICE,
1057:               "FTP LOGIN REFUSED (access denied) FROM %s [%s], %s",
1058:               remotehost, remoteaddr, name);
1059:        anonymous = 0;
1060:    } else {
1061:        reply(530, "User %s access denied.", name);
1062:        syslog(LOG_NOTICE,
1063:               "FTP LOGIN REFUSED (access denied) FROM %s [%s], %s",
1064:               remotehost, remoteaddr, name);
1065:        dologout(0);
1066:    }
<...>
---------------------------------------------------------

---

From: Michael Brennen <[email-masked]>
Date: Fri, 15 Nov 1996 22:37:30 -0600 (CST)

The line you want to modify is 1287, the one marked below.  My
skey_crypt() function will also do shadow, but I hacked my own skey
package with shadow enabled from the logdaemon package.  If you do use
skey, be sure and set pwok if you want to allow regular passwords. 

#ifdef KERBEROS
        xpasswd = crypt16(passwd, salt);
#else
#ifdef SKEY
    xpasswd = skey_crypt(passwd, salt, pw, pwok);
    pwok = 0;
#else
        xpasswd = crypt(passwd, salt);    <===========
#endif
#endif

   -- Michael

---

From: Scot <[email-masked]>
Date: Sat, 16 Nov 1996 20:38:57 -0500 (CDT)

Hi;
 
 I am using wu-ftpd un Digital UNIX 3.2g 

 Installed OK and have got chroot working (following th HOW-TO)
 but apparently the UIDs and GIDs are not being seen in the chrooted 
 environment.

 When I do a ls -la I get the nuberic UID GID file permissions 
 rather than the names. Because these permissions are 
 not set I can ftp in as any user and delete bin etc 
 .rhosts .. and upload a new one.

 In etc I have a passwd file and group file and also 
 the static version of ls in bin. Apparently there 
 are some libs or something which needs 
 to be included also?

 Anyone got a quick fix before I start digging???

 Any help is greatly appreciated!

 TIA
 Scot