Subject: Default umask for chrooted users

From: Scot <[email-masked]>
Date: Thu, 21 Nov 1996 09:45:09 -0500 (EST)

Hi;

 How could I set the default umask for all users who 
 upload files 

 I tried /usr/skel/.login   

 I also tried putting a .login in the users home dir 
 
 Everything seems to default to -rw-r--r--

 Scot

---

From: Michael Brennen <[email-masked]>
Date: Thu, 21 Nov 1996 08:59:53 -0600 (CST)

`man ftpaccess`

Check the upload directive.

   -- Michael

---

From: Scot <[email-masked]>
Date: Thu, 21 Nov 1996 10:13:09 -0500 (EST)

Sorry;

 Posted before I reread the faq 

7.The default umask used when a real user uploads a file is wrong 

 The default umask is inherited from inetd. This can be a wrong
one. There is an  undocumented command line parameter -u. Edit the line in
inetd.conf to something like ftpd -A -L -l -u077. 

Scot