Subject: Problems compiling 242 beta 11 under linux

From: James Poulin <[email-masked]>
Date: Thu, 7 Nov 1996 11:47:48 -0600 (CST)

Gooday folks,

I have been at this for a while now and I can't seem to figure it out. It
will not compile properly. If anyone can help, it would be appreciated,
i'll send ya a Cyber-Beer or somthin .... :-)

Here is a snippit ...

Linking Makefiles.

Making support library.
gcc  -O2 -fomit-frame-pointer   -c fnmatch.c
gcc  -O2 -fomit-frame-pointer   -c strcasestr.c
gcc  -O2 -fomit-frame-pointer   -c authuser.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o authuser.o
ranlib libsupport.a

Making ftpd.
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support o
bison -y  ftpcmd.y
mv -f y.tab.c ftpcmd.c
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support o
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support o
glob.c: In function `matchdir':
glob.c:284: dereferencing pointer to incomplete type
make: *** [glob.o] Error 1

Making ftpcount.
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support w
gcc: vers.o: No such file or directory
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support w
gcc: vers.o: No such file or directory
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd
-L../support c

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
text    data    bss     dec     hex     filename
1032    1865    92      2989    bad     bin/ckconfig
Done

Thanks,

James Poulin
Ottawa, Ontario, Canada

---

From: Perry Rovers <[email-masked]>
Date: Thu, 7 Nov 1996 23:27:08 +0100 (MET)

> i'll send ya a Cyber-Beer or somthin .... :-)
This is in the faq at www.hvu.nl/~koos/wu-ftpd-faq.html now.

> make: *** [glob.o] Error 1
Use -DDIRENT_ILLEGAL_ACCESS in the CFLAGS in src/makefiles/Makefile.lnx

Perry Rovers, Amsterdam (and a number of other places), The Netherlands
Mail: mailto:[email-masked]       | Amsterdam is zo'n gezellige stad
FTP : ftp://ftp.iaehv.nl/pub/users/perry | omdat er zo verdomd veel
WWW : http://www.iaehv.nl/users/perry    | Brabanders wonen - Hans van Mierlo