Subject: Re: wu-ftpd on solaris

From: [email-masked] (Geoff Terry Systems & Net supt 064 923677)
Date: Thu, 28 Nov 1996 11:54:33 +1100 (EST)

Michael,
looks like you need to set your environment so make can find the c compiler.
Either set your path to include the location of your c compiler (the
recomendation is the gnu compiler gcc) or
edit the Makefile.sol (linked from
~distribution/support/makefiles/Makefile.sol to ~distribution/support/Makefile).
Check the variable CC in the ~distribution/support/makefiles/Makefile.sol
(it should be local/bin/gcc or whereever you put the gcc compiler).
Then run build again.
You will also need to ensure that your path includes ar and yacc.

Regards Geofft
>Here are the errors I got when trying to compile it on solaris 2.5
>
>Michael
>
>On Wed, 27 Nov 1996, Jim Davis wrote:
>
>> On Wed, 27 Nov 1996, Michael Haro wrote:
>> 
>> > I have had absolutely no luck compiling wu-ftpd 2.4.2 beta 11 on
solaris 2.5.
>> 
>> That's odd -- it compiled without a hitch for me (and has for many others
>> too).  What problems did you have? 
>> 
>> 
>Content-Type: TEXT/PLAIN; charset=US-ASCII; name=wu-ftp-errors

>Content-ID: <Pine.SOL.3.95.961127160733.4941D@infolane>
>Content-Description: 
>
>./build sol
>make args are : 
>make opts are : 
>
>Linking Makefiles.
>
>Making support library.
>cc -g -DDEBUG   -c fnmatch.c
>make: cc: Command not found
>make: *** [fnmatch.o] Error 127
>
>Making ftpd.
>cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
>make: cc: Command not found
>make: *** [ftpd.o] Error 127
>
>Making ftpcount.
>cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsupport -lsocket -lnsl -lgen 
>make: cc: Command not found
>make: *** [ftpcount] Error 127
>
>Making ftpshut.
>cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupport -lsocket -lnsl -lgen
>make: cc: Command not found
>make: *** [ftpshut] Error 127
>
>Making ckconfig.
>cc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c
>make: cc: Command not found
>make: *** [ckconfig] Error 127
>
>Links to executables are in bin directory:
>./build: size: not found
>Done
>
Geoff Terry
Systems & Network Support
ACR Net
Sapphire Coast NSW 2550
Australia
Ph 064 923677
Mobile 015 668 227
Fax 064 924594

---

From: [email-masked]
Date: Thu, 28 Nov 1996 11:39:18 -0500 (EST)

> Here is the newest attempt using gcc and solaris 2.5
<snip snip>

  I had many problems of that kind under solaris, due to the default /bin/sh
... Just recompile another sh-compatible shell like bash and install it
instead of /bin/sh ( You can leave the original one in /sbin/sh ) . This
should avoid lotsa compilation problems. ( don't forget to patch bash
against a well-known security hole btw ) .

  Best regards, Frank (j).
-- 
>Edit-Online<  International translations, multilanguage WWW creation & hosting
 Europe, Tokyo, Beijing, Seoul, Bangkok, Bombay, Washington, Rio, Buenos-Aires
  <(=-  [http://www.edit-online.com/] <*> [ftp://ftp.edit-online.com/]  -=)>
Frank DENIS aka Jedi/Sector One, network system administrator. Email: [email-masked]