Subject: ftpshut

From: Emanuele Buttice <[email-masked]>
Date: Mon, 04 Nov 1996 21:35:28 -0800

Hi,

Has anyone been sucessfull in getting ftpshut to send a message and
disconnet users after a certain time period. I am running wu-2.4.2Beta
11(1) on Linux 2.0.24 Slakware.

I tried  ftpshut +20 "Shutting down FTP"

This disables further ftp connections but doesn't send the message to
the connected users nor does it disconnect them. 
I tried various other permutations using -d and -l but still can't get
it working. 

Any one know hane any ideas ??   

Thanks.

-- 
Emanuele Buttice  [email-masked] Network Analyst 
Elecomm Corporation - www.elecomm.net

---

From: Alain Magloire <[email-masked]>
Date: Tue, 5 Nov 1996 20:49:00 -0500 (EST)

> Any one know hane any ideas ??   

Hello `Emanuele Buttice', well the thing that we tend to overlook
is the chroot() ... sigh (happens to me all the time) ...

______let's suppose ftp's home is "/home/ftp"__________

for exemple if you have this in your ftpaccess.

"shutdown /etc/shutmsg"

you must have also 
__ /home/ftp/etc/shutmsg __

If you don't have this, ``shutdown'' will not work properly for
anonymous ftp. Because of the chroot() for anonymous

"/etc" ---(will map to)---> "/home/ftp/etc"

and when ftpd does the stat() the file will not exist.

So you can do
1-
 After doing ``ftpshut +20 "Shutting down of FTP by %E"''
 copy by hand /etc/shutmsg in /home/ftp/etc

2-
 Roll up your own ftpshut program that will do the
 job correctly for `real,anonymous and guests'.
 If you do ... __PLEASE__ send me the patch 8-)

3-
 The path of least resistance(mine :-), go on a rampage
 with ps and kill -9. It is certainly very rude, but
 hey ! life's a b... and loving every minute of it >8>

4-
 Other possibilities ? please share, I'm
 curious to hear them.

--
alain