Subject: compiling wu-ftp with sun sparccompiler 4.0 : make fatal error...

From: Snohomish County GIS <[email-masked]>
Date: Mon, 04 Nov 1996 18:32:37 -0800

Thanks for any responses to this question:

We are trying to compile the wuftp version 2.4. 
Very novice with the c compiler and working with public domain software.
Running Sun SPARCompiler C 4.0 on 
an Ultra 140. Got all my paths set right according to the Sun docs.
Also edited the build file according to INSTALL instructions.

The following occurs after issuing "build sol"

make args are : 
make opts are : 

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
make: Fatal error: Don't know how to make target `/lib/libc.a'

there's about another page of messages. Am I missing a Solaris
package here, or is it in the wuftp config files?

thanks again,

Jim Smith, aka
Snohomish County GIS <[email-masked]>

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Tue, 5 Nov 1996 06:33:16 +0100 (MET)

> an Ultra 140. Got all my paths set right according to the Sun docs.

Uhm... I'm not sure how the Sun docs are but I allways have to set up
a Sun Sparc compiler different then original to make it work.

Ik have /usr/ccs/bin in my path *before* /usr/ucb, and :

lrwxrwxrwx   1 root     other         24 Jun  6  1995 /usr/ccs/bin/cc -> /opt/SUNWspro/SC2.0.1/cc*

Make sure you're not using /usr/ucb/cc (you don't want to).

                                              Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Unix op z'n NL's : Segment overtreding - kern uitgescheten       KH106-RIPE