Subject: Chroot to correct virtual root?

From: Cato Antonsen <[email-masked]>
Date: Mon, 04 Nov 1996 19:17:01 +0100

Hi!

I've installed B11 and configured 'ftpaccess' according to 'VIRTUAL.FTP.SUPPORT'. I've set up two virtual domains using ip-aliasing to point to my Irix 5.3 box. 

I have no problems connecting to both virtual domains, but ftpd seemd to ignore the virtual root in 'ftpaccess'. 

What I want is that both 'real' and 'anonymous' users should be chroot'ed to the directory specified in file 'ftpaccess' (virtual ip.ip.ip.ip root /path).

Possible? How?

Thanks in advance!

Med hilsen

<bold>Cato Antonsen, EUnet NORD AS, Telefon 75 01 84 82

</bold>[email-masked], http://login.nord.eunet.no/~cato/

---

From: Alain Magloire <[email-masked]>
Date: Mon, 4 Nov 1996 20:12:44 -0500 (EST)

> What I want is that both 'real' and 'anonymous' users should be chroot'ed to the directory specified in file 'ftpaccess' (virtual ip.ip.ip.ip root /path).

1-
ftpd doesn't change root for `real' users. It will only 
do chroot() for type `anonymous' and `guest'.

Look at the FAQ to learn how to set `guestgroups'(type `guest').

2-
 Don't forget to put the "-a" in the inetd.conf if you
want ftpd to read ftpaccess. 

This error is probably the most __FAQ__ in the mailing list

--
alain