Subject: error on build install

From: Doug Wright <[email-masked]>
Date: Mon, 04 Nov 1996 15:05:47 -0400

I am installing wu-ftpd 2.4 on solaris 2.5
I got the build to work but when I run the build install I get the following

# build install
make args are :
make opts are :
mv -f /usr/local/etc/ftpd /usr/local/etc/ftpd-old
Installing binaries.
install -o bin -g bin -m 755 bin/ftpd /usr/local/etc/ftpd
usage: install [options] file [dir1 ...]
*** Error code 2
make: Fatal error: Command failed for target `install'

the file ftpd is in wu-ftp-2.4/bin and the diectory /usr/local/etc does exist
I am doing the build install as root. 
Any ideas?
-----------------------
    Doug Wright
 Systems Administrator  
 ShareLine Systems Ltd.
  http://shareline.com
   [email-masked]
-----------------------

---

From: Alain Magloire <[email-masked]>
Date: Mon, 4 Nov 1996 17:55:58 -0500 (EST)

> I am doing the build install as root. 

this is a FAQ:

         8. install fails with 'install: ..'
            The makefile is setup for the bsd version of the install
            program. Some OS'es (including Solaris) use the svr4 version.
            In that case set in the makefile :                          
            INSTALL = /usr/ucb/install                                  

for more look at:
<URL:http://www.hvu.nl/~koos/wu-ftpd-faq.html>

--
alain