Subject: Re: anonymous ls -l

From: [email-masked] (Pavel Kolesnikov)
Date: Fri, 1 Nov 1996 11:17:15 +0300

Hello,

I just installed "wu-ftpd-2.4.2-beta-11" under Solaris 2.5.1 yesterday.
It looks working except "ls -l" for anonymous user. It lists only the 
owner and group numbers but not as manes.

I have "~ftp/etc" directory with permissions "dr-xr-xr-x" plus appropriate
files:

-r--r--r--   1 root     other        278 Oct 31 20:14 group
-r--r--r--   1 root     other       1064 Oct 31 20:14 netconfig
-r--r--r--   1 root     other       1184 Oct 31 20:14 nsswitch.conf
-r--r--r--   1 root     other        550 Oct 31 20:14 passwd

Does anybody know what the problem is ?
Thanks in advance,

                         ''~``
                        ( o o )
+------------------.oooO--(_)--Oooo.------------------+
| Pavel  Kolesnikov                Belief             |
|  St. Petersburg,   .oooO             creates        |
|      Russia        (   )   Oooo.         reality... |
+---------------------\ (----(   )--------------------+
                       \_)    ) /
                             (_/

---

From: Serge Bezzubov <[email-masked]>
Date: Fri, 1 Nov 1996 15:50:47 +0300 (MSK)

> From [email-masked] Fri Nov  1 11:53 MSK 1996
> Date: Fri, 1 Nov 1996 11:17:15 +0300
> From: [email-masked] (Pavel Kolesnikov)
> To: [email-masked]
> Subject: Re: anonymous  ls -l
> Mime-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-MD5: tLFR0dxccohqHoFB8F0lUw==
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> Hello,
> 
I had the same problem you are experiencing. The problem has gone when
I added nss_files.so.1 library to the ~ftp/usr/lib. If you are using
NIS or NIS+ you probably should add nss_nis.so.1 or nss_nisplus.so 1
respectively.

Hope this helps.
Serge Bezzubov <[email-masked]>
YNC, Yaroslavl, Russia

---

From: [email-masked] (Neal Pressman ex 2317)
Date: Fri, 1 Nov 96 08:03:37 EST

i had similar problems until i added all the required lib files
into ~ftp/usr/lib if you need a list of theese files let me know

                                \\|//
                                (o o)
----------------------------oooO-(_)-Oooo----------------------------
 Neal S. Pressman                        Raytheon Electronic Systems
 System Administrator (MCAE)             528 Boston Post Road
 phone:  (508) 440-2317                  Sudbury, MA  01776
 fax:    (508) 440-2684                  ms 4-1-283
 E-mail:  [email-masked]
____________________________________Oooo.____________________________
                             .oooO  (___)

-> From [email-masked] Fri Nov  1 03:56:09 1996
-> Date: Fri, 1 Nov 1996 11:17:15 +0300
-> From: [email-masked] (Pavel Kolesnikov)
-> To: [email-masked]
-> Subject: Re: anonymous  ls -l
-> Mime-Version: 1.0
-> Content-Transfer-Encoding: 7bit
-> Content-Md5: tLFR0dxccohqHoFB8F0lUw==
-> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
-> Status: RO
-> 
-> Hello,
-> 
-> I just installed "wu-ftpd-2.4.2-beta-11" under Solaris 2.5.1 yesterday.
-> It looks working except "ls -l" for anonymous user. It lists only the 
-> owner and group numbers but not as manes.
-> 
-> I have "~ftp/etc" directory with permissions "dr-xr-xr-x" plus appropriate
-> files:
-> 
-> -r--r--r--   1 root     other        278 Oct 31 20:14 group
-> -r--r--r--   1 root     other       1064 Oct 31 20:14 netconfig
-> -r--r--r--   1 root     other       1184 Oct 31 20:14 nsswitch.conf
-> -r--r--r--   1 root     other        550 Oct 31 20:14 passwd
-> 
-> 
-> Does anybody know what the problem is ?
-> Thanks in advance,
-> 
-> 
->                          ''~``
->                         ( o o )
-> +------------------.oooO--(_)--Oooo.------------------+
-> | Pavel  Kolesnikov                Belief             |
-> |  St. Petersburg,   .oooO             creates        |
-> |      Russia        (   )   Oooo.         reality... |
-> +---------------------\ (----(   )--------------------+
->                        \_)    ) /
->                              (_/
->

---

From: [email-masked]
Date: Mon, 25 Nov 1996 11:49:08 +0100

I am setting up an anonymous ftp server for my group on Solaris 2.5. 
The single ls works but no ls -l and dir.
Also the command "truss -f chroot ~ftp /bin/ls" could not help 

Both /dev and /usr/lib contains following files:

/usr/lib:
-rwxr-xr-x   1 root     other     106768 Nov 22 10:37 ld.so.1
-rwxr-xr-x   1 root     other     664048 Nov 22 10:21 libc.so
-r-xr-xr-x   1 root     other     664048 Nov 22 09:58 libc.so.1
-rwxr-xr-x   1 root     other       2568 Nov 22 10:21 libdl.so
-r-xr-xr-x   1 root     other       2568 Nov 21 11:20 libdl.so.1
-rwxr-xr-x   1 root     other      15304 Nov 22 10:26 libintl.so.1
-r-xr-xr-x   1 root     other      15720 Nov 22 10:06 libmp.so.1
-rwxr-xr-x   1 root     other     565500 Nov 22 10:30 libnsl.so.1
-rwxr-xr-x   1 root     other      68780 Nov 22 10:30 libsocket.so.1
-rwxr-xr-x   1 root     other      39340 Nov 22 10:26 libw.so.1
-rwxr-xr-x   1 root     other      15636 Nov 22 10:30 nss_compat.so.1
-rwxr-xr-x   1 root     other      10796 Nov 22 10:31 nss_dns.so.1
-r-xr-xr-x   1 root     other      21028 Nov 22 09:44 nss_files.so.1
-r-xr-xr-x   1 root     other      24408 Nov 22 09:45 nss_nis.so.1
-r-xr-xr-x   1 root     other      28848 Nov 22 09:46 nss_nisplus.so.1
-rwxr-xr-x   1 root     other       9316 Nov 22 10:31 straddr.so

/dev:
crw-rw-rw-   1 root     other     11, 42 Nov 21 12:57 tcp
crw-rw-rw-   1 root     other      3, 12 Nov 21 11:14 zero

---

From: [email-masked]
Date: Tue, 26 Nov 1996 11:25:30 +0100

The problem in this case is the size of zero.
In the first time i generate ZERO in /dev/zero with the command:

mknod zero c 3 12 that is not enough LS -L do not work

with mknod zero c 13 12 the system seems enough mmap
                  ^^