Subject: 'ps -ef' output

From: Chuck Davis <[email-masked]>
Date: Wed, 13 Nov 1996 18:05:26 EST

Hello,

wu-ftpd is nice.  A lot more configurable than the standard that came w/
our system.  However there was one feature of the old default server that
wuftpd doesn't seem to support:

We're running HP-UX 10.10.  When using the default HP ftpd and I type 
'ps -ef | grep ftp' I get something like the following:

   root 19813   591  0 0:42    ftpd 131.120.59.51: dmdc: STOR GAIN9093.TXT
   root 21218   591  0 0:00    ftpd 128.183.36.23: anonymous/junk@: TYPE I  

With wuftpd running and typing the same command I get:

    root 20997   591  0 16:49:25 ?         0:07 ftpd -a -l

The 1st shows who's connected from where doing what.  The 2nd just spits
out the entry from /etc/inetd.conf.  Of course I can disect who is doing
what from the syslog and netstat, etc.  But I am wondering is there a way
to get wuftpd to display more info via ps?  'ps -ef | grep ftp' is a very
handy way to keep track of transfers, etc, some of which take several hours.

Any advice?

Thanks

Chuck Davis

*++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++*
+ Chuck Davis                            |   Life is what happens while      *
+ Army Medical Surveillance Activity     | you're busy making other plans    *
+ Walter Reed Army Institute of Research |    ----- John Lennon -----        *
+ [email-masked]             |                                   *
*++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++*

---

From: Alain Magloire <[email-masked]>
Date: Wed, 13 Nov 1996 19:41:17 -0500 (EST)

>     root 20997   591  0 16:49:25 ?         0:07 ftpd -a -l

usulaly this is done in the function
setproctitle() but this function have a history of problems

Try ftpwho instead

--
alain

---

From: Krishna Panyam <[email-masked]>
Date: Wed, 13 Nov 96 16:53:35

I recently 'inherited' a mess of an FTP server, and I am learning everything the hard way.
I have a few questions that I hope someone can and will answer.

1. We seem to be running the well known wu-ftpd 2.4 ftpd, but how to I know that is true? Is 
there a way to find out ?

2. I have 'ftpd -a' in the inetd.conf file, which I understand enables the /etc/ftpaccess file. 
But almost everything I try using the ftpaccess file causes problems.

2a. I have a few 'upload' entries for 'incoming' directories specifying the owner/group and 
permissions on files put here. When I add 'nodirs' to these lines, nobody (including local 
users) is able to create a directory anywhere under the FTP home directory.

2b. When I try to add restrictions for the file names using the path-filter command, it seems to 
restrict all users from creating any directories at all!

3. All file transfers are beign logged. Is this the default ? I tried to add an entry in the 
ftpaccess file to log user commands, but it is not doing anything that I can see.

Is there some common theme behind all these ? 

Thanks
Krishna

---

From: Bob Myers <[email-masked]>
Date: Wed, 13 Nov 1996 17:56:45 -0800

> there a way to find out ?

When you connect to the server, it should give the version number:

% ftp foobar.intelenet.net
Connected to foobar.intelenet.net.
220 foobar.intelenet.net FTP server (Version wu-2.4.2-academ[BETA-11])
Thu Sep 26 11:00:07 PDT 1996) ready.

> users) is able to create a directory anywhere under the FTP home directory.

This is a bug in at least some versions of ftpd, including
wu-2.4.2-academ[BETA-11], the latest release.

> restrict all users from creating any directories at all!

Sounds like the 'nodirs' problem to me - you're sure it's the
path-filter that makes the difference?

> 3. All file transfers are being logged. Is this the default ? I tried to add an entry in the

It apparently logs user commands to the daemon syslog, not the xfer_log.

-- 
Bob Myers                              InteleNet Communications, Inc.
Email: [email-masked]               30 Executive Park, Suite 150
Phone: 714-851-8250 x227               Irvine, CA 92614
Fax:   714-851-1088                    http://www.intelenet.net/

---

From: Krishna Panyam <[email-masked]>
Date: Thu, 14 Nov 96 09:22:21

Bob,

You are right, I am running the wu-2.4.2-academ[BETA-11] version. 
What version should I use? Hopefully there is one that does not have these problems!

By the way, I made a mistake in my original posting - when I try to set up a path-filter entry, 
users are prevented from creating files (not just directories, as I said before) and the 
path-filter message file is printed out.

Thanks
Krishna Panyam

--- On Wed, 13 Nov 1996 17:56:45 -0800  Bob Myers <[email-masked]> wrote:

---------------End of Original Message-----------------