Subject: chroot()

From: [email-masked]
Date: Thu, 3 Oct 1996 14:13:02 +0000

Is it possible having done all this to let a person read his 
directory, and if so how ? I have set all this up and it works except 
for the fact that none of the guests can list their directories, yet 
I want them to maintain them themselves i.e clearing old files and 
the like.

Thanks.
*****************************
* Kaggwa S. Terah           *
* System Engineer           *
* InfoMail (U) Ltd.         *
* E-mail: [email-masked]     *
*         [email-masked]  *
* Tel: 256-41-258361        *
* Fax: 256-41-236256        *
*****************************

InfoMail, The GateWay To Uganda.

---

From: Michael Brennen <[email-masked]>
Date: Thu, 3 Oct 1996 08:39:42 -0500 (CDT)

> I want them to maintain them themselves i.e clearing old files and 

Have a detailed look at the guest howto below, and pay attention to how
the 'ls' command is set up in each guest directory.

   -- Michael

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z

WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto

There are additional security references in the above docs.

---

From: Alain Magloire <[email-masked]>
Date: Thu, 3 Oct 1996 11:41:42 -0400 (EDT)

Hello
  Not a question just a comment, that I hope will be usefull to 
other brave souls who have lost hours of good sleep.

It applies to SunOS-4.1.x, I don't know about
other ARCH (don't have other ARCH :-).

  A common mistake(That I do repeatedly) is forgetting to create
the device /dev/zero. The symptom is :

everything else seems to work(get ,put, ...) but ls doesn't show anything.

  Usually, it happens when ~ftp/bin/ls is dynamically link. ld.so use mmap()
to map and bind share object at run-time. And mmap() probably
zero-fill the aera with an open("/dev/zero", O_RDWR).

So when you have SunOS and ls doesn't work ... it's a good place
to start investigate.

--
good night, alain