Subject: Re: chroot() function

From: Brian Beaulieu <[email-masked]>
Date: Wed, 2 Oct 1996 20:08:25 -0400 (EDT)

At 04:35 PM 96/10/02 -0700, you wrote:

>Hint: guestgroup in the ftpaccess file.

Thanks :)
This is the section from my ftpaccess
-
# specify which group of users will be treated as "guests".
guestgroup ftponly user 
-
I'm assuming it wants system groups.. (ftponly isn't technically a group)
Also, the account 'ftp' doesn't belong to any groups.

Any other 'hints'?

Thanks

Brian
-- 
===================================
CAPE Internet Systems Administrator
http://www.capecod.net
http://despair.capecod.net
[email-masked]
===================================

---

From: Brian Beaulieu <[email-masked]>
Date: Wed, 2 Oct 1996 21:46:11 -0400 (EDT)

At 11:07 AM 96/10/03 +1000, you wrote:

>Don't forget to add /bin/ftponly (or /bin/true whatever you use for the 
>ftponly shell) to /etc/shells  it tends to be easy to overlook.  And on 
>most systems if you dont have a valid shell, you dont have a login.

Yep, got that done.
It is still allowing my to browse directories

I'm runnning BSDi 2.1
This is my passwd/master.passwd entry:
despair# grep brian /etc/*passwd*
/etc/master.passwd:brian:<password>:109:100::0:0:,,,:/usr/home/./brian/:/etc
/ftponly
/etc/passwd:brian:*:109:100:,,,:/usr/home/./brian/:/etc/ftponly
despair# 

------
This is my shells entry

despair# grep ftponly /etc/shells 
/etc/ftponly
despair# 
-------
This is my ftpaccess entry:
despair# grep guestgroup /etc/ftpaccess
guestgroup ftponly user
despair# 

-------
I'm assuming the guestgroup is supposed to be a group on the server.
the group 'user' is the group that all users belong to.

It still doesnt' work with that setup..
This is wu-ftpd 2.4.2 beta-11

Thanks for your help,

Brian