Subject: Re: chroot() function

From: Brian Beaulieu <[email-masked]>
Date: Wed, 2 Oct 1996 21:03:33 -0400 (EDT)

At 05:55 PM 96/10/02 -0700, you wrote:
>In your ftpaccess file add:
>
>	guestgroup <valid group name from /etc/group>
>
>and, in the password file setup the home directory path like,
>
>	/home/./user-dir
>
>The /./ tells chroot to use user-dir as the root directory (/).

OK.. i'm running BSDi 2.2

This is the test user's passwd entry:
brian:*:109:100:,,,:/usr/home/./brian:/bin/bash

This is the ftpaccess entry:
despair# grep guestgroup ftpaccess
guestgroup ftponly user
despair# 

despair# groups brian
user
despair# 
--------
This is wuftpd 2.4.2-beta 11

with that setup, i ftp in.. log in as brian aand i can still browse directories.

Brian
-- 
===================================
CAPE Internet Systems Administrator
http://www.capecod.net
http://despair.capecod.net
[email-masked]
===================================

---

From: Cassandra Perkins <[email-masked]>
Date: Wed, 2 Oct 1996 19:19:40 -0700 (PDT)

> >The /./ tells chroot to use user-dir as the root directory (/).

Sorry, I made a mistake.  The root directory will be /home and user-dir 
is the subdirectory you are placed into when you log in.

> brian:*:109:100:,,,:/usr/home/./brian:/bin/bash

Your example will put you in directory /brian when you ftp.  So you 
should only be able to move up one notch only.
	$ pwd
	/brian
	$ cd ..
	$ pwd
	/

Cassandra