Subject: Re: chroot()

From: [email-masked]
Date: Thu, 3 Oct 1996 18:31:20 +0000

> Date:          Thu, 3 Oct 1996 08:39:42 -0500 (CDT)
> Reply-to:      [email-masked]
> From:          Michael Brennen <[email-masked]>
> To:            [email-masked]
> Subject:       Re: chroot()

> On Thu, 3 Oct 1996 [email-masked] wrote:
> 
> > Is it possible having done all this to let a person read his 
> > directory, and if so how ? I have set all this up and it works except 
> > for the fact that none of the guests can list their directories, yet 
> > I want them to maintain them themselves i.e clearing old files and 
> > the like.
> 
> Have a detailed look at the guest howto below, and pay attention to how
> the 'ls' command is set up in each guest directory.
> 
>    -- Michael
> 
> 
> This is the location for the latest wu-ftpd.  You can't see the
> directory contents, but get the file anyway.  It's there.
> 
> ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z
> 
> WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html
> 
> guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto
> 
> There are additional security references in the above docs.
> 
> 

Sorry, I forgot to mention, my guestusers home dirs are not under the 
ftp directory. I am using a different subtree /home/users . 
*****************************
* Kaggwa S. Terah           *
* System Engineer           *
* InfoMail (U) Ltd.         *
* E-mail: [email-masked]     *
*         [email-masked]  *
* Tel: 256-41-258361        *
* Fax: 256-41-236256        *
*****************************

InfoMail, The GateWay To Uganda.

---

From: Alain Magloire <[email-masked]>
Date: Thu, 3 Oct 1996 12:09:28 -0400 (EDT)

> ftp directory. I am using a different subtree /home/users . 

#ifdef SHORT_ANSWER
 
  make available a  statically version of 'ls' under
  /home/users/bin/ls

#elsif LONG_ANSWER

  what Michael Brennen was saying is that under /home/users
  You must have a correct file system with
  /home/users/lib/*
  /home/users/dev/*
  etc ..
  
  see the docs in Michael emails for more info

#else DEBUG

  one sure way to see if 'ls' is ok:

  chroot /home/users bin/ls

  I suppose that ls is under /home/users/bin/ls

#endif

--
good day, alain