Subject: ftpconversions problem

From: "Fasano, Albert C" <[email-masked]>
Date: Thu, 17 Oct 1996 09:38:43 -0400

Hello,
I am sure you have heard this question many times.
Can't get compress/uncompress to work.

I've copied the entries straight from the O'Reilly book for both
ftpaccess
and ftpconversion.
Here is relevant ftpaccess entries:

class local real IP.IP.IP.*
compress yes local
compress        yes     local
uncompress      yes     local
/bin/compress yes local
#As you can see I've tried many variations trying to get it to work.

Here is entry in ftpconversions
:.Z:  :  :/bin/uncompress -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
:  :  :.Z:/bin/compress -c %s:T_REG|T_ASCII:O_COMPRESS:COMPRESS

Notes about install:
1)Did not compile locally. Took binaries and config files from another
system
2)Running on ports greater than 20000

another problem - I even have trouble preventing my "local" class from
executing delete and mkdir when I add them to ftpaccess file. However
when I remove my classes I get accessed denied not member of any class.
So I assume it is reading the ftpaccess file?

When I attempt the uncompress on the fly:
ftp>ls
file.Z
ftp>get file
200 PORT command successful
550 file: No such file OR directory

Any help is appreciated:
Al Fasano
AT&T Laboratories
Web Hosted Services
(908) 949-0497

---

From: pstewart <[email-masked]>
Date: Thu, 17 Oct 1996 11:42:20 -0400 (EDT)

Hi there...

I know this has been covered lately and apologize.. I had an answer to
this before that worked fine, but lost the answer...

when compiling 2.4-fixed on a linux 2.0.13 machine I get this error
again...

glob.c: line 240 incompatible reference to pointer type (something like
that)
[glob.c] Error 1

It won't complile ftpd like it should.... like I said I had this problem
previously and found a fix via this list... sorry to hash it over AGAIN...

Thanks,

Paul

---

From: Vincent Cojot <[email-masked]>
Date: Thu, 17 Oct 1996 12:01:20 -0400 (EDT)

> glob.c: line 240 incompatible reference to pointer type (something like

Add -DDIRENT_ILLEGAL_ACCESS to Makefile.lnx in Makefile.lnx and re-run 
"build lnx". That will fix the problem.

,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,
Vincent S. Cojot, Computer Engineering. STEP project. _.,-*~'`^`'~*-,._.,-*~
Ecole Polytechnique de Montreal, Comite Micro-Informatique. _.,-*~'`^`'~*-,.
Linux Xview/OpenLook resources page _.,-*~'`^`'~*-,._ [email-masked]
http://www.info.polymtl.ca/~coyote  _.,-*~'`^`'~*-,._ [email-masked]

They cannot scare me with their empty spaces
Between stars - on stars where no human race is
I have it in me so much nearer home
To scare myself with my own desert places.       - Robert Frost

---

From: Alain Magloire <[email-masked]>
Date: Thu, 17 Oct 1996 13:23:51 -0400 (EDT)

> Can't get compress/uncompress to work.
[...deleted]
> #As you can see I've tried many variations trying to get it to work.

:-)
better more than less (or is it the other way ;)

> :  :  :.Z:/bin/compress -c %s:T_REG|T_ASCII:O_COMPRESS:COMPRESS

first question is
ucompress/compress in 
~ftp/bin  ?
don't forget that ftpd do a chroot("/where/ever/ftp")
so "/" is "/where/ever/ftp"

> 1)Did not compile locally. Took binaries and config files from another

;(

did you ask for the man pages and docs also ;-)

> 2)Running on ports greater than 20000

:)

> So I assume it is reading the ftpaccess file?

you have to enable 
`delete' in the ftpaccess for the types(real,guest,anonymous)

--
cheers, alain

---

From: pstewart <[email-masked]>
Date: Thu, 17 Oct 1996 15:02:21 -0400 (EDT)

Hello there...

I just recently compiled 2.4-fixed and compiled in shadow support... a
couple of user accounts work fine, but others don't... I can't find the
logic.....

Anyone have any ideas why?  Everyone uses the same shell to the best of my
knowledge...

Thanks again,

Paul

---

From: Web-Master UTA <[email-masked]>
Date: Thu, 17 Oct 1996 18:05:20 -0300 (CDT)

I'm have a DEC 3000/300 with OSF/1 2.0 and C2 security (enhanced),
when installing wu-ftpd the machine users dont can acces ftp, only the guest
user can acces by ftp. if down C2 Security no problem, because?

thanks

jaime.