Subject: Re: chroot()

From: "Stefan Berg" <[email-masked]>
Date: Wed, 23 Oct 1996 07:12:41 +0100

Could it simply be that you forgot to edit the /etc/passwd entry for
that user to look like this:

ftpuser:x:600:60001:FTP-user:/export/home/ftpuser/./:/bin/ksh
							  ^^^

The user also has to be a member of your defined guestgroup (define it in 
ftpaccess).

/Stefan

Arthur Dent (!) wrote:

> Hi 
>  
> does anyone knows what the requirements are 
> for the chroot(). I followed the following faq (ftp://ftp.fni.com/pub/
> wu-ftpd/guest-howto) on a system with Solaris 2.4 running wu-ftp2.4. 
> the ftp guest users login but the chroot() 
> is not performed as it should. As for the user anonymous and real 
> users, it works fine. 
> Anybody has any idea why? 
>  
>  
> Esaie 
>  
>

---

From: [email-masked] (Arthur Dent)
Date: Wed, 23 Oct 1996 14:20:24 -0400 (EDT)

Hello

I did all that.. (I did read the faq and the doc).
He's part of a group which is part of the guestgroup
in the ftpaccess file. I set his shell to /bin/csh
(defined in the /etc/shells), he gets
"Can't create data socket (0.0.0.0,20): Bad file number."
when he types ls after logging in via ftp.
however, when I set his shell to /bin/false 
(defined in the /etc/shells) he can login but the
chroot() doesn't seem to work since the root dir is wrong.

Any help would be appreciated.
Esaie