Subject: ftpconversions

From: [email-masked] (Thierry Frati)
Date: Thu, 3 Oct 1996 15:13:57 +0200

Is it possible to use the put command to convert a file (for example
compress) ?

ftp> put Rconnect.c.Z
Rconnect.c.Z: No such file or directory
ftp> get Rconnect.c.Z
200 PORT command successful.
150 Opening BINARY mode data connection for /bin/compress.
226 Transfer complete.
local: Rconnect.c.Z remote: Rconnect.c.Z
2443 bytes received in 0.018 seconds (1.3e+02 Kbytes/s)
ftp> 

Here is an extract from my ftpconversions file :

 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS

Any suggestions or idea will be appreciated

Thanks

Thierry

---

From: Alain Magloire <[email-masked]>
Date: Thu, 3 Oct 1996 11:13:56 -0400 (EDT)

> Is it possible to use the put command to convert a file (for example

You got it mix 'Thierry'
The Compression and Decompression on the fly is _only_ done
for downloading _not_ uploading

--------------------
ftp>ls
file1 file2.Z

ftp>get file1.Z

ftpd will compress data according to ftpconversions

ftp>get file2

ftpd will uncompress data according to ftpconversions

and of course ftpaccess has
class   all  real,guest,anonymous *
...
compress yes all
tar yes all
...

--------------------
doing this

put file file.Z

will do nothing except rename file on the remote server to file.Z
Obviously not what you want :)

I don't know of any patch for {DE,}compression on the fly when _uploading_

--
bye, alain

> ftp>=20