Subject: Anonymous uploads owned by wrong user

From: [email-masked] (John Murtari)
Date: Tue, 8 Oct 1996 07:37:04 -0400

Hello All,

	We are still having problems with anonymous uploads being
owned by "ftp" and NOT the user specified in the ftpaccess file.
This is on a Solaris 2.5.1 system.

	I checked the FAQ, and did the "-a" in the inetd.conf file,
but NO luck.  I'm sure it is something simple, but we can't find
the problem?

	Our access file:
===
# specify the upload directory information
upload  /pub/ftp  *             no
upload  /pub/ftp  /thebook/incoming     yes     thebook   www  0600 dirs
upload  /pub/ftp  /bin          no
upload  /pub/ftp  /etc          no
==

	Would appreciate hearing from any Solaris 2.x folks who
have this working!

                                          John
___________________________________________________________________
John Murtari                              Software Workshop Inc.
[email-masked] 315.695.1301(x-211)  "TheBook.Com" (TM)
http://www.thebook.com/

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 17 Oct 1996 23:56:35 +0200 (MET DST)

> This is on a Solaris 2.5.1 system.

Is the upload dir by any chance NFS mounted ?

(if it is, the chown will be disabled by the NFS daemon)

                                              Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Unix op z'n NL's : Segment overtreding - kern uitgescheten       KH106-RIPE