Subject: Help ls -l for REAL users chrooted?

From: Scot Needy <[email-masked]>
Date: Fri, 25 Oct 1996 12:34:15 -0400

Hello All;

 I am trying to create an ftp site which no anonymous users are 
 allowed and all real users are chrooted to thier home dir.
 
 Problems
 
  o They get chrooted OK but there is no ls -la and the 
    documentation I have seen speaks of _PATH_EXECPATH for 
    annonymous user classes but I'm not sure how to implement it here.
    
  o I would like to chroot some users to a directory above 
    thier HOME dir where they are in the same group as other users. 
    They will have r/w here as well as ls -l ....

  Everything else is working great.
  
  Thank you for 
  any comments or sudjestions (sp)
  
  Scot

---

From: Michael Brennen <[email-masked]>
Date: Fri, 25 Oct 1996 13:16:39 -0500 (CDT)

Guest FTP.  See the howto below.

   -- Michael

>  allowed and all real users are chrooted to thier home dir.

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z

WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto

There are additional security references in the above docs.

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Fri, 25 Oct 1996 22:15:17 +0200 (MET DST)

>     annonymous user classes but I'm not sure how to implement it here.

_PATH_EXECPATH is for SITE EXEC commands and *not* used for finding ls,
tar, compress, gzip.

The usual story about devices and libs goes for chrooted homedirs.

                                              Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Unix op z'n NL's : Segment overtreding - kern uitgescheten       KH106-RIPE