Subject: ftpaccess file

From: Steve Calia <[email-masked]>
Date: Fri, 04 Oct 1996 12:59:59 -0600

I have run chconfig and it says that my ftpaccess file is ok. However, although the daemon works, none of the conditions set in the ftpaccess are in effect. Here is the file. 

class local real 128.165.16.*
class local real 128.165.116.*
class local real 128.165.123.*
class anonymous anonymous *

passwd-check rfc822 enforce

upload /usr/export/home/ftpuser * no
upload /usr/export/home/ftpuser pub/incoming yes root incoming 0660
path-filter /usr/local/wu-ftpd-2.4.2-beta-11/messages/path-filter ^[-A-Za-z0-9._]*$ ^.^-
 
email [email-masked]

What am I doing wrong.

---

From: Andy Ellsworth <[email-masked]>
Date: Fri, 4 Oct 1996 14:40:24 -0500 (CDT)

On Fri, 4 Oct 1996, Steve Calia wrote:

> I have run chconfig and it says that my ftpaccess file is ok. However,
> although the daemon works, none of the conditions set in the ftpaccess
> are in effect. Here is the file.

[deletia]

> What am I doing wrong.

In your inetd.conf, call ftpd with a "-a" parameter.  This parameter has
to be present for the ftpd to read ftpaccess (kind of an odd default
behavior for it -not- to read ftpaccess, but oh well...)

+----------------------------------------------------------------------------+
| Andy Ellsworth  |  [email-masked] |  Admin/Cyberdiplomat, Wuarchive    |
+----------------------------------------------------------------------------+
|  "...The wind was not the beginning.  There are neither beginnings nor     |
| endings to the turning of the Wheel of Time.  But it was _a_ beginning..." |
|                                   --The Wheel of Time saga, Robert Jordan  |
+----------------------------------------------------------------------------+

---

From: [email-masked] (Jeffrey R. Tunison)
Date: Fri, 04 Oct 1996 15:32:36 -0500 (EDT)

This is a FAQ. You forgot to put a -a argument in the
/etc/inetd.conf file. As in

ftp  stream  tcp nowait root /usr/site/wu-ftpd/bin/in.ftpd in.ftpd -a
-- 
Jeffrey Tunison        	email: [email-masked]
Computer Sys Mgr	Dept of Physics & Astronomy
Bloomberg Center, Homewood Campus, Johns Hopkins Univ
3400 N. Charles St	Phone:  (410) 516-7392
Baltimore, MD 21218	FAX:    (410) 516-8260
	http://www.pha.jhu.edu/~tunison/

---

From: Brian Beaulieu <[email-masked]>
Date: Fri, 04 Oct 1996 15:47:49 -0400 (EDT)

> path-filter /usr/local/wu-ftpd-2.4.2-beta-11/messages/path-filter ^[-A-Za-z0-9._]*$ ^.^-

I'm not sure what OS you'r running but, did you run ftpd with a -a switch?
to enable the reading of ftpaccess.

Brian

==================================
CAPE Internet System Administrator
http://www.capecod.net
http://despair.capecod.net
[email-masked]
==================================

---

From: James Sneeringer <[email-masked]>
Date: Fri, 4 Oct 1996 16:54:18 -0500 (CDT)

| On Fri, 4 Oct 1996, Steve Calia wrote:
| >
| > path-filter /usr/local/wu-ftpd-2.4.2-beta-11/messages/path-filter
| >     ^[-A-Za-z0-9._]*$ ^. ^-

One other thing.  The man page for ftpaccess(5) recommends the above
filter.  Unfortunately, it will deny all upload attemts, as ^. will of
course match any string where the first character is anything at all :) 

Might want to change  ^. ^-  to  ^[-.].*$  or backquote it  ^\.

-James