Subject: Re: ftpcheck version 2 available

From: "Tim P. Starrin" <[email-masked]>
Date: Wed, 23 Oct 1996 12:05:26 -0400

On a similar note, does anybody have a set of canned tests for ftp that test 
data integrity, transfers, etc...?

Tim P. Starrin (CSC)
DMSS Project Technical Lead
Project Systems Analyst / Computer Scientist
National Aeronautics and Space Administration
Langley Research Center Operations

Address					Telephone/Email
-------					--------------
Computer Sciences Corporation	 	(804) 864-7373
3217 N. Armistead Ave.			(804) 864-7604 Fax
Hampton, VA 23666			[email-masked]

> From [email-masked] Wed Oct 23 11:17:12 1996
> Date: Wed, 23 Oct 1996 10:59:41 -0400
> From: "C. Paul Ferroni" <[email-masked]>
> To: [email-masked]
> Cc: "Ferroni, Paul" <[email-masked]>
> Subject: ftpcheck version 2 available
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> X-Sender: [email-masked]
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> Ftp users,
> 
> "ftpcheck" is a perl program to check an ftp site and report on file
> existence/usage on a customized, personal basis.  It is driven by
> lines in the ftpaccess file that begin with:  ##FTPCHECK
> 
> For those of you who downloaded my original version of ftpcheck (now
> called ftpcheck.v1), I've written a new/improved version: ftpcheck.v2
> that can be retrieved at:  ftp://ftp.cle.ab.com/pub/ftpcheck.v2
> 
> This version, apart from better code, expands the <options> you
> can use on the ##FTPCHECK line, including the ability to simply
> report on files, or only report on old files, and/or to delete
> old files automatically.  The delete and report file ages are
> independant. Below is the section that describes it's usage.  If you
> are interested, pick it up and give it a try.  I'll do my best to
> answer any question and will fix any bugs, but I can't offer
> official support, etc, etc.  Buyer beware.
> 
> ##################################################################
> ### SYNTAX
> #
> # Usage: ftpcheck [-d]
> #
> # Syntax of line in ftpaccess file:
> ##FTPCHECK    <options>    <address>    <directory>
> #
> # where:
> # <option> is comma seperated list of:
> #        SKP   : for SKIPPING this entry -- overrides other options.
> #        RPT   : generate a report if ANY files are found.  No report
> #                is sent to the user if this flag is not set.
> #        OLDxx : define an "old" file as one that is > xx days old.
> #                (defaults to 7).  Note that if OLD date is > DEL date, 
> #                then it's reset to the DEL date.  Also note that
> #                if RPT is not set, and OLD is set, a report is sent
> #                only if old (or deleted) files are found.
> #        DELxx : automatically deleting files that are > xx days old 
> #                (defaults to 14). If report is generated, indicate
> #                files that are deleted.
> #
> # <address> is email comma seperated list of address(es) of responsible 
> #   person(s)
> #
> # <directory> is directory UNDER $FtpRoot this user is responsible for.
> #
> # examples:
> ##FTPCHECK    OLD10,DEL30  [email-masked]    /incoming
> #   Send report if files > 10 days old. Also, delete (and report)
> #    anything > 30 days old.
> #
> ##FTPCHECK    RPT          [email-masked],[email-masked]    /foobar
> #   Send report daily, if any files exist.  Send to two email addresses.
> #
> ##FTPCHECK    SKP,RPT     [email-masked]            /other
> #   Skip this entry regardless of other options.
> #
> ##FTPCHECK    RPT,OLD,DEL21  [email-masked]    /incoming
> #   Send report every day (if any files), marking files > 7 (default) days 
> #   old as "OLD" and deleting files > 21 days old (and reporting this).
> #
> ##FTPCHECK    OLD21,DEL21  [email-masked]    /incoming
> #   Delete files > 21 days old, and send report of this.  Don't send
> #   a report otherwise.  Since OLD days == DEL days, this forces a
> #   report to be sent if old files found, but all "old" files are also deleted.
> ##################################################################
> 
> --
> C. Paul Ferroni          Phone: 216-646-4114 (voice)  216-646-3176 (fax)
> Systems Specialist           Admin areas: UNIX, WWW, Usenet News, etc.
> Allen-Bradley Company, Inc      Email: [email-masked]
>

---

From: John Andrea <[email-masked]>
Date: Wed, 23 Oct 1996 13:24:54 -0300 (ADT)

I'm trying to compile wu-ftpd-2.4.2-beta-11
on an aix 3.2.5.1 system and get lots of errors about missing libraries
and incompatible libraries (below sig)

anyone know if i need to apply a compiler ptf, or install a
programming package which i'm missing ?

thanks
__________________________________________________________________
John Andrea                         St. Francis Xavier Univ.
University Computer Services        Antigonish, NS, CANADA B2G 2W5
http://www.stfx.ca/~jandrea/

Processing include file /usr/include/netdb.h
    1501-106: (S) Include file sys/bitypes.h not found.
Processing include file /usr/include/netdb.h
    1501-106: (S) Include file sys/cdefs.h not found.
"/usr/include/netdb.h", line 130.7: 1506-095 (S) Unexpected parameter endhostent.
"/usr/include/netdb.h", line 130.18: 1506-046 (S) Syntax error.
...

Processing include file /usr/include/arpa/inet.h
    1501-106: (S) Include file sys/bitypes.h not found.
Processing include file /usr/include/arpa/inet.h
    1501-106: (S) Include file sys/cdefs.h not found.
"/usr/include/arpa/inet.h", line 74.1: 1506-046 (S) Syntax error.
"/usr/include/arpa/inet.h", line 74.0: 1506-166 (S) Definition of function __END_DECLS requires parentheses.
"authuser.c", line 20.12: 1506-095 (S) Unexpected parameter errno.
"./authuser.h", line 5.23: 1506-095 (S) Unexpected parameter auth_tcpport.
"./authuser.h", line 14.14: 1506-095 (S) Unexpected parameter auth_xline.
...

"/usr/include/sys/errno.h", line 46.12: 1506-095 (S) Unexpected parameter errno.

"/usr/include/errno.h", line 18.12: 1506-030 (S) Identifier errno cannot be redeclared.

"/usr/include/string.h", line 77.26: 1506-095 (S) Unexpected parameter memchr.
"/usr/include/string.h", line 78.26: 1506-095 (S) Unexpected parameter memcpy.
...

"/usr/include/time.h", line 98.20: 1506-095 (S) Unexpected parameter strftime.
"/usr/include/time.h", line 99.21: 1506-095 (S) Unexpected parameter clock.
...

"/usr/include/sys/dir.h", line 90.3: 1506-095 (S) Unexpected parameter DIR.
"/usr/include/sys/dir.h", line 104.9: 1506-030 (S) Identifier DIR cannot be redeclared.
...

---

From: [email-masked] (Jay Schuster)
Date: Wed, 23 Oct 1996 13:39:51 -0400 (EDT)

> and incompatible libraries (below sig)

It compiled just fine here after I made a minor change given by the README
(using the support/arpa.h file instead of the one in /usr/include).  See
http://www.pcc.com/%7Ejay/src/networking/wu-ftpd-2.4/ORIGINALS/ for more
information.

-- Jay
-- 
Jay Schuster <[email-masked]>
The People's Computer Company	`Revolutionary Programming'