Subject: Problem anonymous ftp

From: "Paul Taylor" <[email-masked]>
Date: Thu, 24 Oct 1996 16:28:08 +0000

Hi All

I have a problem in that a site can not login anonymously log as 
follows :-

> ftp open ftp.microside.com
> Connected to microside.com.
> 220 FTP server (Version wu-2.4.2 (1) Wed Aug 14 16:49:24 GMT+0100
> 1996) ready. 
> User (microside.com:(none)): anonymous 
> 331 Guest login ok, send your complete e-mail address as password. 
> Password:
> Connection closed by remote host. 
> ftp>

I can login here without problems, and I have also tried it from 
another site on the net ok.

It is just one site that this happens with, any ideas ? There is 
nothing in the access file to stop any sites.

Thanks
Paul
________________________________________________________
N e t C u l t u r e   -  Web Hosting
Web: www.NetCulture.net  -  Email: [email-masked]
Tel: +33 1 45 22 00 02   -  Fax: +33 1 45 22 00 52
1 rue Lemercier, 75017 Paris, France

---

From: "Paul Taylor" <[email-masked]>
Date: Thu, 24 Oct 1996 18:47:35 +0000

Hi Anthony

> You say it's just one machine that you can't connect from ?
> Is that machine covered by a deny command in ftpaccess ?
> Sometimed there's a line about "deny !nameserverd..." which rejects from
> hosts for which it can't resolv a valid name/i.p. address.
> Is it mentioned in a file called ftphosts ? ( normally wherever ftpaccess is ) 
> Mind you, if either of these was the problem it should get logged to
> the logs. Maybe you're not getting a detailed enough log file.
> Check what switches are used when ftpd starts up and what they mean.

There is no deny message in the ftpaccess file or any other. The ftpd 
is kicked off by inetd with simply a '-a' for the config files.

This is wierd, problem is it is new client and he ain't too 
impressed. Can you try and login from there, the account is 
ftp.microside.com ?

Thanks in advance.
Paul

---

From: [email-masked] (Miquel Cabanas. BBM-UAB)
Date: Thu, 24 Oct 1996 21:54:55 +0200

hi Paul,

> is kicked off by inetd with simply a '-a' for the config files.

start it with '-dl' so that it logs all debugging information and
transfer sessions as well.

since they are logged through syslog you'll have to hack the syslog.conf
file (ie /etc/syslog.conf) to instruct the syslogd to log whatever ftpd
says. If using Solaris or similar, append the following lines (if not
already present) to syslog.conf

  #
  # 07/03/95  Miquel E Cabanas
  # after Sun Managers FAQ - enable syslogd for ftpd
  #
  daemon.info	/var/adm/syslog

> impressed. Can you try and login from there, the account is 

this is what i got,

  > ftp -d ftp.microside.com
  Connected to microside.com.
  220 FTP server (Version wu-2.4.2 (1) Thu Oct 24 20:01:12 GMT+0100 1996) ready.
  Name (ftp.microside.com:miquel): anonymous
  ---> USER anonymous
  331 Guest login ok, send your complete e-mail address as password.
  Password:
  ---> PASS anon@@@@@@
  230-The response 'anon@@@@@@' is not valid
  230-Next time please use your e-mail address as your password
  230-        for example: [email-masked]
  421 Service not available, remote server has closed connection
  Login failed.
  ftp> open ftp.microside.com
  Connected to microside.com.
  220 FTP server (Version wu-2.4.2 (1) Thu Oct 24 20:01:12 GMT+0100 1996) ready.
  Name (ftp.microside.com:miquel): anonymous
  ---> USER anonymous
  331 Guest login ok, send your complete e-mail address as password.
  Password:
  ---> PASS miquel
  230-The response 'miquel' is not valid
  230-Next time please use your e-mail address as your password
  230-        for example: [email-masked]
  421 Service not available, remote server has closed connection
  Login failed.
  ftp> quit

that is,
  the anonymous ftp user is defined, that the password is checked but
  not enforced, and by some reason the ftp server closes the connection

  i've tried to reproduce the problem but keep getting different types
  of errors. Never this one.

miquel

Miquel E Cabanas ---------------------------------------------------
SeRMN & BBM - Universitat Autonoma de Barcelona, Catalunya - Spain

e-mail: [email-masked]
url:    http://bbm-web.uab.es/biomed-nmr/miquel_angles.html
------------------------------------------o-oo--ooo---ooo--oo-o-----