Subject: Instead of Virtual by IP, chroot per user

From: "James L. McGill" <[email-masked]>
Date: Thu, 31 Oct 1996 18:03:00 -0600 (CST)

I have tried and failed to get the Beta-11
to do what I want - I am not convinced that 
the virtual-by-IP is what I want to do anyhow.

I would like to simply have the FTP server
make it impossible for a user to change above
his home directory.  That is, the user
(Not a 'guest' or an 'anonymous' user) is
authenticated, and the server changes to that
dir, and then chroots it.  

Is this not possible?

--
g-r-a-t-e-f-u-l-l-y---[   email:<[email-masked]>   ]---l-i-v-i-n-g
d-e-a-d-i-c-a-t-e-d---[ http://www.conservatory.com/~fishbowl ]-----l-i-g-h-t

---

From: Bob Myers <[email-masked]>
Date: Thu, 31 Oct 1996 15:23:25 -0800

> dir, and then chroots it.

That's exactly what a guest user *is*.

Why don't you want to use a guest user?

---

From: Michael Brennen <[email-masked]>
Date: Thu, 31 Oct 1996 17:46:29 -0600 (CST)

> dir, and then chroots it.  

You just precisely described guest ftp.  Guest and anonymous ftp are not
the same thing.  Guest ftp chroots the user in their home directory.

To find out how to set it up, get the guest howto below and follow it
carefully.

   -- Michael

This is the location for the latest wu-ftpd.  You can't see the
directory contents, but get the file anyway.  It's there.

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-11.tar.Z

WU-FTPD FAQ:  http://www.hvu.nl/~koos/wu-ftpd-faq.html

guest howto:  ftp://ftp.fni.com/pub/wu-ftpd/guest-howto

There are additional security references in the above docs.