Subject: Setting up a restricted directory??

From: [email-masked]
Date: Thu, 12 Sep 1996 20:44:57 +0000 (GMT)

I'm a fairly new wu-ftpd user and I'm having a problem setting up a particular 
restricted area.  I would appreciate some suggestions.

I need to set up a subdirectory in my /usr/ftp/area which will allow local 'gps' 
group members to insert data into the directory, but only allow noaa employees to 
retrieve the data.

Let me explain what I have so far:

-In the ftpaccess file, I added the following:
 
       class noaa      anonymous       *.noaa.gov
 
       autogroup       noaa    noaa

-I added the following to my /etc/group 
 
 gps:*:700:gps
 noaa:*:999:gps

-I created the following directory:
 
 drwxrwx--x   gps    noaa         /usr/ftp/pub/gps/pub/30min
 I also tried the following
	drwxrwx---   gps    noaa  /usr/ftp/pub/gps/pub/30min

-I created the following test file in 30min:

 -rw-r-----  1 gps    noaa     test.files

With the above settings, nobody can see or retrieve the file.  My question is, 
why don't the group permissions apply (which should allow noaa people to 
retrieve this file)?  If I modify the file to -rw-r--r-- then everyone can 
retrieve it.  What am I missing?  

Thanks for your help. 

If you want to try the annonymous ftp account:
spruce.fsl.noaa.gov 

------------------------------------------------------------------------------
Jil Godesiabois				Systems Administrator			
NOAA/ERL/FSL/DD				[email-masked]
R/E/FS3
325 Broadway				Phone:  303-497-5635
Boulder, CO 80303			FAX:	303-497-6014

---

From: Michael Brennen <[email-masked]>
Date: Fri, 13 Sep 1996 10:21:49 -0500 (CDT)

On Thu, 12 Sep 1996 [email-masked] wrote:

> I need to set up a subdirectory in my /usr/ftp/area which will allow
> local 'gps' group members to insert data into the directory, but only
> allow noaa employees to retrieve the data. 
> ....

I think the information is incomplete.  Do the gps members log in from
noaa.gov also?  There needs to be a way to distinguish gps members from
noaa members, and I'm not seeing how that is done in your example.  Looks
to me like everyone gets noaa group status and you can't tell gps from
noah members.

Below is probably incomplete, but it is a sketch of what I would lay out
off the top of my head. 

In ftpaccess:

class noaa      anonymous       *.noaa.gov
autogroup       noaa            noah
...
class gps       anonymous       ?????
autogroup       gps             gps
...
upload  /usr/ftp  /pub/gps/pub/30min   yes   root  noah  0440 nodirs

Directory ownership/permissions:

drwxrwxr-x   root    gps         /usr/ftp/pub/gps/pub/30min

   -- Michael