Subject: Help!:List command not work

From: Ilya Moiseev <[email-masked]>
Date: Wed, 25 Sep 1996 14:43:39 +0400

List command not work for guest users, no problems with real users

Configuration:
System - SunOS 4.1.4
wu-ftpd v.2.4.2b11

Ftp dir tree:
/ftp - root dir for guest users
	/etc - contain passwd and group files (not system)
	/bin - contain ls (gnu ls from GNU fileutils 3.13)
	/dev - contains: tcp (crw-r--r--), zero (crw-rw-rw)
	/users/ftptest - home dir for ftp test user

Real passwd entry looks like:
ftptest:PASS:300:300:ftp test:/ftp/./users/ftptest:/usr/local/bin/ftponly

300 is a test group id

ftpacces (guest settings):
class users guest
guestgroup test

Problem: no file list then dir command (without errors), then 'm try QUOTE
LIST i'm see this error:
425 Can't build data connection: Connection refused.
ftp_cmd/ftp_user: -30000

Anyone can help me?

Ilya Moiseev

[email-masked]
[email-masked]

---

From: Alain Magloire <[email-masked]>
Date: Wed, 25 Sep 1996 11:02:24 -0400 (EDT)

> 	/users/ftptest - home dir for ftp test user

First impressions:
1-
 Where is /lib/* in Ftp dir tree ?
 if they are missing is it because everything in
   /bin/* is statically link ??
 else
   well you need them
   use ldd to figure out wath you need

2-
  Jut a comment, you say System --> SunOS 4.1.4
  then there is no need for /dev/tcp.
  It is needed for SunOS 5.x because the socket
  implementation is base on STREAMS

3-

  just in case you're using SunOS-5.x

  /dev/tcp has to be (crw-rw-rw-) 666 not (crw-r--r--)

  if the permission is not correct you will have those
  nasty
  "420 Can't ..."

4-
  You're not running this setup in binary compatibilty mode aren't you ?
  (I'm saying this because of /dev/tcp)

5-
  test the ls on the command line

  chroot /ftp bin/ls users

  see the errors

6-
  ....
  Sorry that's all ;-) 

7-
  good luck

--
alain

---

From: Ilya Moiseev <[email-masked]>
Date: Wed, 25 Sep 1996 19:58:49 +0400

Thanks for answer.

>   use ldd to figure out wath you need
lib in ~ftp/usr/lib

hmm, yep.. gnu ls not static, but i'm have libs in ~ftp/usr/lib what ls
needed. i'm replace gnu ls with standart ls and test it by chroot - and it
works (chroot /ftp /bin/ls)

>  implementation is base on STREAMS
I'm read in some FAQ what zero and tcp needs for SunOS 4.1 too

>  if the permission is not correct you will have those
OK, i'm change permissions - LIST still not work :(

>  (I'm saying this because of /dev/tcp)
No, list in ascii mode

>  test the ls on the command line
Heh, no any errors!

>  good luck

Thanks.

Still need help.. :(

Ilya Moiseev

[email-masked]

---

From: Ilya Moiseev <[email-masked]>
Date: Wed, 25 Sep 1996 20:07:25 +0400

>   use ldd to figure out wath you need
.....................

Thanks Alan! I'm recompile gnu fileutils with static option, then it works.
Thanks!

Ilya Moiseev

[email-masked]