Subject: Re: WU-FTP on OSF1

From: [email-masked] (Dr.R.Dassing, IfAG-Wettzell)
Date: Tue, 17 Sep 1996 15:23:54 GMT

>
>> 
>> OS: Dec-Unix V3.2D (formerly OSF/1)
>> WU-FTP: V2.4
>> 
>> The problem arises for "on the fly" actions by using the information in file
>> "ftpconversions".
>..
>[deleted]
>...
>> BUT, TAR+gzip or TAR+Compress does NOT work.
>> 
>> Can anybody give me an hint to solve my problem.
>> 
>
>send the ftpconversions file, so folks could take look,
>maybe it's not set/place right.
>
>--
>alain

Here is ftpconversions:
 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

I used the default one

Reiner

---

From: Alain Magloire <[email-masked]>
Date: Tue, 17 Sep 1996 13:08:50 -0400 (EDT)

...
[deleted]
...
>  :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

when you invoke tar(GNU tar) with the options -z or -Z
it will execpl() the gzip(for -z) or compress(for -Z)
and the paths are the ones it found at compile time
maybe something like "/usr/local/gnu/bin/gzip"

you should have something like :
 :   : :.tar.Z:/bin/tar -c --use-compress-program=/bin/compress -f - %s:T_REG|TDIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c --use-compress-program=/bin/gzip -f - %s:T_REG|T_DI:O_COMPRESS|O_TAR:TAR+GZIP

the --use-compress-program will indicate the right paths

Warning: Of course these only will work for anonymous ftp
because of the chroot i.e. tar will be able to find a /bin/gzip

But for real users WITHOUT the chroot("/home/ftp"), ...
I doubt you have under /bin (realpath) Gnu Tar and gzip.

If you want to make work for real and anonymous

1-
Take a look at Koos's wu-ftpd FAQ, he explains how to set up a pipe
to alleviate this problems and use plain tar.

2-
recreate the hierachie under /home/ftp
i.e
/home/ftp/usr/local/gnu/bin/{gzip,tar}
with the necessary libs if no statically link

3-
do nothing ;-)
one type, real or anonymous depending on ftpconversions, will not be able to do

get dir.tar.gz

bye
--
alain