Subject: WU-FTP

From: Thomas von Stetten <[email-masked]>
Date: Mon, 2 Sep 1996 01:02:30 +0200 (MET DST)

Hello,

this ist a mail from Germany (excuse the bad english).

I am a internet-provider and on one pc wu-ftp ist running with virtual hosts.
When I log in my own (no virtual) ftp it works with ftp and 
anoymous. But when I log in a virtual host as ftp, ls dosn't work and 
other problems. Login with a special username (home-dir is the root of 
the virtual-host and shell is /bin/false), then ls works, but I can change 
with cd the diretory to the root. But I don't want somebody working with total
access to my server.

I hope you will help me...

Thanks
Thomas, <Aragon-Software>

[email-masked]

---

From: Alain Magloire <[email-masked]>
Date: Mon, 2 Sep 1996 20:03:19 -0400 (EDT)

> with cd the diretory to the root. But I don't want somebody working with total

Maybe a little more info !! (like the version of wu-ftpd, OS, ...)

>From a first diagnostic, I'd say you don't have
a correct directory structure.

Doing virtual also means that ftpd will do the chroot() in
different places. So you must provide a full directory structure
with binaries for each virtual home.
meaning you gotta have:

etc/passwd
bin/ls
usr/lib/*
dev/*
....
....

> I hope you will help me...

I really hope so too 8)

--
alain