Subject: question regarding upload

From: [email-masked] (Thierry Frati)
Date: Wed, 25 Sep 96 16:50:22 +0200

Hello,

I installed wuftp 2.4 on a Sun running Solaris 2.3.  I am trying to use the
upload feature of ftpaccess to set the owner and group of the files
being uploaded.  The problem I am having is that the files or directory 
are created with wrong permissions.

Extract from my ftpaccess :

upload /export/home/users/ftp	*	no
upload /export/home/users/ftp   /       no
upload /export/home/users/ftp   /sqm_gst   yes	sqm_out	staff 0400
upload /export/home/users/ftp	/sqm_out   yes	sqm_out	staff 0400 dirs
upload /export/home/users/ftp   /bin       no
upload /export/home/users/ftp   /dev       no
upload /export/home/users/ftp   /etc       no
upload /export/home/users/ftp   /usr       no

ftp ftp

ftp> pwd
257 "/export/home/users/ftp/sqm_out" is current directory.
ftp> mkdir titi
257 MKD command successful.
ftp> ls -l 
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
drwxrwxr-x   2 sqm_out  staff        512 Sep 25 16:44 titi
226 Transfer complete.
ftp> put /etc/passwd ./passwd
200 PORT command successful.
150 Opening ASCII mode data connection for ./passwd.
226 Transfer complete.
local: /etc/passwd remote: passwd
502 bytes sent in 0.004 seconds (1.2e+02 Kbytes/s)
ftp> ls -la
-rw-rw-r--   1 sqm_out  staff        488 Sep 25 16:47 passwd

Am I doing something invalid? 

HELP!

Thierry

---

From: Alain Magloire <[email-masked]>
Date: Wed, 25 Sep 1996 11:51:34 -0400 (EDT)

> upload /export/home/users/ftp   /usr       no

from koos's FAQ

        7. The default umask used when a real user uploads a file is  
            wrong

            The default umask is inherited from inetd. This can be a
            wrong one. There is an undocumented command line parameter
            -u. Edit the line in inetd.conf to something like ftpd -A
            -L -l -u077.

hope it helps

--
alain