Subject: Re: hanging FTP connections and ftpwho output (wu-ftpd 2.4)

From: "Christopher M. Lee" <[email-masked]>
Date: Tue, 03 Sep 1996 16:04:30 -0700

At 07:27 PM 9/3/96 +0200, you wrote:
>On Tue, 3 Sep 1996, Gildas Perrot wrote:
>
>> 1) We saw on HP/UX 9 and HP/UX 10 the following problem. Some FTP
connections 
>> were not closed even if not used (0 in the 1st column of ftpwho output
instead 
>> of 1).
>> Is there any patch to solve this problem ? For the moment, we use a perl 
>> script to kill those connections. 
>This looks like the passive mode hanging - if a connection is made, but 
>dies before the "select", then the process waits.
>
>There is a patch to cure this, although I don't know where ... If you're 
>really stuck, I'll diff my src from the original
>

I wrote a perl script to kill the hung ones, but if there is a patch I would
like to know about it.

-chrisl

---

From: Alain Magloire <[email-masked]>
Date: Tue, 3 Sep 1996 19:48:58 -0400 (EDT)

>From the Koos wu-ftpd FAQ
------------------------------------------------------
 1. Where do I get the updated version ?
         
            The above is the last version created by wuarchive. On the
            mailing list, an updated version has been created which is
            maintained by Stan Barber ([email-masked]).
    
            You can get this beta by ftp from the directory :
              
            ftp://ftp.academ.com/pub/wu-ftpd/private/ the directory is
            not browsable, a .message file will point you to what is the
            latest version. Read this .message.
            
            Remember, these are BETA versions. Before asking/trying
            anything, check first that you have the latest version. And
            if you run this version, keep up with the list to make sure
            you get news of updates.
------------------------------------------------------
ftp ftp.academ.com
ftp>cd pub/wu-ftpd/private
ftp> get .message -
200 PORT command successful.
150 Opening ASCII mode data connection for .message (333 bytes).
This directory contains the latest beta (if one exists) for the
Washington University at Saint Louis FTP daemon for Unix systems with 
bug fixes and enhancements added by Academ Consulting Services.

This directory is protected. The name of the current beta is
wu-ftpd-2.4.2-beta-11.tar.Z and this file must be downloaded in binary.
226 Transfer complete.
remote: .message
339 bytes received in 0.0088 seconds (37 Kbytes/s)
ftp> quit
221 Goodbye.
------------------------------------------------------

beside patches for
- a more secure PORT command
- virtual ftp
- .....
- .....

there is also one for the passive mode. see FIXES-2.4*

hope it helps
--
alain