Subject: compiling wu-ftpd under linux

From: Matthew Whitworth <[email-masked]>
Date: Mon, 23 Sep 1996 13:02:29 -0400 (EDT)

I inherited a linux server from a friend of mine at work that runs 
wu-ftpd.  Anonymous ftp works fine, but I can't get it to allow "real" 
users to save my life.  Since I never seemed to get anywhere 
troubleshooting this problem, I decided to recompile wu-ftpd.

I downloaded wu-ftpd-2.4, edited pathnames.h, confirmed the existence of 
/etc/shells, ran 'build lnx' and got zero.  Here's what it looked like:

----- snip! -----

bash# build lnx
make args are : 
make opts are : 

Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
Makefile:13: *** missing separator.  Stop.

Making ftpd.
make: *** No rule to make target `ftpd'.  Stop.

Making ftpcount.
make: *** No rule to make target `ftpcount'.  Stop.

Making ftpshut.
make: *** No rule to make target `ftpshut'.  Stop.

Making ckconfig.
make: *** No rule to make target `ckconfig'.  Stop.

Links to executables are in bin directory:
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory
size: bin/ckconfig: No such file or directory
Done

----- snip! -----

This may be more of a 'make' question than a 'wu-ftpd' one, but if anyone 
could help me out I'd *really* appreciate it.

Thanks,

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
matthew whitworth  [email-masked]
um itd  computer systems consultant
http://roy.path.med.umich.edu/~whit

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Mon, 23 Sep 1996 20:23:35 +0200 (MET DST)

> Makefile:13: *** missing separator.  Stop.

You need to get a newer version (from ftp.academ.com). This bug in the
Linux makefiles was fixed some beta-versions ago.

This will also fix other bugs that where in the source codes.

                                               Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Quando Omni Flunkis Moritati (If all else fails - play dead)     KH106-RIPE