Subject: Re: your mail

From: [email-masked] (Wen Wen Chang)
Date: Fri, 13 Sep 96 18:24:39 PDT

Hi, All

HELP!!

I always got login failed for guest user ftp on my SunOS but if i 
give it a shell instead /bin/false then it will be OK but i 
don't want to give shell. Everytheing else work fine with ftpaccess setup.

/etc/passwd
	wen:x:10001:500:guest ftp:/export/./wen:/bin/false

/etc/group
	guests::500:wen

ftpaccess
	guestgroup guests

# ftp ftp-serv
Connected to ftp-serv.
220 ram FTP server (Version wu-2.4(4) Thu Sep 5 10:31:18 PDT 1996) ready.
Name (fbi:wen): wen
530 User wen access denied...
Login failed.

All other function in ftpaccess works fine(log, upload, banner, message etc)
so i'm sure ftpd can read ftpaccess.

I'd read "Managing Internet Information Service" from O'Reilly and
i don't know where did i go wrong.

---

From: Samer Safi <[email-masked]>
Date: Sat, 14 Sep 1996 01:03:30 -0400 (EDT)

Sorry to bother the list, but can any of you please tell me what is the
wu-ftpd listserv address so I can unsubscribe.  For the first time I did
not save the original message from the listserv.

Thank you

Sam

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Samer M. Safi                 |       SIMPLY WEB INC.
8372 Barrington Drive         | Advertising      Virtual Trader
Ypsilanti, MI 48198-9446      | Consultation     Virtual Mall
                              | HTML Authoring   Hot List
E-Mail: [email-masked]    | Doc Conversion   Server Setup
Voice/Fax (313) 480-3088      | URL: http://www.simplyweb.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Sat, 14 Sep 1996 11:57:19 +0200 (MET DST)

> don't want to give shell. Everytheing else work fine with ftpaccess setup.

Give it a shell of /bin/ftponly and add the name /bin/ftponly to /etc/shells.
This will make ftpd, sendmail and maybe others recognize it as a valid shell.

Make a /bin/ftponly that is a copy of /bin/false.

Warning (also to others) : since /bin/ftponly IS a valid shell for sendmail,
people WILL be able to perform commands on the machine if they know how to
deal with .forward, procmail/filter or other programs which can execute
filters based on mail content.

Solution : divert mail for guest users from the aliases file or delivery
database before local delivery is attempted.

                                      Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Quando Omni Flunkis Moritati (If all else fails - play dead)     KH106-RIPE

---

From: [email-masked]
Date: Sat, 14 Sep 1996 15:55:15 +0200 (MET DST)

> 	wen:x:10001:500:guest ftp:/export/./wen:/bin/false

Is /bin/false declared as a valid shell ?
(Must be in /etc/shells under SunOS).

Regards.

-- 
-- David Ponzone - ISDnet - Network Administrator --
   Work: +33 1 34 65 78 86  Pager: 06 41 82 45
   Cell: 02 61 21 63        Email: [email-masked]