Subject: Newbie Question...

From: Eric Hake <[email-masked]>
Date: Tue, 03 Sep 1996 16:27:10 -0700

Greetings!

I checked the FAQ, and was unable to answer my questions there...

Here goes:
----------
I want to be able to provide multiple users access to a single ftp server,
and allow each one private directories, so users of one domain can't cross
the border and get into another domain's space (without loggin on under the
other domain :)

In other words:

     FTP.SERVER.COM  is to provide services to:

        ftp.domain1.com   
        ftp.domain2.net
        ftp.domain3.com
        ftp.domain4.org

I want each of these to come up with their own virtual root system, such as:

       ftp.domain1.com/myfiles
       ftp.domain2.net/netfiles

as opposed to the traditional:

       ftp.domain1.com/pub/domain1.com/pub/myfiles

I would like these to be separate, so that when I log into an ftp site, it
shows me the directory "pub, usr, myfiles" that are unique to that domain's
site...

Is there any way to do this with WU-FTPD?

Thanks!
 Eric

---

From: [email-masked] (Alvin Oga)
Date: Tue, 3 Sep 1996 16:46:06 -0700 (PDT)

Hi Eric

I have exactly the same question...
Please see my previous two newsgroup postings...
in ucb.os.linux   and  comp.unix.admin + a couple other assorted newsgroups

I have some detailed info of where to find stuff and what a quick
description of my problem
( I'm attempting to patch either versions of wu-ftpd )
	( wu-ftpd-2.4-fixed  or wu-ftpd-2.4.2-beta-11 )

my problem is extracting the "virtual ftp domain names" from inside 
wu-ftpd.../src/ftpd.c

thanx
alvin