Subject: Re: Bug in mkdir handling (wu-ftpd 2.4.2-academ[beta-11])

From: Craig Stratton <[email-masked]>
Date: Mon, 30 Sep 1996 08:39:39 +0100 (BST)

On Fri, 27 Sep 1996 23:02:35 +0200 (MET DST) Perry Rovers <[email-masked]> 
wrote:

> On Thu, 26 Sep 1996, Bob Myers wrote:
> 
> > Mkdir handling is wrong on wu-2.4.2-academ[BETA-11] - if there is any
> > "upload" configuration entry with "nodirs" on it, no subdirectories
> > can be created at all in any location.  No check to see if the upload
> > command matches the current directory is made.
> I can't seem to reproduce this on FreeBSD 2.1.5 with beta-11 or on Linux
> RedHat 3.0.3 with beta-9.
> The following is a part of one of my ftpaccess files:
> 
> # uploads to incoming only, ownership of files will be root.daemon, 
> # permisssions will be 0400 and no directory creation is allowed
> upload /home/ftp * no
> upload /home/ftp incoming yes root daemon 0400 nodirs
> 
> With this I'm unable to create dirs in /home/ftp as user ftp, but
> I can create dirs as a 'real' user somewhere else. Is that behavior 
> impossible with your configuration?
> 

I'm using FreeBSD 2.1.5 with beta 11 and i do get the problem.
While i only had entries in ftpaccess to allow directories, it 
worked, but as soon as i put a nodirs entry in, nobody could create 
directories.
Have tried putting all dirs entries first and nodirs second and vice 
versa with no luck. As soon as there is a nodirs flag in the file, no 
one can create directories. Still looking for a workaround ...

Regards, Craig Stratton, NetTec plc.

---

From: Perry Rovers <[email-masked]>
Date: Mon, 30 Sep 1996 17:16:16 +0200 (MET DST)

> one can create directories. Still looking for a workaround ...

I've been experimenting a bit.. six cases with different ftpaccess files. 
This is on FreeBSD 2.1.5 with wu-ftpd-2.4.2-beta-11.
I tried creating directories and uploading files as a 'real' user to a 
homedirectory and creating directories and uploading files as an anon user
in an incoming directory in ~ftp
Take your pick:

Case 1:
upload /home/ftp * no
upload /home/ftp incoming yes root daemon 0400 dirs

Real users can upload and create directories
Anon users cannot upload but can create directories (but not delete them)

Case 2:
upload /home/ftp * no

Real users can upload and create directories
Anon users cannot upload and cannot create directories

Case 3:
upload /home/ftp incoming yes root daemon 0400 dirs

Real users can upload and create directories
Anon users can upload and create directories

Case 4:

Real users can upload and cannot create directories
Anon users can upload and cannot create directories

Case 5:
no upload lines

Real users can upload and create directories
Anon users can upload and create directories

Case 6:
/home/ftp * no
/home/ftp /incoming yes root daemon 0400 nodirs

Real users can upload and create directories
Anon users can upload and cannot create directories

In your case, I guess you want Case 6. The / before incoming makes the 
difference.

Perry Rovers, Amsterdam (and a number of other places), The Netherlands
Mail: mailto:[email-masked]       | Amsterdam is zo'n gezellige stad
FTP : ftp://ftp.iaehv.nl/pub/users/perry | omdat er zo verdomd veel
WWW : http://www.iaehv.nl/users/perry    | Brabanders wonen - Hans van Mierlo

---

From: Lael Tucker <[email-masked]>
Date: Mon, 30 Sep 1996 16:08:27 -0700 (EDT)

I can't get wu-ftp (non-beta) version to compile under IRIX 6.2.
I have several questions:

- Is there a wu-ftp FAQ somewhere that isn't out of date?  The one I
found on yahoo claims that the newest wu-ftp is available on wuarchive,
but I can't find it there.
- Where can I find the newest wu-ftp (beta)
- Anyone get wu-ftp to compile under 6.2?

Thanks in advance.