Subject: Problem on Sol2.5 with C4.0

From: [email-masked] (Ruediger Schwarz)
Date: Tue, 10 Sep 1996 20:53:08 +0200

Hi everybody, Hi Andrew,

Andrew wrote:
> I have SPARC 20 Solaris 2.5 and C 3.01.  Mine compiles perfect right out
> of the box.  build sol

Well, I just upgraded to Sol2.5 and installed C two days ago,
so one could think of a damaged/unsuccessful installation.

But I just went through a complete perl5 compilation,
so I expect all components to work fine.

I will clip a log from a compilation of wu-ftpd2.4 at the end of
this mail.

Thanx for any hint on my problem - Ruediger Schwarz

-- 
Ruediger Schwarz               [email-masked]
system administrator at the library of veterinary medicine at the
Free University of Berlin/Germany   Koserstrasse 20, 14195 Berlin
Phone: +49 30 838 3512                       Fax: +49 30 838 3112

$ build clean
make args are : 
make opts are : 
Cleaning root directory.
Cleaning support directory.
rm -f *.o libsupport.a
Cleaning src directory.
rm -f ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o authenticate.o conversions.o hostacc.o ftpd ftpcmd.c ftpshut ftpshut.o ftpcount ftpcount.o
rm -f core index index.o ckconfig ckconfig.o
Cleaning bin directory.
$ build sol
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
cc -g -DDEBUG   -c fnmatch.c
cc -g -DDEBUG   -c strcasestr.c
"strcasestr.c", line 34: warning: const is a keyword in ANSI C
"strcasestr.c", line 34: syntax error before or at: char
"strcasestr.c", line 34: warning: undefined or missing type for: char
"strcasestr.c", line 34: parameter redeclared: const
"strcasestr.c", line 34: warning: undefined or missing type for: char
"strcasestr.c", line 40: undefined symbol: find
"strcasestr.c", line 40: cannot dereference non-pointer type
"strcasestr.c", line 44: undefined symbol: s
"strcasestr.c", line 44: cannot dereference non-pointer type
"strcasestr.c", line 47: undefined symbol: s
"strcasestr.c", line 50: undefined symbol: s
*** Error code 2
make: Fatal error: Command failed for target `strcasestr.o'

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
"/usr/ucbinclude/sys/file.h", line 119: macro L_INCR redefines previous macro at "./config.h", line 15
yacc  ftpcmd.y
mv y.tab.c ftpcmd.c
cc -g -DDEBUG -I.. -I../support -L../support  -c  ftpcmd.c
"ftpcmd.y", line 578: syntax error before or at: )
"/usr/ccs/bin/yaccpar", line 534: cannot recover from previous errors
*** Error code 10
make: Fatal error: Command failed for target `ftpcmd.o'

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport -lsocket -lnsl -lgen 
"/usr/ucbinclude/sys/file.h", line 119: macro L_INCR redefines previous macro at "./config.h", line 15
ld: fatal: file vers.o: cannot open file; errno=2
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors.  No output written to ftpcount
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport -lsocket -lnsl -lgen
"/usr/ucbinclude/sys/file.h", line 119: macro L_INCR redefines previous macro at "./config.h", line 15
ld: fatal: file vers.o: cannot open file; errno=2
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors.  No output written to ftpshut
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
cc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 3656 + 1809 + 327 = 5792
Done

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Tue, 10 Sep 1996 22:06:16 +0200 (MET DST)

> so one could think of a damaged/unsuccessful installation.

installed C two days ago rings a bell :

check if you're using /usr/ccs/bin/cc and NOT /usr/ucb/cc.

The ucb version will definately give problems with the running wu-ftpd.
Maybe in this version it even breaks compiling.

                                                    Grtx KH

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Quando Omni Flunkis Moritati (If all else fails - play dead)     KH106-RIPE

---

From: Carlos Lazcano-Vega <[email-masked]>
Date: Tue, 10 Sep 1996 16:58:32 -0500 ()

Hi:

Some one told me about a feature in WU-FTPD that I haven't been able to
find, this guy told me that with WU-FTPD was possible to create virtual
users, besides growing in me the question, he wasn't able to explain,
but he said it worked something like:
  a. You log into the server as an anonymous user
  b. You authenticate as a diferent user

The nice feature about it, is that the user doesn't have to real, is
virtual to the WU-FTPD server.

Can anyone help me to find out if this is true?

Thankx a lot!

---
Carlos Lazcano-Vega                 Voice: (52-8) 358-2000 x4084
Internet Services Manager           Fax: (52-8) 328-4129
ITESM / Technological Computing     Email: [email-masked]
Av. Eugenio Garza Sada 2501 Sur     http://homepages.mty.itesm.mx/~clazcano/
Sucursal de Correos "J"
Monterrey, N.L, Mexico. CP 64849    Heroes get remembered; legends never died

            *** All my opinions are not really opinions ***