Subject: Re: static binaries

From: Serge Bezzubov <[email-masked]>
Date: Sat, 7 Sep 1996 21:53:00 +0400 (MSD)

> From [email-masked] Wed Aug 28 00:36 MSD 1996
> Date: Tue, 27 Aug 1996 16:28:58 -0400
> From: Luc Desrosiers <[email-masked]>
> To: [email-masked]
> Subject: Re: static binaries 
> Mime-Version: 1.0
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> > I am trying to fix a static ls but got some problems
> > I link with:
> > gcc -static -o ls -s ls.o ls-ls.o ../lib/libfu.a -lintl -lgen
> > but gets:
> > Undefined                       first referenced
> >  symbol                             in file
> > dlclose                             /usr/lib/libc.a(nss_deffinder.o)
> > dlsym                               /usr/lib/libc.a(nss_deffinder.o)
> > dlopen                              /usr/lib/libc.a(nss_deffinder.o)
> > ld: fatal: Symbol referencing errors. No output written to ls
> 
> 
> There is no static version of the dl library. Unless you want to
> do it yourself, get a static ls from
> 
> http://www.eng.auburn.edu/users/doug/second.html
> 
> (as a bonus, you'll find there some other very handy utilities)
> 
> Luc Desrosiers
> 
> 

I downloaded the source code of the ls from mentioned address. In order to
compile (staticly) the ls with gcc and on Solaris system I slightly modified the
Makefile. After compilation succeeded I issued the ./ls -al command and
it seems that it doesn't work properly. Look yourself at the output:

-rw-r--r--  1 116          1491 Aug 15 15:56 .mailrc
-rw-r--r--  1 116           135 Aug 29 21:58 .mailtool-init
drwx------  3 116           512 Aug 29 21:36 .netscape
-rwxr-xr-x  1 116          1391 Aug 29 21:58 .openwin-init

As you can notice there is no group ownership at all and user ownership
displays in numeric format.
So, does anyone know what's wrong and how it can be corrected?

Sorry for bad English.

Cheers,
Serge Bezzubov <[email-masked]>
YNC, Yaroslavl, Russia

---

From: Emil Isberg <[email-masked]>
Date: Sun, 8 Sep 1996 14:34:32 +0200 (MET DST)

Hello ...
Is it possible to lock just one directory with wu-ftpd ..
like you've got this uploads directory
and you want to lock it temporarily .. without editing the configfiles ..
and don't want to do a chmod on the dir ..
I just want to put a file there (named like .nouploads) and noone is able
to upload anything ..
/Emil