Subject: Setting up WU-FTPD on Solaris 2.4

From: [email-masked]
Date: Tue, 17 Sep 96 11:02:04 edt

I have gotten wu-ftpd up and running -- but not much else. I seem to 
     be unable to log on ANY real users. When I try to login i receive the 
     following:
     
     >220 suntest1 FTP server (Version wu-2.4(1) Fri Sep 6 13:41:17 EDT 
     >1996) ready.
     >Name (suntest1:gpiney): gpiney
     >530 User gpiney access denied...        /* NO PASSWORD PROMPT */
     >Login failed.    
     
     The following is the "class" statement in my "ftpaccess" file
     
     >class   all   real  *.mcgraw-hill.com,152.159.*.*
     >class   local real *.mcgraw-hill.com,152.159.*.*
     >class   gpiney real *.mcgraw-hill.com 152.159.*.*
     
     There are no messages logged in /usr/adm/messages. Does this have 
     something to do with the "/etc/shells" file/dir??. If so, what is it,
     how do I set one up, what's in it? etc,etc,etc. Solaris does not
     use a "/etc/shells".

     Thanks in Advance,
     
     Greg Piney
     The McGraw-Hill Companies

---

From: [email-masked] (Miquel Cabanas. BBM-UAB)
Date: Tue, 17 Sep 1996 18:43:00 +0200

> From [email-masked] Tue Sep 17 18:02:17 1996
>
> [lines removed]
> 
> [lines removed]      

well, it does not come with a "/etc/shells" file but it uses it when
available and certainly, ftp requires it. You will have to create it
and put in it all the shells your real-ftp users are using, ie.

	> cd /etc
	> touch shells
	> chmod 644 shells
	> chown root shells
	> chgrp other shells

then edit it and append the following shell files (one shell file per
line)

	> more /etc/shells
	/bin/sh
	/bin/csh
	/bin/ksh
	/bin/jsh
	/usr/bin/sh
	/usr/bin/csh
	/usr/bin/ksh
	/usr/bin/jsh
	/bin/false

remember to also include an 'ftponly' shell or '/bin/false' if you plan to
have users with ftp access and login sessions dissabled (ie no telnet... )

hope this helps. miquel

Miquel E Cabanas ---------------------------------------------------
SeRMN & BBM - Universitat Autonoma de Barcelona, Catalunya - Spain

e-mail: [email-masked]
url:    http://bbm-web.uab.es/biomed-nmr/miquel_angles.html
------------------------------------------o-oo--ooo---ooo--oo-o-----