Subject: Statically linked ls on Sol x86 2.5

From: Thomas Chung <[email-masked]>
Date: Thu, 26 Sep 1996 16:50:28 -0700 (PDT)

I'm trying to compile a statically linked version of ls (with gnu
fileutils 3.13) on Solaris x85 2.5 w/ gcc, and everytime anything
in the src directory is compiled, I get the following error:

gcc  -o chgrp chgrp.o ../lib/libfu.a -lintl -lgen
Undefined                       first referenced
 symbol                             in file
_nl_msg_cat_cntr                    chgrp.o
dcgettext__                         chgrp.o
ld: fatal: Symbol referencing errors. No output written to chgrp
*** Error code 1
make: Fatal error: Command failed for target `chgrp'
Current working directory /opt/work/fileutils-3.13/src
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /opt/work/fileutils-3.13
*** Error code 1
make: Fatal error: Command failed for target `all-recursive-hack'

Note:  I have -static in the CFLAGS and LDFLAGS.  Any clues to get this
compiled properly would be greatly appreciated.

If there's a  statically linked version of ls for Sol x86 somewhere, 
I would appreciated if you can point it out, I would appreciate 
that as well.   

Fail that, if anyone has guest ftp set up where they can do an 'ls -l' or 
'dir' with no problem on Sol x86, I like to know about it.

Many Thanks.
 
----
/****************************************************************************
Thomas Chung | [email-masked] | MCI Mail: 203-3917 | Vnet: 745-6113
*****************************************************************************/

---

From: Yanni <[email-masked]>
Date: Thu, 26 Sep 1996 19:52:10 -0700

> Fail that, if anyone has guest ftp set up where they can do an 'ls -l' 
> or 'dir' with no problem on Sol x86, I like to know about it. 

it works fine for me with sol2.5 on a sparc 5 clone...the key is 
getting everything setup correctly...i had the same problem as you 
before everything was setup correctly...

read all the faqs and man pages...(and this listserv since there has been 
a bunch of sol q's and a's recently..)

hope that helps,

-jon

Jon (no h) S. Stevens        [email-masked]
ClearInk WebMagus      http://www.clearink.com/
finger [email-masked] for pgp pub key
people in cars cause accidents
accidents in cars cause people