Subject: Problems compiling

From: [email-masked]
Date: Thu, 29 Aug 96 13:34:13 EST

Hi,
     
     I have a new Sparc Ultra running Solaris 2.5.1.  Just got the machine 
     and have installed gcc on it.  I am now being asked to put up an 
     anonymous ftp server and want to use wu-ftpd-2.4.  After making 
     changes to the Makefiles to use the gcc compiler, I am getting the 
     output as shown below.  I checked my system and do not have the 
     bitypes.h or cdefs.h files anywhere.  Does anyone know what I need to 
     do to get this to compile correctly?
     
     Thanks.

build sol
make args are : 
make opts are : 
     
Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical 
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical
     
Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
In file included from authuser.c:7:
/usr/include/arpa/inet.h:68: sys/bitypes.h: No such file or directory 
/usr/include/arpa/inet.h:72: sys/cdefs.h: No such file or directory 
In file included from authuser.c:12:
/usr/include/netdb.h:66: sys/bitypes.h: No such file or directory 
/usr/include/netdb.h:68: sys/cdefs.h: No such file or directory 
*** Error code 1
make: Fatal error: Command failed for target `authuser.o'
     
Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c 
In file included from ftpd.c:63:
/usr/include/arpa/inet.h:68: sys/bitypes.h: No such file or directory 
/usr/include/arpa/inet.h:72: sys/cdefs.h: No such file or directory 
In file included from ftpd.c:71:
/usr/include/netdb.h:66: sys/bitypes.h: No such file or directory 
/usr/include/netdb.h:68: sys/cdefs.h: No such file or directory 
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'
     
Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o 
-lsupport -lsocket -lnsl -lgen 
gcc: vers.o: No such file or directory 
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'
     
Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o 
-lsupport -lsocket -lnsl -lgen
gcc: vers.o: No such file or directory 
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'
     
Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical
     
Links to executables are in bin directory: 
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 3904 + 312 + 328 = 4544 
Done

Received: from ns1.usp.org by the.usp.org (SMTPLINK V2.11.01)
    ; Thu, 29 Aug 96 13:20:01 EST
Return-Path: <@ns1.usp.org:[email-masked]>
Report-Version: 2
>To: [email-masked]
To: [email-masked]
Date: Thu Aug 29 17:19:17 GMT 1996
Original-Date: Thu, 29 Aug 96 13:18:55 EST
Original-Subject: Compiler errors
End-of-Header: 
Not-Delivered-To: !recipients due to 11  Transfer Failure
     ORIGINAL MESSAGE ATTACHED
     (rmail: Error # 22 'Surrogate command failed', rc = 2)
En-Route-To: [email-masked] 
     ======= Surrogate command =======

---

From: Michael Halls <[email-masked]>
Date: Thu, 29 Aug 1996 13:54:14 -0600 (MDT)

>      do to get this to compile correctly?

   It looks like you installed Bind 4.94!  It installs netdb.h, resolv.h, 
and inet.h, and nameser.h (and one other) over the Solaris 2.51 header
files.  If you look in the Bind distribution you will find the missing
header files bitypes.h and cdefs.h in the compat directory.

   You can install these files by doing an make install-compat (which
doesn't seem to work well) or put them there by hand.  If you do this you
will get errors about MAXHOST or something being undefined.  The can be
worked around.

   The way I handled it was to back out of the Bind install by
reinstalling bind WITHOUT the shared library, linking libresolv.so to
libresolv.so.1 (instead of binds libresolv.so.2), and restoring the
standard header files instead of the UCB headers and recompile sendmail
and any other program that uses the shared library. Wuftpd compiles
without problems.

				Michael