Subject: help with Permission Capabilities

From: [email-masked]
Date: Fri, 30 Aug 1996 17:17:50 +0200 (DFT)

I am running wu-ftpd 2.4 on AIX 4.1.4
I have created 2 guestgroups, "license" and "misc"
The chroot command works well with these 2 groups.
The group "license" can't delete nothing on the system.
I would like to give the right at "misc"  to delete only
the files that are rw for him . As you will see below
the user "adm_hsl" can remove files that normally he 
is not allowed !!!
What's wrong ?
Thanks for your help

in my /etc/ftpaccess
--------------------
class   real  real   *
class   anon  guest,anonymous  *

guestgroup      license misc

delete  no      ftp,anonymous,license

in my /etc/group
----------------
misc:!:400:adm_hsl,ftp
license:!:200:user1,user2

in my /etc/passwd
-----------------
ftp:*:400:400:Anonymous FTP:/users/ftp:/usr/bin/ksh
adm_hsl:!:103:400::/users/ftp/pub/./ptf_sup:/bin/false
user1:!:345:200:/users/ftp/pub/./products/:/bin/false
user2:!:350:200::/users/ftp/pub/./licenses/:/bin/false

230-
230 User adm_hsl logged in.  Access restrictions apply.
ftp> pwd
257 "/ptf_sup" is current directory.
ftp> ls -l 
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 64
-rw-r--r--   1 103      400        31744 Aug 30 15:31 U438385.bff
226 Transfer complete.
ftp> del U438385.bff
250 DELE command successful.         ====> OK
ftp> cd /
250 CWD command successful.
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 64
d--x--s--x   2 0        0            512 Aug 27 19:47 bin
drwxrwsrwx   2 0        0            512 Aug 30 16:37 incoming
dr-xr-sr-x   2 0        0            512 Aug 27 19:47 lib
drwxr-sr-x  26 0        0            512 Aug 29 13:55 licenses
drwxr-sr-x   3 0        0            512 Aug 29 13:54 products
drwx------   5 103      400          512 Aug 30 15:43 ptf_sup
-rw-r--r--   1 0        0            244 Aug 28 16:34 welcome.msg
226 Transfer complete.
ftp> cd incoming
250 CWD command successful.
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 664
-rw-rw-r--   1 300      0           4131 Aug 29 08:50 README
-rw-r--r--   1 0        0           3573 Aug 29 17:33 U445410.ptf
-rw-r--r--   1 0        0         126976 Aug 28 16:16 Z001101.bff
-rw-r--r--   1 0        0           1909 Aug 28 16:18 Z001102.txt
-rw-r--r--   1 400      400       194026 Aug 29 08:56 plan0229.ps
226 Transfer complete.
ftp> del plan0229.ps
250 DELE command successful.           ===========> KO !!!

-- 

+----------------------------------------------+-----------------------------+
| Pascale Diemer                               |   [email-masked]     |
|                                              |                             |
| Open Systems & Software                      | M/S     : FREC C1-059       |
| Open System Business Unit                    | ICN     : 229 7152          |
| Systems & Pegasus Program                    | Voice   : +33 76 29 71 52   |
| System Software Productization & ISV Support | Fax     : +33 76 29 71 02   |
| Software Packaging & Manufacturing Transfer  |                             | 
+----------------------------------------------+-----------------------------+

---

From: Alain Magloire <[email-masked]>
Date: Fri, 30 Aug 1996 12:58:03 -0400 (EDT)

Hello Pascale

  I beleive that the "delete" key word only take
a typelist i.e. "anonymous, guest, real".

instead of

> delete  no      ftp,anonymous,license

you should have

delete          no      guest,anonymous    

so since "/pub/incoming" was 777 the delete was succesfull

maybe you would like to chekout
ftp://ftp.fni.com/pub/wu-ftpd/guest-howto

for more info

--
au revoir, alain