Subject: Incorrect Logging Times

From: [email-masked]
Date: Wed, 7 Aug 1996 17:33:20 +0200 (DFT)

> 
> On 23 Feb 1996, Herman Weaver/IS/CCC wrote:
> 
> > I'm using wu-ftp 2.4 (no beta) on AIX 4.1.4.  In the ftpaccess file I log all 
> > commands which 
> > works fine but the time stamps on all the entries are wrong.  Anyone seen this 
> > problem 
> > before?
> 
>    Make sure this line appears in your src/config.h file:
> 
> #undef  SETPROCTITLE
> 
> Mike Loewen			Center for Academic Computing
> Email:	[email-masked]		The Pennsylvania State University
> Phone:	(814) 863-4356		University Park, PA  16802
> Office:	17 Willard Bldg.	http://ripsaw.cac.psu.edu/mloewen.html
> 
> 

I have the same problem with wu-ftpd 2.4 under AIX 4.1.4
I have change the src/config.h before the "build aix" command
But the problem is not resolved.

Have you find a solution ?

Thanks in advance

-- 

+----------------------------------------------+-----------------------------+
| Pascale Diemer                               |   [email-masked]     |
|                                              |                             |
| Open Systems & Software                      | M/S     : FREC C1-059       |
| Open System Business Unit                    | ICN     : 229 7152          |
| Systems & Pegasus Program                    | Voice   : +33 76 29 71 52   |
| System Software Productization & ISV Support | Fax     : +33 76 29 71 02   |
| Software Packaging & Manufacturing Transfer  |                             | 
+----------------------------------------------+-----------------------------+

---

From: [email-masked]
Date: Mon, 12 Aug 96 08:03:26 EST

If you want, I can send you my compiled binaries that work OK for me 
        under AIX 3.2.5 and 4.2.

joe matusiewicz                         
national weather service                      __o
silver spring, md                           _`\<,_
301.713.0866 ext 174                       (_)/ (_)  
[email-masked]

______________________________ Reply Separator _________________________________
Subject: Re: Incorrect Logging Times
Author:  [email-masked] at smtpgate
Date:    8/8/96 1:05 PM

I have change the ~src/config/config.aix as you told me before execute 
the build aix .
The problem isn't resolved.
You can notice below that there is a difference of 2 hours
My variable TZ is well declared and the date command returns the good value= 
.
     
So I am lost....
     
Could someone help me.
     
Thanks
     
#ll pub/incoming
total 40
drwxrwsrwx   2 root     system       512 Aug 08 18:24 . 
drwxrwsrwx   3 root     system       512 Aug 07 09:46 .. 
-rw-r--r--   1 ftp      misc         456 Aug 08 18:24 journal 
-rw-r--r--   1 ftp      misc        5054 Aug 07 09:58 z001107.txt
     
BUT:
ftp> cd pub/incoming
250 CWD command successful.
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls. 
total 24
-rw-r--r--   1 ftp      misc         456 Aug  8 16:24 journal 
-rw-r--r--   1 ftp      misc        5054 Aug  7 07:58 z001107.txt 
226 Transfer complete.
     
+----------------------------------------------+---------------------------= 
--+
| Pascale Diemer                               |   [email-masked]   =
  |
|                                              |                           =
  |
| Open Systems & Software                      | M/S     : FREC C1-059     =
  |
| Open System Business Unit                    | ICN     : 229 7152        =
  |
| Systems & Pegasus Program                    | Voice   : +33 76 29 71 52 =
  |
| System Software Productization & ISV Support | Fax     : +33 76 29 71 02 =
  |
| Software Packaging & Manufacturing Transfer  |                           =
  | 
+----------------------------------------------+---------------------------= 
--+

> 
>      
> Gents,
> 
> To solve the timestamp error under AIX, I had to recompile the source cod= 
e.
> If you don't, it seems to display GMT, the time in London.  The SETPROCTI= 
TLE
> definition clobbers the TZ variables.  Go into ~src/config/config.aix and 
> change the line from
> 
>         #define SETPROCTITLE
> TO
>         #undef SETPROCTITLE
> 
> Then do the build aix.
> 
> 
> joe matusiewicz                         
> national weather service                      __o 
> silver spring, md                           _`\<,_
> 301.713.0866 ext 174                       (_)/ (_)  
> [email-masked]=1A
> 
>