Subject: anonymous

From: "Christopher L. Cousins" <[email-masked]>
Date: Mon, 26 Aug 1996 14:45:37 +0000

Someone told me that not being able to do a ls -l or dir as an 
anonymous user is a common problem.  I put the libs reqired by ls in 
the /lib dir.  During text ftp sessions I can use ls, just not ls -l 
or dir.  Am I missing something?  Is there an FAQ on this subject?

TIA
[email-masked]

---

From: Emil Isberg <[email-masked]>
Date: Tue, 27 Aug 1996 00:43:23 +0200 (MET DST)

Hello, 
I am trying to fix a static ls but got some problems
I link with:
gcc -static -o ls -s ls.o ls-ls.o ../lib/libfu.a -lintl -lgen
but gets:
Undefined                       first referenced
 symbol                             in file
dlclose                             /usr/lib/libc.a(nss_deffinder.o)
dlsym                               /usr/lib/libc.a(nss_deffinder.o)
dlopen                              /usr/lib/libc.a(nss_deffinder.o)
ld: fatal: Symbol referencing errors. No output written to ls

when I checked the manpage for dlclose it succested a -ldl flag..
but when I link with it I get:
ld: fatal: library -ldl: not found
ld: fatal: File processing errors.  No output written to ls

when I check whether I got that libld* I found:
/etc/lib/libdl.so.1
/usr/4lib/libdl.so.1.0
/usr/lib/libdl.so
/usr/lib/libdl.so.1

so now I wonder why does the link doesn't work..

Is there some way to get the static binaries for my host?
(uname -a: SunOS boromir 5.5 Generic sun4c sparc SUNW,Sun_4_50)

/Emil

---

From: Luc Desrosiers <[email-masked]>
Date: Tue, 27 Aug 1996 16:28:58 -0400

> ld: fatal: Symbol referencing errors. No output written to ls

There is no static version of the dl library. Unless you want to
do it yourself, get a static ls from

http://www.eng.auburn.edu/users/doug/second.html

(as a bonus, you'll find there some other very handy utilities)

Luc Desrosiers