Subject: Anyone build wu-ftpd-2.4 on Solaris 2.5.1?

From: Mike Richman <[email-masked]>
Date: Tue, 20 Aug 1996 12:27:42 -0500 (CDT)

Hi,
I just grabbed the wu-ftpd-2.4 source and tried to build on an
UltraSparc under Solaris 2.5.1.  I had to use the support/ftp.h
file and the result of build sol is:

make args are : 
make opts are : 

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
`ftpd' is up to date.

Making ftpcount.
`ftpcount' is up to date.

Making ftpshut.
`ftpshut' is up to date.

Making ckconfig.
`ckconfig' is up to date.
ln: ../src/ftpcount and ftpwho are identical
ln: ../src/ckconfig and ckconfig are identical

Links to executables are in bin directory:
bin/ftpd: 235612 + 29164 + 27368 = 292144
bin/ftpcount: 9422 + 787 + 865 = 11074
bin/ftpshut: 7584 + 614 + 334 = 8532
bin/ftpwho: 9422 + 787 + 865 = 11074
bin/ckconfig: 4753 + 568 + 324 = 5645
Done

Then build install resulted in:

make args are : 
make opts are : 
mv -f /usr/local/etc/ftpd /usr/local/etc/ftpd-old
mv: cannot access /usr/local/etc/ftpd
*** Error code 2 (ignored)
Installing binaries.
install -o bin -g bin -m 755 bin/ftpd /usr/local/etc/ftpd
usage: install [options] file [dir1 ...]
*** Error code 2
make: Fatal error: Command failed for target `install'

Any ideas on what went awry?  TIA.

Mike Richman
U. Oklahoma
[email-masked]

---

From: Dale Wellman - Compute Intensive <[email-masked]>
Date: Tue, 20 Aug 1996 11:49:33 -0700

> file and the result of build sol is:

[snip]

> make: Fatal error: Command failed for target `install'

The install program doesn't like the args it was given.  Are you sure
there's a "/usr/local/etc" directory?  Did you edit the pathnames.h
file?

-=-=-=-=-=-=-
Dale Wellman
Sys Admin
Network Intensive

---

From: Michael Maciag <[email-masked]>
Date: Tue, 20 Aug 1996 12:31:04 -0700 (PDT)

> there's a "/usr/local/etc" directory?  Did you edit the pathnames.h

Use /usr/ucb/install instead of (/usr/sbin/)install. It supports those
different arguments.

- Mike.

---

From: Mike Richman <[email-masked]>
Date: Tue, 20 Aug 1996 19:08:18 -0500 (CDT)

Quoting Michael Maciag
> Use /usr/ucb/install instead of (/usr/sbin/)install. It supports those

Worked like a charm (thanks).  So, I modified the /etc/inetd.conf file
comenting out the old ftp line for the new ftpd one.  After a HUP, the
new daemon is running but my attempts to ftp into the machine (from
another one) are denied (either with a real named account or anonymous). 
Newbie Q#2: Any suggestions where to look next?  The supplied ftpd (8) 
man page is not all that enlightening in this regard.  TIA.

Mike Richman
U. Oklahoma
[email-masked]

---

From: Carlos Reed <[email-masked]>
Date: Tue, 20 Aug 1996 20:32:51 -0400 (EDT)

> > Use /usr/ucb/install instead of (/usr/sbin/)install. It supports those
where is the varaible that defines /usr/sbin ?

or do I have to have /usr/ucb before /usr/sbin on my path ?