Subject: .message on login?

From: [email-masked] (Ron Stanonik)
Date: Fri, 30 Aug 1996 11:40:46 -0700

We're running wu-ftpd 2.4 on SunOS 4.1.3_U1.

The .message in the login directory is never displayed.  We modified
wu-ftpd to do this.  Any good reasons not to display the .message in
the login directory?  I'm appending our diffs.

Thanks,

Ron Stanonik
[email-masked]

RCS file: RCS/ftpd.c,v
retrieving revision 1.2
diff -c -r1.2 ftpd.c
*** /tmp/,RCSt1a15525	Fri Aug 30 11:21:58 1996
--- ftpd.c	Fri Aug 30 11:15:54 1996
***************
*** 1175,1180 ****
--- 1175,1182 ----
  
      show_message(230, LOG_IN);
      show_readme(230, LOG_IN);
+     show_message(230, C_WD);
+     show_readme(230, C_WD);
  
  #ifdef ULTRIX_AUTH
      if (!anonymous && numfails > 0) {

RCS file: RCS/extensions.c,v
retrieving revision 1.1
diff -c -r1.1 extensions.c
*** /tmp/,RCSt1a15495	Fri Aug 30 11:20:41 1996
--- extensions.c	Fri Aug 30 11:07:13 1996
***************
*** 324,330 ****
      struct aclmember *entry = NULL;
      FILE *infile;
  
!     if (cwd_beenhere(1) != 0)
          return;
  
  #ifdef HAVE_GETCWD
--- 324,330 ----
      struct aclmember *entry = NULL;
      FILE *infile;
  
!     if (mode == C_WD && cwd_beenhere(1) != 0)
          return;
  
  #ifdef HAVE_GETCWD

---

From: Alain Magloire <[email-masked]>
Date: Fri, 30 Aug 1996 15:13:05 -0400 (EDT)

> the login directory?  I'm appending our diffs.

how about

message .message                cwd=*
message .message                login

in ftpaccess ?

??
maybe I've missed what you're trying to explain

--
alain