Subject: Problem compiling

From: [email-masked]
Date: Thu, 22 Aug 1996 17:26:04 -0500

Hi there...

I recently started to use wu-ftpd 2.4 fixed version.... I really need it
to support shadow passwords for our newest server etc...

When compiling I get the following error:

glob.c: in function 'matchdir':
glob.c: 240: dereferencing pointer to incomplete type
make: *** [glob.c] error 1

Anyone have any suggestions... or better yet, anyone have a shadow
enabled ftpd I can download in binary format ? :-)

Thanks again,

Paul
*** Sent Via Online Computer Distribution (http://www.oncomdis.on.ca) ***

---

From: Michael-John Turner <[email-masked]>
Date: Fri, 23 Aug 1996 12:21:46 +0200 (GMT+0200)

> make: *** [glob.c] error 1

I've noticed this problem on 3 machines using gcc 2.7.2 under Linux.
wu ftpd compiles fine under gcc 2.7.0, so perhaps you should try that.

Cheers
 M-J
-= Michael-John Turner -=-=-=-=-=-=-=-=-=-=-= UNIX: Live free or die -=-
 [email-masked]              Proud Linux user and Team OS/2 member
 [email-masked]         PGP key via mail or finger @phantom
 [email-masked]    http://phantom.eri.uct.ac.za/~mj

---

From: "Chadwick A. Dubuque" <[email-masked]>
Date: Fri, 23 Aug 1996 13:09:53 -0500 (CDT)

Michael-John Turner wrote:

(hmm...someone else wrote:)

> wu ftpd compiles fine under gcc 2.7.0, so perhaps you should try that.

The announcement for gcc-2.7.2.1 said it fixed problems under Linux. Try
that, too.

-- 
Chadwick A. Dubuque              [email-masked]
http://www.acm.ndsu.NoDak.edu/~cdubuque/     finger for PGP pub. key
"If a tree falls in the forest . . . and we've already sold the
tree . . . does it have quality?" -The Pointy Haired Boss, "Dilbert"

---

From: [email-masked] (Volker Schmidt)
Date: 26 Aug 1996 07:09:22 +0200

In article <[email-masked]>, [email-masked] wrote:
: Hi there...

: I recently started to use wu-ftpd 2.4 fixed version.... I really need it
: to support shadow passwords for our newest server etc...

: When compiling I get the following error:

: glob.c: in function 'matchdir':
: glob.c: 240: dereferencing pointer to incomplete type
: make: *** [glob.c] error 1

: Anyone have any suggestions... or better yet, anyone have a shadow
: enabled ftpd I can download in binary format ? :-)

Yep. I got a it working with that fix.

*** wu-ftpd-2.4-old/src/glob.c  Fri Apr  1 21:03:42 1994
--- wu-ftpd-2.4/src/glob.c      Mon Feb 12 00:58:31 1996
***************
*** 237,243 ****
--- 238,248 ----
                        return;
                goto patherr2;
        }
+ #if defined (linux) && defined (__ELF__)
+       if (fstat(dirfd(dirp), &stb) < 0)
+ #else
        if (fstat(dirp->dd_fd, &stb) < 0)
+ #endif
                goto patherr1;
        if (!isdir(stb)) {
                errno = ENOTDIR;

--volker
-- 
Volker Schmidt                          [email-masked]

PGP public key available on request.