Subject: Permission denied for 'upload' dirs

From: [email-masked]
Date: Mon, 1 Jul 96 10:58:02 +0200

Dear experts,

transferring a file into /pub dir yields to :

553: filename: Permission denied

Our set-up:
============

wu-2.4(1) on SunSPARC under Solaris 2.5
User: anonymous
ftp Home dir: /anonymous/ftp
Our 'ftpaccess':
----------------
class   all   real,anonymous  149.243.*.* 139.169.205.26 192.160.74.4

limit   all   10   Any              /usr/local/etc/msg.tomany

readme  README*    login
readme  README*    cwd=*

passwd-check rfc822 enforce
#
upload /anonymous/ftp   *       no
upload /anonymous/ftp   /pub    yes     root    daemon  0600    dirs
#
banner /usr/local/etc/welcome.msg
#
message .welcome                login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /usr/local/etc/shutmsg

email [email-masked]

Any idea what's wrong in our set-up?

Many thanks in advance!

- Rainer

---

From: Michael Brennen <[email-masked]>
Date: Mon, 1 Jul 1996 09:11:37 -0500 (CDT)

> 553: filename: Permission denied

</etc/ftpaccess deleted>

> Any idea what's wrong in our set-up?

Sounds like the /pub directory does not have the proper permissions.  I 
have a /incoming directory like this:

drwx-wx-wx   2 root     daemon       1024 Jun 27 23:45 incoming

This is a permission mask of 0733.  The anonymous user cannot see the
contents of the directory, but the anonymous user can write into it.  The
fact that the directory does not have read permission for other than root
means only that the contents of the directory are not available to the
remote ftp user.  If the file permission has read set, a file in that
directory can be fetched if named specifically. 

You were correct in setting 0600 permissions on the uploaded file so that
it cannot be read back; this will keep unwanted software from being traded
through your site. 

   -- Michael