Subject: He-e-e-e-lp me-e-e-e ....

From: [email-masked] (Pavel Kolesnikov)
Date: Thu, 11 Jul 1996 13:40:54 +0400

Hi everybody !

One time I made a big mistake - I have installed wu-ftpd on my computer ...

So, now I have a lot of troubles .... one of them is I do not know how I can
create new users for wu-ftpd (except FTP of cause) and create new user's groups ....

If somebody knows ... please answer or send some docs on wu-ftpd.

With best regards.

                         ''~``
                        ( o o )
+------------------.oooO--(_)--Oooo.------------------+
| Pavel  Kolesnikov                Belief             |
|  St. Petersburg,   .oooO             creates        |
|      Russia        (   )   Oooo.         reality... |
+---------------------\ (----(   )--------------------+
                       \_)    ) /
                             (_/

---

From: "Peter Harris Service-LL" <[email-masked]>
Date: Thu, 11 Jul 96 11:18:43 +0100

Hi Pavel,

What's your computer; what version of software etc; and show us your 
passwd file!

Pete
___________________________________
Peter Harris
Information Technologist
Services Information Group
Lodge Farm, Lodge Lane
England
Ext: 33201
DDI: +44 1494 541201
email: [email-masked]
___________________________________

---

From: [email-masked] (Pavel Kolesnikov)
Date: Thu, 11 Jul 1996 15:42:05 +0400

> From [email-masked] Thu Jul 11 15:22 ??? 1996
> Date: Thu, 11 Jul 96 11:18:43 +0100
> From: "Peter Harris Service-LL" <[email-masked]>
> To: [email-masked]
> Subject: Re: He-e-e-e-lp me-e-e-e ....
> X-Sender: "Peter Harris Service-LL" <[email-masked]>
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> Hi Pavel,
> 
Hello Pete,

Thank you for your answer.

I work on SPARCstation 5 with Solaris 2.4
My passwd file is showed below:

root:x:0:1:0000-Admin(0000):/:/sbin/sh
daemon:x:1:1:0000-Admin(0000):/:
bin:x:2:2:0000-Admin(0000):/usr/bin:
sys:x:3:3:0000-Admin(0000):/:
adm:x:4:4:0000-Admin(0000):/var/adm:
lp:x:71:8:0000-lp(0000):/usr/spool/lp:
smtp:x:0:0:mail daemon user:/:
uucp:x:5:5:0000-uucp(0000):/usr/lib/uucp:
nuucp:x:9:9:0000-uucp(0000):/var/spool/uucppublic:/usr/lib/uucp/uucico
listen:x:37:4:Network Admin:/usr/net/nls:
nobody:x:60001:60001:uid no body:/:
noaccess:x:60002:60002:uid no access:/:
ftp:x:30000:30000:Anonymous FTP:/export/ftp:/nosuchshell
majordom:x:30001:30001:Mail Robot:/export/majordomo:/usr/local/bin/zsh
ftpowner:x:30010:30010:Owner of FTP:/export/ftp/ftpowner/:/bin/sh

                         ''~``
                        ( o o )

---

From: [email-masked] (Jim Bootz)
Date: Thu, 11 Jul 1996 07:12:13 -0500

> |      Russia        (   )   Oooo.         reality... |

I have a script, "addftpguest", that I'm using with Solaris 2.5. I modified it 
from an Ultrix version when we moved our ftp site to a new machine. I'd include 
it here, but it's rather long and I'd need to explain some things about it. 
You'd probably have to adapt it to your server. Let me know if you want me to 
e-mail a copy to you.

       _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
      _/   XX   XXX    XXX  _/  Jim Bootz    IS Sys Admin   _/
     _/  X  X  X  X  X   X _/  ADC Telecommunications Inc. _/
    _/  XXXX  X  X  X     _/  4900 W. 78th St.            _/
   _/  X  X  X  X  X   X _/  Bloomington, MN 55435       _/
  _/  X  X  XXX    XXX  _/  612-946-3056                _/
 _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: "Peter Harris Service-LL" <[email-masked]>
Date: Thu, 11 Jul 96 13:37:02 +0100

Hi Pavel

Try this for adding another user (i am using different s/w - SCO UNIX - 
but I think it should work)

ftp:x:30000:30000:Anonymous FTP:/export/ftp:/nosuchshell
alpha:x:30002:30000:Anonymous FTP with access to special 
files:/export/ftp/./alpha:/bin/false

where:
./alpha is a subdirectory under /export/ftp; set owner to 'alpha'
/bin/false is an entry in /etc/shells (text file)

What this will do is, hopefully, when *alpha* logs into the ftp service, 
they are placed in the /export/ftp/alpha directory. Set file permissions 
so only they can read/write or whatever (not the group). Set a password 
for this user (as it is looked for before chroot takes place) and you do 
not want everyone to get these files. Set up a new group as normal and 
copy these lines into your ~ftp/etc/passwd and ~ftp/etc/group files.
Is this what you require? If this doesn't work, give me your ftp identity 
and I'll see what it looks like 'from the outside',
Pete 
___________________________________
Peter Harris
Information Technologist
Services Information Group
Lodge Farm, Lodge Lane
England
Ext: 33201
DDI: +44 1494 541201
email: [email-masked]
___________________________________

---

From: [email-masked] (Pavel Kolesnikov)
Date: Fri, 12 Jul 1996 14:17:55 +0400

> From [email-masked] Thu Jul 11 21:29 ??? 1996
> Date: Thu, 11 Jul 1996 12:23:46 -0500 (CDT)
> From: Chris Hamilton <[email-masked]>
> Mime-Version: 1.0
> On Thu, 11 Jul 1996, Pavel Kolesnikov wrote:
> 
> > Hello Jim,
> > 
> > Thank you for your answer. I have already installed "wu-ftpd" and now I really need
> > to create  "ftp" user (not "ftp" or "anonymous"). I need that the user can connect
> > to my computer by "ftp" but not by "telnet" or something else besides that user will
> > not be able to change the FTP ROOT DIRECTORY "/export/ftp/".
> > If is possible to create such a user please mail me.
> > 
> > I work on SPARCstation 5, Solaris 2.4
> > 
> > 
> > PS: I know that I can create user with changible root directory by adding :
> >     "/export/ftp/./somedir" as his/her home directory into "/etc/passwd" file.
> >     But it is not good for me. I need that the user cannot change the FTP ROOT
> >     DIRECTORY "/expoet/ftp/".
> > 
> 
> What you need to do is:
> 
> 1. Create a group in /etc/group called "ftponly".  (This is the default 
> group that wu-ftpd looks for.)
> 2. Create your user account (e.g., "bobftp"), whose primary group 
> membership should be the "ftponly" group.  Set his login shell to be 
> /etc/false.  Let's assume your user's login dir is set to /export/ftp.
> 3. Make sure "/etc/false" appears in your /etc/shells file.  On Solaris, 
> you don't have an /etc/shells file by default, so you'll have to create 
> one with all valid shells plus /etc/false.
> 4. Check your ftpaccess file to make sure that the guestgroup setting is 
> set to "ftponly".
> 5. Now, when "bobftp" logs in, he will be chrooted to /export/ftp.  
> This is because his primary group is "ftponly".  Note that this the 
> only way to cause a user other than "ftp" or "anonymous" to be chrooted 
> to some dir at login time.  Also, "bobftp" cannot login via telnet, 
> because his login shell is /etc/false.
> 6. You'll need to create the logical /dev, /etc, and /usr/lib directories 
> under /export/ftp, of course.
> 
> Hope that helps...
> 
> Chris
> 

Hello Chris,

Thank you very much. You are quite right ! 
I have done these steps and everything is Ok.
I think it is a good guide for inexperiensed wu owners.

Best Regards.

                         ''~``
                        ( o o )