Subject: Re: password for ftp...

From: [email-masked] (Ken Alker)
Date: Fri, 26 Jul 1996 15:41:11 -0700

>There are three things to do.
>
>1.	Make sure that your user is set up with a shell like /bin/false
>
>2.	Make sure that their home directory is where you want them to go.
>
>3.	Make sure that /bin/false is added to /etc/shells
>
>So a typical entry in the passwd file might look something like:
>
>userid:cnskjssdke73i439i:xxx:yyy:usersname:/home/userid/./:/bin/false
>
>If I have missed some other required perameter fit it in where ever it
>goes and make the necessary mental adjustment. This setup will permit
>ftp login under their user name and password but will cause telnet to
>fail.  If you need to disable ftp access for the user just add their
>name to ftpusers which dispite its name is a list of userids which may
>NOT use FTP access.

This does not seem to work with SunOS 4.1.3.

My /usr/bin/false looks like this:

#! /bin/sh
#
#       @(#)false.sh 1.5 88/02/07 SMI; from UCB
#
exit 1
/*********************************************************************
 [email-masked]          [email-masked]          ham radio: KA6SDU
 Impulse Internet Services = internet service provider, Santa Barbara  
 Impulse Engineering = digital design, embedded systems, programming.
*********************************************************************/

---

From: Mike Batchelor <[email-masked]>
Date: Sun, 28 Jul 1996 10:18:25 -0400 (EDT)

> #       @(#)false.sh 1.5 88/02/07 SMI; from UCB

Here is the extent of my C application programming skills:

# cat >false.c
main() { exit(1); }
^D
# gcc -o false false.c
# mv /usr/bin/false /usr/bin/false.sh
# cp false /usr/bin
# cat >true.c
main() { exit(0); }
^D
# gcc -o true true.c
# mv /usr/bin/true /usr/bin/true.sh
# cp true /usr/bin
#

---
  + + +      %%%%% Mike Batchelor % [email-masked] %%%%% A Division
 Capitol.Net %%%%%%%%%%% 301-306-9090 % V.34/ISDN %%%%%%%%%%%    of
     + + +   %% Serving Washington DC, No.VA, and Maryland %%   Criticom, Inc.