Subject: wu-ftpd on FreeBSD?/ gcc QuesTion

From: [email-masked] (laweb)
Date: Sun, 28 Jul 1996 11:49:41 -0800

Thanks for the advice,
The version of wu I got from wuarchive.wustd.edu doesn't have fbs files, though.
I modified the .gen files myself. (P.S. I had to do disable most of the include files in the config.[fbs] file as they weren't inside my include files [I checked with grep].)

I then tried compiling the thingie, and it seemed to do a fine job, except that it didn't find the config.h header file. 
Reminder: The .c files are inside the src directory, and the config.h file is inside its parent directory.
The config.fbs file is inside src/config/ and one of its settings calls for config.h to be at ../config.h
I presume, now, that this is relative to the config and not the src directory...

I took off before trying anymore, and I thought it would be a good idea to ask you guys..  Just in case anyone knows if what I'm doing is by the book, or if I should be doing what.

Most curious to get a confirmation that I should move the config.h file inside src directory, and then compile.

Next will be to run 'build INSTALL' if I am interpreting O'Reilly correctly.

I'd really appreciate any little word from somone who has wu running successfully on FreeBSD.

Thanks,

>Hi Troy,
>
>
>I'm using the BETA-11 release, so I realy don't know if this would work for your wu-ftp release.
>The makefile for FreeBSD is Makefile.fbs in /makefiles.
>But there is allso a script called build, which can make the whole compiling and installing stuff for you. Call it this way: ./build fbs
>
>Please drop me a line how it works.
>
>with greetings from germany
>
>Martin Kandlbinder
>[email-masked]
>
>----------
>Von: 	laweb[SMTP:[email-masked]]
>Gesendet: 	Donnerstag, 25. Juli 1996 01:24
>An: 	[email-masked]
>Betreff: 	wu-ftpd on FreeBSD?
>
>I am just in the process of installing wu-ftpd on a FreeBSD machine.
>
>I was wondering if I should go with gen or BSD settings (makefiles and config files).
>
>Thanks,
>
>
>
>
>
>
>Troy Korjuslommi
>Technical Director/Webmaster
>ALLIANCE STUDIO
>(Los Angeles Web Division)
>ph. (310) 458-0884
>e. [email-masked]
>w3. http://gyw.com/alliance/
>
>
>
>
>Content-Type: application/ms-tnef
>
>Attachment converted: Hard Disk:AW- wu-ftpd on FreeBSD? (????/----) (0000D483)

Troy Korjuslommi
Technical Director/Webmaster
ALLIANCE STUDIO
(Los Angeles Web Division)
ph. (310) 458-0884
e. [email-masked]
w3. http://gyw.com/alliance/

---

From: "Homer W. Smith" <[email-masked]>
Date: Sun, 28 Jul 1996 15:20:05 -0400 (EDT)

Weirdest thing.  Running beta 11 on a Slackware Linux box.
 
    Incoming ftp works fine.  Out going ftp freezes the whole system on
files larger than about 3400 bytes.  Smaller than that they work.  Larger
than that it freezes right up permanently. 
 
    This happens whether or not one ftps from the Linux box to the outside
world sending the file out, or from the outside world in pulling the file
out. 
 
    Incoming files work fine either way.
 
    Homer