Subject: Patch fot 2.4.2 beta 11 on Solaris 2.5 and AIX 4.1

From: Marc Baudoin <[email-masked]>
Date: Wed, 3 Jul 1996 10:57:53 +0200 (MET DST)

Hi,

yesterday, I had to compile wu-ftpd 2.4.2 beta 11 on Solaris 2.5 and AIX
4.1.  In order to get it to compile (with gcc), I had to do the following
things:

- in src/ftpd.c, change

#include <arpa/ftp.h>

into

#define FTP_NAMES
#if defined(SOLARIS_2) || defined(AIX)
#include "ftp.h"
#else
#include <arpa/ftp.h>
#endif

as typenames and the other arrays are not defined in <arpa/ftp.h>.

- in src/extensions.h, line 99, change

extern char *realpath(char *pathname, char *result);

into

extern char *realpath(const char *pathname, char *result);

to make the ANSI compiler happy.

-- 
Marc Baudoin              | e-mail    <[email-masked]>
Hervé Schauer Consultants | WWW       http://www.hsc.fr/
142 rue de Rivoli         | Téléphone +33 (1) 46 38 89 90
75039 PARIS CEDEX 01      | Fax       +33 (1) 46 38 05 05

---

From: "Amin S. Kassem" <[email-masked]>
Date: Wed, 3 Jul 1996 17:59:59 -0500 (CDT)

Hi,

I followed your steps to compile wu-ftpd-2.4.2.b11 on AIX using gcc 2.7.2
but had no success.  I get the following errors.  Any suggestions???

FIXES-2.4.2-BETA-4    README
# ./build aix
make args are :
make opts are :
 
Linking Makefiles.
 
Making support library.
        rm -f libsupport.a
        ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strsep.o  vsnprintf.o authuser.o strdup.o
        ranlib libsupport.a
 
Making ftpd.
        gcc -O2 -I.. -I../support -L../support -c ftpd.c
ftpd.c:70: `defined' without an identifier
ftpd.c:70: parse error
make: 1254-004 The error code from the last command is 1.

Stop.
 
Making ftpcount.
        gcc -O2 -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport -ls
gcc: vers.o: No such file or directory
make: 1254-004 The error code from the last command is 1.

Stop.
 
Making ftpshut.
        gcc -O2 -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport -ls
gcc: vers.o: No such file or directory
make: 1254-004 The error code from the last command is 1.

Stop.
 
Making ckconfig.
        gcc -O2 -I.. -I../support -L../support -o ckconfig ckconfig.c
 
Links to executables are in bin directory:
size: 0654-304 Cannot open bin/ftpd.
size: 0654-304 Cannot open bin/ftpcount.
size: 0654-304 Cannot open bin/ftpshut.
size: 0654-304 Cannot open bin/ftpwho.
bin/ckconfig: 2849 + 540 + 23 + 1543 + 2172 = 7127
Done
#
> --=20
> Herv=E9 Schauer Consultants | WWW       http://www.hsc.fr/
> 142 rue de Rivoli         | T=E9l=E9phone +33 (1) 46 38 89 90

-- 
				 \|||/
 				 (0^0)
==============================oOO=(_)=OOo========+=========================
| Amin Kassem - Network/Systems Administrator    | e-mail: [email-masked]  | 
| Exchange Data, Inc. - Minneapolis, MN.         |         [email-masked] |
| voice: (612)332-2101 - Fax: (612)334-5997      | I would give up an arm | 
| http://www.tccn.com ; A legend in my spare time| to be ambidextrous!    |
=================================================+=========================

---

From: Marc Baudoin <[email-masked]>
Date: Thu, 4 Jul 1996 09:11:49 +0200 (MET DST)

> make: 1254-004 The error code from the last command is 1.

Can you include the portion of code around line 70? This error seems to
come from my patch...

> make: 1254-004 The error code from the last command is 1.

Yes, you need to run

sh newers.sh

by hand in the src directory.