Subject: chroot() is not working

From: Gris Pascal <[email-masked]>
Date: Tue, 16 Jul 1996 15:01:51 +0200

Hello,

I'd like to make files available to special guest users

I'm logging as an anonynous user to my ftp server 
and I use the site group and site gpass command :
 
ftp> quote site group invite-ftp
200 Request for access to group invite-ftp accepted.
ftp> quote site gpass "the-password"
200 Group access enabled.

but no chroot() to /usr3/ftp/invite occurs ! 
I'm still in /usr2/ftp which is the filesystem of my FTP server 

here my configuration files :

----- /etc/passwd -----
invite:x:701:700:Invite FTP:/usr3/ftp/./invite/:/bin/false
-----------------------

----- /etc/group ------
invite::700:invite
-----------------------

----- ftpaccess -------
class   all   real,guest,anonymous * 
limit   all   15   Any              /usr/local/adm/ftp/msg.toomany 
readme  README*    login
readme  README*    cwd=* 
message /welcome.msg            login
message .message                cwd=* 
gzip            yes             anonymous
compress        yes             local remote
tar             yes             local remote
log commands anonymous,real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg
email user@hostname 
passwd-check    rfc822  warn 
private yes
guestgroup invite
---------------------

------ ftpgroups ------
invite-ftp:k7d9nUcQIdU7o:invite
-----------------------

ls -l /usr3/ftp/invite

lrwxrwxrwx   1 root     other          7 Jul 16 13:40 bin -> usr/bin
d--x--x--x   2 root     other        512 May  9  1995 dev
d--x--x--x   2 root     other        512 May  9  1995 etc
d--x--x--x   4 root     other        512 May 13 11:39 usr

I'm running wu-ftp 2.4(7) under Solaris 2.4

I still watched the FAQ, but I don't know what I'm doing wrong !

Thanks a lot for helping me !  

-- 
________________________________________________________________________
Pascal GRIS                             Tel : 88.41.66.12          
Centre Reseau Communication             Fax : 88.41.66.28 
Universite Louis Pasteur                  
7, rue Rene Descartes                   
67084 STRASBOURG Cedex - France         E-mail : [email-masked]	
________________________________________________________________________

---

From: Jim Alton <[email-masked]>
Date: Wed, 17 Jul 1996 11:39:18 -0400 (EDT)

On Tue, 16 Jul 1996, Gris Pascal wrote:

Good Day Gris:

 You appear to have an inconsistency between the group you are trying to
use the site command to access and the one you have shown in your
/etc/group and your ftpaccess file

 The site command issued in ftp changes to group "invite-ftp" but the
actual group shown is invite.

Good luck,
Jim

> invite:x:701:700:Invite FTP:/usr3/ftp/./invite/:/bin/false

        ./\.
     _|\|  |/|_   Jim Alton - Consultant - InteGain Corporation
     \        /   [email-masked]
      >______<    Phone:  (416) 410-4572
         /