Subject: Re: Ftp throuput rates for dial-up PPP modems.

From: [email-masked] (Andrew P. Schwalb)
Date: Tue, 2 Jul 1996 09:32:24 -0400

> From [email-masked] Tue Jul  2 09:21:35 1996
> Date: Tue, 2 Jul 1996 09:09:33 -0400 (EDT)
> From: "W. James Showalter" <[email-masked]>
> To: "Nelson C. L. Pedrozo" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Ftp throuput rates for dial-up PPP modems.
> MIME-Version: 1.0
> X-Sender: [email-masked]
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> For SLIP/PPP connections using TCP things like the MTU size and the TCP 
> window size are important.  Also, depending on the usage and transfers it 
> is possible to get significantly better thruput in one direction vice the 
> other.  For our Communication Servers and our Winsock clients we use an 
> MTU of 600 and a TCP window of 4095.  Some experimentation may be in 
> order to determine the best settings.
>

Where do you modify these settings on Solaris 2.5 ?

> Also keep in mind that some of the bandwidth is gobbled up by protocol  
> headers.  And the fact that the modem appears to max its transfer rate is 
> that you could be doing lots of TCP retransmits which would reduce your 
> effective thruput at the application level.
> 
> Good luck!
> Jim
> 
> 
> On Mon, 1 Jul 1996, Nelson C. L. Pedrozo wrote:
> 
> > 
> > 
> >   Hello WU list,
> > 
> > 
> >   I'm part of an ISP and am currently facing the following problem:
> > My clients, using dial-up PPP, can't seem to get more than 1/4's worth
> > of their total modem throughput (14400, for example), when transferring
> > via ftp. Any special reason why? I suspect the ftp protocol itself, but
> > can't be sure.
> >   Let me illustrate:
> > 
> > 	14400 modem = 1.8 kbytes/sec --> user gets roughly 0.4 kbytes/sec.
> > 	28800 modem = 3.6 kbytes/sec --> user gets roughly 1.0 kbytes/sec.
> > 
> >   What's odd about all this is that if you use windows 95, and bring up the
> > modem monitor, it *shows* throughput that nears the modem's full throughput.
> > It's just the ftp-data part that is much less. 
> > 
> >   Any clues, lights, insights, hints?
> > 
> > 
> >    Thanks,
> > 
> > 			Nelson C. L. Pedrozo
> > 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
0- 
Andrew P. Schwalb - Staff Engineer	(352) 687-5377
Lockheed Martin Ocala Operations	[email-masked]
RASSP Program

---

From: "W. James Showalter" <[email-masked]>
Date: Tue, 2 Jul 1996 11:05:26 -0400 (EDT)

On Solaris 2.x there is a program called ndd which allows one to modify
certain parameters which govern the way a protocol behaves. However, from
what I have recently heard on this list, the implementation of the TCP in the
Kernel is not using them properly so setting them may not help.  There is
very little documentation on ndd and its settings. Unless one is familiar
with the way TCP/IP work and how the driver uses the parameters it may be of
little use.  And since Sun has uses a modified version of "slow start,"
understanding how that works may not be sufficient. 

Jim

---

From: Joseph Backo <[email-masked]>
Date: Tue, 02 Jul 1996 10:16:12 -0400

> Where do you modify these settings on Solaris 2.5 ?

The mods occur in /etc/init.d/inetinit (aka /etc/rc2.d/S69inet):

#
# Set configurable parameters.
#
ndd -set /dev/tcp tcp_old_urp_interpretation 1
ndd -set /dev/tcp tcp_rexmit_interval_initial 5000
ndd -set /dev/tcp tcp_rexmit_interval_min 4000
ndd -set /dev/tcp tcp_mss_max 536
ndd -set /dev/ip ip_icmp_err_interval 0

There are a slew of SunService Tip Sheets at:

http://www.stokely.com/stokely/sunservice.tips/sunservice.tips.html

that deal with ndd parms, Routing, NIS, DNS, etc.

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Joseph F. Backo                E-Mail:     [email-masked]
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=