Subject: ftpaccess/upload: Wildcard problem

From: "Scott J. Ellentuch" <[email-masked]>
Date: Sun, 7 Jul 1996 16:40:57 -0400 (EDT)

Hi,

	I'm running 2.4(1) and am having a problem with the ftpaccess
file.  Its in regards to the upload command.

	I changed my incoming to 1733, and I have a program off my
web server that allows people to create sub-dirs underneath it.  Ok,
no biggie, it works.  HOWEVER, using the format of :

upload /home/ftp /incoming yes ftp ftp 0600 dirs

If they try to put it in /incoming its fine, but /incoming/news isn't.
I tried changing the 3rd field to :

	/incoming*
	/incoming/*
	/incoming/*/*

but it didn't get me anywhere.  Like I said, I can't put ALL the directories
in the list since they are being created dynamically.  

What do I do?!

				Tuc

---

From: [email-masked]
Date: Mon, 8 Jul 1996 17:01:29 +0200

rh> 
rh> In [email-masked]'s own words (And I ">_") :
rh> > 
rh> > 
rh> > Strange. I'm running 2.4. My entry in ftpacces is:
rh> > upload /Ftp/ftp /upload		yes ftp ftp 0444 dirs
rh> > upload /Ftp/ftp /upload/*	yes ftp ftp 0444 dirs
rh> > 
rh> > and this works just fine up-to one level.
rh> > 
rh> 	Is that stock 2.4? I can't get that to work on stock 2.4, but with
rh> academ-beta-11 it does it with just the first line, however it then won't
rh> change the permissions/owner/group properly.

As far as I can see .. it's stock 2.4 on Solaris 2.4.

Ronald.