Subject: chroot-Acount didn't see anything

From: Claus Bayer <[email-masked]>
Date: Wed, 24 Jul 1996 10:28:49 +0200

Hello!

This is maybe a faq, so please forgive me asking, but the provided
documentation didn't help me any further. I've got problems with
chroot()-Acounts. Even my anonymous-User as also any REAL user that i've set
chroot (via guestgroup in ftaccess) can't see any file or directory after
login. A pwd produces a "/" wich seems correct to me. The other acounts work
all fine. I've set the bin/ and etc/ - dirs for the chroot-users as
descriped. Their passwd-entries looks like:

        tii:!:222:205::/usr/local/WWW/doc/tii/./:/etc/ftponly
        ftp:!:224:-2:Anonymous FTP-User:/home/ftp/./:/etc/ftponly

205 is my guestgroup. I start the ftpd via inetd:

        ftp     stream  tcp     nowait  root    /usr/local/etc/ftpd ftpd -a

My ftaccess looks like:

        class   all   real,guest,anonymous  *
        limit   all 5   Any   /usr/local/etc/wuftpd/msgs/msg.dead
        guestgroup ftponly
        readme  README*    login
        readme  README*    cwd=*
        message /welcome.msg            login
        message .message                cwd=*
        # compress        yes             local remote
        # tar             yes             local remote
        log commands real,anonymous
        log transfers anonymous,real inbound,outbound
        shutdown /usr/local/etc/wuftpd/msgs/shutmsg
        email [email-masked]

And for the end, I'am working under a RS6000/220 AIX3.2. If you have any
tips, solutions or suggestions please let me know!

Thanks in advance
Claus
---
    _/_/_/     _/ _/     _/       Dipl. Inf. (FH) Claus Bayer
   _/    _/   _/   _/  _/         Eckenbert Str. 7
  _/_/_/     _/    _/_/           D-67549 Worms
 _/    _/   _/   _/   _/          Fon: +49 6241 952190 Fax: +49 6241 952191
_/_/_/     _/  _/      _/  GmbH   EMail: [email-masked]  NIC-HDL: CB57-RIPE

---

From: [email-masked] (Mark S. Tremblay)
Date: Wed, 24 Jul 1996 08:21:42 -0400 (EDT)

According to Claus Bayer:
> ...

The only suggestion I would have is that make SURE you have the
appropriate directories, etc, bin, dev, usr, located at the locations
the tii and ftp accounts consider home, ie:

	/usr/local/WWW/doc/tii/[bin,lib,etc,usr]
		and
	/home/ftp/[bin,lib,etc,usr]

-- 
-Mark S. Tremblay
 Eastman Kodak - Elmgrove Plant
 [email-masked]
 (716) 253-0102