Subject: umask

From: "Haralds Jass" <[email-masked]>
Date: Sun, 7 Jul 1996 18:02:34 -0800

Although the /etc/default/login has the UMASK=022 (as it should be) any/all 
files uploaded via FTP by anyone are always rw-rw-rw (NOT good!). How do I 
change the default umask for the FTP uploaded files for users.
(which file(s) do I edit on Solaris 2.5 SPARC?).

Thanks in advance!
Haralds

---

From: Jim Davis <[email-masked]>
Date: Sun, 7 Jul 1996 20:10:46 -0700 (MST)

> (which file(s) do I edit on Solaris 2.5 SPARC?).

You can use the -u command line flag to set the umask (this is mentioned
in the FAQ), or have something like

upload /usr/ftp * no
upload /usr/ftp /incoming yes root dept 0640 nodirs

in your ftpaccess file, as the ftpaccess.5 manpage discusses.