Subject: Re: Problems installing wu-ftpd-2.4 on Solaris 2.5

From: Regina Murphy <[email-masked]>
Date: Wed, 24 Jul 1996 08:58:46 -0500

At 12:21 AM 7/24/96 -0700, you wrote:
>(I'm not on the list, so please respond directly...)
>
>I'm trying to install wu-ftpd-2.5 on a SunOS 5.5 machine but not
>having much luck at it.  I finally peppered getdatasock() with
>fprintf()s after staring at the message:
>
>ftp> dir
>425 Can't create data socket (0.0.0.0,20): Bad file number.
>ftp> 
>
>for about 2.5 hours.  I traced it down to the very innocuous
>
>	s = socket(AF_INET, SOCK_STREAM, 0);
>
>the AF_INET should be a PF_INET, but they are defined to the
>same thing so no matter.
>
>I compiled via "gcc -fpcc-struct-return" since I didn't have
>the stock Sun C compiler around.  There are no structs
>involved in this call, however, so that can't have been it.
>
>(on a tangent, I was getting warnings until I applied the
>following patch:
>
>*** support/authuser.c# Fri Apr  1 11:03:53 1994
>--- support/authuser.c  Tue Jul 23 20:47:58 1996
>***************
>*** 4,9 ****
>--- 4,10 ----
>
>  #include "../src/config.h"
>
>+ #include <netinet/in.h>
>  #include <arpa/inet.h>
>  #include <ctype.h>
>  #include <errno.h>
>***************
>*** 10,16 ****
>  #include <fcntl.h>
>  #include <limits.h>
>  #include <netdb.h>
>- #include <netinet/in.h>
>  #include <stdio.h>
>  #include <sys/socket.h>
>  #include <sys/stat.h>
>--- 11,16 ----
>
>but this is not involved in the bug).
>
>Given a rather weak knowledge of Solaris, I looked at /etc/netconfig
>and /devices/pseudo/clone@0:tcp and they all look fine.  I'm
>really stumped.
>
>Has anyone else encountered this problem?
>
>Thanks,
>
>-Philip
>
I had this problem too or at least something very similar. What you need to
do is to read the man page for ftpd on your solaris machine and follow the
instructions on how to set up an ftp site. There are several steps which
differ slightly from the wu-ftpd instructions. 

It looks like you may be missing a few libraries. Below is the list of the
shared libraries you will need to copy.

   ~ftp/usr/lib
                 Make this directory owned by the super-user  and
                 unwritable by anyone.  Copy the following shared
                 libraries from /usr/lib into this directory.:

                 ld.so*
                 libc.so*
                 libdl.so*
                 libintl.so*
                 libw.so*
                 libnsl.so*
                 libsocket.so*
                 nss_nis.so*
                 nss_nisplus.so*
                 nss_dns.so*
                 nss_files.so*
                 straddr.so*

Good luck
****************************************************
Regina Murphy
MIS Support Specialist
Datalogics inc. Formerly Adobe Systems formerly Frame Technology
[email-masked]

---

From: Dave Packham <[email-masked]>
Date: Wed, 24 Jul 1996 12:04:01 -0600

How do I get off this list ??

Please Help

>----------
>From: 	[email-masked][SMTP:[email-masked]]
>Sent: 	Wednesday, July 24, 1996 11:36 AM
>To: 	[email-masked]
>Cc: 	[email-masked]
>Subject: 	Re: Problems installing wu-ftpd-2.4 on Solaris 2.5 
>
>
>Sounds like you need to make a /dev off your main ftp dir, ie
>/home/ftp/dev.  The devs we have are "tcp", "ticotsord", "udp",
>"zero".  Man mknod to find out how to add devs.
>

---

From: "Philip A. Prindeville" <[email-masked]>
Date: Wed, 24 Jul 1996 11:37:43 -0700 (PDT)

Thanks to everyone who responded.  It was indeed a problem pertaining
to /dev and the various "clone" files (i.e. zero, tcp, udp, ticotsord).

-Philip