Subject: Re: He-e-e-e-lp me-e-e-e ....

From: [email-masked] (Pavel Kolesnikov)
Date: Thu, 11 Jul 1996 20:58:04 +0400

> From [email-masked] Thu Jul 11 16:16 ??? 1996
> Date: Thu, 11 Jul 1996 07:12:13 -0500
> From: [email-masked] (Jim Bootz)
> To: [email-masked]
> Subject: Re: He-e-e-e-lp me-e-e-e ....
> Mime-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-Md5: 1tFl4GpvM4BceA0QmESjng==
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> > 
> > One time I made a big mistake - I have installed wu-ftpd on my computer ...
> > 
> > So, now I have a lot of troubles .... one of them is I do not know how I can
> > create new users for wu-ftpd (except FTP of cause) and create new user's 
> groups ....
> > 
> > If somebody knows ... please answer or send some docs on wu-ftpd.
> > 
> > With best regards.
> > 
> > 
> >                          ''~``
> >                         ( o o )
> > +------------------.oooO--(_)--Oooo.------------------+
> > | Pavel  Kolesnikov                Belief             |
> > |  St. Petersburg,   .oooO             creates        |
> > |      Russia        (   )   Oooo.         reality... |
> > +---------------------\ (----(   )--------------------+
> >                        \_)    ) /
> >                              (_/
> > 
> 
> I have a script, "addftpguest", that I'm using with Solaris 2.5. I modified it 
> from an Ultrix version when we moved our ftp site to a new machine. I'd include 
> it here, but it's rather long and I'd need to explain some things about it. 
> You'd probably have to adapt it to your server. Let me know if you want me to 
> e-mail a copy to you.
> 
> 
>        _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>       _/   XX   XXX    XXX  _/  Jim Bootz    IS Sys Admin   _/
>      _/  X  X  X  X  X   X _/  ADC Telecommunications Inc. _/
>     _/  XXXX  X  X  X     _/  4900 W. 78th St.            _/
>    _/  X  X  X  X  X   X _/  Bloomington, MN 55435       _/
>   _/  X  X  XXX    XXX  _/  612-946-3056                _/
>  _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/                 
> 
> 

Hello Jim,

Thank you for your answer. I have already installed "wu-ftpd" and now I really need
to create  "ftp" user (not "ftp" or "anonymous"). I need that the user can connect
to my computer by "ftp" but not by "telnet" or something else besides that user will
not be able to change the FTP ROOT DIRECTORY "/export/ftp/".
If is possible to create such a user please mail me.

I work on SPARCstation 5, Solaris 2.4

PS: I know that I can create user with changible root directory by adding :
    "/export/ftp/./somedir" as his/her home directory into "/etc/passwd" file.
    But it is not good for me. I need that the user cannot change the FTP ROOT
    DIRECTORY "/expoet/ftp/".

Best Regards

                         ''~``
                        ( o o )
+------------------.oooO--(_)--Oooo.------------------+
| Pavel  Kolesnikov                Belief             |
|  St. Petersburg,   .oooO             creates        |
|      Russia        (   )   Oooo.         reality... |
+---------------------\ (----(   )--------------------+
                       \_)    ) /
                             (_/

---

From: Chris Hamilton <[email-masked]>
Date: Thu, 11 Jul 1996 12:23:46 -0500 (CDT)

>     DIRECTORY "/expoet/ftp/".

What you need to do is:

1. Create a group in /etc/group called "ftponly".  (This is the default 
group that wu-ftpd looks for.)
2. Create your user account (e.g., "bobftp"), whose primary group 
membership should be the "ftponly" group.  Set his login shell to be 
/etc/false.  Let's assume your user's login dir is set to /export/ftp.
3. Make sure "/etc/false" appears in your /etc/shells file.  On Solaris, 
you don't have an /etc/shells file by default, so you'll have to create 
one with all valid shells plus /etc/false.
4. Check your ftpaccess file to make sure that the guestgroup setting is 
set to "ftponly".
5. Now, when "bobftp" logs in, he will be chrooted to /export/ftp.  
This is because his primary group is "ftponly".  Note that this the 
only way to cause a user other than "ftp" or "anonymous" to be chrooted 
to some dir at login time.  Also, "bobftp" cannot login via telnet, 
because his login shell is /etc/false.
6. You'll need to create the logical /dev, /etc, and /usr/lib directories 
under /export/ftp, of course.

Hope that helps...

Chris