Subject: ls error with wu-ftp and Solaris 2.4

From: LES MAYEDA TECH SUPPORT/ISS X6656 <[email-masked]>
Date: Mon, 29 Jul 1996 19:28:15 -0700 (PDT)

Hello,

I'm sure the answer to this has been posted before
so please bear with me.  I just finished installing
wu-ftp 2.4 on a solaris 2.4 system and noticed that
I get the following error message with the 'ls' command
was issued:

220 sun1 FTP server (Version wu-2.4(1) Thu Jul 25 12:09:41 PDT 1996) ready.
Name (sun): anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:

230-     Access is allowed all day but limited to 10 concurrent
230-     anonymous ftp users.
230-
230-     Local time is Mon Jul 29 19:22:03 1996.
230-
230-     All transfers are logged with your host name and email address.
230-     If you don't like this policy, please disconnect now.
230-     Files are subject to removal without notice.
230-
230-     Email questions or comments to: [email-masked].
230-
230-
230 Guest login ok, access restrictions apply.
ftp> ls
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.
ftp> 

I copied the 'ls' command from /usr/bin into the ~ftp/bin directory.

Can anyone tell me what this error means?

Thanks,

Les Mayeda
Cedars-Sinai Medical Center
[email-masked]

---

From: [email-masked]
Date: Tue, 30 Jul 1996 11:21:00 -0700

Sounds like the 'ole ~ftp/dev/* stuff is missing.  We have tcp,
ticotsord, udp and zero setup in our ftp area.  'man mknod' to find
out how to make the devices.

-----
Dale Wellman
Sys Admin
Network Intensive  -  "The 'S' in ISP"