Subject: Re: Compound problem :)

From: Chris Hamilton <[email-masked]>
Date: Wed, 10 Jul 1996 08:51:07 -0500 (CDT)

On Wed, 10 Jul 1996, Nelson C. L. Pedrozo wrote:

>   	I want the user to have his home directory set to something in the
> /etc/passwd file. Say the user's homedir will be /export/home/userdir.
> I want the user to be able to have his ftp space in /foo/bar/userdir, though.
> So I created a user account, using normal means, in Solaris, with a user
> directory of /export/home/userdir. And I created the dev, etc, usr/bin, 
> usr/lib and bin link in /foo/bar/. The password file in /foo/bar/etc contains
> the following entry:
> 
> 	user:x:5555:bla bla:/foo/bar/userdir/./:/noshell
> 

I don't think this is possible.  How does wuftp know to use 
/foo/bar/userdir for the chrooted ftp file system for user?  The only 
info wuftp has to start with is what's in the /etc/passwd file, which 
will point it to /export/home/userdir.  The /foo/bar/etc/passwd file is 
there for use only *after* the daemon has chrooted to /foo/bar.   It's a 
cart before the horse thing.

> 
>   I can log in, but I get: 
> 
>     425 Can't create data socket (0.0.0.0,20): Bad file number
> 
> when I try an ls. If I change the /etc/passwd entry for this user for have
> his homedir point to /foo/bar/userdir/./, then ls works. Is there a way around
> this?

That's consistent.  You haven't created the dev and usr/lib stuff under 
/export/home/userdir...

Chris

---

From: Sam Aruti <[email-masked]>
Date: Wed, 10 Jul 1996 07:08:58 -0700 (PDT)

Nelson,
	Not sure if this will resolve your problem but I
encountered the exact same error message when I had the
disk mounted nosetuid.

			Sam
> 
> 
> 
>   Hi folks!
> 
>   I have a little problem regarding my guest ftp. I have guest ftp working
> just fine, if I do it the following manner:
> 
>       On my /etc/passwd file I have
> 
> 	 user's home dir = /export/home/userdir/./
> 
>   Then all I have to do is to create the usual usr, usr/bin, usr/lib, dev
> and etc directories and the bin link in the user's homedir, and I have 
> everything working.
> 
>   Now, what I want to do is the following:
> 
>   Thanks,
> 			Nelson C. L. Pedrozo

---

From: [email-masked] (Nelson C. L. Pedrozo)
Date: Wed, 10 Jul 1996 09:22:45 -0300

Hi folks!

  I can log in, but I get: 

  Thanks,

			Nelson C. L. Pedrozo

---

From: [email-masked]
Date: Wed, 10 Jul 1996 13:33:12 -0700

> 	user:x:5555:bla bla:/foo/bar/userdir/./:/noshell

If you put the dev, etc, user, lib stuff in /foo/bar then you have to
use /foo/bar for the chroot directory.  Try:

	"user:x:5555:bla bla:/foo/bar/./userdir:/noshell" 

>     425 Can't create data socket (0.0.0.0,20): Bad file number

This happens when there's no /dev/tcp from the chroot'd directory -
"/foo/bar/userdir".

---
Dale Wellman
[email-masked]
Network Intensive