Subject: Errors when building on AIX 4.1

From: Per Weisteen <[email-masked]>
Date: Tue, 14 May 1996 16:17:02 +0200

I get the following errors when building wu-ftpd on an AIX 4.1 system. Has anyone
made this work ?

Making ftpd.
cc -O -DDEBUG -I.. -I../support -L../support   -c ftpcmd.c -o ftpcmd.o
"ftpcmd.y", line 371.18: 1506-045 (S) Undeclared identifier cmdtab.
"ftpcmd.y", line 383.26: 1506-045 (S) Undeclared identifier sitetab.
"ftpcmd.y", line 387.22: 1506-045 (S) Undeclared identifier cmdtab.
"ftpcmd.y", line 425.18: 1506-045 (S) Undeclared identifier sitetab.
"ftpcmd.y", line 430.18: 1506-045 (S) Undeclared identifier sitetab.
"ftpcmd.y", line 1519.1: 1506-132 (S) Function print_groups cannot be redeclared.
make: *** [ftpcmd.o] Error 1

-- 
Per Weisteen              !Office: Norsk Hydro a.s, VKD283a
Norsk Hydro               !Email: [email-masked]
Box 200, 1321 Stabekk     !Phone:   (+47) 2273 8227
Norway                    !Carfone: (+47) 905 70756

---

From: Paul Wade <[email-masked]>
Date: Tue, 14 May 1996 14:32:11 -0400

> make: *** [ftpcmd.o] Error 1

The only problems I had with ftpcmd.y under linux were caused by not having yacc on the system.
The build wanted a yacc binary and bison(yacc replacement) did things differently. Making a
copy of the bison binary as yacc caused all kinds of error messages. Finding the actual yacc
binary and installing it solved the problem under linux. Bison also was generating a different
output file name than the subsequent build steps were looking for.

You should check the AIX version of the build. If it needs yacc then be certain that a true
yacc is available.

Hope it helps.

Paul Wade

---

From: Shinanyaku <[email-masked]>
Date: Wed, 15 May 1996 09:48:05 -0400 (EDT)

Paul Wade was heard saying ....

> copy of the bison binary as yacc caused all kinds of error messages. Finding the actual yacc

Apparently (at least under Linux) the order of the statements in the
ftpcmd.y are a lot more strict. I know *nothing* about yacc, but what
I did was to take th areas that were causing the errors and
move them below the definitions ... (I know, that's a clumsy way of
saying that, but like I said, I know *nothing* about yacc).

After that, my 'bison -y' worked fine.

Shin!
__________________________________________________________________________
Another Mailing List personality of Nicholas J. Leon      [email-masked]
  Linux Kernel Database [http://www.binary9.net/nicholas/kerneldb.html]

---

From: Doug Dalton <[email-masked]>
Date: Wed, 15 May 1996 15:08:58 -0400 (EDT)

I compiled wuftp with the -DVIRTUAL and it compiled without errors on 
Solaris 2.5 but it isn't working. Has anyone has success with this?

R/Doug
                           \l/
                          (O O)
o---------------------ooO--(_)--Ooo----------------------------o
I Doug Dalton - Internet Systems Engineer                      I 
I I-NExT - Making The Net Work                                 I
I http://www.internext.com/dougs                               I
o--------------------------------------------------------------o