Subject: multiple anonymous ftp areas on a single host

From: David F Cerrone <[email-masked]>
Date: Mon, 20 May 1996 12:37:48 -0400

.
	I would like to set up a single Solaris-2.4 system to
	have multiple anonymous wu-ftp areas that users are 
	directed to depending on domain name and/or IP address.
	For example:
	    * An anon wu-ftp connection from abc.xyz.com will have
		a chroot'ed home of /ftp-dirs/xyz.com
	    * An anon wu-ftp connection from one.two.com will have
		a chroot'ed home of /ftp-dirs/two.com
	    etc....

	Solaris 2.4 has the ability to configure and support
	muiltiple IP addresses per network interface, and I
	could use a TCP wrapper to figure out the domain name
	and/or IP address, but I am not sure where/how to hand
	things off after that.

	Has anyone done something similar or have any suggestions.

	I don't know if this is possible (or makes sense), but
	could a custom wu-ftpd be configured for each seperate
	ftp area, that would communicate over designated
	ports?  If so, would it make sense to only re-map the 
	connection port (default 21) and leave the data port on
	default port 20?  Are there any security issues that I 
	might be missing here?

	Any information would be appreciated.

						Thanks!
						 Dave

_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_
 
David F. Cerrone                        [email-masked]
Computer Scientist                      (518) 387-5529
GECRD Information Technology Lab
 
_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_*_

---

From: Doug Dalton <[email-masked]>
Date: Mon, 20 May 1996 15:10:59 -0400 (EDT)

David,

What you need to do is get the new Wuftp 2.4.2 beta 11 compile it with 
the -DVIRTUAL in the CFLAGS (in the Makefiles) then you can assign an 
virtual ftp port per ethernet adapter or virtual ethernet adapter. 
In the ftpaccess file you can assign the chroot directory per virtual host, 
see the VIRTUAL.FTP.SUPPORT textfile included in the archive.
 
R/Doug
                           \l/
                          (O O)
o---------------------ooO--(_)--Ooo----------------------------o
I Doug Dalton - Internet Systems Engineer                      I 
I I-NExT - Making The Net Work                                 I
I http://www.internext.com/dougs                               I
o--------------------------------------------------------------o

---

From: Chin Fang <[email-masked]>
Date: Mon, 20 May 1996 13:39:24 -0700 (PDT)

This may seem to be off topic.  However, I am sure it's of many 
readers' interest.  The most recently Apache web server (1.1 beta)
talks about creating virtual web servers without using different 
IP address and the support of such in the HTTP 1.1.

Now, lots ISPs provide both virtual web server and virtual ftp server
using different IPs.  If the web server side has advanced to such
a stage that the IP hungry scheme won't be necessary, then what about
the virtual FTP side?  the File Transfer Protocal itself is not going
to change much?

Any thoughts?

Regards,

Chin Fang
[email-masked]
===============================================================================

---

From: David F Cerrone <[email-masked]>
Date: Tue, 21 May 1996 10:54:36 -0400

Thanks for the info!  Could anyone direct me to URL's
	and/or ftp sites for "Wuftp 2.4.2 beta 11" and it's
	associated textfile(s)?

					Thanks!
					 Dave

>Doug Dalton wrote: