Subject: Compilation error...

From: Dwayne Masters <[email-masked]>
Date: Thu, 2 May 1996 16:31:37 -0500 (CDT)

I've been trying to compile wu-ftpd-2.4 for linux 1.2.13 and have
been getting the following error while compiling ftpd:

Making ftpd.
gcc -O2 -fomit-frame-pointer -I.. -I../support -I/usr/include/bsd -L../support -s   -c glob.c -o glob.o
glob.c: In function `matchdir':
glob.c:284: dereferencing pointer to incomplete type
make: *** [glob.o] Error 1

Here is that section of my glob.c:

	if (fstat(dirp->dd_fd, &stb) < 0)
		goto patherr1;

Any ideas?

--
Dwayne Masters
[email-masked]

---

From: Shinanyaku <[email-masked]>
Date: Fri, 3 May 1996 09:21:51 -0400 (EDT)

Dwayne Masters was heard saying ....
> 	if (fstat(dirp->dd_fd, &stb) < 0)

Yah! You can do this (I do), In your Makefile place 

-DILLEGAL_DIRENT_ACCESS

And all will compile fine

Shin!
__________________________________________________________________________
Another Mailing List personality of Nicholas J. Leon      [email-masked]
  Linux Kernel Database [http://www.binary9.net/nicholas/kerneldb.html]