Subject: AIX virtual ftp patch

From: Eilon Gishri <[email-masked]>
Date: Thu, 2 May 1996 21:31:44 +0300 (IDT)

Hi,
  I week ago I've sent something about a problem using virtual ftp on
AIX. Here is the patch for it (I found out that using my last mail
PASV havn't worked, meaning no netscape). Define CANT_BIND and VIRTUAL
in src/config.aix.

--- ftpd.c.orig	Sat Mar 16 07:00:09 1996
+++ ftpd.c	Thu May  2 18:03:33 1996
@@ -1418,7 +1418,7 @@
         /* We MUST do a chdir() after the chroot. Otherwise the old current
          * directory will be accessible as "." outside the new root! */
 #ifdef VIRTUAL
-      if (virtual_mode) {
+      if (virtual_mode && !guest) {
         strcpy(pw->pw_dir, virtual_root);
       }
 #endif
@@ -2072,6 +2072,11 @@
     /* anchor socket to avoid multi-homing problems */
     data_source.sin_family = AF_INET;
     data_source.sin_addr = ctrl_addr.sin_addr;
+
+#if defined(VIRTUAL) && defined(CANT_BIND) /* can't bind to virtual address */
+    data_source.sin_addr.s_addr = htonl(INADDR_ANY);
+#endif
+
     for (tries = 1;; tries++) {
         if (bind(s, (struct sockaddr *) &data_source,
                  sizeof(data_source)) >= 0)

--
		Eilon Gishri, Tel-Aviv University Computation Center
		Home 03-5078671
		E-mail: [email-masked]

---

From: Desney Tan <[email-masked]>
Date: Thu, 30 May 1996 20:56:00 -0500 (EST)

Hi,
  I have just installed wu-ftpd on a Solaris 2.5 system... Having problems
with 'ls'.... When an anonymous user logs in, and types 'ls' all he/she
gets is the firstletter of each of the dirs/files on a new line... The
case is reversed when a real user logs in and types 'ls'... Instead, the
listing is made with the first two letters removed from each of the
names... Does anyone know why this would happen? I have successfully
installed it on a SunOS system and have done everything pretty much the
same...
  Any help would be greatly appreciated... PLease respond via e-mail cause
I'm not currently subscribed to the newsgroup.
  Thanx

                \=/,          Desney S Tan
                |  @___oo       6 Jalan Hikayat 
      /\  /\   / (___,,,}       Singapore 769851 
     ) /^\) ^\/ _)	        Republic of Singapore 
     )   /^\/   _)     	        (65) 755-2838 
     )   _ /  / _)             
 /\  )/\/ ||  | )_)           [email-masked]
<  >      |(,,) )__)          http://www.nd.edu/~dtan
 ||      /    \)___)\
 | \____(      )___) )___     "Out of order there is chaos,
  \______(_______;;; __;;;     and out of chaos there is order..."