Subject: RE: Solaris 2.5 installation

From: "Kilgore, Robert" <[email-masked]>
Date: Thu, 23 May 96 13:13:00 PDT

The problem most likely is that you don't have all of the libraries that   
you need. The libraries that I have installed into the FTP tree are   
ld.so.1 libc.so.1 libdl.so.1 libintl.so.1 libw.so.1. Along with the truss   
command another good way to try things out is with the chroot command. So   
to test out ls try the following from the root of your FTP tree.

 csh> chroot <FTP root> /bin/ls

You have to be root to run chroot.

     Robert Kilgore <[email-masked]>
      Spring Branch ISD
      Houston, TX
 ----------
From:  Paul Fincher (CACI)[SMTP:[email-masked]]
Sent:  Thursday, May 23, 1996 12:40 PM
To:  [email-masked]
Subject:  Solaris 2.5 installation

Hi,

   I am currently installing WU-FTPD on my Sparcstation 10 running   
Solaris 2.5.
The server is working fine except for the long listing (dir/ls -l)   
command. I am
using the GNU ls, and have created the zero and tcp devices in ~ftp/dev.   
I have
also added the three libraries (libc.so.1, libdl.so.1, libintl.so.1) into   

~ftp/usr/lib this 'ls' is using (found using truss). Here's what happens:

ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
etc
pub
.rhosts
.forward
dev
usr
226 Transfer complete.
44 bytes received in 0.033 seconds (1.3 Kbytes/s)
ftp> ls -l
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp>

   As you can see 'ls' works fine but 'ls -l' does not seem to work. Can   
anyone
tell me what I'm missing??

THANKS :)

Paul
 --------------------------------------------------------------------------  
 -----
Paul Fincher   (Customer Support/Webmaster)
J-Mass Operational Support
[email-masked]

---

From: David Emmerson <[email-masked]>
Date: Thu, 23 May 1996 14:54:17 -0400

Or, for a slightly more succint summary of which libraries are being
used by ls, try using ldd.  Also, try building the nodes ticosord and
udp in your ~ftp/dev directory.

I have two versions of ls on my system, one which was compiled using
gcc's -static switch, and the stock (Solaris 2.4) one.  The ldd output
looks like this:

	1. Stock Solaris /bin/ls
	=> ldd /bin/ls
        	libw.so.1 =>     /usr/lib/libw.so.1
        	libintl.so.1 =>  /usr/lib/libintl.so.1
        	libc.so.1 =>     /usr/lib/libc.so.1
        	libdl.so.1 =>    /usr/lib/libdl.so.1

	2. Static (supposedly) ls
	=> ldd ~none/bin/ls
       		libc.so.1 =>     /usr/lib/libc.so.1
        	libdl.so.1 =>    /usr/lib/libdl.so.1

Now, since I'm not exactly joe programmer, can anyone tell me why an ls
(from gnu's fileutils-3.12), compiled with -static switch, still has
dependancies?  

Alternately, can anyone point me to a completely static version of ls
for Solaris 2.4?  Ftp is working just fine for me (with the stock
/bin/ls and all of the libraries in their own directories), but I do
have a need for an ls which can function in a chroot'ed environment,
without me worrying about including all of the libraries in another
directory.

Thanks, 

Dave