Subject: Problem building ftpd

From: "Scott W. Tyree" <[email-masked]>
Date: Tue, 21 May 1996 09:42:08 -0400 (EDT)

I just got wu-ftpd 2.4 and am having some trouble building the server.
This is on SunOS 4.1.3_U1. The log from the attempt to build is as
follows:

----start included log----

ripken% ./build s41
make args are : 
make opts are : 

Linking Makefiles.

Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strerror.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
gcc -g -DDEBUG    -target sun4 -c  syslog.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o
syslog.o
ranlib libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  ftpd.c
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use this function)
ftpd.c:1982: `strunames' undeclared (first use this function)
ftpd.c:1982: `modenames' undeclared (first use this function)
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

----end of included log----

Other than modifing pathnames.h, nothing else has been changed. If anyone
else has seen this before or someone can point me to the problem I would
appericate it greatly.

Thank you in advance,
Scott
 
-------------------------------+------------------------------
Scott W. Tyree                 | e-mail: [email-masked]
Senior Systems Programmer      | Phone: (301) 805-7306
Institute for Defense Analyses - Center for Computing Sciences

---

From: "Roger A. Hanke" <[email-masked]>
Date: Tue, 21 May 1996 13:39:09 -0400

Scott,
 On SunOS 5.4, Solaris 2, in order to build wu-ftpd 2.4 I had to also make 
changes in src/ftp.c file to include local header found at support/ftp.h 
instead of default system one <arpa/ftp.h>. This ended up resolving 
typename, formnames, strunames, and modenames for me.
	Roger Hanke
-------------------------------------------------------------------
 Roger A. Hanke         AT&T Easy World Wide Web Service
 (908)949-4091          [email-masked] or
 FAX (908)949-7171              [email-masked]
 HO 6C-111              http://lynxhub.ho.att.com/~rah/	
-------------------------------------------------------------------

----------
From: 	Scott W. Tyree[SMTP:[email-masked]]
Sent: 	Tuesday, May 21, 1996 5:42 AM
To: 	wu-ftpd mailing list
Subject: 	Problem building ftpd

----start included log----

ripken% ./build s41
make args are :
make opts are :

Linking Makefiles.

Making support library.

Making ftpd.

----end of included log----

Thank you in advance,
Scott