Subject: Re: Virtual ftp servers

From: Terry Esau <[email-masked]>
Date: Mon, 6 May 1996 15:54:46 -0600

I'm running  beta 10  

this from my ftpaccess file 

virtual 204.209.167.13 root    /export/home/virtual/upi
virtual 204.209.167.13 banner  /export/home/virtual/vmsgs/banner.upi
virtual 204.209.167.13 logfile /export/home/virtual/vlogs/xferlog.upi

if you are running solaris  you need  to setup another ftp directory
with all the bin,etc,dev,usr don't forget the zero files

At 02:38 PM 5/6/96 -0700, you wrote:
>I asked this question about a month ago (with no response).
>
>Can anyone tell me (or give specific example) of how to get multiple
>ftp sites in one physical server using wuftp?
>
>Example:
>
>	Server Name	ftp Directory
>	ftp.ff2.com	/servers/ff2/usr/ftp
>	ftp.oryx.com	/servers/oryx/usr/ftp
>	ftp.disknee.com	/server/disknee/ftp
>
>These would all reside on one physical machine...how is it done?
>
>PS - I already have multiple domain names resolving to an IP address 
>within the machine for http purposes (virtual servers).
>
>Thanx,
>RAK
============================================================
= Terry Esau        Main address:       [email-masked] =
= kneehill internet services       http://www.kneehill.com =
========= Linden ====== Alberta ======== Canada ============

---

From: "Luc I. Suryo" <[email-masked]>
Date: Tue, 7 May 1996 09:25:37 +0200 (MET DST)

Hi,

Got 2 Question's:

1. Running BETA 11 with Linux 1.3.98, it can not be compiled
due a error in glob.c

glob.c: In function `matchdir':
glob.c:284: dereferencing pointer to incomplete type
make: *** [glob.o] Error 1

2. does the virtual option allow site's passwd file
such as:

virtual 10.10.10.110 passwd  /export/home/virtual/etc/passwd
So we can control access, something like virtual host x
can only be access by user A, host y by user b

Anybody has a solution for this?, thnz

-- 
Kind regards,
Luc
______________________________________________________________________________
      PatriotSoft                    |  Full Unix support (Mgt/Audt/Prog)
      Zoetermeer                     |  Phone +31 79 3424 858 / 06 53340139
      The Netherlands                |  E-mail : [email-masked]
------------------------------------------------------------------------------

---

From: "Luc I. Suryo" <[email-masked]>
Date: Tue, 7 May 1996 09:56:06 +0200 (MET DST)

> Got 2 Question's:
Down to 1 now :-)
> make: *** [glob.o] Error 1
So digged the sources and header files
I added the following in the src/Makefilei : -DIRENT_ILLEGAL_ACCESS
And all OK now.

> can only be access by user A, host y by user b
Still need help with this one.

---

From: Shinanyaku <[email-masked]>
Date: Tue, 7 May 1996 09:40:12 -0400 (EDT)

Luc I. Suryo was heard saying ....
> make: *** [glob.o] Error 1

Try setting -DDIRENT_ILLEGAL_ACCESS in your makefile and
recompiling. Or putting

#define DIRENT_ILLEGAL_ACCESS 

at the top of glob.c (and some other places I don't remember).

> Anybody has a solution for this?, thnz

Shin!
__________________________________________________________________________
Another Mailing List personality of Nicholas J. Leon      [email-masked]
  Linux Kernel Database [http://www.binary9.net/nicholas/kerneldb.html]

---

From: "Luc I. Suryo" <[email-masked]>
Date: Tue, 7 May 1996 16:22:35 +0200 (MET DST)

Thnz
(yep I found that in the header file :-))