Subject: Re: ls on ftp ok; ls -la not ok ??

From: [email-masked] (Robert Chea)
Date: Wed, 8 May 1996 14:58:13 -0700

In relation to the problem below,  is there a way to compile a STATIC ls
that will allow you to do ls -la
or ls -lR ?  My core is also getting dumped when I do ls -l on a STATICALLY
compiled ls.  I'm on Solaris 2.x.
Thanks!

>On Wed, 8 May 1996, Winkelmann, Udo / CRYSTAL PALACE wrote:
>
>> when I do an ftp to my anonymous user of the wu-ftp and then ls the directoy
>> ervything is fine, when I do an ls -la a core is dumped.
>> What is wrong with my setup?
>
>Sounds like 'ls' is running wu-ftpd's internal version of ls.  The 'ls -la'
>is definitely running /bin/ls, and that is what is faulting.  You may
>be missing some dynamic libraries or some such thing.
>
>   -- Michael

Robert S. Chea
Director of Information Systems
[email-masked]

Phone:  (408) 261-6222
Fax:  (408) 261-6226

---

From: Michael Brennen <[email-masked]>
Date: Wed, 8 May 1996 17:09:22 -0500 (CDT)

> compiled ls.  I'm on Solaris 2.x.

Using gcc, just add the '-static' flag.  Not sure of other compilers. 
Static utilities are *much* simpler to use, and if you need multiple
instances for multiple guest logins just use hard links to a single file. 

   -- Michael