Subject: Re: Installing wu-ftpd

From: [email-masked]
Date: Thu, 28 Mar 1996 12:15:58 -0800

While we are on this thread, I am still having a similar problem due
to ELF support in libraries:

Repost:

I'm trying to compile ftpd 2.4 on a Sun Sparc 10 running solaris 2.4
using gcc 2.6.3.  I get the following errors during make complaining about
ELF libraries.  I've tried with both ld v2.4 and v2.6.  Is this a config 
error on my end with my GNU compiler, or am I seriously lacking something.

  % build sol
  -----
  make args are : 
  make opts are : 

  Linking Makefiles.
  ln: makefiles/Makefile.sol and Makefile are identical
  ln: config/config.sol and config.h are identical
  ln: makefiles/Makefile.sol and Makefile are identical

  Making support library.
  rm -f libsupport.a
  ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o 
  touch libsupport.a

  Making ftpd.
  cc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o private.o authenticate.o conversions.o hostacc.o -lsupport -lsocket -lnsl -lgen

  ***********
  ERRORS HERE
  ***********
  ld: fatal: file ../support/libsupport.a: unknown type, unable to process using elf(3E) libraries
  ld: fatal: File processing errors.  No output written to ftpd
  make: *** [ftpd] Error 1
  ***********

... other similar errors omitted ...

Is ELF support something that I would have had to explicit install or does
it come with gcc indicating an incomplete installation?  How do I know?

------------------------------------------------------------
Don Maszle
[email-masked] (rfs63 administrator)

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 10:48:10 +0000

> error on my end with my GNU compiler, or am I seriously lacking something.
.
.
.
.
>   Making ftpd.
>   cc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o private.o authent

The makefile used for this run used cc - was that meant to happen? - you say you're using
gcc! 

I have just compiled on Solaris 2.5 using gcc 2.7.1 (which was built by someone else at a
diff site!) and I encountered lots of errors along the way, but this wasn't one of them!

It looks more like an error in the build of libsupport.a to me, poss. something to do with
the "ar" that you're using! 

Hope this helps?

Mike

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.