Subject: Re: backing up over an ethernet network

From: Roland Nygren <[email-masked]>
Date: Wed, 27 Mar 1996 08:35:23 +0100

>does anyone know how i could automate an ftp session?
>
>i have a scrip which backs up certain files at certain times (tcsh) it 
>tars them to disk, then i would like it to automagically ftp to another 
>machine on the same network, login and put the files there?

Why not use rcp ? That would be very easy.
-------------------------------------------------------------------------
Roland Nygren
PharmaSoft
Box 1237
751 42 UPPSALA, Sweden

Tel. + 46 18 185408
Fax. + 46 18 109200
Mail. [email-masked]
http://www.pharmasoft.se
-------------------------------------------------------------------------

---

From: "Kent Frazier" <[email-masked]>
Date: Wed, 27 Mar 1996 08:36:00 +0000

There is a utility called xtp which is a batch version of ftp. It
can be found at various sites (check with archie), usually 
associated with the ImageMagick software. Amongst
them

  ftp.cs.umass.edu  
/pub/rcf/X11R6/ultrix/contrib/programs/ImageMagick/xtp

> Subject:       Re: backing up over an ethernet network

> There are two ways I have done this on Unix SunOS 4.1.X. One is using 
> rcp in conjunction with a cronfile.  The other is using the .netrc file
> which controls automated ftps.  Use cron to initiate the ftp and the
> .netrc file is consulted to see what to do.  On my machine just doing
> a man on netrc will provide the details.
> 
> Jim
> 
> 
> On Thu, 28 Mar 1996, Fundamental wrote:
> 
> > 
> > any ideas how?
> > thanx 
> > \\\\////\\\\////\\\\\////\\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\
> > <Basho>
> > BY THE OWARI SEA
> > Over foam-flecked waves in the falling night, the wild
> > ducks' cries are dying, dim and white.
> > ////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\
> > The Australian Internet Company \\\\////\\\\////\\\\////\\\\ISP Par Exceliance
> > 
> > 
> > 
> 
>

---

From: Tim Capps <[email-masked]>
Date: Wed, 27 Mar 1996 12:08:57 -0800

>From [email-masked] Tue Mar 26 22:07:26 1996
>i have a scrip which backs up certain files at certain times (tcsh)
            ^ that's "script"

> i would like it to automagically ftp to another 

The easiest way to do that is to use rcp, not ftp.  So let's say you wanted
to copy a tar file from machine "red" to machine "blue" you'd do:

red# rcp /u/mydir/mytar.tar blue:/u/mybackupdir

Now, on "blue" you need a ".rhosts" file to make this work.  Let's say you
have user "fred" on both systems, and "fred" is the one initiating the
rcp from his crontab or whatever... in fred's home directory on blue, you'd
need a .rhosts file which contains at least the one line:

    red.mydomain.com fred

That's all there is to it!

Cheers,
Tim

---

From: Jules van Weerden <[email-masked]>
Date: Thu, 28 Mar 1996 08:32:47 +0100

Hi,
> a man on netrc will provide the details.
Another possibility is to instaal an ftp-mirror, like mirror-2.3.

You can find it eg at src.doc.ic.ac.uk [146.169.2.1]
directory: computing/archiving/mirror (shortcut packages/mirror).

>From the READMEf-ile:

Mirror is a package written in Perl that uses the ftp protocol to
duplicate a directory hierarchy between the machine it is run on and a
remote host.  It avoids copying files unnecessarily by comparing the
file timestamps and sizes before transfering.  Amongst other things
can optionally compress, gzip, and split files.

It was written for use by archive maintainers but can be used by
anyone wanting to transfer a lot of files over ftp.

Regards,				Jules van Weerden
					Fac Letteren, UU, NL