Subject: backing up over an ethernet network

From: Fundamental <[email-masked]>
Date: Thu, 28 Mar 1996 01:39:35 +1000 (EST)

does anyone know how i could automate an ftp session?

i have a scrip which backs up certain files at certain times (tcsh) it 
tars them to disk, then i would like it to automagically ftp to another 
machine on the same network, login and put the files there?

any ideas how?

thanx 

\\\\////\\\\////\\\\\////\\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\
<Basho>
BY THE OWARI SEA
Over foam-flecked waves in the falling night, the wild
ducks' cries are dying, dim and white.
////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\
The Australian Internet Company \\\\////\\\\////\\\\////\\\\ISP Par Exceliance

---

From: Andy Ellsworth <[email-masked]>
Date: Wed, 27 Mar 1996 00:35:07 -0600 (CST)

> does anyone know how i could automate an ftp session?

If you simply make a text file that contains the appropriate commands, 
pipe it into FTP, and pipe the output to a file (or /dev/null), that 
should work.  Something like:

  ftp < foo.txt > ftp-log.txt

-should- work fine.  (With the emphasis on 'should' -- I've done what you 
describe before, but it's been a while, and the details are a bit 
sketchy...but you get the general idea.)

Andy Ellsworth             | "...The wind was not the beginning.  There are
[email-masked]         | neither beginnings nor endings to the turning of
Assistant Admin, wuarchive | the Wheel of Time.  But it was _a_ beginning..."
http://cec.wustl.edu/~are1 |          --The Wheel of Time saga, Robert Jordan

---

From: Andrew Bennett <[email-masked]>
Date: Tue, 26 Mar 1996 22:43:11 -0800 (PST)

> does anyone know how i could automate an ftp session?

You might want to look into a package called Expect.  It's basically a 
scripting language that one can use on unix machines to automate 
interactive processes, like an ftp session.

I know O'Reilly & Associates have a book covering it.  I don't own the
book, and can't vouch for it's wholeness.  But you might want to check 
out their website at http://www.ora.com/, specifically the 
http://www.ora.com/www/item/expect.html URL.

Andrew
-- 

  Andrew Bennett
  [email-masked], [email-masked]
  http://taz.hyperreal.com/~abennett/

---

From: "W. James Showalter" <[email-masked]>
Date: Wed, 27 Mar 1996 10:03:13 -0500 (EST)

There are two ways I have done this on Unix SunOS 4.1.X. One is using 
rcp in conjunction with a cronfile.  The other is using the .netrc file
which controls automated ftps.  Use cron to initiate the ftp and the
.netrc file is consulted to see what to do.  On my machine just doing
a man on netrc will provide the details.

Jim

---

From: David Perry <[email-masked]>
Date: Wed, 27 Mar 1996 14:44:18 +0000

I would look at the perl script mirror 2.3 for a basic 
concept. Bet it is close. Think I found it at a gnu 
site.Fundamental wrote:

David Perry

---

From: Carl Payne <[email-masked]>
Date: Wed, 27 Mar 96 14:15:49 -0700

> machine on the same network, login and put the files there?

Maybe I'm lost.  Yep, I bet that's it.  Regardless, I'll ask anyway:

Why don't you just use something better suited to task?

Amanda does a cross-ethernet / cross-network / cross-pen set / cross-your-heart backup to either a tar file on a "server" or to a tape machine on the server.  It's extemely configurable, uses its own port,  and is freeware (i think).

Apologies if that's just not going to work with you.

Carl

---

From: Carl Payne <[email-masked]>
Date: Wed, 27 Mar 96 15:57:05 -0700

Well, after opening my big mouth and mentioning Amanda, I got innundated with requests for it.  Rather than spend time I don't have uploading it to you all, please feel free to FTP it from me:

ftp2.fiber.net/pub/amanda-2.2.6.tar.gz

That ought to help you out.

Carl

---

From: Alex Gadget McColl <[email-masked]>
Date: Thu, 28 Mar 1996 09:31:41 -0700 (MST)

Why don't you just add an ftp statement to your shell script?
If you use ncftp you could have your passwd and login already stored 
in your ~/.ncftp file (or you could just login anonymously).
Hope that helps...
Alex.
% does anyone know how i could automate an ftp session?
% 
% i have a scrip which backs up certain files at certain times (tcsh) it 
% tars them to disk, then i would like it to automagically ftp to another 
% machine on the same network, login and put the files there?
% 
% any ideas how?
% 
% thanx 

Alex.

  ****************************************************************************
  * Alex McColl - Network System Administrator		[email-masked] *
  * Colorado Center for Astrodynamics Research	        Work  (303) 492-1308 *
  * University of Colorado at Boulder		        FAX   (303) 492-2825 *
  * Campus Box 431				  	Pager (303) 465-7556 *
  * Boulder, Colorado 80309-0431			Home  (303) 443-4665 *
  * http://kurgan.colorado.edu/personnel/professionals/mccollh               *
  ****************************************************************************