Subject: Re: FTPD File Permissions

From: Jeff Williams <[email-masked]>
Date: Mon, 04 Mar 1996 10:12:01 -0500

At 10:20 AM 3/1/96 -0600, you wrote:
>
>We are using the wu-ftpd software and when we transfer a file
>to our server the file permissions change.  
>
>We are getting:
>		-rw-rw-r--
>What we want:
>		-rw-r--r--
>
>Has anyone else ran into this problem?  What can we do to configure
>the program, where would we find the segment containing the file 
>permissions?
>
>Thank You,
>
>Vineet Choudhary
>Connect International, Inc.
>
>

I had the same problem.  I found in the list archive that you are supposed
to be able to do a #define CMASK 022 in the config.h and solve the problem.
I am running on Solaris 2.4 and found that did not solve my problem.
sys/param.h is included in ftpd.c after config.h and if redefines CMASK to
0.  Because CMASK is 0 ftpd.c uses CMASK 002.  The only way I saw around it
was to change the default in ftpd.c to 022.

Jeff Williams
Georgia Southern University
[email-masked]
(912) 681-5365

---

From: Jim Easton <[email-masked]>
Date: Wed, 6 Mar 1996 12:47:10 -0700 (MST)

> Georgia Southern University

I was having similar problems until I discovered the -u option
which sets the default umask at run time.

We are running wu-ftpd-2.4 on SunOS 4.1.4.

	Jim Easton