Subject: Re: Install wu-ftpd - Information and Problem

From: Michele Mercer <[email-masked]>
Date: Fri, 29 Mar 1996 09:02:57 -0500

Hi everyone,

I got past my problem with building wu-ftpd. My problem was that in the Makefilein the support directory, I needed to change the CC = cc to CC = gcc and it compiled fine. I'm using gcc 2.7.0. I still havn't gotten it to work though. This is frustrating. Anyway here's my problem.

Since we didn't have a c compiler or a gcc compiler on the machine I want to use wu-ftp on I had to build it on another machine. I built it on a sparc 5 and want to use it on a sparc 1+. But they both have the same OS. So after I built it I tared and zipped the file and ftped it to the sparc 1+. Untared, unzipped it. And tried to do a build install. Hit another snag, Solaris 2.4 didn't like the usage of the install command in the makefile. So I copied the files over using the command line. I then followed the rest of the directions and it still doesn't work. I was unclear of the two of the step though so maybe I can get verification from someone. I also ran the ckconfig it got through it o.k.

Steps I was unclear about.

1. Changing the /etc/inetd.conf file.
My file originally had this in it.
ftp	stream	tcp	nowait	root	/usr/sbin/in.ftpd	in.ftpd

I changed it to.
ftp	stream	tcp	nowait	root	/usr/local/bin/ftpd	ftpd

2. To kill and restart the inetd daemon I did this.
kill -HUP <pid>

Also can anyone tell me if there are changes I need to make anywhere else since I had to build it on one machine and want to install it on another?

Thanks michele
Haven't given up yet!!!!!
[email-masked]

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 14:43:21 +0000

> ftp     stream  tcp     nowait  root    /usr/local/bin/ftpd     ftpd

I think the ftpd file was installed to /usr/local/etc/ftpd wasn't it - I
too had the same problem with "build install" but after installing the
files manually it worked fine. 

> 2. To kill and restart the inetd daemon I did this.

That should do it - but i found "kill -9 <pid>" followed by "inetd -s"
to be better cos I wasn't sure the other one was working properly.

> Also can anyone tell me if there are changes I need to make anywhere else since I had to build it on one machine and want to install it on another?

I don't think the machines will make too much diff. since they are both
running Sol 2.4.

The only other changes you should need to make are to the conf file
ftpaccess, etc.

> Haven't given up yet!!!!!

Glad to here it!

Hope this helps....

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.