Subject: Re: Installing wu-ftpd

From: "Bill Kupiec" <[email-masked]>
Date: 29 Mar 1996 11:01:17 -0500

> Try adding -v to your CFLAGS in src/makefiles/Makefile.s41

Okay, tried the above and got:
.
.
gcc -g -DDEBUG -I.. -I../support -L../support -v -o ftpd ftpd.o ftpcmd.o
glob.o
logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o
authe
nticate.o conversions.o hostacc.o -lsupport
gcc version 2.3.3
 ld -e start -dc -dp -o ftpd /lib/crt0.o -L../support -L/usr/local/lib ftpd.o
ft
pcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o
pr
ivate.o authenticate.o conversions.o hostacc.o -lsupport -lgcc -lc -lg -lgcc
ld: Undefined symbol
   ___builtin_va_arg_incr
*** Error code 1
make: Fatal error: Command failed for target `ftpd'
.
.
Links to executables are in bin directory:
text    data    bss     dec     hex
122880  16384   9528    148792  24538   bin/ftpd
8192    8192    0       16384   4000    bin/ftpcount
8192    8192    0       16384   4000    bin/ftpshut
8192    8192    0       16384   4000    bin/ftpwho
8192    8192    0       16384   4000    bin/ckconfig
Done

But it seemed to create ftpd in the ../bin directory. I tried a build install
and got:

make args are :
make opts are :
mv -f /usr/local/etc/ftpd /usr/local/etc/ftpd-old
Installing binaries.
install -o bin -g bin -m 755 bin/ftpd /usr/local/etc/ftpd
install -o bin -g bin -m 755 bin/ftpshut /usr/local/bin/ftpshut
install -o bin -g bin -m 755 bin/ftpcount /usr/local/bin/ftpcount
install -o bin -g bin -m 755 bin/ftpwho /usr/local/bin/ftpwho
Installing manpages.
install -o bin -g bin -m 755 doc/ftpd.8 /usr/local/man/man8/ftpd.8
install: /usr/local/man/man8/ftpd.8: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `install'

Sorry for asking such a dumb question but, did it work?

-Bill

---

From: "W. James Showalter" <[email-masked]>
Date: Fri, 29 Mar 1996 11:36:10 -0500 (EST)

Bill,

The only thing I can think of is that one of your modules may be compiled
with the old bundled cc compiler.  The reason I think this is that /bin/cc
points to /usr/lib/compile.  /usr/lib/compile calls /usr/lib/ccom and
builtin_va_arg_incr is referenced in /usr/lib/ccom.  This is the only place
where I have found this variable. 

My recommendation is to do the following:

1. Do a build clean.
2. Then when you build the ftpd do
     build s41 CC=gcc

This should ensure that all your objects were compiled with the gcc 
compiler.

I hope this helps!
Jim

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 16:41:15 +0000

> make: Fatal error: Command failed for target `ftpd'

I see that u are using the gcc 2.3.3 compiler (hummmmm.) - not to worry (only joking) but
there is a line (or 2) in the INSTALL file as follows

"
    If you are using gcc...  Make sure that you the include files have been
    properly "fixed" according to the gcc 2.3.3 INSTALL instructions.  If
    the server crashes before printing the banner message (during a vprintf)
    this is most probably the cause.
"

which may (or may not) solve this problem.

> make: Fatal error: Command failed for target `install'

What's in a man page anyway??
Install it by hand (probably best to put it under man/man1m as well 'cos mine didn't get
picked up under man8

At least it installed the binaries for u - that's not been done on Solaris yet!

> Sorry for asking such a dumb question but, did it work?

Eh - I've asked dumber ones - after all you can't clean a window with a shovel!

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.			UNIX - "It's not what you know, but what can you 
NG7 2RD.
				work out from the errors that counts"