Subject: Logging - /usr/adm/xferlog

From: Michele Mercer <[email-masked]>
Date: Fri, 29 Mar 1996 12:05:55 -0500

Okie dokie,

I finally have wu-ftpd up and running but now I want to turn logging on.
>From what I understand I need to have an entry in the ftpaccess file  to have messages go to the /usr/adm/xferlog file. This are my entries:

log 	commands 	anonymous
log 	transfers 	anonymous outbound

Currently root owns my xferlog file with group bin and chmod 777. When I login
anonymously should all commands be written to the /usr/adm/xferlog file? I'm not getting anything? My /var/log/syslog doesn't show anything either. Any clue as to what's going on.

Thanks Michele 
[email-masked]

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 17:48:11 +0000

Michele Mercer wrote:
> anonymously should all commands be written to the /usr/adm/xferlog file? I'm not getting anything? My /var/log/syslog doesn't show anything either. Any clue as
> 
> Thanks Michele
> [email-masked]

I haven't actually got the command logging to work either - Anyone out
there who has - To quote an old TV phrase - "We'd like to hear from you
today - phone now on......."

But, in its favour, it does log transfers. Have a shell windows runnign
the command "tail -f /usr/adm/xferlog" and do an anonymous login.
Transfer a few files at random and watch the tail window - you should
see details of the logging there.

Glad to hear it works!

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.

---

From: Vincent Cojot <[email-masked]>
Date: Fri, 29 Mar 1996 14:14:32 -0500 (EST)

> anonymously should all commands be written to the /usr/adm/xferlog file? I'm not getting anything? My /var/log/syslog doesn't show anything either. Any clue as to what's going on.

Do you have your inetd.conf entry set to:

ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  /usr/sbin/ftpd -a

If you have:

ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  /usr/sbin/ftpd

then it may be the reason why it is ignoring settings in your ftpaccess 
file. Just a thought...

,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,
Vincent S. Cojot, Computer Engineering. STEP administration.
Ecole Polytechnique de Montreal, Comite Micro-Informatique.
[email-masked], [email-masked]

They cannot scare me with their empty spaces
Between stars - on stars where no human race is
I have it in me so much nearer home
To scare myself with my own desert places.       - Robert Frost

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Fri, 29 Mar 1996 21:33:14 +0100 (MET)

> anonymously should all commands be written to the /usr/adm/xferlog file? I'm not getting anything? My /var/log/syslog doesn't show anything either. Any clue as to what's going on.

The xferlog is written with the umask the ftpd inherits from inetd, which is
mostly 777. Simply chmod it as it is only appended.

Commands are logged using syslog indeed, but you need to check at which 
loglevel those are written and check syslog.conf where those should end up.

                                                Koos van den Hout

[ Could you limit your linelength to 77 chars ? makes it more readable ]

-- 
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  Quando Omni Flunkis Moritati (If all else fails - play dead)

---

From: "W. James Showalter" <[email-masked]>
Date: Fri, 29 Mar 1996 15:57:51 -0500 (EST)

For me to correctly log the commands I had to modify my /etc/syslog.conf
file to include the daemon.info message types.  So I put the following
in the /etc/syslog.conf file:

daemon.info                          /var/adm/ftpmsgs

Then I created an empty file called /var/adm/ftpmsgs, and HUP'd the 
syslogd.  Remember to make sure to use tabs and *not* spaces in the
syslog.conf file or it won't work.  Since all daemon.info messages
are written to this log file I am going to use one of the local
facilities LOCAL0-7 defined in syslog.h to log *only* ftp messages
to the file.

Jim