Subject: Installing wu-ftpd

From: "Bill Kupiec" <[email-masked]>
Date: 28 Mar 1996 08:59:55 -0500

Time:8:31 AM
Subject:     Installing wu-ftpd                               Date:3/28/96

I'm new to wu-ftpd and I'm getting the following error(s) when trying to
install wu-ftpd. Can anyone shed some light on where I'm going wrong? (This is
on a Sun 4.1.3 machine).

# build s41
make args are :
make opts are :

Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o
syslog.
o
ranlib libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o
log
wtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o
authenti
cate.o conversions.o hostacc.o -lsupport
ld: -lgcc: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpd'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsu
pport
0: unknown flag -lang-c
0: unknown flag -g
gcc: installation problem, cannot exec cc1: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupp
ort
0: unknown flag -lang-c
0: unknown flag -g
gcc: installation problem, cannot exec cc1: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ftpwho: File exists
ln: ckconfig: File exists

Links to executables are in bin directory:
text    data    bss     dec     hex
122880  16384   9528    148792  24538   bin/ftpd
8192    8192    0       16384   4000    bin/ftpcount
8192    8192    0       16384   4000    bin/ftpshut
8192    8192    0       16384   4000    bin/ftpwho
8192    8192    0       16384   4000    bin/ckconfig
Done

Regards,
-Bill
------------------------------------------------------------
 Bill Kupiec
 Operations Manager
 Carnegie Institution of Washington
 [email-masked]
------------------------------------------------------------

---

From: Mike Arnold <[email-masked]>
Date: Thu, 28 Mar 1996 15:01:40 +0000

> ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o

all this is OK .... just making sure the config files haven't been edited
 
> make: Fatal error: Command failed for target `ftpd'

this is a fairly straightforward error - the compiler can't find the lib file libgcc????? make sure its in the
path or a link to it is in the path.

/opt/FSFgcc/lib/gcc-lib/sparc-sun-solaris2.5/2.7.1/libgcc.a is what mine is called

if it can't find this in your path then it can't link in its functions.

> make: Fatal error: Command failed for target `ftpcount'

A similar thing - cc1 is the precompiler for gcc, and is probably in the gcc bin directory. add a link in
/usr/local/bin to this file (or /usr/bin/ if you like!)

> 8192    8192    0       16384   4000    bin/ckconfig

Once these two links have been created then it should compile (or at least try!)

> -Bill

Don't worry - I was in a similar position for a Solaris 2.5 build last week!

Hope that helps

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 10:23:36 +0000

> install wu-ftpd. Can anyone shed some light on where I'm going wrong? (This is

Just a small point (.) - you are running gcc 2.3.3 or better aren't you?