Subject: solaris dev/tcp dev/zero

From: Fundamental <[email-masked]>
Date: Wed, 13 Mar 1996 20:15:19 +1000 (EST)

after reading the FAQ, it seems that wu-ftpd running on a solaris machine 
needs the following files ~ftp/dev/tcp and dev/zero

but these devices (as far as i know) can not be "cp" ... could someone 
tell me how to get these files (or dummy versions) into ~ftp/dev

thanx

\\\\////\\\\////\\\\\////\\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\
<Issa>
BONDAGE
The caged bird gazes at the butterflies
Beyond the bars with longing - watch its eyes!
////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\
The Australian Internet Company \\\\////\\\\////\\\\////\\\\ISP Par Exceliance

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Wed, 13 Mar 1996 08:21:30 +0100 (MET)

>From the Solaris 2.3 ftpd(1m) man page (the faq points to this) :

     ~ftp/dev    Make this directory owned by the super-user  and
                 unwritable  by  anyone.  First perform ls -lL on
                 the device files listed below to determine their
                 major  and  minor  numbers,  then  use  mknod to
                 create them in this directory.

                 /dev/zero
                 /dev/tcp
                 /dev/udp
                 /dev/ticotsord

                                                 Grtx. KH

-- 
  **  FAQ on current wu-ftpd at http://www.hvu.nl/~koos/wu-ftpd-faq.html  **
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  We are root. You will be assimilated. Resistance is futile. Clickety Click

---

From: Michael Clarkson <[email-masked]>
Date: Wed, 13 Mar 1996 09:12:35 +0000 (GMT)

> tell me how to get these files (or dummy versions) into ~ftp/dev

Hi, try this:

 	cd ~ftp/dev
	(cd /dev; tar chf - tcp zero) | tar xf -
	chmod 644 tcp zero

Hope that helps! 

Michael Clarkson
 ______  __   __    __ _  _
|  ____|/  \  \ \  / /(_)| |      FAXiL,    
| |___ / /_ \  \ \/ /  _ | |      The Wellcome Wing,
|  ___| ____ \  >  <  | || |      The General Infirmary,
| |  / /    \ \/ /\ \ | || |____  Leeds LS1 3EX, UK.
|_| /_/      \_\/  \_\|_||______| Tel: 0113 292 2479 Fax: 0113 242 0926