Subject: Installing wu-ftpd on a Solaris 2.4 machi

From: [email-masked]
Date: Thu, 28 Mar 1996 11:00:45 -0500

I also am new to wu-ftpd and am having problems during the build.

These are the errors I'm getting:

gcc  -g -DDEBUG -I.. -I../support -L../support   -c hostacc.c -o hostacc.o
gcc  -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o private.o authenticate.o conversions.o hostacc.o -lsupport -lsocket -lnsl -lgen
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors.  No output written to ftpd
make: *** [ftpd] Error 1

Making ftpcount.
gcc  -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport -lsocket -lnsl -lgen 
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors.  No output written to ftpcount
make: *** [ftpcount] Error 1

Making ftpshut.
gcc  -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport -lsocket -lnsl -lgen
ld: fatal: library -lsupport: not found
ld: fatal: File processing errors.  No output written to ftpshut
make: *** [ftpshut] Error 1

Apparently it's haveing a problem iwth library -lsupport. I'm 
not familiar with this. Does anyone know how to fix this.

Thanks Michele
[email-masked]

---

From: Mike Arnold <[email-masked]>
Date: Thu, 28 Mar 1996 17:26:16 +0000

[email-masked] wrote:
> gcc  -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o realpath.o acl.o private.o authent

The library.a file is generated as an initial stage of the build process. If you've typed "build sol" it
should begin by creating the library from the ..../support directory that comes with the tarred files.

to check just "ls -lR | grep support" from the wu-ftpd-2.4 directory and see if its there!

	thale% build sol
	make args are : 
	make opts are : 

	Linking Makefiles.

	Making support library.
	gcc -g -DDEBUG   -c fnmatch.c
	gcc -g -DDEBUG   -c strcasestr.c
	gcc -g -DDEBUG   -c strsep.c
	gcc -g -DDEBUG   -c authuser.c
	rm -f libsupport.a
	ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
	touch libsupport.a

is what u should see when you begin the build!

Have fun :-)
 
-- 

Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.

---

From: "W. James Showalter" <[email-masked]>
Date: Thu, 28 Mar 1996 13:12:11 -0500 (EST)

One thing which might help track down these problems is to specify the 
-v arg to gcc.  The -lang-c, -lgcc are default values.  The -v will show the
compile and load time arguments as well as some pathname search information.

Jim