Subject: Re: Installing wu-ftpd

From: "Bill Kupiec" <[email-masked]>
Date: 28 Mar 1996 13:10:25 -0500

Mike,

> setenv LD_LIBRARY_PATH path_to_gcc_lib_file

Okay, I got that set and it seemed to have an effect. I think I'm getting
close, but now I'm getting:
.
.
.
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  hostacc.c
0: unknown flag -lang-c
0: unknown flag -g
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o
log
wtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o
authenticate.o conversions.o hostacc.o -lsupport
ld: Undefined symbol
   ___builtin_va_arg_incr
*** Error code 1
make: Fatal error: Command failed for target `ftpd'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsu
pport
0: unknown flag -lang-c
0: unknown flag -g

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o
-lsupp
ort
0: unknown flag -lang-c
0: unknown flag -g

Making ckconfig.
gcc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c
0: unknown flag -lang-c
0: unknown flag -g

Links to executables are in bin directory:
text    data    bss     dec     hex
122880  16384   9528    148792  24538   bin/ftpd
8192    8192    0       16384   4000    bin/ftpcount
8192    8192    0       16384   4000    bin/ftpshut
8192    8192    0       16384   4000    bin/ftpwho
8192    8192    0       16384   4000    bin/ckconfig
Done

Any thoughts?

-Bill

---

From: "W. James Showalter" <[email-masked]>
Date: Thu, 28 Mar 1996 13:23:20 -0500 (EST)

Bill,

Since gcc passes the -lang-c flags to the loader it could be that the
wrong loader is referenced.  Try specifying the -v option on the gcc
command.  

Jim

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 10:03:19 +0000

Greetings Bill....

Sorry for the delay - different time zones and all that (ba... excuses!)

> make: Fatal error: Command failed for target `ftpd'

I've had a look at the Makefile.s41 that comes with the wu-ftpd2.4 src, and I can't
find any ref to the flags -lang-c and -g. but it looks like these are being passed to
ld in some way!

Sorry - this one's got me stumped! If I think of anything I'll let u know.

> Any thoughts?

The Canary islands are nice this time of year!

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.