Subject: Re: wu-ftp-2.4 and telnet

From: Ken Lui <[email-masked]>
Date: Tue, 12 Mar 1996 12:55:32 -0500 (EST)

On Tue, 12 Mar 1996 10:20:33 -0700 (PDT) LES MAYEDA TECH 
SUPPORT/ISS X6656 <[email-masked]> wrote:
...
>Should there be some shell script in the dummy shell that
>prevents them from logging in using telnet?  
>
What about /bin/false. But make sure you add this to your /etc/shells or they 
wont be able to ftp at all.

Ken Lui 
City of Edmonton

---

From: Shane Castle <[email-masked]>
Date: Tue, 12 Mar 1996 13:39:55 -0700 (MST)

>wont be able to ftp at all.

Appended here is s small C program which can be used as the
user's shell in /etc/passwd.  I think it does the job nicely.

Shane Castle             | "Perfection, then, is finally achieved, not
Boulder County Info Svcs | when there is nothing left to add, but when
Boulder CO USA           | there is nothing left to take away."
                         |                - Antoine de Saint-Exupery

----- ftponly.c ---------------------------------------------------
/*
 * ftponly.c
 *
 * Programmer:	Shane Castle
 * Date:	March 12, 1996
 *
 * Purpose:	To print a message indicating that this account
 *		is valid for FTP only and then to exit.
 */

#include <stdio.h>

main(argc, argv)

int  argc;
char *argv[];

{ /* main */

    fprintf(stdout,"---------------------------------------\nThis account is valid for FTP use only.\n---------------------------------------\n");
    exit(1);
}
----- end ftponly.c ---------------------------------------------------