Subject: Re: Installing wu-ftpd

From: "Bill Kupiec" <[email-masked]>
Date: 28 Mar 1996 11:33:55 -0500

>> Making ftpd.
>> gcc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o
> glob.o
>> log
>> wtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o
> private.o
>> authenti
>> cate.o conversions.o hostacc.o -lsupport
>> ld: -lgcc: No such file or directory
>> *** Error code 1
>> make: Fatal error: Command failed for target `ftpd'
 
> this is a fairly straightforward error - the compiler can't find the lib
> file libgcc????? make sure its in the
> path or a link to it is in the path.
> 
> /opt/FSFgcc/lib/gcc-lib/sparc-sun-solaris2.5/2.7.1/libgcc.a is what mine
> is called
> 
> if it can't find this in your path then it can't link in its functions.

I made sure libgcc.a and cc1 were in my path, but I'm still getting:

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o
-lsu
pport
0: unknown flag -lang-c
0: unknown flag -g
ld: -lgcc: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Should I be concerned about the unknown flags?

Also, John R. Johnson wrote:

> Do you have the path for the gcc library in LD_LIBRARY_PATH?

I'm not sure about this one. Where is LD_LIBRARY_PATH or how do I set the path
for it?

-Bill

---

From: Mike Arnold <[email-masked]>
Date: Thu, 28 Mar 1996 17:41:43 +0000

> I'm not sure about this one. Where is LD_LIBRARY_PATH or how do I set the path

OK, this is one way round it 

setenv LD_LIBRARY_PATH path_to_gcc_lib_file
(for a csh of course)

the other way would be to put a soft link in the /usr/lib 

ln -s /path_to_gcc_lib_file/libgcc.a /usr/lib/libgcc.a

(There's always more than one way to skin a cat!)

The library is probably hiding where it was compiled!

try 
	"ls -lR /usr | grep 'gcc'"

to locate the directory - this may take some time!

TTFN

Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.