Subject: Re: wu-ftp-2.4 and telnet

From: Willy Hertanu <[email-masked]>
Date: 12 Mar 96 15:12:14 EDT

>>Should there be some shell script in the dummy shell that
>>prevents them from logging in using telnet?  
>>

>What about /bin/false. But make sure you add this to your /etc/shells or they 
>wont be able to ftp at all.

Ken,

Is that OS specific? because I couldn't even find the file (/bin/false) on my 
BSD unix (2.1).

Thanks.

WH

---

From: "Bob Izenberg" <[email-masked]>
Date: Tue, 12 Mar 1996 17:21:09 -0600 (CST)

# Is that OS specific? because I couldn't even find the file
# (/bin/false) on my BSD unix (2.1).

That surprises me, but you can always make one by coding up a
shell script or compiled program that returns a value of 255.
You can also have /bin/true return a value of 0.
Good luck,

Bob
-- 
 ============================================================
   bob izenberg                    phone: +1 (512) 306-0700
   sig.net network operations                   [email-masked]
 ============================================================

---

From: Fundamental <[email-masked]>
Date: Wed, 13 Mar 1996 19:14:19 +1000 (EST)

i have wu-ftpd up and running, but with two problems, and i cant find 
what what i missed-

When you anonymously ftp to the machine with the wu-ftp you get in fine, 
but when i do an ls i get this error ..

200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number

AND

when i try and login as a normal user, (ie, not anonymously) this happens
530 User kaneda access denied...
Login failed

any help appreciated:)

\\\\////\\\\////\\\\\////\\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\
<Issa>
BONDAGE
The caged bird gazes at the butterflies
Beyond the bars with longing - watch its eyes!
////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\
The Australian Internet Company \\\\////\\\\////\\\\////\\\\ISP Par Exceliance

---

From: Hung Hing Fai <[email-masked]>
Date: Wed, 13 Mar 1996 10:40:53 +0800 (HKT)

> 425 Can't create data socket (0.0.0.0,20): Bad file number

When you use anonymous ftp, wu-ftpd will chroot to ~ftp, and
/usr/lib/libc.so.1.8 are no longer visible.

There are two possible solutions:
1. copy /usr/lib/libc.so.1.8, /usr/lib/ld.so, /usr/lib/libdl.so.1.0 to
   ~ftp/usr/lib, OR
2. recompile 'ls' with -static.

> 530 User kaneda access denied...

Check whether kaneda is using a shell not listed in /etc/shells,
e.g. /usr/local/bin/tcsh.  If not, add it to /etc/shells.

---

From: [email-masked] (Mikiel Mifsud)
Date: Wed, 13 Mar 1996 23:21:12 +1000 (EST)

> 2. recompile 'ls' with -static.

thanx, ive got this problem licked:)

> e.g. /usr/local/bin/tcsh.  If not, add it to /etc/shells.

i dont have this file /etc/shells?

do i just create one?

thanx

---

From: Hung Hing Fai <[email-masked]>
Date: Wed, 13 Mar 1996 13:12:32 +0800 (HKT)

> i dont have this file /etc/shells?

Create /etc/shells and put the name of the user shells in.

/bin/sh
/bin/csh
/usr/local/bin/tcsh

The paths the shells may be different on your system.

-- hfhung