Subject: User Login STILL failing :(

From: Fundamental <[email-masked]>
Date: Thu, 14 Mar 1996 20:18:49 +1000 (EST)

>From [email-masked] Thu Mar 14 20:17:48 1996
From: [email-masked] (Admin)
Subject: wu
To: [email-masked]
Date: Thu, 14 Mar 1996 10:35:12 +1000 (EST)
Content-Length: 834       
Status: O

My User Logins are still failing!

im about to pull my hair out, i know i have done something wrong 
(configuration wise) but i have no idea what ... here are the pertinent 
config files, if somone could see what ive done wrong and tell me, i 
would *VERY* much appreciate it

im trying to get it working on solaris2.4 x86

thanx in advance ...

my /etc/passwd entry-

ftp:x:60001:60001:anonymous ftp:/home/ftp:/bin/false

my /etc/shadow entry -
 
ftp:*:6445::::::

my /etc/shells and /usr/local/etc/shells entry

# /etc/shells: valid login shells.
# $Id: shells,v 3.1 1995/02/15 14:48:36 imurdock Exp $

#/bin/bash
/usr/bin/csh
/usr/bin/sh
#/usr/bin/es
/usr/bin/ksh
/usr/bin/rc
/usr/bin/tcsh
#/usr/bin/zsh
/usr/bin/false
/bin/ftponly

ftpaccess, ftp.pid, ftpconversions, ftpgroups, and ftphosts are all stock 
standard, unmodified 

\\\\////\\\\////\\\\\////\\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\
<Buson>
SOWN WITH GOLD
How far these fields of rape in blossom run:
East to the moonrise, west to the setting sun!
////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\\\////\\
The Australian Internet Company \\\\////\\\\////\\\\////\\\\ISP Par Exceliance

---

From: "Steve R. Harding" <[email-masked]>
Date: Thu, 14 Mar 1996 06:08:21 -0800 (PST)

> # $Id: shells,v 3.1 1995/02/15 14:48:36 imurdock Exp $

You have /bin/false as ftp's login shell, but only /usr/bin/false in 
/etc/shells.  Could this be the problem?

-------------------------------------------------------------------------------
Steve Harding                                      Email: [email-masked]
TACTech, Inc.                                      Voice: (714) 974-7676 ext.15
Yorba Linda, CA