Subject: Install Working!!!! - Help with ftpaccess

From: Michele Mercer <[email-masked]>
Date: Fri, 29 Mar 1996 10:28:26 -0500

Yeah, It works!!!!! 
sort of 

Can someone give me an example of an ftpaccess file that allows anonymous user's to log in. I'm getting access denied.

Michele
[email-masked]

---

From: Mike Arnold <[email-masked]>
Date: Fri, 29 Mar 1996 16:20:44 +0000

> Can someone give me an example of an ftpaccess file that allows anonymous user's to log in. I'm getting access denied.

I've sent it at the end of the file. However, you should also check the
file syslog writes to using the tail command.
Look in /usr/adm for the file last written to that is an ascii file
(mine is called messages!)

try "tail -f /usr/adm/<whatever the latest log file is>" and look for
errors like this 

	> Mar 29 12:10:11 thale ftpd[26794]: FTP LOGIN REFUSED (bad 				shell)
FROM thale [128.243.116.150], mike 

which are to do with the /etc/shells file. If you have set up the ftp
user account properly then the shell should be /bin/false (ie. no login
shell) But this MUST appear in the /etc/shells file. I've included the
/etc/shells file for you as well.

-- 
Dr. Mike Arnold			Tel: +44 1159 791216			
Department of Life Science	Fax: +44 1159 513251					
University of Nottingham	URL: Under Construction					
University Park,
Nottingham.
NG7 2RD.

######################################

/etc/shells

######################################

/bin/false
/bin/csh
/bin/sh
/bin/tcsh
/bin/bash
/bin/ksh
/usr/bin/ksh
/usr/lib/rsh

######################################

/usr/local/etc/ftpaccess

######################################

class   real    real    *
class   anon    guest,anonymous *

limit   real    25      Any             /etc/ftpmsgs/msg.toomany
limit   anon    15      Any             /etc/ftpmsgs/msg.anon_toomany

loginfails      2

passwd-check    rfc822  warn

banner  /minnesota1/ftp/etc/ftpmsgs/banner

readme  README*    login
readme  README*    cwd=*

message /etc/ftpmsgs/welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             no             local remote

# commands - all default to yes for everybody

delete          no      guest,anonymous
overwrite       no      guest,anonymous
rename          no      guest,anonymous
chmod           no      anonymous
umask           no      anonymous

upload  /minnesota1/ftp/pub/incoming    * yes 

log commands anonymous,real     inbound,outbound 
log transfers anonymous,real inbound,outbound

shutdown /etc/ftpmsgs/shutmsg

email [email-masked]