Subject: Re: 421 Service not available, remote server has closed connection

From: [email-masked] (Roland Siebelink)
Date: Thu, 22 Feb 1996 18:05:22 +0100

>Whoops! I overheard Roland Siebelink saying:
>> When I put it into inetd.conf, however, the server gives the following reply:
>
>> $ ftp ftp.allmansland.com
>> Connected to avrell.allmansland.com.
>> 421 Service not available, remote server has closed connection
>
>Did you kill -HUP <inetd pid> ?

I did, that was not the problem.

The problem was that my inetd.conf had a TCP wrapper around the old ftp
daemon and I had simply copied that to the new entry. Now that I have
removed the TCP wrapper, it seems to work fine.

HOWEVER: does this not mean that I now have a bigger security hole than before?

--
Roland Siebelink <[email-masked]>
Allmansland/De Schutter Digital Media nv/sa
Priemstraat 53 Rue du Poincon - B-1000 Brussels 1 - Belgium
Tel +32 2 5481700 - Fax +32 2 5481717 - http://www.allmansland.com/

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 22 Feb 1996 20:41:06 +0100 (MET)

> I did, that was not the problem.

It even boms when telnetting to the ftp port. I tried ;-)

> HOWEVER: does this not mean that I now have a bigger security hole than before?

Access to your ftp port isn't properly logged now.

Two possibilities :

your tcp-wrapper setup was denying all those connections. 
something in the way tcp-wrapper is called made it stop.

check your syslog.

                                            Grtx. KH

-- 
  **  FAQ on current wu-ftpd at http://www.hvu.nl/~koos/wu-ftpd-faq.html  **
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  We are root. You will be assimilated. Resistance is futile. Clickety Click

---

From: Vincent Cojot <[email-masked]>
Date: Thu, 22 Feb 1996 16:05:19 -0500 (EST)

About the 'remote server has closec connection" problem.. what about the 
/etc/shutdown file? does it exist and does the config file point to it? 
if so, then this behaviour is normal (I think, been some time since I had 
that problem)..

,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'`^`'~*-,
Vincent S. Cojot, Computer Engineering.
Ecole Polytechnique de Montreal, Comite Micro-Informatique.
[email-masked], [email-masked]

They cannot scare me with their empty spaces
Between stars - on stars where no human race is
I have it in me so much nearer home
To scare myself with my own desert places.       - Robert Frost