Subject: ls cutting of 1st 2 chars

From: [email-masked] (Vard Lott)
Date: Fri, 16 Feb 1996 16:25:17 -0800

Anyone have a problem with Academ wu-ftpd
2.4 beta 9 chopping off the first two
characters of the files/dirs on an ls?  I'm
running on Solaris 2.4. This happens for
both anonymous and real users.  It also
happens on two different machines (both
SPARC/Solaris 2.4).

WHAT DOES WORK:
ls -al works for all users. dir works for
all users.  Everything works under the stock
Solaris ftpd for all users.  Everything
works under wu-ftpd 2.4 beta 3 (an earlier
version, that is) for all users.

WHAT I'VE TRIED:
I've been through the faq, the list, the
docs, readmes, Solaris ftpd man page,
Managing Internet Info book, etc., etc. 
Also, I ran truss on ~ftp/bin/ls and
verified the presence and perms of my
libraries.  I've tried both /bin/ls and
/usr/ucb/ls.  No luck.

Can anyone who's got beta 9 running
successfully on Solaris 2.4 on SPARC send me
their config and any clues/suggestions? 
Just like to try the list before I dive into
the code, since it appears to be the ftpd
that's the culprit.

Thanks,
VL

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Sat, 17 Feb 1996 20:36:20 +0100 (MET)

> happens on two different machines (both

Sounds familiair. You have /usr/ucb/cc in your path. Which screws up
include dirs/lib dirs hopelessly. Make a link from /usr/ccs/bin/cc to
/opt/SUNWspro/SC2.0.1/cc

lrwxrwxrwx   1 root     other         24 Jun  6  1995 /usr/ccs/bin/cc -> /opt/SUNWspro/SC2.0.1/cc*

This will make wu-ftpd and lots of other stuff compile a lot better.

                                               Grtx. KH

-- 
  **  FAQ on current wu-ftpd at http://www.hvu.nl/~koos/wu-ftpd-faq.html  **
  Koos van den Hout,     Internetter, Unix freak, ISFJ and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  We are root. You will be assimilated. Resistance is futile. Clickety Click