Subject: Compiling wu-ftpd

From: Craig Hutchison <[email-masked]>
Date: Sat, 10 Feb 1996 23:58:16 -0500

Hi,

I had asked about compiling ftpd and you had suggested I get the beta
version.  I did, and for some reason it still doesn't work.  The
compiling process seems to work very well up to a point with no warnings
or errors, but the it says :
	Make ftpd.
	Make: ***No rule to make target `ftpd'. Stop.
Do you know what is wrong?  

Craig Hutchison
DACnet

---

From: [email-masked] (Dan Foster)
Date: Sun, 11 Feb 1996 00:35:37 -0400

>Do you know what is wrong?

Yup. You might want to read the 'INSTALL' file. :) This is a part of it:

INSTALLATION INSTRUCTIONS as of $Date: 1995/12/11 08:09:37 $

1a. Type "./build xxx" in the root of the source tree.

    where xxx is one of:
        gen : generic make (copy this when porting to a new system)
        aix : IBM AIX
        bsd : BSD
        bdi : BSD/OS
        dgx : Data General Unix
        dyn : Dynix
        fbs : FreeBSD
        hpx : HP-UX
        isc : ISC (Interactive Unix)
        lnx : Linux (tested on 0.99p8)
        nbs : NetBSD
        nx2 : NeXTstep 2.x
        nx3 : NeXTstep 3.x
        osf : OSF/1
        ptx : ???
        sco : SCO Unix 3.2v4.2
        sgi : SGI Irix 4.0.5a

Sounds like you're building on a Linux box.. try a 'build lnx'. But I'd
recommend reading any INSTALL and README files because there are some
Linux-related information (you might have to edit a couple of files to get
the binary to work the way you want it..i.e. with shadow password support or
not, depending on if you've installed shadow on your system, etc..).

-Dan
Internet: [email-masked]