Subject: Users can't log in

From: Jane Ferreira Cunha <[email-masked]>
Date: Thu, 1 Feb 1996 15:42:22 -0600 (CST)

I installed wu-ftpd in a RS/6000 (AIX 3.2.5), and all went all
 right. But now the users that don't use csh (some use ksh or bash) are
 not accepted, they receive the message "permission denied" . Do I have
 to change something in the files ftpaccess, ftpgroups, etc?

			TIA,

				Jane

  %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
  %                                                %
  %  Jane Ferreira Cunha                           %
  %  Network Manager                               %
  %  TELESC                                        %
  %  Florianopolis - SC - Brasil                   %
  %                                                %
  %  Tel. +55 48 231-2600                          %
  %  Fax  +55 48 231-2611                          %
  %  e-mail : [email-masked]                   %
  %                                                %
  %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 1 Feb 1996 21:46:10 +0100 (MET)

>  to change something in the files ftpaccess, ftpgroups, etc?

Close ;-)

/etc/shells

contains a list of valid shells for some actions, including ftp. Since
csh is accepted, I guess you just have to add the full paths of the other
shells (one each line).

SEE ALSO
	shells(8s)

;-)

                                         Grtx. KH

-- 
  **  FAQ on current wu-ftpd at http://www.hvu.nl/~koos/wu-ftpd-faq.html  **
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-30-6036637 28k8)
  [email-masked] (Work)  <-- finger -l for PGPkey    (+31-30-6056619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  We are root. You will be assimilated. Resistance is futile. Clickety Click

---

From: Bill Pemberton <[email-masked]>
Date: Thu, 1 Feb 1996 16:25:03 -0500 (EST)

> csh is accepted, I guess you just have to add the full paths of the other

Or, you can get my patch to wu-ftpd that makes it get the valid shells the
AIX way.  It's at tigger.itc.virginia.edu:/pub/AIX/wu-ftpd.diffs.txt.gz .

-- 
Bill Pemberton                           [email-masked]
ITC/Unix Systems                         [email-masked]
University of Virginia                   uunet!virginia!wfp5p