Subject: Hanging FTPD's -Reply

From: [email-masked] (Vard Lott)
Date: Tue, 13 Feb 1996 10:05:51 -0800

We are most definitely having this problem. 
We have not yet upgraded to wu-ftpd.beta.9,
however.  But I have not yet tested beta 9
for the hanging connections.  Beta 9
documentation does not explicitly mention a
fix, though.

Here is my specific situation:

* Heavy traffic site.
* Solaris 5.4/SPARC 1000E
* wu-ftpd 2.4 beta 8
* hung ftpd's show as CLOSE_WAIT on a
netstat.
* hung ftpd's are processes that I can kill
and the ports are freed (no need to reboot
the server).
* the hung ftpd's appear to result from
ungraceful connection closings by browsers,
but I have not verified this.
* this is obvious, but increasing class
login limitations does not solve the
problem.  100 connections fill up and hang
as easily as 1000.

QUESTIONS:
* Anyone have a patch for beta 9?
* If not, anyone know to read the ftp-pid
files?  Specifically, I'd like to be able to
map a process to a port, so that I won't
just need to kill old processes, but *hung*
processes.
* (for Stan Barber) Did you receive the bug
I entered on this about 3-4 weeks ago?  I
wasn't sure.

Regards,
VL

>>> Barry Suskind <[email-masked]>
02/13/96 07:40am >>>
I have experienced the FTPD hang problem. In
fact I had to reboot the system to clear the
hung processes. I cannot seem to repeat this
problem that occured like a bump in the
night. 

What other people are experiencing hang
problems?
What are the conditions that cause the hang?
Can you repeat the problems?

I am on an HP-UX system running 9.05.

--  barry

|--------------------------|---------------------------------------------|
|Barry A. Suskind          |   "If it
weren't for change, your job would
|
|GE Information Services   | consist of
making sure the corporate abacus
|
|Email: [email-masked] | rods were
adequately greased" - John Cleese
|
|Phone: (301)-340-4667
|---------------------------------------------|
|SnailMail: 401 N Washington St, Mail Stop:
MC07D, Rockville MD, 20850
|

---

From: Andrew Bennett <[email-masked]>
Date: Tue, 13 Feb 1996 15:47:03 -0800 (PST)

> just need to kill old processes, but *hung*

I've been basically running the following command from a command prompt
every now and then:

ftpwho | grep IW | awk '{print $1'} | xargs kill

Granted, this kills any processes that have a state of IW, *or* have
"IW" in their site name.  I've found that in my case, this is the process
state of the hung processes on my machine.

I believe they are related to web browsers.  Many of them, before being
killed, have usernames like "WWWUser@", "Mozilla@", "Netscape@" etc.

Andrew
--

  Andrew Bennett
  [email-masked], [email-masked]
  http://taz.hyperreal.com/~abennett/