Subject: more tests on E-mail address

From: [email-masked] (Claude LE BERRE)
Date: Mon, 5 Feb 1996 19:02:00 +0000

I want to allow anonymous connection only to valid (true !!) E-mail address. I'm getting tired of "[email-masked]", "joe@" or "toto@" which does not really respect the "netiquette".

==> Is there a patch allowing ftpd to do more tests on E-mail address ?

At now, in my "ftpaccess", I use :
        # controle du passwd : email 
        passwd-check rfc822 enforce

[wu-ftp2.4 on a IBM/RS6000 aix3.2.5 system]

CLB.

---

From: Andrew Bennett <[email-masked]>
Date: Mon, 5 Feb 1996 23:23:07 -0800 (PST)

Claude LE BERRE said ::
> 
> 
> I want to allow anonymous connection only to valid (true !!) E-mail 
> address. I'm getting tired of "[email-masked]", "joe@" or "toto@" which 
> does not really respect the "netiquette".
> 

Actually, those addresses to pass rfc822 - that's why they show up in
your log.

The only way I can think of getting around it would be to use identd to
uniquely identify people coming in, and to deny them if they aren't using 
identd.  The drawback is that most of the known world doesn't use identd, 
so it's kinda moot.

Andrew
-- 

  Andrew Bennett
  [email-masked], [email-masked]
  http://taz.hyperreal.com/~abennett/