Subject: "425 can't create data socket" under Solaris 2.4

From: "Bob Izenberg" <[email-masked]>
Date: Tue, 13 Feb 1996 16:16:43 -0600 (CST)

Just built 2.4.2 beta 9 under Solaris 2.4 .  Identified
(non-anonymous) users can do an 'ls', but "anonymous" or "ftp"
fail with this error:

  425 Can't create data socket (0.0.0.0,20): Bad file number.

I see this error with the stock Solaris ls and the FSF ls.
ckconfig says that all is well.  File and directory perms are
what the docs say that they should be.
Suggestions?

Bob
-- 
 ============================================================
   bob izenberg                     home: +1 (512) 442-0614
   sig.net network operations       work: +1 (512) 306-0700
 ============================================================

---

From: [email-masked] (Stan Barber)
Date: 14 Feb 1996 07:11:09 GMT

>what the docs say that they should be.

Did you do a regular solaris stock anonymous ftp installation first? It will
put all the right files in the right places. "ftp.sesqui.net" is a Solaris
2.4 system running beta 9 just fine and does not have this problem.

Do that and then install wu-ftpd on top of that.
-- 
Stan   | Academ Consulting Services        |internet: [email-masked]
Olan   | For more info on academ, see this |uucp: {mcsun|amdahl}!academ!sob
Barber | URL- http://www.academ.com/academ |Opinions expressed are only mine.

---

From: Bob Izenberg <[email-masked]>
Date: Thu, 15 Feb 1996 10:50:08 -0600

At 07:11 AM 2/14/96 GMT, you wrote:

# Did you do a regular solaris stock anonymous ftp installation first? It will
# put all the right files in the right places.

Solved it by moving ~ftp to a partition that allowed suid execution.

Bob
-- 
 ============================================================
   bob izenberg                     work: +1 (512) 306-0700
   sig.net network operations       home: +1 (512) 442-0614
 ============================================================