Subject: Copying /dev/tcp,zero under Solaris

From: Gregg William Riedel <[email-masked]>
Date: Wed, 7 Feb 1996 16:08:49 -0500 (EST)

Okay,

   The FAQ mentions that under Solaris 2.4, I have to have
~ftp/dev/tcp and ~ftp/dev/zero installed.

   My real files in /dev are:

lrwxrwxrwx  1 root 29 Sep 19 18:08 /dev/tcp -> ../devices/pseudo/clone@0:tcp
lrwxrwxrwx  1 root 27 Sep 19 18:08 /dev/zero -> ../devices/pseudo/mm@0:zero

And the files in ~ftp/dev are:

lrwxrwxrwx  1 root 29 Feb  7 16:04 tcp -> ../devices/pseudo/clone@0:tcp
lrwxrwxrwx  1 root 27 Feb  7 16:04 zero -> ../devices/pseudo/mm@0:zero

And yet I get:

# chroot ~ftp /bin/ls
ld.so.1: /bin/ls: fatal: /dev/zero: can't open file: errno=2
Killed

Any help would be appreciated...

Gregg Riedel, Chyron Corp.
[email-masked]

---

From: Luc Desrosiers <[email-masked]>
Date: Wed, 07 Feb 1996 16:33:18 -0500

> ~ftp/dev/tcp and ~ftp/dev/zero installed.

Just create them:

mknod c 11 42 tcp
mknod c 13 12 zero 

Luc Desrosiers
RISQ, CRIM

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 7 Feb 1996 16:46:26 -0500 (EST)

> ld.so.1: /bin/ls: fatal: /dev/zero: can't open file: errno=2
	First guess would be that since ftpd chroot's to ~ftp when it
starts, the symlinks are invalidated.  I know that ~ftp/bin/ls can't
be a symlink for that reason, but I've not used Solaris yet, so this may
not be the case in the instance.

Marc G. Fournier | POP Mail  Telnet Acct  DNS Hosting
System           |  WWW Services   Database Services  | Knowledge, 
  Administrator  |                                    | Information and
 [email-masked]  |      WWW: http://www.ki.net        | Communications, Inc