Subject: Hanging FTPD's -Reply

From: [email-masked] (Vard Lott)
Date: Tue, 13 Feb 1996 10:06:42 -0800

We are most definitely having this problem. 
We have not yet upgraded to wu-ftpd.beta.9,
however.  But I have not yet tested beta 9
for the hanging connections.  Beta 9
documentation does not explicitly mention a
fix, though.

Here is my specific situation:

* Heavy traffic site.
* Solaris 2.4/SPARC 1000E
* wu-ftpd 2.4 beta 8
* hung ftpd's show as CLOSE_WAIT on a
netstat.
* hung ftpd's are processes that I can kill
and the ports are freed (no need to reboot
the server).
* the hung ftpd's appear to result from
ungraceful connection closings by browsers,
but I have not verified this.
* this is obvious, but increasing class
login limitations does not solve the
problem.  100 connections fill up and hang
as easily as 1000.

QUESTIONS:
* Anyone have a patch for beta 9?
* If not, anyone know to read the ftp-pid
files?  Specifically, I'd like to be able to
map a process to a port, so that I won't
just need to kill old processes, but *hung*
processes.
* (for Stan Barber) Did you receive the bug
I entered on this about 3-4 weeks ago?  I
wasn't sure.

Regards,
VL

>>> Barry Suskind <[email-masked]>
02/13/96 07:40am >>>
I have experienced the FTPD hang problem. In
fact I had to reboot the system to clear the
hung processes. I cannot seem to repeat this
problem that occured like a bump in the
night. 

What other people are experiencing hang
problems?
What are the conditions that cause the hang?
Can you repeat the problems?

I am on an HP-UX system running 9.05.

--  barry

|--------------------------|---------------------------------------------|
|Barry A. Suskind          |   "If it
weren't for change, your job would
|
|GE Information Services   | consist of
making sure the corporate abacus
|
|Email: [email-masked] | rods were
adequately greased" - John Cleese
|
|Phone: (301)-340-4667
|---------------------------------------------|
|SnailMail: 401 N Washington St, Mail Stop:
MC07D, Rockville MD, 20850
|

---

From: Barry Suskind <[email-masked]>
Date: Tue, 13 Feb 1996 16:45:05 -0500

Vard Lott wrote:
> * Solaris 5.4/SPARC 1000E
> * wu-ftpd 2.4 beta 8

My hang problem, I saw from netstat both "ESTABLISHED" and
"CLOSE_WAIT" connections. However, NONE of these connections
could be killed with a kill -9. I had to reboot. 

Has anybody specifically experienced this problem of requiring
a reboot to clear the hung processes? (HP-UX system)

-- 
barry

|--------------------------|---------------------------------------------|
|Barry A. Suskind          |   "If it weren't for change, your job would
|
|GE Information Services   | consist of making sure the corporate abacus
|
|Email: [email-masked] | rods were adequately greased" - John Cleese
|
|Phone: (301)-340-4667
|---------------------------------------------|
|SnailMail: 401 N Washington St, Mail Stop: MC07D, Rockville MD, 20850
|

---

From: [email-masked] (Stan Barber)
Date: 14 Feb 1996 07:06:51 GMT

>I entered on this about 3-4 weeks ago?  I

Anyone who sends the bug report/fixes to "[email-masked]" gets
an acknowledgement. If you did this, you should have gotten the ack if
I got it. If you didn't get it, send it again.

Sending it to this list or to my personal mail may not get it in the right
place for me to work with it.
-- 
Stan   | Academ Consulting Services        |internet: [email-masked]
Olan   | For more info on academ, see this |uucp: {mcsun|amdahl}!academ!sob
Barber | URL- http://www.academ.com/academ |Opinions expressed are only mine.

---

From: [email-masked] (Greg A. Lato)
Date: Wed, 14 Feb 1996 12:44:37 -0600

>a reboot to clear the hung processes? (HP-UX system)

I have had a number of "CLOSE_WAIT" and "CLOSING" sockets appear on my
machine when I run netstat (machine is campus web/gopher/ftp server).  The
thing is that this is not a hung process but a hung socket.  Most of the
times the process has been killed but the socket was not closed properly,
thus the socket hangs around in a stat of "CLOSING" but it takes up memory
that is used for network communications (mbufs).  The only way to get rid
of these hung sockets is to reboot the machine (at least with AIX 3.2).
Thus when someone starts a download/netscape access/etc. and then say turns
their machine off, you get a hung socket.  Over time these will build up
and will use up all your memory for the mbufs.

NOTE: this is talking about the result of running netstat.

I don't know if this will help with the specific problem, but this is
something that I have been battling with for the last few weeks and I
thought I would share what I have learned.

Greg

+--------------------------------------------------------------------------+
 Greg A. Lato
  CWIS Administrator                    WWW:   http://www.uwec.edu/~latoga/
  Computing and Networking Services     email: [email-masked]
  University of Wisconsin-Eau Claire           [email-masked] (personal)
  Eau Claire, WI USA 54702-4004         Phone: (715) 836-3058
                                   -----
       "Graduating May 1996 with BS in CS, But Looking for a Job Now."

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 14 Feb 1996 15:29:23 -0500

We've been having this same problem with 2.4 running on Linux 1.1.64 for over a year now.  Due to low volume, we've not worried much about it and have been working under the assumption that it's more a kernel problem than a wuftp problem.  since I now see a report of this with AIX, I'm not so sure.  Question: which version of wuftp is UW/Eau Claie running?

At our site I've noticed sockets in several states, not only CLOSE_WAIT and CLOSING, some even in ESTABLISHED with characters in the queues.  Also, I'm not sure all these sockets _are_ related to wuftp, hence my feeling that it might be a Linux kernel problem.

----------
From: 	Greg A. Lato[SMTP:[email-masked]]
Sent: 	Wednesday, February 14, 1996 1:44 PM
To: 	[email-masked]
Subject: 	Re: Hanging FTPD's -Reply

Greg