Subject: Re: Question about passwd and xferlog file

From: [email-masked]
Date: Mon, 18 Dec 95 17:19:40 gmt

> > >  Thanks for your mail, but I found do there is 
> > > log transfers anonymous,real inbound,outbound
                  ^          ^ Is this comma supposed to be here?
      Is the 's' supposed to be here? Does it matter?
On page 86 of "Managing Internet Information Services" it shows
no 's' in transfer; and no comma between types.

The reson I'm asking is that I can't get logging to work!

I have in my ftpaccess file:
log commands guest real
log transfer guest real inbound,outbound

And in my inetd.conf file:
ftp     stream  tcp     nowait  root    /usr/etc/in.ftpd        in.ftpd -laio

I have this version of ftpd:
220 gatekeeper FTP server (Version wu-2.4.2-academ[BETA-7](1) Sun Dec 17 15:26:43
 EST 1995) ready.

according to ckconfig: 
Checking _PATH_XFERLOG :: /usr/adm/xferlog
ok.

And this file is world writeable:
gatekeeper{neil}45: ls -l /usr/adm/xferlog
-rw-rw-rw-  1 root            0 Aug  1 15:11 /usr/adm/xferlog

I'm using SunOS 4.1.3_U1.
Can anyone help me?

--->Neil

---

From: "Steve R. Harding" <[email-masked]>
Date: Tue, 19 Dec 1995 06:05:52 -0800 (PST)

> I'm using SunOS 4.1.3_U1.

I am using Version wu-2.4(4) on a Solaris 2.3 Sparcstation.  My logging 
works, the ftpaccess file shows:

log transfers guest inbound,outbound
            ^ note the "s".

However, I do not have more than one user type being logged, so I can't tell
you about the comma.  Why not try two lines in your ftpaccess, like this:

log transfers anonymous inbound,outbound
log transfers real inbound, outbound

and see what happens.

Good luck.

-------------------------------------------------------------------------------
Steve Harding                                      Email: [email-masked]
TACTech, Inc.                                      Voice: (714) 974-7676 ext.15
Yorba Linda, CA