Subject: Re: Question about passwd and xferlog file

From: [email-masked] (Daniel Clar)
Date: Mon, 18 Dec 1995 08:36:53 +0200

>  Unfortunately the second problem still remain. That is 
>
> 2) I have access the anonymous ftp many times from another machine, but
>    the /usr/adm/xferlog still empty, why?
>
>  I have checked the pathname.h file. The defination path of xferlog is 
>indeed /usr/adm/xferlog. The sentence define this is 
>  #define _PATH_XFERLOG   "/usr/adm/xferlog"
>
>  So would please help me solve the problem again.
>
>  Thanks in advance,
>  Dawei

Do you have such a line in your ftpaccess file :

log transfers anonymous,real inbound,outbound

Daniel

o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o
|   Daniel Clar          	    	   e-mail : [email-masked]  |
|   Computer Operations Manager			  : [email-masked]	    |
|   Service Informatique Supelec                    and                     |
|   Plateau de Moulon                     DECUSF::CLAR_D or [email-masked] |
|   91192 Gif sur Yvette Cedex - France                                     |
|   Tel : (33 1) 69 85 14 87        	   Fax : (33 1) 69 85 12 34         |
o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o
BTW noboby answers about the lack of STOR and RETR message in the syslog file.

---

From: ldw <[email-masked]>
Date: Mon, 18 Dec 1995 21:13:50 -0800 (PST)

Dear Daniel,
 Thanks for your mail, but I found do there is 
log transfers anonymous,real inbound,outbound
in my ftpaccess file.
 Dawei

---

From: [email-masked] (Mark W. de Raad)
Date: Mon, 18 Dec 1995 23:37:13 +1030 (CST)

You (ldw) wrote.......
> log transfers anonymous,real inbound,outbound

Ok, silly question... what permissions does your xferlog file got?

:) It cant be this simple.. but hey... 

Mark
---
Mark W. de Raad			    			o
					             _ /-_
University of South Australia                 ......(_)>(_)
Australia

Telephone: (+6115) 717 472
In Australia: 015 717 472
For Quick response, please mail: [email-masked]

                              _\\|//_
                              ( O-O )
---------------------------o00--(_)--00o------------------------------
"What, Me Worry?" - Alfred E. Neuman

---

From: ldw <[email-masked]>
Date: Mon, 18 Dec 1995 22:32:55 -0800 (PST)

Dear Mark,
 I don't change the permissions of xferlog, but the log function works! 
The reason is that xferlog only log people who have got some files from 
our server, whom just access the server and just look is not 
logged. That is why these days they are always empty. Today when I got a 
file, I found the xferlog file has something.
 Thanks the all people who help me solve these problems
 Dawei

---

From: Neil Brookins <[email-masked]>
Date: Mon, 18 Dec 1995 11:27:32 -0500 (EST)

> > > log transfers anonymous,real inbound,outbound
                  ^          ^ Is this comma supposed to be here?
						Is the 's' supposed to be here? Does it matter?
On page 86 of "Managing Internet Information Services" it shows
no 's' in transfer; and no comma between types.

The reson I'm asking is that I can't get logging to work!

I have in my ftpaccess file:
log commands guest real
log transfer guest real inbound,outbound

And in my inetd.conf file:
ftp     stream  tcp     nowait  root    /usr/etc/in.ftpd        in.ftpd -laio

I have this version of ftpd:
220 gatekeeper FTP server (Version wu-2.4.2-academ[BETA-7](1) Sun Dec 17 15:26:43 EST 1995) ready.

according to ckconfig: 
Checking _PATH_XFERLOG :: /usr/adm/xferlog
ok.

And this file is world writeable:
gatekeeper{neil}45: ls -l /usr/adm/xferlog
-rw-rw-rw-  1 root            0 Aug  1 15:11 /usr/adm/xferlog

I'm using SunOS 4.1.3_U1.
Can anyone help me?

--->Neil