Subject: Re: Question about passwd and xferlog file

From: Joe Doyle <[email-masked]>
Date: Mon, 18 Dec 1995 09:32:51 -0800

Did you put 

daemon.debug		/var/log/syslog

in your /etc/syslog.conf and then restart your syslogd?  That's
what finally did it for me ;^)

Joe

> From [email-masked] Mon Dec 18 05:42 PST 1995
> Date: Mon, 18 Dec 1995 23:37:13 +1030 (CST)
> From: [email-masked] (Mark W. de Raad)
> To: [email-masked]
> Subject: Re: Question about passwd and xferlog file
> Mime-Version: 1.0
> Content-Transfer-Encoding: 7bit
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> You (ldw) wrote.......
> > 
> > Dear Daniel,
> >  Thanks for your mail, but I found do there is 
> > log transfers anonymous,real inbound,outbound
> > in my ftpaccess file.
> >  Dawei
> >                                          
> 
> Ok, silly question... what permissions does your xferlog file got?
> 
> :) It cant be this simple.. but hey... 
> 
> Mark
> ---
> Mark W. de Raad			    			o
> 					             _ /-_
> University of South Australia                 ......(_)>(_)
> Australia
> 
> Telephone: (+6115) 717 472
> In Australia: 015 717 472
> For Quick response, please mail: [email-masked]
> 
>                               _\\|//_
>                               ( O-O )
> ---------------------------o00--(_)--00o------------------------------
> "What, Me Worry?" - Alfred E. Neuman

---

From: [email-masked] (Daniel Clar)
Date: Mon, 18 Dec 1995 18:46:28 +0200

>                  ^          ^ Is this comma supposed to be here?
>						Is the 's' supposed to be here? Does it matter?
>On page 86 of "Managing Internet Information Services" it shows
>no 's' in transfer; and no comma between types.

I've looked at the file 'ftpaccess.heavy' in the wu-ftpd-2.4/doc/examples 
directory within the distribution tree.

Daniel

o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o
|   Daniel Clar          	    	   e-mail : [email-masked]  |
|   Computer Operations Manager			  : [email-masked]	    |
|   Service Informatique Supelec                    and                     |
|   Plateau de Moulon                     DECUSF::CLAR_D or [email-masked] |
|   91192 Gif sur Yvette Cedex - France                                     |
|   Tel : (33 1) 69 85 14 87        	   Fax : (33 1) 69 85 12 34         |
o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o=o

---

From: "JB.PJB.PROJO.COM" <[email-masked]>
Date: Tue, 19 Dec 1995 16:45:55 -0500

Yes the transfers plural is definitely needed. I spent an couple of hours 
troubleshooting that one until stepping through the code I found the line, 
 
if (!strcasecmp(ARG0,"transfers")) { 
 
Oh well good luck. 
 
-jb

Subject: Re: Question about passwd and xferlog file
From: "Steve R. Harding" <[email-masked]>
To: [email-masked]
Date: 19 Dec 95 06:05:52

On Mon, 18 Dec 1995 [email-masked] wrote:

> The reson I'm asking is that I can't get logging to work!
> 
> I have in my ftpaccess file:
> log commands guest real
> log transfer guest real inbound,outbound
> 
> And in my inetd.conf file:
> ftp     stream  tcp     nowait  root    /usr/etc/in.ftpd      in.ftpd -laio
>
> I have this version of ftpd:
> 220 gatekeeper FTP server (Version wu-2.4.2-academ[BETA-7](1) Sun Dec 17 15:26:43
>  EST 1995) ready.
> 
> according to ckconfig: 
> Checking _PATH_XFERLOG :: /usr/adm/xferlog
> ok.
> 
> And this file is world writeable:
> gatekeeper{neil}45: ls -l /usr/adm/xferlog
> -rw-rw-rw-  1 root            0 Aug  1 15:11 /usr/adm/xferlog
> 
> I'm using SunOS 4.1.3_U1.

I am using Version wu-2.4(4) on a Solaris 2.3 Sparcstation.  My logging 
works, the ftpaccess file shows:

log transfers guest inbound,outbound
            ^ note the "s".

However, I do not have more than one user type being logged, so I can't tell
you about the comma.  Why not try two lines in your ftpaccess, like this:

log transfers anonymous inbound,outbound
log transfers real inbound, outbound

and see what happens.

Good luck.

-------------------------------------------------------------------------------
Steve Harding                                      Email: [email-masked]
TACTech, Inc.                                      Voice: (714) 974-7676 ext.15
Yorba Linda, CA