Subject: Re: Local user access.

From: Graham Carpenter <[email-masked]>
Date: Wed, 15 Nov 1995 11:15:08 +0000 (GMT)

Michael Clarkson writes:
>
>Can somebody help me with the following problem. I have a local user that 
>uses bash as his login shell. And for some reason this appears to prevent 
>him from ftping to the machine, as he recieves an access denied message.
>
>However if i change the login shell to csh, he can ftp and connect correctly.
>
>Why is this ?
>
Because you haven't put bash into /etc/shells.

-- 
Graham Carpenter
University of Surrey, Guildford, Surrey, UK, GU2 5XH

---

From: [email-masked] (Jaime Prilusky)
Date: Wed, 15 Nov 1995 13:21:46 +0200 (EET)

> Michael Clarkson

The reason is that SunOS 4.1.4 does not have the /etc/shells file
(no document either said so. I discover it after several rounds of
trying to debug the wu-ftpd itself).

Just make a /etc/shells file with the following. Add other shells,
at the end, if you need to.

------------- to be pasted into /etc/shells ------------------

# The list of acceptable shells for ftpd, chsh, vipw, and
# eventually others.  "getusershell(3)" should be used by
# programs that wish to read this file.  See related man
# pages for specific details on use of this file by individual
# programs.
#
# Shell names must begin with a '/'.
#
/bin/sh
/bin/csh
/bin/tcsh

-------------- cut here -------------------------------------

-- 
 Dr Jaime Prilusky                ! [email-masked]
 Head Bioinformatics Unit         ! [email-masked]
 Dep. of Biological Services      !
 Weizmann Institute of Science    ! fax: 972-8-344113
 76100 Rehovot - Israel           ! tel: 972-8-343456

 info URL http://bioinformatics.weizmann.ac.il/jaime_prilusky.html

---

From: Michael Clarkson <[email-masked]>
Date: Wed, 15 Nov 1995 10:25:05 +0000 (GMT)

Why is this ?

Thanks in advance

Michael Clarkson
 ______  __   __    __ _  _
|  ____|/  \  \ \  / /(_)| |      FAXiL,    
| |___ / /_ \  \ \/ /  _ | |      The Wellcome Wing,
|  ___| ____ \  >  <  | || |      The General Infirmary,
| |  / /    \ \/ /\ \ | || |____  Leeds LS1 3EX, UK.
|_| /_/      \_\/  \_\|_||______| Tel: 0113 292 2479 Fax: 0113 242 0926

---

From: Ric Anderson <[email-masked]>
Date: Wed, 15 Nov 1995 06:11:43 -0700 (MST)

check /etc/shells.  It lists the valid shell pathnames for 
chsh (if you have it) and ftp.  Should be 1 entry per line,
like
	/bin/sh
	/usr/bin/sh
	/bin/csh
	/usr/bin/csh
	/bin/ksh
	/usr/bin/ksh
	/usr/local/bin/bash
	/usr/local/bin/tcsh

Note that /bin/xxx and /usr/bin/xx must both be listed, even though 
they may be the same file.  The check is made via strcmp() of a
line in /etc/shells against the string in the shell field of
/etc/passwd.

Cheers,
Ric (<[email-masked]> "Ric Anderson", using RTD's public internet access)

---

From: Michael Brennen <[email-masked]>
Date: Wed, 15 Nov 1995 09:17:47 -0600 (CST)

> him from ftping to the machine, as he recieves an access denied message.

Be sure bash is listed in /etc/shells.

Michael
---------------------------------------------------------------------
Michael Brennen, President   /           /           [email-masked]
FishNet, Inc.               / Internet  /         http://www.fni.com/ 
P.O. Box 940451            /  Services /     (214) 783-2553 (vox/fax)
Plano,  TX  75074-0451    /           /  finger me for PGP public key