Subject: Re: time out

From: [email-masked] (Robert R. Hardesty)
Date: Thu, 14 Sep 1995 20:30:38 +0800

> From [email-masked] Thu Sep 14 20:05 PDT 1995
> Date: Thu, 14 Sep 95 17:55:32 PDT
> From: [email-masked] (Syed Babar )
> To: [email-masked]
> Cc: [email-masked]
> Subject: time out
> X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
> 
> 
> Hello;
> 
> 	I am running wu-4.2 on sunos .and i dont know how to tell ftpd
> to close connection after a certain period of idle time. 
> I will be very thankfull if someone can helpme for that
> 
> 
> 
> Thanks
> 
> 
> babar
> 

I picked up an idle logout program from the net a week or two back. It
works great and I set it to log out ftp after about 15 min of idle.  It
is called  idled-1.10.tar.gz and can be found in:

ftp.hardlink.com: pub/unix/utils

via anon ftp.

Regards,

Robert

  ___ ___  Robert R. Hardesty .___.___     .__          __ 
 /   |   \ [email-masked] /|   |    |__|  ____  |  | __
/    ~    \\__  \ \_  __ \ / __ | |   |    |  | /    \ |  |/ /
\    Y    /Free Internet Access (510) 371-6986||   |  \|    <
 \___|___/ (______/|__|   \_____| |_______||__||___|__/|__|__\

---

From: Michael Brennen <[email-masked]>
Date: Fri, 15 Sep 1995 10:54:30 -0500 (CDT)

> ftp.hardlink.com: pub/unix/utils

The latest beta pretty much fixes all residual hanging daemon bugs, and 
wu-ftpd has a built in 15 minute idle timer.  You shouldn't need idled.

If you want the timer to be shorter, either use the "-t##" option (where 
## is the number of minutes idle you will allow) or hack the value of the 
"timeout" variable in ftpd.c

Michael