Subject: Re: Not getting welcome message for anonymous logins

From: Michael Brennen <[email-masked]>
Date: Fri, 1 Sep 1995 14:21:33 -0500 (CDT)

On Fri, 1 Sep 1995, Joe DeBattista wrote:

> Hi,
>    I'm having trouble getting anonymous users to get the welcome 
> message.  It's fine for other logins.  My entry in the ftpaccess file says:
> 
> message /usr/local/etc/welcome.msg            login
> message /usr/local/etc/welcome.msg            cwd=*
> 
> The entry for welcome.msg is
> -rw-r--r--   1 ftp      bin          204 Aug 31 17:21 
> /usr/local/etc/welcome.msg
> 
> The entry for ftpaccess is
> -rwxr-xr-x   1 root     sys          496 Aug 31 18:34 /usr/local/etc/ftpaccess
> 
> 
> I remember seeing something about anonymous users running differently 
> (chroot), but I'm not sure why the anonymous people don't get the welcome 
> message.  This is running under AIX 3.2.5.  Any ideas?

Move the message file for anonymous FTP under the anonymous FTP root 
directory.  When ftpd chroots to that directory it loses access to 
everthing above it, including /usr/local/etc/*.

Hope this does it,

Michael Brennen

---

From: Joe DeBattista <[email-masked]>
Date: Fri, 1 Sep 1995 12:07:39 -0700 (PDT)

Hi,

                                     Joe DeBattista
                                     UCSF, ITS Computing Facility
                          INTERNET:  [email-masked]