Subject: problem with aix version

From: Stefano Pini ST Agrate ++39 <[email-masked]>
Date: Mon, 4 Sep 1995 14:27:04 +0200

Hello, I'm new to wu-ftpd and to this list.
I've a problem to configure ftpacces on my IBM250 AIX3.2.5 machine.
With the anonymous logins there are no problems, but with REAL (local) user
i've returned the access denied message...
Why there are this problem?

Another problem is that the file /welcome.msg is not displayed...

Here are my ftpaccess file:

loginfails 2

class   remote  real,guest,anonymous *
class   local   real,guest,anonymous *.sgs-thomson.it 0.0.0.0

limit   local   2  Any                 /usr/lpp/ftpd/limit.msg
limit   remote  2  SaSu|Any1800-0600   /usr/lpp/ftpd/limit.msg
limit   remote  6  Any                 /usr/lpp/ftpd/limit.msg

readme  README*    login
readme  README*    cwd=*

banner  /usr/lpp/ftpd/banner.msg
message /welcome.msg            login
message .message                cwd=*
shutdown /usr/lpp/ftpd/shut.msg

email [email-masked]

compress        yes             local remote
tar             yes             local remote
private         no

passwd-check    rfc822  warn

log commands real
log transfers anonymous,real inbound,outbound

# all the following default to "yes" for everybody
delete          no      guest,anonymous         # delete permission?
overwrite       no      guest,anonymous         # overwrite permission?
rename          no      guest,anonymous         # rename permission?
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

Thank's in advance,
Stefano Pini
*********************************************
* STEFANO PINI                              *
* SGS-Thomson Microelectronics              *
* Central R&D Techonology                   *
* System and network Engineer               *
* Via Olivetti,2 20041 Agrate Bz. ITALY     *
* Tel: ++39,39,6036113 Fax: ++39,39,6035233 *
* EMail: [email-masked]           *
*********************************************

---

From: [email-masked] (Harald Milz)
Date: Mon, 04 Sep 1995 21:16:41 +0200 (MET DST)

Subject: Re: problem with aix version
To: [email-masked]
Organization: Harry's Box

> Why there are this problem?

Checked /etc/shells? AIX usually comes without this file. Enter all shells
real users might use, auch as

/bin/sh
/bin/ksh
/bin/csh 

etc. ...

> Another problem is that the file /welcome.msg is not displayed...

... to the anonymous user if it isn't located in the chroot()ed area.
Real users see the file /welcome.msg (in the root directory which probably
isn't what you want). 

> banner  /usr/lpp/ftpd/banner.msg

This is checked relative to /

> message /welcome.msg            login

... this one is relative to ~ftp

> shutdown /usr/lpp/ftpd/shut.msg

and this is again relative to /. The man page doesn't clearly state this. 
BTW... installing wu-ftpd under lpp/ is brave, really. ;^)

-hm