Subject: Problem with dir and ls -l as quest user

From: [email-masked]
Date: Mon, 11 Sep 95 11:05:28 PST

I've been having trouble getting the dir command to work when logged in as a 
guest user. The dir command works when logged in as a real user or as a 
anonymous user. Any suggestions?

I'm using a patched version of wu-ftpd 2.4 on SunOS 4.1.3 

Patrick O'Shaughnessy <[email-masked]>
Thomas Bros. Maps
(714) 757-5591

---

From: Chris Woods <[email-masked]>
Date: Tue, 12 Sep 1995 03:09:29 -0400 (EDT)

> anonymous user. Any suggestions?

Statically compile `ls' and place it into $FTP_ROOT/bin. That is, put it 
into /bin under whatever directory the guest user is chroot()'ed to.

     Chris Woods     Senior System Administrator       USAinternet, Inc.
     GCS/CM/IT d- s++:+ a- C++++$ ULS++++$ P+++$>++++  L++++$ E W$ N+ !o
     K++ !w--- !O !M-- !V-- PS+? !PE !Y+>++ PGP+ t+@ !5 X !R tv? b+ DI++
     D+@ G++ e h---- r+++ y++++
     [email-masked]	      http://www.usa1.com	    508-774-4700

---

From: Vidiot <[email-masked]>
Date: Tue, 12 Sep 1995 09:21:51 -0500 (CDT)

Patrick said:

<I've been having trouble getting the dir command to work when logged in as a 
<guest user. The dir command works when logged in as a real user or as a 
<anonymous user. Any suggestions?
<
<I'm using a patched version of wu-ftpd 2.4 on SunOS 4.1.3 

Do you have the following in ~ftp/usr/lib:?

	ld.so
	libc.so.1.9.1
	libdl.so.1.0

If not, then do so.  If you do, I don't know why it doesn't work, as it does
for me.

MB
-- 
System Administrator - FT/MS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - <URL:http://www.cdsnet.net/vidiot/>  (Your link to Star Trek and UPN)