Subject: Cannot COMPRESS plain files... Why?

From: Daniel Tremblay <[email-masked]>
Date: Mon, 11 Sep 1995 13:26:00 -0400

Hi all,

I keep getting this message "Cannot (UN)COMPRESS/G(UN)ZIP plain files" when
I try to retreive a file by changing its extention.  What am I doing wrong?
My ftpaccess file includes both these lines:

compress yes local remote
tar      yes local remote

And here's my ftpconversion file :

 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/usr/local/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/usr/local/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

Seems everything is ok but somehow this is not working...  any help would be
appreciated.

Thanks

Dan.

--------------------------------
 Daniel Tremblay, B.ing.      
 Matrox Electronic Systems Ltd. 
 tel: (514) 969-6000 #2361 fax: (514) 969-6262
 e-mail : [email-masked]

---

From: Yanming PENG <[email-masked]>
Date: Tue, 12 Sep 95 0:28:12 WETDST

> My ftpaccess file includes both these lines:
That is a bug in the source. Get the new beta or fix it your self (ftpd.c,1331). 
I had this problem with one beta, and found beta 4 has fixed this bug.

--
Yanming PENG