Subject: Re: Where is the beta?

From: "Pascale Tetreault" <[email-masked]>
Date: Wed, 13 Sep 1995 10:13:19 +0000

On 13 Sep 95 at 8:56, Chris Woods wrote:

> On Tue, 12 Sep 1995, Vincent Cojot wrote:
> 
> > > The URL for the Academ wu-ftpd beta is
> > > 
> > > 	ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-5.t
> > > r.Z
> > 
> > I may be wrong but I could not find it there.. Could anyone tell
> > me where to find it?
> 
> I just checked; it's still there.
> 

Funny 'cause I just did as well, Wednesday Sept. 13, 10:20 am EST and 
the directory is empty.  Does one need special permission to get 
there and/or see the files??

=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
Pascale Tetreault                  CNG Group Inc.
[email-masked]                Ottawa, Ontario

Visit our web site at
http://www.cng.on.ca/
~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.~.

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Wed, 13 Sep 95 16:47:40 MET DST

> there and/or see the files??

The directory is unreadable. You need to get the filenames blindly.

                                          Grtx. KH

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)

---

From: Aydin Edguer <[email-masked]>
Date: Wed, 13 Sep 1995 11:07:50 -0400 (EDT)

Pascale Tetreault writes:
> > > > ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-5.tar.Z
> > > 

I would recommend checking the permissions of the directory before trying
to perform an operation within the directory.

  ftp> dir
  200 PORT command successful.
  150 Opening ASCII mode data connection for /bin/ls.
  total 788
  -rw-rw-r--  1 sob  wheel     414 May  6 18:52 .message
  drwx--x--x  2 sob  wheel     512 Jul 11 11:14 private
  -rw-rw-r--  1 sob  wheel  193185 May  6 18:54 wu-ftpd-2.4-academ.tar.Z
  -rwxrwxr-x  1 sob  wheel  184907 Jun 18 01:21 wu-ftpd-2.4.tar.Z
  226 Transfer complete.
  259 bytes received in 0.0051 seconds (50 Kbytes/s)
  ftp> 

Note that the directory private only have execute permission ("x")
on the directory, not read permission ("r") for "others".  This means
you can pick up files if you know the name, but you cannot do a "dir"
or "ls" to find the names of files in the directory.

The name "private" is a fairly standard name that is used for this
type of directory - this helps to limit access to a group of people
to whom you have provided the file names.

Instead of trying to do an "ls" or "dir", just do a "get" of the
file "wu-ftpd-2.4.2-beta-5.tar.Z" from the private directory.

  ftp> cd private
  250 CWD command successful.
  ftp> binary
  200 Type set to I.
  ftp> get wu-ftpd-2.4.2-beta-5.tar.Z
  200 PORT command successful.
  ftp> get wu-ftpd-2.4.2-beta-5.tar.Z
  200 PORT command successful.
  150 Opening BINARY mode data connection for wu-ftpd-2.4.2-beta-5.tar.Z (220925 bytes).
  226 Transfer complete.
  local: wu-ftpd-2.4.2-beta-5.tar.Z remote: wu-ftpd-2.4.2-beta-5.tar.Z
  220925 bytes received in 1.9e+02 seconds (1.2 Kbytes/s)
  ftp>