Subject: Re: Help with Groups

From: Mike Gonzalez <[email-masked]>
Date: Fri, 15 Sep 1995 21:44:59 -0600

Michael,
        I just want to thank you for your help. There is alot to say for the Internet and its users and people like yourself that make a great place. I had fiddled with this for a couple weeks (I'm kinda a Unix newbie). I had asked some local gurus for help and so forth and I was getting frustrated. I did exactly as your instructions and was able to get my first group up and going. I hope this helps others too.

Thanks again.

--Mike Gonzalez
[email-masked]

---

From: Yanming PENG <[email-masked]>
Date: Thu, 21 Sep 95 17:38:02 WETDST

> 
> 
> I have been trying to get this group access thing to work with no success.
> The reason it still doesn't work is that wu-ftp does not recognize the 
> group permissions on directories or files. It only recognizes the owner
> and world directory/file permissions. I don't know if this is a problem
> associated with the AIX version that I am running or it is this way across
> all platforms. 

At least it works on my Linux v2.1.13. The group we are talking is in /etc,
not in ~user/etc. I created a group called "ftponly" and made guest a member
of it. guest has the primary group users. A directory owned by root.ftponly
with mode=770 can be accessed (read/write) via guest login.
> 
> But on my system, if I set a directory to rwxrwx--- and have it owned by
> root and group owned by a group named 'shared', and have a user that is 

Where did you define the group "shared"?

> a member of the group 'shared' try to cd to that directory, I get a

via anonymous ftp or guest login? It should not work with anonymous ftp.

> 'Permission denied' error. As soon as I change the access permissions for
> world, I can access the directory. 
> 
> Is this the way it is suppose to work?
> 
> Steve
> -------------------------------------------------------------------------
>      Steve Womble                              [email-masked]
>