Subject: Problems with Group Control

From: [email-masked] (Udo Winkelmann)
Date: Tue, 15 Aug 1995 05:22:28 +0000

Hi,
I have just set up the wu-ftpd 4.2
But I have a problem setting up a guestgroup. For setting the ftpd I uses the
O´Reilly Handbook "Managing Internet Information Systems" but when I create
the ftpaccess file for the guest group like described I get the following 
message when I try to login:

        220-
        220 rcsun1 FTP server (Version wu-2.4(2) Fri Aug 11 14:32:52 MET DST
1995) ready.
        Name (localhost:root): xmmftp
        530 User xmmftp access denied...
        Login failed.
        ftp>

The entry in the /etc/passwd file looks like:
  xmmftp:CtN/XyXEYMPGI:20001:201:XMM-Guest-User:/user/guests/./xmm:/bin/false

The entry in the /etc/group file looks like:
         ftpguests:*:201:xmmftp,poemftp,sciaftp
 
The entry in the /usr/local/etc/ftpaccess file looks like:
        guestgroup ftpguests

Where might be the problem

regards
Udo
--------------------------------------------------------------------------------
Udo Winkelmann
Dornier GmbH
Department RST 46
Friedrichshafen, 88039
Germany
Phone +49 7545 8 9770
FAX   +49 7545 8 3210
email: [email-masked] 
--------------------------------------------------------------------------------

---

From: [email-masked] (Keith Smith)
Date: Tue, 15 Aug 1995 18:42:44 +1200

>  xmmftp:CtN/XyXEYMPGI:20001:201:XMM-Guest-User:/user/guests/./xmm:/bin/false

Is /bin/false in you /etc/shells file?  The file /bin/false doesn't have to
exist but it must be listed in /etc/shells

Good Luck
Keith.

---

From: [email-masked] (Udo Winkelmann)
Date: Tue, 15 Aug 1995 12:08:47 +0000

Thanks for the info
Udo