Subject: Error: Can't create data socket (0.0.0.0,20): Bad File number

From: [email-masked] (Steve Eastham)
Date: Mon, 14 Aug 95 10:23:00 PST

Thanks for all the help.
The other errors have been taken care of by creating the /etc/shells and
syntax errors in /etc/passwd. Now I get logged in but get the following error
when running an ls or dir.

331 Guest login ok, send your complete e-mail address as password.
Password:
230-Please read the file README
230-  it was last modified on Tue Jan 17 16:01:23 1995 - 209 days ago
230 Guest login ok, access restrictions apply.
ftp> ls
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.
ftp>

If anyone has any ideas you can email me or post to forum.
Steve

---

From: [email-masked] (Kari Hakkinen)
Date: Mon, 14 Aug 1995 18:40:35 +0300 (EETDST)

> If anyone has any ideas you can email me or post to forum.

I had exactly the same error on our SCO 3.2v4.2 before I created directories
~ftp/dev and ~ftp/shlib and put the necessary files there.

I hope your operating system documentation tells you what to put there.

Hope this helps,
Kari
-- 
Kari Hakkinen                Internet:  [email-masked]
Relatech Ltd                 Tel:       +358-41-650205
Jyvaskyla FINLAND            Fax:       +358-41-650120