Subject: 2.4.2-betaX

From: [email-masked] (Bruce Walton)
Date: Wed, 9 Aug 95 08:37:11 EDT

Can someone answer:

Where are the beta versions?  I'd like to fix my
hanging ftpd problems.

I can't find the patched version on this site:

   ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-5.tar.Z

Am I looking in the wrong place?

THANKS				-bruce.

-- 
__________________________________________________________________________
| Bruce Walton	[email-masked]	MIT artificial intelligence lab  |
| sysadmin	617-253-9667		545 tech sq. cambridge, MA 02139 |
|________________________________________________________________________|

---

From: Dovid Zirkind <[email-masked]>
Date: Wed, 9 Aug 1995 23:33:20 -0400

I tried compiling wu-ftpd-2.4 for linux, but it gave me the following errors:

ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists
Makefile:13: *** missing separator.  Stop.
In file included from ftpd.c:68:
/usr/include/bsd/signal.h:20: warning: `SIGBUS' redefined
/usr/include/linux/signal.h:16: warning: this is the location of the previous definition
In file included from ftpd.c:42:
config.h:25: syntax error before `typedef'
In file included from ftpd.c:46:
/usr/include/sys/stat.h:28: syntax error before `struct'
ftpd.c:227: parse error before `lostconn'
ftpd.c:227: warning: data definition has no type or storage class
ftpd.c:228: parse error before `randomsig'
ftpd.c:228: warning: data definition has no type or storage class
ftpd.c:229: parse error before `myoob'
ftpd.c:229: warning: data definition has no type or storage class
ftpd.c: In function `main':
ftpd.c:301: too few arguments to function `openlog'
ftpd.c:386: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:389: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:392: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:395: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:398: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:401: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:407: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:410: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:413: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:416: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:419: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:422: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:425: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:428: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:431: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:434: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:437: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:440: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:443: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:446: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:449: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:452: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:455: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:458: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:462: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c:469: warning: passing arg 2 of `__bsd_signal' from incompatible pointer type
ftpd.c: At top level:
ftpd.c:560: parse error before `randomsig'
ftpd.c:571: parse error before `lostconn'
ftpd.c: In function `pass':
ftpd.c:1002: warning: assignment makes integer from pointer without a cast
ftpd.c: In function `opt_string':
ftpd.c:1226: warning: comparison between pointer and integer
ftpd.c:1228: warning: comparison between pointer and integer
ftpd.c:1230: warning: comparison between pointer and integer
ftpd.c: In function `retrieve':
ftpd.c:1342: warning: comparison between pointer and integer
ftpd.c: At top level:
ftpd.c:2430: parse error before `myoob'
make: *** [ftpd.o] Error 1
gcc: vers.o: No such file or directory
In file included from ftpcount.c:42:
/usr/include/bsd/signal.h:20: warning: `SIGBUS' redefined
/usr/include/linux/signal.h:16: warning: this is the location of the previous definition
In file included from ftpcount.c:32:
config.h:25: syntax error before `typedef'
In file included from /usr/include/libio.h:35,
                 from /usr/include/stdio.h:29,
                 from ftpcount.c:34:
/usr/include/_G_config.h:13: syntax error before `typedef'
ftpcount.c: In function `parsetime':
ftpcount.c:98: warning: comparison between pointer and integer
ftpcount.c:107: warning: comparison between pointer and integer
ftpcount.c: In function `acl_getlimit':
ftpcount.c:159: warning: comparison between pointer and integer
ftpcount.c:162: warning: assignment makes integer from pointer without a cast
ftpcount.c: In function `main':
ftpcount.c:307: warning: comparison between pointer and integer
ftpcount.c:310: warning: assignment makes integer from pointer without a cast
make: *** [ftpcount] Error 1
gcc: vers.o: No such file or directory
In file included from ftpshut.c:37:
config.h:25: syntax error before `typedef'
In file included from /usr/include/bsd/errno.h:5,
                 from ftpshut.c:39:
/usr/include/errno.h:8: syntax error before `extern'
ftpshut.c: In function `main':
ftpshut.c:188: warning: comparison between pointer and integer
ftpshut.c:191: warning: assignment makes integer from pointer without a cast
make: *** [ftpshut] Error 1
ln: ckconfig: File exists
size: bin/ftpd: No such file or directory
size: bin/ftpcount: No such file or directory
size: bin/ftpshut: No such file or directory
size: bin/ftpwho: No such file or directory