Subject: Re: wu-ftpd-2.4.2-BETA5: ftpconversions probs

From: [email-masked] (Harald Milz)
Date: Fri, 11 Aug 1995 07:56:51 +0200 (MET DST)

Subject: Re: wu-ftpd-2.4.2-BETA5: ftpconversions probs
To: [email-masked]
Organization: Harry's Box

Derrick J. Brashear ([email-masked]) wrote:
> Here's the code from 2.4:
>             if (S_ISREG(st.st_mode) && !(cptr->types & T_REG)) {
>                 (void) reply(550, "Cannot %s plain files.", cptr->name);
>                 return;
>             }
> Looks like that should be == 0 instead.

Aaaargh. Who's broken that? &%$§/&%$"

Ciao,
hm

---

From: [email-masked] (Harald Milz)
Date: Fri, 11 Aug 95 14:34 CEST

> From: "Derrick J. Brashear" <[email-masked]>

> >newhost _is_ a plain file, and it is supposed to
> >be gzipped properly. The message is generated around
> >line 1460 of ftpd.c:
> >             if (S_ISREG(st.st_mode) && (cptr->types & T_REG) != 0) {

Thanks Derrick, now it works. Anyone listening from the
developers' team? 

Ciao,
hm

Harald Milz ([email-masked])   WWW: http://www.ix.de/ix/editors/hm.html
iX Multiuser Multitasking Magazine      phone +49 (511) 53 52-377
Helstorfer Str. 7, D-30625 Hannover     fax   +49 (511) 53 52-361
Opinions stated herein are my own, not necessarily my employer's.