Subject: Re: soft links not followed?

From: Yanming PENG <[email-masked]>
Date: Thu, 17 Aug 95 10:36:23 WETDST

> I have a space problem.  I've set up a guestgroup with a real account.
> I want to place files in a pub/packages directory within the real
> account directory.  However, the files are too big to reside on the same
> file system as the ~ftp account.  I created a softlink in the ~ftp/pub/packages
> directory to point to a file in another larger filesystem.
> 
You may export the dir and nfs mount to ~ftp/pub/packages (on the same
machine, YES)

> Now when I log in as the real user, an "ls" reveals that the softlinks
> are indeed present, protections lrwxrwxrwx, but owned by "root", and
> group "other".  Even though the files at the other end of the link
> are owned by my ~ftp real user, they cannot be accessed (ie, I can't 
> "GET" them -- permission denied).
> 
> How can I enable softlinks within a guestgroup account?
> 
I think you can't. guestgroup are also chrooted and softlinks to
outside current root is meaningless.

> Thanks
> - Chris
Yanming PENG
[email-masked]

---

From: [email-masked] (Christopher A. Mega)
Date: Thu, 17 Aug 1995 11:32:35 -0400

> You may export the dir and nfs mount to ~ftp/pub/packages (on the same

Thanks for the reply.  Can you tell me how to "export the dir and nfs mount
to ~ftp/pub/packages"?  I'm not very fluent with mnttab, etc.

Thanks much!

- Chris

========================================================================
               Christopher A. Mega ([email-masked])
                      Manager, Internet Services
                       Harpell/Martins & Company
                66 Commonwealth Ave, Concord, MA 01742
              Phone: (508) 371-1510  Fax: (508) 369-7561
========================================================================