Subject: Re: wu-ftpd FAQ?? where?

From: [email-masked] (Harald Milz)
Date: Fri, 25 Aug 1995 07:30:28 +0200 (MET DST)

Subject: Re: wu-ftpd FAQ?? where?
To: [email-masked]
Organization: Harry's Box

Steve Michnick ([email-masked]) wrote:
> I just installed wu-ftpd v2.4 and now have several basic questions
> that are not answered clearly in the man pages.  Is there a FAQ
> for wu-ftpd?  Otherwise, I need to know how to activate passwd verification

AFAIK, there's no such FAQ yet. We should try and find a volunteer to
collect questions and answers from this mailing list. Such a FAQ would
be appreciated by many first-time wu-ftpd users. Anyone?

hm

---

From: Edward Murphy <[email-masked]>
Date: Fri, 25 Aug 1995 08:36:43 -0500 (CDT)

While there may not be a FAQ, check out the URL

  http://fegmania.wustl.edu/

At this writing, the first two links on the page above are connected to
information about WU-FTPD. One is a general "README" type of page detailing
where to get it, etc. The other is a searchable archive of the WU-FTPD
mailing list.  I've found it very helpful. 

Ed
   ----------------------------------------------------------------
			    Edward Murphy
	  [email-masked] * http://www.uno.edu/~emurphy

---

From: Dovid Zirkind <[email-masked]>
Date: Sun, 27 Aug 1995 05:12:40 -0400

has anyone succesfuly compiled wu.ftpd under linux ? (I'm running 1.2.11)

TIA

---

From: Riku Saikkonen <[email-masked]>
Date: Sun, 27 Aug 1995 12:34:09 +0300 (EET DST)

>has anyone succesfuly compiled wu.ftpd under linux ? (I'm running 1.2.11)

Yes, I have, under 1.2.11 (non-ELF). Wasn't that difficult, just had to
check through the config files and Makefiles.

I got the following diff (for wu-ftpd-2.4.2-beta-4) from ftp.funet.fi
/pub/Linux/PEOPLE/Linus/net-source/something-or-other:

*** Begin
--- Makefile.Linux
+++ Makefile.Linux	1995/07/08 12:23:29
@@ -0,0 +1,4 @@
+compile:
+	./build lnx
+
+
--- src/ckconfig.c
+++ src/ckconfig.c	1995/07/08 12:22:20
@@ -34,10 +34,12 @@
 #define  HOST_ACCESS  1
 #endif
 #include <stdio.h>
+#include <string.h>
 #include <sys/types.h>
 #include <sys/stat.h>
 #include "pathnames.h"
 
+int
 main()
 {
   struct stat  sbuf;
@@ -103,4 +105,5 @@
     printf("of the server.\n");
   } else
     printf("ok.\n");
+  exit(0);
 }
--- src/ftpd.c
+++ src/ftpd.c	1995/07/08 12:18:33
@@ -264,6 +264,7 @@
 char  ls_short[50];
 struct aclmember *entry = NULL;
 
+int
 main(int argc, char **argv, char **envp)
 {
     int addrlen,
@@ -700,6 +701,7 @@
  * does not have a standard shell as returned by getusershell().  Disallow
  * anyone mentioned in the file _PATH_FTPUSERS to allow people such as root
  * and uucp to be avoided. */
+void
 user(char *name)
 {
     register char *cp;
@@ -934,6 +936,7 @@
 }
 
 /* Check if a user is in the file _PATH_FTPUSERS */
+int
 checkuser(char *name)
 {
     register FILE *fd;
@@ -958,6 +961,7 @@
 
 /* Terminate login as previous user, if any, resetting state; used when USER
  * command is given or login fails. */
+int
 end_login(void)
 {
 
@@ -1306,6 +1310,7 @@
     return (buf);
 }
 
+void
 retrieve(char *cmd, char *name)
 {
     FILE *fin,
@@ -1894,6 +1899,7 @@
  * encapsulation of the data subject to Mode, Structure, and Type.
  *
  * NB: Form isn't handled. */
+void
 send_data(FILE *instr, FILE *outstr, off_t blksize)
 {
     register int c,
--- src/makefiles/Makefile.lnx
+++ src/makefiles/Makefile.lnx	1995/07/08 12:13:38
@@ -2,10 +2,10 @@
 # YACC     = byacc
 # debian fix:
 YACC     = bison -y
-IFLAGS   = -I.. -I../support -I/usr/include/bsd
+IFLAGS   = -I.. -I../support # -I/usr/include/bsd
 LFLAGS   = -L../support -static -s
-CFLAGS   = -O2 -fomit-frame-pointer ${IFLAGS} ${LFLAGS}
-LIBES    = -lsupport -lbsd # -lshadow
+CFLAGS   = -Wall -O2 -fomit-frame-pointer ${IFLAGS} ${LFLAGS}
+LIBES    = -lsupport # -lbsd # -lshadow
 LIBC     = /usr/lib/libc.a
 LINTFLAGS=	
 LKERB    = -lauth -lckrb -lkrb -ldes
--- support/fnmatch.c
+++ support/fnmatch.c	1995/07/08 12:15:06
@@ -78,7 +78,7 @@
 	 * 3.13.2).  I have chosen to treat it like '!', for 
 	 * consistancy with regular expression syntax.
 	 */
-	if (negate = (*pattern == '!' || *pattern == '^')) {
+	if ((negate = (*pattern == '!' || *pattern == '^'))) {
 		pattern++;
 	}
 	
--- support/makefiles/Makefile.lnx
+++ support/makefiles/Makefile.lnx	1995/07/08 12:13:38
@@ -8,7 +8,7 @@
 LIBC   = /lib/libc.a
 IFLAGS = 
 LFLAGS = 
-CFLAGS = -O2 -fomit-frame-pointer ${IFLAGS} ${LFLAGS}
+CFLAGS = -Wall -O2 -fomit-frame-pointer ${IFLAGS} ${LFLAGS}
 
 SRCS   = fnmatch.c strcasestr.c authuser.c 
 OBJS   = fnmatch.o strcasestr.o authuser.o 
*** End

But that doesn't really do very much, so I think it should compile without
that too...

--
-=- Rjs -=- [email-masked] - IRC: Rjs

---

From: Chris Woods <[email-masked]>
Date: Sun, 27 Aug 1995 08:38:35 -0400 (EDT)

> has anyone succesfuly compiled wu.ftpd under linux ? (I'm running 1.2.11)

Yeah. Version wu-2.4.2-academ[BETA-5] compiled outta the box. Non-shadow
did, I haven't spent a ton of time recompiling it on my shadowed machines.
It didn't go first time, and I didn't spend any real time on it. 

Chris Woods                                               [email-masked]
GCM/CS/E   d---  H++ s+:++ !g  p? au-- a- w+  v++ C++ UL++++ P++>++++ L+++
	   E++>+++ N+ K++ W--- M-- V-- -po+ Y+ t+ !5 !j R G? tv-- b+ D+ B-
	   e+ u+ h---- f r+++ n---- y++++
Network Administrator 	    	 USAinternet, Inc.  	      508-774-4700

---

From: "Chadwick A. Dubuque" <[email-masked]>
Date: Sun, 27 Aug 1995 11:15:39 -0500 (CDT)

> It didn't go first time, and I didn't spend any real time on it. 

1) The wu-2.4.2.academ[BETA-5] that compiles out of the box for Linux is at:

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-5.tar.Z

(Please stay tuned to this list for updates, which, according to the release
notice from the author could be out "any day now." Yeah, that and
Windows 95. Ooops. :-) Really, though, thanks for all the work, Stan!)

2) The way to get wu-ftpd to compile with the shadow package came from
Koos van den Hout:

##############################################################################
First :

- Get the shadow.h from the latest shadow package.
- After building the shadow package, you have a libshadow.a.

Then :
- Copy shadow.h to the src dir.
- Copy libshadow.a to the support dir.
- Edit src/config.h to say '#define SHADOW_PASSWORD' instead of #undef.
- Edit the LIBES line in src/Makefile to read :

LIBES    = -lsupport -lbsd -lshadow

And then modify src/ftpd.c in line 1061 to read :

        xpasswd = pw_encrypt(passwd, salt);

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)
##############################################################################

Hope this helps! Using these two, I've gotten wu-ftpd to do just about
everything I want it to. I think the rest of the problems are mine...

-- 
Chadwick A. Dubuque            [email-masked]
http://www.acm.ndsu.NoDak.edu/~cdubuque/   finger for PGP pub. key 
postal:USA/58105-5164/ND/Fargo/IACC 258 NDSU Box 5164/Chad Dubuque