Subject: Re: Need help re-starting FTP server

From: Yanming PENG <[email-masked]>
Date: Wed, 23 Aug 95 1:32:24 WETDST

> 
> 
> Hey there.  I recently installed and configured v2.4 of the ftp server
> under Solaris 2.4.  Everything was working great until I ran 
> the ftpshut command and brought the server down.  Now, I can't
> seem to get it to start again and I don't see any references in the
> documentation to a "ftpstart" binary.  Is there some sort of lockfile

There is no "ftpstart" and seems no document about "restart" ftp server.
The only way is to read source -- "Luc, use Force!".

> that needs to be removed? Re-starting inetd doesnt seem to do the trick
> either.  Any help would be appreciated.

Rename or delete the file defined in ftpaccess, shutdown statement.
On my workstation, it is in /etc/ftpaccess:
shutdown /etc/shutmsg

Therefore, delete /etc/shutmsg, the ftp server will "restart".
Probably everyone, who use ftpshut first time, asks this question ;-)

> Thanks,
> Brian
> [email-masked]

--
Yanming PENG
[email-masked]

---

From: Brian Vogelsang <[email-masked]>
Date: Tue, 22 Aug 1995 17:31:10 -0700 (PDT)

Thanks for your help Yanming, removing the file "shutmsg" 
enabled the server.  It's too bad there's nothing in the 
ftpshut manpage pointing this out.  Maybe Brian O'Connor
can include this in the next release.

Thanks again,
Brian
[email-masked]