Subject: Idea why 'dir' does not work while 'ls' does?

From: [email-masked] (Steve Eastham)
Date: Fri, 18 Aug 95 21:49:46 PST

I'm looking for help why 'ls' will work but 'dir' will not, I have tried this with all types
of ftp clients and shells all fail. Here's the log. 

331 Guest login ok, send your complete e-mail address as password.
Password:
230-Please read the file README
230-  it was last modified on Tue Jan 17 16:01:23 1995 - 213 days ago
230 Guest login ok, access restrictions apply.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
README
bin
lib
doc
SunOpsisVol1No3.ps.Z
log.ftp
man
SunOpsisVol1No4.ps.Z
dev
etc
usr
SunOpsisVol2No1.ps.Z
setup_anon_ftp.sh
226 Transfer complete.
137 bytes received in 0.12 seconds (1.1 Kbytes/s)
ftp>

---

From: Micah Brandon <[email-masked]>
Date: Sat, 19 Aug 1995 11:13:35 -0400 (EDT)

> of ftp clients and shells all fail. Here's the log. 
	Ok, here's what I did to fix the problem.  I got gnu's version of
ls which is within their fileutils file.  I found it at:

ftp://wuarchive.wustl.edu/systems/gnu/fileutils-3.12.tar.gz

then compile the ls program in there with the -static option for LDFLAGS
and CFLAGS (using gcc).  I think -Bstatic for cc.  After you get the 
executable, put this in ~ftp/bin.  Worked for me.

-Micah