Subject: Problem with wu-ftpd 2.4 in SCO 3.2v4.2

From: [email-masked] (Kari Hakkinen)
Date: Fri, 4 Aug 1995 12:38:08 +0300 (EETDST)

Hi

I am trying to set up an anonymous ftp server on SCO Unix 3.2v4.2.

Everything seems to work OK with a real user. But when an anonymous user tries
"ls" command he gets error:

  425 Can't create data socket (0.0.0.0,20): Bad file number

I am using wu-ftp server version 2.4, which I got from ftp.mols.siu.edu.
The package was already compiled, so I haven't compiled it by my self.

Here is the output of ls -lR of the directory structure:

/usr/local/etc/ftp($) ls -lR
total 8
-rw-------   1 ftp      group        878 Aug 03 16:26 .profile
dr-xr-xr-x   2 root     root          80 Aug 04 11:11 bin
dr-xr-xr-x   2 root     root          64 Aug 03 19:28 etc
drwxrwxrwx   3 ftp      group         48 Aug 04 11:22 pub

./bin:
total 210
---x--x--x   1 root     root       25710 Aug 03 16:32 compress
---x--x--x   1 root     root       23674 Aug 03 16:29 ls
-rwx--x--x   1 root     root       53118 Aug 04 11:11 sh

./etc:
total 4
-r--r--r--   1 root     root         383 Aug 03 19:28 group
-r--r--r--   1 root     root          86 Aug 03 16:30 passwd

./pub:
total 2
drwxr-xr-x   2 root     root          32 Aug 04 11:22 incoming

./pub/incoming:
total 0

/usr/local/etc/ftp($) 

Thanks for any help,
Kari
-- 
Kari Hakkinen                Internet:  [email-masked]
Relatech Ltd                 Tel:       +358-41-650205
Jyvaskyla FINLAND            Fax:       +358-41-650120

---

From: [email-masked] (Bill Campbell)
Date: Fri, 4 Aug 1995 07:17:09 -0700 (PDT)

> drwxrwxrwx   3 ftp      group         48 Aug 04 11:22 pub
You don't have a /dev directory or a /shlib directory (which makes me
thing you didn't read the instructions in the SCO Network Managers
Guide on setting up anonymous ftp).

The /dev directory needs:
crw-rw-rw-   1 root     other     26,  0 Apr 10 14:06 /ftp/dev/socksys

The /shlib directory needs:
-rwxr-xr-x   1 root     other      47745 Nov 03  1993 /ftp/shlib/libc_s

Bill
--
INTERNET:   [email-masked]  Bill Campbell; Celestial Systems, Inc.
UUCP:               camco!bill  PO Box 820; 2835 82nd Avenue S.E. S-100
FAX:            (206) 232-9186  Mercer Island, WA 98040-0820; (206) 236-1676
URL: http://www.celestial.com/

You need only reflect that one of the best ways to get yourself a
reputation as a dangerous citizen these days is to go about repeating
the very phrases which our founding fathers used in the struggle for
independence.
        -- Charles A. Beard