Subject: file name globbing not working (wuftp 2.4 on irix 5.3)

From: [email-masked] ("John R. Vanderpool")
Date: Mon, 7 Aug 1995 15:26:09 -0400 (EDT)

we have discovered a problem with file name globbing under wuftp 2.4 on
irix 5.3, we haven't changed any of the code and didn't define any unusually
strange configs (that i know of):

$ ls tcl*
-rw-rw-r--    1 root     sys       201050 Jun 19 18:10 tcl-book.p1.ps.gz
-rw-rw-r--    1 root     sys       231078 Jun 19 18:10 tcl-book.p2.ps.gz
-rw-rw-r--    1 root     sys        87068 Jun 19 18:10 tcl-book.p3.ps.gz
-rw-rw-r--    1 root     sys       103483 Jun 19 18:10 tcl-book.p4.ps.gz

ftp> ls tcl*gz
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
-rw-rw-r--    1 root     sys       201050 Jun 19 18:10 tcl-book.p1.ps.gz
226 Transfer complete.
ftp> mget tcl*
Arguments too long
can't find list of remote files, oops

any help appreciated...

				fish

-- 
Life is what you make it, at least that's what the people say.
And if we can't make it through tomorrow, we'd better make it through today.
								-ec
John R. Vanderpool      <[email-masked]>   NASA/GSFC/HSTX

---

From: "Ephram Cohen" <[email-masked]>
Date: Mon, 7 Aug 1995 14:08:12 -0700

On Aug 7,  3:26pm, John R. Vanderpool wrote:
> Subject: file name globbing not working (wuftp 2.4 on irix 5.3)
> irix 5.3,
[stuff deleted]
>-- End of excerpt from John R. Vanderpool

I would look in glob.c for

#define GAVSIZ          (NCARGS/6)

If NCARGS is not defined, define it with a largish value. I suspect that
NCARGS absence is being interperted as #def NCARGS 0.
I have defined it with (600) and this seems to work
fine for our very low usage site.  I recieved some mail
from *Hobbit* stating "Making it bigger than 600 would probably be prudent!"

I must admit that I have not made the change yet but I may if one of
my users has file name expansion problems.

Hope this helps.

-- 

We must prevent those commies from compromising the integrity
of our precious bodily fluids.      -Gen. Jack D. Ripper

Ephram Cohen                       [email-masked]

---

From: [email-masked] ("John R. Vanderpool")
Date: Mon, 7 Aug 1995 17:57:07 -0400 (EDT)

Ephram Cohen writes...
> from *Hobbit* stating "Making it bigger than 600 would probably be prudent!"

dude! that was it - thanx so much.  i changed mine to 2048 since that's what
/bin/sh uses i think - i can't believe this isn't documented or that more
folks haven't run into the same problem - my coadmin installed the package
and had it set to only 36 (since as you mentioned it wasn't define in the
system header files at all on irix)

			see ya,
				fish