Subject: FAQ

From: [email-masked] (Don Cunningham)
Date: Fri, 21 Jul 95 10:19:05 EDT

Hi,
  I just subscribed to this list and was
wondering if there is a FAQ available. I've
also got one problem and a question:

Problem: Can't seem to get the SITE commands
to work. Always get a "?Invalid command" error
on the client and it doesn't show up in the
command list. Any magic to turning on this
feature?

Question: Can the annonymous account be setup
to allow sublogins(it appears only real accounts
have this privilege)?

Server specs: SPARC w/ SunOS4.1.3_U1 running wu-2.4

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Don Cunningham - UNIX SysAdmin     |     Progress Software Corporation
[email-masked]        |     14 Oak Park
(617)280-4252                      |     Bedford, MA 01730-1414
http://www.progress.com            |
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

---

From: [email-masked] (Don Cunningham)
Date: Fri, 21 Jul 95 10:30:23 EDT

The problem only shows up on Sun clients. HP &
AIX systems can see the site commands. Is Sun
using some brain-dead version of ftp?

Don

***** In Reply To *****
>>command list. Any magic to turning on this
** End of Included Message **

---

From: "William L. Larson (Bill)" <[email-masked]>
Date: Fri, 21 Jul 1995 10:04:49 -0600 (MDT)

> >>command list. Any magic to turning on this

Yes, Sun (at least with SunOS 4.x, I don't know about Solaris) uses a
brain dead version of the ftp client which does not support the use of
the "SITE" command.

A VERY simple solution is to obtain the BSD ftp client software and
compile it on the Sun and replace the SunOS version.  I don't remember
exactly what was necessary, but considering that I did it, it can't be
too difficult.  If anyone is really interested, I can track this down
for you, but the sources are available all over the place.

Bill Larson  ([email-masked])	Phone: (505)844-2103
Sandia National Laboratories		  FAX: (505)844-2067
Org. 13918 M/S 0806
PO Box 5800
Albuquerque NM 87185