Subject: Re: undeclared varaibles

From: "Steven W. Litras" <[email-masked]>
Date: Mon, 17 Jul 1995 07:33:27 -0700

You need to replace your ftp.h (/usr/include/arpa/ftp.h) with the one in the 
distibution (support directory).

Good Luck,
Steve

In message <[email-masked]>  writes:
::I'm trying to compile wu-ftp 2.4 under SUN OS 4.1.3 with the gcc 2.5.8
::compiler.  When I "build s41" I keep getting undeclared error messages
::for the variables :
::
::  1) formnames
::  2) strunames
::  3) modenames  
::
::   All of these variables are in the yacc file - ftpcmd.c and ftpd.c
::can't find them and dies during the compile.  Any Ideas??????
::
::Martin B. Isaksen
::Defense Technical Information Center
::[email-masked]
::

---

From: [email-masked]
Date: Mon, 17 Jul 1995 10:04:51 -0500 (cdt)

I'm trying to compile wu-ftp 2.4 under SUN OS 4.1.3 with the gcc 2.5.8
compiler.  When I "build s41" I keep getting undeclared error messages
for the variables :

  1) formnames
  2) strunames
  3) modenames  

   All of these variables are in the yacc file - ftpcmd.c and ftpd.c
can't find them and dies during the compile.  Any Ideas??????

Martin B. Isaksen
Defense Technical Information Center
[email-masked]

---

From: Vidiot <[email-masked]>
Date: Mon, 17 Jul 1995 10:55:51 -0500 (CDT)

<You need to replace your ftp.h (/usr/include/arpa/ftp.h) with the one in the 
<distibution (support directory).

I forgot about that.  The reason my compile passed is that I did that for
the first time I built it.

I suggest that the INSTALL file include the above information.  I'm sure putting
the info at the top of the file will save others from the same grief.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.cdsnet.net/vidiot/  (Your link to the world of Star Trek)

---

From: Vidiot <[email-masked]>
Date: Mon, 17 Jul 1995 10:53:27 -0500 (CDT)

<
<I'm trying to compile wu-ftp 2.4 under SUN OS 4.1.3 with the gcc 2.5.8
<compiler.  When I "build s41" I keep getting undeclared error messages
<for the variables :
<
<  1) formnames
<  2) strunames
<  3) modenames  
<
<   All of these variables are in the yacc file - ftpcmd.c and ftpd.c
<can't find them and dies during the compile.  Any Ideas??????

Interesting, I just did a "build s41" of 2.4.2-beta 5 without a single
problem.  I used gcc 2.6.0.

MB