Subject: logging is not working!

From: Neil Brookins <[email-masked]>
Date: Fri, 28 Jul 1995 12:00:56 -0400 (EDT)

I spent the last two days installing and configuring ftpd.
Platform is SunOS4.1.3_U1 (gatekeeper.fnx.com)
I have everything working; except NOTHING is being logged into
/var/log/syslog  NOR  is there anything in /usr/adm/xferlog
(syslog does have sendmail's logging into it, just not ftpd's)
I want to log all commands and transfers in both directions.

I think I followed the instructions correctly...
In /etc/inetd.conf I have:
ftp   stream   tcp   nowait   root  /usr/local/etc/ftpd  ftpd -L -l

And in /usr/local/etc/ftpaccess I have:
----------------------------------cut here------------
class fullshell real *
class restrict guest *
guestgroup clients
tar      yes fullshell
tar      yes restrict
compress yes fullshell
compress yes restrict
loginfails 2
chmod     no guest
delete    no guest
overwrite no guest
rename    no guest
umask     no guest
banner                 /usr/local/etc/banner
message                /usr/lib/msg.login login
limit restrict  5 Any /usr/local/etc/msg.toomany
limit fullshell 10 Any /usr/local/etc/msg.toomany
log commands guest
log commands real
log transfer guest inbound, outbound
log transfer real  inbound, outbound
----------------------------------cut here-----------

Any ideas?

---->Neil

---

From: trylax <[email-masked]>
Date: Fri, 28 Jul 1995 12:43:20 -0400 (EDT)

> I want to log all commands and transfers in both directions.

I would suggest checking in pathnames.h to be sure syslog and xferlog are 
pointing to the right files and paths.

also you need -i to log files received to xferlog perhaps?

			Trylax

---

From: Andy Smith <[email-masked]>
Date: Fri, 28 Jul 1995 17:14:54 +0100 (BST)

according to Neil Brookins :-
> /var/log/syslog  NOR  is there anything in /usr/adm/xferlog

Just did the same myself - probably you want this in /etc/syslog.conf :-

daemon.debug    @loghost

(or whatever) and send a HUP to syslog.

That should sort out syslog, cant help you with xferlog though, worked
fine for me first time.
-- 
  _          __        
 /_|   _/   (  _  '_// 
(  |/)(/(/ __)//)/ //) 
        /