Subject: Re: Problems with exec's. in anonymous

From: [email-masked] (Tom Leach)
Date: Mon, 17 Jul 1995 09:33:39 -0700

you didn't say which OS you are running, but if it's a Sun running Solaris2x,
then make sure that ~ftp/dev/zero and ~ftp/dev/tcp exist along with any
library referenced by the execs.  You can test your set up by the following:
(as root on the FTP server)
chroot ~ftp /bin/ls (the /bin/ls is with respect to ~ftp).

You can also use truss (or trace on SunOS) to watch what's being loaded.

Tom Leach
[email-masked]

---

From: "Ketan Shah" <[email-masked]>
Date: Tue, 18 Jul 1995 16:19:36 -0400

what options should the ftpd be run with from the inetd.conf?

---

From: Vidiot <[email-masked]>
Date: Tue, 18 Jul 1995 15:52:17 -0500 (CDT)

<what options should the ftpd be run with from the inetd.conf?

Depends on your needs/configuration.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.cdsnet.net/vidiot/  (Your link to the world of Star Trek)

---

From: "Ketan Shah" <[email-masked]>
Date: Tue, 18 Jul 1995 18:08:09 -0400

On Jul 18,  3:52pm, Vidiot wrote:
> Subject: Re: Problems with exec's. in anonymous
>-- End of excerpt from Vidiot
Currently,I have the -ld options.

I would like to monitor/log the ftp transaction--files and people.
What information can I expect to find the /usr/adm/wtmp file?
Currently it seems to have garbage...

---

From: "Clarence Smith Jr." <[email-masked]>
Date: Tue, 18 Jul 1995 15:22:02 -0700 (PDT)

> Currently it seems to have garbage...

hmm...you could always use tcp_wrappers with your ftpdaemon, it comes 
with a file called 'xferlog' that contains the information you desire; 
that is, once you've 'wrapped' your (ftpd), etc.

==============================================================================
Clarence Smith, Jr				    [email-masked]  
SysAdmin/Tech Webmaster/Programming                     Knowledge Base Project
		http://www.hitl.washington.edu/pub/people/csmith
==============================================================================