Subject: Re: Problems with exec's. in anonymous

From: [email-masked] (Keith Smith)
Date: Wed, 19 Jul 1995 10:43:40 +1200

>Currently,I have the -ld options.
>
>I would like to monitor/log the ftp transaction--files and people.
>What information can I expect to find the /usr/adm/wtmp file?
>Currently it seems to have garbage...

The wtmp file contains the 'last' login records. ftpd will put entries into
this file to record that an ftp user logged in.  Did you use 'last' to view
this file?

I use the -l -a -L options, which will force ftpd to log all sessions and
all commands (made by users specified in ftpaccess) to the syslog.

In  my ftpaccess I have the lines:
   log commands    guest,anonymous
   log transfers   real,guest,anonymous    inbound,outbound
which logs all commands for all users except real (to the syslog), and all
file transfers (to the 'xferlog' file).

Remember to make sure that your /etc/syslog.conf has an entry for syslog
that your ftpd sends it logs to - 'daemon' is the default.  So my
/etc/syslog.conf has the line:
   daemon.info          /var/log/daemonlog

Hope this helps,
Keith.

---

From: "Ketan Shah" <[email-masked]>
Date: Wed, 19 Jul 1995 10:14:47 -0400

>  daemon.info          /var/log/daemonlog

Does SunOS 4.1.4 recognize
daemon.*	/var/log/daemonlog

or do I have to break
daemon.*

into

daemon.info
daemon.debug
daemon.err

Thanks for the help.

---

From: "Ketan Shah" <[email-masked]>
Date: Wed, 19 Jul 1995 10:58:50 -0400

I have included these lines in my ftpaccess file.
but the messages do not seem to show.?

readme		README* 	login
readme 		README* 	cwd=*

message		 /welcome.msg   	        login
message		 ~ftp/pub/.message        	cwd=*

What am I doing wrong?
I have included the -a flag for the ftpd to enable the ftpaccess file.
I am not clear whether the ftpaccess should be in the
/usr/local/etc/...   or   ~ftp/usr/etc/....

---

From: [email-masked] (Derald McMillan)
Date: Wed, 19 Jul 1995 11:17:00 -0400 (EDT)

The ftpaccess file should be in /etc (which might be a link to /usr/etc
on your system or might not).

Good Luck
-- 

Derald H McMillan III
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
SolTech Systems Corporation
1180 Sam Rittenberg Blvd.		 Phone: 803-556-2500
Suite 310				 Fax:   803-556-2596 
Charleston, SC 29407			 email: [email-masked]	
http://www.soltech.com

         "Out the 10Base-2, through the router, over the leased line,
             off the bridge, past the firewall...nothing but Net"
                             -Gary Predmore
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "Clarence Smith Jr." <[email-masked]>
Date: Wed, 19 Jul 1995 09:23:15 -0700 (PDT)

> /usr/local/etc/...   or   ~ftp/usr/etc/....

I believe that /usr/local/etc/ is the [default] place to put your 
ftpaccess file.  Also, the file does not have to be a dot-file (i.e. 
.message); 

And, the path suggested in yoru ftp access file (message /pub/.message), 
should be relative to your (ftp's -- home dir). For instance, I have mine 
in ftp's /etc dir: 
			message /etc/message LOGIN

Hope some of this helps.

==============================================================================
Clarence Smith, Jr				    [email-masked]  
SysAdmin/Tech Webmaster/Programming                     Knowledge Base Project
		http://www.hitl.washington.edu/pub/people/csmith
==============================================================================

---

From: "Ketan Shah" <[email-masked]>
Date: Wed, 19 Jul 1995 14:36:00 -0400

The following line is in my /etc/inetd.conf file.

ftp     stream  tcp     nowait  root    /usr/etc/in.ftpd        in.ftpd -laL

But I get Unknown flag -a ignored. what have I missed out this time?

Thanks everyone for your help.

-- 
Ketan Shah ([email-masked])              __/      __/	  __/__/__/__/
				    __/    __/	    	 __/
Varimetrix Corporation		   __/  __/		__/
2350 Commerce Pk. Dr., No. 4	  __/__/	       __/__/__/__/
Palm Bay, FL 32905		 __/  __/		       __/
                                __/    __/	      	      __/
Work: Tel. No.(407)-676-3222   __/      __/                  __/
Home:	      (407)-729-6819  __/        __/  __/  __/__/__/__/

---

From: [email-masked] (Al Longyear)
Date: Wed, 19 Jul 1995 19:09:06 -0700 (PDT)

> But I get Unknown flag -a ignored. what have I missed out this time?

That's the default value now. The '-A' must be specified if you wish to
ignore the ftpaccess file. The previous versions had this option reversed.

Just remove the 'a'. It is not important now.

-- 
Al Longyear           [email-masked]
Finger for PGP key

---

From: "Ketan Shah" <[email-masked]>
Date: Thu, 20 Jul 1995 09:28:58 -0400

On Jul 19,  7:09pm, Al Longyear wrote:
> Subject: Re: unknown flag
> Ketan Shah wrote:
>
>-- End of excerpt from Al Longyear

Thanks for the info, but I still have problems. The -L too has the
same problem as the 'a' option.
I still can't get the messages going.

Is there a way of finding out whether the ftpd is picking up the
ftpaccess file?

Also can some comment on the wrapper from my previous mail, and how
to use it? is it needed? and why?

---

From: "Ketan Shah" <[email-masked]>
Date: Fri, 21 Jul 1995 11:05:32 -0400

Thanks once again to all. Things seem to be working better.

How does one deny access to all from *.com or *.org for instance?

What kind of an entry would I include to do this?