Subject: wu-ftpd - Solaris - logging

From: [email-masked] (Pascal Maes)
Date: Mon, 17 Jul 1995 17:05:58 +0200

It seems that the command "last" on machines running Solaris 2.4 and using
the wu-ftpd (2.4) don't give a line like :

ftp       ftp      levant-gate-elec Mon Jul 17 16:48 - 16:49  (00:00)

this is not the case on machines running SunOS 4.x and using wu-ftpd (2.4)
or on machines running solaris 2.4 and using in.ftpd

any idea ?

--------------------------
Pascal Maes
UCL/FSA/ELEC
Place du Levant,3
B-1348 Louvain-la-Neuve
BELGIUM
email: [email-masked]

---

From: Marcel Schlapfer <[email-masked]>
Date: Mon, 17 Jul 1995 08:32:43 -0700

> or on machines running solaris 2.4 and using in.ftpd
 
Yes, I have noticed this too and am also curious why?

I've also noticed a difference in the output of ftpwho running Solaris 2.4.  
Under SunOS 4.1.3, output looks like:

Service class local: 
 9485 ?  S     0:00 -erendira.arc.nasa.gov: anonymous/marcel@ns (in.ftpd)
   -   1 users (  0 maximum)
 
Service class remote: 
   -   0 users (  0 maximum)
 
Under Solaris 2.4, it looks like...

Service class remote: 
 8 S     0  5772   139 22  41 20 fc038328    350 fc26f85e ?        0:00 in.ftpd
 8 S     0  4223   139 35  41 20 fc3e5678    350 fc26f576 ?        0:00 in.ftpd
 8 S     0  5770   139 42  41 20 fc534010    520 fc4b4296 ?        0:00 in.ftpd
 8 S     0  5790   139 47  41 20 fc56ecc0    520 fc185b4e ?        0:00 in.ftpd
 8 S     0  5738   139 66  41 20 fc037008    520 fc281c7e ?        0:01 in.ftpd
 8 S     0  5732   139 38  41 20 fc275980    518 fc52e066 ?        0:00 in.ftpd
 8 S     0  5769   139 80  41 20 fc56e660    350 fc357996 ?        0:03 in.ftpd
 8 S     0  5747   139 23  41 20 fc4c6340    350 fc185f2e ?        0:00 in.ftpd
 8 S     0  5779   139 32  41 20 fc535990    350 fc52e15e ?        0:00 in.ftpd
   -  9 users ( 50 maximum)

Under SunOS 4.1.3, the output was a little more usefull.  Any ideas on this 
one?

Thanks,
Marcel Schlapfer

--------

---

From: Brad Burdick <[email-masked]>
Date: Mon, 17 Jul 1995 11:55:37 -0400 (EDT)

> Under SunOS 4.1.3, the output was a little more usefull.  Any ideas on this 

SVR* derived Unix systems do not support the process/environment munging that
BSD Unix systems do...

-brad
-- 
Brad Burdick                                      [email-masked]
Internet Multicasting Service, NPB, Suite 1155, Washington, DC 20045
                Under contract from UUcom, Inc.