Subject: password/group problem

From: Eric Vielet <[email-masked]>
Date: Mon, 24 Jul 1995 17:42:03 +0200

I try to install wu-ftp2.4 under solaris2.4

Everything is OK, except that i didn't succeed in getting owner names rather 
than numbers.

Here's what i have :

~ftp/etc/passwd :

root:*:0:1:Mr Root:/:/bin/csh
ftp:*:901:900:Anonymous ftp:/usr/local/ftp:/bin/false

~ftp/etc/group :

other:*:1:
archive:*:900:ftp

when i do "ls -al" in ~ftp :

drwxr-xr-x   7 ftp      archive      512 Jul 21 09:09 ./
drwxr-xr-x  16 root     other        512 Jul 21 11:37 ../
drwxr-xr-x   2 root     other        512 Jul 24 15:10 bin/
drwxr-xr-x   2 root     other        512 Jul 24 10:00 dev/
drwxr-xr-x   3 root     other        512 Jul 24 15:19 etc/
drwxr-xr-x   2 ftp      archive      512 Jul 21 12:07 pub/
drwxr-xr-x   3 root     other        512 Jul 24 15:13 usr/

and in ~ftp/etc

drwxr-xr-x   3 root     other        512 Jul 24 15:19 ./
drwxr-xr-x   7 ftp      archive      512 Jul 21 09:09 ../
-r--r--r--   1 root     other         28 Jul 24 17:06 group
drwxr-xr-x   2 root     other        512 Jul 20 17:35 msgs/
-r--r--r--   1 root     other         84 Jul 24 17:08 passwd

When i log as anonymous ftp user, if i do a "ls" :

ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 14
drwxr-xr-x   7 901      900          512 Jul 21 07:09 .
drwxr-xr-x   7 901      900          512 Jul 21 07:09 ..
drwxr-xr-x   2 0        1            512 Jul 24 13:10 bin
drwxr-xr-x   2 0        1            512 Jul 24 08:00 dev
drwxr-xr-x   3 0        1            512 Jul 24 13:19 etc
drwxr-xr-x   2 901      900          512 Jul 21 10:07 pub
drwxr-xr-x   3 0        1            512 Jul 24 13:13 usr
226 Transfer complete.
ftp> 

What's wrong ??
------------------------------------------------------------------------
Vielet Eric			| CRIHAN
Phone : (+33) 35 59 61 59	| Parc Technologique de la Vatine
Fax   : (+33) 35 59 61 40	| 32, rue Raymond Aron
E-mail : [email-masked]		| 76130 Mont-Saint-Aignan, France
------------------------------------------------------------------------

---

From: Luc Desrosiers <[email-masked]>
Date: Mon, 24 Jul 1995 13:43:08 -0400

> Everything is OK, except that i didn't succeed in getting owner names rather 

using ls which comes with solaris 2.4, you will need these library to make
it work properly:

---x--x---   1 bin      web        97804 Jul 16  1994 ld.so.1
lrwxrwxrwx   1 root     root          11 Jul  7 18:32 libc.so -> ./libc.so.1
-r--r-----   1 bin      web       621540 Mar  9 15:30 libc.so.1
lrwxrwxrwx   1 root     root          10 Jul  7 18:32 libdl.so -> libdl.so.1
-r--r-----   1 bin      web         3492 Jul 15  1994 libdl.so.1
lrwxrwxrwx   1 root     root          12 Jul  7 18:32 libintl.so -> 
libintl.so.1
-r--r-----   1 bin      web        13516 Jul 15  1994 libintl.so.1
-r--r-----   1 bin      web        88868 Jul 16  1994 libld.so.1
lrwxrwxrwx   1 root     root           9 Jul  7 18:32 libw.so -> libw.so.1
-r--r-----   1 bin      web        41704 Jul 15  1994 libw.so.1

If you want as well to see what's in etc/password and /etc/group instead
od number, add

nss_files.so.1

and finally, if you want to see who is logging in with ftp using the
last command, you have to use wu-ftp 2.4.2BETA5. The "old" wu-ftp 2.4 
cannot log entry in wtmpx

or else, get a static version of ls.

good luck
Luc Desrosiers
CIRISQ, CRIM

---

From: "Ketan Shah" <[email-masked]>
Date: Mon, 24 Jul 1995 15:21:12 -0400

where can i find the latest version of wu-ftpd?

Thanks.

-- 
Ketan Shah ([email-masked])
	
Varimetrix Corporation
2350 Commerce Pk. Dr., No. 4
Palm Bay, FL 32905
   
Work: Tel. No.(407)-676-3222

---

From: Andy Smith <[email-masked]>
Date: Tue, 25 Jul 1995 09:51:37 +0100 (BST)

according to Ketan Shah :-
> where can i find the latest version of wu-ftpd?

Did you get an answer?  I just tried ftp.wustl.co.uk, but that server
is sooo busy..

-- 
  _          __        
 /_|   _/   (  _  '_// 
(  |/)(/(/ __)//)/ //) 
        /

---

From: Alexander Haiut - Software Support <[email-masked]>
Date: Tue, 25 Jul 1995 12:47:02 +0300 (IDT)

> > where can i find the latest version of wu-ftpd?

	I guess ftp://wuarchive.wustl.edu/ is official wu-ftpd home;
	The site ftp://ftp.academ.com/ contains Academ's version of
	wu-ftpd, modified by Stan Barber <[email-masked]>.

			Thanks!			--alex.

--
 
Alexander L. Haiut                                             +972-3-7513633
Software Engineer					      [email-masked]
E & M Computing, Ltd.				http://www.eandm.co.il/~alx/

---

From: "Ketan Shah" <[email-masked]>
Date: Tue, 25 Jul 1995 09:00:27 -0400

I apologize, I did read all my mail this morning. Hence the previos
message, regarding request for sites to download from.

Thanks and my apologies.

-- 
Ketan Shah ([email-masked])
	
Varimetrix Corporation

---

From: "Ketan Shah" <[email-masked]>
Date: Tue, 25 Jul 1995 08:57:52 -0400

On Jul 25,  9:51am, Andy Smith wrote:
> Subject: Re: wu-ftpd latest
>-- End of excerpt from Andy Smith

Sorry no answers yet?
Someone out there thats a hint...Please direct us towards the lastest
version.

-- 
Ketan Shah ([email-masked])
	
Varimetrix Corporation