Subject: Re: sun 4.1.3 problems with dir

From: [email-masked] (Roger Kuhlman)
Date: Fri, 7 Jul 95 17:02:19 EDT

> 
> ls -l and dir in ftp are different than normal. Under ~/ftp you need to
> have the lib directory with ld.so and libc.so.1* and libdl.so.* (if it
> exists), you also need dev/zero. Things are slightly different for Solaris
> lib subdirectory. I don't recall offhand those exact requisites. Sorry.
> 
> Hope something here helps.
> 
> PCVS
> 
	I compiled the GNU ls and vdir static, so unless SunOs is really
twisted, shared libraries should not matter. I did a file on them,
and it reported 'dir: sparc demand paged executable'
and 'ls: sparc demand paged executable'
I also had previously created /dev/zero
with proper permissions (/dev dir 555 and zero 666);
	I'm stumped.

	Roger Kuhlman

---

From: [email-masked] (Roger Kuhlman)
Date: Fri, 7 Jul 95 17:29:01 EDT

> with proper permissions (/dev dir 555 and zero 666);
again, just in case GNU ls is broken, i made a copy of /bin/ls and put it
in the ftp bin directory, and made a link to /usr/lib, failed, and made 
a lib directory and copied ld.so, libc.so.1.9 and libdl.so.1.0 to the lib
directory.  Still zilch

	Thanks, RK

---

From: "Ketan Shah" <[email-masked]>
Date: Fri, 7 Jul 1995 17:41:48 -0400

On Jul 7,  5:29pm, Roger Kuhlman wrote:
> Subject: Re: sun 4.1.3 problems with dir
> >
> > >
>-- End of excerpt from Roger Kuhlman

I do have that problem on sun4.1.4
I have

ld.so
libc.so.1.9.1
libdl.so.1.0

Do not make any links.

---

From: "The best things in life ... are fantasy." <[email-masked]>
Date: Fri, 7 Jul 1995 16:00:52 -0400 (EDT)

PCVS

---

From: "Zachary K. Girouard" <[email-masked]>
Date: Fri, 7 Jul 1995 15:15:50 -0500 (CDT)

Hello fellow wu-ftpd users:

Having just installed wu-ftpd on our systems, I was wondering
one thing:
(Forgive me if this is in the docs, I read them all and didn't
 see it.)

Is there a way to set something up like ncsa_httpd's /~foouser/public_html
directories?

I would like to be able to allow my users to make certain files available
for anon ftp users. I was hoping the could create a directory in their
home dir (say, public_ftp), and somehow do it that way.

Does wu-ftpd support this?

Thanks in advance
-=Zakk

Zachary Girouard,
Systems Administrator, Intersurf Online Inc.
[email-masked]

(using my school account for mail until our domain name is registered)

---

From: [email-masked] (Roger Kuhlman)
Date: Sat, 8 Jul 95 15:57:29 EDT

Hello:
	I finally figured out the dir problem.  The instructions 
in the O'Reilly Book, and in the distribution says that the
default bin path is ~ftp/bin/ftp-exec.  Not so. That is an
INSTRUCTION for the daemon to look for the executables for
ftp anonymous users in the directory ~ftp/bin!!
	One does need /dev/zero, and either a statically linked ls,
OR a copy of the three libraries /usr/lib/ld.so, /usr/lib/libc.so.x.x
and /usr/lib/libdl.so.x.x (where x.x are the version numbers of the 
libraries) and these MUST be not in a lib directory off ~ftp,
but in a /usr/lib/directory!!!
	Wheeeew!

	Roger Kuhlman