Subject: Re: Solaris 2.4 vs. wuftpd 2.4

From: [email-masked]
Date: Fri, 7 Jul 1995 07:47:48 +0200

rh> 
rh> The current score is not in favor of the server...
rh> 
rh> Two problems really...
rh> 
rh> a) anonymous logins get in, but can't do anything, they seem to lose all
rh>    knowledge of the sending address, e.g.
rh> 
rh>     230 Guest login ok, access restrictions apply.
rh>     ftp> ls
rh>     200 PORT command successful.
rh>     425 Can't create data socket (0.0.0.0,20): Bad file number.

Looks to me like one of the following applies here:
- your <ftp-root>/dev is not OK (check in.ftpd(1M))
- your <ftp-root>/usr/lib is not OK (check in.ftpd(1M))
- your link <ftp-root>/lib -> usr/lib is not there
- you are mounting <ftp-root> over NFS with the nosuid option active, don't

rh> 
rh> 	real users get to keep the ip address (I checked that).
rh> 
rh> b) even though I defined SETPROCTITLE, the name of the loginee(?) 
rh>    doesn't show up on a ps, even though it seems fine under SunOS.

This changed under SunOS 5.x. This stopped working for all my program's
that did this under SunOS 4.1.x. A strcpy to argv[0] used to be enough,
but it is not any more.

I hope this helps,

Ronald.

__
// Ronald Hello  ([email-masked])
// University of Twente
// Department of Computer Science
// The Netherlands

---

From: John Grant <[email-masked]>
Date: Fri, 7 Jul 1995 09:11:31 -0700 (PDT)

Many thanks ! I was missing the dev directory. I read the man pages that 
came with wuftpd, but never tought to look at the Solaris ones - I never
expected them to be *that* helpful, a script too !

											John