Subject: FAQ for wu-ftpd

From: Abel Sanchez <[email-masked]>
Date: Wed, 05 Jul 1995 09:43:11 -0600

Hi,

	Is there an FAQ for wu-ftpd somewhere out there? I've compiled wu-ftpd 2.4
	for IRIX 5.2 and some things are not working correctly. For instance, 
	I get GMT in the xferlogs and magic cookies aren't working right. If
	you know of an FAQ I would appreciate an address.

	Thanks.

	Abel Sanchez
	[email-masked]

---

From: Edward Murphy <[email-masked]>
Date: Wed, 5 Jul 1995 11:15:28 -0500 (CDT)

Abel,

To Abel and others, try the WUarchive WU-FTPD web page:

  http://fegmania.wustl.edu/ftp.html

I found it extremely helpful.

Ed

P.S. Is there any more work on the idea of a periodic list posting of 
basic information such as the above? --em

   ----------------------------------------------------------------
			    Edward Murphy
	  [email-masked] * http://www.uno.edu/~emurphy

---

From: Matthew Bailey <[email-masked]>
Date: Wed, 5 Jul 1995 22:24:49 -0400 (EDT)

I remember a few months back when someone mentioned that they had a program
that would place ftp archive log information into a nice html format...
If anyone has this or knows where I can find this please let me know. I 
hate having to rwite programs and then find out there is one already out 
there. This I one I know is out there I just need to find it. :)

N E WAY enjoy!
Thanks
Matthew S. Bailey
[email-masked]

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 6 Jul 95 9:23:19 MET DST

> there. This I one I know is out there I just need to find it. :)

That was me ;-)

The file is now in perl, and is in

ftp.cetis.hvu.nl:/pub/koos/ftplogcheck

To check the html output it generates, look at :

http://www.cetis.hvu.nl/system/ftpusage.html

                                        Grtx. KH

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)

---

From: "Ketan Shah" <[email-masked]>
Date: Thu, 6 Jul 1995 16:04:02 -0400

Need help setting up my wu-ftp site!

Any volunteers?
Its on a sun sparc 4.1.4

I have the files in place but dont know what to do with them.
such messages, access, etc, also whether I need the ftpd in ~ftp/bin etc...

-- 
Ketan Shah (Source Code Admininstrator)

Varimetrix Corporation
2350 Commerce Pk. Dr., No. 4
Palm Bay, FL 32905

Tel. No. (407)-676-3222

---

From: [email-masked] (Kelly Setzer)
Date: Thu, 06 Jul 1995 15:27:18 -0500 (CDT)

> such messages, access, etc, also whether I need the ftpd in ~ftp/bin etc...

I don't mind helping out....I just went through my first install a few
months ago and have done several more since .

Kelly

---

From: "Ketan Shah" <[email-masked]>
Date: Fri, 7 Jul 1995 17:11:32 -0400

On Jul 6,  3:27pm, Kelly Setzer wrote:
> Subject: Re: Logging program?
> >
>-- End of excerpt from Kelly Setzer

Thanks, looking forward to your help.

-- 
Ketan Shah ([email-masked])

Varimetrix Corporation

Work: Tel. No. 	(407)-676-3222
Home:		(407)-729-6819

---

From: "Ketan Shah" <[email-masked]>
Date: Wed, 12 Jul 1995 15:59:25 -0400

I need a little help in setting up my ftp server?
On a Sun Sparc 4.1.4.

-- 
Ketan Shah ([email-masked])                 __/	 __/	       __/__/__/__/
				       __/    __/	      __/
Varimetrix Corporation		      __/  __/		     __/
2350 Commerce Pk. Dr., No. 4	     __/__/		    __/__/__/__/
Palm Bay, FL 32905		    __/  __/		            __/
                                   __/    __/	  		   __/
Work: Tel. No. 	(407)-676-3222    __/      __/                    __/
Home:		(407)-729-6819   __/        __/  __/    __/__/__/__/

---

From: Vidiot <[email-masked]>
Date: Wed, 12 Jul 1995 15:29:36 -0500 (CDT)

<I need a little help in setting up my ftp server?
<On a Sun Sparc 4.1.4.

I guess it is time to post the script again.  It is a great aid in getting
a starting configuration in place.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.cdsnet.net/vidiot/  (Your link to the world of Star Trek)

#!/bin/sh

# Set this to whoever will maintain your ftp site. root is probably a good bet.
# Your username is another possibility.  ftp is NOT!  No directories or files
# inside ~ftp should be owned by ftp.
YOU=root

# No other parameters should need to be changed

# Get the UID of YOU and ftp
YOUUID=`grep "^$YOU:" /etc/passwd | cut -d: -f3`
if [ "x" = "x$YOUUID" ]; then
  echo User $YOU not found
  exit
fi
FTPDIR=`grep "^ftp:" /etc/passwd | cut -d: -f6`
if [ "x" = "x$FTPDIR" ]; then
  echo ftp home directory not found
  exit
fi

# Find the correct libc.so and libdl.so
LIBC=`ls /usr/lib/libc.so.* | tail -1`
LIBDL=`ls /usr/lib/libdl.so.* | tail -1`

install -d -o $YOU -g wheel -m 755 $FTPDIR
cd $FTPDIR
install -d -o root -g wheel -m 555 bin
install    -o root -g wheel -m 111 /usr/bin/ls bin
install -d -o root -g wheel -m 555 dev
install -d -o root -g wheel -m 555 etc
install -d -o $YOU -g wheel -m 722 incoming
install -d -o $YOU -g wheel -m 755 pub
install -d -o root -g wheel -m 555 usr
install -d -o root -g wheel -m 555 usr/lib
install    -o root -g wheel -m 555 /usr/lib/ld.so  usr/lib
install    -o root -g wheel -m 555 $LIBC usr/lib
if [ "x" != "x$LIBDL" ]; then
install    -o root -g wheel -m 555 $LIBDL usr/lib
fi
install -d -o root -g wheel -m 555 usr/share
install -d -o root -g wheel -m 555 usr/share/lib
install -d -o root -g wheel -m 555 usr/share/lib/zoneinfo
install    -o root -g wheel -m 444 /usr/share/lib/zoneinfo/localtime usr/share/lib/zoneinfo

mknod dev/zero c 3 12
chown root.wheel dev/zero
chmod 444 dev/zero

echo "wheel:*:0:" >etc/group
chown root.wheel etc/group
chmod 444 etc/group

echo "root:*:0:0:::" >etc/passwd
if [ $YOUUID != 0 ]; then
echo "ftpadmin:*:$YOUUID:0:::" >>etc/passwd
fi
chown root.wheel etc/passwd
chmod 444 etc/passwd

exit

---

From: Matthew Bailey <[email-masked]>
Date: Wed, 12 Jul 1995 18:35:13 -0400 (EDT)

> I need a little help in setting up my ftp server?

Hey if your not in a rush :) and can wait a week I can help you just as 
soon as I finish our 4.1.4 upgrade......

Also have you compiled X11R6 on 4.1.4 and then emacs or xxgdb????

Thanks
Matt

---

From: "Ketan Shah" <[email-masked]>
Date: Thu, 13 Jul 1995 09:00:18 -0400

On Jul 12,  6:35pm, Matthew Bailey wrote:
> Subject: Re: Need a little help
Thanks I think I can wait.

> Also have you compiled X11R6 on 4.1.4 and then emacs or xxgdb????

Nope have not compiled X11R6...

>-- End of excerpt from Matthew Bailey