Subject: Errors compiling wu-ftpd V2.4

From: [email-masked] (Dominique Baisnee)
Date: Fri, 7 Jul 1995 09:42:04 +0100

Hello,

        I tried to compile wu-ftpd 2.4 on an DEC Alpha 3000/300 under OSF/1
V3.0 and I've got the following errors :

build osf
make args are :
make opts are :

Linking Makefiles.
ln: Makefile and makefiles/Makefile.osf are identical.
ln: config.h and config/config.osf are identical.
ln: Makefile and makefiles/Makefile.osf are identical.

Making support library.
rm -f libsupport.a
ar cq libsupport.a getusershell.o fnmatch.o strcasestr.o strerror.o strsep.o aut
huser.o
ranlib libsupport.a
s - creating symbol hash table. Wait...

Making ftpd.
`ftpd' is up to date.

Making ftpcount.
cc -O -DDEBUG -I.. -I../support -L../support -s -x -o ftpcount ftpcount.c vers.o
 -lsupport
/usr/lib/cmplrs/cc/cfe: Error: ./extensions.h, line 28: Syntax Error
 struct aclmember {
 ^
*** Exit 1
Stop.

Making ftpshut.
cc -O -DDEBUG -I.. -I../support -L../support -s -x -o ftpshut ftpshut.c vers.o -
lsupport
/usr/lib/cmplrs/cc/cfe: Error: ftpshut.c, line 54: Syntax Error
 int denyoffset = 10;
 ^
*** Exit 1
Stop.

Making ckconfig.
`ckconfig' is up to date.
ln: ftpwho and ../src/ftpcount are identical.
ln: ckconfig and ../src/ckconfig are identical.

Links to executables are in bin directory:
text    data    bss     dec     hex
106496  32768   23632   162896  27c50   bin/ftpd
16384   8192    0       24576   6000    bin/ftpcount
16384   8192    0       24576   6000    bin/ftpshut
16384   8192    0       24576   6000    bin/ftpwho
8192    8192    0       16384   4000    bin/ckconfig
Done

Please help me, I send this message few days ago and I've got no response yet.

===================================================================*********
**********************************************************

   Mme Dominique BAISNEE
Centre des Faibles Radioactivités
   Service Informatique
  Laboratoire mixte CEA/CNRS

Avenue de la Terrasse
   91198 GIF SUR YVETTE
   --------------------
     Tel : 69-82-43-51
     Fax : 69-82-35-68
     E-mail : [email-masked]

---

From: Matt Klevemann <[email-masked]>
Date: Fri, 7 Jul 1995 10:53:33 -0400 (EDT)

Has anyone got a version of wu-ftpd with shadow password support for 
Linux ?

Thanks,
matt

=============================================================================
Matt Klevemann, Branch Of Information Services (ADP), U.S. Bureau Of Mines
email: [email-masked]  voice: 412-892-6499   fax: 412-892-4205

                      We Like Rocks, They Like Us
=============================================================================

---

From: Bjarki Magnusson <[email-masked]>
Date: Fri, 7 Jul 1995 23:32:31 +0000 (GMT)

I guess I have an old version of wu-ftpd for linux which apperantly has some
security holes in it.

Can anyone advise me if I can get a secure precompiled wu-ftpd for linux 
(slackware), I have tried compiling one, but build lnx returns error
errors and does not manage to build anything.

Kind regards

[email-masked]

---

From: [email-masked]
Date: Sun, 9 Jul 1995 00:37:16 +0100 (BST)

> errors and does not manage to build anything.

   Take a look at:

   nix.mechnet.liv.ac.uk:/pub/Linux/Wu-ftpd/wu-ftpd-2.4.nix.tar.gz

Its the source I fixed up (probly after the same errors you got) and
seems to work just fine for nix itself.

  Anyone want to chekc what I did to see if I glaringly broke
anything? (I didn't spot anything in a few quick tests and have had no
complaints from users, been in operation for over 6 weeks now).

-Neil
-- 
**************************************************************************
* Neil Peter Charley          * Athanasius                               *
* [email-masked]           * Surfers - zippy.spods.dcs.kcl.ac.uk 3232 *
* [email-masked]    * MeatMud - bovina.cs.utexas.edu 2800      *
* [email-masked] * Resort  - evans.cudenver.edu 2323        *
**************************************************************************