Subject: wu-ftp and afs

From: "Laura de Leon" <[email-masked]>
Date: Wed, 19 Jul 1995 10:01:26 -0700

Does anyone have a recent version of wu-ftp modified to work with AFS,
preferably on HP-UX?

Please let me know if you do.

Thanks!

				Laura de Leon
				[email-masked]

---

From: Michelle Butler <[email-masked]>
Date: Wed, 19 Jul 1995 16:40:45 -0400

modified how?  

NCSA has 3 HP workstations running on HP-UX... running wu-ftp 2.4 ... all 
files served from AFS. 

I installed the normal ftp server, and pointed the home directory to somewhere
in AFS land. 

Michelle Butler 

---------  Received message begins Here  ---------

 !! From [email-masked] Wed Jul 19 12:57:49 1995
 !! Received: from transarc.com by newton.ncsa.uiuc.edu with SMTP id AA29211
 !!   (5.65a/IDA-1.4.2 for mbutler); Wed, 19 Jul 95 12:57:37 -0500
 !! Received: by transarc.com (5.54/3.15) id <AA02483>; Wed, 19 Jul 95 13:13:55 EDT
 !! Received: via switchmail; Wed, 19 Jul 1995 13:13:54 -0400 (EDT)
 !! Received: from transarc.com via qmail
 !!           ID </afs/transarc.com/service/mailqs/sq1/QF.sk3HojX0Bi8101KkAe>;
 !!           Wed, 19 Jul 1995 13:13:19 -0400 (EDT)
 !! Received: from po2.transarc.com via qmail
 !!           ID </afs/transarc.com/service/mailqs/sq1/QF.Uk3HjlP0Bi8241XkAg>;
 !!           Wed, 19 Jul 1995 13:08:08 -0400 (EDT)
 !! Received: from po2.transarc.com via qmail
 !!           ID </afs/transarc.com/service/mailqs/q1/QF.0k3Hdyr0Bi824OJU4:>;
 !!           Wed, 19 Jul 1995 13:01:53 -0400 (EDT)
 !! Received: from hplms26.hpl.hp.com (hplms26.hpl.hp.com, [15.255.168.31]) by po2.transarc.com (5.54/3.15) id <AA06732> for Info-AFS; Wed, 19 Jul 95 13:01:33 EDT
 !! Received: from hplabsz.hpl.hp.com by hplms26.hpl.hp.com with ESMTP
 !! 	($Revision: 1.36.108.11 $/15.5+ECS 3.3+HPL1.1S) id AA178383321; Wed, 19 Jul 1995 10:02:03 -0700
 !! Received: by hplabsz.hpl.hp.com
 !! 	(1.37.109.15/15.5+ECS 3.3+HPL1.1) id AA188023287; Wed, 19 Jul 1995 10:01:27 -0700
 !! From: "Laura de Leon" <[email-masked]>
 !! Message-Id: <[email-masked]>
 !! Date: Wed, 19 Jul 1995 10:01:26 -0700
 !! X-Mailer: Z-Mail (3.0.0 15dec93)
 !! To: [email-masked], [email-masked]
 !! Subject: wu-ftp and afs
 !! Content-Type: text/plain; charset=us-ascii
 !! Mime-Version: 1.0
 !! Status: N
 !! Content-Length: 173
 !! X-Lines: 9
 !! X-Display-Position: 0
 !! 
 !! Does anyone have a recent version of wu-ftp modified to work with AFS,
 !! preferably on HP-UX?
 !! 
 !! Please let me know if you do.
 !! 
 !! Thanks!
 !! 
 !! 				Laura de Leon
 !! 				[email-masked]
 !! 

Michelle Butler 
National Center for Supercomputing Applications 
AFS & Mass Storage 
email: [email-masked]

---

From: Mitch Collinsworth <[email-masked]>
Date: Thu, 20 Jul 95 13:14:53 -0400

>I installed the normal ftp server, and pointed the home directory to somewhere

Yeah, that's what I've done here and so far, mostly good.

--BUT--

First, while it seems to do a good job providing an anonymous ftp server,
it doesn't work if someone wants to ftp in with their own username/password
and access their home directory.  Since it doesn't authenticate to AFS,
there is no token (unless they first telnet and klog).

Second, there is a security concern that Rick Cochran has pointed out
here before.  If you happen to login to the ftp server as root, do a klog,
and leave a token owned by root laying around, all anonymous ftp users
will have access to that token until it expires (or you unlog it)!

I've found a pointer to an AFS-aware WUarchive FTPd on the AFS Reference
Page at http://www.contrib.andrew.cmu.edu:8001/usr/db74/afs.html  but
haven't checked it out yet.  Hope to soon.  Hopefully it does the right
thing.  If you get to it first, how about a report?