Subject: .tar files 0 bytes long

From: trylax <[email-masked]>
Date: Wed, 26 Jul 1995 19:41:06 -0400 (EDT)

Okay, I finally got my wu-ftpd server working good. Reads the ftpaccess 
file, lets the right people in, displays the nice .message files, 
and ALMOST lets you get <dir>.tar and <dir>.tar.gz

It correctly gets a <dir>.tar or .tar.gz
exept that it gets 0 byte files!
yes i copied tar, gzip to ~ftp bin, and made a link for compress.

any ideas? when it cant find tar it yells about that, it didnt yell. said 
no problem, opening data connection, and creates a zero bite file on the 
local side.....

				Thanks,
				Trylax

---

From: Simon-Bernard Drolet <[email-masked]>
Date: Wed, 26 Jul 1995 21:18:35 -0400 (EDT)

You really need tar from GNU !

Be sure that it's working in a chroot() env. To try it, do
a cd ~/ftp. Then, do "chroot . tar cvf tarfile your-dir-in-ftp".

If it's works, it should with ftp.
-- 
Simon-Bernard Drolet                E-mail: [email-masked]
Administrateur de systemes Unix     Tel:    (819) 564-5600 ext.4819
Centre Canadien de Geomatique       Fax:    (819) 564-5698
"I'm Pentium of Borg. Division is futile. You will be approximated..."

---

From: Gregory A Lundberg <[email-masked]>
Date: Wed, 26 Jul 1995 21:27:35 -0400 (EDT)

> If it's works, it should with ftp.

If it doesn't, get the GNU tar and be sure to link standalone.  If you 
link with dynamic libraries it won't work. 

----

Gregory A Lundberg		Senior Partner, VRnet Company
1441 Elmdale Drive              email: [email-masked] [199.18.177.65]
Kettering, OH 45409-1615 USA    voice: +1 (513) 299-7653

---

From: Tien Dao <[email-masked]>
Date: Thu, 27 Jul 1995 11:52:39 +1000

Hi all,

I have just installed wu-ftpd2.4.
Currently I cannot invoke the "compress"  feature when retrieving
a <file>.Z (real name is <file>).

The error I got is 

  200 PORT command successful.
  550 Local error: conversion program not found. Cannot COMPRESS file.

My ftpconversions entries:

:.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
:   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS

My "compress" program is in both /usr/bin/compress as well as ~/ftp/bin

Could someone please tell me what I've done wrong?

Thanks
Tien Dao