Subject: Compiling probs (NCARGS, IRIX 5.3)

From: Tobias Richter <[email-masked]>
Date: Thu, 6 Jul 95 0:53:24 MET DST

Hi (i'm new),

I just tried to compile wu-ftpd but i have problems doing so.
It seems that 'NCARGS' with is used in glob.c is never defined.
I have idea what this value is for - so what shall i do?

I have IRIX 5.3 here and tried out 'build sgi'.

TNX

Tobias

-- 
IPK		| Telefon  : 030/314-21733
Bereich-KT	| Telefax  : 030/3911037
Pascalstr. 8-9	| E-Mail   : [email-masked]
10587 Berlin 	| DFN-Mail : G=Tobias;S=Richter;O=IPK;P=FHG;A=DBP;C=de

---

From: "Erik Patynen" <[email-masked]>
Date: Thu, 6 Jul 1995 10:17:58 +0000

On Jul 5, 11:53pm, Tobias Richter wrote:
> Subject: Compiling probs (NCARGS, IRIX 5.3)
> Hi (i'm new),
>

Here is the beginning of the glob.c I managed to compile under
IRIX 5.3 after meny difficulties. Plus I used the CC-flag
-cckr  (to get rid of the warning messages during the compilation)
and -mips2 (to produce R4000 compliant executables, the default is
R3000 which do run on the R4000 system). And according the advices
on this list the shared library /lib/libc.so.1 should be copied under the
~ftp/lib -directory.

/* beginning of the excerpt of glob.c */

#ifndef lint
static char sccsid[] = "@(#)glob.c      5.9 (Berkeley) 2/25/91";
#endif /* not lint */

/*
 * C-shell glob for random programs.
 */
#include "config.h"

#include <sys/param.h>
#include <sys/stat.h>

#ifdef HAVE_DIRENT
#include <dirent.h>
#else
#include <sys/dir.h>
#endif

#include <pwd.h>
#include <errno.h>
#include <stdio.h>
#include <string.h>

#define QUOTE 0200
#define TRIM 0177
#define eq(a,b)         (strcmp(a, b)==0)
#define NCARGS 960
#define GAVSIZ          (NCARGS/6)
#define isdir(d)        ((d.st_mode & S_IFMT) == S_IFDIR)

/*end of the excerpt from the glob.c */

-- 
* Erik Patynen         **IXTJ**          <grin>       [email-masked] *
* EVITech                       Finland                  [email-masked] *
* Espoo-Vantaa Institute of Technology, Department of Information Technology *
* <A HREF="http://www.evitech.fi/~erikp/home.shtml">Erik's Home Page</A> *****