Subject: BETA-3 is now available

From: [email-masked] (Stan Barber)
Date: Sun, 18 Jun 1995 21:36:25 -0500 (CDT)

I did some more work and now the third beta is ready. This one has been
check on linux 1.2.8 and more throughly on Solaris 2.4 than previously.

The URL is:

ftp://ftp.academ.com/pub/wu-ftpd/private/wu-ftpd-2.4.2-beta-3.tar

There is also updates to the documentation files in this beta.

-- 
Stan   | Academ Consulting Services        |internet: [email-masked]
Olan   | For more info on academ, see this |uucp: bcm!academ!sob
Barber | URL- http://www.academ.com/academ |Opinions expressed are only mine.

---

From: Matthew Bailey <[email-masked]>
Date: Mon, 19 Jun 1995 20:58:26 -0400 (EDT)

> There is also updates to the documentation files in this beta.
I saw a while back that someone had hacked virtual hosts into the code.
Would someone give me a pointer as to where that might be...
I would really like to use this code. I also need to use two totally 
different sub trees please tell me how.

Thanks again.
Matthew S. Bailey
[email-masked]

---

From: [email-masked] (Warren Burstein)
Date: Tue, 20 Jun 1995 09:44:11 +0300

> Would someone give me a pointer as to where that might be...

What I did was I added a switch to override the ~ftp dir.  It's up to
you to arrange to have different copies of ftpd run for each virtual
host, each with a different ~ftp dir.

It's in ftp:://israel.nysernet.org/ftpd

---

From: Mikael Hugo <[email-masked]>
Date: Tue, 20 Jun 1995 09:55:43 +0200 (MET DST)

Hi everybody!

I have been searching high and low for a solution like this:

That I can offer my users a ftp://ftp.dataphone.se/pub/users/$user directory.

In other words that the user can create a $home/ftp directory, and share 
some of his files, for others to access with anonymous ftp.

I have tried to consult other Internet Providers, but they dont want to 
let go of the secret.

Thank you in advance!

	Mikael Hugo

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Tue, 20 Jun 95 10:48:03 MET DST

> I have tried to consult other Internet Providers, but they dont want to 

mkdir ~ftp/pub/users/$user
chown $user ~ftp/pub/users/$user
ln -s ~ftp/pub/users/$user ~$user/ftp

                                            Grtz. KH

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)

---

From: Rob Jenson <[email-masked]>
Date: Tue, 20 Jun 1995 11:16:08 -0400 (EDT)

One solution is as follows:

When a user needs an outgoing FTP directory,
we create one within the chroot()'ed area
for them.  The /etc/passwd file that wuftp
sees contains a reference to that user and
their directory relative to the chroot() root,
i.e., /pub/users/jim.  The user is responsible
for moving the files to this area, and policy
dictates that only outgoing files may go here
(incoming is handled completely differently).

e.g.:
====
Real /etc/passwd entry:
jim:SoMeCrYptOfLd:1011:100:Jim Someone:/diska/home/jim:/bin/csh

$FTPROOT/etc/passwd entry:
jim:*:1011:100:Jim Someone:/pub/users/jim:/bin/sh

This is somewhat inconvenient (compared to making
a directory in the home filesystem automagically FTP-able),
but considerably more secure.

As a rule of thumb, we also don't make the $FTPROOT filesystem
available via NFS, for added user inconvenience and
greater security.

_rob_
>...From the mail of Mikael Hugo:
> Hi everybody!
> 

-- 
Rob Jenson, Code 664 Systems and Network Administrator
Hughes Information Technology Corp. @ NASA GSFC Lab for High Energy Astrophysics
E-mail: [email-masked]; Phone V:(301)2863016 FAX:(301)2861684
LHEA SYSTEMS HELP DESK: (301) 286-3692 or mail to [email-masked]
Snailmail: Code 664 Bldg 2 Rm W230K, NASA/GSFC, Greenbelt,MD,20771
....Save electrons and my sanity...Send E-mail instead of telephoning!

---

From: robert chea <[email-masked]>
Date: Wed, 28 Jun 1995 08:28:48 -0700 (PDT)

Hi Rob,

I've been looking for a solution as to how to handle an incoming ftp directory
for users but no one has been able to answer me yet.  I would like a user to
have chrooted ftp access (preferably they would be in the guest group) and
be able to deposit files.  I would really appreciate any help or even a 
pointer in the right direction.

Thanks

Robert