Subject: Are 2 DAEMONs too much?

From: [email-masked]
Date: Thu, 08 Jun 95 18:11:54 CST

We were handling ftp on a SCO UNIX platform using the SCO UNIX ftpd.  
     When I tried to run WU-FTPD simultaneously ( giving the WU-FTPD a 
     different name in etc/services and etc/inetd.cnf), WU-FTPD  says 
     "service not available".  
     
     But when I run WU-FTPD by itself under the name ftpd, it works.  
     Are 2 daemons too much or does it not like the name I gave it 
     (wuftpd).

                                Thanks
     
                                Long Nguyen
                                [email-masked]

---

From: [email-masked]
Date: Wed, 14 Jun 95 19:23:47 CST

Question:
     
     How does the daemon know to associate "wuftpd-data" with "wuftpd" if 
     the names were arbitrary?  Is there some way I can specify this 
     relation?
     
                                        Thanks,
                
                                        Long Nguyen
                                        [email-masked]

______________________________ Reply Separator _________________________________
Subject: Re: Re[2]: Are 2 DAEMONs too much? 
Author:  [email-masked] at Internet-NO
Date:    6/9/95 11:42 AM

Yes, it is possible.  Just make sure that you have both listed in your 
services file, on different ports, with names that correspond to your 
inetd.conf file.  Here's an example of what I did on my Sun SPARC10 w/ 
Solaris 2.3 (yours is probably different):
     
/etc/ientd.conf:
     
ftp    stream  tcp     nowait  root    /usr/sbin/in.ftpd       in.ftpd 
wuftpd stream tcp nowait root /usr/local/sbin/ftpd ftpd

/etc/services:
     
ftp 21
ftp-data 20
     
wuftpd 6001
wuftpd-data 6000
     
After we were done testing, I just changed a couple lines to get wuftpd 
running as ftp on 21.
     
On Fri, 9 Jun 1995 [email-masked] wrote:
     
>      Yes, I'm sure.  When I connect, it specifically tells me that I'm 
>      running the "WU-FTPD" version.
>      
>      What I'm really trying to ask is if it is possible to run 2 ftp 
>      daemons from different ports.
>      
>      Does anyone know?
>      
>      
>                                         Thanks 
>      
>                                         Long Nguyen
>                                         [email-masked] 
>      
> 
> 
> ______________________________ Reply Separator 
_________________________________
> Subject: RE: Are 2 DAEMONs too much? 
> Author:  [email-masked] at Internet-NO 
> Date:    6/9/95 9:30 AM
> 
> 
> Are you sure you're not running the original SCO ftpd?  Check the ordering 
> on your path and see if you might be fetching the old ftpd first.  The 
> actual name of the program should be unimportant. 
>      
> ---------------
> Michael Brennen                    Intecom, Inc. 
> [email-masked]               5057 Keller Springs 
> (214) 447-8074                     Dallas,  TX  75248 
>      
>      
> On Thu, 08 Jun 95 18:11:54 CST  [email-masked] wrote:
     
marc
---------
[email-masked]          
[email-masked] [Washington State Information Exchange (InfoX)]

---

From: [email-masked] (Marc Russell)
Date: Thu, 15 Jun 1995 00:11:23 +0800

I'm not sure what you're asking.  I think the -data extension is probably
defined in the relevant RFC.  As far as how /etc/inetd.conf and
/etc/services get along, I think it goes something like this:
        /etc/inetd.conf uses the name of the service in its file (in this
case, wuftpd) to associate with a name in /etc/services.  Then, if the
service happens to be an ftp service (such as ftpd is), it will look for the
corresponding <servicename>-data service (in this case, wuftpd-data).
Probably FTP was designed to use two ports like this, and the ability to
associate the two names is built in to all RFC-compliant ftp daemons.

>[email-masked] [Washington State Information Exchange (InfoX)]  

marc russell
---------------
[email-masked]
[email-masked]