Subject: Re: NFS mounting of ftpd seems to require root-write access !?!

From: [email-masked] (Derald McMillan)
Date: Fri, 16 Jun 1995 07:07:52 -0400

> 
> Hello,
> 
> I am installing wu-ftpd on a series of workstations, but am encountering a
> problem, whereby it seems that the NFS-fs upon which ftpd lives must be

...stuff deleted...

> 
> I'm working with "Version wu-2.4(6)".
> 

Karl, 

I have set up wu-ftp (2.4) on some machines running Solaris 2.4 in which I use an
NFS mounted drive that contains the ftp home directory.  However, I have installed
wu-ftpd on each machine individually.  Basically all this means is that my config
files and the binary live locally on each machine, which works fine for me.  So
while this might not be the solution you were looking for, it is how I got it
to work.  Oh yea, you'll want to make sure that there is a user account (ftp) 
accessable from all of your machines, that could be the source of your problems 
as well.  I use a Solaris utility called rdist(1) to update my config files and 
my password and shadow files.  rdist allows you distribute select files from a
central server to as many clients as you wish. (Be careful with this utility!).

Good Luck,

Derald

-- 

Derald
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
SolTech Systems Corporation
1180 Sam Rittenberg Blvd.		 Phone: 803-556-2500
Suite 310				 Fax:   803-556-2596 
Charleston, SC 29407			 email: [email-masked]	
http://www.soltech.com

         "Out the 10Base-2, through the router, over the leased line,
             off the bridge, past the firewall...nothing but Net"
                             -Gary Predmore
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: [email-masked] (Fabrizio Bettucci)
Date: Fri, 16 Jun 95 14:08:39 MET DST

Hello,
I am new new new of list,

I don't able to compile 
FTPD 2.4
I don't know a problem there is
output of <build s41>
===============================================================================
.........
........
Making support library. 
rm -f libsupport.a 
ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o syslog.o 
ranlib libsupport.a 

Making ftpd. 
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  ftpd.c 
ftpd.c: In function `statcmd': 
ftpd.c:1972: `typenames' undeclared (first use this function) 
ftpd.c:1972: (Each undeclared identifier is reported only once 
ftpd.c:1972: for each function it appears in.) 
ftpd.c:1974: `formnames' undeclared (first use this function) 
ftpd.c:1982: `strunames' undeclared (first use this function) 
ftpd.c:1982: `modenames' undeclared (first use this function) 
*** Error code 1 
make: Fatal error: Command failed for target `ftpd.o' 
===============================================================================

B E C A U S E !!!!!!!!!!!

these declaration are in ftpdcmd.y
but I don't know how insert on ftpd.c

and HELP ME please...........