Subject: AIX wu-ftpd v2.4 problems with groups

From: Dick Locke <[email-masked]>
Date: Tue, 13 Jun 1995 20:43:41 +22300919

I was not able to locate an archive for this list and I'm not
sure how active it is here, but I could *really* use some help
with authenticating groups on AIX v3.2.5.

Compiling wu-ftpd-2.4, I was only able to authenticate to a
user id's primary group; the other groups that the id is a
member of are ignored.  I see the ftpd.c section that says:

/* AIX 3 lossage.  Don't ask.  It's undocumented.  */

but I was hoping some one might have a work-around.

I've tried scenarios where I changed the setegid() call
directly before initgroups() to a setgid() and manually
issued a setgroups() based on setgrent()/getgrent()/endgrent()
loop with setgidx() and setegid(), and, although ugly, it worked
on one of our 3.2.5 machines, but now another box seems to ignore
the getgrent() calls completely.

Any help would be appreciated.

Thanks,
Dick

---

From: [email-masked] (Bill Campbell)
Date: Tue, 13 Jun 1995 18:11:32 -0700 (PDT)

> with authenticating groups on AIX v3.2.5.
I don't know offhand about official archives, but we have it going back
to June 1994 in ftp://ftp.celestial.com/pub/mailing-lists/*/wu-ftpd.gz
where * is YYMM.  The current month's archive isn't compressed with
gzip as it's ``live'' and updated as mail comes in.

Bill
--
INTERNET:   [email-masked]  Bill Campbell; Celestial Systems, Inc.
UUCP:               camco!bill  PO Box 820; 2835 82nd Avenue S.E. S-100
FAX:            (206) 232-9186  Mercer Island, WA 98040-0820; (206) 236-1676
URL: http://www.celestial.com/

You need only reflect that one of the best ways to get yourself a
reputation as a dangerous citizen these days is to go about repeating
the very phrases which our founding fathers used in the struggle for
independence.
        -- Charles A. Beard

---

From: "Terry J. Klarich" <[email-masked]>
Date: Wed, 14 Jun 1995 09:24:47 -0500

>Any help would be appreciated.

If you find out anything, would you please let me know.  I am having the
same troubles you are having.  I have gcc; and, have been thinking about
trying to get the gnu libc ccompiled.

Terry Klarich (ki5zw)
Systems Analyst
Oklahoma State University, Stillwater Oklahoma
A man is not complete until he is married; then, he is finished.

---

From: Bill Pemberton <[email-masked]>
Date: Wed, 14 Jun 1995 15:13:06 -0400 (EDT)

> member of are ignored.  I see the ftpd.c section that says:

I ran into this (and a few other) problems under AIX.  My patches are
available at:

tigger.itc.virginia.edu:/pub/AIX/wu-ftpd.diffs.txt.gz

-- 
Bill Pemberton                           [email-masked]
ITC/Unix Systems                         [email-masked]
University of Virginia                   uunet!virginia!wfp5p