Subject: Re: Problem with DIR command in WU-FTPD 2.4

From: [email-masked] (Raza Rizvi)
Date: Thu, 4 May 1995 09:38:15 +0100

I've had a couple of good suggestions now, but still no luck!

My /usr/ftp/usr/lib contains the libraries I need
(ld.so,libc.so.1.9,libdl.so.1.0) according to the man pages for ftpd, and
they are both readable and executable. They are also readable and
executable in /usr/lib.

The /usr/ftp/usr and /usr/ftp/usr/lib directories are chmod 555.

The file /usr/ftp/bin is executable and the file /usr/ftp/bin/ls is
read/execute.

WU-FTPD Guest UNIX FTP terminal users issuing a DIR, or Mac FETCH users
(who issue a DIR unbeknown to them), get no file listing back. They do if
they issue a LS.

A transcript is below:

luggage# ftp ftp.rednet.co.uk
Connected to ftp.rednet.co.uk.
220 luggage FTP server (Version wu-2.4(1) Mon Nov 14 16:01:35 GMT 1994) ready.
Name (ftp.rednet.co.uk:rizvi_r): user1
331 Password required for user1.
Password:
230 User user1 logged in.  Access restrictions apply.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
test
not-so-simple.cf
226 Transfer complete.
24 bytes received in 0.0062 seconds (3.8 Kbytes/s)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> quit
221 Goodbye.

I am open to further suggestions and will post a summary to the list (oh
and this time I will try to make sure that I don't goof up and send the
reply to any answers BACK to the list :-) )

Raza

Raza Rizvi ([email-masked])
RedNet Ltd, High Wycombe, England
Tel - +44 (0)1494 513333  Fax - +44 (0)1494 443374

---

From: Ariel Spivakovsky <[email-masked]>
Date: Fri, 5 May 1995 16:52:44 -0400 (EDT)

What platform are you runing on?
Try doing a man ftpd.

This one bugged me for a week.
Good luck 
Ari