Subject: hanging sockets problem tested & available

From: Dan Thorson <[email-masked]>
Date: Fri, 12 May 1995 17:11:05 -0400 (EDT)

Hi all.
I've received a confirmation that my "hanging sockets" patch worked
[Thanks to JP Price ([email-masked])], and have now tested it myself
on ftp.seagate.com.... and all looks good!

If folks would like to check out the returned messages, they should
feel free to telnet to ftp.seagate.com i.e.:
 telnet ftp.seagate.com 21
 user anonymous
 pass yourname@yourhost
 pasv
 list
and then wait 120 seconds.  You'll see a timeout message on your screen,
and what _was_ a hanging socket connection on my machine will have gone
away cleanly.

Oh, and then
 quit
the telnet session.  If you've missed the patch, or can't find it on the 
non-wustl-sanctioned-but-it's-all-we've-got patch server (where was that
again?) you can pick it up at URL:

 ftp://ftp.seagate.com/pub/wu-ftpd-2.4.patch

Dan Thorson
satisfied at last!

---

From: JP Price <[email-masked]>
Date: Fri, 12 May 1995 19:27:49 -0500

Hmm, it appears that this only fixes processes that go zombie, and doesn't catch
 processes that just go idle for a long time.

I was using ps -aux | grep ftp to catch the processes, but have been informed that
I should ps -auxww | grep ftp to see everything.

Apparently the idle timeout doesn't work, but at least this patch does clean out the
zombie processes.

 -patrick

----------
From: 	Stan Barber[SMTP:[email-masked]]
Sent: 	Friday, May 12, 1995 7:03 PM
To: 	[email-masked]; wu-ftpd
Cc: 	jprice
Subject: 	Re: hanging sockets problem tested & available

Thanks for the note. I will get this and put it in my distirbution as a beta
and other folks can test it before I make it main line.

this should happen this weekend.

-- 
Stan   | Academ Consulting Services        |internet: [email-masked]
Olan   | For more info on academ, see this |uucp: bcm!academ!sob
Barber | URL- http://www.academ.com/academ |Opinions expressed are only mine.

---

From: Dan Thorson <[email-masked]>
Date: 15 May 95 8:30:26 EDT

> Hmm, it appears that this only fixes processes that go zombie,
> and doesn't catch processes that just go idle for a long time.

It's not supposed to.

> I was using ps -aux | grep ftp to catch the processes, but have
> been informed that I should ps -auxww | grep ftp to see everything.
> Apparently the idle timeout doesn't work, but at least this patch
> does clean out the zombie processes.

I believe that what you're seeing is the initial (control) connection
is staying up.  These should time out based on the "normal" timeout 
functions.... i.e. -T and -t command line switches.

I've been running with the patch since last Friday (5/12/95).  As of
this morning (Monday 5/15) I'm seeing zero zombies, and nothing called
ftpd appears when I do any form of ps.
[ and yes, I _am_ seeing occasional "valid" connections :-) ]

Bottom line is that my confidence is 100% in this patch  (Uh oh, I
heard Murphy chuckling when I typed that!)

dct