Subject: limit anonymous ftp

From: [email-masked] (demo_2)
Date: Wed, 10 May 1995 00:15:31 +0800 (HKT)

I have a misunderstanding relative to the anonymous ftp of my ftp site. 
 Whenerver a user anonymous-ftp my site, he can randomly input the passwd and
 my site will accept it. If fact, it should be his email account, e.g. hoo@.
 How do I fix this problem?
 
 By the way, may I ask how to write perl and can gopher run perl so that I 
 can download program drectly via clicking the item not via pressing shift-d.
 
  -- 
 =============================================
  ^^^^^       Name: James Leong
 <* J *>     email: [email-masked]
  \ v / 
    =        Have a nice day!
 ==============================================

-- 
=============================================
 ^^^^^       Name: James Leong
<* J *>     email: [email-masked]
 \ v / 
   =        Have a nice day!
==============================================

---

From: [email-masked] (Dave Wolfe)
Date: Tue, 9 May 1995 11:48:53 -0500 (CDT)

[ demo_2 (James Leong) writes: ]
>  How do I fix this problem?

Set "passwd-check rfc822 enforce" in your ftpaccess file. See the
ftpaccess(5) man page for details.

>  can download program drectly via clicking the item not via pressing shift-d.

What does this have to do with wu-ftpd?

-- 
 Dave Wolfe    *Not a spokesman for Motorola*  (512) 891-3246
 Motorola MMTG  6501 Wm. Cannon Dr. W. OE112  Austin  TX  78735-8598

---

From: Steve Blass <[email-masked]>
Date: Tue, 9 May 1995 13:20:33 -0700 (PDT)

<...> 
> ftpaccess(5) man page for details.

My question is can wu-ftpd actually enforce that the anonymous passwd 
match the originating account and host ?

---

From: [email-masked] (Patrick Salsbury)
Date: Tue, 9 May 95 09:58:00 PDT

- By the way, may I ask how to write perl and can gopher run perl so that I 
- can download program drectly via clicking the item not via pressing shift-d.
- 
-  -- 
- =============================================
-  ^^^^^       Name: James Leong
- <* J *>     email: [email-masked]
-  \ v / 
-    =        Have a nice day!
- ==============================================

	O'Reilly & Associates has a good book called (you guessed it)
"Learning Perl." Check it out....

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	              SCO/IXI/Visionware           
	Sys Admin/Webmaster                   330 Encinal Street
	Voice: 408-429-4529	             Santa Cruz, CA 95060
     email: [email-masked]		       FAX: 408-427-5460	
		      X/UNIX/PC Integration Specialists
  Check out <A HREF="http://www.visionware.com/">The Visionware Homepage</A>

---

From: Troy Morrison <[email-masked]>
Date: Tue, 9 May 1995 11:21:06 -0700 (PDT)

> My question's been answered - NO it can't - which I figured was the case.
> tcp_wrappers can't either out of the box but with the wrappers on and 
> wu-ftpd running with -l flag the logging is quite copius and that will do.

Is there any patch to use the IDENT or TAP protocols to attempt to 
authenticate the "anonymous password"?  Ie. FTP connection arrives from 
some.remote.host, sends USER anonymous and then PASSWD 
[email-masked], then wu-ftpd calls an IDENT server at 
some.remote.host and checks to see if it really is me?

Realizing that anonymous FTP is by definition anonymous, such 
authentication would be useful for a semi-anonymous FTP.

Troy

---

From: Steve Blass <[email-masked]>
Date: Tue, 9 May 1995 13:44:57 -0700 (PDT)

Thanks