Subject: address checking

From: [email-masked] (Bill Townsley)
Date: Wed, 3 May 95 07:23:04 EDT

I know that wuftp can be configured to resolve the address
of the host machine of remote users and allow only those
will resolveable addresses access to the system.  Is it 
possible to log this address regardless of an actual login.
That is, I'd like to be able to log the host address for
everyone who attempts to log into my system.  Or to log the
address of everyone who logs in successfully regardless of 
any file transfers. Is that possible?

|====================================|
| Bill Townsley, Computer Specialist |
|  USGS Center for Coastal Geology   |
|   St. Petersburg, Florida 33701    |
|    [email-masked]      |
|      813-893-3100 ext. 3019        |
|====================================|

---

From: Matthew Harrell <[email-masked]>
Date: Wed, 3 May 1995 09:39:31 -0400 (EDT)

: 
: I know that wuftp can be configured to resolve the address
: of the host machine of remote users and allow only those
: will resolveable addresses access to the system.  Is it 
: possible to log this address regardless of an actual login.
: That is, I'd like to be able to log the host address for
: everyone who attempts to log into my system.  Or to log the
: address of everyone who logs in successfully regardless of 
: any file transfers. Is that possible?
: 

My present configuration does exactly this, but I can't figure
out how to get wu-ftpd to do it when I compile it myself.  At
present, all login attempts (failed or not) are logged to
/var/adm/syslog/daemon.log.  When I compile the program, this
feature goes away.
-- 
        /-------------------\              Phonenet address:
       /  Matthew Harrell      \             202.767.4085
      /   Naval Research Lab     \ 
      /   Code 7640                \       Internet address:
       \  Washington, DC   ___==== /         [email-masked]
        |--------------------\               
        |====================/             Friends don't let friends do DOS.

---

From: [email-masked] (Bill Campbell)
Date: Wed, 3 May 1995 08:12:48 -0700 (PDT)

> any file transfers. Is that possible?
We use tcp_wrappers around wuftp and it provides a consistent way to
log and permit/deny access to any upd/tcp port accessed through inetd.
It also has a keepalive option that will kill connections if the other
end goes away (not uncommon with more MS-Windows clients in use every
day and Windows crashing with some degree of regularity).

Bill
--
INTERNET:   [email-masked]  Bill Campbell; Celestial Systems, Inc.
UUCP:               camco!bill  PO Box 820; 2835 82nd Avenue S.E. S-100
FAX:            (206) 232-9186  Mercer Island, WA 98040-0820; (206) 236-1676
URL: http://www.celestial.com/

You need only reflect that one of the best ways to get yourself a
reputation as a dangerous citizen these days is to go about repeating
the very phrases which our founding fathers used in the struggle for
independence.
        -- Charles A. Beard