Subject: Re: Not so anonymous ftp

From: [email-masked]
Date: Tue, 9 May 1995 15:21:12 +0200

rh>
rh>
rh>/etc/passwd file entry:
rh>
rh>   jht:x:202:202:Guest FTP Account:/home/ftp/pub/./home/ftp/pub/jht:/bin/false

jht:x:202:202:Guest FTP Account:/home/ftp/./pub/jht:/bin/false
                                ^^^^^^^^^
                                chroot part
                                           ^^^^^^^^
                                           cd part

/etc/group:
jht:*:202:

rh>
rh>directory listing:
rh>/
rh>drwxr-xr-x  16 root     root         512 May  5 11:27 home
rh>
rh>./home
rh>dr-xr-xr-x   9 root     other        512 May  9 08:49 ftp  
rh>
rh>./ftp
rh>dr-xr-xr-x   9 root     other        512 May  9 08:45 .                         
rh>drwxr-xr-x  16 root     root         512 May  5 11:27 ..
rh>d--x--x--x   2 root     other        512 Apr  3 09:51 bin
rh>d--x--x--x   2 root     other        512 Apr  3 09:27 dev
rh>d--x--x--x   2 root     other        512 Mar 21 11:48 devices
rh>-rw-r--r--   1 root     other          0 May  9 08:45 dir.txt
rh>d--x--x--x   2 root     other        512 Apr 28 15:56 etc
rh>dr-xr-xr-x   2 root     other        512 Mar 20 11:09 msgs
rh>drwxrwxrwx   7 root     other        512 May  8 14:21 pub
rh>d--x--x--x   3 root     other        512 Apr  3 10:57 usr      
rh>
rh>./pub:
rh>total 16                                                                        
rh>drwxrwxrwx   7 root     other        512 May  8 14:21 .
rh>dr-xr-xr-x   9 root     other        512 May  9 08:45 ..
rh>drwxr-xr-x   2 root     other        512 May  8 14:16 docs
rh>d-wx-wx-wx   2 root     other        512 May  8 14:10 incoming
rh>drwxr-xr-x   2 ftp      jht          512 May  8 14:22 jht
rh>drwxrwxr-x   5 ftp      ftp         1536 May  8 21:10 stratis
rh>drwxr-xr-x   5 root     other        512 May  8 14:12 utils  
rh>
rh>
rh>Thanks in advance,
rh>Janice Lang
rh>BDM Federal Inc.
rh>NASA IVV Facility
rh>Fairmont WV 26505
rh>
rh>

Hope this helps,

Ronald.

---

From: John Elliot <[email-masked]>
Date: Tue, 9 May 95 14:31:28 BST

> I have attempted to use the guestgroup facility in wu-ftpd running on solaris
> 2.4.  I have set up the user as a guest in the ftpaccess file.  I have created
> a 'real account' for the user as well as an account within the ftp group and
> passwd files.  When I attempt to log in as that user, I get the following error:
> 
>         550 Can't set group privileges
> 

> /etc/passwd file entry:
> 
>    jht:x:202:202:Guest FTP Account:/home/ftp/pub/./home/ftp/pub/jht:/bin/false

This is (at least part) of your problem.  The home directory entry is wrong.
The part after the . is a continuation of the pathname, you do not specify
the entire pathname again.  It should read :

/home/ftp/pub/./jht

Hope this helps

John.