Subject: Re: WU-FTPD/Group Controls

From: "Miren U. Libano" <[email-masked]>
Date: Wed, 17 May 1995 17:48:29 +0200

This is the same problem I have. FTP access is denied if the user does not
have the right shell (listed in man ftpd) and of course a guest user should
not have a real shell. What you should do is edit the file /etc/shells and
include /bin/false. My problem is that I do not know the format of
/etc/shell. Can someone tell me. Thanks.

>I am trying to set up a guest ftp account.  Using the O'Reilly &
>Associates, I put the following line in /etc/group
>
>guests:*:21:guest1
>
>In /etc/passwd I put
>
>guest1:password:201:21:Guest FTP:/home/guests/./guest1:/bin/false
>
>Then I added
>
>guestgroup guests
>
>to the file /usr/local/etc/ftpaccess
>
>However, when I try to ftp as guest1, I get the message access denied.
>I am using SUN OS.
>
>???
>
>Thanks,
>Mark Williamson, NIST
>
>
>
>

Miren Usua Libano Albert
B.S. Computer Science
European Software Institute
Parque Tecnológico
E-48016 Zamudio (Bilbao)
Bizkaia - Spain
Tel: ++34-4-420-95-19
Fax: ++34-4-420-94-20
e-mail: [email-masked]

---

From: Thomas Erskine <[email-masked]>
Date: Wed, 17 May 1995 12:58:55 -0400 (EDT)

> /etc/shell. Can someone tell me. Thanks.

It's one shell per line, like:

/bin/sh
/bin/csh
...

However, what I'd suggest is putting /bin/true into /etc/shells, but not 
putting /bin/false.  I  do it this way so that I can have users who can 
use ftp, but not telnet/rlogin (with shell /bin/true), and users who 
can't even use ftp (with shell /bin/false).  You can also put the latter 
in /etc/ftpusers, but I'm always forgetting about it.

[snip]

--
Thomas Erskine        <[email-masked]>           (613) 998-2836

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 18 May 95 9:13:54 MET DST

> /etc/shell. Can someone tell me. Thanks.

The file here contains :

/sbin/sh
/sbin/jsh
/bin/sh
/bin/csh
/bin/ksh
/bin/jsh
/usr/bin/sh
/usr/bin/csh
/usr/bin/jsh
/usr/bin/ksh
/usr/bin/bash

In short, the full names of all login shells who's users can use ftp.

                                                 Grtz. KH

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)