Subject: WU-FTPD/Group Controls

From: [email-masked] (Mark Williamson)
Date: Wed, 17 May 95 11:07:19 EDT and do not reflect NIST policy or agreement.

I am trying to set up a guest ftp account.  Using the O'Reilly &
Associates, I put the following line in /etc/group

guests:*:21:guest1

In /etc/passwd I put

guest1:password:201:21:Guest FTP:/home/guests/./guest1:/bin/false

Then I added

guestgroup guests

to the file /usr/local/etc/ftpaccess

However, when I try to ftp as guest1, I get the message access denied.
I am using SUN OS.

???

Thanks,
Mark Williamson, NIST

---

From: [email-masked]
Date: Wed, 17 May 95 11:05:28 PDT

Do you have a class that allows guest login?

---------------
Michael Brennen                    Intecom, Inc.
[email-masked]               5057 Keller Springs
(214) 447-8074                     Dallas,  TX  75248

On Wed, 17 May 95 11:07:19 EDT and do not reflect NIST policy or

---

From: [email-masked] (Mark Williamson)
Date: Wed, 17 May 95 12:27:31 EDT and do not reflect NIST policy or agreement.

>This is the same problem I have. FTP access is denied if the user does not
>have the right shell (listed in man ftpd) and of course a guest user should
>not have a real shell. What you should do is edit the file /etc/shells and
>include /bin/false. My problem is that I do not know the format of
>/etc/shell. Can someone tell me. Thanks.
>
>
>
>Miren Usua Libano Albert
>B.S. Computer Science
>European Software Institute
>Parque Tecnológico
>E-48016 Zamudio (Bilbao)
>Bizkaia - Spain
>Tel: ++34-4-420-95-19
>Fax: ++34-4-420-94-20
>e-mail: [email-masked]
>

My /etc/shells looks like so:

/bin/sh
/bin/csh
/bin/tcsh
/bin/false

Mark Williamson, NIST

---

From: [email-masked] (Mark Williamson)
Date: Wed, 17 May 95 15:44:54 EDT and do not reflect NIST policy or agreement.

Thanks for all the help with the WU-FTPD Group Control.  I was able to get
it working.  However, it was my understanding that the guests/./guest1 path
prevented a group user from CDing out of the guest1 directory.  This is not
working for me.  I can cd all the way to the root.

Have I set something incorrectly?

Mark Williamson, NIST

---

From: [email-masked]
Date: Wed, 17 May 95 15:01:50 PDT

Hmmmm, sounds like you might be running as 'real', not guest.  Make sure 
the group name you define as 'guestgroup' in ftpaccess exists in the 
/etc/group file.  

To keep from cd'ing out of the guest1 directory, make the path

/guests/guest1/./

As written you could cd up to the guests directory.

Hope this gets you further,

---------------

On Wed, 17 May 95 15:44:54 EDT and do not reflect NIST policy or