Subject: Problem with DIR command in WU-FTPD 2.4

From: [email-masked] (Raza Rizvi)
Date: Tue, 2 May 1995 18:05:51 +0100

I had a very odd response back from the server when I sent this on Monday
so here it is again, apologies if it is a repeat :-)

Some time ago on this list I reported a problem using FETCH with WU-FTPD
2.4, I had little response so took the tack of reporting it as a bug in
FETCH which produced a bit more info....

Fetch 2.1.1 on PPC 7100/66 with System 7.5 connecting to Sun Sparc 4.1.3_U1
with the WU-FTPD 2.4

Works fine for real and anonymous users but WUFTP allows Guest Users who
are CHROOTed to a particular directory by specifying their home directory
slightly differently in /etc/passwd. It would be represented as
/usr/users/whatever/./userdir    which means that the first directory shown
is userdir but the user appears to have their root directory immediately
above.

For this scenario, the user connects okay but is not presented with a file
listing for their home directory or the (new) root directory.

If the same user logs in from another Unix machine, all is well.

A transcript of the session is shown below:
*******
220 luggage FTP server (Version wu-2.4(1) Mon Nov 14 16:01:35 GMT 1994) ready.
USER user1
331 Password required for user1.
PASS
230 User user1 logged in.  Access restrictions apply.
SYST
215 UNIX Type: L8
PWD
257 "/user1" is current directory.
PORT 193,131,68,112,60,7
200 PORT command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
CWD /
250-This area is for downloading files. Access to some of the
250-directories may be restricted.  If you have any problems
250-please email [email-masked] with an explanation of
250-your problem.  Alternatively, telephone the onLine support
250-team on 01494 513333.
250-
250-The directory /incoming/general is NOT for scratch storage !
250-Please do not try to download files to it unless you have been
250-asked to do so explicitly. If you do so you will not be able to
250-retrieve them.
250-
250-Thankyou
250-
250 CWD command successful.
PWD
257 "/" is current directory.
PORT 193,131,68,112,22,241
200 PORT command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
*******

Now it seems that if a UNIX FTP terminal users issue a DIR, which is what
FETCH issues, they get no file listing back. They do if they issue a LS.

Any suggestions?

Is it due to /bin/ls not being found?
Am I the only one using FETCH as a client!

Raza

Raza Rizvi ([email-masked])
RedNet Ltd, High Wycombe, England
Tel - +44 (0)1494 513333  Fax - +44 (0)1494 443374

---

From: [email-masked] (Patrick Salsbury)
Date: Tue, 2 May 95 10:53:37 PDT

-Now it seems that if a UNIX FTP terminal users issue a DIR, which is what
-FETCH issues, they get no file listing back. They do if they issue a LS.
-
-Any suggestions?
-
-Is it due to /bin/ls not being found?
	I had this problem. Turned out my /usr/lib dir was chmod 111. Doing a
chmod 555 on it fixed the problem. (People could execute the directory, but
couldn't read the libraries out of it, so the dir version of ls didn't work.
Only the built-in version did.

-Am I the only one using FETCH as a client!
-
-Raza
-Raza Rizvi ([email-masked])
-RedNet Ltd, High Wycombe, England
-Tel - +44 (0)1494 513333  Fax - +44 (0)1494 443374

	Possibly. ;^) 
	I don't know. I'm not familiar with that one....

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	              SCO/IXI/Visionware           
	Sys Admin/Webmaster                   330 Encinal Street
	Voice: 408-429-4529	             Santa Cruz, CA 95060
     email: [email-masked]		       FAX: 408-427-5460	
		      X/UNIX/PC Integration Specialists
  Check out <A HREF="http://www.visionware.com/">The Visionware Homepage</A>