Subject: problem - wu-ftpd-2.4, AIX 3.2.5, can't use LIST

From: Quentin Fennessy <[email-masked]>
Date: Fri, 05 May 1995 14:33:52 -0500

I have built version 2.4 of WU-ftpd on AIX3.2.5 using both 
the AIX cc and GNU cc, and with both versions I have a similar problem.
The 'ls -l' and 'dir' commands fail for the anonymous user, while
'ls' and 'get' work.

I actually suspect an AIX problem rather than a WU-ftpd problem.
I have built version 2.4 for other AIX systems  before that have
worked fine.

I have installed ftpd in /usr/local/etc, with various versions of ftpaccess.
ftpd works with non-anonymous logins, but when I connect as the anonymous
user the NLIST command fails.  I can 'see' a directory listing using 
the ftp client 'ls' command, but both 'dir' and 'ls -l' fail, as
you can see in the session below.

I am able to retrieve files as the anonymous user.
I do have a copy of '/bin/ls' available in ~ftp.

I built ftpd with:
	build clean
	build aix
A few pointer->integer errors were reported, but nothing that looked
serious.

I did patch my ftp.h file.

Does anyone have any suggestions as to what to do next?

Thanks,
	Quentin

	$ ftp et
	Connected to et
	220 et FTP server (Version wu-2.4(7) Fri May 5 10:51:55 CDT 1995) ready.
	Name (et:fennessq): ftp
	331 Guest login ok, send your complete e-mail address as password.
	Password:
	230 Guest login ok, access restrictions apply.
	ftp> dir
	200 PORT command successful.
fails:	150 Opening ASCII mode data connection for /bin/ls.
fails:	226 Transfer complete.
	ftp> ls -l
	200 PORT command successful.
fails:	150 Opening ASCII mode data connection for /bin/ls.
fails:	226 Transfer complete.
	ftp> ls
works:	200 PORT command successful.
works:	150 Opening ASCII mode data connection for file list.
works:	online
	abstract
	bin
	summary
	.sh_history
	document
	software
	etc
	.rhosts
	.forward
	lib
	usr
	public
	226 Transfer complete.
	ftp> 221 Goodbye.

---

From: Quentin Fennessy <[email-masked]>
Date: Fri, 05 May 1995 15:45:37 -0500

I solved my problem due to some inspiration from Dave Wolfe.  Dave
advised me to run the AIX command 'dump -H' on ~ftp/bin/ls to ensure
I had the correct shared libs.  I emailed Dave and assured him this
was already taken care of.

I decided to be safe and took Dave's suggestion.  I ran 'dump -H'
and dump refused to recognize 'ls.'
I had the correct shared lib -- but I had a SPARC /bin/ls, not an AIX
/bin/ls!   AAAAHHHHHHHHHH!!!!!  I could have finished this project last
week except for my own stupidity!

Thanks to [email-masked] (Dave Wolfe) and
Brad Christensen for their suggestions.

Quentin