Subject: Compiling wu-ftpd-2.4.1 on NeXTstep 3.0

From: Pablo E Romo <[email-masked]>
Date: Mon, 15 May 1995 15:07:27 -0600 (GMT-0600)

I'm trying to compile the BETA of the wu-ftpd on nextstep 3.0 and 
i'm getting the following errors:

cc -O2 -I.. -L../support -c vers.c
cc -O2 -I.. -L../support -c access.c
cc -O2 -I.. -L../support -c extensions.c
cc -O2 -I.. -L../support -c realpath.c
cc -O2 -I.. -L../support -c acl.c
cc -O2 -I.. -L../support -c private.c
cc -O2 -I.. -L../support -c authenticate.c
authenticate.c:36: header file 'authuser.h' not found        
*** Exit 1
Stop.

Making ftpcount.
cc -O2 -I.. -L../support -o ftpcount ftpcount.c vers.o -lsupport

Making ftpshut.
cc -O2 -I.. -L../support -o ftpshut ftpshut.c vers.o -lsupport

Making ckconfig.
cc -O2 -I.. -L../support -o ckconfig ckconfig.c

Links to executables are in bin directory:
size: bin/ftpd not found
__TEXT  __DATA  __OBJC  others  dec     hex
8192    8192    0       57344   73728   12000   bin/ftpcount
8192    8192    0       49152   65536   10000   bin/ftpshut
8192    8192    0       57344   73728   12000   bin/ftpwho
8192    8192    0       40960   57344   e000    bin/ckconfig
Done

	Any hints?

-----------------------------------------------------------------------
Pablo Ernesto Romo Ochoa         NeXTMAIL: [email-masked]
ITESM Campus Monterrey           Internet: [email-masked]
Administrador de Equipos UNIX
Departamento de Tecnologia Computacional/DINF (8) 358-20-00 Ext 4082
    +------------------------------------------------------------------+
                                 \\\|///     " The absence of danger 
                                \\ ~ ~ //      signal does NOT mean 
                                (/ @ @ /)      that everything is OK "
    +-------------------------oOOo-(_)-oOOo-----------------------------+

---

From: DI Winfried Ritsch <[email-masked]>
Date: Tue, 16 May 95 10:24:04 +0200

I had the same problem and heres the solution:

=========
because of:
  authenticate.c:36: header file 'authuser.h' not found
I changed in a it:
[...]
/*#include "authuser.h"*/
#include "../support/authuser.h"
[...]

and it worked with some warnings as before.

=====
Then I did:

iem:8# build install
make args are :
make opts are :
mv -f /usr/local/etc/ftpd /usr/local/etc/ftpd-old
Installing binaries.
install -o bin -g bin -m 755 bin/ftpd /usr/local/etc/ftpd
chown: unknown user id: bin
*** Exit 1
Stop.
iem:9#

It didnt work because in my NeXT NeXTStep3.2 (and Ichanged nothing) is no  
usr "bin", so I changed in the Makefile "bin" to be "root" and because there  
is no local man, even in the manpath of the system /usr/local/man in  
/usr/man:
BINDIR=         /usr/local/bin
ETCDIR=         /usr/local/etc
MANDIR=         /usr/man
MANEXT=         8

all:
        @ echo 'Use the "build" command (shell script) to make ftpd.'
        @ echo 'You can say "build help" for details on how it works.'

install: bin/ftpd bin/ftpcount bin/ftpshut
        -mv -f ${ETCDIR}/ftpd ${ETCDIR}/ftpd-old
        @echo Installing binaries.
        install -o root -g bin -m 755 bin/ftpd ${ETCDIR}/ftpd
        install -o root -g bin -m 755 bin/ftpshut ${BINDIR}/ftpshut
        install -o root -g bin -m 755 bin/ftpcount ${BINDIR}/ftpcount
        install -o root -g bin -m 755 bin/ftpwho ${BINDIR}/ftpwho
        @echo Installing manpages.
        install -o root -g bin -m 755 doc/ftpd.8 ${MANDIR}/man8/ftpd.8
        install -o root -g bin -m 755 doc/ftpcount.1 ${MANDIR}/man1/ftpcount.1
        install -o root -g bin -m 755 doc/ftpwho.1 ${MANDIR}/man1/ftpwho.1
        install -o root -g bin -m 755 doc/ftpshut.8 ${MANDIR}/man8/ftpshut.8
        install -o root -g bin -m 755 doc/ftpaccess.5 ${MANDIR}/man5/ftpaccess.5
        install -o root -g bin -m 755 doc/ftphosts.5 ${MANDIR}/man5/ftphosts.5
        install -o root -g bin -m 755 doc/ftpconversions.5  
${MANDIR}/man5/ftpconversions.5
        install -o root -g bin -m 755 doc/xferlog.5 ${MANDIR}/man5/xferlog.5

[...]

Since the I had no problems and it worked perfect except the on the fly  
conversion (I dont know how to statically compile gnutar and so on :-( ), if  
you did this please mail me

Stop.

Making ftpcount.

Making ftpshut.

Making ckconfig.

	Any hints?