Subject: Can't create data socket?

From: Clyde Poole <[email-masked]>
Date: Wed, 03 May 1995 10:56:08 -0500

I have installed wu-ftpd 2.4 on an Sun running Solaris 2.4.  I have built an "ls"
binary without shared libraries (the GNU ls) and I get the following error when I
do an "ls" command:

425 Can't create data socket (0.0.0.0,20): Bad file number.

What in the world is wrong and how can I fix it?

ctp
-----
Clyde T. Poole
Statewide Planning Analyst
Texas Dept. of Information Resources
[email-masked]

---

From: [email-masked] (J.J.Bailey)
Date: Wed, 3 May 1995 11:23:37 -0700 (PDT)

> 
> I have installed wu-ftpd 2.4 on an Sun running Solaris 2.4.  I have built
> an "ls" binary without shared libraries (the GNU ls) and I get the
> following error when I do an "ls" command:
> 

I'm having the same problem on Interactive 4.1.  In my case, it's only
when a user logs in as "anonymous."  When I use my own login, no problem.

I traced this error to a failed socket() call (ENOENT).  The code looks
correct, so I'm leaving this to a day when I can role my sleeves up for
a few hours.

-- 
J.J.Bailey
Consultant
[email-masked]