Subject: Re: Accessing directories outside of the ftp structure?

From: John Elliot <[email-masked]>
Date: Tue, 25 Apr 95 09:49:34 BST

> FTP is setup in /usr/local/ftp which looks to be pretty typical.
> 
> The BBS directories are located in 	/bbs/bbsfiles/DIME with a bunch of

> So... an attempt to provide a symbolic link from the BBS directories
> to the ftp directories like...
> 
> 	ln -s /bbs/bbsfiles/DIME /usr/local/ftp/pub/DIME
> 
> and away we go....  But it doesn't work.

ftpd runs chroot on the ftp area (/usr/local/ftp) which means that as
far as ftpd is concerned the rest of the file space does not exist.
This is why your symbolic link doesn't work.  You have two options to
get round this:

 1. set up an ftp tree on top of your BBS directories.  But you didn't want
to do this.

 2. mount the directories you wan't available via ftp under your current
ftp tree, and use links from the bbs area to the ftp area (assuming this
doesn't confuse your BBS software).

John.

---

From: Vidiot <[email-masked]>
Date: Tue, 25 Apr 1995 14:15:27 -0500 (CDT)

Fellow wu-ftp users:

I can't get the guest login to work.  I have the O'Reilly Managing Internet
book, but it hasn't helped.  Here is my setup:

Dir of ~ftp: (note the ftms directory)

total 23
drwxr-xr-x  9 root     wheel         512 Apr 25 11:19 .
drwxr-xr-x 37 root     wheel        1024 Apr 25 01:02 ..
-rw-rw-r--  1 root     daemon        117 Jan 31 22:07 .welcome.msg
dr-xr-xr-x  2 root     wheel         512 Jan 27 19:39 bin
dr-xr-xr-x  2 root     wheel         512 Jan 27 17:39 dev
dr-xr-xr-x  2 root     wheel         512 Jan 31 21:55 etc
drwxr-xr-x  2 ftmsftp  guest         512 Apr 25 11:19 ftms
drwx-wx-wx  2 brown    ftms_dev     1536 Apr 24 16:05 incoming
-rw-rw-r--  1 root     daemon      11438 Apr 25 00:10 ls-lR
drwxr-xr-x  7 root     wheel         512 Apr 22 18:22 pub
dr-xr-xr-x  4 root     wheel         512 Jan 27 17:39 usr

/etc/password entry for ftmsftp user:

ftmsftp:r0MnCHgJv2gqQ:5001:5000:Guest FTP account:/usr/ftp/./ftms:/bin/false

/etc/group entry for guest:

guest:*:5000:ftmsftp

/etc/ftp/ftpaccess:

class   local    real  *
class   remote   anonymous  *
 
guestgroup guest
 
limit   remote   20   SaSu|Any1800-0700    /etc/ftp/msg.tomany
limit   remote    3   Any                  /etc/ftp/msg.tomany
 
readme  README*    login
readme  README*    cwd=*
 
message .welcome.msg            login
message .message                cwd=*
 
compress        yes             local remote
tar             yes             local remote
 
log commands real
log transfers anonymous,real inbound,outbound
 
shutdown /etc/shutmsg
 
private no
email [email-masked]

When I try to log in as ftmsftp, I get:

220 ftms FTP server (Version wu-2.4(5) Sat Feb 4 17:45:31 CST 1995) ready.
Name (ftms.com:brown): ftmsftp
530 User ftmsftp access denied...
Login failed.

I can log in as myself just fine, or even anonymous.

Thanks for any help in getting this user to work.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.ftms.com/vidiot/  (Your link to the world of Star Trek)