Subject: restricting via time in ftpaccess?

From: "Kerr, James A." <[email-masked]>
Date: Thu, 27 Apr 1995 15:02:00 -0500 (EST)

I am trying to restrict a certain domain from entering my ftp server between 
11pm and 9 am.  When I do a ftpwho I can see that 0 users are allowed in the 
class Jim (which is me for testing).  However....  I can still log in even 
though it says 0 users (0 maximum)

Here is a copy of my file:

loginfails 4

guestgroup ftp

# class special real jmc4.cdc.gov jak7.cdc.gov ntb2.cdc.gov ntb10.cdc.gov
class   Crawford        guest   *.crawford.com
class   Jim     guest   *.cdc.gov   <-------------------------------- This 
is who I want to restrict!!!!!!!!!!!!!!!!!!
class remote guest *
class anonymous_CDC anonymous *.cdc.gov
class anonymous_Outside anonymous *

# deny !nameserved /etc/msgs/msg.denied

limit   special 25  Any    /etc/msgs/msg.toomanylocal
limit   Crawford 1 SuMoTuWeThFrSa900-2259 /etc/msgs/msg.crawford
limit   Jim 1   SuMoTuWeThFrSa1010-1100        /etc/msgs/msg.crawford 
<------ I limited him to one connection.  If I attempt to login outside of 
this time limit I can still logon!  for ex: for the class Craword I do not 
want them to get in between 11:00 p.m. and 9:00 a.m. Can anyone help??? 

limit   remote 25  Any     /etc/msgs/msg.toomany
limit   anonymous_CDC 50  Any  /etc/msgs/msg.toomany
limit   anonymous_Outside  100  Any /etc/msgs/msg.toomany

readme  README*    login
readme  README*    cwd=*

message /welcome.msg        login
message /.change.dir            cwd=* anonymous_Outside anonymous_CDC 
special lo
cal

compress        yes             special anonymous_CDC anonymous_Outside 
remote
tar             yes             special anonymous_CDC anonymous_Outside 
remote
gzip            yes             special anonymous_CDC anonymous_Outside 
remote
# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  warn
log commands real,guest,anonymous
log transfers anonymous,real,guest,special inbound,outbound
shutdown /etc/shutmsg
# all the following default to "yes" for everybody
delete          yes     real,local
overwrite       yes     real,local
rename          yes     real,local
chmod           yes     real,local
umask           yes     real,local
# cdpath
# cdpath  /pub
# cdpath  /
# path-filter...
# path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
# path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

email [email-masked]

---

From: [email-masked] (Koos van den Hout _U nix and we all_)
Date: Thu, 27 Apr 95 21:15:04 MET DST

> though it says 0 users (0 maximum)

The first thing that jumps to my mind when reading this :
Is the pids (process id) dir defined and does it exist ? And since the pids
files have the name of the class, if you have a filesystem with a 14 char
limit, long names can give a problem (but obviously not Jim).

                                                Grtx. KH

-- 
  Koos van den Hout,           Internetter, Unix freak and BBS SysOp at large
  [email-masked] (Home)        BBS Koos z'n Doos (+31-3402-36637 28k8)
  [email-masked] (Work)  <-- finger for PGPkey       (+31-3402-56619 14k4)
  http://www.hvu.nl/~koos (WWW)    Looking for a license plate with "RFC 822"
  GCS d- p(-) c++(+++) l+ u+++ e++ m+(-) s+/- !n h f+ g+ w(++) t+ r !y(*)