Subject: Guestgroup puzzle...

From: [email-masked] (Tom Lojewski)
Date: Mon, 3 Apr 1995 16:54:09 -0700 (PDT)

Dear wu-ftpd user,

I reposted this because of a typo in the first one I sent out.
Basically it says that two guestgroup members can't write into
each other's directories.

That is, groupA and groupB are both guestgroups.  If a member of
groupA owns a directory, a member of groupB can't write into the
directory even if the directory group ownership is groupB.

Given the following wu-ftpd setup, when ftpadmin ftp's in to the
server why, can't he write to the "/FTP/guests/aguest/pub directory"?
I get an "upload" error.  He can read the directory fine.
Thanks for any help you can give me.

(real)/etc/passwd:
------------------
ftpadmin:x:90:90:FTPADMIN:/FTP/guests:/bin/false
aguest:x:100:91:A. GUEST:/FTP/guests/./aguest:/bin/false

(real)/etc/group:
-----------------
FTPADMGROUP:*:90:
GUESTS:*:91:ftpadmin

ftpaccess:
----------
guestgroup aguest,FTPADMGROUP
upload /FTP/guests   *   no
upload /FTP/guests pub/* yes  ftpadmin FTPADMGROUP 0660 nodirs

permissions on /FTP/guests/aguest/pub:
--------------------------------------
drwxrwx---  2  aguest  FTPADMGROUP  37  Apr 3 15:11  /FTP/guests/aguest/pub

--------------------------------------------------------------------------
Tom Lojewski  -  ACUSON Corp  -  Mountain View, CA - ([email-masked])

---

From: [email-masked]
Date: Tue, 4 Apr 95 09:14:42 PDT

>I get an "upload" error.  He can read the directory fine.  User "aguest"
>can read and write just fine.
>

                                      ^^

What happens if you make this path "/FTP/guests/./"?  This is something of a wild guess, but 
it might be worth a try.  To me the rest of it looks ok.

Michael

>guestgroup aguest,ftpadmin
>upload /FTP/guests   *   no
>upload /FTP/guests pub/* yes  ftpadmin ftpadmin 0660 nodirs
>
>drwxrwx---  2  aguest  ftpadmin  37  Apr 3 15:11  /FTP/guests/aguest/pub
>
>
>

---

From: [email-masked]
Date: Wed, 5 Apr 1995 09:14:16 +0200

rh>>
rh>>Dear wu-ftpd user,
rh>>
rh>>Given the following wu-ftpd setup, when ftpadmin ftp's in to the
rh>>server why, can't he write to the "/FTP/guests/aguest/pub directory"?
rh>>I get an "upload" error.  He can read the directory fine.  User "aguest"
rh>>can read and write just fine.
rh>>
rh>>Thanks for any help you can give me.
rh>>
rh>>(real)/etc/passwd:
rh>>------------------
rh>>ftpadmin:x:90:90:FTPADMIN:/FTP/guests:/bin/false
rh>
rh>
rh>>aguest:x:100:91:A. GUEST:/FTP/guests/./aguest:/bin/false
rh>>
rh>>
rh>>(real)/etc/group:
rh>>-----------------
rh>>FTPADMGROUP:*:90:
rh>>GUESTS:*:91:ftpadmin
rh>>
rh>>
rh>>ftpaccess:
rh>>----------
rh>>guestgroup aguest,ftpadmin
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

It's guestgroup groupid, not guestgroup userid.

rh>>upload /FTP/guests   *   no
rh>>upload /FTP/guests pub/* yes  ftpadmin ftpadmin 0660 nodirs
rh>>
rh>>permissions on /FTP/guests/aguest/pub:
rh>>--------------------------------------
rh>>drwxrwx---  2  aguest  ftpadmin  37  Apr 3 15:11  /FTP/guests/aguest/pub
rh>>
rh>

Ronald.