Subject: Re: anon ftp outside of domain under SOLARIS -- somewhat long

From: [email-masked] (Joseph Fornataro Jr (x2163))
Date: Wed, 5 Apr 1995 07:52:58 +0800

> >  - The hosts.allow entry for ftp for the tcpd wrapper reads:
> > 
> > in.ftpd:LOCAL,ALL
> 
should be:

ftpd: LOCAL, ALL

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Joseph Fornataro                              [email-masked]
Technical Support Specialist                  (714) 821-2163
CalComp, Inc.                                 (714) 821-2374 FAX

---

From: [email-masked] (Richard A Haas)
Date: Wed, 05 Apr 1995 12:28:45 -0400

> From [email-masked] Wed Apr  5 11:34 EDT 1995
> 
> 
> Does /etc/ftpshut exist?  If so, delete it.
>

Nope.  Neither /etc/ftpshut or ~ftp/etc/ftpshut exist.  ~ftp/bin/ftpshut
(shutdown binary) does exist.
 
> 
> 
> Try making all the paths below into full paths from root, not relative to 
> ftp home directory.
> 

I made these changes in pathnames.h, rebuilt everything, and HU-ed inetd.  
ckconfig now works and finds its files:

48>./ckconfig
Checking _PATH_FTPUSERS :: /export/asao/ftp/etc/ftpusers
ok.
... etc

Offsite ftp attempts are unchanged (nimitz is offsite machine):

[nimitz]{3}% ftp ftp.lerc.nasa.gov
Connected to ftp.lerc.nasa.gov.
421 Service not available, remote server has closed connection
ftp> 

All other ftps (onsite real, onsite anonymous) are still working fine.

> 
> 
> 
> Hope some of this helps...
>

It's progress in my book.  :-)  Thanks Michael.

Now if someone has a reason why these connections keep being dropped or
what the "421" error is ...

Richard
--
-----------------------------------------------------------------------------
Richard A. Haas			|     Distributed System Admin / Unix Team 
NASA Lewis Research Center     	|     Advanced Space Analysis Office 
Cleveland, Ohio           	|     email: [email-masked] 
-----------------------------------------------------------------------------

---

From: [email-masked] (Harald Milz)
Date: Thu, 06 Apr 1995 09:20:29 +0100 (MET DST)

Subject: Re: anon ftp outside of domain under SOLARIS -- somewhat long
To: [email-masked]
Organization: Harry's Box

> ftpd: LOCAL, ALL

Errr... "ftpd" should be the same as argv[0] in inetd.conf. Plus, my
version of tcpd requires to leave blanks on both sides of the colon. 
Last, ALL should be sufficient because it includes LOCAL. 

Hope this helps. 

hm