Subject: Re: Setup of Specific devices in ~ftp/dev

From: [email-masked] (David Sears)
Date: Thu, 02 Mar 1995 09:48:55 -0700 (MST)

Do a "man ftpd" on your SunOS 5.3 host - there is a ton of a info on setting
up anonymous ftp under SunOS 5.x, including the ~ftp/dev area.  A snippet...

     ~ftp/dev    Make this directory owned by the super-user  and
                 unwritable  by  anyone.  First perform ls -lL on
                 the device files listed below to determine their
                 major  and  minor  numbers,  then  use  mknod to
                 create them in this directory.
 
                 /dev/zero
                 /dev/tcp
                 /dev/udp
                 /dev/ticotsord

Hope this helps. 

David Sears
Sandia National Labs
Dept 1511, Mail Stop 0827
Albuquerque, New Mexico  87185
U.S.A
Voice:	505-844-5729
Fax:	505-844-8251
E-Mail:	[email-masked]

> Date: Thu, 02 Mar 1995 08:37:42 -0400
> From: [email-masked] (jeff garner)
> Subject: Setup of Specific devices in ~ftp/dev
>  
> How do you setup the needed devices with Solaris 2.3 in the ~ftp/dev
> directory?  I don't have much of a background with Unix and I haven't been
> able to find any specific information on how to setup up these needed devices.
>  
> Jeff
> Jeffery P Garner            [email-masked]
>                             Netscan Technology Corporation
> (703) 876-9200              Fairfax, Virginia

---

From: [email-masked] (Kelly Long)
Date: Fri, 03 Mar 1995 18:12:06 -0700 (MST)

> able to find any specific information on how to setup up these needed devices.

Here is what I did on solaris 2.4.  Make sure your major/minor node numbers
are the same as mine or you'll need to change them.

Here is how to determine your major/minor node numbers:

www# ls -lL /dev/zero /dev/tcp /dev/udp /dev/ticotsord
crw-rw-rw-   1 root     sys       11, 42 Feb 27 19:03 /dev/tcp
crw-rw-rw-   1 root     sys      105,  1 Feb 27 19:03 /dev/ticotsord
crw-rw-rw-   1 root     sys       11, 41 Oct 25 10:28 /dev/udp
crw-rw-rw-   1 root     sys       13, 12 Oct 25 10:28 /dev/zero
                                ^^^^  ^^^
                               major  minor

Then execute the following commands:

mknod ~ftp/dev/zero c 13 12
mknod ~ftp/dev/tcp c 11 42
mknod ~ftp/dev/udp c 11 41
mknod ~ftp/dev/ticotsord c 105 1

Kelly Long
[email-masked]

---

From: Lee McLoughlin <[email-masked]>
Date: Sat, 04 Mar 1995 23:37:16 +0000

I have a login account sharing space with the ~ftp area and found I needed
even more items in ~ftp/dev to make it work.

I found the easiest way to populate ~ftp/dev to use a tar that
supported devices, and symlinks since under Solaris 2.3 /dev/is mostly
sylinks, and copied it all by tar'ing up then unravelling /dev.  BTW I
used gnu-tar and, under Solaris 2.3 did:
	cd /dev; tar cfh - . | ( cd ~ftp/dev && tar xvBf - )

-- 
--
Lee McLoughlin.                          Phone: +44 171 594 8388
Dept of Computing, Imperial College,     Fax: +44 171 584 8301
180 Queens Gate, London, SW7 2BZ, UK.    Email: [email-masked]