Subject: Patches/Patch level

From: [email-masked] (David B. Small)
Date: Fri, 03 Mar 1995 07:57:47 -0800

I've got wu-ftpd running just fine, but my question is:

Other sites often have different numbers (than 1) in the parentheses when connecting:

331-(----GATEWAY CONNECTED TO ftp.aud.alcatel.com----)
331-(220 ftp FTP server (Version wu-2.4(5) Fri Sep 16 07:39:22 CDT 1994) ready.

331-(----GATEWAY CONNECTED TO sunsite.unc.edu----)
331-(220 calypso-2.oit.unc.edu FTP server (Version wu-2.4(36) Mon Feb

530-(----GATEWAY CONNECTED TO ftp.uu.net----)
530-(220 ftp.UU.NET FTP server (Version wu-2.4(3) Fri Nov 25 16:08:40 EST 1994) ready.)

(Here the numbers are 5, 36, and 3.)

To what does this number refer?  If it indicates a patch level, where are those patches
archived?

-David

---

From: [email-masked]
Date: Fri, 03 Mar 1995 16:06:52 -0700 (MST)

David B. Small writes:
>[...]
>To what does this number refer?  If it indicates a patch level, where
>are those patches archived?

Not to worry, that number is automatically incremented for each build/make
of wu-ftpd that you perform.  There is a file vers.c that is edited by
the shell script newvers.sh during the make in src/.

--
Mark Walker                     UNM/EECE, 7-3688, [email-masked]

                "I didn't do it."               -- Bart Simpson

---

From: [email-masked] (Russell Street)
Date: Sat, 4 Mar 1995 12:20:22 +1300 (NDT)

Hello...

> 331-(220 ftp FTP server (Version wu-2.4(5) Fri Sep 16 07:39:22 CDT 1994) ready.

The number in parentheses is the number of times the daemon has been
rebuilt on the system.  Check out src/newvers.sh and src/Makefile in
the distribution to see how it does it.

Cheers
Russell
 -------------------------------------------------------------------
 Russell Street ([email-masked]) +64 (9) 373-7599 extn 6487
   UNIX Systems Programmer, Computer Centre, University of Auckland
	     http://www.auckland.ac.nz/cc/People/RS.html

	   It's something to do with the shortage of money
	       and the holidays in the South of France.