Subject: Need help with wu-ftpd 2.4

From: [email-masked] (Bill Weissborn)
Date: Fri, 31 Mar 1995 11:15:18 -0600

First problem was that there was a variable NGROUPS_MAX not defined in
ftpcmd.y.  I added a "define" and defined that variable the number 20.  Is
that a good value?

I did the build install, edited the inetd.conf and killed the inetd and
restarted it.

I copied the files from doc/examples to the various directories to the
directories in src/pathnames.h

I can bin/ckconfig and get the following:

Checking _PATH_FTPUSERS :: /etc/ftpusers
ok.
 
Checking _PATH_FTPACCESS :: /usr/local/etc/ftpaccess
ok.
 
Checking _PATH_PIDNAMES :: /usr/local/daemon/ftpd/ftp.pids-%s
I can't find it...
You need to make this directory [/usr/local/daemon/ftpd] in order for
the limit and user count functions to work.
 
Checking _PATH_CVT :: /usr/local/etc/ftpconversions
I can't find it... look in doc/examples for an example.
 
Checking _PATH_XFERLOG :: /usr/adm/xferlog
I can't find it... 
Don't worry, it will be created automatically by the
server if you do transfer logging.
 
Checking _PATH_PRIVATE :: /etc/ftpgroups
ok.
 
Checking _PATH_FTPHOSTS :: /usr/local/etc/ftphosts
I can't find it... look in doc/examples for an example.
You only need this if you are using the HOST ACCESS features
of the server.

Finally, I rebooted the machine.

HOWEVER, when try to access the system via ftp, I a message about the
Service is not available.

Help!

thanks in advance

Bill W.

*********************************************************
Bill Weissborn                                          
GeoQuest ICS-GNA Tech Support                                   
4100 Spring Valley Rd.                                      
Suite 600                                                             
Dallas TX  75244

Internet:    [email-masked]
 VAXmail: dfwdsr::weissborn
 Voice: 1-214-980-7924
FAX: 1-214-991-4180                                         
********************************************************

---

From: Jonathan Zamick <[email-masked]>
Date: Fri, 31 Mar 1995 10:18:13 -0800

1. Have you set up ~ftp/dev/zero as needed by SunOS?

2. Check the options as set by ftpaccess

3. Check inetd.conf to make sure it refers to the new ftpd properly (I think
   you mentioned doing this, but still it can't hurt to check.)

Jonathan