Subject: Re: The upload command in ftpaccess file

From: Randy Medd <[email-masked]>
Date: Wed, 08 Mar 1995 08:40:13 -0800

>Excuse me for being dumb, but what does the struct timeval have to do with
>timeout?  Timeout isn't even in the structure.

><       timeout.tv_usec = 0;
><       timeout.tv_sec = 120;
>
>< if (select(pdata+1, &set, (fd_set *) 0, (fd_set *) 0, &timeout) == 0 ||
                                                         ^^^^^^^^
How about this timeout?  The select() call waits for either a connection
event on the socket or for 120 seconds to pass.  The 120 second timeout is
what prevents the documented hangs.

-- 
-------------------------------------------------------------
Randy Medd                           email: [email-masked]
Telamon, Inc.
492 Ninth Street, Suite 310          voice: 510-987-7700
Oakland, CA 94607                      fax: 510-987-7009
-------------------------------------------------------------

---

From: [email-masked]
Date: Wed, 08 Mar 1995 10:00:31 -0800 (PST)

>-upload  /Second/Users/ftp  *       no
>-upload  /Second/Users/ftp  /incoming  yes  root  wheel  0600  nodirs   

>	Maybe flip those lines? I know several other things in the access file
>read top-down, so it may see the "no" first off, and just stop. If you flip
>'em, it should see the /incoming as a yes, and everything else as a no.

I have them in this order and all is working well.  This is the order of the ftpaccess
files that come with wu-ftpd.

Michael
---------------
Michael Brennen                    Intecom, Inc.
[email-masked]               5057 Keller Springs
(214) 447-8074                     Dallas,  TX  75248