Subject: not work during anonymous ftp

From: [email-masked] (demo_2)
Date: Mon, 27 Mar 95 17:06:02 HKT

I have got a problem during I use anonymous ftp.  For my site, I installed wu-ftpd-2.4 in the sparc-sun-sorlaris2.4. If I use the real account to login the ftp, it works properly. But, if I anonymous ftp it, there is that error message:
	425 Can't create data socket (0.0.0.0,20): Bad file number.
after I type dir, ls, uncompress.....  Here, I have copy ls , uncompress... in the <ftphome>/bin and its relative library in <ftphome>/usr/lib.  I think it should some problem in the solaris2.4, there are some special files that are necessary.
	Who can help me to solve it?

---

From: [email-masked] (Russell Street)
Date: Mon, 27 Mar 1995 21:26:20 +1200 (NZT)

> after I type dir, ls, uncompress.....  Here, I have copy ls , uncompress... in the <ftphome>/bin and its relative library in <ftphome>/usr/lib.  I think it should some problem in the solaris2.4, th…

Have you put all the libraries listed in the Sun man page for ftpd?

Check your device nodes' major and minor numbers.  Make sure
	ls -lL /dev/udp ~ftp/dev/udp
 etc match up.

Better still:
	Go and get the Recommended Patch Cluster from Solaris 2.4
	If you have software support, bug your vendor!
	If you don't The Solaris FAQ should tell you where it is.
	Install the patches.  Solaris 2.{3,4} straight from the CD has
	problems.

	move your current FTP tree safely out of the way

	read the Solaris man page and follow their 5 or so steps to
	  creating an FTP site

	Use the vendor *supplied* version FIRST and make sure it works

	Then replace the line in 'ftp' /etc/inet/inded.conf with the WU-FTPD.

A few nights ago I created an anon FTP area on our Solaris 2.4 machine
from scratch by following the instructions in the man page.  The
WU-FTPD (compiled on a 2.3 system) worked just fine, as did the stock
Sun version.

Good luck
Russell
-------------------------------------------
Russell Street [[email-masked]]
http://www.auckland.ac.nz/cc/People/RS.html
(.samtsirhC rof sdrawkcab gnipyT)