Subject: bin/ls not properly working

From: [email-masked] (jeff garner)
Date: Fri, 03 Mar 1995 17:52:59 -0400

When connecting from my internal lan using anonymous the ls command works
fine, but connecting from outside using anonymous I'm able to login but when
I do a ls I receive the following:

ftp>ls
200 PORT command successful.
150 <Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp>

I'm running my server on Solaris 2.3. I've moved the runtime loader and the
shared version of the standard C library into the ~ftp/usr/lib directory and
the ls into the ~ftp/bin directory.

Thank you for your help in advance.

Jeff
Jeffery P Garner            [email-masked]
                            Netscan Technology Corporation
(703) 876-9200              Fairfax, Virginia

Jeffery P Garner            [email-masked]
                            Netscan Technology Corporation
(703) 876-9200              Fairfax, Virginia

---

From: [email-masked]
Date: Mon, 06 Mar 1995 08:47:23 +0100

rh>
rh>When connecting from my internal lan using anonymous the ls command works
rh>fine, but connecting from outside using anonymous I'm able to login but when
rh>I do a ls I receive the following:
rh>
rh>ftp>ls
rh>200 PORT command successful.
rh>150 <Opening ASCII mode data connection for /bin/ls.
rh>226 Transfer complete.
rh>ftp>
rh>
rh>I'm running my server on Solaris 2.3. I've moved the runtime loader and the
rh>shared version of the standard C library into the ~ftp/usr/lib directory and
rh>the ls into the ~ftp/bin directory.

You need far more in /lib. Look at the ftpd manual page from Solaris.

rh>
rh>Thank you for your help in advance.
rh>
rh>Jeff

Ronald.