Subject: using "put"

From: Laura Schrager-Wingard <[email-masked]>
Date: Wed, 01 Mar 1995 16:11:16 -0800

When I use "put" to write out a file, the owner of the file (after it
gets written out) is owned by "ftp".  Where is this coming from?
I don't have this in my ftpaccess file.  I'd like the owner to be someone
else other than ftp.  I've read far too much stuff about not ever having
a directory or file be owned by ftp.  Is there any easy way to change
the default ownership of ftp to someone else?

Thanks,

Laura
([email-masked])

---

From: [email-masked] (Russell Street)
Date: Thu, 2 Mar 1995 16:34:46 +1300 (NDT)

> gets written out) is owned by "ftp".  Where is this coming from?

Because the deamon is running as FTP at this point... or something....

I have...

## -----------------------------------------------------------------
## Permission capabilities for the anonymous users
## They are not allowed to chmod, delete, overwrite or change umask
## -----------------------------------------------------------------

chmod		no	anonymous
delete		no	anonymous
rename		no	anonymous
overwrite	no	anonymous
umask		no	anonymous

path-filter anonymous /etc/allowed.filenames ^[-A-Za-z0-9\._]*$ ^\. ^-

## There is only one upload directory /incoming
## Files are owned by `root.ftpadmin' and are chmod 660
## Subdirectories can not be made

upload	/home/ftp	*		no
upload	/home/ftp	/incoming	yes root ftpadmin 0660 nodirs

in my access file.  Is that the sort of thing you want?

Cheers
Russell
[where was that FAQ again?]

 -------------------------------------------------------------------
 Russell Street ([email-masked]) +64 (9) 373-7599 extn 6487
   UNIX Systems Programmer, Computer Centre, University of Auckland
	     http://www.auckland.ac.nz/cc/People/RS.html

	   It's something to do with the shortage of money
	       and the holidays in the South of France.