Subject: Re: wuftpd 2.1 & mosaic

From: [email-masked] (demo_2)
Date: Fri, 17 Mar 95 10:43:06 HKT

Dear Sir,
	I have copy "ls" in /<ftpdir>/bin and the lib of ls in /<ftpdir>/usr/lib. I am sure that /usr/lib is 555.  But the problem still exists. Can you give me more detail in the configuration and how to solve it?

Thank you.

---

From: [email-masked] (Patrick Salsbury)
Date: Fri, 17 Mar 95 15:48:49 PST

-Date: Fri, 17 Mar 95 10:43:06 HKT
-Reply-To: [email-masked]
-Sender: [email-masked]
-From: [email-masked] (demo_2)
-X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
-
-Dear Sir,
-	I have copy "ls" in /<ftpdir>/bin and the lib of ls in /<ftpdir>/usr/lib. I am sure that /usr/lib is 555.  But the problem still exists. Can you give me more detail in the configuration and how to solve it?
-
-Thank you.
-
	Here's a bit from my tree...

(3:47pm)Fri 17#l -aR bin/ usr/
bin/:
total 397
dr-xr-sr-x  3 root          512 Mar 10 16:35 .
dr-xr-xr-x  9 root          512 Mar  9 17:37 ..
-r-xr-xr-x  1 root        24576 Aug  9  1994 compress
dr-xr-sr-x  2 root          512 Jul 28  1994 ftp-exec
-r-xr-xr-x  1 root        98304 Aug  9  1994 gzip
-r-xr-xr-x  1 root       114688 Mar 10 16:35 ls
-r-xr-xr-x  1 root       114688 Mar 10 16:13 ls-dynam
-r-xr-xr-x  1 root        19973 Mar  9 17:03 ls-ftp
-r-xr-xr-x  1 root        13352 Sep 30  1993 ls-old

bin/ftp-exec:
total 122
dr-xr-sr-x  2 root          512 Jul 28  1994 .
dr-xr-sr-x  3 root          512 Mar 10 16:35 ..
---x--x--x  1 root        24576 Jul 21  1994 compress
---x--x--x  1 root        98304 Jul 28  1994 gzip

usr/:
total 3
dr-x--s--x  3 root          512 Sep 30  1993 .
dr-xr-xr-x  9 root          512 Mar  9 17:37 ..
dr-xr-sr-x  2 root          512 Mar 15 13:52 lib

usr/lib:
total 1242
dr-xr-sr-x  2 root          512 Mar 15 13:52 .
dr-x--s--x  3 root          512 Sep 30  1993 ..
-r-xr-xr-x  1 root        40960 Sep 30  1993 ld.so
-r--r--r--  1 root       661708 Oct 13  1993 libc.a
-r--r--r--  1 root         7996 Oct 13  1993 libc.sa.1.9
-r--r--r--  1 root       516096 Mar 10 15:43 libc.so.1.9
-r--r--r--  1 root        24576 Oct 13  1993 libdl.so.1.0
(3:47pm)Fri 17#

	Could also be your libraries in /usr/lib/

	I'm running SunOS 4.1.3_U1. Used 'ldd ls' on the ls in the bin dir to
find out what libs it needed.

(3:47pm)Fri 17#ldd bin/ls
        -lc.1 => /usr/lib/libc.so.1.9
        -ldl.1 => /usr/lib/libdl.so.1.0

	Hope this helps!  

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                IXI/Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists