Subject: Dir command Doesn't work

From: Peter Merritt <[email-masked]>
Date: Wed, 22 Mar 1995 12:23:57 +0000

I have everything working correctly with wu-ftpd-2.4. I just can't get 
the "dir" command to work. Here is what I mean.

331 Guest login ok, send your complete e-mail address as password.
Password:
230 Guest login ok, access restrictions apply.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
0 bytes received in 0.0039 seconds (0 Kbytes/s)
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
dos
windows
macintosh
linux
graphics
bcca

As you can see "ls" works, just dir doesn't produce output. I have a 
statically linked binary of "ls" in the /home/ftp/bin directory. And the 
appropriate passwd and groups files int /home/ftp/etc. I've tried several 
things and nothing has worked. Any help would be greatly appreciated.
 Peter

Knowledge is a single point, but the ignorant have multiplied it - Baha'u'llah
  / __ \___ ___ _____ / /____ _____  [email-masked]   
 / /_/ / _ `/ // (_-</ __/ _ `/ __/  Bahainet:109:6020/191     Tucson, Arizona
/_____/\_,_/\_, /___/\__/\_,_/_/     Fidonet :1:300/107        (602) 798-1763
           /___/           
Win95 - OS of Global Domination ************** LINUX - OS of Global Cooperation

---

From: [email-masked]
Date: Wed, 22 Mar 95 15:00:43 PST

ls is done by ftpd w/o using bin/ls; dir uses bin/ls.  Sounds like it could be a protection 
problem; it works to set both bin and ls to 111.  Make sure is really is a static version of 
ls - others have struggled with that recently, only to find out it was in fact dynamic.  It 
sounds like the problem is quite isolated, so judicious checking should get it.

Hope this is of some help.

---------------
Michael Brennen                    Intecom, Inc.
[email-masked]               5057 Keller Springs
(214) 447-8074                     Dallas,  TX  75248