Subject: ftp conversions on Irix 5.2

From: [email-masked]
Date: Fri, 10 Mar 1995 17:09:46 +0000 (GMT)

I have been trying to get the ftpconversions bits working on Irix 5.2,
but haven't succeeded yet. It does send the files, but no conversions
are getting done. Other people having problems appear to get 0 length
files, but I'm just not getting the conversion. I have run ckconfig
and that seems to find the relevant files.

I have tried running odump -DL <binary> on the files to check for any
missing libraries, but the only one needed appears to be libc.so.1,
which is in the ~ftp/lib directory along with rld.

Any ideas would be much appreciated.

Bill Edmunds, IT Services, University of Exeter
[email-masked]

----------------------------------------------------------------------
ftpconversions:

 :.Z:  :  :/bin/uncompress -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

----------------------------------------------------------------------
ftpaccess:

#
# Set up classes of users (at least 1)
#
#     classname   type-list             site-list
#
class local       real,anonymous        *.ex.ac.uk 144.173.*.*
class remote      real,anonymous        *
class guest-users guest                 *

#
# Print README files
#
#      pathname  when    class
#
readme README*   login
readme README*   cwd=*

#
# Print messages
#
#       pathname  when    class
#
message /Welcome  login
message .message  cwd=*

#
# Transfer mechanisms
#
#        y/n class-name
#
compress yes      local remote
tar      yes      *
gzip     yes      *

#
# Terminate connection after login failures
#
#          limit
#
loginfails   3

#
# Limit FTP logins
#
#     class-name  limit  time        message-file
#
limit local         8    Any         /usr/local/etc/ftp/ftp.local.toomany
limit remote        8    Any         /usr/local/etc/ftp/ftp.remote.toomany
limit guest-users   0    Any         /usr/local/etc/ftp/ftp.guest.toomany

#
# Login banner
#
#      banner-file
#
banner /usr/local/etc/ftp/ftp.banner

#
# Email address of FTP administrator
#
#     address
#
email [email-masked]

#
# Logging requirements
#
#   desc       type-list            directions
#
log commands   anonymous,guest
log transfers  anonymous,guest,real inbound,outbound

#
# Permission capabilities
#
#         y/n type-list
#
chmod     no  anonymous
delete    no  anonymous
overwrite no  anonymous
rename    no  anonymous
umask     no  anonymous

#
# Password check
#
#            level   severity
#
passwd-check rfc822  enforce

#
# Upload directory
#
#      root    dirname    n/y  owner    group
#
upload /ftp    *          no   ftp      ftp
upload /ftp    /incoming  yes  ftp      ftp

#
# Shutdown message
#
#        message-file
#
shutdown /usr/local/etc/ftp/ftp.shutdown

#
# End of configuration
#

---

From: "D.Ashton-Reader" <[email-masked]>
Date: Mon, 13 Mar 1995 15:28:21 +0000

Ron Hall wrote:

> 	But what did you do to compile it. I'm getting grevious errors
> 	form /usr/include/sys/select.h about improperly formed C code.

Ah: I think I may have GNUed it (cos I seem to remember those probs too)

							David A-R :-)