Subject: RE: wu-ftpd stopped working

From: [email-masked]
Date: Tue, 14 Mar 1995 13:59:35 +0100

rh>
rh>On Mon, 13 Mar 1995 [email-masked] wrote:
rh>
rh>> Sounds like a kernel problem to me???  Have you changed your OS?  If not
rh>> I don't have any suggestions.
rh>
rh>
rh>I did change OS, maybe that's the cause. However, a complete recompile 
rh>didn't work either (original message follows)
rh>
rh>> 
rh>> >I had set up wu-ftpd 2.4 on my machine (sparc-station 20, solaris2.3, 
rh>> >later 2.4) and it worked just fine (though there wasn't any usefull info 
rh>> >on it yet :-). However, now it just stopped working!?!
rh>> >
rh>> >The only thing I ca get out of it is:
rh>> >
rh>> >USER boekhold: No control connection for command (9): Bad file number
rh>> >Login failed.
rh>> >
rh>> >I can't get any more info, since I still haven't got syslogging working 
rh>> >here (with wu-ftpd I mean).
rh>> >
rh>> >Anybody got a clue as what might be wrong???
rh>> >
rh>> >Maarten
rh>> 

Did you replace your /etc, /dev, (/usr)/lib and (/usr)/bin ?
I think you will need that when you change OS.

Hope this helps,

Ronald.

__
// Ronald Hello  ([email-masked])
// University of Twente
// Department of Computer Science
// The Netherlands

---

From: Maarten Boekhold <[email-masked]>
Date: Fri, 17 Mar 1995 14:40:49 +0200 (METDST)

> I think you will need that when you change OS.

Nope, didn't help. I think I now tried about everything, and still can't 
get it to work. Not even with real users :-(

So, I decided to mail everything to the list. If anybody can help me on 
this, *please* do so. I need this server up and running again soon now. 
My boss is pushing me.

Maarten

The computer is a SparcStation 20 with Solaris 2.4. Relevant files and 
data follows....

/etc/inetd.conf:

ftp     stream  tcp     nowait  root    /usr/local/lib/wu-ftpd/bin/ftpd ftpd -a 

/etc/passwd:

ftp:x:30000:30000:Anonymous FTP:/home/ftp:/nosuchshell

/etc/shadow:

ftp:NP:6445::::::

/etc/ftpusers is empty, all shells are in /etc/shells

All files/directories under /home/ftp are as in the Solaris ftpd-manpage, 
except for ~ftp/pub, which is 775, not 777

ftpaccess:

class   local   real  library.tudelft.nl
class   remote	anonymous,guest,real	*

limit   remote	 5   Any              /.remote-tomany
limit	local	10   Any	      /.local-tomany

banner /home/ftp/.pre-login-msg

readme  /README   login	remote

readme  README   cwd=*  remote

message /.welcome-msg            login	remote

message .message                cwd=*	remote

compress        no              local remote
tar             no              local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutdown

passwd-check	rfc822	warn

path-filter anonymous	/etc/pathmsg	^$^.

upload  /home/ftp * no
upload	/home/ftp pub/incoming	yes	ftp	info	0660 nodirs

delete		no	guest, anonymous
overwrite	no	guest, anonymous
rename		no	guest, anonymous
chmod		no	guest, anonymous
umask		no	guest, anonymous

email [email-masked]

---

If anybody can help me on this, *please*....

Maarten

ps. It would also be real nice if someone could tell me how to get 
logging to syslog working. It has never worked for me, thought I have 
done some hacking on it....
 
_____________________________________________________________________________
|    Maarten Boekhold, Faculty of Electronical Engineering TU Delft,  NL    |
|        [email-masked]      [email-masked]         |
|          <a href="http://morra.et.tudelft.nl/~boekhold">me</a>            | 
-----------------------------------------------------------------------------