Subject: Static ls

From: [email-masked] (Patrick Salsbury)
Date: Thu, 09 Mar 1995 17:08:38 -0800 (PST)

Ok, I think I'm losing it...

	I went through the searchable archives, and pulled up a message on the
static binary of ls. Gave a reference to a site where I could even grab one.
So I did, and IT isn't working, either!	
	What the heck am I missing?

				 (snip snip)
-------------------------------------------------------------------------------
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
etc
pub
usr
dev
exi
eval
welcome.msg
.rhosts
.forward
226 Transfer complete.
68 bytes received in 0.0043 seconds (15 Kbytes/s)
ftp> ls -al
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
-------------------------------------------------------------------------------

>From my ftp's /bin directory:

total 155
-r-xr-xr-x  1 root     wheel       24576 Aug  9  1994 compress
dr-xr-sr-x  2 root     wheel         512 Jul 28  1994 ftp-exec
-r-xr-xr-x  1 root     wheel       98304 Aug  9  1994 gzip
-r-xr-xr-x  1 root     wheel       19973 Mar  9 17:03 ls
-r-xr-xr-x  1 root     wheel       13352 Sep 30  1993 ls-old

	(ls-old is the dynamically linked version)

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                IXI/Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists

---

From: Steve Young <[email-masked]>
Date: Fri, 10 Mar 1995 08:39:58 -0500 (EST)

> 	What the heck am I missing?

	Test ls in a chroot'd environment: (Check the manpages on chroot)

	chroot /home/ftp /bin/ls

	And follow the errors from there.

Steve

---

From: giorgos adamopoulos <[email-masked]>
Date: Fri, 10 Mar 1995 16:13:57 +0200 (EET)

> Ok, I think I'm losing it...
  
  No!  it doesn't worth it!

> 	What the heck am I missing?

  I use the GNU version of ls.  My ~ftp/bin is:

  # ls -ldF bin
  d--x--x--x   2 root     system        512 Oct 27  1993 bin/

  # cd bin; ls -alF
  d--x--x--x   2 root     system        512 Oct 27  1993 ./
  drwxr-xr-x   5 root     system        512 Mar  8 18:50 ../
  ---x--x--x   1 root     bin        224680 Oct 27  1993 ls*

  *Every* executable in the ~ftp/bin should be of mode 0111.
  (from the orig. man page of ftpd(8)).
-- 
 giorgos adamopoulos ([email-masked])