Subject: Can't use sid to ftp in

From: Dave Shutt <[email-masked]>
Date: Wed, 22 Mar 1995 10:22:46 -0500 (EST)

I have recently set ftpd 2.4 and everything works except that I cannot ftp
in as a user, only as anonymous ftp.  I get the following message:

530 User mylogin access denied...
Login failed.
ftp>

Also, I realized the the "passwd-check  rfc822  warn" line was not in the
etc/ftpaccess file in the beginning but I still can't make it work even with
the line added.  Any ideas?

Dave Shutt

---

From: [email-masked] (Patrick Salsbury)
Date: Wed, 22 Mar 95 09:46:08 PST

-Date: Wed, 22 Mar 1995 10:22:46 -0500 (EST)
-Reply-To: [email-masked]
-Sender: [email-masked]
-From: Dave Shutt <[email-masked]>
-Mime-Version: 1.0
-Content-Type: TEXT/PLAIN; charset=US-ASCII
-X-Listprocessor-Version: 7.1 -- ListProcessor by CREN
-
-I have recently set ftpd 2.4 and everything works except that I cannot ftp
-in as a user, only as anonymous ftp.  I get the following message:
-
-530 User mylogin access denied...
-Login failed.
-ftp>
-
-Also, I realized the the "passwd-check  rfc822  warn" line was not in the
-etc/ftpaccess file in the beginning but I still can't make it work even with
-the line added.  Any ideas?
-
-Dave Shutt
-
-
	Have you defined a class for 'real' users in ftpaccess?
Here's mine:

class	local		real	192.187.225.* *.visionware.com 

	Hope this helps! 

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                IXI/Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists
 Check out <A HREF="http://www.visionware.com/">The Visionware Homepage</A>

---

From: [email-masked]
Date: Wed, 22 Mar 1995 17:25:44 +0000 (GMT)

> the line added.  Any ideas?

Make sure your default shell appears in /etc/shells and then it should be OK.

Bill Edmunds, IT Services, University of Exeter