Subject: Setup of Specific devices in ~ftp/dev

From: [email-masked] (jeff garner)
Date: Thu, 02 Mar 1995 08:37:42 -0400

How do you setup the needed devices with Solaris 2.3 in the ~ftp/dev
directory?  I don't have much of a background with Unix and I haven't been
able to find any specific information on how to setup up these needed devices.

Jeff
Jeffery P Garner            [email-masked]
                            Netscan Technology Corporation
(703) 876-9200              Fairfax, Virginia

---

From: [email-masked]
Date: Thu, 02 Mar 1995 09:41:39 -0700 (MST)

>able to find any specific information on how to setup up these needed devices.

By using the mknod command.  For an example see the prototype script
in the Sun man page for ftpd: 'man -s 1m ftpd'

One must first determine what the major and minor device numbers are for
the special device files of interest: 'ls -alL /dev/{zero,tcp,udp,ticotsord}'
and then do mknods in ~ftp/dev to match.

On my system this went something like:

# ls -alL /dev/{zero,tcp,udp,ticotsord}
crw-rw-rw-   1 root     sys       11, 42 Dec 26  1993 /dev/tcp
crw-rw-rw-   1 root     sys       11,  9 Dec 26  1993 /dev/ticotsord
crw-rw-rw-   1 root     sys       11, 41 Dec 26  1993 /dev/udp
crw-rw-rw-   1 root     sys       13, 12 Dec 26  1993 /dev/zero
# cd ~ftp/dev
mknod tcp c 11 42
mknod ticotsord c 11 9
mknod udp c 11 41
mknod zero c 13 12

We actually ran for a couple of years with only tcp and zero, but the 
Sun man page states all 4 are needed for various purposes so I now
use all of them.

This same manpage says the device files must be mode 666.  I don't
know if this really is necessary or not.  It makes some of us a bit
nervous, but we don't real know if there is a security issue
or not.

--
Mark Walker               UNM/EECE, 7-3688, [email-masked]

      "Trust me, I know what I'm doing."     -- Sledge Hammer

---

From: [email-masked] (Russell Street)
Date: Fri, 3 Mar 1995 09:01:29 +1300 (NDT)

> able to find any specific information on how to setup up these needed devices.

Isn't it all explained in the Solaris manual page for ftpd?  I have...

ls -l ~ftp/dev
total 0
crw-rw-rw-   1 root     root      11, 42 Mar 28  1994 tcp
crw-rw-rw-   1 root     root      11,  9 Mar 28  1994 ticotsord
crw-rw-rw-   1 root     root      11, 41 Mar 28  1994 udp
crw-rw-rw-   1 root     root      13, 12 Mar 28  1994 zero

and it seems to work just fine.

Cheers
Russell
 -------------------------------------------------------------------
 Russell Street ([email-masked]) +64 (9) 373-7599 extn 6487
   UNIX Systems Programmer, Computer Centre, University of Auckland
	     http://www.auckland.ac.nz/cc/People/RS.html

	   It's something to do with the shortage of money
	       and the holidays in the South of France.

---

From: [email-masked] (Tom Lojewski)
Date: Mon, 06 Mar 1995 10:09:13 -0800 (PST)

> and it seems to work just fine.

My question is, do they *need* to be "rw" to the world?

--------------------------------------------------------------------------
Tom Lojewski  -  ACUSON Corp  -  Mountain View, CA - ([email-masked])

---

From: [email-masked] (Russell Street)
Date: Tue, 7 Mar 1995 18:12:24 +1300 (NDT)

> My question is, do they *need* to be "rw" to the world?

That is the way the "real" devices are set up (in /devices).  I am
curious about this point as well.  I think there was someone from Sun
lurking on this list.  Perhaps he could answer our concerns.

Cheers
Russell

---

From: Stefan Rensing <[email-masked]>
Date: Tue, 07 Mar 1995 09:18:04 +0100 (MET)

> My question is, do they *need* to be "rw" to the world?
This is my configuration:

15838    0 crw-rw-rw-   1 root     other      2,  2 Nov 18 13:50 null
15834    0 crw-rw-rw-   1 root     other     11, 42 Nov 18 13:27 tcp
15835    0 crw-r--r--   1 root     other     11,  9 Nov 18 13:27 ticotsord
23124    0 crw-rw-rw-   1 root     other      1,  0 Nov 18 13:46 tty
15836    0 crw-r--r--   1 root     other     11, 41 Nov 18 13:27 udp
15837    0 crw-r--r--   1 root     other     13, 12 Nov 18 13:28 zero

which works fine :)

- Stefan.

-- 
Stefan A. Rensing             Institute of Biology II/III - Schaenzlestr. 1
The SysOp Biologist           D-79104 Germany, phone: +49 761 2676 / FAX: 2675
e-mail: [email-masked]  MUD: port 4242 on that <- host
http://www.biologie.uni-freiburg.de/data/people/lije.html IRC:Lije MUD:Aragorn
                                                      "I love you !" "I know."