Subject: Re: ftp conversions on Irix 5.2

From: "D.Ashton-Reader" <[email-masked]>
Date: Mon, 13 Mar 1995 10:16:40 +0000

Bill Edmunds wrote:

> I have been trying to get the ftpconversions bits working on Irix 5.2,
> but haven't succeeded yet. It does send the files, but no conversions
> are getting done. Other people having problems appear to get 0 length
> files, but I'm just not getting the conversion. I have run ckconfig
> and that seems to find the relevant files.
> 
> I have tried running odump -DL <binary> on the files to check for any
> missing libraries, but the only one needed appears to be libc.so.1,
> which is in the ~ftp/lib directory along with rld.

I got IRIX 5.2 working with the following:

lib:
total 3780
-r-xr-xr-x    1 root     1310168 Feb 21 11:44 libc.so.1
-r-xr-xr-x    1 root      624832 Feb 21 11:52 rld

usr/lib:
total 869
lrwxr-xr-x    1 root          19 Feb 21 14:19 libc.so.1 -> ../../lib/libc.so.1
-r-xr-xr-x    1 root      313060 Feb 21 14:35 libnsl.so
-r-xr-xr-x    1 root      130892 Feb 21 14:35 libsocket.so

dev:
total 0
cr--r--r--    1 root      37,  0 Feb 21 12:13 zero

I hope that helps?
							Cheers, David A-R :-)

---

From: Ron Hall <[email-masked]>
Date: Mon, 13 Mar 1995 08:21:20 -0500 (EST)

> I got IRIX 5.2 working with the following:

	But what did you do to compile it. I'm getting grevious errors
	form /usr/include/sys/select.h about improperly formed C code.

	Any hints here?

       Ron Hall       | DISCLAIMER: I said it. I must've meant it. There is
       Analyst        |             nobody else to blame.
 <[email-masked]> | Clown:n: A man who acts too natural.
   +1 514 398 3718    | "Whenever doubt can be called into question, do so."

---

From: [email-masked]
Date: Mon, 13 Mar 1995 15:37:37 +0000 (GMT)

> cr--r--r--    1 root      37,  0 Feb 21 12:13 zero

Hmm...

Tried that, but no different, I'm afraid!

Bill Edmunds, IT Services, University of Exeter

---

From: [email-masked]
Date: Mon, 13 Mar 1995 15:32:58 +0000 (GMT)

>    +1 514 398 3718    | "Whenever doubt can be called into question, do so."

There is a version floating around that has been altered for IRIX 5.2. I
can't remember the site that I got the software from, but it was called
SGI_wuftpd-2.4.tar.gz - you'll need to do an archie search. Failing that
I could post you a copy if you would prefer.