Subject: Help with DIR

From: [email-masked]
Date: Mon, 20 Mar 95 12:54:55 PST

Hello All,
I need some help...  I have installed wu-ftpd v2.4(1) at my site.  
Everything seems OK, but after I make a connection I get no listing
when I do a DIR.  Can anybody point me in the right direction or
tell me what I am doing wrong???  Thanks in advance.
Paul

  Paul W. Pelland                             Internet: [email-masked]       
  Applied Micro Circuits Corp.                UUCP: ...!ucsd!amcc!paulp  
  6195 Lusk Blvd.                                                            
  San Diego, CA 92121                        Voice: (619) 535-4228

---

From: Vidiot <[email-masked]>
Date: Mon, 20 Mar 1995 16:04:41 -0600 (CST)

Paul (and othjer interested parties):

<Hello All,
<I need some help...  I have installed wu-ftpd v2.4(1) at my site.  
<Everything seems OK, but after I make a connection I get no listing
<when I do a DIR.  Can anybody point me in the right direction or
<tell me what I am doing wrong???  Thanks in advance.

Here is a script that definately helps install the necessary files:

#!/bin/sh

# Set this to whoever will maintain your ftp site. root is probably a good bet.
# Your username is another possibility.  ftp is NOT!  No directories or files
# inside ~ftp should be owned by ftp.
YOU=root

# No other parameters should need to be changed

# Get the UID of YOU and ftp
YOUUID=`grep "^$YOU:" /etc/passwd | cut -d: -f3`
if [ "x" = "x$YOUUID" ]; then
  echo User $YOU not found
  exit
fi
FTPDIR=`grep "^ftp:" /etc/passwd | cut -d: -f6`
if [ "x" = "x$FTPDIR" ]; then
  echo ftp home directory not found
  exit
fi

# Find the correct libc.so and libdl.so
LIBC=`ls /usr/lib/libc.so.* | tail -1`
LIBDL=`ls /usr/lib/libdl.so.* | tail -1`

install -d -o $YOU -g wheel -m 755 $FTPDIR
cd $FTPDIR
install -d -o root -g wheel -m 555 bin
install    -o root -g wheel -m 111 /usr/bin/ls bin
install -d -o root -g wheel -m 555 dev
install -d -o root -g wheel -m 555 etc
install -d -o $YOU -g wheel -m 722 incoming
install -d -o $YOU -g wheel -m 755 pub
install -d -o root -g wheel -m 555 usr
install -d -o root -g wheel -m 555 usr/lib
install    -o root -g wheel -m 555 /usr/lib/ld.so  usr/lib
install    -o root -g wheel -m 555 $LIBC usr/lib
if [ "x" != "x$LIBDL" ]; then
install    -o root -g wheel -m 555 $LIBDL usr/lib
fi
install -d -o root -g wheel -m 555 usr/share
install -d -o root -g wheel -m 555 usr/share/lib
install -d -o root -g wheel -m 555 usr/share/lib/zoneinfo
install    -o root -g wheel -m 444 /usr/share/lib/zoneinfo/localtime usr/share/lib/zoneinfo

mknod dev/zero c 3 12
chown root.wheel dev/zero
chmod 444 dev/zero

echo "wheel:*:0:" >etc/group
chown root.wheel etc/group
chmod 444 etc/group

echo "root:*:0:0:::" >etc/passwd
if [ $YOUUID != 0 ]; then
echo "ftpadmin:*:$YOUUID:0:::" >>etc/passwd
fi
chown root.wheel etc/passwd
chmod 444 etc/passwd

exit

Note: If you have backup copies of original libc.s* stuff (as a result of
installing resolve2.1+), this script will copy over the wrong libc.s* files.
Also, the incoming directory has the wrong permissions, it should be 733
in order for someone to enter the directory and upload stuff.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.ftms.com/vidiot/  (Your link to the world of Star Trek)