Subject: guest logins

From: Darren Ensley <[email-masked]>
Date: Wed, 22 Feb 1995 15:10:29 -0800

After days of trying, I am unable to get the wu-ftpd guest logins to work correctly.
I am running wu-ftpd 2.4 on a SPARCstation 2 running SunOS 4.1.3.
I am following the examples out of Managing Internet Information Services from
O'Reilly.  When I attempt to log in as the guest user, I get an immediate "User guest1 access
denied" message and never a password prompt.  If I change the guest users shell in /etc/passwd
to /bin/csh instead of /bin/false it works (chroot'd too), but then the user can telnet in also,
which is bad.
Any ideas?

Thanks,

Darren Ensley
[email-masked]

---

From: [email-masked] (Russell Street)
Date: Thu, 23 Feb 1995 18:17:45 +1300 (NDT)

> to /bin/csh instead of /bin/false it works (chroot'd too), but then the user can telnet in also,

One word: /etc/shells...

If the user's shell is not listed in that file (or whatever you have
compiled the FTPD with) the user is denied FTP access.  Anon FTP access
does not check for that, however.

Is that of any help?
Russell
-------------------------------------------
Russell Street [[email-masked]]
http://www.auckland.ac.nz/cc/People/RS.html
(.samtsirhC rof sdrawkcab gnipyT)

---

From: [email-masked] (Patrick Salsbury)
Date: Thu, 23 Feb 1995 15:47:14 -0800 (PST)

-Date: Wed, 22 Feb 1995 15:10:29 -0800
-From: Darren Ensley <[email-masked]>
-
-After days of trying, I am unable to get the wu-ftpd guest logins to work correctly.
-I am running wu-ftpd 2.4 on a SPARCstation 2 running SunOS 4.1.3.
-I am following the examples out of Managing Internet Information Services from
-O'Reilly.  When I attempt to log in as the guest user, I get an immediate "User guest1 access
-denied" message and never a password prompt.  If I change the guest users shell in /etc/passwd
-to /bin/csh instead of /bin/false it works (chroot'd too), but then the user can telnet in also,
-which is bad.
-Any ideas?
-
-Thanks,
-
-Darren Ensley
[email-masked]
-

[More from The Ftpaccess Manpage (TFM) ;^)  ]

				 (snip snip)
-------------------------------------------------------------------------------
     class <class> <typelist> <addrglob> [<addrglob> ...]
          Define <class> of users, with source addresses  of  the
          form  <addrglob>.   Multiple  members of <class> may be
          defined.  There may be multiple "class" commands  list-
          ing  additional  members  of  the  class.   If multiple
          "class" commands can apply to the current session,  the
          first  one  listed in the access file is used.  Failing
          to define a valid class for a host will cause access to
          be denied.  <typelist> is a comma-separated list of any
          of the keywords "anonymous", "guest"  and  "real".   If
          the  "real"  keyword  is  included, the class can match
          users using FTP to access real  accounts,  and  if  the
          "anonymous"  keyword  is  included  the class can match
          users using anonymous FTP.  The "guest" keyword matches
          guest access accounts (see "guestgroup" for more infor-
          mation)

          <addrglob> may be a globbed domain name  or  a  globbed
          numeric address.
-------------------------------------------------------------------------------

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                  Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists