Subject: Service not available

From: [email-masked] (TheBenO Peter Straka)
Date: Thu, 16 Feb 1995 13:50:58 +0100

Hello,

I'm doing my first wu-ftpd.

I have	: computer SUN Sparcstation IPX 
	: UNIX SunOS 4.1.3 with client NIS (YP)
	: compilator gcc version 2.4.5

====

My 'build' is O.K. (build s41)
My 'bin/ckconfig' 

Checking _PATH_FTPUSERS :: /etc/ftpusers
ok.
Checking _PATH_FTPACCESS :: /local/etc/ftpaccess
ok.
Checking _PATH_PIDNAMES :: /local/etc/ftp.pids-%s
ok.
Checking _PATH_CVT :: /local/etc/ftpconversions
ok.
Checking _PATH_XFERLOG :: /var/adm/xferlog
ok.
Checking _PATH_PRIVATE :: /etc/ftpgroups
ok. 
Checking _PATH_FTPHOSTS :: /local/etc/ftphosts
ok.

My 'build install' is O.K.

In my /etc/initd.conf is this line with ftp:
ftp     stream  tcp     nowait  root    /local/etc/ftpd         ftpd -d

I running ftp : ftp ipx2.kesp.elf.stuba.sk 
Message in terminal:
==========================
Connected to ipx2.
220-
220 
Name (ipx2:straka): straka
421 Service not available, remote server has closed connection
Login failed.
ftp> bye
==========================
It's the same when I login as 'ftp' or 'anonymous'

In /var/adm/messages is this new line:
Feb 16 12:50:02 ipx2 ftpd[13107]: exiting on signal 11
or
Feb 16 12:50:29 ipx2 ftpd[13115]: setsockopt (SO_OOBINLINE): Socket operation on non-socket

Thanks for any suggestion
                                            TheBenO ( Ing. Peter Straka )
  --------------------------------------------------------------------------
  | KESP EF STU Bratislava                  [email-masked]       |
  |                                         [email-masked]            |
  | Unix,TeX,C,Assebler,Gfx,Toonz,...,SGI,Sun,Amiga,Power-Mac,...,         |
  --------------------------------------------------------------------------

---

From: Michael Jungmann <[email-masked]>
Date: Fri, 17 Feb 1995 09:00:33 +0100

Hi !

> Feb 16 12:50:29 ipx2 ftpd[13115]: setsockopt (SO_OOBINLINE): Socket operation > on non-socket

I've got exactly the same problem - but - sorry - no solution !!
So please inform me, when you have a solution !!