Subject: Installing wu-ftpd-2.4

From: Jonathan Zamick <[email-masked]>
Date: Wed, 22 Feb 1995 16:32:11 -0800 (PST)

Hello list folk,

I've recently begun installation of the wu-ftpd on a relatively plain
SunOS 4.1.3_U1 system. (The main deviation is a reversion back to the
4.1.3 /usr/include files due to some missing files in U1 release. These
missing files effected netdb.h and arpa/init.h, so we went back to the
previous releases that didn't call the missing files. This hasn't hurt
in the past.

Now on building the files using gcc, we get the following errors:
(note, there is no vers.o that I can find, and vers.c is a one line
file which doesn't have the standard disclaimers found in all the
other *.c files.)

The build up to this point gave no errors-->

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use this function)
ftpd.c:1982: `strunames' undeclared (first use this function)
ftpd.c:1982: `modenames' undeclared (first use this function)
make: *** [ftpd.o] Error 1

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsu
pport
gcc: vers.o: No such file or directory
make: *** [ftpcount] Error 1

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupp
ort
gcc: vers.o: No such file or directory
make: *** [ftpshut] Error 1

Making ckconfig.
gcc -g -DDEBUG -I.. -I../support -L../support -o ckconfig ckconfig.c
ld: /lib/libc.sa.1.9.2: warning: table of contents for archive is out of date; r
erun ranlib(1)
(While included, the ranlib comment is not an error with the compilation, I
simply left it in for completeness.)

Links to executables are in bin directory:
size: bin/ftpd not found
size: bin/ftpcount not found
size: bin/ftpshut not found
size: bin/ftpwho not found
text    data    bss     dec     hex
8192    8192    0       16384   4000    bin/ckconfig

If anyone has any ideas about the vers.o problem, or the errors with ftpd.c,
I'd be appreciative of any advice or suggestions you could make.

Jonathan

---

From: Vidiot <[email-masked]>
Date: Wed, 22 Feb 1995 21:28:53 -0600 (CST)

<Making ftpd.
<gcc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
<ftpd.c: In function `statcmd':
<ftpd.c:1972: `typenames' undeclared (first use this function)
<ftpd.c:1972: (Each undeclared identifier is reported only once
<ftpd.c:1972: for each function it appears in.)
<ftpd.c:1974: `formnames' undeclared (first use this function)
<ftpd.c:1982: `strunames' undeclared (first use this function)
<ftpd.c:1982: `modenames' undeclared (first use this function)
<make: *** [ftpd.o] Error 1

The INSTALL file contains the following message:

    If cc complains about strunames, typenames, modenames, ... being undefined
    you need to install support/ftp.h as /usr/include/arpa/ftp.h (always make
    a backup of the old ftp.h just in case!) and do the build again.  The new
    ftp.h should be a compatible superset of your existing ftp.h, so you
    shouldn't have problems with this replacement.

<Making ftpcount.
<gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsu
<pport
<gcc: vers.o: No such file or directory
<make: *** [ftpcount] Error 1
<
<Making ftpshut.
<gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupp
<ort
<gcc: vers.o: No such file or directory
<make: *** [ftpshut] Error 1

The vers.o doesn't exist because ftpd failed to compile.  I had the same
problem.  Once it passes the compile for ftpd.o, the other pieces that make
up ftpd will compile, including vers.o.

<If anyone has any ideas about the vers.o problem, or the errors with ftpd.c,
<I'd be appreciative of any advice or suggestions you could make.

Once you do the /usr/include/arpa/ftp.h install, you should get the following
when compiling:

make args are : 
make opts are : 

Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
gcc -g -DDEBUG   -c fnmatch.c
gcc -g -DDEBUG   -c strcasestr.c
gcc -g -DDEBUG   -c strerror.c
gcc -g -DDEBUG   -c strsep.c
gcc -g -DDEBUG   -c authuser.c
gcc -g -DDEBUG    -target sun4 -c  syslog.c
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o syslog.o
ranlib libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  ftpd.c
yacc  ftpcmd.y
mv y.tab.c ftpcmd.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  ftpcmd.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  glob.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  logwtmp.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  popen.c
sh newvers.sh
gcc -g -DDEBUG -I.. -I../support -L../support -c vers.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  access.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  extensions.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  realpath.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  acl.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  private.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  authenticate.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  conversions.c
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  hostacc.c
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpd ftpd.o ftpcmd.o glob.o logwtmp.o popen.o vers.o access.o extensions.o  realpath.o acl.o private.o authenticate.o conversions.o hostacc.o -lsupport

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport

Making ckconfig.
`ckconfig' is up to date.

Links to executables are in bin directory:
text	data	bss	dec	hex
122880	16384	10784	150048	24a20	bin/ftpd
8192	8192	0	16384	4000	bin/ftpcount
8192	8192	0	16384	4000	bin/ftpshut
8192	8192	0	16384	4000	bin/ftpwho
8192	8192	0	16384	4000	bin/ckconfig
Done

All this for the lack of reading the INSTALL file :-(  Don't feel bad, it
took me a couple of times reading the file to finally notice the little note.

MB
-- 
System Administrator - Extrel FTMS - Madison WI.
e-mail: [email-masked]
phone: (608) 273-8262  fax: (608) 273-8719  voice-mail: (800) 426-6488 ext 6293
Visit - http://www.ftms.com/vidiot/  (Your link to the world of Star Trek)

---

From: Alexander Haiut <[email-masked]>
Date: Thu, 23 Feb 1995 18:38:39 -0200 (GMT-0200)

Hi,

> *** Error code 1
> make: Fatal error: Command failed for target `ftpd.o'

	this error fully explained in INSTALL file in wu-ftpd package.
	Here are few lines from there:

  .... INSTALL ......................................................

  ...................................................................

		Thanks!		--alex.

  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]
  voice  : +972-7-461658