Subject: Re: More on the 'dir' command

From: Hsi-Lien Chen <[email-masked]>
Date: Thu, 16 Feb 1995 16:09:43 -0600

You are not the only one who has the problem with 'ls -l" command.
I have been tracing this problem for more than a week.  For somehow the
function execv() in popen.c does not work properly.  I am still looking
for the answer and I think it is something to do with the system library
function.  It caused the syslog() function fail too.  I fixed the problem
by replacing the syslog() with the real source code from GNU C library.
If you find the answer, please let me know.

Thanks-
Lenny Chen
[email-masked]

---

From: "The best things in life ... are fantasy." <[email-masked]>
Date: Thu, 16 Feb 1995 16:19:50 -0500 (EST)

Do you have all the necessary lib* files in ~ftp/lib? Which ones
you require depends on what OS you are using.

PCVS

---

From: "G. D. Alexander (Geoff) ((T/L 444) 254-5216)" <[email-masked]>
Date: Thu, 16 Feb 1995 21:59:54 -0500 (EST)

I also am experiencing this problem on an AIX 3.2.5 installation.  Any
suggestions would be appreciated.

Thanks,
Geoff Alexander

---

From: "The best things in life ... are fantasy." <[email-masked]>
Date: Fri, 17 Feb 1995 13:24:58 -0500 (EST)

That's why you need the share libraries. My melieu is Sun rather than AIX
but the idea is the same. You might need something on the order of the
following:
	ld.so, libc.so.*,libdl.so.*
(and possibly others).

Good luck

PCVS

---

From: "G. D. Alexander (Geoff) ((T/L 444) 254-5216)" <[email-masked]>
Date: Fri, 17 Feb 1995 11:15:32 -0500 (EST)

> AIX's ls uses share libraries. Make sure you have the necessary
> share libs installed as well. See the anonymous setup note
> on AIX for details

What anonymous set up note?  I have been unable to find any information
on which shared libraries need to be copied.  Also, I'm not sure the
correct ls is executed.  Here what I get when ftping in as a guest user:

  ftp> ls
  200 PORT command successful.
  150 Opening ASCII mode data connection for file list.
  bin
  db2_scripts
  cmvc_exits
  226 Transfer complete.
  ftp> ls -l
  200 PORT command successful.
  150 Opening ASCII mode data connection for /bin/ls.
  226 Transfer complete.
  ftp> dir
  200 PORT command successful.
  150 Opening ASCII mode data connection for /bin/ls.
  226 Transfer complete.
  ftp>

Note that it seems that /bin/ls is executed rather than ~ftp/bin/ls.  Is
this the expected behavior?

Thanks,
Geoff Alexander