Subject: Compiling on Solaris 2.3

From: [email-masked] (Charlie Kim (ISD) x5494)
Date: Tue, 28 Feb 1995 11:07:05 -0500

Can anyone please help me :-(  ?
I currently have ftp anonymous already running on my Solaris 2.3 system,
but I can't seem to get wuftpd compiled.
So far I have taken only the defaults and I have included
/usr/sbin:/bin:/usr/bin:/usr/ccs/bin in my PATH.
Please advise.

Thanks,
Charlie

#./build sol
make args are : 
make opts are : 
 
Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical
 
Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o 
touch libsupport.a
 
Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o ftpd.o
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use this function)
ftpd.c:1982: `strunames' undeclared (first use this function)
ftpd.c:1982: `modenames' undeclared (first use this function)
make: *** [ftpd.o] Error 1

Making ftpcount.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport -lsocket -lnsl -lgen 
Cc: vers.o:, No, such, file, or, directory
make: *** [ftpcount] Error 1
 
Making ftpshut.
cc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport -lsocket -lnsl -lgen
Cc: vers.o:, No, such, file, or, directory
make: *** [ftpshut] Error 1
 
Making ckconfig.
make: `ckconfig' is up to date.
ln: ../src/ckconfig and ckconfig are identical
 
Links to executables are in bin directory:
size: bin/ftpd: cannot open
size: bin/ftpcount: cannot open
size: bin/ftpshut: cannot open
size: bin/ftpwho: cannot open
bin/ckconfig: 4264 + 288 + 328 = 4880
Done
#

---

From: Joshua Krage <[email-masked]>
Date: Tue, 28 Feb 1995 12:54:00 -0500 (EST)

> make: *** [ftpd.o] Error 1

Since I experienced this problem a few days ago, I can tell you that the 
answer is in the INSTALL file of the distribution, under section 2a, 
"build xxx".  You need to install support/ftp.h as 
/usr/include/arpa/ftp.h (after making a backup, of course).  The INSTALL
file explains this nicely.

----------------------------------------------------------------------------
Joshua Krage                                            [email-masked]
Network Administrator          SCIENTECH, Inc.        (301) 468-6425 (Voice)