Subject: Guestgroups vs. Real users

From: Anne Kilarjian <[email-masked]>
Date: Thu, 16 Feb 1995 16:50:19 -0500 (EST)

I wanted to make use of the guestgroup feature of the wu-ftpd
so that individual faculty members here could have subdirectories
 in the anonymous ftp area which could be made accessible to
certain users only at their discretion.  The same faculty also
need ftp access to this machine as themselves.

I set up a guest id with password they could distribute as wanted, 
gave that id a ch'rooted home dir and put the id into group which
was given access with the "guestgroup" feature.  This worked out
fine for the guest id.

The problem is that the faculty member also needs ftp access
to this machine as a Real user because he has a home dir there
for other uses.  If I add his userid to the group which is
allowed access with guestgroups, when he ftp's in as himself
it puts him in a ch'rooted area with no ability to see any
files.  He does not even see the files visible to the rest
of the group.  

On the other hand, if his own userid is not part of the group,
he cannot chgrp the files he is putting in the group's area
to the group id.

Is there a way around this?  I know about the site group
command but I think the guestgroups is nicer -

Thanks for any help - I hope I have explained this problem
clearly enough -

Anne Kilarjian
SUNY Stony Brook

[email-masked]

---

From: [email-masked] (Patrick Salsbury)
Date: Thu, 16 Feb 1995 16:05:26 -0800 (PST)

-The problem is that the faculty member also needs ftp access
-to this machine as a Real user because he has a home dir there
-for other uses.  If I add his userid to the group which is
-allowed access with guestgroups, when he ftp's in as himself
-it puts him in a ch'rooted area with no ability to see any
-files.  He does not even see the files visible to the rest
-of the group.  
-
-On the other hand, if his own userid is not part of the group,
-he cannot chgrp the files he is putting in the group's area
-to the group id.
	Perhaps it's a matter of ordering in the ftpaccess file? I know that
it will match the first class and let them in as that, so perhaps put the
"real" user entry before the guest user. 
	Also, if the guest account is set up with a unique name, then they
should be able to either FTP in as themselves, or the guest user, with no
conflict. 
	I seem to remember something in the O'Reilly book about a command to
do something similar to an 'su (non-root)' or 'login' once logged in as
anonymous, to get to a private subdir. I don't have the book with me, though.
Anyone else seen this?

-Anne Kilarjian
-SUNY Stony Brook
[email-masked]
-

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                  Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists