Subject: Re: More on the 'dir' commandy

From: [email-masked] (Mark Powell)
Date: Tue, 21 Feb 1995 09:53 +0000 (GMT)

In article <[email-masked]>,
Joe Rosenfeld <[email-masked]> wrote:
>> I have found the solution to the problem.
>> There are following libraries, that are been using by the command 'ls' :
>> 
>>  ld.so.1*
>>  libc.so.1*
>>  libdl.so.1*
>>  libintl.so.1*
>>  libw.so.1*
>
>Yes, this will do it.  You can also grab the source code from GNU and
>recompile ls with the -static flag, when using GCC, or the -Bstatic flag,
>for CC.  This works without requiring the libraries to be copied.  On the
>other hand the resulting ls binary is larger (you can use strip), so maybe
>having the libraries in the ~ftp tree is a better idea.

Maybe. I once had this working. Unfortunately, 'ls -l' stopped working sometime
and I've never been able to figure out why, 'ls' can work, but not 'ls -l'.
I'd of thought any instance of 'ls' would need some library routines, even
without any flags. Anyway, I installed the statically linked GNU 'ls' and
all works fine. 

The Dell SVR4 v2.2 /bin/ls is 12596 bytes and the statically linked GNU
version is 79760. However, the shared libraries are 256000 bytes. Maybe
a useful saving as this anonymous account is pretty rarely used.

> Joe Rosenfeld	        219-631-3939       [email-masked]
-- 
Mark Powell - Network Technician - Room: C806
Computer Services Unit, University College Salford, Salford, UK.
Tel:	+44 161 745 3376		Fax:	+44 161 736 3596
Email:	[email-masked]	PGP key available
<A HREF="http://plato.ucsalf.ac.uk/~mark/">Home Page</A>

---

From: root <[email-masked]>
Date: Tue, 21 Feb 1995 11:32:27 -0500

My ls -l works great, however I need a static copy of tar that also 
supports int gzipping etc..

DO you have one or know where I can get one for solaris?
Jim

---

From: [email-masked] (Joe Rosenfeld)
Date: Tue, 21 Feb 1995 15:36:32 -0500 (EST)

> DO you have one or know where I can get one for solaris?

FTP to prep.ai.mit.edu, go to the /pub/gnu directory and grab the tar*.gz
package.

=======================================================================
 Joe Rosenfeld	        219-631-3939       [email-masked]
 Director of Law School Computing, University of Notre Dame Law School
=======================================================================

---

From: Alexander Haiut <[email-masked]>
Date: Tue, 21 Feb 1995 23:12:37 -0200 (GMT-0200)

> supports int gzipping etc..

	Get GNU tar and gzip, compile them statically and it will work.
	I have all these, compiled for 4.1.3, so don't think it's good
	for Solaris.

	GNU tar and gzip available at prep.ai.mit.edu:/pub/gnu .

		That's it.		--alex.
	
  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]
  voice  : +972-7-461658